Ubuntu 12.04 Precise 64bits

Logs

====== Attempt #1

-----> Fetching repository

Cloning into '/tmp/d20160503-16665-jpnl8f/input'...

-----> Restoring cache

-----> Starting packaging process

-----> Installing missing build dependencies: libicu-dev

-----> Fetching buildpack /tmp/buildpacks/sources/pkgr/heroku-buildpack-ruby.git at universal

-----> Ruby app

-----> Running hook: "./bin/pkgr_before_precompile.sh"

-----> Compiling Ruby/Rails

Retrying command...

-----> Using Ruby version: ruby-2.0.0

-----> Installing dependencies using bundler 1.9.7

Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j2 --deployment

Fetching gem metadata from https://rubygems.org/.......

Fetching version metadata from https://rubygems.org/...

Fetching dependency metadata from https://rubygems.org/..

Installing rake 10.4.2

Installing CFPropertyList 2.3.1

Installing RedCloth 4.2.9

Installing ace-rails-ap 2.0.1

Installing i18n 0.7.0

Installing json 1.8.3

Installing minitest 5.7.0

Installing thread_safe 0.3.5

Installing tzinfo 1.2.2

Installing activesupport 4.1.12

Installing builder 3.2.2

Installing erubis 2.7.0

Installing actionview 4.1.12

Installing rack 1.5.5

Installing rack-test 0.6.3

Installing actionpack 4.1.12

Installing mime-types 1.25.1

Installing mail 2.6.3

Installing actionmailer 4.1.12

Installing activemodel 4.1.12

Installing arel 5.0.1.20140414130214

Installing activerecord 4.1.12

Installing activerecord-deprecated_finders 1.0.4

Installing thor 0.19.1

Installing railties 4.1.12

Installing activerecord-session_store 0.1.1

Installing rails-observers 0.1.2

Installing activeresource 4.0.0

Installing acts-as-taggable-on 3.5.0

Installing addressable 2.3.8

Using bundler 1.9.7

Installing hike 1.2.3

Installing multi_json 1.11.2

Installing tilt 1.4.1

Installing sprockets 2.12.4

Installing sprockets-rails 2.3.2

Installing rails 4.1.12

Installing after_commit_queue 1.1.0

Installing asana 0.0.6

Installing asciidoctor 1.5.2

Installing encryptor 1.3.0

Installing attr_encrypted 1.3.4

Installing attr_required 1.0.0

Installing execjs 2.6.0

Installing autoprefixer-rails 5.2.1.2

Installing descendants_tracker 0.0.4

Installing ice_nine 0.11.1

Installing axiom-types 0.1.1

Installing babosa 1.0.2

Installing bcrypt 3.1.10

Installing sass 3.2.19

Installing bootstrap-sass 3.3.5

Installing browser 1.0.0

Installing cal-heatmap-rails 0.0.1

Installing carrierwave 0.9.0

Installing hitimes 1.2.3

Installing timers 4.0.4

Installing celluloid 0.16.0

Installing charlock_holmes 0.7.3

Installing chunky_png 1.3.4

Installing coercible 1.0.0

Installing coffee-script-source 1.9.1.1

Installing coffee-script 2.4.1

Installing coffee-rails 4.1.0

Installing colored 1.2

Installing colorize 0.5.8

Installing connection_pool 2.2.0

Installing safe_yaml 1.0.4

Installing crack 0.4.2

Installing creole 0.3.8

Installing d3_rails 3.5.6

Installing default_value_for 3.0.1

Installing orm_adapter 0.5.0

Installing responders 1.1.2

Installing warden 1.2.3

Installing devise 3.5.2

Installing devise-async 0.9.0

Installing rotp 2.1.1

Installing devise-two-factor 2.0.0

Installing diff-lcs 1.2.5

Installing diffy 3.0.7

Installing doorkeeper 2.1.4

Installing dropzonejs-rails 0.7.1

Installing email_reply_parser 0.5.8

Installing enumerize 0.7.0

Installing equalizer 0.0.11

Installing escape_utils 1.1.0

Installing eventmachine 1.0.8

Installing excon 0.45.4

Installing expression_parser 0.9.0

Installing multipart-post 2.0.0

Installing faraday 0.9.2

Installing faraday_middleware 0.10.0

Installing fission 0.5.0

Installing multi_xml 0.5.5

Installing httparty 0.13.5

Installing flowdock 0.7.0

Installing formatador 0.2.5

Installing net-ssh 2.9.2

Installing net-scp 1.2.1

Installing fog-core 1.32.1

Installing fog-json 1.0.2

Installing inflecto 0.0.2

Installing fog-brightbox 0.9.0

Installing mini_portile 0.6.2

Installing nokogiri 1.6.6.2

Installing fog-xml 0.1.2

Installing fog-profitbricks 0.0.5

Installing fog-radosgw 0.0.4

Installing fog-sakuracloud 1.0.1

Installing fog-softlayer 0.4.7

Installing fog-terremark 0.1.0

Installing fog-vmfusion 0.1.0

Installing fog-voxel 0.1.0

Installing ipaddress 0.8.0

Installing trollop 2.1.2

Installing rbvmomi 1.8.2

Installing opennebula 4.12.1

Installing fog 1.25.0

Installing font-awesome-rails 4.4.0.0

Installing rugged 0.23.3

Installing gemnasium-gitlab-service 0.2.6

Installing gemojione 2.0.1

Installing get_process_mem 0.2.0

Installing github-linguist 4.7.0

Installing github-markup 1.3.3

Installing posix-spawn 0.3.11

Installing gitlab-grit 2.7.3

Installing gitlab-flowdock-git-hook 1.0.1

Installing gitlab_emoji 0.1.1

Installing gitlab_git 7.2.20

Installing gitlab_meta 7.0

Installing net-ldap 0.11

Installing hashie 3.4.2

Installing omniauth 1.2.2

Installing pyu-ruby-sasl 0.0.3.3

Installing rubyntlm 0.5.2

Installing gitlab_omniauth-ldap 1.2.1

Installing gollum-grit_adapter 1.0.0

Installing rouge 1.10.1

Installing sanitize 2.1.0

Installing stringex 2.5.2

Installing gollum-lib 4.0.3

Installing gon 5.0.4

Installing rack-accept 0.4.5

Installing rack-mount 0.8.3

Installing virtus 1.0.5

Installing grape 0.13.0

Installing grape-entity 0.4.8

Installing haml 4.0.7

Installing sexp_processor 4.6.0

Installing ruby_parser 3.5.0

Installing html2haml 2.0.0

Installing haml-rails 0.9.0

Installing mimemagic 0.3.0

Installing hipchat 1.5.2

Installing html-pipeline 1.11.0

Installing http_parser.rb 0.5.3

Installing httpclient 2.6.0.1

Installing ice_cube 0.11.1

Installing jquery-atwho-rails 1.3.2

Installing jquery-rails 3.1.3

Installing jquery-scrollto-rails 1.4.3

Installing turbolinks 2.5.3

Installing jquery-turbolinks 2.0.2

Installing jquery-ui-rails 4.2.1

Installing jwt 1.5.1

Installing kaminari 0.16.3

Installing kgio 2.9.3

Installing systemu 2.6.5

Installing macaddr 1.7.1

Installing mail_room 0.6.1

Installing mousetrap-rails 1.4.6

Installing mysql2 0.3.20

Installing nested_form 0.3.2

Installing newrelic_rpm 3.9.4.245

Installing newrelic-grape 2.0.0

Installing nprogress-rails 0.1.6.7

Installing oauth 0.4.7

Installing oauth2 1.0.0

Installing sawyer 0.6.0

Installing octokit 3.7.1

Installing omniauth-oauth 1.1.0

Installing omniauth-bitbucket 0.0.2

Installing omniauth-oauth2 1.3.1

Installing omniauth-facebook 3.0.0

Installing omniauth-github 1.1.2

Installing omniauth-gitlab 1.0.0

Installing omniauth-google-oauth2 0.2.6

Installing omniauth-multipassword 0.4.2

Installing timfel-krb5-auth 0.8.3

Installing omniauth-kerberos 0.3.0

Installing uuid 2.3.8

Installing ruby-saml 1.0.0

Installing omniauth-saml 1.4.1

Installing omniauth-shibboleth 1.2.1

Installing omniauth-twitter 1.2.1

Installing omniauth_crowd 2.2.3

Installing rubypants 0.2.0

Installing org-ruby 0.9.12

Installing paranoia 2.1.3

Installing pg 0.18.2

Installing rack-attack 4.3.0

Installing rack-cors 0.4.0

Installing rack-oauth2 1.0.10

Installing rack-protection 1.5.3

Installing raindrops 0.15.0

Installing raphael-rails 2.1.2

Installing rdoc 3.12.2

Installing redcarpet 3.3.3

Installing redis 3.2.1

Installing redis-store 1.1.6

Installing redis-rack 1.5.0

Installing redis-actionpack 4.0.0

Installing redis-activesupport 4.1.1

Installing redis-namespace 1.5.2

Installing redis-rails 4.0.0

Installing request_store 1.2.0

Installing rinku 1.7.3

Installing rqrcode 0.7.0

Installing rqrcode-rails3 0.1.7

Installing ruby-fogbugz 0.2.1

Installing sass-rails 4.0.5

Installing seed-fu 2.3.5

Installing select2-rails 3.5.9.3

Installing settingslogic 2.0.9

Installing sidekiq 3.3.0

Installing sidetiq 0.6.3

Installing simple_oauth 0.1.9

Installing sinatra 1.4.6

Installing six 0.2.0

Installing slack-notifier 1.2.1

Installing stamp 0.6.0

Installing state_machines 0.4.0

Installing state_machines-activemodel 0.3.0

Installing state_machines-activerecord 0.3.0

Installing task_list 1.0.2

Installing twitter-stream 0.1.16

Installing tinder 1.10.1

Installing uglifier 2.7.2

Installing underscore-rails 1.4.4

Installing unf_ext 0.0.7.1

Installing unf 0.1.4

Installing unicorn 4.8.3

Installing unicorn-worker-killer 0.4.3

Installing version_sorter 2.0.0

Installing wikicloth 0.8.1

Bundle complete! 154 Gemfile dependencies, 247 gems now installed.

Gems in the groups development and test were not installed.

Bundled gems are installed into ./vendor/bundle.

Post-install message from acts-as-taggable-on:

When upgrading

Re-run the migrations generator

This will create any new migrations and skip existing ones

Version 3.5.0 has a migration for mysql adapter

#################### WARNING ##############################

# Internet Explorer detection has changed on v1.0.0+. #

# #

Post-install message from browser:

rake acts_as_taggable_on_engine:install:migrations

# https://github.com/fnando/browser#internet-explorer #

* Support for Ruby 1.8.6 dropped

# If this is important for you, please read #

Post-install message from httparty:

When you HTTParty, you must party hard!

###########################################################

HEADS UP! Haml 4.0 has many improvements, but also has changes that may break

Post-install message from haml:

* Support for Rails 2 dropped

* Sass filter now always outputs <style> tags

# #

your application:

* Data attributes are now hyphenated, not underscored

* html2haml utility moved to the html2haml gem

* Textile and Maruku filters moved to the haml-contrib gem

Post-install message from html-pipeline:

http://rubydoc.info/github/haml/haml/file/CHANGELOG.md

https://github.com/jch/html-pipeline#dependencies

-------------------------------------------------

Thank you for installing html-pipeline!

See html-pipeline README.md for more details.

You must bundle Filter gem dependencies.

-------------------------------------------------

For more info see:

Post-install message from mousetrap-rails:

$ rails generate mousetrap:install 

Remember to run generator to generate sample file and include mousetrap-rails with Rails Asset Pipeline

Post-install message from rdoc:

Depending on your version of ruby, you may need to install ruby rdoc/ri data:

<= 1.8.6 : unsupported

= 1.8.7 : gem install rdoc-data; rdoc-data --install

= 1.9.1 : gem install rdoc-data; rdoc-data --install

>= 1.9.2 : nothing to do! Yay!

Bundle completed (318.36s)

Cleaning up the bundler cache.

-----> Preparing app for Rails asset pipeline

Running: rake assets:precompile

WARNING: This version of GitLab depends on gitlab-shell 2.6.8, but you're running Unknown. Please update gitlab-shell.

Missing `db_key_base` for 'production' environment. The secrets will be generated and stored in `config/secrets.yml`

rake aborted!

Errno::ENOENT: No such file or directory - /tmp/d20160503-17-hpo49n/opt/gitlab-ce/.secret

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/app/models/user.rb:82:in `read'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/app/models/user.rb:64:in `<top (required)>'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/app/models/user.rb:82:in `<class:User>'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.12/lib/active_support/dependencies.rb:247:in `require'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.12/lib/active_support/dependencies.rb:247:in `block in require'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.12/lib/active_support/dependencies.rb:247:in `require'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.12/lib/active_support/dependencies.rb:480:in `load_missing_constant'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.12/lib/active_support/inflector/methods.rb:238:in `block in constantize'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.12/lib/active_support/dependencies.rb:348:in `require_or_load'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.12/lib/active_support/inflector/methods.rb:236:in `constantize'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.12/lib/active_support/dependencies.rb:232:in `load_dependency'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.12/lib/active_support/dependencies.rb:180:in `const_missing'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.12/lib/active_support/inflector/methods.rb:236:in `each'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.12/lib/active_support/inflector/methods.rb:238:in `const_get'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.12/lib/active_support/dependencies.rb:552:in `get'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.12/lib/active_support/inflector/methods.rb:236:in `inject'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.12/lib/active_support/dependencies.rb:583:in `constantize'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/devise-3.5.2/lib/devise/mapping.rb:81:in `to'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/devise-3.5.2/lib/devise/mapping.rb:93:in `routes'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/devise-3.5.2/lib/devise/mapping.rb:76:in `modules'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/devise-3.5.2/lib/devise/mapping.rb:160:in `default_used_route'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/devise-3.5.2/lib/devise/mapping.rb:70:in `initialize'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/devise-3.5.2/lib/devise.rb:287:in `get'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/devise-3.5.2/lib/devise.rb:321:in `new'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/devise-3.5.2/lib/devise.rb:321:in `add_mapping'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/devise-3.5.2/lib/devise/rails/routes.rb:223:in `each'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/devise-3.5.2/lib/devise/rails/routes.rb:224:in `block in devise_for'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/config/routes.rb:377:in `block in <top (required)>'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/devise-3.5.2/lib/devise/rails/routes.rb:223:in `devise_for'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/actionpack-4.1.12/lib/action_dispatch/routing/route_set.rb:351:in `eval_block'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/actionpack-4.1.12/lib/action_dispatch/routing/route_set.rb:351:in `instance_exec'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/actionpack-4.1.12/lib/action_dispatch/routing/route_set.rb:329:in `draw'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/config/routes.rb:4:in `<top (required)>'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.12/lib/active_support/dependencies.rb:241:in `load'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.12/lib/active_support/dependencies.rb:241:in `block in load'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.12/lib/active_support/dependencies.rb:232:in `load_dependency'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.12/lib/active_support/dependencies.rb:241:in `load'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/railties-4.1.12/lib/rails/application/routes_reloader.rb:40:in `block in load_paths'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/railties-4.1.12/lib/rails/application/routes_reloader.rb:40:in `each'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/railties-4.1.12/lib/rails/application/routes_reloader.rb:40:in `load_paths'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/railties-4.1.12/lib/rails/application/routes_reloader.rb:16:in `reload!'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.12/lib/active_support/file_update_checker.rb:75:in `call'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/railties-4.1.12/lib/rails/application/routes_reloader.rb:26:in `block in updater'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/railties-4.1.12/lib/rails/application/routes_reloader.rb:7:in `execute_if_updated'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.12/lib/active_support/file_update_checker.rb:75:in `execute'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/railties-4.1.12/lib/rails/application/routes_reloader.rb:27:in `updater'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/railties-4.1.12/lib/rails/initializable.rb:30:in `instance_exec'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/railties-4.1.12/lib/rails/application/finisher.rb:71:in `block in <module:Finisher>'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/railties-4.1.12/lib/rails/initializable.rb:30:in `run'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/railties-4.1.12/lib/rails/initializable.rb:54:in `run_initializers'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/railties-4.1.12/lib/rails/initializable.rb:55:in `block in run_initializers'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/railties-4.1.12/lib/rails/railtie.rb:194:in `public_send'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/railties-4.1.12/lib/rails/application.rb:300:in `initialize!'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/railties-4.1.12/lib/rails/railtie.rb:194:in `method_missing'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/config/environment.rb:5:in `<top (required)>'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.12/lib/active_support/dependencies.rb:247:in `require'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.12/lib/active_support/dependencies.rb:247:in `block in require'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.12/lib/active_support/dependencies.rb:232:in `load_dependency'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/activesupport-4.1.12/lib/active_support/dependencies.rb:247:in `require'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/railties-4.1.12/lib/rails/application.rb:276:in `require_environment!'

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/railties-4.1.12/lib/rails/application.rb:405:in `block in run_tasks_blocks'

Tasks: TOP => environment

/tmp/d20160503-17-hpo49n/opt/gitlab-ce/vendor/bundle/ruby/2.0.0/gems/sprockets-rails-2.3.2/lib/sprockets/rails/task.rb:64:in `block (2 levels) in define'

(See full trace by running task with --trace)

!

! Precompiling assets failed.

!

! ERROR: compile failed

! FAILED.

! Please contact support.

Failure during packaging