Install

openproject-ce

Build run #279

Build Logs

====== Attempt #1

-----> Fetching repository

Cloning into '/tmp/d20170122-16665-ddnyqq/input'...

-----> Restoring cache

-----> Starting packaging process

-----> Installing missing build dependencies: ImageMagick-devel

-----> [wizard] adding legacy-installer wizard (https://github.com/pkgr/addon-legacy-installer#master)

-----> [wizard] adding mysql wizard (https://github.com/pkgr/addon-mysql#master)

-----> [wizard] adding apache2 wizard (https://github.com/pkgr/addon-apache2#master)

-----> [wizard] adding repositories wizard (https://github.com/finnlabs/addon-repositories#master)

-----> [wizard] adding smtp wizard (https://github.com/pkgr/addon-smtp#master)

-----> [wizard] adding memcached wizard (https://github.com/pkgr/addon-memcached#master)

-----> [wizard] adding openproject wizard (https://github.com/pkgr/addon-openproject#master)

-----> Fetching buildpack https://github.com/opf/heroku-buildpack-multi.git at master

-----> Multipack app

-----> Running hook: "packaging/setup"

WARNING: This buildpack is no longer maintained.

Please choose a different buildpack or go to https://github.com/ddollar/heroku-buildpack-multi

and fork it to your own account.

=====> Downloading Buildpack: https://github.com/pkgr/pkgr-buildpack-imagemagick.git

=====> Detected Framework: ImageMagick

-----> SKIP

=====> Downloading Buildpack: https://github.com/heroku/heroku-buildpack-nodejs.git

=====> Detected Framework: Node.js

-----> Reading application state

package.json...

build directory...

cache directory...

environment variables...

Node engine: 6.9.1

Npm engine: 4.0.0

Start mechanism: Procfile

node_modules source: package.json

node_modules cached: true

NPM_CONFIG_PRODUCTION=true

NODE_MODULES_CACHE=true

-----> Installing binaries

Downloading and installing node 6.9.1...

Downloading and installing npm 4.0.0 (replacing version 3.10.8)...

-----> Building dependencies

Restoring node modules from cache

Pruning unused dependencies

Installing any new modules

> openproject@0.1.0 postinstall /tmp/d20170122-17-x1bn1q/opt/openproject

> cd frontend && npm install

> openproject-frontend@0.1.0 postinstall /tmp/d20170122-17-x1bn1q/opt/openproject/frontend

> bower install --config.interactive=false

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 not-cached git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolve git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de not-cached git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolve git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 not-cached git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolve git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 checkout d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower jquery-ui#~1.10.4 not-cached https://github.com/components/jqueryui.git#~1.10.4

bower jquery-ui#~1.10.4 resolve https://github.com/components/jqueryui.git#~1.10.4

bower jquery#1.11.0 not-cached https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery#1.11.0 resolve https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery-ujs#1.0.0 not-cached https://github.com/rails/jquery-ujs.git#1.0.0

bower jquery-ujs#1.0.0 resolve https://github.com/rails/jquery-ujs.git#1.0.0

bower angular-animate#~1.5.8 not-cached https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-animate#~1.5.8 resolve https://github.com/angular/bower-angular-animate.git#~1.5.8

bower select2#3.5.2 not-cached https://github.com/ivaynberg/select2.git#3.5.2

bower select2#3.5.2 resolve https://github.com/ivaynberg/select2.git#3.5.2

bower jquery.atwho#0.5.1 not-cached https://github.com/ichord/At.js.git#0.5.1

bower jquery.atwho#0.5.1 resolve https://github.com/ichord/At.js.git#0.5.1

bower angular-aria#~1.5.8 not-cached https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-aria#~1.5.8 resolve https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-ui-router#~0.3.1 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-ui-router#~0.3.1 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-i18n#~1.5.5 not-cached https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-i18n#~1.5.5 resolve https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-sanitize#~1.5.8 not-cached https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-sanitize#~1.5.8 resolve https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-elastic#~2.5.1 not-cached https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-elastic#~2.5.1 resolve https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-cache#~4.6.0 not-cached https://github.com/jmdobry/angular-cache.git#~4.6.0

bower angular-cache#~4.6.0 resolve https://github.com/jmdobry/angular-cache.git#~4.6.0

bower jquery-migrate#~1.2.1 not-cached https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower jquery-migrate#~1.2.1 resolve https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower moment#~2.10.6 not-cached https://github.com/moment/moment.git#~2.10.6

bower moment#~2.10.6 resolve https://github.com/moment/moment.git#~2.10.6

bower moment-timezone#0.4.x not-cached https://github.com/moment/moment-timezone.git#0.4.x

bower moment-timezone#0.4.x resolve https://github.com/moment/moment-timezone.git#0.4.x

bower angular-busy#~4.1.3 not-cached https://github.com/cgross/angular-busy.git#~4.1.3

bower angular-busy#~4.1.3 resolve https://github.com/cgross/angular-busy.git#~4.1.3

bower foundation-apps#1.1.0 not-cached https://github.com/zurb/foundation-apps.git#1.1.0

bower foundation-apps#1.1.0 resolve https://github.com/zurb/foundation-apps.git#1.1.0

bower lodash#~2.4.1 not-cached https://github.com/lodash/lodash.git#~2.4.1

bower lodash#~2.4.1 resolve https://github.com/lodash/lodash.git#~2.4.1

bower bourbon#~4.2.1 not-cached https://github.com/thoughtbot/bourbon.git#~4.2.1

bower bourbon#~4.2.1 resolve https://github.com/thoughtbot/bourbon.git#~4.2.1

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de checkout fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 checkout a908eccaec323cd66973d58af4965694bdff16a1

bower angular-ui-select#~0.19.4 not-cached https://github.com/angular-ui/ui-select.git#~0.19.4

bower angular-ui-select#~0.19.4 resolve https://github.com/angular-ui/ui-select.git#~0.19.4

bower mousetrap#~1.4.6 not-cached https://github.com/ccampbell/mousetrap.git#~1.4.6

bower mousetrap#~1.4.6 resolve https://github.com/ccampbell/mousetrap.git#~1.4.6

bower ng-file-upload#~5.0.9 not-cached https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower ng-file-upload#~5.0.9 resolve https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower rxjs#^4.1.0 not-cached https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower rxjs#^4.1.0 resolve https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower angular-dragula#^1.2.8 not-cached https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower angular-dragula#^1.2.8 resolve https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower ng-dialog#^0.6.2 not-cached https://github.com/likeastore/ngDialog.git#^0.6.2

bower ng-dialog#^0.6.2 resolve https://github.com/likeastore/ngDialog.git#^0.6.2

bower mocha#~1.14.0 not-cached https://github.com/mochajs/mocha.git#~1.14.0

bower mocha#~1.14.0 resolve https://github.com/mochajs/mocha.git#~1.14.0

bower angular-mocks#~1.5.8 not-cached https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower angular-mocks#~1.5.8 resolve https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower chai#~1.9.0 not-cached https://github.com/chaijs/chai.git#~1.9.0

bower chai#~1.9.0 resolve https://github.com/chaijs/chai.git#~1.9.0

bower jquery-mockjax#~1.5.3 not-cached https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery-mockjax#~1.5.3 resolve https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery-ui#~1.10.4 checkout 1.10.4

bower jquery#1.11.0 checkout 1.11.0

bower jquery-ujs#1.0.0 checkout v1.0.0

bower jquery.atwho#0.5.1 checkout v0.5.1

bower select2#3.5.2 checkout 3.5.2

bower angular-animate#~1.5.8 checkout v1.5.11

bower angular-ui-router#~0.3.1 checkout 0.3.2

bower angular-aria#~1.5.8 checkout v1.5.11

bower angular-cache#~4.6.0 checkout 4.6.0

bower angular-elastic#~2.5.1 checkout v2.5.1

bower angular-sanitize#~1.5.8 checkout v1.5.11

bower angular-i18n#~1.5.5 checkout v1.5.11

bower foundation-apps#1.1.0 checkout v1.1.0

bower angular-busy#~4.1.3 checkout v4.1.4

bower moment-timezone#0.4.x checkout 0.4.1

bower moment#~2.10.6 checkout 2.10.6

bower jquery-migrate#~1.2.1 checkout 1.2.1

bower bourbon#~4.2.1 checkout v4.2.7

bower mousetrap#~1.4.6 checkout 1.4.6

bower angular-ui-select#~0.19.4 checkout v0.19.6

bower lodash#~2.4.1 checkout 2.4.2

bower ng-file-upload#~5.0.9 checkout 5.0.9

bower rxjs#^4.1.0 checkout v4.1.0

bower ng-dialog#^0.6.2 checkout v0.6.6

bower angular-dragula#^1.2.8 checkout v1.2.8

bower mocha#~1.14.0 checkout 1.14.0

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolved git://github.com/nickmessing/angular-context-menu.git#a908eccaec

bower angular-mocks#~1.5.8 checkout v1.5.11

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolved git://github.com/finnlabs/angular-modal.git#d45eb9ceb7

bower chai#~1.9.0 checkout 1.9.2

bower jquery-mockjax#~1.5.3 checkout v1.5.4

bower jquery-ui#~1.10.4 resolved https://github.com/components/jqueryui.git#1.10.4

bower jquery-ujs#1.0.0 resolved https://github.com/rails/jquery-ujs.git#1.0.0

bower angular#>= 1.2.5 not-cached https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 resolve https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#~1.5.8 not-cached https://github.com/angular/bower-angular.git#~1.5.8

bower angular#~1.5.8 resolve https://github.com/angular/bower-angular.git#~1.5.8

bower angular#^1.3.0 not-cached https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 resolve https://github.com/angular/bower-angular.git#^1.3.0

bower jquery#1.11.0 resolved https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery.atwho#0.5.1 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .png files: ["select2.png","select2x2.png"]

bower angular-aria#~1.5.8 resolved https://github.com/angular/bower-angular-aria.git#1.5.11

bower select2#3.5.2 resolved https://github.com/ivaynberg/select2.git#3.5.2

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolved git://github.com/sparkalow/angular-truncate.git#fdf60fda26

bower angular-animate#~1.5.8 resolved https://github.com/angular/bower-angular-animate.git#1.5.11

bower jquery.atwho#0.5.1 resolved https://github.com/ichord/At.js.git#0.5.1

bower angular-ui-router#~0.3.1 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.3.2

bower Caret.js#>= 0.2.0 not-cached https://github.com/ichord/Caret.js.git#>= 0.2.0

bower Caret.js#>= 0.2.0 resolve https://github.com/ichord/Caret.js.git#>= 0.2.0

bower angular-elastic#~2.5.1 resolved https://github.com/monospaced/angular-elastic.git#2.5.1

bower angular#>=1.0.6 not-cached https://github.com/angular/bower-angular.git#>=1.0.6

bower angular#>=1.0.6 resolve https://github.com/angular/bower-angular.git#>=1.0.6

bower angular-cache#~4.6.0 resolved https://github.com/jmdobry/angular-cache.git#4.6.0

bower angular#>=1.x not-cached https://github.com/angular/bower-angular.git#>=1.x

bower angular#>=1.x resolve https://github.com/angular/bower-angular.git#>=1.x

bower angular-sanitize#~1.5.8 resolved https://github.com/angular/bower-angular-sanitize.git#1.5.11

bower foundation-apps#1.1.0 resolved https://github.com/zurb/foundation-apps.git#1.1.0

bower angular#~1.3.4 not-cached https://github.com/angular/bower-angular.git#~1.3.4

bower angular#~1.3.4 resolve https://github.com/angular/bower-angular.git#~1.3.4

bower angular-ui-router#~0.2.12 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-ui-router#~0.2.12 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-animate#~1.3.4 not-cached https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular-animate#~1.3.4 resolve https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular-ui-router#~0.2.12 checkout 0.2.18

bower angular-animate#~1.3.4 checkout v1.3.20

bower jquery-migrate#~1.2.1 deprecated Package jquery-migrate is using the deprecated component.json

bower jquery-migrate#~1.2.1 resolved https://github.com/appleboy/jquery-migrate.git#1.2.1

bower angular-busy#~4.1.3 resolved https://github.com/cgross/angular-busy.git#4.1.4

bower angular#>=1.3 not-cached https://github.com/angular/bower-angular.git#>=1.3

bower angular#>=1.3 resolve https://github.com/angular/bower-angular.git#>=1.3

bower viewport-units-buggyfill#~0.4.1 not-cached https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower viewport-units-buggyfill#~0.4.1 resolve https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower fastclick#~1.0.3 not-cached https://github.com/ftlabs/fastclick.git#~1.0.3

bower fastclick#~1.0.3 resolve https://github.com/ftlabs/fastclick.git#~1.0.3

bower tether#~0.6.5 not-cached https://github.com/HubSpot/tether.git#~0.6.5

bower tether#~0.6.5 resolve https://github.com/HubSpot/tether.git#~0.6.5

bower hammerjs#~2.0.4 not-cached https://github.com/EightMedia/hammer.js.git#~2.0.4

bower hammerjs#~2.0.4 resolve https://github.com/EightMedia/hammer.js.git#~2.0.4

bower moment-timezone#0.4.x resolved https://github.com/moment/moment-timezone.git#0.4.1

bower moment#>= 2.6.0 not-cached https://github.com/moment/moment.git#>= 2.6.0

bower moment#>= 2.6.0 resolve https://github.com/moment/moment.git#>= 2.6.0

bower mousetrap#~1.4.6 resolved https://github.com/ccampbell/mousetrap.git#1.4.6

bower moment#>= 2.6.0 checkout 2.17.1

bower angular-ui-select#~0.19.4 resolved https://github.com/angular-ui/ui-select.git#0.19.6

bower angular#>=1.2.18 not-cached https://github.com/angular/bower-angular.git#>=1.2.18

bower angular#>=1.2.18 resolve https://github.com/angular/bower-angular.git#>=1.2.18

bower bourbon#~4.2.1 resolved https://github.com/thoughtbot/bourbon.git#4.2.7

bower ng-dialog#^0.6.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .css files: ["css/ngDialog.css","css/ngDialog-theme-default.css"]

bower ng-file-upload#~5.0.9 resolved https://github.com/danialfarid/angular-file-upload-bower.git#5.0.9

bower moment#~2.10.6 resolved https://github.com/moment/moment.git#2.10.6

bower lodash#~2.4.1 resolved https://github.com/lodash/lodash.git#2.4.2

bower ng-dialog#^0.6.2 resolved https://github.com/likeastore/ngDialog.git#0.6.6

bower angular#>=1.5 not-cached https://github.com/angular/bower-angular.git#>=1.5

bower angular#>=1.5 resolve https://github.com/angular/bower-angular.git#>=1.5

bower angular-dragula#^1.2.8 resolved https://github.com/bevacqua/angular-dragula.git#1.2.8

bower chai#~1.9.0 resolved https://github.com/chaijs/chai.git#1.9.2

bower mocha#~1.14.0 mismatch Version declared in the json (1.12.0) is different than the resolved one (1.14.0)

bower mocha#~1.14.0 resolved https://github.com/mochajs/mocha.git#1.14.0

bower angular-mocks#~1.5.8 resolved https://github.com/angular/bower-angular-mocks.git#1.5.11

bower angular-i18n#~1.5.5 resolved https://github.com/angular/bower-angular-i18n.git#1.5.11

bower angular#~1.5.8 checkout v1.5.11

bower angular#^1.3.0 checkout v1.6.1

bower angular#>=1.0.6 checkout v1.6.1

bower angular#>=1.x checkout v1.6.1

bower angular#~1.3.4 checkout v1.3.20

bower angular#>=1.3 checkout v1.6.1

bower angular#>=1.2.18 checkout v1.6.1

bower angular#>=1.5 checkout v1.6.1

bower angular#>= 1.2.5 checkout v1.6.1

bower Caret.js#>= 0.2.0 checkout v0.3.1

bower angular-animate#~1.3.4 resolved https://github.com/angular/bower-angular-animate.git#1.3.20

bower jquery-mockjax#~1.5.3 resolved https://github.com/jakerella/jquery-mockjax.git#1.5.4

bower angular-ui-router#~0.2.12 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.2.18

bower fastclick#~1.0.3 checkout v1.0.6

bower viewport-units-buggyfill#~0.4.1 checkout v0.4.1

bower hammerjs#~2.0.4 checkout v2.0.8

bower tether#~0.6.5 checkout v0.6.5

bower rxjs#^4.1.0 resolved https://github.com/Reactive-Extensions/RxJS.git#4.1.0

bower moment#>= 2.6.0 resolved https://github.com/moment/moment.git#2.17.1

bower angular#~1.5.8 resolved https://github.com/angular/bower-angular.git#1.5.11

bower angular#^1.3.0 resolved https://github.com/angular/bower-angular.git#1.6.1

bower angular#>=1.x resolved https://github.com/angular/bower-angular.git#1.6.1

bower angular#>=1.0.6 resolved https://github.com/angular/bower-angular.git#1.6.1

bower angular#~1.3.4 resolved https://github.com/angular/bower-angular.git#1.3.20

bower angular#>=1.3 resolved https://github.com/angular/bower-angular.git#1.6.1

bower Caret.js#>= 0.2.0 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower angular#>=1.2.18 resolved https://github.com/angular/bower-angular.git#1.6.1

bower Caret.js#>= 0.2.0 resolved https://github.com/ichord/Caret.js.git#0.3.1

bower angular#>=1.5 resolved https://github.com/angular/bower-angular.git#1.6.1

bower angular#>= 1.2.5 resolved https://github.com/angular/bower-angular.git#1.6.1

bower fastclick#~1.0.3 resolved https://github.com/ftlabs/fastclick.git#1.0.6

bower viewport-units-buggyfill#~0.4.1 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .js files: ["./viewport-units-buggyfill.js","./viewport-units-buggyfill.hacks.js"]

bower viewport-units-buggyfill#~0.4.1 resolved https://github.com/rodneyrehm/viewport-units-buggyfill.git#0.4.1

bower hammerjs#~2.0.4 resolved https://github.com/EightMedia/hammer.js.git#2.0.8

bower tether#~0.6.5 resolved https://github.com/HubSpot/tether.git#0.6.5

Please note that,

foundation-apps#1.1.0 depends on angular-animate#~1.3.4 which resolved to angular-animate#1.3.20

openproject depends on angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

angular-busy#4.1.4 depends on angular-animate#>=1.3 which resolved to angular-animate#1.5.11

Resort to using angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

Code incompatibilities may occur.

Please note that,

foundation-apps#1.1.0 depends on angular-ui-router#~0.2.12 which resolved to angular-ui-router#0.2.18

openproject depends on angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Resort to using angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Code incompatibilities may occur.

Please note that,

foundation-apps#1.1.0 depends on angular#~1.3.4 which resolved to angular#1.3.20

angular-animate#1.3.20 depends on angular#1.3.20 which resolved to angular#1.3.20

angular-animate#1.5.11, angular-aria#1.5.11, angular-mocks#1.5.11, angular-sanitize#1.5.11 depends on angular#1.5.11 which resolved to angular#1.5.11

angular-ui-router#0.3.2, angular-ui-router#0.2.18 depends on angular#^1.0.8 which resolved to angular#1.5.11

openproject depends on angular#~1.5.8 which resolved to angular#1.5.11

ng-dialog#0.6.6 depends on angular#>=1.5 which resolved to angular#1.6.1

angular-cache#4.6.0 depends on angular#>=1.x which resolved to angular#1.6.1

angular-modal#d45eb9ceb7 depends on angular#^1.3.0 which resolved to angular#1.6.1

angular-elastic#2.5.1 depends on angular#>=1.0.6 which resolved to angular#1.6.1

angular-busy#4.1.4 depends on angular#>=1.3 which resolved to angular#1.6.1

angular-ui-select#0.19.6 depends on angular#>=1.2.18 which resolved to angular#1.6.1

angular-context-menu#a908eccaec depends on angular#>= 1.2.5 which resolved to angular#1.6.1

Resort to using angular#~1.5.8 which resolved to angular#1.5.11

Code incompatibilities may occur.

bower jquery extra-resolution Unnecessary resolution: jquery#1.11.0

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 install angular-context-menu#a908eccaec

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 install angular-modal#d45eb9ceb7

bower jquery-ui#~1.10.4 install jquery-ui#1.10.4

bower jquery-ujs#1.0.0 install jquery-ujs#1.0.0

bower jquery#1.11.0 install jquery#1.11.0

bower angular-aria#~1.5.8 install angular-aria#1.5.11

bower select2#3.5.2 install select2#3.5.2

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de install angular-truncate#fdf60fda26

bower angular-animate#~1.5.8 install angular-animate#1.5.11

bower jquery.atwho#0.5.1 install jquery.atwho#0.5.1

bower angular-ui-router#~0.3.1 install angular-ui-router#0.3.2

bower angular-elastic#~2.5.1 install angular-elastic#2.5.1

bower angular-cache#~4.6.0 install angular-cache#4.6.0

bower angular-sanitize#~1.5.8 install angular-sanitize#1.5.11

bower foundation-apps#1.1.0 install foundation-apps#1.1.0

bower jquery-migrate#~1.2.1 install jquery-migrate#1.2.1

bower angular-busy#~4.1.3 install angular-busy#4.1.4

bower moment-timezone#0.4.x install moment-timezone#0.4.1

bower mousetrap#~1.4.6 install mousetrap#1.4.6

bower angular-ui-select#~0.19.4 install angular-ui-select#0.19.6

bower bourbon#~4.2.1 install bourbon#4.2.7

bower ng-file-upload#~5.0.9 install ng-file-upload#5.0.9

bower moment#~2.10.6 install moment#2.10.6

bower lodash#~2.4.1 install lodash#2.4.2

bower ng-dialog#^0.6.2 install ng-dialog#0.6.6

bower angular-dragula#^1.2.8 install angular-dragula#1.2.8

bower chai#~1.9.0 install chai#1.9.2

bower mocha#~1.14.0 install mocha#1.14.0

bower angular-mocks#~1.5.8 install angular-mocks#1.5.11

bower angular-i18n#~1.5.5 install angular-i18n#1.5.11

bower jquery-mockjax#~1.5.3 install jquery-mockjax#1.5.4

bower rxjs#^4.1.0 install rxjs#4.1.0

bower angular#1.5.11 install angular#1.5.11

bower Caret.js#>= 0.2.0 install Caret.js#0.3.1

bower fastclick#~1.0.3 install fastclick#1.0.6

bower viewport-units-buggyfill#~0.4.1 install viewport-units-buggyfill#0.4.1

bower hammerjs#~2.0.4 install hammerjs#2.0.8

bower tether#~0.6.5 install tether#0.6.5

angular-context-menu#a908eccaec bower_components/angular-context-menu

└── angular#1.5.11

angular-modal#d45eb9ceb7 bower_components/angular-modal

└── angular#1.5.11

jquery-ui#1.10.4 bower_components/jquery-ui

└── jquery#1.11.0

jquery-ujs#1.0.0 bower_components/jquery-ujs

└── jquery#1.11.0

jquery#1.11.0 bower_components/jquery

angular-aria#1.5.11 bower_components/angular-aria

└── angular#1.5.11

select2#3.5.2 bower_components/select2

└── jquery#1.11.0

angular-truncate#fdf60fda26 bower_components/angular-truncate

angular-animate#1.5.11 bower_components/angular-animate

└── angular#1.5.11

jquery.atwho#0.5.1 bower_components/jquery.atwho

├── Caret.js#0.3.1

└── jquery#1.11.0

angular-ui-router#0.3.2 bower_components/angular-ui-router

└── angular#1.5.11

angular-elastic#2.5.1 bower_components/angular-elastic

└── angular#1.5.11

angular-cache#4.6.0 bower_components/angular-cache

└── angular#1.5.11

angular-sanitize#1.5.11 bower_components/angular-sanitize

└── angular#1.5.11

foundation-apps#1.1.0 bower_components/foundation-apps

├── angular#1.5.11

├── angular-animate#1.5.11

├── angular-ui-router#0.3.2

├── fastclick#1.0.6

├── hammerjs#2.0.8

├── tether#0.6.5

└── viewport-units-buggyfill#0.4.1

jquery-migrate#1.2.1 bower_components/jquery-migrate

angular-busy#4.1.4 bower_components/angular-busy

├── angular#1.5.11

└── angular-animate#1.5.11

moment-timezone#0.4.1 bower_components/moment-timezone

└── moment#2.10.6

mousetrap#1.4.6 bower_components/mousetrap

angular-ui-select#0.19.6 bower_components/angular-ui-select

└── angular#1.5.11

bourbon#4.2.7 bower_components/bourbon

ng-file-upload#5.0.9 bower_components/ng-file-upload

moment#2.10.6 bower_components/moment

lodash#2.4.2 bower_components/lodash

ng-dialog#0.6.6 bower_components/ng-dialog

└── angular#1.5.11

angular-dragula#1.2.8 bower_components/angular-dragula

chai#1.9.2 bower_components/chai

mocha#1.14.0 bower_components/mocha

angular-mocks#1.5.11 bower_components/angular-mocks

└── angular#1.5.11

angular-i18n#1.5.11 bower_components/angular-i18n

jquery-mockjax#1.5.4 bower_components/jquery-mockjax

rxjs#4.1.0 bower_components/rxjs

angular#1.5.11 bower_components/angular

Caret.js#0.3.1 bower_components/Caret.js

└── jquery#1.11.0

fastclick#1.0.6 bower_components/fastclick

viewport-units-buggyfill#0.4.1 bower_components/viewport-units-buggyfill

hammerjs#2.0.8 bower_components/hammerjs

tether#0.6.5 bower_components/tether

openproject-frontend@0.1.0 /tmp/d20170122-17-x1bn1q/opt/openproject/frontend

+-- acorn@2.6.4

+-- align-text@0.1.4

+-- alter@0.2.0

+-- amdefine@1.0.0

+-- angular@1.5.8

+-- angular-elastic@2.5.1

+-- angular-ui-bootstrap@2.2.0

+-- anymatch@1.3.0

+-- arr-diff@2.0.0

+-- arr-flatten@1.0.1

+-- array-unique@0.2.1

+-- arrify@1.0.1

+-- assert@1.4.1

+-- async@0.2.10

+-- async-each@1.0.1

+-- atoa@1.0.0

+-- autoprefixer-core@5.2.1

+-- autoprefixer-loader@1.2.0

+-- awesome-typescript-loader@2.2.4

| `-- lodash@4.16.4

+-- balanced-match@0.4.2

+-- Base64@0.2.1

+-- base64-js@1.2.0

+-- big.js@3.1.3

+-- binary-extensions@1.7.0

+-- bower@1.7.9

+-- brace-expansion@1.1.6

+-- braces@1.8.5

+-- browserify-zlib@0.1.4

+-- browserslist@0.4.0

+-- buffer@4.9.1

+-- buffer-shims@1.0.0

+-- camelcase@1.2.1

+-- caniuse-db@1.0.30000569

+-- center-align@0.1.3

+-- chokidar@1.6.1

+-- cliui@2.1.0

| `-- wordwrap@0.0.2

+-- clone@1.0.2

+-- colors@1.1.2

+-- concat-map@0.0.1

+-- console-browserify@1.1.0

+-- constants-browserify@0.0.1

+-- contra@1.9.4

+-- convert-source-map@1.1.3

+-- core-util-is@1.0.2

+-- crossvent@1.5.4

+-- crypto-browserify@3.2.8

+-- css-loader@0.9.1

| `-- source-map@0.1.43

+-- csso@1.3.12

+-- custom-event@1.0.0

+-- d@0.1.1

+-- date-now@0.1.4

+-- decamelize@1.2.0

+-- domain-browser@1.1.7

+-- dragula@3.7.2

+-- emojis-list@2.1.0

+-- enhanced-resolve@2.3.0

+-- errno@0.1.4

+-- es5-ext@0.10.12

+-- es6-iterator@2.0.0

+-- es6-promise@2.3.0

+-- es6-symbol@3.1.0

+-- es6-weak-map@0.1.4

| +-- es6-iterator@0.1.3

| `-- es6-symbol@2.0.1

+-- event-emitter@0.3.4

+-- events@1.1.1

+-- expand-brackets@0.1.5

+-- expand-range@1.8.2

+-- exports-loader@0.6.3

| `-- source-map@0.1.43

+-- expose-loader@0.6.0

+-- extglob@0.3.2

+-- extract-text-webpack-plugin@0.3.8

| `-- source-map@0.1.43

+-- fastparse@1.1.1

+-- file-loader@0.8.5

+-- filename-regex@2.0.0

+-- fill-range@2.2.3

+-- for-in@0.1.6

+-- for-own@0.1.4

+-- glob@4.5.3

+-- glob-base@0.3.0

+-- glob-parent@2.0.0

+-- graceful-fs@4.1.9

+-- has-flag@1.0.0

+-- html-loader@0.2.3

| `-- source-map@0.1.43

+-- html-minifier@0.5.6

+-- http-browserify@1.7.0

+-- https-browserify@0.0.0

+-- ieee754@1.1.8

+-- indexof@0.0.1

+-- inflight@1.0.6

+-- inherits@2.0.3

+-- interpret@0.6.6

+-- is-binary-path@1.0.1

+-- is-buffer@1.1.4

+-- is-dotfile@1.0.2

+-- is-equal-shallow@0.1.3

+-- is-extendable@0.1.1

+-- is-extglob@1.0.0

+-- is-glob@2.0.1

+-- is-number@2.1.0

+-- is-posix-bracket@0.1.1

+-- is-primitive@2.0.0

+-- isarray@1.0.0

+-- isobject@2.1.0

+-- js-base64@2.1.9

+-- json5@0.4.0

+-- kind-of@3.0.4

+-- lazy-cache@1.0.4

+-- loader-utils@0.2.16

| `-- json5@0.5.0

+-- lodash@2.4.2

+-- longest@1.0.1

+-- lru-queue@0.1.0

+-- memoizee@0.3.10

+-- memory-fs@0.3.0

+-- micromatch@2.3.11

+-- mime@1.2.11

+-- minimatch@2.0.10

+-- minimist@0.0.10

+-- mkdirp@0.5.1

| `-- minimist@0.0.8

+-- nan@2.4.0

+-- next-tick@0.2.2

+-- ng-annotate@1.2.1

| `-- source-map@0.5.6

+-- ng-annotate-loader@0.0.10

| `-- source-map@0.4.2

+-- ngtemplate-loader@0.1.3

+-- node-libs-browser@0.6.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- normalize-path@2.0.1

+-- num2fraction@1.2.2

+-- object-assign@4.1.0

+-- object.omit@2.0.1

+-- observable-array@0.0.4

+-- observable-value@0.0.5

+-- once@1.4.0

+-- optimist@0.6.1

+-- ordered-ast-traverse@1.1.1

+-- ordered-esprima-props@1.1.0

+-- os-browserify@0.1.2

+-- pako@0.2.9

+-- parse-glob@3.0.4

+-- path-browserify@0.0.0

+-- path-is-absolute@1.0.1

+-- pbkdf2-compat@2.0.1

+-- phantomjs-polyfill@0.0.2

+-- postcss@4.1.16

+-- preserve@0.2.0

+-- process@0.11.9

+-- process-nextick-args@1.0.7

+-- prr@0.0.0

+-- punycode@1.4.1

+-- querystring@0.2.0

+-- querystring-es3@0.2.1

+-- randomatic@1.1.5

+-- readable-stream@2.1.5

+-- readdirp@2.1.0

| `-- minimatch@3.0.3

+-- regex-cache@0.4.3

+-- repeat-element@1.1.2

+-- repeat-string@1.6.1

+-- right-align@0.1.3

+-- ripemd160@0.2.0

+-- set-immediate-shim@1.0.1

+-- sha.js@2.2.6

+-- shelljs@0.3.0

+-- simple-fmt@0.1.0

+-- simple-is@0.2.0

+-- source-list-map@0.1.6

+-- source-map@0.4.4

+-- source-map-support@0.4.5

| `-- source-map@0.5.6

+-- stable@0.1.5

+-- stream-browserify@1.0.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- string_decoder@0.10.31

+-- stringmap@0.2.2

+-- stringset@0.2.1

+-- style-loader@0.8.3

+-- supports-color@3.1.2

+-- tapable@0.2.4

+-- ticky@1.0.1

+-- timers-browserify@1.4.2

+-- timers-ext@0.1.0

+-- tryor@0.1.2

+-- tty-browserify@0.0.0

+-- typescript@2.0.6

+-- uglify-js@2.7.4

| `-- source-map@0.5.6

+-- uglify-to-browserify@1.0.2

+-- URIjs@1.16.1

+-- url@0.10.3

| `-- punycode@1.3.2

+-- url-loader@0.5.7

+-- util@0.10.3

| `-- inherits@2.0.1

+-- util-deprecate@1.0.2

+-- vm-browserify@0.0.4

+-- watchpack@0.2.9

| `-- async@0.9.2

+-- webpack@1.13.3

| +-- acorn@3.3.0

| +-- async@1.5.2

| +-- enhanced-resolve@0.9.1

| | `-- memory-fs@0.2.0

| `-- tapable@0.1.10

+-- webpack-core@0.6.8

+-- window-size@0.1.0

+-- wordwrap@0.0.3

+-- wrappy@1.0.2

`-- yargs@3.10.0

npm WARN openproject-frontend@0.1.0 No repository field.

npm WARN openproject-frontend@0.1.0 No license field.

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.0.14 (node_modules/fsevents):

npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.0.14: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

-----> Checking startup method

Found Procfile

-----> Finalizing build

Creating runtime environment

Exporting binary paths

Cleaning npm artifacts

Cleaning previous cache

Caching results for future builds

-----> Build succeeded!

openproject@0.1.0 /tmp/d20170122-17-x1bn1q/opt/openproject

`-- typescript@2.0.8

=====> Downloading Buildpack: https://github.com/pkgr/heroku-buildpack-ruby.git

=====> Detected Framework: Ruby

-----> Compiling Ruby/Rails

-----> Using Ruby version: ruby-2.3.1

-----> Installing dependencies using bundler 1.13.2

cp: `/tmp/d20170122-17-x1bn1q/opt/openproject/.git/cache/vendor/bundle/.' and `/tmp/d20170122-17-x1bn1q/opt/openproject/.git/cache/vendor/bundle/.' are the same file

Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Fetching gem metadata from https://rubygems.org/......

Fetching version metadata from https://rubygems.org/..

Fetching dependency metadata from https://rubygems.org/.

Using i18n 0.7.0

Installing rake 11.3.0

Installing minitest 5.9.0

Installing concurrent-ruby 1.0.2

Using thread_safe 0.3.5

Using erubis 2.7.0

Using mini_portile2 2.1.0

Using rack 2.0.1

Using nio4r 1.2.1

Using websocket-extensions 0.1.2

Using mime-types 2.99.3

Using method_source 0.8.2

Installing builder 3.2.2

Installing pkg-config 1.1.7

Using multi_json 1.12.1

Using acts_as_silent_list 3.0.0

Using addressable 2.4.0

Using airbrake-ruby 1.5.0

Using attr_required 1.0.1

Using execjs 2.7.0

Using ice_nine 0.11.2

Using bcrypt 3.1.11

Using bindata 2.3.4

Using sass 3.4.22

Using tilt 2.0.5

Using uber 0.0.15

Using erbse 0.0.2

Using coderay 1.1.1

Using color-tools 1.3.0

Using unf_ext 0.0.7.2

Using netrc 0.11.0

Using daemons 1.2.4

Using dalli 2.7.6

Using enumerable-lazy 0.0.1

Using equalizer 0.0.11

Using excon 0.52.0

Using ffi 1.9.14

Using formatador 0.2.5

Using ipaddress 0.8.3

Using get_process_mem 0.2.1

Using request_store 1.3.1

Using json 1.8.3

Using hashie 3.4.6

Using multi_xml 0.5.5

Using gravatar_image_tag 1.2.0

Using bundler 1.13.2

Using htmldiff 0.0.1

Installing thor 0.19.1

Installing arel 7.1.2

Using icalendar 2.3.0

Using iso8601 0.9.1

Using securecompare 1.0.0

Using url_safe_base64 0.2.2

Using kgio 2.10.0

Using mixlib-shellout 2.1.0

Using mysql2 0.4.4

Using net-ldap 0.14.0

Using newrelic_rpm 3.16.2.321

Using oj 2.17.4

Using pdf-core 0.6.1

Using ttfunk 1.4.0

Using rmagick 2.15.4

Using rubyzip 1.2.0

Using ruby-ole 1.2.12

Using pg 0.19.0

Using rails_serve_static_assets 0.0.5

Using rails_stdout_logging 0.0.5

Using raindrops 0.17.0

Using ruby-progressbar 1.8.1

Using structured_warnings 0.2.0

Using sqlite3 1.3.11

Using stringex 2.6.1

Using svg-graph 2.0.1

Using syck 1.0.5

Using will_paginate 3.1.3

Using i18n-js 3.0.0.rc14

Using tzinfo 1.2.2

Using descendants_tracker 0.0.4

Using rack-test 0.6.3

Using rack-accept 0.4.5

Using passenger 5.0.30

Using rack-attack 5.0.1

Using rack-protection 2.0.0.beta2

Using warden 1.2.6

Using websocket-driver 0.6.4

Using mail 2.6.4

Installing httpclient 2.8.2.4

Using airbrake 5.1.0

Using autoprefixer-rails 6.4.1.1

Using cells 4.1.3

Using unf 0.1.4

Using mustermann19 0.4.4

Using sys-filesystem 1.1.7

Using fog-core 1.42.0

Using rdoc 4.2.2

Using omniauth 1.3.1 from https://github.com/oliverguenther/omniauth (at 8385bc0@8385bc0)

Using bourbon 4.2.7

Using prawn 2.1.0

Using spreadsheet 0.8.9

Using rails_12factor 0.0.3

Using unicorn 5.1.0

Using rubytree 0.9.7

Installing sprockets 3.7.0

Using tzinfo-data 1.2016.6

Using axiom-types 0.1.1

Using coercible 1.0.0

Using warden-basic_auth 0.2.1

Using cells-erb 0.0.8

Using domain_name 0.5.20161129

Using fog-json 1.0.2

Using prawn-table 0.2.2

Using unicorn-worker-killer 0.4.4

Using virtus 1.0.5

Using http-cookie 1.0.3

Using rest-client 1.8.0

Using crowdin-api 0.4.1

Installing activesupport 5.0.0.1

Using globalid 0.3.7

Using climate_control 0.0.3

Using delayed_job 4.1.2

Using grape 0.17.0

Installing nokogiri 1.6.8 with native extensions

Installing json-jwt 1.6.5

Installing activemodel 5.0.0.1

Using swd 1.0.1

Using webfinger 1.0.2

Using rabl 0.13.0

Using ruby-duration 3.2.3

Installing rack-oauth2 1.4.0

Using cocaine 0.5.8

Using grape-cache_control 1.0.1

Installing activejob 5.0.0.1

Using carrierwave 1.0.0.beta from https://github.com/carrierwaveuploader/carrierwave (at master@5367a63)

Installing activerecord 5.0.0.1

Using date_validator 0.9.0

Using validate_email 0.1.6

Using validate_url 1.0.2

Using activemodel-serializers-xml 1.0.1

Using acts_as_list 0.8.1

Using acts_as_tree 2.5.1

Using awesome_nested_set 3.1.1

Using delayed_job_active_record 4.1.1

Using friendly_id 5.2.0.beta.1 from https://github.com/norman/friendly_id (at aff0564@aff0564)

Using globalize 5.1.0 from https://github.com/globalize/globalize (at 38443bc@38443bc)

Using transactional_lock 0.1.0 from https://github.com/finnlabs/transactional_lock.git (at master@6948b1d)

Using openid_connect 0.8.3

Using omniauth-openid-connect 0.2.0 from https://github.com/finnlabs/omniauth-openid-connect.git (at dev@c3bce4c)

Using omniauth-openid_connect-providers 0.1.0 from https://github.com/finnlabs/omniauth-openid_connect-providers.git (at dev@86f3670)

Using loofah 2.0.3

Using representable 2.1.8

Using fog-xml 0.1.2

Using ruby-saml 1.4.0

Using disposable 0.0.9

Using roar 1.0.4

Using rails-html-sanitizer 1.0.3

Using fog-aws 0.11.0

Using omniauth-saml 1.6.0 from git://github.com/omniauth/omniauth-saml.git (at master@5559d6b)

Using reform 1.2.6

Using openproject-auth_saml 0.1.0 from https://github.com/finnlabs/openproject-auth_saml (at dev@97212ab)

Installing rails-dom-testing 2.0.1

Installing actionview 5.0.0.1

Installing actionpack 5.0.0.1

Installing actionmailer 5.0.0.1

Using cells-rails 0.0.6

Using gon 4.1.1

Using sprockets-rails 3.2.0

Installing actioncable 5.0.0.1

Installing railties 5.0.0.1

Using actionpack-xml_parser 2.0.0

Using activerecord-session_store 1.0.0

Using jquery-tablesorter 1.22.7

Using responders 2.3.0

Using sass-rails 5.0.6

Installing rails 5.0.0.1

Using health_check 2.2.1

Using lobby_boy 0.1.2

Using openproject-auth_plugins 6.1.4 from source at `vendored-plugins/openproject-auth_plugins`

Using openproject-pdf_export 6.1.4 from source at `vendored-plugins/openproject-pdf_export`

Using openproject-costs 6.1.4 from source at `vendored-plugins/openproject-costs`

Using openproject-documents 6.1.4 from source at `vendored-plugins/openproject-documents`

Using openproject-webhooks 6.1.4 from source at `vendored-plugins/openproject-webhooks`

Using openproject-global_roles 6.1.4 from source at `vendored-plugins/openproject-global_roles`

Using openproject-local_avatars 6.1.4 from source at `vendored-plugins/openproject-local_avatars`

Using openproject-meeting 6.1.4 from source at `vendored-plugins/openproject-meeting`

Using openproject-my_project_page 6.1.4 from source at `vendored-plugins/openproject-my_project_page`

Using reporting_engine 6.1.4 from source at `vendored-plugins/reporting_engine`

Using openproject-themes-dark 6.1.4 from source at `vendored-plugins/openproject-themes-dark`

Using openproject-translations 6.1.4 from https://github.com/opf/openproject-translations.git (at stable/6@da52ff9)

Using openproject-xls_export 6.1.4 from source at `vendored-plugins/openproject-xls_export`

Using rails-angular-xss 0.3.0.pre.pre from https://github.com/opf/rails-angular-xss (at a45267d@a45267d)

Using rails_autolink 1.1.6

Using openproject-openid_connect 6.1.4 from source at `vendored-plugins/openproject-openid_connect`

Using openproject-github_integration 6.1.4 from source at `vendored-plugins/openproject-github_integration`

Using openproject-reporting 6.1.4 from source at `vendored-plugins/openproject-reporting`

Using openproject-backlogs 6.1.4 from source at `vendored-plugins/openproject-backlogs`

Bundle complete! 138 Gemfile dependencies, 195 gems now installed.

Gems in the groups development and test were not installed.

Bundled gems are installed into ./vendor/bundle.

Bundle completed (19.79s)

Cleaning up the bundler cache.

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Removing thor (0.19.4)

Removing builder (3.2.3)

Removing arel (7.1.4)

Removing concurrent-ruby (1.0.4)

Removing activerecord (5.0.1)

Removing sprockets (3.7.1)

Removing rails-dom-testing (2.0.2)

Removing actioncable (5.0.1)

Removing rails (5.0.1)

Removing actionview (5.0.1)

Removing activesupport (5.0.1)

Removing rake (12.0.0)

Removing activejob (5.0.1)

Removing railties (5.0.1)

Removing rack-oauth2 (1.5.1)

Removing minitest (5.10.1)

Removing httpclient (2.8.3)

Removing activemodel (5.0.1)

Removing actionmailer (5.0.1)

Removing json-jwt (1.7.1)

Removing openproject-token (1.0.0)

Removing nokogiri (1.6.8.1)

Removing actionpack (5.0.1)

-----> Detecting rake tasks

-----> Preparing app for Rails asset pipeline

Running: rake assets:precompile

$(npm bin)/webpack --config webpack.production.config.js

{"omniauth-openid-connect":"/tmp/d20170122-17-x1bn1q/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid-connect-c3bce4c9e9ac","omniauth-openid_connect-providers":"/tmp/d20170122-17-x1bn1q/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid_connect-providers-86f3670e127e","omniauth-saml":"/tmp/d20170122-17-x1bn1q/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-saml-5559d6b80805","openproject-auth_plugins":"/tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-auth_plugins","openproject-auth_saml":"/tmp/d20170122-17-x1bn1q/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-auth_saml-97212abb8378","openproject-pdf_export":"/tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-pdf_export","openproject-backlogs":"/tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-backlogs","openproject-costs":"/tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-costs","openproject-documents":"/tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-documents","openproject-webhooks":"/tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-webhooks","openproject-github_integration":"/tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-github_integration","openproject-global_roles":"/tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-global_roles","openproject-local_avatars":"/tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-local_avatars","openproject-meeting":"/tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-meeting","openproject-my_project_page":"/tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-my_project_page","openproject-openid_connect":"/tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-openid_connect","reporting_engine":"/tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/reporting_engine","openproject-reporting":"/tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-reporting","openproject-themes-dark":"/tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-themes-dark","openproject-translations":"/tmp/d20170122-17-x1bn1q/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-translations-da52ff92cdcd","openproject-xls_export":"/tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-xls_export"}

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Hash: 0fd9450cadfcf112b5d0

Version: webpack 1.13.3

Child

Hash: 0fd9450cadfcf112b5d0

Version: webpack 1.13.3

Time: 15934ms

Asset Size Chunks Chunk Names

7b9776076d5fceef4993b55c9383dedd.gif 1.85 kB [emitted]

openproject-backlogs.js 453 kB 0 [emitted] backlogs

openproject-core-app.js 3.43 MB 1 [emitted] core-app

openproject-costs.js 526 kB 2 [emitted] costs

openproject-global.js 3.51 MB 3 [emitted] global

openproject-my_project_page.js 14.3 kB 4 [emitted] my_project_page

openproject-core-app.css 4.71 kB 1 [emitted] core-app

openproject-global.css 49 kB 3 [emitted] global

[213] ./templates \.html$ 1.22 kB {1} [built]

[242] ./components ^((?!\.(test|spec)).)*\.(js|ts|html)$ 16.1 kB {1} [built]

[633] /tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 425 bytes {2} [built]

[765] /tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 330 bytes {4} [built]

+ 769 hidden modules

ERROR in [default]

File '/tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-budget-subform.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-x1bn1q/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-x1bn1q/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/subform/cost-subform.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-x1bn1q/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts' is not under 'rootDir' '/tmp/d20170122-17-x1bn1q/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts' is not under 'rootDir' '/tmp/d20170122-17-x1bn1q/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-block.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-x1bn1q/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-page-layout.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-x1bn1q/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-textile-block.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-x1bn1q/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default] /tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:49:18

Argument of type 'string' is not assignable to parameter of type '{ [key: string]: any; }'.

ERROR in [default] /tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:53:4

Supplied parameters do not match any signature of call target.

ERROR in [default] /tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:30:38

Cannot find module 'app/components/work-packages/work-package-cache.service'.

ERROR in [default] /tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:49:30

Cannot find name 'HalResource'.

ERROR in [default] /tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:54:57

Property '$injector' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:13

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:27

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:60:11

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:70:23

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:76:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:77:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:78:16

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:36:17

Property 'value' does not exist on type 'CurrencyDisplayField'.

ERROR in [default] /tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:37:23

Property 'value' does not exist on type 'CurrencyDisplayField'.

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 5 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

autoprefixer: /tmp/d20170122-17-x1bn1q/opt/openproject/app/assets/stylesheets/default.css.sass:6426:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-x1bn1q/opt/openproject/app/assets/stylesheets/default.css.sass:6456:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-x1bn1q/opt/openproject/app/assets/stylesheets/default.css.sass:11729:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-x1bn1q/opt/openproject/app/assets/stylesheets/default.css.sass:12110:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-x1bn1q/opt/openproject/app/assets/stylesheets/default.css.sass:12155:3: You should write display: flex by final spec instead of display: box

I, [2017-01-22T22:15:15.476758 #2542] INFO -- : Writing /tmp/d20170122-17-x1bn1q/opt/openproject/public/assets/default-b00e18110df905a5bf6f92466cbe06ed3965967d2d5e90d24ce836de132adb64.css

I, [2017-01-22T22:15:15.477350 #2542] INFO -- : Writing /tmp/d20170122-17-x1bn1q/opt/openproject/public/assets/default-b00e18110df905a5bf6f92466cbe06ed3965967d2d5e90d24ce836de132adb64.css.gz

I, [2017-01-22T22:15:17.428187 #2542] INFO -- : Writing /tmp/d20170122-17-x1bn1q/opt/openproject/public/assets/application-c35747bd6ba4882bfcba0e88b23946b0eb1e9507084ba77663a1955ac1d60457.js

I, [2017-01-22T22:15:17.428524 #2542] INFO -- : Writing /tmp/d20170122-17-x1bn1q/opt/openproject/public/assets/application-c35747bd6ba4882bfcba0e88b23946b0eb1e9507084ba77663a1955ac1d60457.js.gz

I, [2017-01-22T22:15:17.477086 #2542] INFO -- : Writing /tmp/d20170122-17-x1bn1q/opt/openproject/public/assets/locales/fa-ddde1dd90c7cd953dfe06fe7a99c8374773412c294f93ffe9efa3414e6b62c2a.js

I, [2017-01-22T22:15:17.477252 #2542] INFO -- : Writing /tmp/d20170122-17-x1bn1q/opt/openproject/public/assets/locales/fa-ddde1dd90c7cd953dfe06fe7a99c8374773412c294f93ffe9efa3414e6b62c2a.js.gz

I, [2017-01-22T22:15:17.488222 #2542] INFO -- : Writing /tmp/d20170122-17-x1bn1q/opt/openproject/public/assets/locales/id-a2a805a38128ac7a7ac9f665acb2885e446ba208b069cf9378b8ec1aec800649.js

I, [2017-01-22T22:15:17.488392 #2542] INFO -- : Writing /tmp/d20170122-17-x1bn1q/opt/openproject/public/assets/locales/id-a2a805a38128ac7a7ac9f665acb2885e446ba208b069cf9378b8ec1aec800649.js.gz

I, [2017-01-22T22:15:17.494865 #2542] INFO -- : Writing /tmp/d20170122-17-x1bn1q/opt/openproject/public/assets/locales/it-2da9fe25a38c3b5ecc1ad49f013f4f2780e7cc8c7760e14b5e0cf9133a3ca888.js

I, [2017-01-22T22:15:17.495031 #2542] INFO -- : Writing /tmp/d20170122-17-x1bn1q/opt/openproject/public/assets/locales/it-2da9fe25a38c3b5ecc1ad49f013f4f2780e7cc8c7760e14b5e0cf9133a3ca888.js.gz

I, [2017-01-22T22:15:17.502788 #2542] INFO -- : Writing /tmp/d20170122-17-x1bn1q/opt/openproject/public/assets/locales/ja-f8632d5fff009c766a77c499986ac2ab325405dc4f1bf26622ae18f9ce8792a8.js

I, [2017-01-22T22:15:17.502961 #2542] INFO -- : Writing /tmp/d20170122-17-x1bn1q/opt/openproject/public/assets/locales/ja-f8632d5fff009c766a77c499986ac2ab325405dc4f1bf26622ae18f9ce8792a8.js.gz

I, [2017-01-22T22:15:17.520020 #2542] INFO -- : Writing /tmp/d20170122-17-x1bn1q/opt/openproject/public/assets/locales/nl-e7e1a58e4a0fe3814cc911c20cd36192bb5110c5ac32a7e583e9d4d177bd693e.js

I, [2017-01-22T22:15:17.520193 #2542] INFO -- : Writing /tmp/d20170122-17-x1bn1q/opt/openproject/public/assets/locales/nl-e7e1a58e4a0fe3814cc911c20cd36192bb5110c5ac32a7e583e9d4d177bd693e.js.gz

autoprefixer: /tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:6446:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:6476:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:11749:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:12130:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-x1bn1q/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:12175:3: You should write display: flex by final spec instead of display: box

I, [2017-01-22T22:15:31.992731 #2542] INFO -- : Writing /tmp/d20170122-17-x1bn1q/opt/openproject/public/assets/dark-feeac1abf7e73be6eb6d80d8a8f8e5b9bf79b47ce3eba05b133e96395d495c5a.css

I, [2017-01-22T22:15:31.992992 #2542] INFO -- : Writing /tmp/d20170122-17-x1bn1q/opt/openproject/public/assets/dark-feeac1abf7e73be6eb6d80d8a8f8e5b9bf79b47ce3eba05b133e96395d495c5a.css.gz

Asset precompilation completed (62.67s)

Cleaning assets

Running: rake assets:clean

I, [2017-01-22T22:15:40.596860 #2773] INFO -- : Removed locales/fa-0dbf392eccd6c0bdd63cfadefebb8a9b2ae0ffc90b91c905764f3b009aecb046.js

I, [2017-01-22T22:15:40.605697 #2773] INFO -- : Removed locales/id-a7c8c482240a4e457ff26930c4a800331ec9a565832f4a26b05aa189e690b876.js

I, [2017-01-22T22:15:40.613854 #2773] INFO -- : Removed locales/it-7e1d737729288534422df10d26c1b9357bd99ef564864ac74c1080c53037c9a5.js

I, [2017-01-22T22:15:40.621883 #2773] INFO -- : Removed locales/ja-90d4866d75e8e5c66cb904ef183adae9eb1ec8ea412d548a25b9f8b367258fdf.js

I, [2017-01-22T22:15:40.634714 #2773] INFO -- : Removed default-270b9c30b239e0622b55c68a93351ad8b56bde4af52e9dc6dee3ed4d7e1124b5.css

I, [2017-01-22T22:15:40.640644 #2773] INFO -- : Removed locales/nl-3f2643487cd26bc712d2d53bade04dcfbf8de02db124d1453990847eac991965.js

I, [2017-01-22T22:15:40.646219 #2773] INFO -- : Removed dark-681a673a66ecee6ff638adb9b42edc00086247fb6aa9dc57b93483f16f574571.css

I, [2017-01-22T22:15:40.651902 #2773] INFO -- : Removed application-4e414437c93e3dd8890b023cd4f0a6956039106d4911b74b267599f15a4f8311.js

Using release configuration from last framework (Ruby).

-----> [cron] /opt/openproject/packaging/cron/openproject-clear-old-sessions => /etc/cron.d/openproject-clear-old-sessions

NEW PACKAGE: openproject-6.1.4-1485121203.2cb8b63.centos6.x86_64.rpm (285.42 MiB)

-----> Releasing...

DONE!

====== Attempt #1

-----> Fetching repository

Cloning into '/tmp/d20170122-16665-145i7bq/input'...

-----> Restoring cache

-----> Starting packaging process

-----> Installing missing build dependencies: mysql-devel, ImageMagick-devel

-----> [wizard] adding legacy-installer wizard (https://github.com/pkgr/addon-legacy-installer#master)

-----> [wizard] adding mysql wizard (https://github.com/pkgr/addon-mysql#master)

-----> [wizard] adding apache2 wizard (https://github.com/pkgr/addon-apache2#master)

-----> [wizard] adding repositories wizard (https://github.com/finnlabs/addon-repositories#master)

-----> [wizard] adding smtp wizard (https://github.com/pkgr/addon-smtp#master)

-----> [wizard] adding memcached wizard (https://github.com/pkgr/addon-memcached#master)

-----> [wizard] adding openproject wizard (https://github.com/pkgr/addon-openproject#master)

-----> Fetching buildpack https://github.com/opf/heroku-buildpack-multi.git at master

-----> Multipack app

-----> Running hook: "packaging/setup"

WARNING: This buildpack is no longer maintained.

Please choose a different buildpack or go to https://github.com/ddollar/heroku-buildpack-multi

and fork it to your own account.

=====> Downloading Buildpack: https://github.com/pkgr/pkgr-buildpack-imagemagick.git

=====> Detected Framework: ImageMagick

-----> SKIP

=====> Downloading Buildpack: https://github.com/heroku/heroku-buildpack-nodejs.git

=====> Detected Framework: Node.js

-----> Reading application state

package.json...

build directory...

cache directory...

environment variables...

Node engine: 6.9.1

Npm engine: 4.0.0

Start mechanism: Procfile

node_modules source: package.json

node_modules cached: true

NPM_CONFIG_PRODUCTION=true

NODE_MODULES_CACHE=true

-----> Installing binaries

Downloading and installing node 6.9.1...

Downloading and installing npm 4.0.0 (replacing version 3.10.8)...

-----> Building dependencies

Restoring node modules from cache

Pruning unused dependencies

Installing any new modules

> openproject@0.1.0 postinstall /tmp/d20170122-17-sryd45/opt/openproject

> cd frontend && npm install

> openproject-frontend@0.1.0 postinstall /tmp/d20170122-17-sryd45/opt/openproject/frontend

> bower install --config.interactive=false

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 not-cached git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolve git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de not-cached git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolve git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 not-cached git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolve git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 checkout d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower jquery#1.11.0 not-cached https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery#1.11.0 resolve https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery-ui#~1.10.4 not-cached https://github.com/components/jqueryui.git#~1.10.4

bower jquery-ui#~1.10.4 resolve https://github.com/components/jqueryui.git#~1.10.4

bower select2#3.5.2 not-cached https://github.com/ivaynberg/select2.git#3.5.2

bower select2#3.5.2 resolve https://github.com/ivaynberg/select2.git#3.5.2

bower jquery.atwho#0.5.1 not-cached https://github.com/ichord/At.js.git#0.5.1

bower jquery.atwho#0.5.1 resolve https://github.com/ichord/At.js.git#0.5.1

bower jquery-ujs#1.0.0 not-cached https://github.com/rails/jquery-ujs.git#1.0.0

bower jquery-ujs#1.0.0 resolve https://github.com/rails/jquery-ujs.git#1.0.0

bower angular#~1.5.8 not-cached https://github.com/angular/bower-angular.git#~1.5.8

bower angular#~1.5.8 resolve https://github.com/angular/bower-angular.git#~1.5.8

bower angular-ui-router#~0.3.1 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-ui-router#~0.3.1 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-aria#~1.5.8 not-cached https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-aria#~1.5.8 resolve https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-i18n#~1.5.5 not-cached https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-i18n#~1.5.5 resolve https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-animate#~1.5.8 not-cached https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-animate#~1.5.8 resolve https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-sanitize#~1.5.8 not-cached https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-sanitize#~1.5.8 resolve https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-elastic#~2.5.1 not-cached https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-elastic#~2.5.1 resolve https://github.com/monospaced/angular-elastic.git#~2.5.1

bower jquery-migrate#~1.2.1 not-cached https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower jquery-migrate#~1.2.1 resolve https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower angular-cache#~4.6.0 not-cached https://github.com/jmdobry/angular-cache.git#~4.6.0

bower angular-cache#~4.6.0 resolve https://github.com/jmdobry/angular-cache.git#~4.6.0

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de checkout fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 checkout a908eccaec323cd66973d58af4965694bdff16a1

bower moment#~2.10.6 not-cached https://github.com/moment/moment.git#~2.10.6

bower moment#~2.10.6 resolve https://github.com/moment/moment.git#~2.10.6

bower lodash#~2.4.1 not-cached https://github.com/lodash/lodash.git#~2.4.1

bower lodash#~2.4.1 resolve https://github.com/lodash/lodash.git#~2.4.1

bower angular-busy#~4.1.3 not-cached https://github.com/cgross/angular-busy.git#~4.1.3

bower angular-busy#~4.1.3 resolve https://github.com/cgross/angular-busy.git#~4.1.3

bower moment-timezone#0.4.x not-cached https://github.com/moment/moment-timezone.git#0.4.x

bower moment-timezone#0.4.x resolve https://github.com/moment/moment-timezone.git#0.4.x

bower mousetrap#~1.4.6 not-cached https://github.com/ccampbell/mousetrap.git#~1.4.6

bower mousetrap#~1.4.6 resolve https://github.com/ccampbell/mousetrap.git#~1.4.6

bower bourbon#~4.2.1 not-cached https://github.com/thoughtbot/bourbon.git#~4.2.1

bower bourbon#~4.2.1 resolve https://github.com/thoughtbot/bourbon.git#~4.2.1

bower angular-ui-select#~0.19.4 not-cached https://github.com/angular-ui/ui-select.git#~0.19.4

bower angular-ui-select#~0.19.4 resolve https://github.com/angular-ui/ui-select.git#~0.19.4

bower foundation-apps#1.1.0 not-cached https://github.com/zurb/foundation-apps.git#1.1.0

bower foundation-apps#1.1.0 resolve https://github.com/zurb/foundation-apps.git#1.1.0

bower ng-file-upload#~5.0.9 not-cached https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower ng-file-upload#~5.0.9 resolve https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower ng-dialog#^0.6.2 not-cached https://github.com/likeastore/ngDialog.git#^0.6.2

bower ng-dialog#^0.6.2 resolve https://github.com/likeastore/ngDialog.git#^0.6.2

bower angular-dragula#^1.2.8 not-cached https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower angular-dragula#^1.2.8 resolve https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower jquery-mockjax#~1.5.3 not-cached https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery-mockjax#~1.5.3 resolve https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower mocha#~1.14.0 not-cached https://github.com/mochajs/mocha.git#~1.14.0

bower mocha#~1.14.0 resolve https://github.com/mochajs/mocha.git#~1.14.0

bower rxjs#^4.1.0 not-cached https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower rxjs#^4.1.0 resolve https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower chai#~1.9.0 not-cached https://github.com/chaijs/chai.git#~1.9.0

bower chai#~1.9.0 resolve https://github.com/chaijs/chai.git#~1.9.0

bower angular-mocks#~1.5.8 not-cached https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower angular-mocks#~1.5.8 resolve https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower jquery#1.11.0 checkout 1.11.0

bower select2#3.5.2 checkout 3.5.2

bower jquery-ui#~1.10.4 checkout 1.10.4

bower jquery.atwho#0.5.1 checkout v0.5.1

bower angular-ui-router#~0.3.1 checkout 0.3.2

bower angular#~1.5.8 checkout v1.5.11

bower jquery-migrate#~1.2.1 checkout 1.2.1

bower jquery-ujs#1.0.0 checkout v1.0.0

bower angular-aria#~1.5.8 checkout v1.5.11

bower angular-cache#~4.6.0 checkout 4.6.0

bower angular-i18n#~1.5.5 checkout v1.5.11

bower moment#~2.10.6 checkout 2.10.6

bower angular-elastic#~2.5.1 checkout v2.5.1

bower angular-sanitize#~1.5.8 checkout v1.5.11

bower angular-animate#~1.5.8 checkout v1.5.11

bower bourbon#~4.2.1 checkout v4.2.7

bower mousetrap#~1.4.6 checkout 1.4.6

bower moment-timezone#0.4.x checkout 0.4.1

bower angular-busy#~4.1.3 checkout v4.1.4

bower lodash#~2.4.1 checkout 2.4.2

bower angular-ui-select#~0.19.4 checkout v0.19.6

bower ng-file-upload#~5.0.9 checkout 5.0.9

bower angular-dragula#^1.2.8 checkout v1.2.8

bower foundation-apps#1.1.0 checkout v1.1.0

bower ng-dialog#^0.6.2 checkout v0.6.6

bower jquery-mockjax#~1.5.3 checkout v1.5.4

bower mocha#~1.14.0 checkout 1.14.0

bower chai#~1.9.0 checkout 1.9.2

bower rxjs#^4.1.0 checkout v4.1.0

bower angular-mocks#~1.5.8 checkout v1.5.11

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolved git://github.com/finnlabs/angular-modal.git#d45eb9ceb7

bower angular#^1.3.0 not-cached https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 resolve https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 checkout v1.6.1

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolved git://github.com/nickmessing/angular-context-menu.git#a908eccaec

bower angular#>= 1.2.5 not-cached https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 resolve https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 checkout v1.6.1

bower jquery.atwho#0.5.1 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .png files: ["select2.png","select2x2.png"]

bower select2#3.5.2 resolved https://github.com/ivaynberg/select2.git#3.5.2

bower jquery-ui#~1.10.4 resolved https://github.com/components/jqueryui.git#1.10.4

bower angular-ui-router#~0.3.1 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.3.2

bower jquery.atwho#0.5.1 resolved https://github.com/ichord/At.js.git#0.5.1

bower jquery#1.11.0 resolved https://github.com/jquery/jquery-dist.git#1.11.0

bower Caret.js#>= 0.2.0 not-cached https://github.com/ichord/Caret.js.git#>= 0.2.0

bower Caret.js#>= 0.2.0 resolve https://github.com/ichord/Caret.js.git#>= 0.2.0

bower jquery-migrate#~1.2.1 deprecated Package jquery-migrate is using the deprecated component.json

bower jquery-migrate#~1.2.1 resolved https://github.com/appleboy/jquery-migrate.git#1.2.1

bower angular-aria#~1.5.8 resolved https://github.com/angular/bower-angular-aria.git#1.5.11

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolved git://github.com/sparkalow/angular-truncate.git#fdf60fda26

bower jquery-ujs#1.0.0 resolved https://github.com/rails/jquery-ujs.git#1.0.0

bower angular-cache#~4.6.0 resolved https://github.com/jmdobry/angular-cache.git#4.6.0

bower angular#>=1.x not-cached https://github.com/angular/bower-angular.git#>=1.x

bower angular#>=1.x resolve https://github.com/angular/bower-angular.git#>=1.x

bower angular#>=1.x checkout v1.6.1

bower angular#~1.5.8 resolved https://github.com/angular/bower-angular.git#1.5.11

bower angular-elastic#~2.5.1 resolved https://github.com/monospaced/angular-elastic.git#2.5.1

bower angular-sanitize#~1.5.8 resolved https://github.com/angular/bower-angular-sanitize.git#1.5.11

bower angular-animate#~1.5.8 resolved https://github.com/angular/bower-angular-animate.git#1.5.11

bower moment#~2.10.6 resolved https://github.com/moment/moment.git#2.10.6

bower bourbon#~4.2.1 resolved https://github.com/thoughtbot/bourbon.git#4.2.7

bower mousetrap#~1.4.6 resolved https://github.com/ccampbell/mousetrap.git#1.4.6

bower angular-busy#~4.1.3 resolved https://github.com/cgross/angular-busy.git#4.1.4

bower angular-ui-select#~0.19.4 resolved https://github.com/angular-ui/ui-select.git#0.19.6

bower ng-file-upload#~5.0.9 resolved https://github.com/danialfarid/angular-file-upload-bower.git#5.0.9

bower lodash#~2.4.1 resolved https://github.com/lodash/lodash.git#2.4.2

bower moment-timezone#0.4.x resolved https://github.com/moment/moment-timezone.git#0.4.1

bower angular-i18n#~1.5.5 resolved https://github.com/angular/bower-angular-i18n.git#1.5.11

bower angular-dragula#^1.2.8 resolved https://github.com/bevacqua/angular-dragula.git#1.2.8

bower ng-dialog#^0.6.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .css files: ["css/ngDialog.css","css/ngDialog-theme-default.css"]

bower ng-dialog#^0.6.2 resolved https://github.com/likeastore/ngDialog.git#0.6.6

bower foundation-apps#1.1.0 resolved https://github.com/zurb/foundation-apps.git#1.1.0

bower angular#~1.3.4 not-cached https://github.com/angular/bower-angular.git#~1.3.4

bower angular#~1.3.4 resolve https://github.com/angular/bower-angular.git#~1.3.4

bower angular-ui-router#~0.2.12 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-ui-router#~0.2.12 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-animate#~1.3.4 not-cached https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular-animate#~1.3.4 resolve https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular#~1.3.4 checkout v1.3.20

bower angular-ui-router#~0.2.12 checkout 0.2.18

bower angular-animate#~1.3.4 checkout v1.3.20

bower angular-mocks#~1.5.8 resolved https://github.com/angular/bower-angular-mocks.git#1.5.11

bower jquery-mockjax#~1.5.3 resolved https://github.com/jakerella/jquery-mockjax.git#1.5.4

bower fastclick#~1.0.3 not-cached https://github.com/ftlabs/fastclick.git#~1.0.3

bower fastclick#~1.0.3 resolve https://github.com/ftlabs/fastclick.git#~1.0.3

bower viewport-units-buggyfill#~0.4.1 not-cached https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower viewport-units-buggyfill#~0.4.1 resolve https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower mocha#~1.14.0 mismatch Version declared in the json (1.12.0) is different than the resolved one (1.14.0)

bower mocha#~1.14.0 resolved https://github.com/mochajs/mocha.git#1.14.0

bower chai#~1.9.0 resolved https://github.com/chaijs/chai.git#1.9.2

bower hammerjs#~2.0.4 not-cached https://github.com/EightMedia/hammer.js.git#~2.0.4

bower hammerjs#~2.0.4 resolve https://github.com/EightMedia/hammer.js.git#~2.0.4

bower tether#~0.6.5 not-cached https://github.com/HubSpot/tether.git#~0.6.5

bower tether#~0.6.5 resolve https://github.com/HubSpot/tether.git#~0.6.5

bower Caret.js#>= 0.2.0 checkout v0.3.1

bower angular#^1.3.0 resolved https://github.com/angular/bower-angular.git#1.6.1

bower angular#>= 1.2.5 resolved https://github.com/angular/bower-angular.git#1.6.1

bower angular-ui-router#~0.2.12 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.2.18

bower angular#>=1.x resolved https://github.com/angular/bower-angular.git#1.6.1

bower angular-animate#~1.3.4 resolved https://github.com/angular/bower-angular-animate.git#1.3.20

bower fastclick#~1.0.3 checkout v1.0.6

bower angular#~1.3.4 resolved https://github.com/angular/bower-angular.git#1.3.20

bower viewport-units-buggyfill#~0.4.1 checkout v0.4.1

bower hammerjs#~2.0.4 checkout v2.0.8

bower tether#~0.6.5 checkout v0.6.5

bower rxjs#^4.1.0 resolved https://github.com/Reactive-Extensions/RxJS.git#4.1.0

bower Caret.js#>= 0.2.0 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower Caret.js#>= 0.2.0 resolved https://github.com/ichord/Caret.js.git#0.3.1

bower fastclick#~1.0.3 resolved https://github.com/ftlabs/fastclick.git#1.0.6

bower viewport-units-buggyfill#~0.4.1 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .js files: ["./viewport-units-buggyfill.js","./viewport-units-buggyfill.hacks.js"]

bower viewport-units-buggyfill#~0.4.1 resolved https://github.com/rodneyrehm/viewport-units-buggyfill.git#0.4.1

bower hammerjs#~2.0.4 resolved https://github.com/EightMedia/hammer.js.git#2.0.8

bower tether#~0.6.5 resolved https://github.com/HubSpot/tether.git#0.6.5

Please note that,

foundation-apps#1.1.0 depends on angular-ui-router#~0.2.12 which resolved to angular-ui-router#0.2.18

openproject depends on angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Resort to using angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Code incompatibilities may occur.

Please note that,

angular-animate#1.3.20 depends on angular#1.3.20 which resolved to angular#1.3.20

foundation-apps#1.1.0 depends on angular#~1.3.4 which resolved to angular#1.3.20

angular-animate#1.5.11, angular-aria#1.5.11, angular-mocks#1.5.11, angular-sanitize#1.5.11 depends on angular#1.5.11 which resolved to angular#1.5.11

angular-ui-router#0.3.2, angular-ui-router#0.2.18 depends on angular#^1.0.8 which resolved to angular#1.5.11

angular-busy#4.1.4 depends on angular#>=1.3 which resolved to angular#1.5.11

angular-ui-select#0.19.6 depends on angular#>=1.2.18 which resolved to angular#1.5.11

ng-dialog#0.6.6 depends on angular#>=1.5 which resolved to angular#1.5.11

openproject depends on angular#~1.5.8 which resolved to angular#1.5.11

angular-elastic#2.5.1 depends on angular#>=1.0.6 which resolved to angular#1.5.11

angular-context-menu#a908eccaec depends on angular#>= 1.2.5 which resolved to angular#1.6.1

angular-cache#4.6.0 depends on angular#>=1.x which resolved to angular#1.6.1

angular-modal#d45eb9ceb7 depends on angular#^1.3.0 which resolved to angular#1.6.1

Resort to using angular#~1.5.8 which resolved to angular#1.5.11

Code incompatibilities may occur.

Please note that,

foundation-apps#1.1.0 depends on angular-animate#~1.3.4 which resolved to angular-animate#1.3.20

openproject depends on angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

angular-busy#4.1.4 depends on angular-animate#>=1.3 which resolved to angular-animate#1.5.11

Resort to using angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

Code incompatibilities may occur.

bower jquery extra-resolution Unnecessary resolution: jquery#1.11.0

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 install angular-modal#d45eb9ceb7

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 install angular-context-menu#a908eccaec

bower select2#3.5.2 install select2#3.5.2

bower jquery-ui#~1.10.4 install jquery-ui#1.10.4

bower angular-ui-router#~0.3.1 install angular-ui-router#0.3.2

bower jquery.atwho#0.5.1 install jquery.atwho#0.5.1

bower jquery#1.11.0 install jquery#1.11.0

bower jquery-migrate#~1.2.1 install jquery-migrate#1.2.1

bower angular-aria#~1.5.8 install angular-aria#1.5.11

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de install angular-truncate#fdf60fda26

bower jquery-ujs#1.0.0 install jquery-ujs#1.0.0

bower angular-cache#~4.6.0 install angular-cache#4.6.0

bower angular#1.5.11 install angular#1.5.11

bower angular-elastic#~2.5.1 install angular-elastic#2.5.1

bower angular-sanitize#~1.5.8 install angular-sanitize#1.5.11

bower angular-animate#~1.5.8 install angular-animate#1.5.11

bower moment#~2.10.6 install moment#2.10.6

bower bourbon#~4.2.1 install bourbon#4.2.7

bower mousetrap#~1.4.6 install mousetrap#1.4.6

bower angular-busy#~4.1.3 install angular-busy#4.1.4

bower angular-ui-select#~0.19.4 install angular-ui-select#0.19.6

bower ng-file-upload#~5.0.9 install ng-file-upload#5.0.9

bower lodash#~2.4.1 install lodash#2.4.2

bower moment-timezone#0.4.x install moment-timezone#0.4.1

bower angular-i18n#~1.5.5 install angular-i18n#1.5.11

bower angular-dragula#^1.2.8 install angular-dragula#1.2.8

bower ng-dialog#^0.6.2 install ng-dialog#0.6.6

bower foundation-apps#1.1.0 install foundation-apps#1.1.0

bower angular-mocks#~1.5.8 install angular-mocks#1.5.11

bower jquery-mockjax#~1.5.3 install jquery-mockjax#1.5.4

bower mocha#~1.14.0 install mocha#1.14.0

bower chai#~1.9.0 install chai#1.9.2

bower rxjs#^4.1.0 install rxjs#4.1.0

bower Caret.js#>= 0.2.0 install Caret.js#0.3.1

bower fastclick#~1.0.3 install fastclick#1.0.6

bower viewport-units-buggyfill#~0.4.1 install viewport-units-buggyfill#0.4.1

bower hammerjs#~2.0.4 install hammerjs#2.0.8

bower tether#~0.6.5 install tether#0.6.5

angular-modal#d45eb9ceb7 bower_components/angular-modal

└── angular#1.5.11

angular-context-menu#a908eccaec bower_components/angular-context-menu

└── angular#1.5.11

select2#3.5.2 bower_components/select2

└── jquery#1.11.0

jquery-ui#1.10.4 bower_components/jquery-ui

└── jquery#1.11.0

angular-ui-router#0.3.2 bower_components/angular-ui-router

└── angular#1.5.11

jquery.atwho#0.5.1 bower_components/jquery.atwho

├── Caret.js#0.3.1

└── jquery#1.11.0

jquery#1.11.0 bower_components/jquery

jquery-migrate#1.2.1 bower_components/jquery-migrate

angular-aria#1.5.11 bower_components/angular-aria

└── angular#1.5.11

angular-truncate#fdf60fda26 bower_components/angular-truncate

jquery-ujs#1.0.0 bower_components/jquery-ujs

└── jquery#1.11.0

angular-cache#4.6.0 bower_components/angular-cache

└── angular#1.5.11

angular#1.5.11 bower_components/angular

angular-elastic#2.5.1 bower_components/angular-elastic

└── angular#1.5.11

angular-sanitize#1.5.11 bower_components/angular-sanitize

└── angular#1.5.11

angular-animate#1.5.11 bower_components/angular-animate

└── angular#1.5.11

moment#2.10.6 bower_components/moment

bourbon#4.2.7 bower_components/bourbon

mousetrap#1.4.6 bower_components/mousetrap

angular-busy#4.1.4 bower_components/angular-busy

├── angular#1.5.11

└── angular-animate#1.5.11

angular-ui-select#0.19.6 bower_components/angular-ui-select

└── angular#1.5.11

ng-file-upload#5.0.9 bower_components/ng-file-upload

lodash#2.4.2 bower_components/lodash

moment-timezone#0.4.1 bower_components/moment-timezone

└── moment#2.10.6

angular-i18n#1.5.11 bower_components/angular-i18n

angular-dragula#1.2.8 bower_components/angular-dragula

ng-dialog#0.6.6 bower_components/ng-dialog

└── angular#1.5.11

foundation-apps#1.1.0 bower_components/foundation-apps

├── angular#1.5.11

├── angular-animate#1.5.11

├── angular-ui-router#0.3.2

├── fastclick#1.0.6

├── hammerjs#2.0.8

├── tether#0.6.5

└── viewport-units-buggyfill#0.4.1

angular-mocks#1.5.11 bower_components/angular-mocks

└── angular#1.5.11

jquery-mockjax#1.5.4 bower_components/jquery-mockjax

mocha#1.14.0 bower_components/mocha

chai#1.9.2 bower_components/chai

rxjs#4.1.0 bower_components/rxjs

Caret.js#0.3.1 bower_components/Caret.js

└── jquery#1.11.0

fastclick#1.0.6 bower_components/fastclick

viewport-units-buggyfill#0.4.1 bower_components/viewport-units-buggyfill

hammerjs#2.0.8 bower_components/hammerjs

tether#0.6.5 bower_components/tether

openproject-frontend@0.1.0 /tmp/d20170122-17-sryd45/opt/openproject/frontend

+-- acorn@2.6.4

+-- align-text@0.1.4

+-- alter@0.2.0

+-- amdefine@1.0.0

+-- angular@1.5.8

+-- angular-elastic@2.5.1

+-- angular-ui-bootstrap@2.2.0

+-- anymatch@1.3.0

+-- arr-diff@2.0.0

+-- arr-flatten@1.0.1

+-- array-unique@0.2.1

+-- arrify@1.0.1

+-- assert@1.4.1

+-- async@0.2.10

+-- async-each@1.0.1

+-- atoa@1.0.0

+-- autoprefixer-core@5.2.1

+-- autoprefixer-loader@1.2.0

+-- awesome-typescript-loader@2.2.4

| `-- lodash@4.16.4

+-- balanced-match@0.4.2

+-- Base64@0.2.1

+-- base64-js@1.2.0

+-- big.js@3.1.3

+-- binary-extensions@1.7.0

+-- bower@1.7.9

+-- brace-expansion@1.1.6

+-- braces@1.8.5

+-- browserify-zlib@0.1.4

+-- browserslist@0.4.0

+-- buffer@4.9.1

+-- buffer-shims@1.0.0

+-- camelcase@1.2.1

+-- caniuse-db@1.0.30000569

+-- center-align@0.1.3

+-- chokidar@1.6.1

+-- cliui@2.1.0

| `-- wordwrap@0.0.2

+-- clone@1.0.2

+-- colors@1.1.2

+-- concat-map@0.0.1

+-- console-browserify@1.1.0

+-- constants-browserify@0.0.1

+-- contra@1.9.4

+-- convert-source-map@1.1.3

+-- core-util-is@1.0.2

+-- crossvent@1.5.4

+-- crypto-browserify@3.2.8

+-- css-loader@0.9.1

| `-- source-map@0.1.43

+-- csso@1.3.12

+-- custom-event@1.0.0

+-- d@0.1.1

+-- date-now@0.1.4

+-- decamelize@1.2.0

+-- domain-browser@1.1.7

+-- dragula@3.7.2

+-- emojis-list@2.1.0

+-- enhanced-resolve@2.3.0

+-- errno@0.1.4

+-- es5-ext@0.10.12

+-- es6-iterator@2.0.0

+-- es6-promise@2.3.0

+-- es6-symbol@3.1.0

+-- es6-weak-map@0.1.4

| +-- es6-iterator@0.1.3

| `-- es6-symbol@2.0.1

+-- event-emitter@0.3.4

+-- events@1.1.1

+-- expand-brackets@0.1.5

+-- expand-range@1.8.2

+-- exports-loader@0.6.3

| `-- source-map@0.1.43

+-- expose-loader@0.6.0

+-- extglob@0.3.2

+-- extract-text-webpack-plugin@0.3.8

| `-- source-map@0.1.43

+-- fastparse@1.1.1

+-- file-loader@0.8.5

+-- filename-regex@2.0.0

+-- fill-range@2.2.3

+-- for-in@0.1.6

+-- for-own@0.1.4

+-- glob@4.5.3

+-- glob-base@0.3.0

+-- glob-parent@2.0.0

+-- graceful-fs@4.1.9

+-- has-flag@1.0.0

+-- html-loader@0.2.3

| `-- source-map@0.1.43

+-- html-minifier@0.5.6

+-- http-browserify@1.7.0

+-- https-browserify@0.0.0

+-- ieee754@1.1.8

+-- indexof@0.0.1

+-- inflight@1.0.6

+-- inherits@2.0.3

+-- interpret@0.6.6

+-- is-binary-path@1.0.1

+-- is-buffer@1.1.4

+-- is-dotfile@1.0.2

+-- is-equal-shallow@0.1.3

+-- is-extendable@0.1.1

+-- is-extglob@1.0.0

+-- is-glob@2.0.1

+-- is-number@2.1.0

+-- is-posix-bracket@0.1.1

+-- is-primitive@2.0.0

+-- isarray@1.0.0

+-- isobject@2.1.0

+-- js-base64@2.1.9

+-- json5@0.4.0

+-- kind-of@3.0.4

+-- lazy-cache@1.0.4

+-- loader-utils@0.2.16

| `-- json5@0.5.0

+-- lodash@2.4.2

+-- longest@1.0.1

+-- lru-queue@0.1.0

+-- memoizee@0.3.10

+-- memory-fs@0.3.0

+-- micromatch@2.3.11

+-- mime@1.2.11

+-- minimatch@2.0.10

+-- minimist@0.0.10

+-- mkdirp@0.5.1

| `-- minimist@0.0.8

+-- nan@2.4.0

+-- next-tick@0.2.2

+-- ng-annotate@1.2.1

| `-- source-map@0.5.6

+-- ng-annotate-loader@0.0.10

| `-- source-map@0.4.2

+-- ngtemplate-loader@0.1.3

+-- node-libs-browser@0.6.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- normalize-path@2.0.1

+-- num2fraction@1.2.2

+-- object-assign@4.1.0

+-- object.omit@2.0.1

+-- observable-array@0.0.4

+-- observable-value@0.0.5

+-- once@1.4.0

+-- optimist@0.6.1

+-- ordered-ast-traverse@1.1.1

+-- ordered-esprima-props@1.1.0

+-- os-browserify@0.1.2

+-- pako@0.2.9

+-- parse-glob@3.0.4

+-- path-browserify@0.0.0

+-- path-is-absolute@1.0.1

+-- pbkdf2-compat@2.0.1

+-- phantomjs-polyfill@0.0.2

+-- postcss@4.1.16

+-- preserve@0.2.0

+-- process@0.11.9

+-- process-nextick-args@1.0.7

+-- prr@0.0.0

+-- punycode@1.4.1

+-- querystring@0.2.0

+-- querystring-es3@0.2.1

+-- randomatic@1.1.5

+-- readable-stream@2.1.5

+-- readdirp@2.1.0

| `-- minimatch@3.0.3

+-- regex-cache@0.4.3

+-- repeat-element@1.1.2

+-- repeat-string@1.6.1

+-- right-align@0.1.3

+-- ripemd160@0.2.0

+-- set-immediate-shim@1.0.1

+-- sha.js@2.2.6

+-- shelljs@0.3.0

+-- simple-fmt@0.1.0

+-- simple-is@0.2.0

+-- source-list-map@0.1.6

+-- source-map@0.4.4

+-- source-map-support@0.4.5

| `-- source-map@0.5.6

+-- stable@0.1.5

+-- stream-browserify@1.0.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- string_decoder@0.10.31

+-- stringmap@0.2.2

+-- stringset@0.2.1

+-- style-loader@0.8.3

+-- supports-color@3.1.2

+-- tapable@0.2.4

+-- ticky@1.0.1

+-- timers-browserify@1.4.2

+-- timers-ext@0.1.0

+-- tryor@0.1.2

+-- tty-browserify@0.0.0

+-- typescript@2.0.6

+-- uglify-js@2.7.4

| `-- source-map@0.5.6

+-- uglify-to-browserify@1.0.2

+-- URIjs@1.16.1

+-- url@0.10.3

| `-- punycode@1.3.2

+-- url-loader@0.5.7

+-- util@0.10.3

| `-- inherits@2.0.1

+-- util-deprecate@1.0.2

+-- vm-browserify@0.0.4

+-- watchpack@0.2.9

| `-- async@0.9.2

+-- webpack@1.13.3

| +-- acorn@3.3.0

| +-- async@1.5.2

| +-- enhanced-resolve@0.9.1

| | `-- memory-fs@0.2.0

| `-- tapable@0.1.10

+-- webpack-core@0.6.8

+-- window-size@0.1.0

+-- wordwrap@0.0.3

+-- wrappy@1.0.2

`-- yargs@3.10.0

npm WARN openproject-frontend@0.1.0 No repository field.

npm WARN openproject-frontend@0.1.0 No license field.

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.0.14 (node_modules/fsevents):

npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.0.14: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

-----> Checking startup method

Found Procfile

-----> Finalizing build

Creating runtime environment

Exporting binary paths

Cleaning npm artifacts

Cleaning previous cache

Caching results for future builds

-----> Build succeeded!

openproject@0.1.0 /tmp/d20170122-17-sryd45/opt/openproject

`-- typescript@2.0.8

=====> Downloading Buildpack: https://github.com/pkgr/heroku-buildpack-ruby.git

=====> Detected Framework: Ruby

-----> Compiling Ruby/Rails

-----> Using Ruby version: ruby-2.3.1

-----> Installing dependencies using bundler 1.13.2

cp: ‘/tmp/d20170122-17-sryd45/opt/openproject/.git/cache/vendor/bundle/.’ and ‘/tmp/d20170122-17-sryd45/opt/openproject/.git/cache/vendor/bundle/.’ are the same file

Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Fetching gem metadata from https://rubygems.org/......

Fetching version metadata from https://rubygems.org/..

Fetching dependency metadata from https://rubygems.org/.

Using i18n 0.7.0

Installing minitest 5.9.0

Installing rake 11.3.0

Installing concurrent-ruby 1.0.2

Using thread_safe 0.3.5

Using erubis 2.7.0

Using mini_portile2 2.1.0

Using rack 2.0.1

Using nio4r 1.2.1

Using websocket-extensions 0.1.2

Using mime-types 2.99.3

Using method_source 0.8.2

Installing builder 3.2.2

Installing pkg-config 1.1.7

Using multi_json 1.12.1

Using acts_as_silent_list 3.0.0

Using addressable 2.4.0

Using airbrake-ruby 1.5.0

Using attr_required 1.0.1

Using execjs 2.7.0

Using ice_nine 0.11.2

Using bcrypt 3.1.11

Using bindata 2.3.4

Using sass 3.4.22

Using tilt 2.0.5

Using uber 0.0.15

Using erbse 0.0.2

Using coderay 1.1.1

Using color-tools 1.3.0

Using unf_ext 0.0.7.2

Using netrc 0.11.0

Using daemons 1.2.4

Using dalli 2.7.6

Using enumerable-lazy 0.0.1

Using equalizer 0.0.11

Using excon 0.52.0

Using ffi 1.9.14

Using formatador 0.2.5

Using ipaddress 0.8.3

Using get_process_mem 0.2.1

Using request_store 1.3.1

Using json 1.8.3

Using hashie 3.4.6

Using multi_xml 0.5.5

Using gravatar_image_tag 1.2.0

Using bundler 1.13.2

Using htmldiff 0.0.1

Installing thor 0.19.1

Installing arel 7.1.2

Using icalendar 2.3.0

Using iso8601 0.9.1

Using securecompare 1.0.0

Using url_safe_base64 0.2.2

Using kgio 2.10.0

Using mixlib-shellout 2.1.0

Using mysql2 0.4.4

Using net-ldap 0.14.0

Using newrelic_rpm 3.16.2.321

Using oj 2.17.4

Using pdf-core 0.6.1

Using ttfunk 1.4.0

Using rmagick 2.15.4

Using rubyzip 1.2.0

Using ruby-ole 1.2.12

Using pg 0.19.0

Using rails_serve_static_assets 0.0.5

Using rails_stdout_logging 0.0.5

Using raindrops 0.17.0

Using ruby-progressbar 1.8.1

Using structured_warnings 0.2.0

Using sqlite3 1.3.11

Using stringex 2.6.1

Using svg-graph 2.0.1

Using syck 1.0.5

Using will_paginate 3.1.3

Using i18n-js 3.0.0.rc14

Using tzinfo 1.2.2

Using descendants_tracker 0.0.4

Using rack-test 0.6.3

Using rack-accept 0.4.5

Using passenger 5.0.30

Using rack-attack 5.0.1

Using rack-protection 2.0.0.beta2

Using warden 1.2.6

Using websocket-driver 0.6.4

Using mail 2.6.4

Installing httpclient 2.8.2.4

Using airbrake 5.1.0

Using autoprefixer-rails 6.4.1.1

Using cells 4.1.3

Using unf 0.1.4

Using mustermann19 0.4.4

Using sys-filesystem 1.1.7

Using fog-core 1.42.0

Using rdoc 4.2.2

Using omniauth 1.3.1 from https://github.com/oliverguenther/omniauth (at 8385bc0@8385bc0)

Using bourbon 4.2.7

Using prawn 2.1.0

Using spreadsheet 0.8.9

Using rails_12factor 0.0.3

Using unicorn 5.1.0

Installing sprockets 3.7.0

Using rubytree 0.9.7

Using tzinfo-data 1.2016.6

Using axiom-types 0.1.1

Using coercible 1.0.0

Using warden-basic_auth 0.2.1

Using cells-erb 0.0.8

Using domain_name 0.5.20161129

Using fog-json 1.0.2

Using prawn-table 0.2.2

Using unicorn-worker-killer 0.4.4

Using virtus 1.0.5

Using http-cookie 1.0.3

Using rest-client 1.8.0

Using crowdin-api 0.4.1

Installing activesupport 5.0.0.1

Using globalid 0.3.7

Using climate_control 0.0.3

Using delayed_job 4.1.2

Using grape 0.17.0

Installing json-jwt 1.6.5

Installing activemodel 5.0.0.1

Using swd 1.0.1

Using webfinger 1.0.2

Using rabl 0.13.0

Using ruby-duration 3.2.3

Installing rack-oauth2 1.4.0

Installing activejob 5.0.0.1

Using cocaine 0.5.8

Using grape-cache_control 1.0.1

Using carrierwave 1.0.0.beta from https://github.com/carrierwaveuploader/carrierwave (at master@5367a63)

Using date_validator 0.9.0

Using validate_email 0.1.6

Using validate_url 1.0.2

Using openid_connect 0.8.3

Using omniauth-openid-connect 0.2.0 from https://github.com/finnlabs/omniauth-openid-connect.git (at dev@c3bce4c)

Using omniauth-openid_connect-providers 0.1.0 from https://github.com/finnlabs/omniauth-openid_connect-providers.git (at dev@86f3670)

Installing nokogiri 1.6.8 with native extensions

Installing activerecord 5.0.0.1

Using activemodel-serializers-xml 1.0.1

Using acts_as_list 0.8.1

Using acts_as_tree 2.5.1

Using awesome_nested_set 3.1.1

Using delayed_job_active_record 4.1.1

Using friendly_id 5.2.0.beta.1 from https://github.com/norman/friendly_id (at aff0564@aff0564)

Using globalize 5.1.0 from https://github.com/globalize/globalize (at 38443bc@38443bc)

Using transactional_lock 0.1.0 from https://github.com/finnlabs/transactional_lock.git (at master@6948b1d)

Using loofah 2.0.3

Using representable 2.1.8

Using fog-xml 0.1.2

Using ruby-saml 1.4.0

Using rails-html-sanitizer 1.0.3

Using fog-aws 0.11.0

Using disposable 0.0.9

Using roar 1.0.4

Using omniauth-saml 1.6.0 from git://github.com/omniauth/omniauth-saml.git (at master@5559d6b)

Using reform 1.2.6

Using openproject-auth_saml 0.1.0 from https://github.com/finnlabs/openproject-auth_saml (at dev@97212ab)

Installing rails-dom-testing 2.0.1

Installing actionview 5.0.0.1

Installing actionpack 5.0.0.1

Installing actionmailer 5.0.0.1

Installing actioncable 5.0.0.1

Using cells-rails 0.0.6

Using gon 4.1.1

Using sprockets-rails 3.2.0

Installing railties 5.0.0.1

Using actionpack-xml_parser 2.0.0

Using activerecord-session_store 1.0.0

Using jquery-tablesorter 1.22.7

Using responders 2.3.0

Using sass-rails 5.0.6

Installing rails 5.0.0.1

Using health_check 2.2.1

Using lobby_boy 0.1.2

Using openproject-auth_plugins 6.1.4 from source at `vendored-plugins/openproject-auth_plugins`

Using openproject-pdf_export 6.1.4 from source at `vendored-plugins/openproject-pdf_export`

Using openproject-costs 6.1.4 from source at `vendored-plugins/openproject-costs`

Using openproject-documents 6.1.4 from source at `vendored-plugins/openproject-documents`

Using openproject-webhooks 6.1.4 from source at `vendored-plugins/openproject-webhooks`

Using openproject-global_roles 6.1.4 from source at `vendored-plugins/openproject-global_roles`

Using openproject-local_avatars 6.1.4 from source at `vendored-plugins/openproject-local_avatars`

Using openproject-meeting 6.1.4 from source at `vendored-plugins/openproject-meeting`

Using openproject-my_project_page 6.1.4 from source at `vendored-plugins/openproject-my_project_page`

Using reporting_engine 6.1.4 from source at `vendored-plugins/reporting_engine`

Using openproject-themes-dark 6.1.4 from source at `vendored-plugins/openproject-themes-dark`

Using openproject-translations 6.1.4 from https://github.com/opf/openproject-translations.git (at stable/6@da52ff9)

Using openproject-xls_export 6.1.4 from source at `vendored-plugins/openproject-xls_export`

Using rails-angular-xss 0.3.0.pre.pre from https://github.com/opf/rails-angular-xss (at a45267d@a45267d)

Using rails_autolink 1.1.6

Using openproject-openid_connect 6.1.4 from source at `vendored-plugins/openproject-openid_connect`

Using openproject-backlogs 6.1.4 from source at `vendored-plugins/openproject-backlogs`

Using openproject-github_integration 6.1.4 from source at `vendored-plugins/openproject-github_integration`

Using openproject-reporting 6.1.4 from source at `vendored-plugins/openproject-reporting`

Bundle complete! 138 Gemfile dependencies, 195 gems now installed.

Gems in the groups development and test were not installed.

Bundled gems are installed into ./vendor/bundle.

Bundle completed (21.80s)

Cleaning up the bundler cache.

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Removing thor (0.19.4)

Removing builder (3.2.3)

Removing arel (7.1.4)

Removing concurrent-ruby (1.0.4)

Removing activerecord (5.0.1)

Removing sprockets (3.7.1)

Removing rails-dom-testing (2.0.2)

Removing actioncable (5.0.1)

Removing rails (5.0.1)

Removing actionview (5.0.1)

Removing activesupport (5.0.1)

Removing rake (12.0.0)

Removing activejob (5.0.1)

Removing railties (5.0.1)

Removing rack-oauth2 (1.5.1)

Removing minitest (5.10.1)

Removing httpclient (2.8.3)

Removing activemodel (5.0.1)

Removing actionmailer (5.0.1)

Removing json-jwt (1.7.1)

Removing openproject-token (1.0.0)

Removing nokogiri (1.6.8.1)

Removing actionpack (5.0.1)

-----> Detecting rake tasks

-----> Preparing app for Rails asset pipeline

Running: rake assets:precompile

$(npm bin)/webpack --config webpack.production.config.js

{"omniauth-openid-connect":"/tmp/d20170122-17-sryd45/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid-connect-c3bce4c9e9ac","omniauth-openid_connect-providers":"/tmp/d20170122-17-sryd45/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid_connect-providers-86f3670e127e","omniauth-saml":"/tmp/d20170122-17-sryd45/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-saml-5559d6b80805","openproject-auth_plugins":"/tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-auth_plugins","openproject-auth_saml":"/tmp/d20170122-17-sryd45/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-auth_saml-97212abb8378","openproject-pdf_export":"/tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-pdf_export","openproject-backlogs":"/tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-backlogs","openproject-costs":"/tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-costs","openproject-documents":"/tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-documents","openproject-webhooks":"/tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-webhooks","openproject-github_integration":"/tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-github_integration","openproject-global_roles":"/tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-global_roles","openproject-local_avatars":"/tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-local_avatars","openproject-meeting":"/tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-meeting","openproject-my_project_page":"/tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-my_project_page","openproject-openid_connect":"/tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-openid_connect","reporting_engine":"/tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/reporting_engine","openproject-reporting":"/tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-reporting","openproject-themes-dark":"/tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-themes-dark","openproject-translations":"/tmp/d20170122-17-sryd45/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-translations-da52ff92cdcd","openproject-xls_export":"/tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-xls_export"}

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Hash: 0e0be060324e501d7fb2

Version: webpack 1.13.3

Child

Hash: 0e0be060324e501d7fb2

Version: webpack 1.13.3

Time: 14673ms

Asset Size Chunks Chunk Names

7b9776076d5fceef4993b55c9383dedd.gif 1.85 kB [emitted]

openproject-backlogs.js 453 kB 0 [emitted] backlogs

openproject-core-app.js 3.43 MB 1 [emitted] core-app

openproject-costs.js 526 kB 2 [emitted] costs

openproject-global.js 3.51 MB 3 [emitted] global

openproject-my_project_page.js 14.3 kB 4 [emitted] my_project_page

openproject-core-app.css 4.71 kB 1 [emitted] core-app

openproject-global.css 49 kB 3 [emitted] global

[213] ./templates \.html$ 1.22 kB {1} [built]

[242] ./components ^((?!\.(test|spec)).)*\.(js|ts|html)$ 16.1 kB {1} [built]

[633] /tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 425 bytes {2} [built]

[765] /tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 330 bytes {4} [built]

+ 769 hidden modules

ERROR in [default]

File '/tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-budget-subform.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-sryd45/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-sryd45/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/subform/cost-subform.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-sryd45/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts' is not under 'rootDir' '/tmp/d20170122-17-sryd45/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts' is not under 'rootDir' '/tmp/d20170122-17-sryd45/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-block.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-sryd45/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-page-layout.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-sryd45/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-textile-block.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-sryd45/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default] /tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:49:18

Argument of type 'string' is not assignable to parameter of type '{ [key: string]: any; }'.

ERROR in [default] /tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:53:4

Supplied parameters do not match any signature of call target.

ERROR in [default] /tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:30:38

Cannot find module 'app/components/work-packages/work-package-cache.service'.

ERROR in [default] /tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:49:30

Cannot find name 'HalResource'.

ERROR in [default] /tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:54:57

Property '$injector' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:13

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:27

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:60:11

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:70:23

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:76:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:77:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:78:16

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:36:17

Property 'value' does not exist on type 'CurrencyDisplayField'.

ERROR in [default] /tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:37:23

Property 'value' does not exist on type 'CurrencyDisplayField'.

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 5 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

autoprefixer: /tmp/d20170122-17-sryd45/opt/openproject/app/assets/stylesheets/default.css.sass:6426:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-sryd45/opt/openproject/app/assets/stylesheets/default.css.sass:6456:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-sryd45/opt/openproject/app/assets/stylesheets/default.css.sass:11729:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-sryd45/opt/openproject/app/assets/stylesheets/default.css.sass:12110:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-sryd45/opt/openproject/app/assets/stylesheets/default.css.sass:12155:3: You should write display: flex by final spec instead of display: box

I, [2017-01-22T22:03:46.145078 #2531] INFO -- : Writing /tmp/d20170122-17-sryd45/opt/openproject/public/assets/default-b00e18110df905a5bf6f92466cbe06ed3965967d2d5e90d24ce836de132adb64.css

I, [2017-01-22T22:03:46.145503 #2531] INFO -- : Writing /tmp/d20170122-17-sryd45/opt/openproject/public/assets/default-b00e18110df905a5bf6f92466cbe06ed3965967d2d5e90d24ce836de132adb64.css.gz

I, [2017-01-22T22:03:48.208650 #2531] INFO -- : Writing /tmp/d20170122-17-sryd45/opt/openproject/public/assets/application-1711fde1b8d3b090b0bf026afb7a9e67b81a069cfa42694957afd5d2e8603702.js

I, [2017-01-22T22:03:48.209122 #2531] INFO -- : Writing /tmp/d20170122-17-sryd45/opt/openproject/public/assets/application-1711fde1b8d3b090b0bf026afb7a9e67b81a069cfa42694957afd5d2e8603702.js.gz

I, [2017-01-22T22:03:48.422583 #2531] INFO -- : Writing /tmp/d20170122-17-sryd45/opt/openproject/public/assets/locales/fa-ddde1dd90c7cd953dfe06fe7a99c8374773412c294f93ffe9efa3414e6b62c2a.js

I, [2017-01-22T22:03:48.422768 #2531] INFO -- : Writing /tmp/d20170122-17-sryd45/opt/openproject/public/assets/locales/fa-ddde1dd90c7cd953dfe06fe7a99c8374773412c294f93ffe9efa3414e6b62c2a.js.gz

I, [2017-01-22T22:03:48.437349 #2531] INFO -- : Writing /tmp/d20170122-17-sryd45/opt/openproject/public/assets/locales/id-a2a805a38128ac7a7ac9f665acb2885e446ba208b069cf9378b8ec1aec800649.js

I, [2017-01-22T22:03:48.437589 #2531] INFO -- : Writing /tmp/d20170122-17-sryd45/opt/openproject/public/assets/locales/id-a2a805a38128ac7a7ac9f665acb2885e446ba208b069cf9378b8ec1aec800649.js.gz

I, [2017-01-22T22:03:48.446320 #2531] INFO -- : Writing /tmp/d20170122-17-sryd45/opt/openproject/public/assets/locales/it-2da9fe25a38c3b5ecc1ad49f013f4f2780e7cc8c7760e14b5e0cf9133a3ca888.js

I, [2017-01-22T22:03:48.446487 #2531] INFO -- : Writing /tmp/d20170122-17-sryd45/opt/openproject/public/assets/locales/it-2da9fe25a38c3b5ecc1ad49f013f4f2780e7cc8c7760e14b5e0cf9133a3ca888.js.gz

I, [2017-01-22T22:03:48.455791 #2531] INFO -- : Writing /tmp/d20170122-17-sryd45/opt/openproject/public/assets/locales/ja-f8632d5fff009c766a77c499986ac2ab325405dc4f1bf26622ae18f9ce8792a8.js

I, [2017-01-22T22:03:48.455960 #2531] INFO -- : Writing /tmp/d20170122-17-sryd45/opt/openproject/public/assets/locales/ja-f8632d5fff009c766a77c499986ac2ab325405dc4f1bf26622ae18f9ce8792a8.js.gz

I, [2017-01-22T22:03:48.472823 #2531] INFO -- : Writing /tmp/d20170122-17-sryd45/opt/openproject/public/assets/locales/nl-e7e1a58e4a0fe3814cc911c20cd36192bb5110c5ac32a7e583e9d4d177bd693e.js

I, [2017-01-22T22:03:48.473011 #2531] INFO -- : Writing /tmp/d20170122-17-sryd45/opt/openproject/public/assets/locales/nl-e7e1a58e4a0fe3814cc911c20cd36192bb5110c5ac32a7e583e9d4d177bd693e.js.gz

autoprefixer: /tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:6446:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:6476:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:11749:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:12130:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-sryd45/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:12175:3: You should write display: flex by final spec instead of display: box

I, [2017-01-22T22:04:02.010144 #2531] INFO -- : Writing /tmp/d20170122-17-sryd45/opt/openproject/public/assets/dark-feeac1abf7e73be6eb6d80d8a8f8e5b9bf79b47ce3eba05b133e96395d495c5a.css

I, [2017-01-22T22:04:02.010445 #2531] INFO -- : Writing /tmp/d20170122-17-sryd45/opt/openproject/public/assets/dark-feeac1abf7e73be6eb6d80d8a8f8e5b9bf79b47ce3eba05b133e96395d495c5a.css.gz

Asset precompilation completed (58.73s)

Cleaning assets

Running: rake assets:clean

I, [2017-01-22T22:04:10.538402 #2763] INFO -- : Removed locales/fa-0dbf392eccd6c0bdd63cfadefebb8a9b2ae0ffc90b91c905764f3b009aecb046.js

I, [2017-01-22T22:04:10.718994 #2763] INFO -- : Removed locales/id-a7c8c482240a4e457ff26930c4a800331ec9a565832f4a26b05aa189e690b876.js

I, [2017-01-22T22:04:10.725347 #2763] INFO -- : Removed locales/it-7e1d737729288534422df10d26c1b9357bd99ef564864ac74c1080c53037c9a5.js

I, [2017-01-22T22:04:10.731445 #2763] INFO -- : Removed locales/ja-90d4866d75e8e5c66cb904ef183adae9eb1ec8ea412d548a25b9f8b367258fdf.js

I, [2017-01-22T22:04:10.740404 #2763] INFO -- : Removed default-270b9c30b239e0622b55c68a93351ad8b56bde4af52e9dc6dee3ed4d7e1124b5.css

I, [2017-01-22T22:04:10.745510 #2763] INFO -- : Removed locales/nl-3f2643487cd26bc712d2d53bade04dcfbf8de02db124d1453990847eac991965.js

I, [2017-01-22T22:04:10.751022 #2763] INFO -- : Removed dark-681a673a66ecee6ff638adb9b42edc00086247fb6aa9dc57b93483f16f574571.css

I, [2017-01-22T22:04:10.756511 #2763] INFO -- : Removed application-c474ed977091f10c89e0a93512558efe4c151d14a804aff49127caa858396163.js

Using release configuration from last framework (Ruby).

-----> [cron] /opt/openproject/packaging/cron/openproject-clear-old-sessions => /etc/cron.d/openproject-clear-old-sessions

NEW PACKAGE: openproject-6.1.4-1485121203.2cb8b63.centos7.x86_64.rpm (294.27 MiB)

-----> Releasing...

DONE!

====== Attempt #1

-----> Fetching repository

Cloning into '/tmp/d20170122-16665-j2hlrz/input'...

-----> Restoring cache

-----> Starting packaging process

-----> Installing missing build dependencies: libmagickwand-dev, libsqlite3-dev

-----> [wizard] adding legacy-installer wizard (https://github.com/pkgr/addon-legacy-installer#master)

-----> [wizard] adding mysql wizard (https://github.com/pkgr/addon-mysql#master)

-----> [wizard] adding apache2 wizard (https://github.com/pkgr/addon-apache2#master)

-----> [wizard] adding repositories wizard (https://github.com/finnlabs/addon-repositories#master)

-----> [wizard] adding smtp wizard (https://github.com/pkgr/addon-smtp#master)

-----> [wizard] adding memcached wizard (https://github.com/pkgr/addon-memcached#master)

-----> [wizard] adding openproject wizard (https://github.com/pkgr/addon-openproject#master)

/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)

-----> Fetching buildpack https://github.com/opf/heroku-buildpack-multi.git at master

-----> Multipack app

-----> Running hook: "packaging/setup"

WARNING: This buildpack is no longer maintained.

Please choose a different buildpack or go to https://github.com/ddollar/heroku-buildpack-multi

and fork it to your own account.

=====> Downloading Buildpack: https://github.com/pkgr/pkgr-buildpack-imagemagick.git

=====> Detected Framework: ImageMagick

-----> SKIP

=====> Downloading Buildpack: https://github.com/heroku/heroku-buildpack-nodejs.git

=====> Detected Framework: Node.js

-----> Reading application state

package.json...

build directory...

cache directory...

environment variables...

Node engine: 6.9.1

Npm engine: 4.0.0

Start mechanism: Procfile

node_modules source: package.json

node_modules cached: true

NPM_CONFIG_PRODUCTION=true

NODE_MODULES_CACHE=true

-----> Installing binaries

Downloading and installing node 6.9.1...

Downloading and installing npm 4.0.0 (replacing version 3.10.8)...

-----> Building dependencies

Restoring node modules from cache

Pruning unused dependencies

Installing any new modules

> openproject@0.1.0 postinstall /tmp/d20170122-17-n79hap/opt/openproject

> cd frontend && npm install

> openproject-frontend@0.1.0 postinstall /tmp/d20170122-17-n79hap/opt/openproject/frontend

> bower install --config.interactive=false

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 not-cached git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolve git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de not-cached git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolve git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 not-cached git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolve git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 checkout d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower jquery#1.11.0 not-cached https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery#1.11.0 resolve https://github.com/jquery/jquery-dist.git#1.11.0

bower select2#3.5.2 not-cached https://github.com/ivaynberg/select2.git#3.5.2

bower select2#3.5.2 resolve https://github.com/ivaynberg/select2.git#3.5.2

bower jquery-ujs#1.0.0 not-cached https://github.com/rails/jquery-ujs.git#1.0.0

bower jquery-ujs#1.0.0 resolve https://github.com/rails/jquery-ujs.git#1.0.0

bower jquery.atwho#0.5.1 not-cached https://github.com/ichord/At.js.git#0.5.1

bower jquery.atwho#0.5.1 resolve https://github.com/ichord/At.js.git#0.5.1

bower angular-animate#~1.5.8 not-cached https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-animate#~1.5.8 resolve https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular#~1.5.8 not-cached https://github.com/angular/bower-angular.git#~1.5.8

bower angular#~1.5.8 resolve https://github.com/angular/bower-angular.git#~1.5.8

bower angular-aria#~1.5.8 not-cached https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-aria#~1.5.8 resolve https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-ui-router#~0.3.1 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-ui-router#~0.3.1 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-i18n#~1.5.5 not-cached https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-i18n#~1.5.5 resolve https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-cache#~4.6.0 not-cached https://github.com/jmdobry/angular-cache.git#~4.6.0

bower angular-cache#~4.6.0 resolve https://github.com/jmdobry/angular-cache.git#~4.6.0

bower angular-sanitize#~1.5.8 not-cached https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-sanitize#~1.5.8 resolve https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower moment#~2.10.6 not-cached https://github.com/moment/moment.git#~2.10.6

bower moment#~2.10.6 resolve https://github.com/moment/moment.git#~2.10.6

bower jquery-migrate#~1.2.1 not-cached https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower jquery-migrate#~1.2.1 resolve https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower angular-elastic#~2.5.1 not-cached https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-elastic#~2.5.1 resolve https://github.com/monospaced/angular-elastic.git#~2.5.1

bower moment-timezone#0.4.x not-cached https://github.com/moment/moment-timezone.git#0.4.x

bower moment-timezone#0.4.x resolve https://github.com/moment/moment-timezone.git#0.4.x

bower angular-busy#~4.1.3 not-cached https://github.com/cgross/angular-busy.git#~4.1.3

bower angular-busy#~4.1.3 resolve https://github.com/cgross/angular-busy.git#~4.1.3

bower lodash#~2.4.1 not-cached https://github.com/lodash/lodash.git#~2.4.1

bower lodash#~2.4.1 resolve https://github.com/lodash/lodash.git#~2.4.1

bower foundation-apps#1.1.0 not-cached https://github.com/zurb/foundation-apps.git#1.1.0

bower foundation-apps#1.1.0 resolve https://github.com/zurb/foundation-apps.git#1.1.0

bower bourbon#~4.2.1 not-cached https://github.com/thoughtbot/bourbon.git#~4.2.1

bower bourbon#~4.2.1 resolve https://github.com/thoughtbot/bourbon.git#~4.2.1

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de checkout fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 checkout a908eccaec323cd66973d58af4965694bdff16a1

bower angular-ui-select#~0.19.4 not-cached https://github.com/angular-ui/ui-select.git#~0.19.4

bower angular-ui-select#~0.19.4 resolve https://github.com/angular-ui/ui-select.git#~0.19.4

bower mousetrap#~1.4.6 not-cached https://github.com/ccampbell/mousetrap.git#~1.4.6

bower mousetrap#~1.4.6 resolve https://github.com/ccampbell/mousetrap.git#~1.4.6

bower ng-file-upload#~5.0.9 not-cached https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower ng-file-upload#~5.0.9 resolve https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower rxjs#^4.1.0 not-cached https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower rxjs#^4.1.0 resolve https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower ng-dialog#^0.6.2 not-cached https://github.com/likeastore/ngDialog.git#^0.6.2

bower ng-dialog#^0.6.2 resolve https://github.com/likeastore/ngDialog.git#^0.6.2

bower mocha#~1.14.0 not-cached https://github.com/mochajs/mocha.git#~1.14.0

bower mocha#~1.14.0 resolve https://github.com/mochajs/mocha.git#~1.14.0

bower angular-mocks#~1.5.8 not-cached https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower angular-mocks#~1.5.8 resolve https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower chai#~1.9.0 not-cached https://github.com/chaijs/chai.git#~1.9.0

bower chai#~1.9.0 resolve https://github.com/chaijs/chai.git#~1.9.0

bower jquery-mockjax#~1.5.3 not-cached https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery-mockjax#~1.5.3 resolve https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery#1.11.0 checkout 1.11.0

bower select2#3.5.2 checkout 3.5.2

bower jquery-ujs#1.0.0 checkout v1.0.0

bower jquery.atwho#0.5.1 checkout v0.5.1

bower angular-animate#~1.5.8 checkout v1.5.11

bower angular-ui-router#~0.3.1 checkout 0.3.2

bower angular-aria#~1.5.8 checkout v1.5.11

bower angular-cache#~4.6.0 checkout 4.6.0

bower angular-i18n#~1.5.5 checkout v1.5.11

bower angular#~1.5.8 checkout v1.5.11

bower moment-timezone#0.4.x checkout 0.4.1

bower angular-elastic#~2.5.1 checkout v2.5.1

bower jquery-migrate#~1.2.1 checkout 1.2.1

bower moment#~2.10.6 checkout 2.10.6

bower angular-sanitize#~1.5.8 checkout v1.5.11

bower angular-ui-select#~0.19.4 checkout v0.19.6

bower bourbon#~4.2.1 checkout v4.2.7

bower foundation-apps#1.1.0 checkout v1.1.0

bower lodash#~2.4.1 checkout 2.4.2

bower angular-busy#~4.1.3 checkout v4.1.4

bower mousetrap#~1.4.6 checkout 1.4.6

bower ng-file-upload#~5.0.9 checkout 5.0.9

bower ng-dialog#^0.6.2 checkout v0.6.6

bower rxjs#^4.1.0 checkout v4.1.0

bower jquery-ui#~1.10.4 not-cached https://github.com/components/jqueryui.git#~1.10.4

bower jquery-ui#~1.10.4 resolve https://github.com/components/jqueryui.git#~1.10.4

bower mocha#~1.14.0 checkout 1.14.0

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolved git://github.com/nickmessing/angular-context-menu.git#a908eccaec

bower angular#>= 1.2.5 not-cached https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 resolve https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolved git://github.com/finnlabs/angular-modal.git#d45eb9ceb7

bower angular#^1.3.0 not-cached https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 resolve https://github.com/angular/bower-angular.git#^1.3.0

bower angular#>= 1.2.5 checkout v1.6.1

bower jquery-mockjax#~1.5.3 checkout v1.5.4

bower chai#~1.9.0 checkout 1.9.2

bower angular-mocks#~1.5.8 checkout v1.5.11

bower angular#^1.3.0 checkout v1.6.1

bower angular-dragula#^1.2.8 not-cached https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower angular-dragula#^1.2.8 resolve https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower jquery.atwho#0.5.1 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .png files: ["select2.png","select2x2.png"]

bower select2#3.5.2 resolved https://github.com/ivaynberg/select2.git#3.5.2

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolved git://github.com/sparkalow/angular-truncate.git#fdf60fda26

bower jquery-ujs#1.0.0 resolved https://github.com/rails/jquery-ujs.git#1.0.0

bower jquery.atwho#0.5.1 resolved https://github.com/ichord/At.js.git#0.5.1

bower angular-animate#~1.5.8 resolved https://github.com/angular/bower-angular-animate.git#1.5.11

bower Caret.js#>= 0.2.0 not-cached https://github.com/ichord/Caret.js.git#>= 0.2.0

bower Caret.js#>= 0.2.0 resolve https://github.com/ichord/Caret.js.git#>= 0.2.0

bower angular-aria#~1.5.8 resolved https://github.com/angular/bower-angular-aria.git#1.5.11

bower angular-cache#~4.6.0 resolved https://github.com/jmdobry/angular-cache.git#4.6.0

bower angular#>=1.x not-cached https://github.com/angular/bower-angular.git#>=1.x

bower angular#>=1.x resolve https://github.com/angular/bower-angular.git#>=1.x

bower angular#>=1.x checkout v1.6.1

bower angular-ui-router#~0.3.1 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.3.2

bower jquery#1.11.0 resolved https://github.com/jquery/jquery-dist.git#1.11.0

bower angular-elastic#~2.5.1 resolved https://github.com/monospaced/angular-elastic.git#2.5.1

bower angular#>=1.0.6 not-cached https://github.com/angular/bower-angular.git#>=1.0.6

bower angular#>=1.0.6 resolve https://github.com/angular/bower-angular.git#>=1.0.6

bower angular#>=1.0.6 checkout v1.6.1

bower jquery-migrate#~1.2.1 deprecated Package jquery-migrate is using the deprecated component.json

bower jquery-migrate#~1.2.1 resolved https://github.com/appleboy/jquery-migrate.git#1.2.1

bower angular-ui-select#~0.19.4 resolved https://github.com/angular-ui/ui-select.git#0.19.6

bower angular#>=1.2.18 not-cached https://github.com/angular/bower-angular.git#>=1.2.18

bower angular#>=1.2.18 resolve https://github.com/angular/bower-angular.git#>=1.2.18

bower angular#>=1.2.18 checkout v1.6.1

bower angular-sanitize#~1.5.8 resolved https://github.com/angular/bower-angular-sanitize.git#1.5.11

bower moment-timezone#0.4.x resolved https://github.com/moment/moment-timezone.git#0.4.1

bower moment#>= 2.6.0 not-cached https://github.com/moment/moment.git#>= 2.6.0

bower moment#>= 2.6.0 resolve https://github.com/moment/moment.git#>= 2.6.0

bower moment#>= 2.6.0 checkout 2.17.1

bower angular-i18n#~1.5.5 resolved https://github.com/angular/bower-angular-i18n.git#1.5.11

bower bourbon#~4.2.1 resolved https://github.com/thoughtbot/bourbon.git#4.2.7

bower foundation-apps#1.1.0 resolved https://github.com/zurb/foundation-apps.git#1.1.0

bower angular#~1.3.4 not-cached https://github.com/angular/bower-angular.git#~1.3.4

bower angular#~1.3.4 resolve https://github.com/angular/bower-angular.git#~1.3.4

bower angular-ui-router#~0.2.12 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-ui-router#~0.2.12 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-animate#~1.3.4 not-cached https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular-animate#~1.3.4 resolve https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular#~1.3.4 checkout v1.3.20

bower angular-ui-router#~0.2.12 checkout 0.2.18

bower angular-animate#~1.3.4 checkout v1.3.20

bower mousetrap#~1.4.6 resolved https://github.com/ccampbell/mousetrap.git#1.4.6

bower angular-busy#~4.1.3 resolved https://github.com/cgross/angular-busy.git#4.1.4

bower angular#>=1.3 not-cached https://github.com/angular/bower-angular.git#>=1.3

bower angular#>=1.3 resolve https://github.com/angular/bower-angular.git#>=1.3

bower angular#>=1.3 checkout v1.6.1

bower hammerjs#~2.0.4 not-cached https://github.com/EightMedia/hammer.js.git#~2.0.4

bower hammerjs#~2.0.4 resolve https://github.com/EightMedia/hammer.js.git#~2.0.4

bower fastclick#~1.0.3 not-cached https://github.com/ftlabs/fastclick.git#~1.0.3

bower fastclick#~1.0.3 resolve https://github.com/ftlabs/fastclick.git#~1.0.3

bower viewport-units-buggyfill#~0.4.1 not-cached https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower viewport-units-buggyfill#~0.4.1 resolve https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower tether#~0.6.5 not-cached https://github.com/HubSpot/tether.git#~0.6.5

bower tether#~0.6.5 resolve https://github.com/HubSpot/tether.git#~0.6.5

bower moment#~2.10.6 resolved https://github.com/moment/moment.git#2.10.6

bower angular#~1.5.8 progress Receiving objects: 83% (3036/3657), 15.25 MiB | 5.05 MiB/s

bower ng-dialog#^0.6.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .css files: ["css/ngDialog.css","css/ngDialog-theme-default.css"]

bower ng-dialog#^0.6.2 resolved https://github.com/likeastore/ngDialog.git#0.6.6

bower angular#>=1.5 not-cached https://github.com/angular/bower-angular.git#>=1.5

bower angular#>=1.5 resolve https://github.com/angular/bower-angular.git#>=1.5

bower angular#>=1.5 checkout v1.6.1

bower jquery-ui#~1.10.4 checkout 1.10.4

bower ng-file-upload#~5.0.9 resolved https://github.com/danialfarid/angular-file-upload-bower.git#5.0.9

bower lodash#~2.4.1 progress Resolving deltas: 9% (1806/20031)

bower angular#~1.5.8 progress Receiving objects: 85% (3109/3657), 18.68 MiB | 4.63 MiB/s

bower rxjs#^4.1.0 progress Receiving objects: 19% (432/2270), 900.00 KiB | 1.71 MiB/s

bower mocha#~1.14.0 progress Resolving deltas: 52% (745/1417)

bower mocha#~1.14.0 mismatch Version declared in the json (1.12.0) is different than the resolved one (1.14.0)

bower mocha#~1.14.0 resolved https://github.com/mochajs/mocha.git#1.14.0

bower angular#>= 1.2.5 progress Receiving objects: 89% (372/417)

bower lodash#~2.4.1 progress Resolving deltas: 100% (20031/20031), done.

bower angular#~1.5.8 progress Receiving objects: 89% (3255/3657), 22.77 MiB | 3.91 MiB/s

bower jquery-mockjax#~1.5.3 resolved https://github.com/jakerella/jquery-mockjax.git#1.5.4

bower angular#>= 1.2.5 resolved https://github.com/angular/bower-angular.git#1.6.1

bower lodash#~2.4.1 resolved https://github.com/lodash/lodash.git#2.4.2

bower rxjs#^4.1.0 progress Receiving objects: 75% (1703/2270), 3.25 MiB | 2.15 MiB/s

bower chai#~1.9.0 resolved https://github.com/chaijs/chai.git#1.9.2

bower angular#^1.3.0 progress remote: Compressing objects: 39% (78/198)

bower angular#~1.5.8 progress Receiving objects: 92% (3365/3657), 27.01 MiB | 3.80 MiB/s

bower angular-dragula#^1.2.8 checkout v1.2.8

bower Caret.js#>= 0.2.0 checkout v0.3.1

bower rxjs#^4.1.0 resolved https://github.com/Reactive-Extensions/RxJS.git#4.1.0

bower angular-mocks#~1.5.8 resolved https://github.com/angular/bower-angular-mocks.git#1.5.11

bower angular#^1.3.0 resolved https://github.com/angular/bower-angular.git#1.6.1

bower angular#~1.5.8 progress Receiving objects: 99% (3621/3657), 31.51 MiB | 4.03 MiB/s

bower angular#>=1.x progress Receiving objects: 28% (117/417)

bower angular#>=1.0.6 progress Resolving deltas: 54% (132/244)

bower angular#>=1.0.6 resolved https://github.com/angular/bower-angular.git#1.6.1

bower angular#>=1.x resolved https://github.com/angular/bower-angular.git#1.6.1

bower angular#~1.5.8 progress Resolving deltas: 46% (1078/2299)

bower angular#>=1.2.18 resolved https://github.com/angular/bower-angular.git#1.6.1

bower moment#>= 2.6.0 resolved https://github.com/moment/moment.git#2.17.1

bower angular-ui-router#~0.2.12 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.2.18

bower angular#~1.5.8 progress Resolving deltas: 100% (2299/2299), done.

bower hammerjs#~2.0.4 checkout v2.0.8

bower angular#~1.5.8 resolved https://github.com/angular/bower-angular.git#1.5.11

bower fastclick#~1.0.3 checkout v1.0.6

bower viewport-units-buggyfill#~0.4.1 checkout v0.4.1

bower tether#~0.6.5 checkout v0.6.5

bower angular#~1.3.4 progress Receiving objects: 11% (1268/11521)

bower angular#~1.3.4 progress Receiving objects: 12% (1383/11521)

bower angular#~1.3.4 progress Receiving objects: 13% (1498/11521)

bower angular-animate#~1.3.4 resolved https://github.com/angular/bower-angular-animate.git#1.3.20

bower angular#>=1.3 resolved https://github.com/angular/bower-angular.git#1.6.1

bower Caret.js#>= 0.2.0 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower Caret.js#>= 0.2.0 resolved https://github.com/ichord/Caret.js.git#0.3.1

bower angular-dragula#^1.2.8 resolved https://github.com/bevacqua/angular-dragula.git#1.2.8

bower jquery-ui#~1.10.4 resolved https://github.com/components/jqueryui.git#1.10.4

bower angular#~1.3.4 progress Receiving objects: 42% (4881/11521), 7.64 MiB | 15.19 MiB/s

bower fastclick#~1.0.3 resolved https://github.com/ftlabs/fastclick.git#1.0.6

bower hammerjs#~2.0.4 resolved https://github.com/EightMedia/hammer.js.git#2.0.8

bower angular#>=1.5 resolved https://github.com/angular/bower-angular.git#1.6.1

bower viewport-units-buggyfill#~0.4.1 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .js files: ["./viewport-units-buggyfill.js","./viewport-units-buggyfill.hacks.js"]

bower viewport-units-buggyfill#~0.4.1 resolved https://github.com/rodneyrehm/viewport-units-buggyfill.git#0.4.1

bower tether#~0.6.5 resolved https://github.com/HubSpot/tether.git#0.6.5

bower angular#~1.3.4 progress Receiving objects: 52% (5991/11521), 22.11 MiB | 11.01 MiB/s

bower angular#~1.3.4 progress Receiving objects: 59% (6838/11521), 26.94 MiB | 10.74 MiB/s

bower angular#~1.3.4 progress Receiving objects: 64% (7402/11521), 36.69 MiB | 10.45 MiB/s

bower angular#~1.3.4 progress Receiving objects: 67% (7720/11521), 47.77 MiB | 8.89 MiB/s

bower angular#~1.3.4 progress Receiving objects: 76% (8756/11521), 54.04 MiB | 8.10 MiB/s

bower angular#~1.3.4 progress Receiving objects: 86% (9933/11521), 57.41 MiB | 7.81 MiB/s

bower angular#~1.3.4 progress Receiving objects: 88% (10209/11521), 64.77 MiB | 7.30 MiB/s

bower angular#~1.3.4 progress Receiving objects: 90% (10481/11521), 72.89 MiB | 6.90 MiB/s

bower angular#~1.3.4 progress Receiving objects: 93% (10802/11521), 81.76 MiB | 7.51 MiB/s

bower angular#~1.3.4 progress Receiving objects: 98% (11347/11521), 90.92 MiB | 8.17 MiB/s

bower angular#~1.3.4 progress Resolving deltas: 19% (1497/7586)

bower angular#~1.3.4 progress Resolving deltas: 35% (2704/7586)

bower angular#~1.3.4 progress Resolving deltas: 63% (4783/7586)

bower angular#~1.3.4 progress Resolving deltas: 71% (5441/7586)

bower angular#~1.3.4 progress Resolving deltas: 96% (7324/7586)

bower angular#~1.3.4 progress Resolving deltas: 100% (7586/7586)

bower angular#~1.3.4 progress Resolving deltas: 100% (7586/7586), done.

bower angular#~1.3.4 resolved https://github.com/angular/bower-angular.git#1.3.20

Please note that,

foundation-apps#1.1.0 depends on angular-animate#~1.3.4 which resolved to angular-animate#1.3.20

openproject depends on angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

angular-busy#4.1.4 depends on angular-animate#>=1.3 which resolved to angular-animate#1.5.11

Resort to using angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

Code incompatibilities may occur.

Please note that,

foundation-apps#1.1.0 depends on angular-ui-router#~0.2.12 which resolved to angular-ui-router#0.2.18

openproject depends on angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Resort to using angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Code incompatibilities may occur.

Please note that,

angular-animate#1.3.20 depends on angular#1.3.20 which resolved to angular#1.3.20

foundation-apps#1.1.0 depends on angular#~1.3.4 which resolved to angular#1.3.20

angular-animate#1.5.11, angular-aria#1.5.11, angular-mocks#1.5.11, angular-sanitize#1.5.11 depends on angular#1.5.11 which resolved to angular#1.5.11

openproject depends on angular#~1.5.8 which resolved to angular#1.5.11

angular-ui-router#0.3.2, angular-ui-router#0.2.18 depends on angular#^1.0.8 which resolved to angular#1.6.1

angular-modal#d45eb9ceb7 depends on angular#^1.3.0 which resolved to angular#1.6.1

angular-context-menu#a908eccaec depends on angular#>= 1.2.5 which resolved to angular#1.6.1

ng-dialog#0.6.6 depends on angular#>=1.5 which resolved to angular#1.6.1

angular-elastic#2.5.1 depends on angular#>=1.0.6 which resolved to angular#1.6.1

angular-cache#4.6.0 depends on angular#>=1.x which resolved to angular#1.6.1

angular-ui-select#0.19.6 depends on angular#>=1.2.18 which resolved to angular#1.6.1

angular-busy#4.1.4 depends on angular#>=1.3 which resolved to angular#1.6.1

Resort to using angular#~1.5.8 which resolved to angular#1.5.11

Code incompatibilities may occur.

bower jquery extra-resolution Unnecessary resolution: jquery#1.11.0

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 install angular-context-menu#a908eccaec

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 install angular-modal#d45eb9ceb7

bower select2#3.5.2 install select2#3.5.2

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de install angular-truncate#fdf60fda26

bower jquery-ujs#1.0.0 install jquery-ujs#1.0.0

bower jquery.atwho#0.5.1 install jquery.atwho#0.5.1

bower angular-animate#~1.5.8 install angular-animate#1.5.11

bower angular-aria#~1.5.8 install angular-aria#1.5.11

bower angular-cache#~4.6.0 install angular-cache#4.6.0

bower angular-ui-router#~0.3.1 install angular-ui-router#0.3.2

bower jquery#1.11.0 install jquery#1.11.0

bower angular-elastic#~2.5.1 install angular-elastic#2.5.1

bower jquery-migrate#~1.2.1 install jquery-migrate#1.2.1

bower angular-ui-select#~0.19.4 install angular-ui-select#0.19.6

bower angular-sanitize#~1.5.8 install angular-sanitize#1.5.11

bower moment-timezone#0.4.x install moment-timezone#0.4.1

bower angular-i18n#~1.5.5 install angular-i18n#1.5.11

bower bourbon#~4.2.1 install bourbon#4.2.7

bower foundation-apps#1.1.0 install foundation-apps#1.1.0

bower mousetrap#~1.4.6 install mousetrap#1.4.6

bower angular-busy#~4.1.3 install angular-busy#4.1.4

bower moment#~2.10.6 install moment#2.10.6

bower ng-dialog#^0.6.2 install ng-dialog#0.6.6

bower ng-file-upload#~5.0.9 install ng-file-upload#5.0.9

bower mocha#~1.14.0 install mocha#1.14.0

bower jquery-mockjax#~1.5.3 install jquery-mockjax#1.5.4

bower angular#1.5.11 install angular#1.5.11

bower lodash#~2.4.1 install lodash#2.4.2

bower chai#~1.9.0 install chai#1.9.2

bower rxjs#^4.1.0 install rxjs#4.1.0

bower angular-mocks#~1.5.8 install angular-mocks#1.5.11

bower Caret.js#>= 0.2.0 install Caret.js#0.3.1

bower angular-dragula#^1.2.8 install angular-dragula#1.2.8

bower jquery-ui#~1.10.4 install jquery-ui#1.10.4

bower fastclick#~1.0.3 install fastclick#1.0.6

bower hammerjs#~2.0.4 install hammerjs#2.0.8

bower viewport-units-buggyfill#~0.4.1 install viewport-units-buggyfill#0.4.1

bower tether#~0.6.5 install tether#0.6.5

angular-context-menu#a908eccaec bower_components/angular-context-menu

└── angular#1.5.11

angular-modal#d45eb9ceb7 bower_components/angular-modal

└── angular#1.5.11

select2#3.5.2 bower_components/select2

└── jquery#1.11.0

angular-truncate#fdf60fda26 bower_components/angular-truncate

jquery-ujs#1.0.0 bower_components/jquery-ujs

└── jquery#1.11.0

jquery.atwho#0.5.1 bower_components/jquery.atwho

├── Caret.js#0.3.1

└── jquery#1.11.0

angular-animate#1.5.11 bower_components/angular-animate

└── angular#1.5.11

angular-aria#1.5.11 bower_components/angular-aria

└── angular#1.5.11

angular-cache#4.6.0 bower_components/angular-cache

└── angular#1.5.11

angular-ui-router#0.3.2 bower_components/angular-ui-router

└── angular#1.5.11

jquery#1.11.0 bower_components/jquery

angular-elastic#2.5.1 bower_components/angular-elastic

└── angular#1.5.11

jquery-migrate#1.2.1 bower_components/jquery-migrate

angular-ui-select#0.19.6 bower_components/angular-ui-select

└── angular#1.5.11

angular-sanitize#1.5.11 bower_components/angular-sanitize

└── angular#1.5.11

moment-timezone#0.4.1 bower_components/moment-timezone

└── moment#2.10.6

angular-i18n#1.5.11 bower_components/angular-i18n

bourbon#4.2.7 bower_components/bourbon

foundation-apps#1.1.0 bower_components/foundation-apps

├── angular#1.5.11

├── angular-animate#1.5.11

├── angular-ui-router#0.3.2

├── fastclick#1.0.6

├── hammerjs#2.0.8

├── tether#0.6.5

└── viewport-units-buggyfill#0.4.1

mousetrap#1.4.6 bower_components/mousetrap

angular-busy#4.1.4 bower_components/angular-busy

├── angular#1.5.11

└── angular-animate#1.5.11

moment#2.10.6 bower_components/moment

ng-dialog#0.6.6 bower_components/ng-dialog

└── angular#1.5.11

ng-file-upload#5.0.9 bower_components/ng-file-upload

mocha#1.14.0 bower_components/mocha

jquery-mockjax#1.5.4 bower_components/jquery-mockjax

angular#1.5.11 bower_components/angular

lodash#2.4.2 bower_components/lodash

chai#1.9.2 bower_components/chai

rxjs#4.1.0 bower_components/rxjs

angular-mocks#1.5.11 bower_components/angular-mocks

└── angular#1.5.11

Caret.js#0.3.1 bower_components/Caret.js

└── jquery#1.11.0

angular-dragula#1.2.8 bower_components/angular-dragula

jquery-ui#1.10.4 bower_components/jquery-ui

└── jquery#1.11.0

fastclick#1.0.6 bower_components/fastclick

hammerjs#2.0.8 bower_components/hammerjs

viewport-units-buggyfill#0.4.1 bower_components/viewport-units-buggyfill

tether#0.6.5 bower_components/tether

openproject-frontend@0.1.0 /tmp/d20170122-17-n79hap/opt/openproject/frontend

+-- acorn@2.6.4

+-- align-text@0.1.4

+-- alter@0.2.0

+-- amdefine@1.0.0

+-- angular@1.5.8

+-- angular-elastic@2.5.1

+-- angular-ui-bootstrap@2.2.0

+-- anymatch@1.3.0

+-- arr-diff@2.0.0

+-- arr-flatten@1.0.1

+-- array-unique@0.2.1

+-- arrify@1.0.1

+-- assert@1.4.1

+-- async@0.2.10

+-- async-each@1.0.1

+-- atoa@1.0.0

+-- autoprefixer-core@5.2.1

+-- autoprefixer-loader@1.2.0

+-- awesome-typescript-loader@2.2.4

| `-- lodash@4.16.4

+-- balanced-match@0.4.2

+-- Base64@0.2.1

+-- base64-js@1.2.0

+-- big.js@3.1.3

+-- binary-extensions@1.7.0

+-- bower@1.7.9

+-- brace-expansion@1.1.6

+-- braces@1.8.5

+-- browserify-zlib@0.1.4

+-- browserslist@0.4.0

+-- buffer@4.9.1

+-- buffer-shims@1.0.0

+-- camelcase@1.2.1

+-- caniuse-db@1.0.30000569

+-- center-align@0.1.3

+-- chokidar@1.6.1

+-- cliui@2.1.0

| `-- wordwrap@0.0.2

+-- clone@1.0.2

+-- colors@1.1.2

+-- concat-map@0.0.1

+-- console-browserify@1.1.0

+-- constants-browserify@0.0.1

+-- contra@1.9.4

+-- convert-source-map@1.1.3

+-- core-util-is@1.0.2

+-- crossvent@1.5.4

+-- crypto-browserify@3.2.8

+-- css-loader@0.9.1

| `-- source-map@0.1.43

+-- csso@1.3.12

+-- custom-event@1.0.0

+-- d@0.1.1

+-- date-now@0.1.4

+-- decamelize@1.2.0

+-- domain-browser@1.1.7

+-- dragula@3.7.2

+-- emojis-list@2.1.0

+-- enhanced-resolve@2.3.0

+-- errno@0.1.4

+-- es5-ext@0.10.12

+-- es6-iterator@2.0.0

+-- es6-promise@2.3.0

+-- es6-symbol@3.1.0

+-- es6-weak-map@0.1.4

| +-- es6-iterator@0.1.3

| `-- es6-symbol@2.0.1

+-- event-emitter@0.3.4

+-- events@1.1.1

+-- expand-brackets@0.1.5

+-- expand-range@1.8.2

+-- exports-loader@0.6.3

| `-- source-map@0.1.43

+-- expose-loader@0.6.0

+-- extglob@0.3.2

+-- extract-text-webpack-plugin@0.3.8

| `-- source-map@0.1.43

+-- fastparse@1.1.1

+-- file-loader@0.8.5

+-- filename-regex@2.0.0

+-- fill-range@2.2.3

+-- for-in@0.1.6

+-- for-own@0.1.4

+-- glob@4.5.3

+-- glob-base@0.3.0

+-- glob-parent@2.0.0

+-- graceful-fs@4.1.9

+-- has-flag@1.0.0

+-- html-loader@0.2.3

| `-- source-map@0.1.43

+-- html-minifier@0.5.6

+-- http-browserify@1.7.0

+-- https-browserify@0.0.0

+-- ieee754@1.1.8

+-- indexof@0.0.1

+-- inflight@1.0.6

+-- inherits@2.0.3

+-- interpret@0.6.6

+-- is-binary-path@1.0.1

+-- is-buffer@1.1.4

+-- is-dotfile@1.0.2

+-- is-equal-shallow@0.1.3

+-- is-extendable@0.1.1

+-- is-extglob@1.0.0

+-- is-glob@2.0.1

+-- is-number@2.1.0

+-- is-posix-bracket@0.1.1

+-- is-primitive@2.0.0

+-- isarray@1.0.0

+-- isobject@2.1.0

+-- js-base64@2.1.9

+-- json5@0.4.0

+-- kind-of@3.0.4

+-- lazy-cache@1.0.4

+-- loader-utils@0.2.16

| `-- json5@0.5.0

+-- lodash@2.4.2

+-- longest@1.0.1

+-- lru-queue@0.1.0

+-- memoizee@0.3.10

+-- memory-fs@0.3.0

+-- micromatch@2.3.11

+-- mime@1.2.11

+-- minimatch@2.0.10

+-- minimist@0.0.10

+-- mkdirp@0.5.1

| `-- minimist@0.0.8

+-- nan@2.4.0

+-- next-tick@0.2.2

+-- ng-annotate@1.2.1

| `-- source-map@0.5.6

+-- ng-annotate-loader@0.0.10

| `-- source-map@0.4.2

+-- ngtemplate-loader@0.1.3

+-- node-libs-browser@0.6.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- normalize-path@2.0.1

+-- num2fraction@1.2.2

+-- object-assign@4.1.0

+-- object.omit@2.0.1

+-- observable-array@0.0.4

+-- observable-value@0.0.5

+-- once@1.4.0

+-- optimist@0.6.1

+-- ordered-ast-traverse@1.1.1

+-- ordered-esprima-props@1.1.0

+-- os-browserify@0.1.2

+-- pako@0.2.9

+-- parse-glob@3.0.4

+-- path-browserify@0.0.0

+-- path-is-absolute@1.0.1

+-- pbkdf2-compat@2.0.1

+-- phantomjs-polyfill@0.0.2

+-- postcss@4.1.16

+-- preserve@0.2.0

+-- process@0.11.9

+-- process-nextick-args@1.0.7

+-- prr@0.0.0

+-- punycode@1.4.1

+-- querystring@0.2.0

+-- querystring-es3@0.2.1

+-- randomatic@1.1.5

+-- readable-stream@2.1.5

+-- readdirp@2.1.0

| `-- minimatch@3.0.3

+-- regex-cache@0.4.3

+-- repeat-element@1.1.2

+-- repeat-string@1.6.1

+-- right-align@0.1.3

+-- ripemd160@0.2.0

+-- set-immediate-shim@1.0.1

+-- sha.js@2.2.6

+-- shelljs@0.3.0

+-- simple-fmt@0.1.0

+-- simple-is@0.2.0

+-- source-list-map@0.1.6

+-- source-map@0.4.4

+-- source-map-support@0.4.5

| `-- source-map@0.5.6

+-- stable@0.1.5

+-- stream-browserify@1.0.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- string_decoder@0.10.31

+-- stringmap@0.2.2

+-- stringset@0.2.1

+-- style-loader@0.8.3

+-- supports-color@3.1.2

+-- tapable@0.2.4

+-- ticky@1.0.1

+-- timers-browserify@1.4.2

+-- timers-ext@0.1.0

+-- tryor@0.1.2

+-- tty-browserify@0.0.0

+-- typescript@2.0.6

+-- uglify-js@2.7.4

| `-- source-map@0.5.6

+-- uglify-to-browserify@1.0.2

+-- URIjs@1.16.1

+-- url@0.10.3

| `-- punycode@1.3.2

+-- url-loader@0.5.7

+-- util@0.10.3

| `-- inherits@2.0.1

+-- util-deprecate@1.0.2

+-- vm-browserify@0.0.4

+-- watchpack@0.2.9

| `-- async@0.9.2

+-- webpack@1.13.3

| +-- acorn@3.3.0

| +-- async@1.5.2

| +-- enhanced-resolve@0.9.1

| | `-- memory-fs@0.2.0

| `-- tapable@0.1.10

+-- webpack-core@0.6.8

+-- window-size@0.1.0

+-- wordwrap@0.0.3

+-- wrappy@1.0.2

`-- yargs@3.10.0

npm WARN openproject-frontend@0.1.0 No repository field.

npm WARN openproject-frontend@0.1.0 No license field.

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.0.14 (node_modules/fsevents):

npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.0.14: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

-----> Checking startup method

Found Procfile

-----> Finalizing build

Creating runtime environment

Exporting binary paths

Cleaning npm artifacts

Cleaning previous cache

Caching results for future builds

-----> Build succeeded!

openproject@0.1.0 /tmp/d20170122-17-n79hap/opt/openproject

`-- typescript@2.0.8

=====> Downloading Buildpack: https://github.com/pkgr/heroku-buildpack-ruby.git

=====> Detected Framework: Ruby

-----> Compiling Ruby/Rails

-----> Using Ruby version: ruby-2.3.1

-----> Installing dependencies using bundler 1.13.2

cp: `/tmp/d20170122-17-n79hap/opt/openproject/.git/cache/vendor/bundle/.' and `/tmp/d20170122-17-n79hap/opt/openproject/.git/cache/vendor/bundle/.' are the same file

Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Fetching gem metadata from https://rubygems.org/......

Fetching version metadata from https://rubygems.org/..

Fetching dependency metadata from https://rubygems.org/.

Using i18n 0.7.0

Installing minitest 5.9.0

Installing rake 11.3.0

Using thread_safe 0.3.5

Installing concurrent-ruby 1.0.2

Using erubis 2.7.0

Using mini_portile2 2.1.0

Using rack 2.0.1

Using nio4r 1.2.1

Using websocket-extensions 0.1.2

Using mime-types 2.99.3

Using method_source 0.8.2

Installing builder 3.2.2

Installing pkg-config 1.1.7

Using multi_json 1.12.1

Using acts_as_silent_list 3.0.0

Using addressable 2.4.0

Using airbrake-ruby 1.5.0

Using attr_required 1.0.1

Using execjs 2.7.0

Using ice_nine 0.11.2

Using bcrypt 3.1.11

Using bindata 2.3.4

Using sass 3.4.22

Using tilt 2.0.5

Using uber 0.0.15

Using erbse 0.0.2

Using coderay 1.1.1

Using color-tools 1.3.0

Using unf_ext 0.0.7.2

Using netrc 0.11.0

Using daemons 1.2.4

Using dalli 2.7.6

Using enumerable-lazy 0.0.1

Using equalizer 0.0.11

Using excon 0.52.0

Using ffi 1.9.14

Using formatador 0.2.5

Using ipaddress 0.8.3

Using get_process_mem 0.2.1

Using request_store 1.3.1

Using json 1.8.3

Using hashie 3.4.6

Using multi_xml 0.5.5

Using gravatar_image_tag 1.2.0

Using bundler 1.13.2

Using htmldiff 0.0.1

Installing thor 0.19.1

Installing arel 7.1.2

Using icalendar 2.3.0

Using iso8601 0.9.1

Using securecompare 1.0.0

Using url_safe_base64 0.2.2

Using kgio 2.10.0

Using mixlib-shellout 2.1.0

Using mysql2 0.4.4

Using net-ldap 0.14.0

Using newrelic_rpm 3.16.2.321

Using oj 2.17.4

Using pdf-core 0.6.1

Using ttfunk 1.4.0

Using rmagick 2.15.4

Using rubyzip 1.2.0

Using ruby-ole 1.2.12

Using pg 0.19.0

Using rails_serve_static_assets 0.0.5

Using rails_stdout_logging 0.0.5

Using raindrops 0.17.0

Using ruby-progressbar 1.8.1

Using structured_warnings 0.2.0

Using sqlite3 1.3.11

Using stringex 2.6.1

Using svg-graph 2.0.1

Using syck 1.0.5

Using will_paginate 3.1.3

Using i18n-js 3.0.0.rc14

Using tzinfo 1.2.2

Using descendants_tracker 0.0.4

Using rack-test 0.6.3

Using rack-accept 0.4.5

Using passenger 5.0.30

Using rack-attack 5.0.1

Using rack-protection 2.0.0.beta2

Using warden 1.2.6

Using websocket-driver 0.6.4

Using mail 2.6.4

Installing httpclient 2.8.2.4

Using airbrake 5.1.0

Using autoprefixer-rails 6.4.1.1

Using cells 4.1.3

Using unf 0.1.4

Using mustermann19 0.4.4

Using sys-filesystem 1.1.7

Using fog-core 1.42.0

Using rdoc 4.2.2

Using omniauth 1.3.1 from https://github.com/oliverguenther/omniauth (at 8385bc0@8385bc0)

Using prawn 2.1.0

Using spreadsheet 0.8.9

Using rails_12factor 0.0.3

Using unicorn 5.1.0

Using rubytree 0.9.7

Installing sprockets 3.7.0

Using tzinfo-data 1.2016.6

Using axiom-types 0.1.1

Using coercible 1.0.0

Using bourbon 4.2.7

Using warden-basic_auth 0.2.1

Using cells-erb 0.0.8

Using domain_name 0.5.20161129

Using fog-json 1.0.2

Using prawn-table 0.2.2

Using unicorn-worker-killer 0.4.4

Using virtus 1.0.5

Using http-cookie 1.0.3

Using rest-client 1.8.0

Using crowdin-api 0.4.1

Installing activesupport 5.0.0.1

Using globalid 0.3.7

Using climate_control 0.0.3

Using delayed_job 4.1.2

Using grape 0.17.0

Installing json-jwt 1.6.5

Installing activemodel 5.0.0.1

Using swd 1.0.1

Using webfinger 1.0.2

Using rabl 0.13.0

Using ruby-duration 3.2.3

Installing nokogiri 1.6.8 with native extensions

Installing rack-oauth2 1.4.0

Installing activejob 5.0.0.1

Using cocaine 0.5.8

Using grape-cache_control 1.0.1

Using carrierwave 1.0.0.beta from https://github.com/carrierwaveuploader/carrierwave (at master@5367a63)

Using date_validator 0.9.0

Using validate_email 0.1.6

Using validate_url 1.0.2

Using openid_connect 0.8.3

Using omniauth-openid-connect 0.2.0 from https://github.com/finnlabs/omniauth-openid-connect.git (at dev@c3bce4c)

Using omniauth-openid_connect-providers 0.1.0 from https://github.com/finnlabs/omniauth-openid_connect-providers.git (at dev@86f3670)

Installing activerecord 5.0.0.1

Using activemodel-serializers-xml 1.0.1

Using acts_as_list 0.8.1

Using acts_as_tree 2.5.1

Using awesome_nested_set 3.1.1

Using delayed_job_active_record 4.1.1

Using friendly_id 5.2.0.beta.1 from https://github.com/norman/friendly_id (at aff0564@aff0564)

Using globalize 5.1.0 from https://github.com/globalize/globalize (at 38443bc@38443bc)

Using transactional_lock 0.1.0 from https://github.com/finnlabs/transactional_lock.git (at master@6948b1d)

Using loofah 2.0.3

Using representable 2.1.8

Using fog-xml 0.1.2

Using ruby-saml 1.4.0

Using rails-html-sanitizer 1.0.3

Using disposable 0.0.9

Using roar 1.0.4

Using omniauth-saml 1.6.0 from git://github.com/omniauth/omniauth-saml.git (at master@5559d6b)

Using fog-aws 0.11.0

Using reform 1.2.6

Using openproject-auth_saml 0.1.0 from https://github.com/finnlabs/openproject-auth_saml (at dev@97212ab)

Installing rails-dom-testing 2.0.1

Installing actionview 5.0.0.1

Installing actionpack 5.0.0.1

Installing actionmailer 5.0.0.1

Installing actioncable 5.0.0.1

Using cells-rails 0.0.6

Using gon 4.1.1

Using sprockets-rails 3.2.0

Installing railties 5.0.0.1

Using actionpack-xml_parser 2.0.0

Using activerecord-session_store 1.0.0

Using jquery-tablesorter 1.22.7

Using responders 2.3.0

Using sass-rails 5.0.6

Installing rails 5.0.0.1

Using health_check 2.2.1

Using lobby_boy 0.1.2

Using openproject-auth_plugins 6.1.4 from source at `vendored-plugins/openproject-auth_plugins`

Using openproject-pdf_export 6.1.4 from source at `vendored-plugins/openproject-pdf_export`

Using openproject-costs 6.1.4 from source at `vendored-plugins/openproject-costs`

Using openproject-documents 6.1.4 from source at `vendored-plugins/openproject-documents`

Using openproject-webhooks 6.1.4 from source at `vendored-plugins/openproject-webhooks`

Using openproject-global_roles 6.1.4 from source at `vendored-plugins/openproject-global_roles`

Using openproject-local_avatars 6.1.4 from source at `vendored-plugins/openproject-local_avatars`

Using openproject-meeting 6.1.4 from source at `vendored-plugins/openproject-meeting`

Using openproject-my_project_page 6.1.4 from source at `vendored-plugins/openproject-my_project_page`

Using reporting_engine 6.1.4 from source at `vendored-plugins/reporting_engine`

Using openproject-themes-dark 6.1.4 from source at `vendored-plugins/openproject-themes-dark`

Using openproject-translations 6.1.4 from https://github.com/opf/openproject-translations.git (at stable/6@da52ff9)

Using openproject-xls_export 6.1.4 from source at `vendored-plugins/openproject-xls_export`

Using rails-angular-xss 0.3.0.pre.pre from https://github.com/opf/rails-angular-xss (at a45267d@a45267d)

Using rails_autolink 1.1.6

Using openproject-openid_connect 6.1.4 from source at `vendored-plugins/openproject-openid_connect`

Using openproject-backlogs 6.1.4 from source at `vendored-plugins/openproject-backlogs`

Using openproject-github_integration 6.1.4 from source at `vendored-plugins/openproject-github_integration`

Using openproject-reporting 6.1.4 from source at `vendored-plugins/openproject-reporting`

Bundle complete! 138 Gemfile dependencies, 195 gems now installed.

Gems in the groups development and test were not installed.

Bundled gems are installed into ./vendor/bundle.

Bundle completed (22.12s)

Cleaning up the bundler cache.

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Removing thor (0.19.4)

Removing builder (3.2.3)

Removing arel (7.1.4)

Removing concurrent-ruby (1.0.4)

Removing activerecord (5.0.1)

Removing sprockets (3.7.1)

Removing rails-dom-testing (2.0.2)

Removing actioncable (5.0.1)

Removing rails (5.0.1)

Removing actionview (5.0.1)

Removing activesupport (5.0.1)

Removing rake (12.0.0)

Removing activejob (5.0.1)

Removing railties (5.0.1)

Removing rack-oauth2 (1.5.1)

Removing minitest (5.10.1)

Removing httpclient (2.8.3)

Removing activemodel (5.0.1)

Removing actionmailer (5.0.1)

Removing json-jwt (1.7.1)

Removing openproject-token (1.0.0)

Removing nokogiri (1.6.8.1)

Removing actionpack (5.0.1)

-----> Detecting rake tasks

-----> Preparing app for Rails asset pipeline

Running: rake assets:precompile

$(npm bin)/webpack --config webpack.production.config.js

{"omniauth-openid-connect":"/tmp/d20170122-17-n79hap/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid-connect-c3bce4c9e9ac","omniauth-openid_connect-providers":"/tmp/d20170122-17-n79hap/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid_connect-providers-86f3670e127e","omniauth-saml":"/tmp/d20170122-17-n79hap/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-saml-5559d6b80805","openproject-auth_plugins":"/tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-auth_plugins","openproject-auth_saml":"/tmp/d20170122-17-n79hap/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-auth_saml-97212abb8378","openproject-pdf_export":"/tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-pdf_export","openproject-backlogs":"/tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-backlogs","openproject-costs":"/tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-costs","openproject-documents":"/tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-documents","openproject-webhooks":"/tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-webhooks","openproject-github_integration":"/tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-github_integration","openproject-global_roles":"/tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-global_roles","openproject-local_avatars":"/tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-local_avatars","openproject-meeting":"/tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-meeting","openproject-my_project_page":"/tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-my_project_page","openproject-openid_connect":"/tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-openid_connect","reporting_engine":"/tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/reporting_engine","openproject-reporting":"/tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-reporting","openproject-themes-dark":"/tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-themes-dark","openproject-translations":"/tmp/d20170122-17-n79hap/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-translations-da52ff92cdcd","openproject-xls_export":"/tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-xls_export"}

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Hash: 81c69e79e07103befba2

Version: webpack 1.13.3

Child

Hash: 81c69e79e07103befba2

Version: webpack 1.13.3

Time: 14233ms

Asset Size Chunks Chunk Names

7b9776076d5fceef4993b55c9383dedd.gif 1.85 kB [emitted]

openproject-backlogs.js 453 kB 0 [emitted] backlogs

openproject-core-app.js 3.43 MB 1 [emitted] core-app

openproject-costs.js 526 kB 2 [emitted] costs

openproject-global.js 3.51 MB 3 [emitted] global

openproject-my_project_page.js 14.3 kB 4 [emitted] my_project_page

openproject-core-app.css 4.71 kB 1 [emitted] core-app

openproject-global.css 49 kB 3 [emitted] global

[213] ./templates \.html$ 1.22 kB {1} [built]

[242] ./components ^((?!\.(test|spec)).)*\.(js|ts|html)$ 16.1 kB {1} [built]

[633] /tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 425 bytes {2} [built]

[765] /tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 330 bytes {4} [built]

+ 769 hidden modules

ERROR in [default]

File '/tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-budget-subform.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-n79hap/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-n79hap/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/subform/cost-subform.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-n79hap/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts' is not under 'rootDir' '/tmp/d20170122-17-n79hap/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts' is not under 'rootDir' '/tmp/d20170122-17-n79hap/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-block.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-n79hap/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-page-layout.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-n79hap/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-textile-block.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-n79hap/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default] /tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:49:18

Argument of type 'string' is not assignable to parameter of type '{ [key: string]: any; }'.

ERROR in [default] /tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:53:4

Supplied parameters do not match any signature of call target.

ERROR in [default] /tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:30:38

Cannot find module 'app/components/work-packages/work-package-cache.service'.

ERROR in [default] /tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:49:30

Cannot find name 'HalResource'.

ERROR in [default] /tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:54:57

Property '$injector' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:13

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:27

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:60:11

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:70:23

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:76:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:77:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:78:16

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:36:17

Property 'value' does not exist on type 'CurrencyDisplayField'.

ERROR in [default] /tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:37:23

Property 'value' does not exist on type 'CurrencyDisplayField'.

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 5 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

autoprefixer: /tmp/d20170122-17-n79hap/opt/openproject/app/assets/stylesheets/default.css.sass:6426:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-n79hap/opt/openproject/app/assets/stylesheets/default.css.sass:6456:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-n79hap/opt/openproject/app/assets/stylesheets/default.css.sass:11729:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-n79hap/opt/openproject/app/assets/stylesheets/default.css.sass:12110:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-n79hap/opt/openproject/app/assets/stylesheets/default.css.sass:12155:3: You should write display: flex by final spec instead of display: box

I, [2017-01-22T21:45:59.117368 #2726] INFO -- : Writing /tmp/d20170122-17-n79hap/opt/openproject/public/assets/default-b00e18110df905a5bf6f92466cbe06ed3965967d2d5e90d24ce836de132adb64.css

I, [2017-01-22T21:45:59.118445 #2726] INFO -- : Writing /tmp/d20170122-17-n79hap/opt/openproject/public/assets/default-b00e18110df905a5bf6f92466cbe06ed3965967d2d5e90d24ce836de132adb64.css.gz

I, [2017-01-22T21:46:00.870909 #2726] INFO -- : Writing /tmp/d20170122-17-n79hap/opt/openproject/public/assets/application-233e620c40609f5644d33557c0ff84a2bb22711de54030ef458d205ce846d65e.js

I, [2017-01-22T21:46:00.871298 #2726] INFO -- : Writing /tmp/d20170122-17-n79hap/opt/openproject/public/assets/application-233e620c40609f5644d33557c0ff84a2bb22711de54030ef458d205ce846d65e.js.gz

I, [2017-01-22T21:46:01.130409 #2726] INFO -- : Writing /tmp/d20170122-17-n79hap/opt/openproject/public/assets/locales/fa-ddde1dd90c7cd953dfe06fe7a99c8374773412c294f93ffe9efa3414e6b62c2a.js

I, [2017-01-22T21:46:01.130770 #2726] INFO -- : Writing /tmp/d20170122-17-n79hap/opt/openproject/public/assets/locales/fa-ddde1dd90c7cd953dfe06fe7a99c8374773412c294f93ffe9efa3414e6b62c2a.js.gz

I, [2017-01-22T21:46:01.155073 #2726] INFO -- : Writing /tmp/d20170122-17-n79hap/opt/openproject/public/assets/locales/id-a2a805a38128ac7a7ac9f665acb2885e446ba208b069cf9378b8ec1aec800649.js

I, [2017-01-22T21:46:01.155248 #2726] INFO -- : Writing /tmp/d20170122-17-n79hap/opt/openproject/public/assets/locales/id-a2a805a38128ac7a7ac9f665acb2885e446ba208b069cf9378b8ec1aec800649.js.gz

I, [2017-01-22T21:46:01.161799 #2726] INFO -- : Writing /tmp/d20170122-17-n79hap/opt/openproject/public/assets/locales/it-2da9fe25a38c3b5ecc1ad49f013f4f2780e7cc8c7760e14b5e0cf9133a3ca888.js

I, [2017-01-22T21:46:01.161928 #2726] INFO -- : Writing /tmp/d20170122-17-n79hap/opt/openproject/public/assets/locales/it-2da9fe25a38c3b5ecc1ad49f013f4f2780e7cc8c7760e14b5e0cf9133a3ca888.js.gz

I, [2017-01-22T21:46:01.169224 #2726] INFO -- : Writing /tmp/d20170122-17-n79hap/opt/openproject/public/assets/locales/ja-f8632d5fff009c766a77c499986ac2ab325405dc4f1bf26622ae18f9ce8792a8.js

I, [2017-01-22T21:46:01.169411 #2726] INFO -- : Writing /tmp/d20170122-17-n79hap/opt/openproject/public/assets/locales/ja-f8632d5fff009c766a77c499986ac2ab325405dc4f1bf26622ae18f9ce8792a8.js.gz

I, [2017-01-22T21:46:01.181942 #2726] INFO -- : Writing /tmp/d20170122-17-n79hap/opt/openproject/public/assets/locales/nl-e7e1a58e4a0fe3814cc911c20cd36192bb5110c5ac32a7e583e9d4d177bd693e.js

I, [2017-01-22T21:46:01.182082 #2726] INFO -- : Writing /tmp/d20170122-17-n79hap/opt/openproject/public/assets/locales/nl-e7e1a58e4a0fe3814cc911c20cd36192bb5110c5ac32a7e583e9d4d177bd693e.js.gz

autoprefixer: /tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:6446:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:6476:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:11749:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:12130:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-n79hap/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:12175:3: You should write display: flex by final spec instead of display: box

I, [2017-01-22T21:46:15.100671 #2726] INFO -- : Writing /tmp/d20170122-17-n79hap/opt/openproject/public/assets/dark-feeac1abf7e73be6eb6d80d8a8f8e5b9bf79b47ce3eba05b133e96395d495c5a.css

I, [2017-01-22T21:46:15.100938 #2726] INFO -- : Writing /tmp/d20170122-17-n79hap/opt/openproject/public/assets/dark-feeac1abf7e73be6eb6d80d8a8f8e5b9bf79b47ce3eba05b133e96395d495c5a.css.gz

Asset precompilation completed (63.67s)

Cleaning assets

Running: rake assets:clean

I, [2017-01-22T21:46:23.510454 #2961] INFO -- : Removed locales/fa-0dbf392eccd6c0bdd63cfadefebb8a9b2ae0ffc90b91c905764f3b009aecb046.js

I, [2017-01-22T21:46:23.515982 #2961] INFO -- : Removed locales/id-a7c8c482240a4e457ff26930c4a800331ec9a565832f4a26b05aa189e690b876.js

I, [2017-01-22T21:46:23.520773 #2961] INFO -- : Removed locales/it-7e1d737729288534422df10d26c1b9357bd99ef564864ac74c1080c53037c9a5.js

I, [2017-01-22T21:46:23.525500 #2961] INFO -- : Removed locales/ja-90d4866d75e8e5c66cb904ef183adae9eb1ec8ea412d548a25b9f8b367258fdf.js

I, [2017-01-22T21:46:23.534752 #2961] INFO -- : Removed default-270b9c30b239e0622b55c68a93351ad8b56bde4af52e9dc6dee3ed4d7e1124b5.css

I, [2017-01-22T21:46:23.539930 #2961] INFO -- : Removed locales/nl-3f2643487cd26bc712d2d53bade04dcfbf8de02db124d1453990847eac991965.js

I, [2017-01-22T21:46:23.545509 #2961] INFO -- : Removed dark-681a673a66ecee6ff638adb9b42edc00086247fb6aa9dc57b93483f16f574571.css

I, [2017-01-22T21:46:23.551534 #2961] INFO -- : Removed application-be38c116e1c3089bb3e228a3f2adb6e8bde6fc6f029f8fc9f9d9b05d132f3dce.js

Using release configuration from last framework (Ruby).

-----> [cron] /opt/openproject/packaging/cron/openproject-clear-old-sessions => /etc/cron.d/openproject-clear-old-sessions

-----> Verifying package openproject_6.1.4-1485121203.2cb8b63.wheezy_amd64.deb

NEW PACKAGE: openproject_6.1.4-1485121203.2cb8b63.wheezy_amd64.deb (291.75 MiB)

-----> Releasing...

DONE!

====== Attempt #1

-----> Fetching repository

Cloning into '/tmp/d20170122-16665-18bmrxk/input'...

-----> Restoring cache

-----> Starting packaging process

-----> Installing missing build dependencies: libmagickwand-dev, libsqlite3-dev

-----> [wizard] adding legacy-installer wizard (https://github.com/pkgr/addon-legacy-installer#master)

-----> [wizard] adding mysql wizard (https://github.com/pkgr/addon-mysql#master)

-----> [wizard] adding apache2 wizard (https://github.com/pkgr/addon-apache2#master)

-----> [wizard] adding repositories wizard (https://github.com/finnlabs/addon-repositories#master)

-----> [wizard] adding smtp wizard (https://github.com/pkgr/addon-smtp#master)

-----> [wizard] adding memcached wizard (https://github.com/pkgr/addon-memcached#master)

-----> [wizard] adding openproject wizard (https://github.com/pkgr/addon-openproject#master)

/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)

-----> Fetching buildpack https://github.com/opf/heroku-buildpack-multi.git at master

-----> Multipack app

-----> Running hook: "packaging/setup"

WARNING: This buildpack is no longer maintained.

Please choose a different buildpack or go to https://github.com/ddollar/heroku-buildpack-multi

and fork it to your own account.

=====> Downloading Buildpack: https://github.com/pkgr/pkgr-buildpack-imagemagick.git

=====> Detected Framework: ImageMagick

-----> SKIP

=====> Downloading Buildpack: https://github.com/heroku/heroku-buildpack-nodejs.git

=====> Detected Framework: Node.js

-----> Reading application state

package.json...

build directory...

cache directory...

environment variables...

Node engine: 6.9.1

Npm engine: 4.0.0

Start mechanism: Procfile

node_modules source: package.json

node_modules cached: true

NPM_CONFIG_PRODUCTION=true

NODE_MODULES_CACHE=true

-----> Installing binaries

Downloading and installing node 6.9.1...

Downloading and installing npm 4.0.0 (replacing version 3.10.8)...

-----> Building dependencies

Restoring node modules from cache

Pruning unused dependencies

Installing any new modules

> openproject@0.1.0 postinstall /tmp/d20170122-17-1hnt7d5/opt/openproject

> cd frontend && npm install

> openproject-frontend@0.1.0 postinstall /tmp/d20170122-17-1hnt7d5/opt/openproject/frontend

> bower install --config.interactive=false

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 not-cached git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolve git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de not-cached git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolve git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 not-cached git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolve git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 checkout d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower jquery-ui#~1.10.4 not-cached https://github.com/components/jqueryui.git#~1.10.4

bower jquery-ui#~1.10.4 resolve https://github.com/components/jqueryui.git#~1.10.4

bower jquery#1.11.0 not-cached https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery#1.11.0 resolve https://github.com/jquery/jquery-dist.git#1.11.0

bower select2#3.5.2 not-cached https://github.com/ivaynberg/select2.git#3.5.2

bower select2#3.5.2 resolve https://github.com/ivaynberg/select2.git#3.5.2

bower jquery-ujs#1.0.0 not-cached https://github.com/rails/jquery-ujs.git#1.0.0

bower jquery-ujs#1.0.0 resolve https://github.com/rails/jquery-ujs.git#1.0.0

bower angular#~1.5.8 not-cached https://github.com/angular/bower-angular.git#~1.5.8

bower angular#~1.5.8 resolve https://github.com/angular/bower-angular.git#~1.5.8

bower angular-animate#~1.5.8 not-cached https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-animate#~1.5.8 resolve https://github.com/angular/bower-angular-animate.git#~1.5.8

bower jquery.atwho#0.5.1 not-cached https://github.com/ichord/At.js.git#0.5.1

bower jquery.atwho#0.5.1 resolve https://github.com/ichord/At.js.git#0.5.1

bower angular-aria#~1.5.8 not-cached https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-aria#~1.5.8 resolve https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-ui-router#~0.3.1 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-ui-router#~0.3.1 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-i18n#~1.5.5 not-cached https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-i18n#~1.5.5 resolve https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-sanitize#~1.5.8 not-cached https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-sanitize#~1.5.8 resolve https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-elastic#~2.5.1 not-cached https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-elastic#~2.5.1 resolve https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-cache#~4.6.0 not-cached https://github.com/jmdobry/angular-cache.git#~4.6.0

bower angular-cache#~4.6.0 resolve https://github.com/jmdobry/angular-cache.git#~4.6.0

bower jquery-migrate#~1.2.1 not-cached https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower jquery-migrate#~1.2.1 resolve https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower moment-timezone#0.4.x not-cached https://github.com/moment/moment-timezone.git#0.4.x

bower moment-timezone#0.4.x resolve https://github.com/moment/moment-timezone.git#0.4.x

bower angular-busy#~4.1.3 not-cached https://github.com/cgross/angular-busy.git#~4.1.3

bower angular-busy#~4.1.3 resolve https://github.com/cgross/angular-busy.git#~4.1.3

bower lodash#~2.4.1 not-cached https://github.com/lodash/lodash.git#~2.4.1

bower lodash#~2.4.1 resolve https://github.com/lodash/lodash.git#~2.4.1

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de checkout fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 checkout a908eccaec323cd66973d58af4965694bdff16a1

bower foundation-apps#1.1.0 not-cached https://github.com/zurb/foundation-apps.git#1.1.0

bower foundation-apps#1.1.0 resolve https://github.com/zurb/foundation-apps.git#1.1.0

bower bourbon#~4.2.1 not-cached https://github.com/thoughtbot/bourbon.git#~4.2.1

bower bourbon#~4.2.1 resolve https://github.com/thoughtbot/bourbon.git#~4.2.1

bower angular-ui-select#~0.19.4 not-cached https://github.com/angular-ui/ui-select.git#~0.19.4

bower angular-ui-select#~0.19.4 resolve https://github.com/angular-ui/ui-select.git#~0.19.4

bower mousetrap#~1.4.6 not-cached https://github.com/ccampbell/mousetrap.git#~1.4.6

bower mousetrap#~1.4.6 resolve https://github.com/ccampbell/mousetrap.git#~1.4.6

bower ng-file-upload#~5.0.9 not-cached https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower ng-file-upload#~5.0.9 resolve https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower rxjs#^4.1.0 not-cached https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower rxjs#^4.1.0 resolve https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower ng-dialog#^0.6.2 not-cached https://github.com/likeastore/ngDialog.git#^0.6.2

bower ng-dialog#^0.6.2 resolve https://github.com/likeastore/ngDialog.git#^0.6.2

bower angular-dragula#^1.2.8 not-cached https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower angular-dragula#^1.2.8 resolve https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower angular-mocks#~1.5.8 not-cached https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower angular-mocks#~1.5.8 resolve https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower mocha#~1.14.0 not-cached https://github.com/mochajs/mocha.git#~1.14.0

bower mocha#~1.14.0 resolve https://github.com/mochajs/mocha.git#~1.14.0

bower chai#~1.9.0 not-cached https://github.com/chaijs/chai.git#~1.9.0

bower chai#~1.9.0 resolve https://github.com/chaijs/chai.git#~1.9.0

bower jquery-mockjax#~1.5.3 not-cached https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery-mockjax#~1.5.3 resolve https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery-ui#~1.10.4 checkout 1.10.4

bower jquery#1.11.0 checkout 1.11.0

bower select2#3.5.2 checkout 3.5.2

bower jquery-ujs#1.0.0 checkout v1.0.0

bower angular#~1.5.8 checkout v1.5.11

bower angular-ui-router#~0.3.1 checkout 0.3.2

bower angular-aria#~1.5.8 checkout v1.5.11

bower jquery.atwho#0.5.1 checkout v0.5.1

bower angular-animate#~1.5.8 checkout v1.5.11

bower jquery-migrate#~1.2.1 checkout 1.2.1

bower angular-cache#~4.6.0 checkout 4.6.0

bower angular-elastic#~2.5.1 checkout v2.5.1

bower angular-sanitize#~1.5.8 checkout v1.5.11

bower angular-i18n#~1.5.5 checkout v1.5.11

bower bourbon#~4.2.1 checkout v4.2.7

bower foundation-apps#1.1.0 checkout v1.1.0

bower lodash#~2.4.1 checkout 2.4.2

bower angular-busy#~4.1.3 checkout v4.1.4

bower moment-timezone#0.4.x checkout 0.4.1

bower mousetrap#~1.4.6 checkout 1.4.6

bower ng-file-upload#~5.0.9 checkout 5.0.9

bower angular-ui-select#~0.19.4 checkout v0.19.6

bower ng-dialog#^0.6.2 checkout v0.6.6

bower rxjs#^4.1.0 checkout v4.1.0

bower angular-dragula#^1.2.8 checkout v1.2.8

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolved git://github.com/finnlabs/angular-modal.git#d45eb9ceb7

bower angular#^1.3.0 not-cached https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 resolve https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 checkout v1.6.1

bower jquery-mockjax#~1.5.3 checkout v1.5.4

bower chai#~1.9.0 checkout 1.9.2

bower mocha#~1.14.0 checkout 1.14.0

bower angular-mocks#~1.5.8 checkout v1.5.11

bower moment#~2.10.6 not-cached https://github.com/moment/moment.git#~2.10.6

bower moment#~2.10.6 resolve https://github.com/moment/moment.git#~2.10.6

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .png files: ["select2.png","select2x2.png"]

bower jquery-ui#~1.10.4 resolved https://github.com/components/jqueryui.git#1.10.4

bower select2#3.5.2 resolved https://github.com/ivaynberg/select2.git#3.5.2

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolved git://github.com/sparkalow/angular-truncate.git#fdf60fda26

bower jquery-ujs#1.0.0 resolved https://github.com/rails/jquery-ujs.git#1.0.0

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolved git://github.com/nickmessing/angular-context-menu.git#a908eccaec

bower angular#>= 1.2.5 not-cached https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 resolve https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 checkout v1.6.1

bower angular#~1.5.8 resolved https://github.com/angular/bower-angular.git#1.5.11

bower jquery.atwho#0.5.1 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower jquery.atwho#0.5.1 resolved https://github.com/ichord/At.js.git#0.5.1

bower angular-aria#~1.5.8 resolved https://github.com/angular/bower-angular-aria.git#1.5.11

bower jquery#1.11.0 resolved https://github.com/jquery/jquery-dist.git#1.11.0

bower angular-animate#~1.5.8 resolved https://github.com/angular/bower-angular-animate.git#1.5.11

bower jquery-migrate#~1.2.1 deprecated Package jquery-migrate is using the deprecated component.json

bower jquery-migrate#~1.2.1 resolved https://github.com/appleboy/jquery-migrate.git#1.2.1

bower Caret.js#>= 0.2.0 not-cached https://github.com/ichord/Caret.js.git#>= 0.2.0

bower Caret.js#>= 0.2.0 resolve https://github.com/ichord/Caret.js.git#>= 0.2.0

bower angular-ui-router#~0.3.1 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.3.2

bower angular-elastic#~2.5.1 resolved https://github.com/monospaced/angular-elastic.git#2.5.1

bower angular-cache#~4.6.0 resolved https://github.com/jmdobry/angular-cache.git#4.6.0

bower angular-sanitize#~1.5.8 resolved https://github.com/angular/bower-angular-sanitize.git#1.5.11

bower bourbon#~4.2.1 resolved https://github.com/thoughtbot/bourbon.git#4.2.7

bower foundation-apps#1.1.0 resolved https://github.com/zurb/foundation-apps.git#1.1.0

bower angular#~1.3.4 not-cached https://github.com/angular/bower-angular.git#~1.3.4

bower angular#~1.3.4 resolve https://github.com/angular/bower-angular.git#~1.3.4

bower angular-ui-router#~0.2.12 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-ui-router#~0.2.12 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-animate#~1.3.4 not-cached https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular-animate#~1.3.4 resolve https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular#~1.3.4 checkout v1.3.20

bower angular-ui-router#~0.2.12 checkout 0.2.18

bower angular-animate#~1.3.4 checkout v1.3.20

bower mousetrap#~1.4.6 resolved https://github.com/ccampbell/mousetrap.git#1.4.6

bower hammerjs#~2.0.4 not-cached https://github.com/EightMedia/hammer.js.git#~2.0.4

bower hammerjs#~2.0.4 resolve https://github.com/EightMedia/hammer.js.git#~2.0.4

bower viewport-units-buggyfill#~0.4.1 not-cached https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower viewport-units-buggyfill#~0.4.1 resolve https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower ng-file-upload#~5.0.9 resolved https://github.com/danialfarid/angular-file-upload-bower.git#5.0.9

bower lodash#~2.4.1 resolved https://github.com/lodash/lodash.git#2.4.2

bower tether#~0.6.5 not-cached https://github.com/HubSpot/tether.git#~0.6.5

bower tether#~0.6.5 resolve https://github.com/HubSpot/tether.git#~0.6.5

bower fastclick#~1.0.3 not-cached https://github.com/ftlabs/fastclick.git#~1.0.3

bower fastclick#~1.0.3 resolve https://github.com/ftlabs/fastclick.git#~1.0.3

bower angular-busy#~4.1.3 resolved https://github.com/cgross/angular-busy.git#4.1.4

bower moment-timezone#0.4.x resolved https://github.com/moment/moment-timezone.git#0.4.1

bower moment#>= 2.6.0 not-cached https://github.com/moment/moment.git#>= 2.6.0

bower moment#>= 2.6.0 resolve https://github.com/moment/moment.git#>= 2.6.0

bower ng-dialog#^0.6.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .css files: ["css/ngDialog.css","css/ngDialog-theme-default.css"]

bower angular-dragula#^1.2.8 resolved https://github.com/bevacqua/angular-dragula.git#1.2.8

bower ng-dialog#^0.6.2 resolved https://github.com/likeastore/ngDialog.git#0.6.6

bower angular-ui-select#~0.19.4 resolved https://github.com/angular-ui/ui-select.git#0.19.6

bower jquery-mockjax#~1.5.3 resolved https://github.com/jakerella/jquery-mockjax.git#1.5.4

bower chai#~1.9.0 resolved https://github.com/chaijs/chai.git#1.9.2

bower mocha#~1.14.0 mismatch Version declared in the json (1.12.0) is different than the resolved one (1.14.0)

bower mocha#~1.14.0 resolved https://github.com/mochajs/mocha.git#1.14.0

bower moment#>= 2.6.0 checkout 2.17.1

bower moment#~2.10.6 checkout 2.10.6

bower angular#^1.3.0 resolved https://github.com/angular/bower-angular.git#1.6.1

bower Caret.js#>= 0.2.0 checkout v0.3.1

bower angular-mocks#~1.5.8 resolved https://github.com/angular/bower-angular-mocks.git#1.5.11

bower angular-i18n#~1.5.5 resolved https://github.com/angular/bower-angular-i18n.git#1.5.11

bower angular-ui-router#~0.2.12 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.2.18

bower hammerjs#~2.0.4 checkout v2.0.8

bower viewport-units-buggyfill#~0.4.1 checkout v0.4.1

bower angular#~1.3.4 resolved https://github.com/angular/bower-angular.git#1.3.20

bower angular#>= 1.2.5 resolved https://github.com/angular/bower-angular.git#1.6.1

bower angular-animate#~1.3.4 resolved https://github.com/angular/bower-angular-animate.git#1.3.20

bower tether#~0.6.5 checkout v0.6.5

bower fastclick#~1.0.3 checkout v1.0.6

bower Caret.js#>= 0.2.0 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower rxjs#^4.1.0 resolved https://github.com/Reactive-Extensions/RxJS.git#4.1.0

bower Caret.js#>= 0.2.0 resolved https://github.com/ichord/Caret.js.git#0.3.1

bower hammerjs#~2.0.4 resolved https://github.com/EightMedia/hammer.js.git#2.0.8

bower viewport-units-buggyfill#~0.4.1 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .js files: ["./viewport-units-buggyfill.js","./viewport-units-buggyfill.hacks.js"]

bower viewport-units-buggyfill#~0.4.1 resolved https://github.com/rodneyrehm/viewport-units-buggyfill.git#0.4.1

bower tether#~0.6.5 resolved https://github.com/HubSpot/tether.git#0.6.5

bower fastclick#~1.0.3 resolved https://github.com/ftlabs/fastclick.git#1.0.6

bower moment#~2.10.6 resolved https://github.com/moment/moment.git#2.10.6

bower moment#>= 2.6.0 resolved https://github.com/moment/moment.git#2.17.1

Please note that,

angular-animate#1.3.20 depends on angular#1.3.20 which resolved to angular#1.3.20

foundation-apps#1.1.0 depends on angular#~1.3.4 which resolved to angular#1.3.20

angular-animate#1.5.11, angular-aria#1.5.11, angular-mocks#1.5.11, angular-sanitize#1.5.11 depends on angular#1.5.11 which resolved to angular#1.5.11

angular-ui-router#0.3.2, angular-ui-router#0.2.18 depends on angular#^1.0.8 which resolved to angular#1.5.11

angular-elastic#2.5.1 depends on angular#>=1.0.6 which resolved to angular#1.5.11

angular-cache#4.6.0 depends on angular#>=1.x which resolved to angular#1.5.11

angular-busy#4.1.4 depends on angular#>=1.3 which resolved to angular#1.5.11

angular-ui-select#0.19.6 depends on angular#>=1.2.18 which resolved to angular#1.5.11

openproject depends on angular#~1.5.8 which resolved to angular#1.5.11

ng-dialog#0.6.6 depends on angular#>=1.5 which resolved to angular#1.5.11

angular-context-menu#a908eccaec depends on angular#>= 1.2.5 which resolved to angular#1.6.1

angular-modal#d45eb9ceb7 depends on angular#^1.3.0 which resolved to angular#1.6.1

Resort to using angular#~1.5.8 which resolved to angular#1.5.11

Code incompatibilities may occur.

Please note that,

foundation-apps#1.1.0 depends on angular-animate#~1.3.4 which resolved to angular-animate#1.3.20

openproject depends on angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

angular-busy#4.1.4 depends on angular-animate#>=1.3 which resolved to angular-animate#1.5.11

Resort to using angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

Code incompatibilities may occur.

Please note that,

foundation-apps#1.1.0 depends on angular-ui-router#~0.2.12 which resolved to angular-ui-router#0.2.18

openproject depends on angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Resort to using angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Code incompatibilities may occur.

bower jquery extra-resolution Unnecessary resolution: jquery#1.11.0

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 install angular-modal#d45eb9ceb7

bower jquery-ui#~1.10.4 install jquery-ui#1.10.4

bower select2#3.5.2 install select2#3.5.2

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de install angular-truncate#fdf60fda26

bower jquery-ujs#1.0.0 install jquery-ujs#1.0.0

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 install angular-context-menu#a908eccaec

bower angular#1.5.11 install angular#1.5.11

bower jquery.atwho#0.5.1 install jquery.atwho#0.5.1

bower angular-aria#~1.5.8 install angular-aria#1.5.11

bower jquery#1.11.0 install jquery#1.11.0

bower angular-animate#~1.5.8 install angular-animate#1.5.11

bower jquery-migrate#~1.2.1 install jquery-migrate#1.2.1

bower angular-ui-router#~0.3.1 install angular-ui-router#0.3.2

bower angular-elastic#~2.5.1 install angular-elastic#2.5.1

bower angular-cache#~4.6.0 install angular-cache#4.6.0

bower angular-sanitize#~1.5.8 install angular-sanitize#1.5.11

bower bourbon#~4.2.1 install bourbon#4.2.7

bower foundation-apps#1.1.0 install foundation-apps#1.1.0

bower mousetrap#~1.4.6 install mousetrap#1.4.6

bower ng-file-upload#~5.0.9 install ng-file-upload#5.0.9

bower lodash#~2.4.1 install lodash#2.4.2

bower angular-busy#~4.1.3 install angular-busy#4.1.4

bower moment-timezone#0.4.x install moment-timezone#0.4.1

bower angular-dragula#^1.2.8 install angular-dragula#1.2.8

bower ng-dialog#^0.6.2 install ng-dialog#0.6.6

bower angular-ui-select#~0.19.4 install angular-ui-select#0.19.6

bower jquery-mockjax#~1.5.3 install jquery-mockjax#1.5.4

bower chai#~1.9.0 install chai#1.9.2

bower mocha#~1.14.0 install mocha#1.14.0

bower angular-mocks#~1.5.8 install angular-mocks#1.5.11

bower angular-i18n#~1.5.5 install angular-i18n#1.5.11

bower rxjs#^4.1.0 install rxjs#4.1.0

bower Caret.js#>= 0.2.0 install Caret.js#0.3.1

bower hammerjs#~2.0.4 install hammerjs#2.0.8

bower viewport-units-buggyfill#~0.4.1 install viewport-units-buggyfill#0.4.1

bower tether#~0.6.5 install tether#0.6.5

bower fastclick#~1.0.3 install fastclick#1.0.6

bower moment#~2.10.6 install moment#2.10.6

angular-modal#d45eb9ceb7 bower_components/angular-modal

└── angular#1.5.11

jquery-ui#1.10.4 bower_components/jquery-ui

└── jquery#1.11.0

select2#3.5.2 bower_components/select2

└── jquery#1.11.0

angular-truncate#fdf60fda26 bower_components/angular-truncate

jquery-ujs#1.0.0 bower_components/jquery-ujs

└── jquery#1.11.0

angular-context-menu#a908eccaec bower_components/angular-context-menu

└── angular#1.5.11

angular#1.5.11 bower_components/angular

jquery.atwho#0.5.1 bower_components/jquery.atwho

├── Caret.js#0.3.1

└── jquery#1.11.0

angular-aria#1.5.11 bower_components/angular-aria

└── angular#1.5.11

jquery#1.11.0 bower_components/jquery

angular-animate#1.5.11 bower_components/angular-animate

└── angular#1.5.11

jquery-migrate#1.2.1 bower_components/jquery-migrate

angular-ui-router#0.3.2 bower_components/angular-ui-router

└── angular#1.5.11

angular-elastic#2.5.1 bower_components/angular-elastic

└── angular#1.5.11

angular-cache#4.6.0 bower_components/angular-cache

└── angular#1.5.11

angular-sanitize#1.5.11 bower_components/angular-sanitize

└── angular#1.5.11

bourbon#4.2.7 bower_components/bourbon

foundation-apps#1.1.0 bower_components/foundation-apps

├── angular#1.5.11

├── angular-animate#1.5.11

├── angular-ui-router#0.3.2

├── fastclick#1.0.6

├── hammerjs#2.0.8

├── tether#0.6.5

└── viewport-units-buggyfill#0.4.1

mousetrap#1.4.6 bower_components/mousetrap

ng-file-upload#5.0.9 bower_components/ng-file-upload

lodash#2.4.2 bower_components/lodash

angular-busy#4.1.4 bower_components/angular-busy

├── angular#1.5.11

└── angular-animate#1.5.11

moment-timezone#0.4.1 bower_components/moment-timezone

└── moment#2.10.6

angular-dragula#1.2.8 bower_components/angular-dragula

ng-dialog#0.6.6 bower_components/ng-dialog

└── angular#1.5.11

angular-ui-select#0.19.6 bower_components/angular-ui-select

└── angular#1.5.11

jquery-mockjax#1.5.4 bower_components/jquery-mockjax

chai#1.9.2 bower_components/chai

mocha#1.14.0 bower_components/mocha

angular-mocks#1.5.11 bower_components/angular-mocks

└── angular#1.5.11

angular-i18n#1.5.11 bower_components/angular-i18n

rxjs#4.1.0 bower_components/rxjs

Caret.js#0.3.1 bower_components/Caret.js

└── jquery#1.11.0

hammerjs#2.0.8 bower_components/hammerjs

viewport-units-buggyfill#0.4.1 bower_components/viewport-units-buggyfill

tether#0.6.5 bower_components/tether

fastclick#1.0.6 bower_components/fastclick

moment#2.10.6 bower_components/moment

openproject-frontend@0.1.0 /tmp/d20170122-17-1hnt7d5/opt/openproject/frontend

+-- acorn@2.6.4

+-- align-text@0.1.4

+-- alter@0.2.0

+-- amdefine@1.0.0

+-- angular@1.5.8

+-- angular-elastic@2.5.1

+-- angular-ui-bootstrap@2.2.0

+-- anymatch@1.3.0

+-- arr-diff@2.0.0

+-- arr-flatten@1.0.1

+-- array-unique@0.2.1

+-- arrify@1.0.1

+-- assert@1.4.1

+-- async@0.2.10

+-- async-each@1.0.1

+-- atoa@1.0.0

+-- autoprefixer-core@5.2.1

+-- autoprefixer-loader@1.2.0

+-- awesome-typescript-loader@2.2.4

| `-- lodash@4.16.4

+-- balanced-match@0.4.2

+-- Base64@0.2.1

+-- base64-js@1.2.0

+-- big.js@3.1.3

+-- binary-extensions@1.7.0

+-- bower@1.7.9

+-- brace-expansion@1.1.6

+-- braces@1.8.5

+-- browserify-zlib@0.1.4

+-- browserslist@0.4.0

+-- buffer@4.9.1

+-- buffer-shims@1.0.0

+-- camelcase@1.2.1

+-- caniuse-db@1.0.30000569

+-- center-align@0.1.3

+-- chokidar@1.6.1

+-- cliui@2.1.0

| `-- wordwrap@0.0.2

+-- clone@1.0.2

+-- colors@1.1.2

+-- concat-map@0.0.1

+-- console-browserify@1.1.0

+-- constants-browserify@0.0.1

+-- contra@1.9.4

+-- convert-source-map@1.1.3

+-- core-util-is@1.0.2

+-- crossvent@1.5.4

+-- crypto-browserify@3.2.8

+-- css-loader@0.9.1

| `-- source-map@0.1.43

+-- csso@1.3.12

+-- custom-event@1.0.0

+-- d@0.1.1

+-- date-now@0.1.4

+-- decamelize@1.2.0

+-- domain-browser@1.1.7

+-- dragula@3.7.2

+-- emojis-list@2.1.0

+-- enhanced-resolve@2.3.0

+-- errno@0.1.4

+-- es5-ext@0.10.12

+-- es6-iterator@2.0.0

+-- es6-promise@2.3.0

+-- es6-symbol@3.1.0

+-- es6-weak-map@0.1.4

| +-- es6-iterator@0.1.3

| `-- es6-symbol@2.0.1

+-- event-emitter@0.3.4

+-- events@1.1.1

+-- expand-brackets@0.1.5

+-- expand-range@1.8.2

+-- exports-loader@0.6.3

| `-- source-map@0.1.43

+-- expose-loader@0.6.0

+-- extglob@0.3.2

+-- extract-text-webpack-plugin@0.3.8

| `-- source-map@0.1.43

+-- fastparse@1.1.1

+-- file-loader@0.8.5

+-- filename-regex@2.0.0

+-- fill-range@2.2.3

+-- for-in@0.1.6

+-- for-own@0.1.4

+-- glob@4.5.3

+-- glob-base@0.3.0

+-- glob-parent@2.0.0

+-- graceful-fs@4.1.9

+-- has-flag@1.0.0

+-- html-loader@0.2.3

| `-- source-map@0.1.43

+-- html-minifier@0.5.6

+-- http-browserify@1.7.0

+-- https-browserify@0.0.0

+-- ieee754@1.1.8

+-- indexof@0.0.1

+-- inflight@1.0.6

+-- inherits@2.0.3

+-- interpret@0.6.6

+-- is-binary-path@1.0.1

+-- is-buffer@1.1.4

+-- is-dotfile@1.0.2

+-- is-equal-shallow@0.1.3

+-- is-extendable@0.1.1

+-- is-extglob@1.0.0

+-- is-glob@2.0.1

+-- is-number@2.1.0

+-- is-posix-bracket@0.1.1

+-- is-primitive@2.0.0

+-- isarray@1.0.0

+-- isobject@2.1.0

+-- js-base64@2.1.9

+-- json5@0.4.0

+-- kind-of@3.0.4

+-- lazy-cache@1.0.4

+-- loader-utils@0.2.16

| `-- json5@0.5.0

+-- lodash@2.4.2

+-- longest@1.0.1

+-- lru-queue@0.1.0

+-- memoizee@0.3.10

+-- memory-fs@0.3.0

+-- micromatch@2.3.11

+-- mime@1.2.11

+-- minimatch@2.0.10

+-- minimist@0.0.10

+-- mkdirp@0.5.1

| `-- minimist@0.0.8

+-- nan@2.4.0

+-- next-tick@0.2.2

+-- ng-annotate@1.2.1

| `-- source-map@0.5.6

+-- ng-annotate-loader@0.0.10

| `-- source-map@0.4.2

+-- ngtemplate-loader@0.1.3

+-- node-libs-browser@0.6.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- normalize-path@2.0.1

+-- num2fraction@1.2.2

+-- object-assign@4.1.0

+-- object.omit@2.0.1

+-- observable-array@0.0.4

+-- observable-value@0.0.5

+-- once@1.4.0

+-- optimist@0.6.1

+-- ordered-ast-traverse@1.1.1

+-- ordered-esprima-props@1.1.0

+-- os-browserify@0.1.2

+-- pako@0.2.9

+-- parse-glob@3.0.4

+-- path-browserify@0.0.0

+-- path-is-absolute@1.0.1

+-- pbkdf2-compat@2.0.1

+-- phantomjs-polyfill@0.0.2

+-- postcss@4.1.16

+-- preserve@0.2.0

+-- process@0.11.9

+-- process-nextick-args@1.0.7

+-- prr@0.0.0

+-- punycode@1.4.1

+-- querystring@0.2.0

+-- querystring-es3@0.2.1

+-- randomatic@1.1.5

+-- readable-stream@2.1.5

+-- readdirp@2.1.0

| `-- minimatch@3.0.3

+-- regex-cache@0.4.3

+-- repeat-element@1.1.2

+-- repeat-string@1.6.1

+-- right-align@0.1.3

+-- ripemd160@0.2.0

+-- set-immediate-shim@1.0.1

+-- sha.js@2.2.6

+-- shelljs@0.3.0

+-- simple-fmt@0.1.0

+-- simple-is@0.2.0

+-- source-list-map@0.1.6

+-- source-map@0.4.4

+-- source-map-support@0.4.5

| `-- source-map@0.5.6

+-- stable@0.1.5

+-- stream-browserify@1.0.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- string_decoder@0.10.31

+-- stringmap@0.2.2

+-- stringset@0.2.1

+-- style-loader@0.8.3

+-- supports-color@3.1.2

+-- tapable@0.2.4

+-- ticky@1.0.1

+-- timers-browserify@1.4.2

+-- timers-ext@0.1.0

+-- tryor@0.1.2

+-- tty-browserify@0.0.0

+-- typescript@2.0.6

+-- uglify-js@2.7.4

| `-- source-map@0.5.6

+-- uglify-to-browserify@1.0.2

+-- URIjs@1.16.1

+-- url@0.10.3

| `-- punycode@1.3.2

+-- url-loader@0.5.7

+-- util@0.10.3

| `-- inherits@2.0.1

+-- util-deprecate@1.0.2

+-- vm-browserify@0.0.4

+-- watchpack@0.2.9

| `-- async@0.9.2

+-- webpack@1.13.3

| +-- acorn@3.3.0

| +-- async@1.5.2

| +-- enhanced-resolve@0.9.1

| | `-- memory-fs@0.2.0

| `-- tapable@0.1.10

+-- webpack-core@0.6.8

+-- window-size@0.1.0

+-- wordwrap@0.0.3

+-- wrappy@1.0.2

`-- yargs@3.10.0

npm WARN openproject-frontend@0.1.0 No repository field.

npm WARN openproject-frontend@0.1.0 No license field.

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.0.14 (node_modules/fsevents):

npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.0.14: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

-----> Checking startup method

Found Procfile

-----> Finalizing build

Creating runtime environment

Exporting binary paths

Cleaning npm artifacts

Cleaning previous cache

Caching results for future builds

-----> Build succeeded!

openproject@0.1.0 /tmp/d20170122-17-1hnt7d5/opt/openproject

`-- typescript@2.0.8

=====> Downloading Buildpack: https://github.com/pkgr/heroku-buildpack-ruby.git

=====> Detected Framework: Ruby

-----> Compiling Ruby/Rails

-----> Using Ruby version: ruby-2.3.1

-----> Installing dependencies using bundler 1.13.2

cp: '/tmp/d20170122-17-1hnt7d5/opt/openproject/.git/cache/vendor/bundle/.' and '/tmp/d20170122-17-1hnt7d5/opt/openproject/.git/cache/vendor/bundle/.' are the same file

Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Fetching gem metadata from https://rubygems.org/......

Fetching version metadata from https://rubygems.org/..

Fetching dependency metadata from https://rubygems.org/.

Using i18n 0.7.0

Installing minitest 5.9.0

Installing rake 11.3.0

Installing concurrent-ruby 1.0.2

Using thread_safe 0.3.5

Using erubis 2.7.0

Using mini_portile2 2.1.0

Using rack 2.0.1

Using nio4r 1.2.1

Using websocket-extensions 0.1.2

Using mime-types 2.99.3

Using method_source 0.8.2

Installing builder 3.2.2

Installing pkg-config 1.1.7

Using multi_json 1.12.1

Using acts_as_silent_list 3.0.0

Using addressable 2.4.0

Using airbrake-ruby 1.5.0

Using attr_required 1.0.1

Using execjs 2.7.0

Using ice_nine 0.11.2

Using bcrypt 3.1.11

Using bindata 2.3.4

Using sass 3.4.22

Using tilt 2.0.5

Using uber 0.0.15

Using erbse 0.0.2

Using coderay 1.1.1

Using color-tools 1.3.0

Using unf_ext 0.0.7.2

Using netrc 0.11.0

Using daemons 1.2.4

Using dalli 2.7.6

Using enumerable-lazy 0.0.1

Using equalizer 0.0.11

Using excon 0.52.0

Using ffi 1.9.14

Using formatador 0.2.5

Using ipaddress 0.8.3

Using get_process_mem 0.2.1

Using request_store 1.3.1

Using json 1.8.3

Using hashie 3.4.6

Using multi_xml 0.5.5

Using gravatar_image_tag 1.2.0

Using bundler 1.13.2

Using htmldiff 0.0.1

Installing thor 0.19.1

Using icalendar 2.3.0

Using iso8601 0.9.1

Using securecompare 1.0.0

Using url_safe_base64 0.2.2

Using kgio 2.10.0

Using mixlib-shellout 2.1.0

Using mysql2 0.4.4

Using net-ldap 0.14.0

Using newrelic_rpm 3.16.2.321

Using oj 2.17.4

Installing arel 7.1.2

Using pdf-core 0.6.1

Using ttfunk 1.4.0

Using rmagick 2.15.4

Using rubyzip 1.2.0

Using ruby-ole 1.2.12

Using pg 0.19.0

Using rails_serve_static_assets 0.0.5

Using rails_stdout_logging 0.0.5

Using raindrops 0.17.0

Using ruby-progressbar 1.8.1

Using structured_warnings 0.2.0

Using sqlite3 1.3.11

Using stringex 2.6.1

Using svg-graph 2.0.1

Using syck 1.0.5

Using will_paginate 3.1.3

Using i18n-js 3.0.0.rc14

Using tzinfo 1.2.2

Using descendants_tracker 0.0.4

Using rack-test 0.6.3

Using rack-accept 0.4.5

Using passenger 5.0.30

Using rack-attack 5.0.1

Using rack-protection 2.0.0.beta2

Using warden 1.2.6

Using websocket-driver 0.6.4

Using mail 2.6.4

Installing httpclient 2.8.2.4

Using airbrake 5.1.0

Using autoprefixer-rails 6.4.1.1

Using cells 4.1.3

Using unf 0.1.4

Using mustermann19 0.4.4

Using sys-filesystem 1.1.7

Using fog-core 1.42.0

Using rdoc 4.2.2

Using omniauth 1.3.1 from https://github.com/oliverguenther/omniauth (at 8385bc0@8385bc0)

Using bourbon 4.2.7

Installing sprockets 3.7.0

Using prawn 2.1.0

Using spreadsheet 0.8.9

Using rails_12factor 0.0.3

Using unicorn 5.1.0

Using rubytree 0.9.7

Using tzinfo-data 1.2016.6

Using axiom-types 0.1.1

Using coercible 1.0.0

Using warden-basic_auth 0.2.1

Using cells-erb 0.0.8

Using domain_name 0.5.20161129

Using fog-json 1.0.2

Using prawn-table 0.2.2

Using unicorn-worker-killer 0.4.4

Using virtus 1.0.5

Using http-cookie 1.0.3

Using rest-client 1.8.0

Using crowdin-api 0.4.1

Installing activesupport 5.0.0.1

Using globalid 0.3.7

Using climate_control 0.0.3

Using delayed_job 4.1.2

Using grape 0.17.0

Installing json-jwt 1.6.5

Installing activemodel 5.0.0.1

Using swd 1.0.1

Using webfinger 1.0.2

Using rabl 0.13.0

Using ruby-duration 3.2.3

Installing rack-oauth2 1.4.0

Installing activejob 5.0.0.1

Using cocaine 0.5.8

Using grape-cache_control 1.0.1

Using carrierwave 1.0.0.beta from https://github.com/carrierwaveuploader/carrierwave (at master@5367a63)

Using date_validator 0.9.0

Using validate_email 0.1.6

Using validate_url 1.0.2

Using openid_connect 0.8.3

Using omniauth-openid-connect 0.2.0 from https://github.com/finnlabs/omniauth-openid-connect.git (at dev@c3bce4c)

Using omniauth-openid_connect-providers 0.1.0 from https://github.com/finnlabs/omniauth-openid_connect-providers.git (at dev@86f3670)

Installing nokogiri 1.6.8 with native extensions

Installing activerecord 5.0.0.1

Using activemodel-serializers-xml 1.0.1

Using acts_as_list 0.8.1

Using acts_as_tree 2.5.1

Using awesome_nested_set 3.1.1

Using delayed_job_active_record 4.1.1

Using friendly_id 5.2.0.beta.1 from https://github.com/norman/friendly_id (at aff0564@aff0564)

Using globalize 5.1.0 from https://github.com/globalize/globalize (at 38443bc@38443bc)

Using transactional_lock 0.1.0 from https://github.com/finnlabs/transactional_lock.git (at master@6948b1d)

Using loofah 2.0.3

Using representable 2.1.8

Using fog-xml 0.1.2

Using ruby-saml 1.4.0

Using rails-html-sanitizer 1.0.3

Using disposable 0.0.9

Using roar 1.0.4

Using omniauth-saml 1.6.0 from git://github.com/omniauth/omniauth-saml.git (at master@5559d6b)

Using fog-aws 0.11.0

Using reform 1.2.6

Using openproject-auth_saml 0.1.0 from https://github.com/finnlabs/openproject-auth_saml (at dev@97212ab)

Installing rails-dom-testing 2.0.1

Installing actionview 5.0.0.1

Installing actionpack 5.0.0.1

Installing actionmailer 5.0.0.1

Installing actioncable 5.0.0.1

Using cells-rails 0.0.6

Using gon 4.1.1

Using sprockets-rails 3.2.0

Installing railties 5.0.0.1

Using actionpack-xml_parser 2.0.0

Using activerecord-session_store 1.0.0

Using jquery-tablesorter 1.22.7

Using responders 2.3.0

Using sass-rails 5.0.6

Installing rails 5.0.0.1

Using health_check 2.2.1

Using lobby_boy 0.1.2

Using openproject-auth_plugins 6.1.4 from source at `vendored-plugins/openproject-auth_plugins`

Using openproject-pdf_export 6.1.4 from source at `vendored-plugins/openproject-pdf_export`

Using openproject-costs 6.1.4 from source at `vendored-plugins/openproject-costs`

Using openproject-documents 6.1.4 from source at `vendored-plugins/openproject-documents`

Using openproject-webhooks 6.1.4 from source at `vendored-plugins/openproject-webhooks`

Using openproject-global_roles 6.1.4 from source at `vendored-plugins/openproject-global_roles`

Using openproject-local_avatars 6.1.4 from source at `vendored-plugins/openproject-local_avatars`

Using openproject-meeting 6.1.4 from source at `vendored-plugins/openproject-meeting`

Using openproject-my_project_page 6.1.4 from source at `vendored-plugins/openproject-my_project_page`

Using reporting_engine 6.1.4 from source at `vendored-plugins/reporting_engine`

Using openproject-themes-dark 6.1.4 from source at `vendored-plugins/openproject-themes-dark`

Using openproject-translations 6.1.4 from https://github.com/opf/openproject-translations.git (at stable/6@da52ff9)

Using openproject-xls_export 6.1.4 from source at `vendored-plugins/openproject-xls_export`

Using rails-angular-xss 0.3.0.pre.pre from https://github.com/opf/rails-angular-xss (at a45267d@a45267d)

Using rails_autolink 1.1.6

Using openproject-backlogs 6.1.4 from source at `vendored-plugins/openproject-backlogs`

Using openproject-openid_connect 6.1.4 from source at `vendored-plugins/openproject-openid_connect`

Using openproject-github_integration 6.1.4 from source at `vendored-plugins/openproject-github_integration`

Using openproject-reporting 6.1.4 from source at `vendored-plugins/openproject-reporting`

Bundle complete! 138 Gemfile dependencies, 195 gems now installed.

Gems in the groups development and test were not installed.

Bundled gems are installed into ./vendor/bundle.

Bundle completed (22.41s)

Cleaning up the bundler cache.

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Removing thor (0.19.4)

Removing builder (3.2.3)

Removing arel (7.1.4)

Removing concurrent-ruby (1.0.4)

Removing activerecord (5.0.1)

Removing sprockets (3.7.1)

Removing rails-dom-testing (2.0.2)

Removing actioncable (5.0.1)

Removing rails (5.0.1)

Removing actionview (5.0.1)

Removing activesupport (5.0.1)

Removing rake (12.0.0)

Removing activejob (5.0.1)

Removing railties (5.0.1)

Removing rack-oauth2 (1.5.1)

Removing minitest (5.10.1)

Removing httpclient (2.8.3)

Removing activemodel (5.0.1)

Removing actionmailer (5.0.1)

Removing json-jwt (1.7.1)

Removing openproject-token (1.0.0)

Removing nokogiri (1.6.8.1)

Removing actionpack (5.0.1)

-----> Detecting rake tasks

-----> Preparing app for Rails asset pipeline

Running: rake assets:precompile

$(npm bin)/webpack --config webpack.production.config.js

{"omniauth-openid-connect":"/tmp/d20170122-17-1hnt7d5/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid-connect-c3bce4c9e9ac","omniauth-openid_connect-providers":"/tmp/d20170122-17-1hnt7d5/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid_connect-providers-86f3670e127e","omniauth-saml":"/tmp/d20170122-17-1hnt7d5/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-saml-5559d6b80805","openproject-auth_plugins":"/tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-auth_plugins","openproject-auth_saml":"/tmp/d20170122-17-1hnt7d5/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-auth_saml-97212abb8378","openproject-pdf_export":"/tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-pdf_export","openproject-backlogs":"/tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-backlogs","openproject-costs":"/tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-costs","openproject-documents":"/tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-documents","openproject-webhooks":"/tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-webhooks","openproject-github_integration":"/tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-github_integration","openproject-global_roles":"/tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-global_roles","openproject-local_avatars":"/tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-local_avatars","openproject-meeting":"/tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-meeting","openproject-my_project_page":"/tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-my_project_page","openproject-openid_connect":"/tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-openid_connect","reporting_engine":"/tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/reporting_engine","openproject-reporting":"/tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-reporting","openproject-themes-dark":"/tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-themes-dark","openproject-translations":"/tmp/d20170122-17-1hnt7d5/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-translations-da52ff92cdcd","openproject-xls_export":"/tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-xls_export"}

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Hash: 8d3d02f710d780152f58

Version: webpack 1.13.3

Child

Hash: 8d3d02f710d780152f58

Version: webpack 1.13.3

Time: 13188ms

Asset Size Chunks Chunk Names

7b9776076d5fceef4993b55c9383dedd.gif 1.85 kB [emitted]

openproject-backlogs.js 453 kB 0 [emitted] backlogs

openproject-core-app.js 3.43 MB 1 [emitted] core-app

openproject-costs.js 526 kB 2 [emitted] costs

openproject-global.js 3.51 MB 3 [emitted] global

openproject-my_project_page.js 14.3 kB 4 [emitted] my_project_page

openproject-core-app.css 4.71 kB 1 [emitted] core-app

openproject-global.css 49 kB 3 [emitted] global

[213] ./templates \.html$ 1.22 kB {1} [built]

[242] ./components ^((?!\.(test|spec)).)*\.(js|ts|html)$ 16.1 kB {1} [built]

[633] /tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 425 bytes {2} [built]

[765] /tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 330 bytes {4} [built]

+ 769 hidden modules

ERROR in [default]

File '/tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-budget-subform.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-1hnt7d5/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-1hnt7d5/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/subform/cost-subform.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-1hnt7d5/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts' is not under 'rootDir' '/tmp/d20170122-17-1hnt7d5/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts' is not under 'rootDir' '/tmp/d20170122-17-1hnt7d5/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-block.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-1hnt7d5/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-page-layout.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-1hnt7d5/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-textile-block.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-1hnt7d5/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default] /tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:49:18

Argument of type 'string' is not assignable to parameter of type '{ [key: string]: any; }'.

ERROR in [default] /tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:53:4

Supplied parameters do not match any signature of call target.

ERROR in [default] /tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:30:38

Cannot find module 'app/components/work-packages/work-package-cache.service'.

ERROR in [default] /tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:49:30

Cannot find name 'HalResource'.

ERROR in [default] /tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:54:57

Property '$injector' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:13

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:27

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:60:11

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:70:23

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:76:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:77:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:78:16

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:36:17

Property 'value' does not exist on type 'CurrencyDisplayField'.

ERROR in [default] /tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:37:23

Property 'value' does not exist on type 'CurrencyDisplayField'.

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 5 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

autoprefixer: /tmp/d20170122-17-1hnt7d5/opt/openproject/app/assets/stylesheets/default.css.sass:6426:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-1hnt7d5/opt/openproject/app/assets/stylesheets/default.css.sass:6456:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-1hnt7d5/opt/openproject/app/assets/stylesheets/default.css.sass:11729:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-1hnt7d5/opt/openproject/app/assets/stylesheets/default.css.sass:12110:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-1hnt7d5/opt/openproject/app/assets/stylesheets/default.css.sass:12155:3: You should write display: flex by final spec instead of display: box

I, [2017-01-22T21:45:11.765678 #2687] INFO -- : Writing /tmp/d20170122-17-1hnt7d5/opt/openproject/public/assets/default-b00e18110df905a5bf6f92466cbe06ed3965967d2d5e90d24ce836de132adb64.css

I, [2017-01-22T21:45:11.766245 #2687] INFO -- : Writing /tmp/d20170122-17-1hnt7d5/opt/openproject/public/assets/default-b00e18110df905a5bf6f92466cbe06ed3965967d2d5e90d24ce836de132adb64.css.gz

I, [2017-01-22T21:45:13.899003 #2687] INFO -- : Writing /tmp/d20170122-17-1hnt7d5/opt/openproject/public/assets/application-fe2e17e17963f4fa0bbde3044ba3d3eed9bef9f808ad7342fdb05871a782e8f9.js

I, [2017-01-22T21:45:13.899399 #2687] INFO -- : Writing /tmp/d20170122-17-1hnt7d5/opt/openproject/public/assets/application-fe2e17e17963f4fa0bbde3044ba3d3eed9bef9f808ad7342fdb05871a782e8f9.js.gz

I, [2017-01-22T21:45:14.104856 #2687] INFO -- : Writing /tmp/d20170122-17-1hnt7d5/opt/openproject/public/assets/locales/fa-ddde1dd90c7cd953dfe06fe7a99c8374773412c294f93ffe9efa3414e6b62c2a.js

I, [2017-01-22T21:45:14.105174 #2687] INFO -- : Writing /tmp/d20170122-17-1hnt7d5/opt/openproject/public/assets/locales/fa-ddde1dd90c7cd953dfe06fe7a99c8374773412c294f93ffe9efa3414e6b62c2a.js.gz

I, [2017-01-22T21:45:14.117753 #2687] INFO -- : Writing /tmp/d20170122-17-1hnt7d5/opt/openproject/public/assets/locales/id-a2a805a38128ac7a7ac9f665acb2885e446ba208b069cf9378b8ec1aec800649.js

I, [2017-01-22T21:45:14.117923 #2687] INFO -- : Writing /tmp/d20170122-17-1hnt7d5/opt/openproject/public/assets/locales/id-a2a805a38128ac7a7ac9f665acb2885e446ba208b069cf9378b8ec1aec800649.js.gz

I, [2017-01-22T21:45:14.125094 #2687] INFO -- : Writing /tmp/d20170122-17-1hnt7d5/opt/openproject/public/assets/locales/it-2da9fe25a38c3b5ecc1ad49f013f4f2780e7cc8c7760e14b5e0cf9133a3ca888.js

I, [2017-01-22T21:45:14.125214 #2687] INFO -- : Writing /tmp/d20170122-17-1hnt7d5/opt/openproject/public/assets/locales/it-2da9fe25a38c3b5ecc1ad49f013f4f2780e7cc8c7760e14b5e0cf9133a3ca888.js.gz

I, [2017-01-22T21:45:14.131745 #2687] INFO -- : Writing /tmp/d20170122-17-1hnt7d5/opt/openproject/public/assets/locales/ja-f8632d5fff009c766a77c499986ac2ab325405dc4f1bf26622ae18f9ce8792a8.js

I, [2017-01-22T21:45:14.131857 #2687] INFO -- : Writing /tmp/d20170122-17-1hnt7d5/opt/openproject/public/assets/locales/ja-f8632d5fff009c766a77c499986ac2ab325405dc4f1bf26622ae18f9ce8792a8.js.gz

I, [2017-01-22T21:45:14.144395 #2687] INFO -- : Writing /tmp/d20170122-17-1hnt7d5/opt/openproject/public/assets/locales/nl-e7e1a58e4a0fe3814cc911c20cd36192bb5110c5ac32a7e583e9d4d177bd693e.js

I, [2017-01-22T21:45:14.144557 #2687] INFO -- : Writing /tmp/d20170122-17-1hnt7d5/opt/openproject/public/assets/locales/nl-e7e1a58e4a0fe3814cc911c20cd36192bb5110c5ac32a7e583e9d4d177bd693e.js.gz

autoprefixer: /tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:6446:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:6476:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:11749:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:12130:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-1hnt7d5/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:12175:3: You should write display: flex by final spec instead of display: box

I, [2017-01-22T21:45:28.616762 #2687] INFO -- : Writing /tmp/d20170122-17-1hnt7d5/opt/openproject/public/assets/dark-feeac1abf7e73be6eb6d80d8a8f8e5b9bf79b47ce3eba05b133e96395d495c5a.css

I, [2017-01-22T21:45:28.617094 #2687] INFO -- : Writing /tmp/d20170122-17-1hnt7d5/opt/openproject/public/assets/dark-feeac1abf7e73be6eb6d80d8a8f8e5b9bf79b47ce3eba05b133e96395d495c5a.css.gz

Asset precompilation completed (57.66s)

Cleaning assets

Running: rake assets:clean

I, [2017-01-22T21:45:38.440645 #2919] INFO -- : Removed locales/fa-0dbf392eccd6c0bdd63cfadefebb8a9b2ae0ffc90b91c905764f3b009aecb046.js

I, [2017-01-22T21:45:38.446569 #2919] INFO -- : Removed locales/id-a7c8c482240a4e457ff26930c4a800331ec9a565832f4a26b05aa189e690b876.js

I, [2017-01-22T21:45:38.451566 #2919] INFO -- : Removed locales/it-7e1d737729288534422df10d26c1b9357bd99ef564864ac74c1080c53037c9a5.js

I, [2017-01-22T21:45:38.456607 #2919] INFO -- : Removed locales/ja-90d4866d75e8e5c66cb904ef183adae9eb1ec8ea412d548a25b9f8b367258fdf.js

I, [2017-01-22T21:45:38.465709 #2919] INFO -- : Removed default-270b9c30b239e0622b55c68a93351ad8b56bde4af52e9dc6dee3ed4d7e1124b5.css

I, [2017-01-22T21:45:38.470902 #2919] INFO -- : Removed locales/nl-3f2643487cd26bc712d2d53bade04dcfbf8de02db124d1453990847eac991965.js

I, [2017-01-22T21:45:38.476512 #2919] INFO -- : Removed dark-681a673a66ecee6ff638adb9b42edc00086247fb6aa9dc57b93483f16f574571.css

I, [2017-01-22T21:45:38.482000 #2919] INFO -- : Removed application-ccd94b50703f598615de05ad1c31a2df32e0e765783c0dc6bf194345afdfd574.js

Using release configuration from last framework (Ruby).

-----> [cron] /opt/openproject/packaging/cron/openproject-clear-old-sessions => /etc/cron.d/openproject-clear-old-sessions

-----> Verifying package openproject_6.1.4-1485121203.2cb8b63.jessie_amd64.deb

NEW PACKAGE: openproject_6.1.4-1485121203.2cb8b63.jessie_amd64.deb (291.49 MiB)

-----> Releasing...

DONE!

====== Attempt #1

-----> Fetching repository

Cloning into '/tmp/d20170122-16665-sp02q6/input'...

-----> Restoring cache

-----> Starting packaging process

-----> Installing missing build dependencies: timezone

-----> [wizard] adding legacy-installer wizard (https://github.com/pkgr/addon-legacy-installer#master)

-----> [wizard] adding mysql wizard (https://github.com/pkgr/addon-mysql#master)

-----> [wizard] adding apache2 wizard (https://github.com/pkgr/addon-apache2#master)

-----> [wizard] adding repositories wizard (https://github.com/finnlabs/addon-repositories#master)

-----> [wizard] adding smtp wizard (https://github.com/pkgr/addon-smtp#master)

-----> [wizard] adding memcached wizard (https://github.com/pkgr/addon-memcached#master)

-----> [wizard] adding openproject wizard (https://github.com/pkgr/addon-openproject#master)

-----> Fetching buildpack https://github.com/opf/heroku-buildpack-multi.git at master

-----> Multipack app

-----> Running hook: "packaging/setup"

WARNING: This buildpack is no longer maintained.

Please choose a different buildpack or go to https://github.com/ddollar/heroku-buildpack-multi

and fork it to your own account.

=====> Downloading Buildpack: https://github.com/pkgr/pkgr-buildpack-imagemagick.git

=====> Detected Framework: ImageMagick

% Total % Received % Xferd Average Speed Time Time Time Current

Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0 0 10.0M 0 16363 0 0 58790 0 0:02:59 --:--:-- 0:02:59 114k 57 10.0M 57 5915k 0 0 4615k 0 0:00:02 0:00:01 0:00:01 5180k 100 10.0M 100 10.0M 0 0 6070k 0 0:00:01 0:00:01 --:--:-- 6611k

=====> Downloading Buildpack: https://github.com/heroku/heroku-buildpack-nodejs.git

=====> Detected Framework: Node.js

-----> Reading application state

package.json...

build directory...

cache directory...

environment variables...

Node engine: 6.9.1

Npm engine: 4.0.0

Start mechanism: Procfile

node_modules source: package.json

node_modules cached: true

NPM_CONFIG_PRODUCTION=true

NODE_MODULES_CACHE=true

-----> Installing binaries

Downloading and installing node 6.9.1...

Downloading and installing npm 4.0.0 (replacing version 3.10.8)...

-----> Building dependencies

Restoring node modules from cache

Pruning unused dependencies

Installing any new modules

> openproject@0.1.0 postinstall /tmp/d20170122-17-r0um0x/opt/openproject

> cd frontend && npm install

> openproject-frontend@0.1.0 postinstall /tmp/d20170122-17-r0um0x/opt/openproject/frontend

> bower install --config.interactive=false

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 not-cached git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolve git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de not-cached git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolve git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 not-cached git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolve git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 checkout d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower select2#3.5.2 not-cached https://github.com/ivaynberg/select2.git#3.5.2

bower select2#3.5.2 resolve https://github.com/ivaynberg/select2.git#3.5.2

bower jquery#1.11.0 not-cached https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery#1.11.0 resolve https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery-ujs#1.0.0 not-cached https://github.com/rails/jquery-ujs.git#1.0.0

bower jquery-ujs#1.0.0 resolve https://github.com/rails/jquery-ujs.git#1.0.0

bower jquery-ui#~1.10.4 not-cached https://github.com/components/jqueryui.git#~1.10.4

bower jquery-ui#~1.10.4 resolve https://github.com/components/jqueryui.git#~1.10.4

bower angular-ui-router#~0.3.1 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-ui-router#~0.3.1 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower jquery.atwho#0.5.1 not-cached https://github.com/ichord/At.js.git#0.5.1

bower jquery.atwho#0.5.1 resolve https://github.com/ichord/At.js.git#0.5.1

bower angular-i18n#~1.5.5 not-cached https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-i18n#~1.5.5 resolve https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-sanitize#~1.5.8 not-cached https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-sanitize#~1.5.8 resolve https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-animate#~1.5.8 not-cached https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-animate#~1.5.8 resolve https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-elastic#~2.5.1 not-cached https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-elastic#~2.5.1 resolve https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular#~1.5.8 not-cached https://github.com/angular/bower-angular.git#~1.5.8

bower angular#~1.5.8 resolve https://github.com/angular/bower-angular.git#~1.5.8

bower angular-cache#~4.6.0 not-cached https://github.com/jmdobry/angular-cache.git#~4.6.0

bower angular-cache#~4.6.0 resolve https://github.com/jmdobry/angular-cache.git#~4.6.0

bower moment#~2.10.6 not-cached https://github.com/moment/moment.git#~2.10.6

bower moment#~2.10.6 resolve https://github.com/moment/moment.git#~2.10.6

bower moment-timezone#0.4.x not-cached https://github.com/moment/moment-timezone.git#0.4.x

bower moment-timezone#0.4.x resolve https://github.com/moment/moment-timezone.git#0.4.x

bower angular-aria#~1.5.8 not-cached https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-aria#~1.5.8 resolve https://github.com/angular/bower-angular-aria.git#~1.5.8

bower mousetrap#~1.4.6 not-cached https://github.com/ccampbell/mousetrap.git#~1.4.6

bower mousetrap#~1.4.6 resolve https://github.com/ccampbell/mousetrap.git#~1.4.6

bower angular-busy#~4.1.3 not-cached https://github.com/cgross/angular-busy.git#~4.1.3

bower angular-busy#~4.1.3 resolve https://github.com/cgross/angular-busy.git#~4.1.3

bower jquery-migrate#~1.2.1 not-cached https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower jquery-migrate#~1.2.1 resolve https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower lodash#~2.4.1 not-cached https://github.com/lodash/lodash.git#~2.4.1

bower lodash#~2.4.1 resolve https://github.com/lodash/lodash.git#~2.4.1

bower rxjs#^4.1.0 not-cached https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower rxjs#^4.1.0 resolve https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower foundation-apps#1.1.0 not-cached https://github.com/zurb/foundation-apps.git#1.1.0

bower foundation-apps#1.1.0 resolve https://github.com/zurb/foundation-apps.git#1.1.0

bower bourbon#~4.2.1 not-cached https://github.com/thoughtbot/bourbon.git#~4.2.1

bower bourbon#~4.2.1 resolve https://github.com/thoughtbot/bourbon.git#~4.2.1

bower mocha#~1.14.0 not-cached https://github.com/mochajs/mocha.git#~1.14.0

bower mocha#~1.14.0 resolve https://github.com/mochajs/mocha.git#~1.14.0

bower ng-dialog#^0.6.2 not-cached https://github.com/likeastore/ngDialog.git#^0.6.2

bower ng-dialog#^0.6.2 resolve https://github.com/likeastore/ngDialog.git#^0.6.2

bower angular-mocks#~1.5.8 not-cached https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower angular-mocks#~1.5.8 resolve https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower angular-dragula#^1.2.8 not-cached https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower angular-dragula#^1.2.8 resolve https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower chai#~1.9.0 not-cached https://github.com/chaijs/chai.git#~1.9.0

bower chai#~1.9.0 resolve https://github.com/chaijs/chai.git#~1.9.0

bower jquery-mockjax#~1.5.3 not-cached https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery-mockjax#~1.5.3 resolve https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower angular-ui-select#~0.19.4 not-cached https://github.com/angular-ui/ui-select.git#~0.19.4

bower angular-ui-select#~0.19.4 resolve https://github.com/angular-ui/ui-select.git#~0.19.4

bower ng-file-upload#~5.0.9 not-cached https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower ng-file-upload#~5.0.9 resolve https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de checkout fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 checkout a908eccaec323cd66973d58af4965694bdff16a1

bower jquery#1.11.0 checkout 1.11.0

bower select2#3.5.2 checkout 3.5.2

bower jquery-ui#~1.10.4 checkout 1.10.4

bower jquery-ujs#1.0.0 checkout v1.0.0

bower angular-ui-router#~0.3.1 checkout 0.3.2

bower angular-i18n#~1.5.5 checkout v1.5.11

bower angular-elastic#~2.5.1 checkout v2.5.1

bower angular-cache#~4.6.0 checkout 4.6.0

bower angular-animate#~1.5.8 checkout v1.5.11

bower angular-sanitize#~1.5.8 checkout v1.5.11

bower angular-busy#~4.1.3 checkout v4.1.4

bower angular-aria#~1.5.8 checkout v1.5.11

bower moment#~2.10.6 checkout 2.10.6

bower jquery.atwho#0.5.1 checkout v0.5.1

bower mousetrap#~1.4.6 checkout 1.4.6

bower angular#~1.5.8 checkout v1.5.11

bower ng-dialog#^0.6.2 checkout v0.6.6

bower mocha#~1.14.0 checkout 1.14.0

bower foundation-apps#1.1.0 checkout v1.1.0

bower lodash#~2.4.1 checkout 2.4.2

bower moment-timezone#0.4.x checkout 0.4.1

bower angular-dragula#^1.2.8 checkout v1.2.8

bower jquery-mockjax#~1.5.3 checkout v1.5.4

bower chai#~1.9.0 checkout 1.9.2

bower angular-mocks#~1.5.8 checkout v1.5.11

bower ng-file-upload#~5.0.9 checkout 5.0.9

bower angular-ui-select#~0.19.4 checkout v0.19.6

bower bourbon#~4.2.1 checkout v4.2.7

bower rxjs#^4.1.0 checkout v4.1.0

bower jquery-migrate#~1.2.1 checkout 1.2.1

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolved git://github.com/nickmessing/angular-context-menu.git#a908eccaec

bower angular#>= 1.2.5 not-cached https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 resolve https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 checkout v1.6.1

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolved git://github.com/finnlabs/angular-modal.git#d45eb9ceb7

bower angular#^1.3.0 not-cached https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 resolve https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 checkout v1.6.1

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .png files: ["select2.png","select2x2.png"]

bower select2#3.5.2 resolved https://github.com/ivaynberg/select2.git#3.5.2

bower jquery-ui#~1.10.4 resolved https://github.com/components/jqueryui.git#1.10.4

bower jquery-ujs#1.0.0 resolved https://github.com/rails/jquery-ujs.git#1.0.0

bower angular-ui-router#~0.3.1 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.3.2

bower jquery#1.11.0 resolved https://github.com/jquery/jquery-dist.git#1.11.0

bower angular-animate#~1.5.8 resolved https://github.com/angular/bower-angular-animate.git#1.5.11

bower angular-sanitize#~1.5.8 resolved https://github.com/angular/bower-angular-sanitize.git#1.5.11

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolved git://github.com/sparkalow/angular-truncate.git#fdf60fda26

bower angular-elastic#~2.5.1 resolved https://github.com/monospaced/angular-elastic.git#2.5.1

bower angular#>=1.0.6 not-cached https://github.com/angular/bower-angular.git#>=1.0.6

bower angular#>=1.0.6 resolve https://github.com/angular/bower-angular.git#>=1.0.6

bower angular#>=1.0.6 checkout v1.6.1

bower angular-cache#~4.6.0 resolved https://github.com/jmdobry/angular-cache.git#4.6.0

bower angular#>=1.x not-cached https://github.com/angular/bower-angular.git#>=1.x

bower angular#>=1.x resolve https://github.com/angular/bower-angular.git#>=1.x

bower angular#>=1.x checkout v1.6.1

bower jquery.atwho#0.5.1 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower mousetrap#~1.4.6 resolved https://github.com/ccampbell/mousetrap.git#1.4.6

bower angular-aria#~1.5.8 resolved https://github.com/angular/bower-angular-aria.git#1.5.11

bower angular-busy#~4.1.3 resolved https://github.com/cgross/angular-busy.git#4.1.4

bower angular#>=1.3 not-cached https://github.com/angular/bower-angular.git#>=1.3

bower angular#>=1.3 resolve https://github.com/angular/bower-angular.git#>=1.3

bower angular#>=1.3 checkout v1.6.1

bower jquery.atwho#0.5.1 resolved https://github.com/ichord/At.js.git#0.5.1

bower ng-dialog#^0.6.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .css files: ["css/ngDialog.css","css/ngDialog-theme-default.css"]

bower Caret.js#>= 0.2.0 not-cached https://github.com/ichord/Caret.js.git#>= 0.2.0

bower Caret.js#>= 0.2.0 resolve https://github.com/ichord/Caret.js.git#>= 0.2.0

bower ng-dialog#^0.6.2 resolved https://github.com/likeastore/ngDialog.git#0.6.6

bower angular#>=1.5 not-cached https://github.com/angular/bower-angular.git#>=1.5

bower angular#>=1.5 resolve https://github.com/angular/bower-angular.git#>=1.5

bower angular#>=1.5 checkout v1.6.1

bower angular#~1.5.8 resolved https://github.com/angular/bower-angular.git#1.5.11

bower mocha#~1.14.0 mismatch Version declared in the json (1.12.0) is different than the resolved one (1.14.0)

bower mocha#~1.14.0 resolved https://github.com/mochajs/mocha.git#1.14.0

bower lodash#~2.4.1 resolved https://github.com/lodash/lodash.git#2.4.2

bower foundation-apps#1.1.0 resolved https://github.com/zurb/foundation-apps.git#1.1.0

bower angular#~1.3.4 not-cached https://github.com/angular/bower-angular.git#~1.3.4

bower angular#~1.3.4 resolve https://github.com/angular/bower-angular.git#~1.3.4

bower angular-ui-router#~0.2.12 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-ui-router#~0.2.12 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-animate#~1.3.4 not-cached https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular-animate#~1.3.4 resolve https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular#~1.3.4 checkout v1.3.20

bower angular-ui-router#~0.2.12 checkout 0.2.18

bower angular-animate#~1.3.4 checkout v1.3.20

bower moment-timezone#0.4.x progress Receiving objects: 8% (57/708)

bower angular-dragula#^1.2.8 resolved https://github.com/bevacqua/angular-dragula.git#1.2.8

bower angular-mocks#~1.5.8 resolved https://github.com/angular/bower-angular-mocks.git#1.5.11

bower fastclick#~1.0.3 not-cached https://github.com/ftlabs/fastclick.git#~1.0.3

bower fastclick#~1.0.3 resolve https://github.com/ftlabs/fastclick.git#~1.0.3

bower hammerjs#~2.0.4 not-cached https://github.com/EightMedia/hammer.js.git#~2.0.4

bower hammerjs#~2.0.4 resolve https://github.com/EightMedia/hammer.js.git#~2.0.4

bower viewport-units-buggyfill#~0.4.1 not-cached https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower viewport-units-buggyfill#~0.4.1 resolve https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower jquery-mockjax#~1.5.3 resolved https://github.com/jakerella/jquery-mockjax.git#1.5.4

bower tether#~0.6.5 not-cached https://github.com/HubSpot/tether.git#~0.6.5

bower tether#~0.6.5 resolve https://github.com/HubSpot/tether.git#~0.6.5

bower chai#~1.9.0 resolved https://github.com/chaijs/chai.git#1.9.2

bower moment#~2.10.6 resolved https://github.com/moment/moment.git#2.10.6

bower moment-timezone#0.4.x resolved https://github.com/moment/moment-timezone.git#0.4.1

bower jquery-migrate#~1.2.1 deprecated Package jquery-migrate is using the deprecated component.json

bower ng-file-upload#~5.0.9 resolved https://github.com/danialfarid/angular-file-upload-bower.git#5.0.9

bower jquery-migrate#~1.2.1 resolved https://github.com/appleboy/jquery-migrate.git#1.2.1

bower angular-ui-select#~0.19.4 resolved https://github.com/angular-ui/ui-select.git#0.19.6

bower bourbon#~4.2.1 resolved https://github.com/thoughtbot/bourbon.git#4.2.7

bower angular-i18n#~1.5.5 resolved https://github.com/angular/bower-angular-i18n.git#1.5.11

bower rxjs#^4.1.0 progress Receiving objects: 14% (280/1996)

bower angular#>= 1.2.5 resolved https://github.com/angular/bower-angular.git#1.6.1

bower angular#^1.3.0 resolved https://github.com/angular/bower-angular.git#1.6.1

bower Caret.js#>= 0.2.0 checkout v0.3.1

bower angular#>=1.0.6 resolved https://github.com/angular/bower-angular.git#1.6.1

bower angular#>=1.x resolved https://github.com/angular/bower-angular.git#1.6.1

bower angular-ui-router#~0.2.12 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.2.18

bower fastclick#~1.0.3 checkout v1.0.6

bower viewport-units-buggyfill#~0.4.1 checkout v0.4.1

bower hammerjs#~2.0.4 checkout v2.0.8

bower rxjs#^4.1.0 resolved https://github.com/Reactive-Extensions/RxJS.git#4.1.0

bower angular#>=1.3 resolved https://github.com/angular/bower-angular.git#1.6.1

bower tether#~0.6.5 checkout v0.6.5

bower angular-animate#~1.3.4 resolved https://github.com/angular/bower-angular-animate.git#1.3.20

bower angular#~1.3.4 resolved https://github.com/angular/bower-angular.git#1.3.20

bower angular#>=1.5 resolved https://github.com/angular/bower-angular.git#1.6.1

bower Caret.js#>= 0.2.0 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower Caret.js#>= 0.2.0 resolved https://github.com/ichord/Caret.js.git#0.3.1

bower fastclick#~1.0.3 resolved https://github.com/ftlabs/fastclick.git#1.0.6

bower viewport-units-buggyfill#~0.4.1 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .js files: ["./viewport-units-buggyfill.js","./viewport-units-buggyfill.hacks.js"]

bower viewport-units-buggyfill#~0.4.1 resolved https://github.com/rodneyrehm/viewport-units-buggyfill.git#0.4.1

bower hammerjs#~2.0.4 resolved https://github.com/EightMedia/hammer.js.git#2.0.8

bower tether#~0.6.5 resolved https://github.com/HubSpot/tether.git#0.6.5

Please note that,

foundation-apps#1.1.0 depends on angular-ui-router#~0.2.12 which resolved to angular-ui-router#0.2.18

openproject depends on angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Resort to using angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Code incompatibilities may occur.

Please note that,

foundation-apps#1.1.0 depends on angular-animate#~1.3.4 which resolved to angular-animate#1.3.20

openproject depends on angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

angular-busy#4.1.4 depends on angular-animate#>=1.3 which resolved to angular-animate#1.5.11

Resort to using angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

Code incompatibilities may occur.

Please note that,

angular-animate#1.3.20 depends on angular#1.3.20 which resolved to angular#1.3.20

foundation-apps#1.1.0 depends on angular#~1.3.4 which resolved to angular#1.3.20

angular-animate#1.5.11, angular-aria#1.5.11, angular-mocks#1.5.11, angular-sanitize#1.5.11 depends on angular#1.5.11 which resolved to angular#1.5.11

angular-ui-router#0.3.2, angular-ui-router#0.2.18 depends on angular#^1.0.8 which resolved to angular#1.5.11

angular-ui-select#0.19.6 depends on angular#>=1.2.18 which resolved to angular#1.5.11

openproject depends on angular#~1.5.8 which resolved to angular#1.5.11

angular-context-menu#a908eccaec depends on angular#>= 1.2.5 which resolved to angular#1.6.1

angular-modal#d45eb9ceb7 depends on angular#^1.3.0 which resolved to angular#1.6.1

angular-cache#4.6.0 depends on angular#>=1.x which resolved to angular#1.6.1

ng-dialog#0.6.6 depends on angular#>=1.5 which resolved to angular#1.6.1

angular-busy#4.1.4 depends on angular#>=1.3 which resolved to angular#1.6.1

angular-elastic#2.5.1 depends on angular#>=1.0.6 which resolved to angular#1.6.1

Resort to using angular#~1.5.8 which resolved to angular#1.5.11

Code incompatibilities may occur.

bower jquery extra-resolution Unnecessary resolution: jquery#1.11.0

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 install angular-context-menu#a908eccaec

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 install angular-modal#d45eb9ceb7

bower select2#3.5.2 install select2#3.5.2

bower jquery-ui#~1.10.4 install jquery-ui#1.10.4

bower jquery-ujs#1.0.0 install jquery-ujs#1.0.0

bower angular-ui-router#~0.3.1 install angular-ui-router#0.3.2

bower jquery#1.11.0 install jquery#1.11.0

bower angular-animate#~1.5.8 install angular-animate#1.5.11

bower angular-sanitize#~1.5.8 install angular-sanitize#1.5.11

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de install angular-truncate#fdf60fda26

bower angular-elastic#~2.5.1 install angular-elastic#2.5.1

bower angular-cache#~4.6.0 install angular-cache#4.6.0

bower mousetrap#~1.4.6 install mousetrap#1.4.6

bower angular-aria#~1.5.8 install angular-aria#1.5.11

bower angular-busy#~4.1.3 install angular-busy#4.1.4

bower jquery.atwho#0.5.1 install jquery.atwho#0.5.1

bower ng-dialog#^0.6.2 install ng-dialog#0.6.6

bower angular#1.5.11 install angular#1.5.11

bower mocha#~1.14.0 install mocha#1.14.0

bower lodash#~2.4.1 install lodash#2.4.2

bower foundation-apps#1.1.0 install foundation-apps#1.1.0

bower angular-dragula#^1.2.8 install angular-dragula#1.2.8

bower angular-mocks#~1.5.8 install angular-mocks#1.5.11

bower jquery-mockjax#~1.5.3 install jquery-mockjax#1.5.4

bower chai#~1.9.0 install chai#1.9.2

bower moment#~2.10.6 install moment#2.10.6

bower moment-timezone#0.4.x install moment-timezone#0.4.1

bower ng-file-upload#~5.0.9 install ng-file-upload#5.0.9

bower jquery-migrate#~1.2.1 install jquery-migrate#1.2.1

bower angular-ui-select#~0.19.4 install angular-ui-select#0.19.6

bower bourbon#~4.2.1 install bourbon#4.2.7

bower angular-i18n#~1.5.5 install angular-i18n#1.5.11

bower rxjs#^4.1.0 install rxjs#4.1.0

bower Caret.js#>= 0.2.0 install Caret.js#0.3.1

bower fastclick#~1.0.3 install fastclick#1.0.6

bower viewport-units-buggyfill#~0.4.1 install viewport-units-buggyfill#0.4.1

bower hammerjs#~2.0.4 install hammerjs#2.0.8

bower tether#~0.6.5 install tether#0.6.5

angular-context-menu#a908eccaec bower_components/angular-context-menu

└── angular#1.5.11

angular-modal#d45eb9ceb7 bower_components/angular-modal

└── angular#1.5.11

select2#3.5.2 bower_components/select2

└── jquery#1.11.0

jquery-ui#1.10.4 bower_components/jquery-ui

└── jquery#1.11.0

jquery-ujs#1.0.0 bower_components/jquery-ujs

└── jquery#1.11.0

angular-ui-router#0.3.2 bower_components/angular-ui-router

└── angular#1.5.11

jquery#1.11.0 bower_components/jquery

angular-animate#1.5.11 bower_components/angular-animate

└── angular#1.5.11

angular-sanitize#1.5.11 bower_components/angular-sanitize

└── angular#1.5.11

angular-truncate#fdf60fda26 bower_components/angular-truncate

angular-elastic#2.5.1 bower_components/angular-elastic

└── angular#1.5.11

angular-cache#4.6.0 bower_components/angular-cache

└── angular#1.5.11

mousetrap#1.4.6 bower_components/mousetrap

angular-aria#1.5.11 bower_components/angular-aria

└── angular#1.5.11

angular-busy#4.1.4 bower_components/angular-busy

├── angular#1.5.11

└── angular-animate#1.5.11

jquery.atwho#0.5.1 bower_components/jquery.atwho

├── Caret.js#0.3.1

└── jquery#1.11.0

ng-dialog#0.6.6 bower_components/ng-dialog

└── angular#1.5.11

angular#1.5.11 bower_components/angular

mocha#1.14.0 bower_components/mocha

lodash#2.4.2 bower_components/lodash

foundation-apps#1.1.0 bower_components/foundation-apps

├── angular#1.5.11

├── angular-animate#1.5.11

├── angular-ui-router#0.3.2

├── fastclick#1.0.6

├── hammerjs#2.0.8

├── tether#0.6.5

└── viewport-units-buggyfill#0.4.1

angular-dragula#1.2.8 bower_components/angular-dragula

angular-mocks#1.5.11 bower_components/angular-mocks

└── angular#1.5.11

jquery-mockjax#1.5.4 bower_components/jquery-mockjax

chai#1.9.2 bower_components/chai

moment#2.10.6 bower_components/moment

moment-timezone#0.4.1 bower_components/moment-timezone

└── moment#2.10.6

ng-file-upload#5.0.9 bower_components/ng-file-upload

jquery-migrate#1.2.1 bower_components/jquery-migrate

angular-ui-select#0.19.6 bower_components/angular-ui-select

└── angular#1.5.11

bourbon#4.2.7 bower_components/bourbon

angular-i18n#1.5.11 bower_components/angular-i18n

rxjs#4.1.0 bower_components/rxjs

Caret.js#0.3.1 bower_components/Caret.js

└── jquery#1.11.0

fastclick#1.0.6 bower_components/fastclick

viewport-units-buggyfill#0.4.1 bower_components/viewport-units-buggyfill

hammerjs#2.0.8 bower_components/hammerjs

tether#0.6.5 bower_components/tether

openproject-frontend@0.1.0 /tmp/d20170122-17-r0um0x/opt/openproject/frontend

+-- acorn@2.6.4

+-- align-text@0.1.4

+-- alter@0.2.0

+-- amdefine@1.0.0

+-- angular@1.5.8

+-- angular-elastic@2.5.1

+-- angular-ui-bootstrap@2.2.0

+-- anymatch@1.3.0

+-- arr-diff@2.0.0

+-- arr-flatten@1.0.1

+-- array-unique@0.2.1

+-- arrify@1.0.1

+-- assert@1.4.1

+-- async@0.2.10

+-- async-each@1.0.1

+-- atoa@1.0.0

+-- autoprefixer-core@5.2.1

+-- autoprefixer-loader@1.2.0

+-- awesome-typescript-loader@2.2.4

| `-- lodash@4.16.4

+-- balanced-match@0.4.2

+-- Base64@0.2.1

+-- base64-js@1.2.0

+-- big.js@3.1.3

+-- binary-extensions@1.7.0

+-- bower@1.7.9

+-- brace-expansion@1.1.6

+-- braces@1.8.5

+-- browserify-zlib@0.1.4

+-- browserslist@0.4.0

+-- buffer@4.9.1

+-- buffer-shims@1.0.0

+-- camelcase@1.2.1

+-- caniuse-db@1.0.30000569

+-- center-align@0.1.3

+-- chokidar@1.6.1

+-- cliui@2.1.0

| `-- wordwrap@0.0.2

+-- clone@1.0.2

+-- colors@1.1.2

+-- concat-map@0.0.1

+-- console-browserify@1.1.0

+-- constants-browserify@0.0.1

+-- contra@1.9.4

+-- convert-source-map@1.1.3

+-- core-util-is@1.0.2

+-- crossvent@1.5.4

+-- crypto-browserify@3.2.8

+-- css-loader@0.9.1

| `-- source-map@0.1.43

+-- csso@1.3.12

+-- custom-event@1.0.0

+-- d@0.1.1

+-- date-now@0.1.4

+-- decamelize@1.2.0

+-- domain-browser@1.1.7

+-- dragula@3.7.2

+-- emojis-list@2.1.0

+-- enhanced-resolve@2.3.0

+-- errno@0.1.4

+-- es5-ext@0.10.12

+-- es6-iterator@2.0.0

+-- es6-promise@2.3.0

+-- es6-symbol@3.1.0

+-- es6-weak-map@0.1.4

| +-- es6-iterator@0.1.3

| `-- es6-symbol@2.0.1

+-- event-emitter@0.3.4

+-- events@1.1.1

+-- expand-brackets@0.1.5

+-- expand-range@1.8.2

+-- exports-loader@0.6.3

| `-- source-map@0.1.43

+-- expose-loader@0.6.0

+-- extglob@0.3.2

+-- extract-text-webpack-plugin@0.3.8

| `-- source-map@0.1.43

+-- fastparse@1.1.1

+-- file-loader@0.8.5

+-- filename-regex@2.0.0

+-- fill-range@2.2.3

+-- for-in@0.1.6

+-- for-own@0.1.4

+-- glob@4.5.3

+-- glob-base@0.3.0

+-- glob-parent@2.0.0

+-- graceful-fs@4.1.9

+-- has-flag@1.0.0

+-- html-loader@0.2.3

| `-- source-map@0.1.43

+-- html-minifier@0.5.6

+-- http-browserify@1.7.0

+-- https-browserify@0.0.0

+-- ieee754@1.1.8

+-- indexof@0.0.1

+-- inflight@1.0.6

+-- inherits@2.0.3

+-- interpret@0.6.6

+-- is-binary-path@1.0.1

+-- is-buffer@1.1.4

+-- is-dotfile@1.0.2

+-- is-equal-shallow@0.1.3

+-- is-extendable@0.1.1

+-- is-extglob@1.0.0

+-- is-glob@2.0.1

+-- is-number@2.1.0

+-- is-posix-bracket@0.1.1

+-- is-primitive@2.0.0

+-- isarray@1.0.0

+-- isobject@2.1.0

+-- js-base64@2.1.9

+-- json5@0.4.0

+-- kind-of@3.0.4

+-- lazy-cache@1.0.4

+-- loader-utils@0.2.16

| `-- json5@0.5.0

+-- lodash@2.4.2

+-- longest@1.0.1

+-- lru-queue@0.1.0

+-- memoizee@0.3.10

+-- memory-fs@0.3.0

+-- micromatch@2.3.11

+-- mime@1.2.11

+-- minimatch@2.0.10

+-- minimist@0.0.10

+-- mkdirp@0.5.1

| `-- minimist@0.0.8

+-- nan@2.4.0

+-- next-tick@0.2.2

+-- ng-annotate@1.2.1

| `-- source-map@0.5.6

+-- ng-annotate-loader@0.0.10

| `-- source-map@0.4.2

+-- ngtemplate-loader@0.1.3

+-- node-libs-browser@0.6.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- normalize-path@2.0.1

+-- num2fraction@1.2.2

+-- object-assign@4.1.0

+-- object.omit@2.0.1

+-- observable-array@0.0.4

+-- observable-value@0.0.5

+-- once@1.4.0

+-- optimist@0.6.1

+-- ordered-ast-traverse@1.1.1

+-- ordered-esprima-props@1.1.0

+-- os-browserify@0.1.2

+-- pako@0.2.9

+-- parse-glob@3.0.4

+-- path-browserify@0.0.0

+-- path-is-absolute@1.0.1

+-- pbkdf2-compat@2.0.1

+-- phantomjs-polyfill@0.0.2

+-- postcss@4.1.16

+-- preserve@0.2.0

+-- process@0.11.9

+-- process-nextick-args@1.0.7

+-- prr@0.0.0

+-- punycode@1.4.1

+-- querystring@0.2.0

+-- querystring-es3@0.2.1

+-- randomatic@1.1.5

+-- readable-stream@2.1.5

+-- readdirp@2.1.0

| `-- minimatch@3.0.3

+-- regex-cache@0.4.3

+-- repeat-element@1.1.2

+-- repeat-string@1.6.1

+-- right-align@0.1.3

+-- ripemd160@0.2.0

+-- set-immediate-shim@1.0.1

+-- sha.js@2.2.6

+-- shelljs@0.3.0

+-- simple-fmt@0.1.0

+-- simple-is@0.2.0

+-- source-list-map@0.1.6

+-- source-map@0.4.4

+-- source-map-support@0.4.5

| `-- source-map@0.5.6

+-- stable@0.1.5

+-- stream-browserify@1.0.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- string_decoder@0.10.31

+-- stringmap@0.2.2

+-- stringset@0.2.1

+-- style-loader@0.8.3

+-- supports-color@3.1.2

+-- tapable@0.2.4

+-- ticky@1.0.1

+-- timers-browserify@1.4.2

+-- timers-ext@0.1.0

+-- tryor@0.1.2

+-- tty-browserify@0.0.0

+-- typescript@2.0.6

+-- uglify-js@2.7.4

| `-- source-map@0.5.6

+-- uglify-to-browserify@1.0.2

+-- URIjs@1.16.1

+-- url@0.10.3

| `-- punycode@1.3.2

+-- url-loader@0.5.7

+-- util@0.10.3

| `-- inherits@2.0.1

+-- util-deprecate@1.0.2

+-- vm-browserify@0.0.4

+-- watchpack@0.2.9

| `-- async@0.9.2

+-- webpack@1.13.3

| +-- acorn@3.3.0

| +-- async@1.5.2

| +-- enhanced-resolve@0.9.1

| | `-- memory-fs@0.2.0

| `-- tapable@0.1.10

+-- webpack-core@0.6.8

+-- window-size@0.1.0

+-- wordwrap@0.0.3

+-- wrappy@1.0.2

`-- yargs@3.10.0

npm WARN openproject-frontend@0.1.0 No repository field.

npm WARN openproject-frontend@0.1.0 No license field.

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.0.14 (node_modules/fsevents):

npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.0.14: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

-----> Checking startup method

Found Procfile

-----> Finalizing build

Creating runtime environment

Exporting binary paths

Cleaning npm artifacts

Cleaning previous cache

Caching results for future builds

-----> Build succeeded!

openproject@0.1.0 /tmp/d20170122-17-r0um0x/opt/openproject

`-- typescript@2.0.8

=====> Downloading Buildpack: https://github.com/pkgr/heroku-buildpack-ruby.git

=====> Detected Framework: Ruby

-----> Compiling Ruby/Rails

-----> Using Ruby version: ruby-2.3.1

-----> Installing dependencies using bundler 1.13.2

cp: `/tmp/d20170122-17-r0um0x/opt/openproject/.git/cache/vendor/bundle/.' and `/tmp/d20170122-17-r0um0x/opt/openproject/.git/cache/vendor/bundle/.' are the same file

Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Fetching gem metadata from https://rubygems.org/......

Fetching version metadata from https://rubygems.org/..

Fetching dependency metadata from https://rubygems.org/.

Using i18n 0.7.0

Installing minitest 5.9.0

Installing rake 11.3.0

Using thread_safe 0.3.5

Installing concurrent-ruby 1.0.2

Using erubis 2.7.0

Using mini_portile2 2.1.0

Using rack 2.0.1

Using nio4r 1.2.1

Using websocket-extensions 0.1.2

Using mime-types 2.99.3

Using method_source 0.8.2

Installing builder 3.2.2

Installing pkg-config 1.1.7

Using multi_json 1.12.1

Using acts_as_silent_list 3.0.0

Using addressable 2.4.0

Using airbrake-ruby 1.5.0

Using attr_required 1.0.1

Using execjs 2.7.0

Using ice_nine 0.11.2

Using bcrypt 3.1.11

Using bindata 2.3.4

Using sass 3.4.22

Using tilt 2.0.5

Using uber 0.0.15

Using erbse 0.0.2

Using coderay 1.1.1

Using color-tools 1.3.0

Using unf_ext 0.0.7.2

Using netrc 0.11.0

Using daemons 1.2.4

Using dalli 2.7.6

Using enumerable-lazy 0.0.1

Using equalizer 0.0.11

Using excon 0.52.0

Using ffi 1.9.14

Installing thor 0.19.1

Using formatador 0.2.5

Using ipaddress 0.8.3

Using get_process_mem 0.2.1

Using request_store 1.3.1

Using json 1.8.3

Using hashie 3.4.6

Using multi_xml 0.5.5

Using gravatar_image_tag 1.2.0

Using bundler 1.13.2

Using htmldiff 0.0.1

Installing arel 7.1.2

Using icalendar 2.3.0

Using iso8601 0.9.1

Using securecompare 1.0.0

Using url_safe_base64 0.2.2

Using kgio 2.10.0

Using mixlib-shellout 2.1.0

Using mysql2 0.4.4

Using net-ldap 0.14.0

Using newrelic_rpm 3.16.2.321

Using oj 2.17.4

Using pdf-core 0.6.1

Using ttfunk 1.4.0

Using rmagick 2.15.4

Using rubyzip 1.2.0

Using ruby-ole 1.2.12

Using pg 0.19.0

Using rails_serve_static_assets 0.0.5

Using rails_stdout_logging 0.0.5

Using raindrops 0.17.0

Using ruby-progressbar 1.8.1

Using structured_warnings 0.2.0

Using sqlite3 1.3.11

Using stringex 2.6.1

Using svg-graph 2.0.1

Using syck 1.0.5

Using will_paginate 3.1.3

Using i18n-js 3.0.0.rc14

Using tzinfo 1.2.2

Using descendants_tracker 0.0.4

Using rack-test 0.6.3

Using rack-accept 0.4.5

Using passenger 5.0.30

Using rack-attack 5.0.1

Using rack-protection 2.0.0.beta2

Using warden 1.2.6

Using websocket-driver 0.6.4

Using mail 2.6.4

Installing httpclient 2.8.2.4

Using airbrake 5.1.0

Using autoprefixer-rails 6.4.1.1

Using cells 4.1.3

Using unf 0.1.4

Using mustermann19 0.4.4

Using sys-filesystem 1.1.7

Using fog-core 1.42.0

Using rdoc 4.2.2

Using omniauth 1.3.1 from https://github.com/oliverguenther/omniauth (at 8385bc0@8385bc0)

Using prawn 2.1.0

Using spreadsheet 0.8.9

Using rails_12factor 0.0.3

Using unicorn 5.1.0

Using rubytree 0.9.7

Installing sprockets 3.7.0

Using tzinfo-data 1.2016.6

Using axiom-types 0.1.1

Using coercible 1.0.0

Using bourbon 4.2.7

Using warden-basic_auth 0.2.1

Using cells-erb 0.0.8

Using domain_name 0.5.20161129

Using fog-json 1.0.2

Using prawn-table 0.2.2

Using unicorn-worker-killer 0.4.4

Using virtus 1.0.5

Using http-cookie 1.0.3

Using rest-client 1.8.0

Using crowdin-api 0.4.1

Installing activesupport 5.0.0.1

Using globalid 0.3.7

Using climate_control 0.0.3

Using delayed_job 4.1.2

Using grape 0.17.0

Installing nokogiri 1.6.8 with native extensions

Installing json-jwt 1.6.5

Installing activemodel 5.0.0.1

Using swd 1.0.1

Using webfinger 1.0.2

Using rabl 0.13.0

Using ruby-duration 3.2.3

Installing rack-oauth2 1.4.0

Using cocaine 0.5.8

Using grape-cache_control 1.0.1

Installing activejob 5.0.0.1

Using carrierwave 1.0.0.beta from https://github.com/carrierwaveuploader/carrierwave (at master@5367a63)

Installing activerecord 5.0.0.1

Using date_validator 0.9.0

Using validate_email 0.1.6

Using validate_url 1.0.2

Using activemodel-serializers-xml 1.0.1

Using acts_as_list 0.8.1

Using acts_as_tree 2.5.1

Using awesome_nested_set 3.1.1

Using delayed_job_active_record 4.1.1

Using friendly_id 5.2.0.beta.1 from https://github.com/norman/friendly_id (at aff0564@aff0564)

Using globalize 5.1.0 from https://github.com/globalize/globalize (at 38443bc@38443bc)

Using transactional_lock 0.1.0 from https://github.com/finnlabs/transactional_lock.git (at master@6948b1d)

Using openid_connect 0.8.3

Using omniauth-openid-connect 0.2.0 from https://github.com/finnlabs/omniauth-openid-connect.git (at dev@c3bce4c)

Using omniauth-openid_connect-providers 0.1.0 from https://github.com/finnlabs/omniauth-openid_connect-providers.git (at dev@86f3670)

Using loofah 2.0.3

Using representable 2.1.8

Using fog-xml 0.1.2

Using ruby-saml 1.4.0

Using rails-html-sanitizer 1.0.3

Using disposable 0.0.9

Using roar 1.0.4

Using fog-aws 0.11.0

Using omniauth-saml 1.6.0 from git://github.com/omniauth/omniauth-saml.git (at master@5559d6b)

Using reform 1.2.6

Using openproject-auth_saml 0.1.0 from https://github.com/finnlabs/openproject-auth_saml (at dev@97212ab)

Installing rails-dom-testing 2.0.1

Installing actionview 5.0.0.1

Installing actionpack 5.0.0.1

Installing actionmailer 5.0.0.1

Using cells-rails 0.0.6

Using gon 4.1.1

Using sprockets-rails 3.2.0

Installing actioncable 5.0.0.1

Installing railties 5.0.0.1

Using actionpack-xml_parser 2.0.0

Using activerecord-session_store 1.0.0

Using jquery-tablesorter 1.22.7

Using responders 2.3.0

Using sass-rails 5.0.6

Installing rails 5.0.0.1

Using health_check 2.2.1

Using lobby_boy 0.1.2

Using openproject-auth_plugins 6.1.4 from source at `vendored-plugins/openproject-auth_plugins`

Using openproject-pdf_export 6.1.4 from source at `vendored-plugins/openproject-pdf_export`

Using openproject-costs 6.1.4 from source at `vendored-plugins/openproject-costs`

Using openproject-documents 6.1.4 from source at `vendored-plugins/openproject-documents`

Using openproject-webhooks 6.1.4 from source at `vendored-plugins/openproject-webhooks`

Using openproject-global_roles 6.1.4 from source at `vendored-plugins/openproject-global_roles`

Using openproject-local_avatars 6.1.4 from source at `vendored-plugins/openproject-local_avatars`

Using openproject-meeting 6.1.4 from source at `vendored-plugins/openproject-meeting`

Using openproject-my_project_page 6.1.4 from source at `vendored-plugins/openproject-my_project_page`

Using reporting_engine 6.1.4 from source at `vendored-plugins/reporting_engine`

Using openproject-themes-dark 6.1.4 from source at `vendored-plugins/openproject-themes-dark`

Using openproject-translations 6.1.4 from https://github.com/opf/openproject-translations.git (at stable/6@da52ff9)

Using openproject-xls_export 6.1.4 from source at `vendored-plugins/openproject-xls_export`

Using rails-angular-xss 0.3.0.pre.pre from https://github.com/opf/rails-angular-xss (at a45267d@a45267d)

Using rails_autolink 1.1.6

Using openproject-backlogs 6.1.4 from source at `vendored-plugins/openproject-backlogs`

Using openproject-openid_connect 6.1.4 from source at `vendored-plugins/openproject-openid_connect`

Using openproject-github_integration 6.1.4 from source at `vendored-plugins/openproject-github_integration`

Using openproject-reporting 6.1.4 from source at `vendored-plugins/openproject-reporting`

Bundle complete! 138 Gemfile dependencies, 195 gems now installed.

Gems in the groups development and test were not installed.

Bundled gems are installed into ./vendor/bundle.

Bundle completed (15.15s)

Cleaning up the bundler cache.

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Removing thor (0.19.4)

Removing builder (3.2.3)

Removing arel (7.1.4)

Removing concurrent-ruby (1.0.4)

Removing activerecord (5.0.1)

Removing sprockets (3.7.1)

Removing rails-dom-testing (2.0.2)

Removing actioncable (5.0.1)

Removing rails (5.0.1)

Removing actionview (5.0.1)

Removing activesupport (5.0.1)

Removing rake (12.0.0)

Removing activejob (5.0.1)

Removing railties (5.0.1)

Removing rack-oauth2 (1.5.1)

Removing minitest (5.10.1)

Removing httpclient (2.8.3)

Removing activemodel (5.0.1)

Removing actionmailer (5.0.1)

Removing json-jwt (1.7.1)

Removing openproject-token (1.0.0)

Removing nokogiri (1.6.8.1)

Removing actionpack (5.0.1)

-----> Detecting rake tasks

-----> Preparing app for Rails asset pipeline

Running: rake assets:precompile

$(npm bin)/webpack --config webpack.production.config.js

{"omniauth-openid-connect":"/tmp/d20170122-17-r0um0x/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid-connect-c3bce4c9e9ac","omniauth-openid_connect-providers":"/tmp/d20170122-17-r0um0x/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid_connect-providers-86f3670e127e","omniauth-saml":"/tmp/d20170122-17-r0um0x/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-saml-5559d6b80805","openproject-auth_plugins":"/tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-auth_plugins","openproject-auth_saml":"/tmp/d20170122-17-r0um0x/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-auth_saml-97212abb8378","openproject-pdf_export":"/tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-pdf_export","openproject-backlogs":"/tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-backlogs","openproject-costs":"/tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-costs","openproject-documents":"/tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-documents","openproject-webhooks":"/tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-webhooks","openproject-github_integration":"/tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-github_integration","openproject-global_roles":"/tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-global_roles","openproject-local_avatars":"/tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-local_avatars","openproject-meeting":"/tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-meeting","openproject-my_project_page":"/tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-my_project_page","openproject-openid_connect":"/tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-openid_connect","reporting_engine":"/tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/reporting_engine","openproject-reporting":"/tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-reporting","openproject-themes-dark":"/tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-themes-dark","openproject-translations":"/tmp/d20170122-17-r0um0x/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-translations-da52ff92cdcd","openproject-xls_export":"/tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-xls_export"}

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Hash: b90aa7f8a278d6b5152e

Version: webpack 1.13.3

Child

Hash: b90aa7f8a278d6b5152e

Version: webpack 1.13.3

Time: 13883ms

Asset Size Chunks Chunk Names

7b9776076d5fceef4993b55c9383dedd.gif 1.85 kB [emitted]

openproject-backlogs.js 453 kB 0 [emitted] backlogs

openproject-core-app.js 3.43 MB 1 [emitted] core-app

openproject-costs.js 526 kB 2 [emitted] costs

openproject-global.js 3.51 MB 3 [emitted] global

openproject-my_project_page.js 14.3 kB 4 [emitted] my_project_page

openproject-core-app.css 4.71 kB 1 [emitted] core-app

openproject-global.css 49 kB 3 [emitted] global

[213] ./templates \.html$ 1.22 kB {1} [built]

[242] ./components ^((?!\.(test|spec)).)*\.(js|ts|html)$ 16.1 kB {1} [built]

[633] /tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 425 bytes {2} [built]

[765] /tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 330 bytes {4} [built]

+ 769 hidden modules

ERROR in [default]

File '/tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-budget-subform.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-r0um0x/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-r0um0x/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/subform/cost-subform.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-r0um0x/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts' is not under 'rootDir' '/tmp/d20170122-17-r0um0x/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts' is not under 'rootDir' '/tmp/d20170122-17-r0um0x/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-block.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-r0um0x/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-page-layout.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-r0um0x/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-textile-block.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-r0um0x/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default] /tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:49:18

Argument of type 'string' is not assignable to parameter of type '{ [key: string]: any; }'.

ERROR in [default] /tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:53:4

Supplied parameters do not match any signature of call target.

ERROR in [default] /tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:30:38

Cannot find module 'app/components/work-packages/work-package-cache.service'.

ERROR in [default] /tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:49:30

Cannot find name 'HalResource'.

ERROR in [default] /tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:54:57

Property '$injector' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:13

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:27

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:60:11

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:70:23

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:76:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:77:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:78:16

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:36:17

Property 'value' does not exist on type 'CurrencyDisplayField'.

ERROR in [default] /tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:37:23

Property 'value' does not exist on type 'CurrencyDisplayField'.

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 5 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

autoprefixer: /tmp/d20170122-17-r0um0x/opt/openproject/app/assets/stylesheets/default.css.sass:6426:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-r0um0x/opt/openproject/app/assets/stylesheets/default.css.sass:6456:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-r0um0x/opt/openproject/app/assets/stylesheets/default.css.sass:11729:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-r0um0x/opt/openproject/app/assets/stylesheets/default.css.sass:12110:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-r0um0x/opt/openproject/app/assets/stylesheets/default.css.sass:12155:3: You should write display: flex by final spec instead of display: box

I, [2017-01-22T21:55:32.015040 #2390] INFO -- : Writing /tmp/d20170122-17-r0um0x/opt/openproject/public/assets/default-b00e18110df905a5bf6f92466cbe06ed3965967d2d5e90d24ce836de132adb64.css

I, [2017-01-22T21:55:32.016119 #2390] INFO -- : Writing /tmp/d20170122-17-r0um0x/opt/openproject/public/assets/default-b00e18110df905a5bf6f92466cbe06ed3965967d2d5e90d24ce836de132adb64.css.gz

I, [2017-01-22T21:55:33.951415 #2390] INFO -- : Writing /tmp/d20170122-17-r0um0x/opt/openproject/public/assets/application-c933f224e8bf6487553e0734a3a712e8b65ff0bc7594586152c1a9ce89f73ca6.js

I, [2017-01-22T21:55:33.951827 #2390] INFO -- : Writing /tmp/d20170122-17-r0um0x/opt/openproject/public/assets/application-c933f224e8bf6487553e0734a3a712e8b65ff0bc7594586152c1a9ce89f73ca6.js.gz

I, [2017-01-22T21:55:34.010533 #2390] INFO -- : Writing /tmp/d20170122-17-r0um0x/opt/openproject/public/assets/locales/fa-ddde1dd90c7cd953dfe06fe7a99c8374773412c294f93ffe9efa3414e6b62c2a.js

I, [2017-01-22T21:55:34.010752 #2390] INFO -- : Writing /tmp/d20170122-17-r0um0x/opt/openproject/public/assets/locales/fa-ddde1dd90c7cd953dfe06fe7a99c8374773412c294f93ffe9efa3414e6b62c2a.js.gz

I, [2017-01-22T21:55:34.025868 #2390] INFO -- : Writing /tmp/d20170122-17-r0um0x/opt/openproject/public/assets/locales/id-a2a805a38128ac7a7ac9f665acb2885e446ba208b069cf9378b8ec1aec800649.js

I, [2017-01-22T21:55:34.026091 #2390] INFO -- : Writing /tmp/d20170122-17-r0um0x/opt/openproject/public/assets/locales/id-a2a805a38128ac7a7ac9f665acb2885e446ba208b069cf9378b8ec1aec800649.js.gz

I, [2017-01-22T21:55:34.033436 #2390] INFO -- : Writing /tmp/d20170122-17-r0um0x/opt/openproject/public/assets/locales/it-2da9fe25a38c3b5ecc1ad49f013f4f2780e7cc8c7760e14b5e0cf9133a3ca888.js

I, [2017-01-22T21:55:34.033594 #2390] INFO -- : Writing /tmp/d20170122-17-r0um0x/opt/openproject/public/assets/locales/it-2da9fe25a38c3b5ecc1ad49f013f4f2780e7cc8c7760e14b5e0cf9133a3ca888.js.gz

I, [2017-01-22T21:55:34.041389 #2390] INFO -- : Writing /tmp/d20170122-17-r0um0x/opt/openproject/public/assets/locales/ja-f8632d5fff009c766a77c499986ac2ab325405dc4f1bf26622ae18f9ce8792a8.js

I, [2017-01-22T21:55:34.041547 #2390] INFO -- : Writing /tmp/d20170122-17-r0um0x/opt/openproject/public/assets/locales/ja-f8632d5fff009c766a77c499986ac2ab325405dc4f1bf26622ae18f9ce8792a8.js.gz

I, [2017-01-22T21:55:34.054912 #2390] INFO -- : Writing /tmp/d20170122-17-r0um0x/opt/openproject/public/assets/locales/nl-e7e1a58e4a0fe3814cc911c20cd36192bb5110c5ac32a7e583e9d4d177bd693e.js

I, [2017-01-22T21:55:34.055238 #2390] INFO -- : Writing /tmp/d20170122-17-r0um0x/opt/openproject/public/assets/locales/nl-e7e1a58e4a0fe3814cc911c20cd36192bb5110c5ac32a7e583e9d4d177bd693e.js.gz

autoprefixer: /tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:6446:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:6476:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:11749:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:12130:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-r0um0x/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:12175:3: You should write display: flex by final spec instead of display: box

I, [2017-01-22T21:55:48.145445 #2390] INFO -- : Writing /tmp/d20170122-17-r0um0x/opt/openproject/public/assets/dark-feeac1abf7e73be6eb6d80d8a8f8e5b9bf79b47ce3eba05b133e96395d495c5a.css

I, [2017-01-22T21:55:48.145826 #2390] INFO -- : Writing /tmp/d20170122-17-r0um0x/opt/openproject/public/assets/dark-feeac1abf7e73be6eb6d80d8a8f8e5b9bf79b47ce3eba05b133e96395d495c5a.css.gz

Asset precompilation completed (62.43s)

Cleaning assets

Running: rake assets:clean

I, [2017-01-22T21:55:56.458426 #2622] INFO -- : Removed locales/fa-0dbf392eccd6c0bdd63cfadefebb8a9b2ae0ffc90b91c905764f3b009aecb046.js

I, [2017-01-22T21:55:56.464852 #2622] INFO -- : Removed locales/id-a7c8c482240a4e457ff26930c4a800331ec9a565832f4a26b05aa189e690b876.js

I, [2017-01-22T21:55:56.470214 #2622] INFO -- : Removed locales/it-7e1d737729288534422df10d26c1b9357bd99ef564864ac74c1080c53037c9a5.js

I, [2017-01-22T21:55:56.475945 #2622] INFO -- : Removed locales/ja-90d4866d75e8e5c66cb904ef183adae9eb1ec8ea412d548a25b9f8b367258fdf.js

I, [2017-01-22T21:55:56.486005 #2622] INFO -- : Removed default-270b9c30b239e0622b55c68a93351ad8b56bde4af52e9dc6dee3ed4d7e1124b5.css

I, [2017-01-22T21:55:56.497426 #2622] INFO -- : Removed locales/nl-3f2643487cd26bc712d2d53bade04dcfbf8de02db124d1453990847eac991965.js

I, [2017-01-22T21:55:56.503326 #2622] INFO -- : Removed dark-681a673a66ecee6ff638adb9b42edc00086247fb6aa9dc57b93483f16f574571.css

I, [2017-01-22T21:55:56.508831 #2622] INFO -- : Removed application-3e2c7ceba189e1a8687e0a1842ad402386f99080b1ce3c64335930f6583d4456.js

Using release configuration from last framework (Ruby).

-----> [cron] /opt/openproject/packaging/cron/openproject-clear-old-sessions => /etc/cron.d/openproject-clear-old-sessions

NEW PACKAGE: openproject-6.1.4-1485121203.2cb8b63.sles11.x86_64.rpm (294.32 MiB)

-----> Releasing...

DONE!

====== Attempt #1

-----> Fetching repository

Cloning into '/tmp/d20170122-16665-yw8xcf/input'...

-----> Restoring cache

-----> Starting packaging process

-----> Installing missing build dependencies: gcc-c++, readline-devel, libxml2-devel, libxslt-devel, libevent-devel, libmysqlclient-devel, sqlite3-devel, timezone, kernel-devel, postgresql-devel, ImageMagick-devel

-----> [wizard] adding legacy-installer wizard (https://github.com/pkgr/addon-legacy-installer#master)

-----> [wizard] adding mysql wizard (https://github.com/pkgr/addon-mysql#master)

-----> [wizard] adding apache2 wizard (https://github.com/pkgr/addon-apache2#master)

-----> [wizard] adding repositories wizard (https://github.com/finnlabs/addon-repositories#master)

-----> [wizard] adding smtp wizard (https://github.com/pkgr/addon-smtp#master)

-----> [wizard] adding memcached wizard (https://github.com/pkgr/addon-memcached#master)

-----> [wizard] adding openproject wizard (https://github.com/pkgr/addon-openproject#master)

-----> Fetching buildpack https://github.com/opf/heroku-buildpack-multi.git at master

-----> Multipack app

-----> Running hook: "packaging/setup"

WARNING: This buildpack is no longer maintained.

Please choose a different buildpack or go to https://github.com/ddollar/heroku-buildpack-multi

and fork it to your own account.

=====> Downloading Buildpack: https://github.com/pkgr/pkgr-buildpack-imagemagick.git

=====> Detected Framework: ImageMagick

-----> SKIP

=====> Downloading Buildpack: https://github.com/heroku/heroku-buildpack-nodejs.git

=====> Detected Framework: Node.js

-----> Reading application state

package.json...

build directory...

cache directory...

environment variables...

Node engine: 6.9.1

Npm engine: 4.0.0

Start mechanism: Procfile

node_modules source: package.json

node_modules cached: true

NPM_CONFIG_PRODUCTION=true

NODE_MODULES_CACHE=true

-----> Installing binaries

Downloading and installing node 6.9.1...

Downloading and installing npm 4.0.0 (replacing version 3.10.8)...

-----> Building dependencies

Restoring node modules from cache

Pruning unused dependencies

Installing any new modules

> openproject@0.1.0 postinstall /tmp/d20170122-18-1qtslcz/opt/openproject

> cd frontend && npm install

> openproject-frontend@0.1.0 postinstall /tmp/d20170122-18-1qtslcz/opt/openproject/frontend

> bower install --config.interactive=false

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 not-cached git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolve git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de not-cached git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolve git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 not-cached git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolve git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 checkout d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower jquery#1.11.0 not-cached https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery#1.11.0 resolve https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery-ui#~1.10.4 not-cached https://github.com/components/jqueryui.git#~1.10.4

bower jquery-ui#~1.10.4 resolve https://github.com/components/jqueryui.git#~1.10.4

bower jquery-ujs#1.0.0 not-cached https://github.com/rails/jquery-ujs.git#1.0.0

bower jquery-ujs#1.0.0 resolve https://github.com/rails/jquery-ujs.git#1.0.0

bower angular-animate#~1.5.8 not-cached https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-animate#~1.5.8 resolve https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular#~1.5.8 not-cached https://github.com/angular/bower-angular.git#~1.5.8

bower angular#~1.5.8 resolve https://github.com/angular/bower-angular.git#~1.5.8

bower angular-aria#~1.5.8 not-cached https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-aria#~1.5.8 resolve https://github.com/angular/bower-angular-aria.git#~1.5.8

bower jquery.atwho#0.5.1 not-cached https://github.com/ichord/At.js.git#0.5.1

bower jquery.atwho#0.5.1 resolve https://github.com/ichord/At.js.git#0.5.1

bower angular-ui-router#~0.3.1 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-ui-router#~0.3.1 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-i18n#~1.5.5 not-cached https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-i18n#~1.5.5 resolve https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-sanitize#~1.5.8 not-cached https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-sanitize#~1.5.8 resolve https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-elastic#~2.5.1 not-cached https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-elastic#~2.5.1 resolve https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-cache#~4.6.0 not-cached https://github.com/jmdobry/angular-cache.git#~4.6.0

bower angular-cache#~4.6.0 resolve https://github.com/jmdobry/angular-cache.git#~4.6.0

bower moment#~2.10.6 not-cached https://github.com/moment/moment.git#~2.10.6

bower moment#~2.10.6 resolve https://github.com/moment/moment.git#~2.10.6

bower jquery-migrate#~1.2.1 not-cached https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower jquery-migrate#~1.2.1 resolve https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower angular-busy#~4.1.3 not-cached https://github.com/cgross/angular-busy.git#~4.1.3

bower angular-busy#~4.1.3 resolve https://github.com/cgross/angular-busy.git#~4.1.3

bower moment-timezone#0.4.x not-cached https://github.com/moment/moment-timezone.git#0.4.x

bower moment-timezone#0.4.x resolve https://github.com/moment/moment-timezone.git#0.4.x

bower lodash#~2.4.1 not-cached https://github.com/lodash/lodash.git#~2.4.1

bower lodash#~2.4.1 resolve https://github.com/lodash/lodash.git#~2.4.1

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de checkout fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 checkout a908eccaec323cd66973d58af4965694bdff16a1

bower bourbon#~4.2.1 not-cached https://github.com/thoughtbot/bourbon.git#~4.2.1

bower bourbon#~4.2.1 resolve https://github.com/thoughtbot/bourbon.git#~4.2.1

bower foundation-apps#1.1.0 not-cached https://github.com/zurb/foundation-apps.git#1.1.0

bower foundation-apps#1.1.0 resolve https://github.com/zurb/foundation-apps.git#1.1.0

bower angular-ui-select#~0.19.4 not-cached https://github.com/angular-ui/ui-select.git#~0.19.4

bower angular-ui-select#~0.19.4 resolve https://github.com/angular-ui/ui-select.git#~0.19.4

bower rxjs#^4.1.0 not-cached https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower rxjs#^4.1.0 resolve https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower ng-file-upload#~5.0.9 not-cached https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower ng-file-upload#~5.0.9 resolve https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower mousetrap#~1.4.6 not-cached https://github.com/ccampbell/mousetrap.git#~1.4.6

bower mousetrap#~1.4.6 resolve https://github.com/ccampbell/mousetrap.git#~1.4.6

bower mocha#~1.14.0 not-cached https://github.com/mochajs/mocha.git#~1.14.0

bower mocha#~1.14.0 resolve https://github.com/mochajs/mocha.git#~1.14.0

bower ng-dialog#^0.6.2 not-cached https://github.com/likeastore/ngDialog.git#^0.6.2

bower ng-dialog#^0.6.2 resolve https://github.com/likeastore/ngDialog.git#^0.6.2

bower angular-dragula#^1.2.8 not-cached https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower angular-dragula#^1.2.8 resolve https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower chai#~1.9.0 not-cached https://github.com/chaijs/chai.git#~1.9.0

bower chai#~1.9.0 resolve https://github.com/chaijs/chai.git#~1.9.0

bower angular-mocks#~1.5.8 not-cached https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower angular-mocks#~1.5.8 resolve https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower jquery-mockjax#~1.5.3 not-cached https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery-mockjax#~1.5.3 resolve https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery-ui#~1.10.4 checkout 1.10.4

bower jquery#1.11.0 checkout 1.11.0

bower jquery-ujs#1.0.0 checkout v1.0.0

bower angular-animate#~1.5.8 checkout v1.5.11

bower angular-ui-router#~0.3.1 checkout 0.3.2

bower jquery.atwho#0.5.1 checkout v0.5.1

bower angular-aria#~1.5.8 checkout v1.5.11

bower angular-cache#~4.6.0 checkout 4.6.0

bower angular-elastic#~2.5.1 checkout v2.5.1

bower angular#~1.5.8 checkout v1.5.11

bower angular-busy#~4.1.3 checkout v4.1.4

bower jquery-migrate#~1.2.1 checkout 1.2.1

bower moment#~2.10.6 checkout 2.10.6

bower angular-sanitize#~1.5.8 checkout v1.5.11

bower angular-i18n#~1.5.5 checkout v1.5.11

bower angular-ui-select#~0.19.4 checkout v0.19.6

bower foundation-apps#1.1.0 checkout v1.1.0

bower bourbon#~4.2.1 checkout v4.2.7

bower lodash#~2.4.1 checkout 2.4.2

bower moment-timezone#0.4.x checkout 0.4.1

bower mousetrap#~1.4.6 checkout 1.4.6

bower ng-file-upload#~5.0.9 checkout 5.0.9

bower rxjs#^4.1.0 checkout v4.1.0

bower mocha#~1.14.0 checkout 1.14.0

bower ng-dialog#^0.6.2 checkout v0.6.6

bower angular-dragula#^1.2.8 checkout v1.2.8

bower chai#~1.9.0 checkout 1.9.2

bower jquery-mockjax#~1.5.3 checkout v1.5.4

bower angular-mocks#~1.5.8 checkout v1.5.11

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolved git://github.com/nickmessing/angular-context-menu.git#a908eccaec

bower angular#>= 1.2.5 not-cached https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 resolve https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 checkout v1.6.1

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolved git://github.com/finnlabs/angular-modal.git#d45eb9ceb7

bower angular#^1.3.0 not-cached https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 resolve https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 checkout v1.6.1

bower select2#3.5.2 not-cached https://github.com/ivaynberg/select2.git#3.5.2

bower select2#3.5.2 resolve https://github.com/ivaynberg/select2.git#3.5.2

bower jquery-ui#~1.10.4 resolved https://github.com/components/jqueryui.git#1.10.4

bower angular-animate#~1.5.8 resolved https://github.com/angular/bower-angular-animate.git#1.5.11

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolved git://github.com/sparkalow/angular-truncate.git#fdf60fda26

bower jquery.atwho#0.5.1 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower angular-aria#~1.5.8 resolved https://github.com/angular/bower-angular-aria.git#1.5.11

bower jquery-ujs#1.0.0 resolved https://github.com/rails/jquery-ujs.git#1.0.0

bower angular-elastic#~2.5.1 resolved https://github.com/monospaced/angular-elastic.git#2.5.1

bower angular#>=1.0.6 not-cached https://github.com/angular/bower-angular.git#>=1.0.6

bower angular#>=1.0.6 resolve https://github.com/angular/bower-angular.git#>=1.0.6

bower angular#>=1.0.6 checkout v1.6.1

bower angular#~1.5.8 resolved https://github.com/angular/bower-angular.git#1.5.11

bower jquery-migrate#~1.2.1 deprecated Package jquery-migrate is using the deprecated component.json

bower jquery-migrate#~1.2.1 resolved https://github.com/appleboy/jquery-migrate.git#1.2.1

bower angular-ui-router#~0.3.1 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.3.2

bower jquery.atwho#0.5.1 resolved https://github.com/ichord/At.js.git#0.5.1

bower angular-cache#~4.6.0 resolved https://github.com/jmdobry/angular-cache.git#4.6.0

bower jquery#1.11.0 resolved https://github.com/jquery/jquery-dist.git#1.11.0

bower angular-sanitize#~1.5.8 resolved https://github.com/angular/bower-angular-sanitize.git#1.5.11

bower Caret.js#>= 0.2.0 not-cached https://github.com/ichord/Caret.js.git#>= 0.2.0

bower Caret.js#>= 0.2.0 resolve https://github.com/ichord/Caret.js.git#>= 0.2.0

bower angular-busy#~4.1.3 resolved https://github.com/cgross/angular-busy.git#4.1.4

bower angular-ui-select#~0.19.4 resolved https://github.com/angular-ui/ui-select.git#0.19.6

bower moment#~2.10.6 resolved https://github.com/moment/moment.git#2.10.6

bower bourbon#~4.2.1 resolved https://github.com/thoughtbot/bourbon.git#4.2.7

bower foundation-apps#1.1.0 resolved https://github.com/zurb/foundation-apps.git#1.1.0

bower angular#~1.3.4 not-cached https://github.com/angular/bower-angular.git#~1.3.4

bower angular#~1.3.4 resolve https://github.com/angular/bower-angular.git#~1.3.4

bower angular-ui-router#~0.2.12 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-ui-router#~0.2.12 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-animate#~1.3.4 not-cached https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular-animate#~1.3.4 resolve https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular#~1.3.4 checkout v1.3.20

bower angular-ui-router#~0.2.12 checkout 0.2.18

bower angular-animate#~1.3.4 checkout v1.3.20

bower mousetrap#~1.4.6 resolved https://github.com/ccampbell/mousetrap.git#1.4.6

bower ng-file-upload#~5.0.9 resolved https://github.com/danialfarid/angular-file-upload-bower.git#5.0.9

bower tether#~0.6.5 not-cached https://github.com/HubSpot/tether.git#~0.6.5

bower tether#~0.6.5 resolve https://github.com/HubSpot/tether.git#~0.6.5

bower viewport-units-buggyfill#~0.4.1 not-cached https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower viewport-units-buggyfill#~0.4.1 resolve https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower lodash#~2.4.1 resolved https://github.com/lodash/lodash.git#2.4.2

bower hammerjs#~2.0.4 not-cached https://github.com/EightMedia/hammer.js.git#~2.0.4

bower hammerjs#~2.0.4 resolve https://github.com/EightMedia/hammer.js.git#~2.0.4

bower fastclick#~1.0.3 not-cached https://github.com/ftlabs/fastclick.git#~1.0.3

bower fastclick#~1.0.3 resolve https://github.com/ftlabs/fastclick.git#~1.0.3

bower moment-timezone#0.4.x resolved https://github.com/moment/moment-timezone.git#0.4.1

bower ng-dialog#^0.6.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .css files: ["css/ngDialog.css","css/ngDialog-theme-default.css"]

bower ng-dialog#^0.6.2 resolved https://github.com/likeastore/ngDialog.git#0.6.6

bower mocha#~1.14.0 mismatch Version declared in the json (1.12.0) is different than the resolved one (1.14.0)

bower mocha#~1.14.0 resolved https://github.com/mochajs/mocha.git#1.14.0

bower angular-dragula#^1.2.8 resolved https://github.com/bevacqua/angular-dragula.git#1.2.8

bower chai#~1.9.0 resolved https://github.com/chaijs/chai.git#1.9.2

bower jquery-mockjax#~1.5.3 resolved https://github.com/jakerella/jquery-mockjax.git#1.5.4

bower select2#3.5.2 checkout 3.5.2

bower angular-mocks#~1.5.8 resolved https://github.com/angular/bower-angular-mocks.git#1.5.11

bower angular-i18n#~1.5.5 resolved https://github.com/angular/bower-angular-i18n.git#1.5.11

bower Caret.js#>= 0.2.0 checkout v0.3.1

bower angular#>= 1.2.5 resolved https://github.com/angular/bower-angular.git#1.6.1

bower angular#^1.3.0 resolved https://github.com/angular/bower-angular.git#1.6.1

bower tether#~0.6.5 checkout v0.6.5

bower angular-ui-router#~0.2.12 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.2.18

bower viewport-units-buggyfill#~0.4.1 checkout v0.4.1

bower hammerjs#~2.0.4 checkout v2.0.8

bower fastclick#~1.0.3 checkout v1.0.6

bower rxjs#^4.1.0 resolved https://github.com/Reactive-Extensions/RxJS.git#4.1.0

bower angular-animate#~1.3.4 resolved https://github.com/angular/bower-angular-animate.git#1.3.20

bower angular#~1.3.4 resolved https://github.com/angular/bower-angular.git#1.3.20

bower angular#>=1.0.6 resolved https://github.com/angular/bower-angular.git#1.6.1

bower Caret.js#>= 0.2.0 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .png files: ["select2.png","select2x2.png"]

bower select2#3.5.2 resolved https://github.com/ivaynberg/select2.git#3.5.2

bower Caret.js#>= 0.2.0 resolved https://github.com/ichord/Caret.js.git#0.3.1

bower tether#~0.6.5 resolved https://github.com/HubSpot/tether.git#0.6.5

bower viewport-units-buggyfill#~0.4.1 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .js files: ["./viewport-units-buggyfill.js","./viewport-units-buggyfill.hacks.js"]

bower viewport-units-buggyfill#~0.4.1 resolved https://github.com/rodneyrehm/viewport-units-buggyfill.git#0.4.1

bower hammerjs#~2.0.4 resolved https://github.com/EightMedia/hammer.js.git#2.0.8

bower fastclick#~1.0.3 resolved https://github.com/ftlabs/fastclick.git#1.0.6

Please note that,

foundation-apps#1.1.0 depends on angular-animate#~1.3.4 which resolved to angular-animate#1.3.20

openproject depends on angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

angular-busy#4.1.4 depends on angular-animate#>=1.3 which resolved to angular-animate#1.5.11

Resort to using angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

Code incompatibilities may occur.

Please note that,

angular-animate#1.3.20 depends on angular#1.3.20 which resolved to angular#1.3.20

foundation-apps#1.1.0 depends on angular#~1.3.4 which resolved to angular#1.3.20

angular-animate#1.5.11, angular-aria#1.5.11, angular-mocks#1.5.11, angular-sanitize#1.5.11 depends on angular#1.5.11 which resolved to angular#1.5.11

angular-ui-router#0.3.2, angular-ui-router#0.2.18 depends on angular#^1.0.8 which resolved to angular#1.5.11

ng-dialog#0.6.6 depends on angular#>=1.5 which resolved to angular#1.5.11

angular-busy#4.1.4 depends on angular#>=1.3 which resolved to angular#1.5.11

angular-ui-select#0.19.6 depends on angular#>=1.2.18 which resolved to angular#1.5.11

openproject depends on angular#~1.5.8 which resolved to angular#1.5.11

angular-cache#4.6.0 depends on angular#>=1.x which resolved to angular#1.5.11

angular-modal#d45eb9ceb7 depends on angular#^1.3.0 which resolved to angular#1.6.1

angular-elastic#2.5.1 depends on angular#>=1.0.6 which resolved to angular#1.6.1

angular-context-menu#a908eccaec depends on angular#>= 1.2.5 which resolved to angular#1.6.1

Resort to using angular#~1.5.8 which resolved to angular#1.5.11

Code incompatibilities may occur.

Please note that,

foundation-apps#1.1.0 depends on angular-ui-router#~0.2.12 which resolved to angular-ui-router#0.2.18

openproject depends on angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Resort to using angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Code incompatibilities may occur.

bower jquery extra-resolution Unnecessary resolution: jquery#1.11.0

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 install angular-context-menu#a908eccaec

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 install angular-modal#d45eb9ceb7

bower jquery-ui#~1.10.4 install jquery-ui#1.10.4

bower angular-animate#~1.5.8 install angular-animate#1.5.11

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de install angular-truncate#fdf60fda26

bower angular-aria#~1.5.8 install angular-aria#1.5.11

bower jquery-ujs#1.0.0 install jquery-ujs#1.0.0

bower angular-elastic#~2.5.1 install angular-elastic#2.5.1

bower angular#1.5.11 install angular#1.5.11

bower jquery-migrate#~1.2.1 install jquery-migrate#1.2.1

bower angular-ui-router#~0.3.1 install angular-ui-router#0.3.2

bower jquery.atwho#0.5.1 install jquery.atwho#0.5.1

bower angular-cache#~4.6.0 install angular-cache#4.6.0

bower jquery#1.11.0 install jquery#1.11.0

bower angular-sanitize#~1.5.8 install angular-sanitize#1.5.11

bower angular-busy#~4.1.3 install angular-busy#4.1.4

bower angular-ui-select#~0.19.4 install angular-ui-select#0.19.6

bower moment#~2.10.6 install moment#2.10.6

bower bourbon#~4.2.1 install bourbon#4.2.7

bower foundation-apps#1.1.0 install foundation-apps#1.1.0

bower mousetrap#~1.4.6 install mousetrap#1.4.6

bower ng-file-upload#~5.0.9 install ng-file-upload#5.0.9

bower lodash#~2.4.1 install lodash#2.4.2

bower moment-timezone#0.4.x install moment-timezone#0.4.1

bower ng-dialog#^0.6.2 install ng-dialog#0.6.6

bower mocha#~1.14.0 install mocha#1.14.0

bower angular-dragula#^1.2.8 install angular-dragula#1.2.8

bower chai#~1.9.0 install chai#1.9.2

bower jquery-mockjax#~1.5.3 install jquery-mockjax#1.5.4

bower angular-mocks#~1.5.8 install angular-mocks#1.5.11

bower angular-i18n#~1.5.5 install angular-i18n#1.5.11

bower rxjs#^4.1.0 install rxjs#4.1.0

bower select2#3.5.2 install select2#3.5.2

bower Caret.js#>= 0.2.0 install Caret.js#0.3.1

bower tether#~0.6.5 install tether#0.6.5

bower viewport-units-buggyfill#~0.4.1 install viewport-units-buggyfill#0.4.1

bower hammerjs#~2.0.4 install hammerjs#2.0.8

bower fastclick#~1.0.3 install fastclick#1.0.6

angular-context-menu#a908eccaec bower_components/angular-context-menu

└── angular#1.5.11

angular-modal#d45eb9ceb7 bower_components/angular-modal

└── angular#1.5.11

jquery-ui#1.10.4 bower_components/jquery-ui

└── jquery#1.11.0

angular-animate#1.5.11 bower_components/angular-animate

└── angular#1.5.11

angular-truncate#fdf60fda26 bower_components/angular-truncate

angular-aria#1.5.11 bower_components/angular-aria

└── angular#1.5.11

jquery-ujs#1.0.0 bower_components/jquery-ujs

└── jquery#1.11.0

angular-elastic#2.5.1 bower_components/angular-elastic

└── angular#1.5.11

angular#1.5.11 bower_components/angular

jquery-migrate#1.2.1 bower_components/jquery-migrate

angular-ui-router#0.3.2 bower_components/angular-ui-router

└── angular#1.5.11

jquery.atwho#0.5.1 bower_components/jquery.atwho

├── Caret.js#0.3.1

└── jquery#1.11.0

angular-cache#4.6.0 bower_components/angular-cache

└── angular#1.5.11

jquery#1.11.0 bower_components/jquery

angular-sanitize#1.5.11 bower_components/angular-sanitize

└── angular#1.5.11

angular-busy#4.1.4 bower_components/angular-busy

├── angular#1.5.11

└── angular-animate#1.5.11

angular-ui-select#0.19.6 bower_components/angular-ui-select

└── angular#1.5.11

moment#2.10.6 bower_components/moment

bourbon#4.2.7 bower_components/bourbon

foundation-apps#1.1.0 bower_components/foundation-apps

├── angular#1.5.11

├── angular-animate#1.5.11

├── angular-ui-router#0.3.2

├── fastclick#1.0.6

├── hammerjs#2.0.8

├── tether#0.6.5

└── viewport-units-buggyfill#0.4.1

mousetrap#1.4.6 bower_components/mousetrap

ng-file-upload#5.0.9 bower_components/ng-file-upload

lodash#2.4.2 bower_components/lodash

moment-timezone#0.4.1 bower_components/moment-timezone

└── moment#2.10.6

ng-dialog#0.6.6 bower_components/ng-dialog

└── angular#1.5.11

mocha#1.14.0 bower_components/mocha

angular-dragula#1.2.8 bower_components/angular-dragula

chai#1.9.2 bower_components/chai

jquery-mockjax#1.5.4 bower_components/jquery-mockjax

angular-mocks#1.5.11 bower_components/angular-mocks

└── angular#1.5.11

angular-i18n#1.5.11 bower_components/angular-i18n

rxjs#4.1.0 bower_components/rxjs

select2#3.5.2 bower_components/select2

└── jquery#1.11.0

Caret.js#0.3.1 bower_components/Caret.js

└── jquery#1.11.0

tether#0.6.5 bower_components/tether

viewport-units-buggyfill#0.4.1 bower_components/viewport-units-buggyfill

hammerjs#2.0.8 bower_components/hammerjs

fastclick#1.0.6 bower_components/fastclick

openproject-frontend@0.1.0 /tmp/d20170122-18-1qtslcz/opt/openproject/frontend

+-- acorn@2.6.4

+-- align-text@0.1.4

+-- alter@0.2.0

+-- amdefine@1.0.0

+-- angular@1.5.8

+-- angular-elastic@2.5.1

+-- angular-ui-bootstrap@2.2.0

+-- anymatch@1.3.0

+-- arr-diff@2.0.0

+-- arr-flatten@1.0.1

+-- array-unique@0.2.1

+-- arrify@1.0.1

+-- assert@1.4.1

+-- async@0.2.10

+-- async-each@1.0.1

+-- atoa@1.0.0

+-- autoprefixer-core@5.2.1

+-- autoprefixer-loader@1.2.0

+-- awesome-typescript-loader@2.2.4

| `-- lodash@4.16.4

+-- balanced-match@0.4.2

+-- Base64@0.2.1

+-- base64-js@1.2.0

+-- big.js@3.1.3

+-- binary-extensions@1.7.0

+-- bower@1.7.9

+-- brace-expansion@1.1.6

+-- braces@1.8.5

+-- browserify-zlib@0.1.4

+-- browserslist@0.4.0

+-- buffer@4.9.1

+-- buffer-shims@1.0.0

+-- camelcase@1.2.1

+-- caniuse-db@1.0.30000569

+-- center-align@0.1.3

+-- chokidar@1.6.1

+-- cliui@2.1.0

| `-- wordwrap@0.0.2

+-- clone@1.0.2

+-- colors@1.1.2

+-- concat-map@0.0.1

+-- console-browserify@1.1.0

+-- constants-browserify@0.0.1

+-- contra@1.9.4

+-- convert-source-map@1.1.3

+-- core-util-is@1.0.2

+-- crossvent@1.5.4

+-- crypto-browserify@3.2.8

+-- css-loader@0.9.1

| `-- source-map@0.1.43

+-- csso@1.3.12

+-- custom-event@1.0.0

+-- d@0.1.1

+-- date-now@0.1.4

+-- decamelize@1.2.0

+-- domain-browser@1.1.7

+-- dragula@3.7.2

+-- emojis-list@2.1.0

+-- enhanced-resolve@2.3.0

+-- errno@0.1.4

+-- es5-ext@0.10.12

+-- es6-iterator@2.0.0

+-- es6-promise@2.3.0

+-- es6-symbol@3.1.0

+-- es6-weak-map@0.1.4

| +-- es6-iterator@0.1.3

| `-- es6-symbol@2.0.1

+-- event-emitter@0.3.4

+-- events@1.1.1

+-- expand-brackets@0.1.5

+-- expand-range@1.8.2

+-- exports-loader@0.6.3

| `-- source-map@0.1.43

+-- expose-loader@0.6.0

+-- extglob@0.3.2

+-- extract-text-webpack-plugin@0.3.8

| `-- source-map@0.1.43

+-- fastparse@1.1.1

+-- file-loader@0.8.5

+-- filename-regex@2.0.0

+-- fill-range@2.2.3

+-- for-in@0.1.6

+-- for-own@0.1.4

+-- glob@4.5.3

+-- glob-base@0.3.0

+-- glob-parent@2.0.0

+-- graceful-fs@4.1.9

+-- has-flag@1.0.0

+-- html-loader@0.2.3

| `-- source-map@0.1.43

+-- html-minifier@0.5.6

+-- http-browserify@1.7.0

+-- https-browserify@0.0.0

+-- ieee754@1.1.8

+-- indexof@0.0.1

+-- inflight@1.0.6

+-- inherits@2.0.3

+-- interpret@0.6.6

+-- is-binary-path@1.0.1

+-- is-buffer@1.1.4

+-- is-dotfile@1.0.2

+-- is-equal-shallow@0.1.3

+-- is-extendable@0.1.1

+-- is-extglob@1.0.0

+-- is-glob@2.0.1

+-- is-number@2.1.0

+-- is-posix-bracket@0.1.1

+-- is-primitive@2.0.0

+-- isarray@1.0.0

+-- isobject@2.1.0

+-- js-base64@2.1.9

+-- json5@0.4.0

+-- kind-of@3.0.4

+-- lazy-cache@1.0.4

+-- loader-utils@0.2.16

| `-- json5@0.5.0

+-- lodash@2.4.2

+-- longest@1.0.1

+-- lru-queue@0.1.0

+-- memoizee@0.3.10

+-- memory-fs@0.3.0

+-- micromatch@2.3.11

+-- mime@1.2.11

+-- minimatch@2.0.10

+-- minimist@0.0.10

+-- mkdirp@0.5.1

| `-- minimist@0.0.8

+-- nan@2.4.0

+-- next-tick@0.2.2

+-- ng-annotate@1.2.1

| `-- source-map@0.5.6

+-- ng-annotate-loader@0.0.10

| `-- source-map@0.4.2

+-- ngtemplate-loader@0.1.3

+-- node-libs-browser@0.6.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- normalize-path@2.0.1

+-- num2fraction@1.2.2

+-- object-assign@4.1.0

+-- object.omit@2.0.1

+-- observable-array@0.0.4

+-- observable-value@0.0.5

+-- once@1.4.0

+-- optimist@0.6.1

+-- ordered-ast-traverse@1.1.1

+-- ordered-esprima-props@1.1.0

+-- os-browserify@0.1.2

+-- pako@0.2.9

+-- parse-glob@3.0.4

+-- path-browserify@0.0.0

+-- path-is-absolute@1.0.1

+-- pbkdf2-compat@2.0.1

+-- phantomjs-polyfill@0.0.2

+-- postcss@4.1.16

+-- preserve@0.2.0

+-- process@0.11.9

+-- process-nextick-args@1.0.7

+-- prr@0.0.0

+-- punycode@1.4.1

+-- querystring@0.2.0

+-- querystring-es3@0.2.1

+-- randomatic@1.1.5

+-- readable-stream@2.1.5

+-- readdirp@2.1.0

| `-- minimatch@3.0.3

+-- regex-cache@0.4.3

+-- repeat-element@1.1.2

+-- repeat-string@1.6.1

+-- right-align@0.1.3

+-- ripemd160@0.2.0

+-- set-immediate-shim@1.0.1

+-- sha.js@2.2.6

+-- shelljs@0.3.0

+-- simple-fmt@0.1.0

+-- simple-is@0.2.0

+-- source-list-map@0.1.6

+-- source-map@0.4.4

+-- source-map-support@0.4.5

| `-- source-map@0.5.6

+-- stable@0.1.5

+-- stream-browserify@1.0.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- string_decoder@0.10.31

+-- stringmap@0.2.2

+-- stringset@0.2.1

+-- style-loader@0.8.3

+-- supports-color@3.1.2

+-- tapable@0.2.4

+-- ticky@1.0.1

+-- timers-browserify@1.4.2

+-- timers-ext@0.1.0

+-- tryor@0.1.2

+-- tty-browserify@0.0.0

+-- typescript@2.0.6

+-- uglify-js@2.7.4

| `-- source-map@0.5.6

+-- uglify-to-browserify@1.0.2

+-- URIjs@1.16.1

+-- url@0.10.3

| `-- punycode@1.3.2

+-- url-loader@0.5.7

+-- util@0.10.3

| `-- inherits@2.0.1

+-- util-deprecate@1.0.2

+-- vm-browserify@0.0.4

+-- watchpack@0.2.9

| `-- async@0.9.2

+-- webpack@1.13.3

| +-- acorn@3.3.0

| +-- async@1.5.2

| +-- enhanced-resolve@0.9.1

| | `-- memory-fs@0.2.0

| `-- tapable@0.1.10

+-- webpack-core@0.6.8

+-- window-size@0.1.0

+-- wordwrap@0.0.3

+-- wrappy@1.0.2

`-- yargs@3.10.0

npm WARN openproject-frontend@0.1.0 No repository field.

npm WARN openproject-frontend@0.1.0 No license field.

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.0.14 (node_modules/fsevents):

npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.0.14: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

-----> Checking startup method

Found Procfile

-----> Finalizing build

Creating runtime environment

Exporting binary paths

Cleaning npm artifacts

Cleaning previous cache

Caching results for future builds

-----> Build succeeded!

openproject@0.1.0 /tmp/d20170122-18-1qtslcz/opt/openproject

`-- typescript@2.0.8

=====> Downloading Buildpack: https://github.com/pkgr/heroku-buildpack-ruby.git

=====> Detected Framework: Ruby

-----> Compiling Ruby/Rails

-----> Using Ruby version: ruby-2.3.1

-----> Installing dependencies using bundler 1.13.2

cp: ‘/tmp/d20170122-18-1qtslcz/opt/openproject/.git/cache/vendor/bundle/.’ and ‘/tmp/d20170122-18-1qtslcz/opt/openproject/.git/cache/vendor/bundle/.’ are the same file

Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Fetching gem metadata from https://rubygems.org/......

Fetching version metadata from https://rubygems.org/..

Fetching dependency metadata from https://rubygems.org/.

Using i18n 0.7.0

Installing minitest 5.9.0

Installing rake 11.3.0

Using thread_safe 0.3.5

Installing concurrent-ruby 1.0.2

Using erubis 2.7.0

Using mini_portile2 2.1.0

Using rack 2.0.1

Using nio4r 1.2.1

Using websocket-extensions 0.1.2

Using mime-types 2.99.3

Using method_source 0.8.2

Installing builder 3.2.2

Installing pkg-config 1.1.7

Using multi_json 1.12.1

Using acts_as_silent_list 3.0.0

Using addressable 2.4.0

Using airbrake-ruby 1.5.0

Using attr_required 1.0.1

Using execjs 2.7.0

Using ice_nine 0.11.2

Using bcrypt 3.1.11

Using bindata 2.3.4

Using sass 3.4.22

Using tilt 2.0.5

Using uber 0.0.15

Using erbse 0.0.2

Using coderay 1.1.1

Using color-tools 1.3.0

Using unf_ext 0.0.7.2

Using netrc 0.11.0

Using daemons 1.2.4

Using dalli 2.7.6

Using enumerable-lazy 0.0.1

Using equalizer 0.0.11

Using excon 0.52.0

Using ffi 1.9.14

Using formatador 0.2.5

Using ipaddress 0.8.3

Using get_process_mem 0.2.1

Using request_store 1.3.1

Using json 1.8.3

Using hashie 3.4.6

Using multi_xml 0.5.5

Using gravatar_image_tag 1.2.0

Using bundler 1.13.2

Using htmldiff 0.0.1

Installing thor 0.19.1

Using icalendar 2.3.0

Using iso8601 0.9.1

Using securecompare 1.0.0

Using url_safe_base64 0.2.2

Using kgio 2.10.0

Using mixlib-shellout 2.1.0

Using mysql2 0.4.4

Using net-ldap 0.14.0

Using newrelic_rpm 3.16.2.321

Using oj 2.17.4

Using pdf-core 0.6.1

Installing arel 7.1.2

Using ttfunk 1.4.0

Using rmagick 2.15.4

Using rubyzip 1.2.0

Using ruby-ole 1.2.12

Using pg 0.19.0

Using rails_serve_static_assets 0.0.5

Using rails_stdout_logging 0.0.5

Using raindrops 0.17.0

Using ruby-progressbar 1.8.1

Using structured_warnings 0.2.0

Using sqlite3 1.3.11

Using stringex 2.6.1

Using svg-graph 2.0.1

Using syck 1.0.5

Using will_paginate 3.1.3

Using i18n-js 3.0.0.rc14

Using tzinfo 1.2.2

Using descendants_tracker 0.0.4

Using rack-test 0.6.3

Using rack-accept 0.4.5

Using passenger 5.0.30

Using rack-attack 5.0.1

Using rack-protection 2.0.0.beta2

Using warden 1.2.6

Using websocket-driver 0.6.4

Using mail 2.6.4

Installing httpclient 2.8.2.4

Using airbrake 5.1.0

Using autoprefixer-rails 6.4.1.1

Using cells 4.1.3

Using unf 0.1.4

Using mustermann19 0.4.4

Using sys-filesystem 1.1.7

Using fog-core 1.42.0

Using rdoc 4.2.2

Using omniauth 1.3.1 from https://github.com/oliverguenther/omniauth (at 8385bc0@8385bc0)

Using bourbon 4.2.7

Using prawn 2.1.0

Using spreadsheet 0.8.9

Using rails_12factor 0.0.3

Using unicorn 5.1.0

Using rubytree 0.9.7

Installing sprockets 3.7.0

Using tzinfo-data 1.2016.6

Using axiom-types 0.1.1

Using coercible 1.0.0

Using warden-basic_auth 0.2.1

Using cells-erb 0.0.8

Using domain_name 0.5.20161129

Using fog-json 1.0.2

Using prawn-table 0.2.2

Using unicorn-worker-killer 0.4.4

Using virtus 1.0.5

Using http-cookie 1.0.3

Using rest-client 1.8.0

Using crowdin-api 0.4.1

Installing activesupport 5.0.0.1

Using globalid 0.3.7

Using climate_control 0.0.3

Using delayed_job 4.1.2

Using grape 0.17.0

Installing nokogiri 1.6.8 with native extensions

Installing json-jwt 1.6.5

Installing activemodel 5.0.0.1

Using swd 1.0.1

Using webfinger 1.0.2

Using rabl 0.13.0

Using ruby-duration 3.2.3

Installing rack-oauth2 1.4.0

Installing activejob 5.0.0.1

Using cocaine 0.5.8

Using grape-cache_control 1.0.1

Using carrierwave 1.0.0.beta from https://github.com/carrierwaveuploader/carrierwave (at master@5367a63)

Installing activerecord 5.0.0.1

Using date_validator 0.9.0

Using validate_email 0.1.6

Using validate_url 1.0.2

Using activemodel-serializers-xml 1.0.1

Using acts_as_list 0.8.1

Using acts_as_tree 2.5.1

Using awesome_nested_set 3.1.1

Using delayed_job_active_record 4.1.1

Using friendly_id 5.2.0.beta.1 from https://github.com/norman/friendly_id (at aff0564@aff0564)

Using globalize 5.1.0 from https://github.com/globalize/globalize (at 38443bc@38443bc)

Using transactional_lock 0.1.0 from https://github.com/finnlabs/transactional_lock.git (at master@6948b1d)

Using openid_connect 0.8.3

Using omniauth-openid-connect 0.2.0 from https://github.com/finnlabs/omniauth-openid-connect.git (at dev@c3bce4c)

Using omniauth-openid_connect-providers 0.1.0 from https://github.com/finnlabs/omniauth-openid_connect-providers.git (at dev@86f3670)

Using loofah 2.0.3

Using representable 2.1.8

Using fog-xml 0.1.2

Using ruby-saml 1.4.0

Using rails-html-sanitizer 1.0.3

Using disposable 0.0.9

Using roar 1.0.4

Using fog-aws 0.11.0

Using omniauth-saml 1.6.0 from git://github.com/omniauth/omniauth-saml.git (at master@5559d6b)

Using reform 1.2.6

Using openproject-auth_saml 0.1.0 from https://github.com/finnlabs/openproject-auth_saml (at dev@97212ab)

Installing rails-dom-testing 2.0.1

Installing actionview 5.0.0.1

Installing actionpack 5.0.0.1

Installing actionmailer 5.0.0.1

Installing actioncable 5.0.0.1

Using cells-rails 0.0.6

Using gon 4.1.1

Using sprockets-rails 3.2.0

Installing railties 5.0.0.1

Using actionpack-xml_parser 2.0.0

Using activerecord-session_store 1.0.0

Using jquery-tablesorter 1.22.7

Using responders 2.3.0

Using sass-rails 5.0.6

Installing rails 5.0.0.1

Using health_check 2.2.1

Using lobby_boy 0.1.2

Using openproject-auth_plugins 6.1.4 from source at `vendored-plugins/openproject-auth_plugins`

Using openproject-pdf_export 6.1.4 from source at `vendored-plugins/openproject-pdf_export`

Using openproject-costs 6.1.4 from source at `vendored-plugins/openproject-costs`

Using openproject-documents 6.1.4 from source at `vendored-plugins/openproject-documents`

Using openproject-webhooks 6.1.4 from source at `vendored-plugins/openproject-webhooks`

Using openproject-global_roles 6.1.4 from source at `vendored-plugins/openproject-global_roles`

Using openproject-local_avatars 6.1.4 from source at `vendored-plugins/openproject-local_avatars`

Using openproject-meeting 6.1.4 from source at `vendored-plugins/openproject-meeting`

Using openproject-my_project_page 6.1.4 from source at `vendored-plugins/openproject-my_project_page`

Using reporting_engine 6.1.4 from source at `vendored-plugins/reporting_engine`

Using openproject-themes-dark 6.1.4 from source at `vendored-plugins/openproject-themes-dark`

Using openproject-translations 6.1.4 from https://github.com/opf/openproject-translations.git (at stable/6@da52ff9)

Using openproject-xls_export 6.1.4 from source at `vendored-plugins/openproject-xls_export`

Using rails-angular-xss 0.3.0.pre.pre from https://github.com/opf/rails-angular-xss (at a45267d@a45267d)

Using rails_autolink 1.1.6

Using openproject-openid_connect 6.1.4 from source at `vendored-plugins/openproject-openid_connect`

Using openproject-backlogs 6.1.4 from source at `vendored-plugins/openproject-backlogs`

Using openproject-github_integration 6.1.4 from source at `vendored-plugins/openproject-github_integration`

Using openproject-reporting 6.1.4 from source at `vendored-plugins/openproject-reporting`

Bundle complete! 138 Gemfile dependencies, 195 gems now installed.

Gems in the groups development and test were not installed.

Bundled gems are installed into ./vendor/bundle.

Bundle completed (20.77s)

Cleaning up the bundler cache.

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Removing thor (0.19.4)

Removing builder (3.2.3)

Removing arel (7.1.4)

Removing concurrent-ruby (1.0.4)

Removing activerecord (5.0.1)

Removing sprockets (3.7.1)

Removing rails-dom-testing (2.0.2)

Removing actioncable (5.0.1)

Removing rails (5.0.1)

Removing actionview (5.0.1)

Removing activesupport (5.0.1)

Removing rake (12.0.0)

Removing activejob (5.0.1)

Removing railties (5.0.1)

Removing rack-oauth2 (1.5.1)

Removing minitest (5.10.1)

Removing httpclient (2.8.3)

Removing activemodel (5.0.1)

Removing actionmailer (5.0.1)

Removing json-jwt (1.7.1)

Removing openproject-token (1.0.0)

Removing nokogiri (1.6.8.1)

Removing actionpack (5.0.1)

-----> Detecting rake tasks

-----> Preparing app for Rails asset pipeline

Running: rake assets:precompile

$(npm bin)/webpack --config webpack.production.config.js

{"omniauth-openid-connect":"/tmp/d20170122-18-1qtslcz/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid-connect-c3bce4c9e9ac","omniauth-openid_connect-providers":"/tmp/d20170122-18-1qtslcz/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid_connect-providers-86f3670e127e","omniauth-saml":"/tmp/d20170122-18-1qtslcz/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-saml-5559d6b80805","openproject-auth_plugins":"/tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-auth_plugins","openproject-auth_saml":"/tmp/d20170122-18-1qtslcz/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-auth_saml-97212abb8378","openproject-pdf_export":"/tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-pdf_export","openproject-backlogs":"/tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-backlogs","openproject-costs":"/tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-costs","openproject-documents":"/tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-documents","openproject-webhooks":"/tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-webhooks","openproject-github_integration":"/tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-github_integration","openproject-global_roles":"/tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-global_roles","openproject-local_avatars":"/tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-local_avatars","openproject-meeting":"/tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-meeting","openproject-my_project_page":"/tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-my_project_page","openproject-openid_connect":"/tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-openid_connect","reporting_engine":"/tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/reporting_engine","openproject-reporting":"/tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-reporting","openproject-themes-dark":"/tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-themes-dark","openproject-translations":"/tmp/d20170122-18-1qtslcz/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-translations-da52ff92cdcd","openproject-xls_export":"/tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-xls_export"}

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Hash: e8441f566cad76755667

Version: webpack 1.13.3

Child

Hash: e8441f566cad76755667

Version: webpack 1.13.3

Time: 13371ms

Asset Size Chunks Chunk Names

7b9776076d5fceef4993b55c9383dedd.gif 1.85 kB [emitted]

openproject-backlogs.js 453 kB 0 [emitted] backlogs

openproject-core-app.js 3.43 MB 1 [emitted] core-app

openproject-costs.js 526 kB 2 [emitted] costs

openproject-global.js 3.51 MB 3 [emitted] global

openproject-my_project_page.js 14.3 kB 4 [emitted] my_project_page

openproject-core-app.css 4.71 kB 1 [emitted] core-app

openproject-global.css 49 kB 3 [emitted] global

[213] ./templates \.html$ 1.22 kB {1} [built]

[242] ./components ^((?!\.(test|spec)).)*\.(js|ts|html)$ 16.1 kB {1} [built]

[633] /tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 425 bytes {2} [built]

[765] /tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 330 bytes {4} [built]

+ 769 hidden modules

ERROR in [default]

File '/tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-budget-subform.directive.ts' is not under 'rootDir' '/tmp/d20170122-18-1qtslcz/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts' is not under 'rootDir' '/tmp/d20170122-18-1qtslcz/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/subform/cost-subform.directive.ts' is not under 'rootDir' '/tmp/d20170122-18-1qtslcz/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts' is not under 'rootDir' '/tmp/d20170122-18-1qtslcz/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts' is not under 'rootDir' '/tmp/d20170122-18-1qtslcz/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-block.directive.ts' is not under 'rootDir' '/tmp/d20170122-18-1qtslcz/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-page-layout.directive.ts' is not under 'rootDir' '/tmp/d20170122-18-1qtslcz/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-textile-block.directive.ts' is not under 'rootDir' '/tmp/d20170122-18-1qtslcz/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default] /tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:49:18

Argument of type 'string' is not assignable to parameter of type '{ [key: string]: any; }'.

ERROR in [default] /tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:53:4

Supplied parameters do not match any signature of call target.

ERROR in [default] /tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:30:38

Cannot find module 'app/components/work-packages/work-package-cache.service'.

ERROR in [default] /tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:49:30

Cannot find name 'HalResource'.

ERROR in [default] /tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:54:57

Property '$injector' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:13

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:27

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:60:11

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:70:23

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:76:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:77:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:78:16

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:36:17

Property 'value' does not exist on type 'CurrencyDisplayField'.

ERROR in [default] /tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:37:23

Property 'value' does not exist on type 'CurrencyDisplayField'.

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 5 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

autoprefixer: /tmp/d20170122-18-1qtslcz/opt/openproject/app/assets/stylesheets/default.css.sass:6426:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-18-1qtslcz/opt/openproject/app/assets/stylesheets/default.css.sass:6456:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-18-1qtslcz/opt/openproject/app/assets/stylesheets/default.css.sass:11729:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-18-1qtslcz/opt/openproject/app/assets/stylesheets/default.css.sass:12110:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-18-1qtslcz/opt/openproject/app/assets/stylesheets/default.css.sass:12155:3: You should write display: flex by final spec instead of display: box

I, [2017-01-22T22:05:17.534527 #2562] INFO -- : Writing /tmp/d20170122-18-1qtslcz/opt/openproject/public/assets/default-b00e18110df905a5bf6f92466cbe06ed3965967d2d5e90d24ce836de132adb64.css

I, [2017-01-22T22:05:17.535194 #2562] INFO -- : Writing /tmp/d20170122-18-1qtslcz/opt/openproject/public/assets/default-b00e18110df905a5bf6f92466cbe06ed3965967d2d5e90d24ce836de132adb64.css.gz

I, [2017-01-22T22:05:19.418821 #2562] INFO -- : Writing /tmp/d20170122-18-1qtslcz/opt/openproject/public/assets/application-5bab1cb6e76aebb9eaf99ad45cedc48308fb4bf2f991f6acc4588d60fbd59aa4.js

I, [2017-01-22T22:05:19.419157 #2562] INFO -- : Writing /tmp/d20170122-18-1qtslcz/opt/openproject/public/assets/application-5bab1cb6e76aebb9eaf99ad45cedc48308fb4bf2f991f6acc4588d60fbd59aa4.js.gz

I, [2017-01-22T22:05:19.616302 #2562] INFO -- : Writing /tmp/d20170122-18-1qtslcz/opt/openproject/public/assets/locales/fa-ddde1dd90c7cd953dfe06fe7a99c8374773412c294f93ffe9efa3414e6b62c2a.js

I, [2017-01-22T22:05:19.616474 #2562] INFO -- : Writing /tmp/d20170122-18-1qtslcz/opt/openproject/public/assets/locales/fa-ddde1dd90c7cd953dfe06fe7a99c8374773412c294f93ffe9efa3414e6b62c2a.js.gz

I, [2017-01-22T22:05:19.629427 #2562] INFO -- : Writing /tmp/d20170122-18-1qtslcz/opt/openproject/public/assets/locales/id-a2a805a38128ac7a7ac9f665acb2885e446ba208b069cf9378b8ec1aec800649.js

I, [2017-01-22T22:05:19.629959 #2562] INFO -- : Writing /tmp/d20170122-18-1qtslcz/opt/openproject/public/assets/locales/id-a2a805a38128ac7a7ac9f665acb2885e446ba208b069cf9378b8ec1aec800649.js.gz

I, [2017-01-22T22:05:19.637967 #2562] INFO -- : Writing /tmp/d20170122-18-1qtslcz/opt/openproject/public/assets/locales/it-2da9fe25a38c3b5ecc1ad49f013f4f2780e7cc8c7760e14b5e0cf9133a3ca888.js

I, [2017-01-22T22:05:19.638095 #2562] INFO -- : Writing /tmp/d20170122-18-1qtslcz/opt/openproject/public/assets/locales/it-2da9fe25a38c3b5ecc1ad49f013f4f2780e7cc8c7760e14b5e0cf9133a3ca888.js.gz

I, [2017-01-22T22:05:19.645925 #2562] INFO -- : Writing /tmp/d20170122-18-1qtslcz/opt/openproject/public/assets/locales/ja-f8632d5fff009c766a77c499986ac2ab325405dc4f1bf26622ae18f9ce8792a8.js

I, [2017-01-22T22:05:19.646084 #2562] INFO -- : Writing /tmp/d20170122-18-1qtslcz/opt/openproject/public/assets/locales/ja-f8632d5fff009c766a77c499986ac2ab325405dc4f1bf26622ae18f9ce8792a8.js.gz

I, [2017-01-22T22:05:19.661053 #2562] INFO -- : Writing /tmp/d20170122-18-1qtslcz/opt/openproject/public/assets/locales/nl-e7e1a58e4a0fe3814cc911c20cd36192bb5110c5ac32a7e583e9d4d177bd693e.js

I, [2017-01-22T22:05:19.661186 #2562] INFO -- : Writing /tmp/d20170122-18-1qtslcz/opt/openproject/public/assets/locales/nl-e7e1a58e4a0fe3814cc911c20cd36192bb5110c5ac32a7e583e9d4d177bd693e.js.gz

autoprefixer: /tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:6446:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:6476:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:11749:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:12130:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-18-1qtslcz/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:12175:3: You should write display: flex by final spec instead of display: box

I, [2017-01-22T22:05:33.040810 #2562] INFO -- : Writing /tmp/d20170122-18-1qtslcz/opt/openproject/public/assets/dark-feeac1abf7e73be6eb6d80d8a8f8e5b9bf79b47ce3eba05b133e96395d495c5a.css

I, [2017-01-22T22:05:33.041091 #2562] INFO -- : Writing /tmp/d20170122-18-1qtslcz/opt/openproject/public/assets/dark-feeac1abf7e73be6eb6d80d8a8f8e5b9bf79b47ce3eba05b133e96395d495c5a.css.gz

Asset precompilation completed (65.02s)

Cleaning assets

Running: rake assets:clean

I, [2017-01-22T22:05:41.147056 #2794] INFO -- : Removed locales/fa-0dbf392eccd6c0bdd63cfadefebb8a9b2ae0ffc90b91c905764f3b009aecb046.js

I, [2017-01-22T22:05:41.153379 #2794] INFO -- : Removed locales/id-a7c8c482240a4e457ff26930c4a800331ec9a565832f4a26b05aa189e690b876.js

I, [2017-01-22T22:05:41.159848 #2794] INFO -- : Removed locales/it-7e1d737729288534422df10d26c1b9357bd99ef564864ac74c1080c53037c9a5.js

I, [2017-01-22T22:05:41.165634 #2794] INFO -- : Removed locales/ja-90d4866d75e8e5c66cb904ef183adae9eb1ec8ea412d548a25b9f8b367258fdf.js

I, [2017-01-22T22:05:41.176781 #2794] INFO -- : Removed default-270b9c30b239e0622b55c68a93351ad8b56bde4af52e9dc6dee3ed4d7e1124b5.css

I, [2017-01-22T22:05:41.182541 #2794] INFO -- : Removed locales/nl-3f2643487cd26bc712d2d53bade04dcfbf8de02db124d1453990847eac991965.js

I, [2017-01-22T22:05:41.188807 #2794] INFO -- : Removed dark-681a673a66ecee6ff638adb9b42edc00086247fb6aa9dc57b93483f16f574571.css

I, [2017-01-22T22:05:41.195177 #2794] INFO -- : Removed application-c587ad9004139c350dc2a2bb49ef407a21c2aafee7221e943c5c0765cbaecb1c.js

Using release configuration from last framework (Ruby).

-----> [cron] /opt/openproject/packaging/cron/openproject-clear-old-sessions => /etc/cron.d/openproject-clear-old-sessions

NEW PACKAGE: openproject-6.1.4-1485121203.2cb8b63.sles12.x86_64.rpm (294.39 MiB)

-----> Releasing...

DONE!

====== Attempt #1

-----> Fetching repository

Cloning into '/tmp/d20170122-16665-cta7oz/input'...

-----> Restoring cache

-----> Starting packaging process

-----> Installing missing build dependencies: libmagickwand-dev, libsqlite3-dev

-----> [wizard] adding legacy-installer wizard (https://github.com/pkgr/addon-legacy-installer#master)

-----> [wizard] adding mysql wizard (https://github.com/pkgr/addon-mysql#master)

-----> [wizard] adding apache2 wizard (https://github.com/pkgr/addon-apache2#master)

-----> [wizard] adding repositories wizard (https://github.com/finnlabs/addon-repositories#master)

-----> [wizard] adding smtp wizard (https://github.com/pkgr/addon-smtp#master)

-----> [wizard] adding memcached wizard (https://github.com/pkgr/addon-memcached#master)

-----> [wizard] adding openproject wizard (https://github.com/pkgr/addon-openproject#master)

-----> Fetching buildpack https://github.com/opf/heroku-buildpack-multi.git at master

-----> Multipack app

-----> Running hook: "packaging/setup"

WARNING: This buildpack is no longer maintained.

Please choose a different buildpack or go to https://github.com/ddollar/heroku-buildpack-multi

and fork it to your own account.

=====> Downloading Buildpack: https://github.com/pkgr/pkgr-buildpack-imagemagick.git

=====> Detected Framework: ImageMagick

-----> SKIP

=====> Downloading Buildpack: https://github.com/heroku/heroku-buildpack-nodejs.git

=====> Detected Framework: Node.js

-----> Reading application state

package.json...

build directory...

cache directory...

environment variables...

Node engine: 6.9.1

Npm engine: 4.0.0

Start mechanism: Procfile

node_modules source: package.json

node_modules cached: true

NPM_CONFIG_PRODUCTION=true

NODE_MODULES_CACHE=true

-----> Installing binaries

Downloading and installing node 6.9.1...

Downloading and installing npm 4.0.0 (replacing version 3.10.8)...

-----> Building dependencies

Restoring node modules from cache

Pruning unused dependencies

Installing any new modules

> openproject@0.1.0 postinstall /tmp/d20170122-17-13e7qmq/opt/openproject

> cd frontend && npm install

> openproject-frontend@0.1.0 postinstall /tmp/d20170122-17-13e7qmq/opt/openproject/frontend

> bower install --config.interactive=false

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 not-cached git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolve git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de not-cached git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolve git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 not-cached git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolve git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 checkout d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower select2#3.5.2 not-cached https://github.com/ivaynberg/select2.git#3.5.2

bower select2#3.5.2 resolve https://github.com/ivaynberg/select2.git#3.5.2

bower jquery-ui#~1.10.4 not-cached https://github.com/components/jqueryui.git#~1.10.4

bower jquery-ui#~1.10.4 resolve https://github.com/components/jqueryui.git#~1.10.4

bower jquery-ujs#1.0.0 not-cached https://github.com/rails/jquery-ujs.git#1.0.0

bower jquery-ujs#1.0.0 resolve https://github.com/rails/jquery-ujs.git#1.0.0

bower jquery#1.11.0 not-cached https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery#1.11.0 resolve https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery.atwho#0.5.1 not-cached https://github.com/ichord/At.js.git#0.5.1

bower jquery.atwho#0.5.1 resolve https://github.com/ichord/At.js.git#0.5.1

bower angular#~1.5.8 not-cached https://github.com/angular/bower-angular.git#~1.5.8

bower angular#~1.5.8 resolve https://github.com/angular/bower-angular.git#~1.5.8

bower angular-animate#~1.5.8 not-cached https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-animate#~1.5.8 resolve https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-aria#~1.5.8 not-cached https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-aria#~1.5.8 resolve https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-ui-router#~0.3.1 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-ui-router#~0.3.1 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-i18n#~1.5.5 not-cached https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-i18n#~1.5.5 resolve https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-sanitize#~1.5.8 not-cached https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-sanitize#~1.5.8 resolve https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-elastic#~2.5.1 not-cached https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-elastic#~2.5.1 resolve https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-cache#~4.6.0 not-cached https://github.com/jmdobry/angular-cache.git#~4.6.0

bower angular-cache#~4.6.0 resolve https://github.com/jmdobry/angular-cache.git#~4.6.0

bower jquery-migrate#~1.2.1 not-cached https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower jquery-migrate#~1.2.1 resolve https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower moment#~2.10.6 not-cached https://github.com/moment/moment.git#~2.10.6

bower moment#~2.10.6 resolve https://github.com/moment/moment.git#~2.10.6

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de checkout fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 checkout a908eccaec323cd66973d58af4965694bdff16a1

bower moment-timezone#0.4.x not-cached https://github.com/moment/moment-timezone.git#0.4.x

bower moment-timezone#0.4.x resolve https://github.com/moment/moment-timezone.git#0.4.x

bower angular-busy#~4.1.3 not-cached https://github.com/cgross/angular-busy.git#~4.1.3

bower angular-busy#~4.1.3 resolve https://github.com/cgross/angular-busy.git#~4.1.3

bower lodash#~2.4.1 not-cached https://github.com/lodash/lodash.git#~2.4.1

bower lodash#~2.4.1 resolve https://github.com/lodash/lodash.git#~2.4.1

bower angular-ui-select#~0.19.4 not-cached https://github.com/angular-ui/ui-select.git#~0.19.4

bower angular-ui-select#~0.19.4 resolve https://github.com/angular-ui/ui-select.git#~0.19.4

bower bourbon#~4.2.1 not-cached https://github.com/thoughtbot/bourbon.git#~4.2.1

bower bourbon#~4.2.1 resolve https://github.com/thoughtbot/bourbon.git#~4.2.1

bower mousetrap#~1.4.6 not-cached https://github.com/ccampbell/mousetrap.git#~1.4.6

bower mousetrap#~1.4.6 resolve https://github.com/ccampbell/mousetrap.git#~1.4.6

bower ng-file-upload#~5.0.9 not-cached https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower ng-file-upload#~5.0.9 resolve https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower rxjs#^4.1.0 not-cached https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower rxjs#^4.1.0 resolve https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower ng-dialog#^0.6.2 not-cached https://github.com/likeastore/ngDialog.git#^0.6.2

bower ng-dialog#^0.6.2 resolve https://github.com/likeastore/ngDialog.git#^0.6.2

bower mocha#~1.14.0 not-cached https://github.com/mochajs/mocha.git#~1.14.0

bower mocha#~1.14.0 resolve https://github.com/mochajs/mocha.git#~1.14.0

bower angular-dragula#^1.2.8 not-cached https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower angular-dragula#^1.2.8 resolve https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower angular-mocks#~1.5.8 not-cached https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower angular-mocks#~1.5.8 resolve https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower chai#~1.9.0 not-cached https://github.com/chaijs/chai.git#~1.9.0

bower chai#~1.9.0 resolve https://github.com/chaijs/chai.git#~1.9.0

bower jquery-mockjax#~1.5.3 not-cached https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery-mockjax#~1.5.3 resolve https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery-ui#~1.10.4 checkout 1.10.4

bower select2#3.5.2 checkout 3.5.2

bower jquery.atwho#0.5.1 checkout v0.5.1

bower jquery-ujs#1.0.0 checkout v1.0.0

bower jquery#1.11.0 checkout 1.11.0

bower angular#~1.5.8 checkout v1.5.11

bower angular-aria#~1.5.8 checkout v1.5.11

bower angular-ui-router#~0.3.1 checkout 0.3.2

bower angular-i18n#~1.5.5 checkout v1.5.11

bower angular-animate#~1.5.8 checkout v1.5.11

bower moment#~2.10.6 checkout 2.10.6

bower angular-cache#~4.6.0 checkout 4.6.0

bower angular-elastic#~2.5.1 checkout v2.5.1

bower jquery-migrate#~1.2.1 checkout 1.2.1

bower angular-sanitize#~1.5.8 checkout v1.5.11

bower bourbon#~4.2.1 checkout v4.2.7

bower angular-ui-select#~0.19.4 checkout v0.19.6

bower lodash#~2.4.1 checkout 2.4.2

bower angular-busy#~4.1.3 checkout v4.1.4

bower moment-timezone#0.4.x checkout 0.4.1

bower mousetrap#~1.4.6 checkout 1.4.6

bower ng-file-upload#~5.0.9 checkout 5.0.9

bower rxjs#^4.1.0 checkout v4.1.0

bower ng-dialog#^0.6.2 checkout v0.6.6

bower mocha#~1.14.0 checkout 1.14.0

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolved git://github.com/finnlabs/angular-modal.git#d45eb9ceb7

bower angular#^1.3.0 not-cached https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 resolve https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 checkout v1.6.1

bower chai#~1.9.0 checkout 1.9.2

bower jquery-mockjax#~1.5.3 checkout v1.5.4

bower angular-dragula#^1.2.8 checkout v1.2.8

bower angular-mocks#~1.5.8 checkout v1.5.11

bower jquery.atwho#0.5.1 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .png files: ["select2.png","select2x2.png"]

bower foundation-apps#1.1.0 not-cached https://github.com/zurb/foundation-apps.git#1.1.0

bower foundation-apps#1.1.0 resolve https://github.com/zurb/foundation-apps.git#1.1.0

bower jquery-ui#~1.10.4 resolved https://github.com/components/jqueryui.git#1.10.4

bower select2#3.5.2 resolved https://github.com/ivaynberg/select2.git#3.5.2

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolved git://github.com/sparkalow/angular-truncate.git#fdf60fda26

bower jquery-ujs#1.0.0 resolved https://github.com/rails/jquery-ujs.git#1.0.0

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolved git://github.com/nickmessing/angular-context-menu.git#a908eccaec

bower angular#>= 1.2.5 not-cached https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 resolve https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 checkout v1.6.1

bower jquery.atwho#0.5.1 resolved https://github.com/ichord/At.js.git#0.5.1

bower jquery#1.11.0 resolved https://github.com/jquery/jquery-dist.git#1.11.0

bower Caret.js#>= 0.2.0 not-cached https://github.com/ichord/Caret.js.git#>= 0.2.0

bower Caret.js#>= 0.2.0 resolve https://github.com/ichord/Caret.js.git#>= 0.2.0

bower angular-aria#~1.5.8 resolved https://github.com/angular/bower-angular-aria.git#1.5.11

bower angular-animate#~1.5.8 resolved https://github.com/angular/bower-angular-animate.git#1.5.11

bower angular#~1.5.8 resolved https://github.com/angular/bower-angular.git#1.5.11

bower angular-ui-router#~0.3.1 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.3.2

bower angular-cache#~4.6.0 resolved https://github.com/jmdobry/angular-cache.git#4.6.0

bower jquery-migrate#~1.2.1 deprecated Package jquery-migrate is using the deprecated component.json

bower jquery-migrate#~1.2.1 resolved https://github.com/appleboy/jquery-migrate.git#1.2.1

bower angular-elastic#~2.5.1 resolved https://github.com/monospaced/angular-elastic.git#2.5.1

bower moment#~2.10.6 resolved https://github.com/moment/moment.git#2.10.6

bower angular-sanitize#~1.5.8 resolved https://github.com/angular/bower-angular-sanitize.git#1.5.11

bower bourbon#~4.2.1 resolved https://github.com/thoughtbot/bourbon.git#4.2.7

bower angular-i18n#~1.5.5 resolved https://github.com/angular/bower-angular-i18n.git#1.5.11

bower angular-ui-select#~0.19.4 resolved https://github.com/angular-ui/ui-select.git#0.19.6

bower angular-busy#~4.1.3 resolved https://github.com/cgross/angular-busy.git#4.1.4

bower lodash#~2.4.1 resolved https://github.com/lodash/lodash.git#2.4.2

bower mousetrap#~1.4.6 resolved https://github.com/ccampbell/mousetrap.git#1.4.6

bower ng-file-upload#~5.0.9 resolved https://github.com/danialfarid/angular-file-upload-bower.git#5.0.9

bower ng-dialog#^0.6.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .css files: ["css/ngDialog.css","css/ngDialog-theme-default.css"]

bower ng-dialog#^0.6.2 resolved https://github.com/likeastore/ngDialog.git#0.6.6

bower moment-timezone#0.4.x resolved https://github.com/moment/moment-timezone.git#0.4.1

bower mocha#~1.14.0 mismatch Version declared in the json (1.12.0) is different than the resolved one (1.14.0)

bower mocha#~1.14.0 resolved https://github.com/mochajs/mocha.git#1.14.0

bower chai#~1.9.0 resolved https://github.com/chaijs/chai.git#1.9.2

bower angular#^1.3.0 resolved https://github.com/angular/bower-angular.git#1.6.1

bower jquery-mockjax#~1.5.3 resolved https://github.com/jakerella/jquery-mockjax.git#1.5.4

bower angular-dragula#^1.2.8 resolved https://github.com/bevacqua/angular-dragula.git#1.2.8

bower foundation-apps#1.1.0 checkout v1.1.0

bower Caret.js#>= 0.2.0 checkout v0.3.1

bower angular-mocks#~1.5.8 resolved https://github.com/angular/bower-angular-mocks.git#1.5.11

bower rxjs#^4.1.0 resolved https://github.com/Reactive-Extensions/RxJS.git#4.1.0

bower Caret.js#>= 0.2.0 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower Caret.js#>= 0.2.0 resolved https://github.com/ichord/Caret.js.git#0.3.1

bower angular#>= 1.2.5 resolved https://github.com/angular/bower-angular.git#1.6.1

bower foundation-apps#1.1.0 resolved https://github.com/zurb/foundation-apps.git#1.1.0

bower angular#~1.3.4 not-cached https://github.com/angular/bower-angular.git#~1.3.4

bower angular#~1.3.4 resolve https://github.com/angular/bower-angular.git#~1.3.4

bower angular-ui-router#~0.2.12 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-ui-router#~0.2.12 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-animate#~1.3.4 not-cached https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular-animate#~1.3.4 resolve https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular#~1.3.4 checkout v1.3.20

bower angular-ui-router#~0.2.12 checkout 0.2.18

bower angular-animate#~1.3.4 checkout v1.3.20

bower viewport-units-buggyfill#~0.4.1 not-cached https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower viewport-units-buggyfill#~0.4.1 resolve https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower tether#~0.6.5 not-cached https://github.com/HubSpot/tether.git#~0.6.5

bower tether#~0.6.5 resolve https://github.com/HubSpot/tether.git#~0.6.5

bower fastclick#~1.0.3 not-cached https://github.com/ftlabs/fastclick.git#~1.0.3

bower fastclick#~1.0.3 resolve https://github.com/ftlabs/fastclick.git#~1.0.3

bower hammerjs#~2.0.4 not-cached https://github.com/EightMedia/hammer.js.git#~2.0.4

bower hammerjs#~2.0.4 resolve https://github.com/EightMedia/hammer.js.git#~2.0.4

bower viewport-units-buggyfill#~0.4.1 checkout v0.4.1

bower tether#~0.6.5 checkout v0.6.5

bower angular-ui-router#~0.2.12 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.2.18

bower fastclick#~1.0.3 checkout v1.0.6

bower hammerjs#~2.0.4 checkout v2.0.8

bower angular-animate#~1.3.4 resolved https://github.com/angular/bower-angular-animate.git#1.3.20

bower angular#~1.3.4 resolved https://github.com/angular/bower-angular.git#1.3.20

bower viewport-units-buggyfill#~0.4.1 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .js files: ["./viewport-units-buggyfill.js","./viewport-units-buggyfill.hacks.js"]

bower viewport-units-buggyfill#~0.4.1 resolved https://github.com/rodneyrehm/viewport-units-buggyfill.git#0.4.1

bower fastclick#~1.0.3 resolved https://github.com/ftlabs/fastclick.git#1.0.6

bower tether#~0.6.5 resolved https://github.com/HubSpot/tether.git#0.6.5

bower hammerjs#~2.0.4 resolved https://github.com/EightMedia/hammer.js.git#2.0.8

Please note that,

foundation-apps#1.1.0 depends on angular-animate#~1.3.4 which resolved to angular-animate#1.3.20

openproject depends on angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

angular-busy#4.1.4 depends on angular-animate#>=1.3 which resolved to angular-animate#1.5.11

Resort to using angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

Code incompatibilities may occur.

Please note that,

angular-animate#1.3.20 depends on angular#1.3.20 which resolved to angular#1.3.20

foundation-apps#1.1.0 depends on angular#~1.3.4 which resolved to angular#1.3.20

angular-animate#1.5.11, angular-aria#1.5.11, angular-mocks#1.5.11, angular-sanitize#1.5.11 depends on angular#1.5.11 which resolved to angular#1.5.11

angular-ui-router#0.3.2, angular-ui-router#0.2.18 depends on angular#^1.0.8 which resolved to angular#1.5.11

angular-cache#4.6.0 depends on angular#>=1.x which resolved to angular#1.5.11

angular-elastic#2.5.1 depends on angular#>=1.0.6 which resolved to angular#1.5.11

angular-ui-select#0.19.6 depends on angular#>=1.2.18 which resolved to angular#1.5.11

ng-dialog#0.6.6 depends on angular#>=1.5 which resolved to angular#1.5.11

openproject depends on angular#~1.5.8 which resolved to angular#1.5.11

angular-busy#4.1.4 depends on angular#>=1.3 which resolved to angular#1.5.11

angular-context-menu#a908eccaec depends on angular#>= 1.2.5 which resolved to angular#1.6.1

angular-modal#d45eb9ceb7 depends on angular#^1.3.0 which resolved to angular#1.6.1

Resort to using angular#~1.5.8 which resolved to angular#1.5.11

Code incompatibilities may occur.

Please note that,

foundation-apps#1.1.0 depends on angular-ui-router#~0.2.12 which resolved to angular-ui-router#0.2.18

openproject depends on angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Resort to using angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Code incompatibilities may occur.

bower jquery extra-resolution Unnecessary resolution: jquery#1.11.0

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 install angular-modal#d45eb9ceb7

bower jquery-ui#~1.10.4 install jquery-ui#1.10.4

bower select2#3.5.2 install select2#3.5.2

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de install angular-truncate#fdf60fda26

bower jquery-ujs#1.0.0 install jquery-ujs#1.0.0

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 install angular-context-menu#a908eccaec

bower jquery.atwho#0.5.1 install jquery.atwho#0.5.1

bower jquery#1.11.0 install jquery#1.11.0

bower angular-aria#~1.5.8 install angular-aria#1.5.11

bower angular-animate#~1.5.8 install angular-animate#1.5.11

bower angular#1.5.11 install angular#1.5.11

bower angular-ui-router#~0.3.1 install angular-ui-router#0.3.2

bower angular-cache#~4.6.0 install angular-cache#4.6.0

bower jquery-migrate#~1.2.1 install jquery-migrate#1.2.1

bower angular-elastic#~2.5.1 install angular-elastic#2.5.1

bower moment#~2.10.6 install moment#2.10.6

bower angular-sanitize#~1.5.8 install angular-sanitize#1.5.11

bower bourbon#~4.2.1 install bourbon#4.2.7

bower angular-i18n#~1.5.5 install angular-i18n#1.5.11

bower angular-ui-select#~0.19.4 install angular-ui-select#0.19.6

bower angular-busy#~4.1.3 install angular-busy#4.1.4

bower lodash#~2.4.1 install lodash#2.4.2

bower mousetrap#~1.4.6 install mousetrap#1.4.6

bower ng-file-upload#~5.0.9 install ng-file-upload#5.0.9

bower ng-dialog#^0.6.2 install ng-dialog#0.6.6

bower moment-timezone#0.4.x install moment-timezone#0.4.1

bower mocha#~1.14.0 install mocha#1.14.0

bower chai#~1.9.0 install chai#1.9.2

bower jquery-mockjax#~1.5.3 install jquery-mockjax#1.5.4

bower angular-dragula#^1.2.8 install angular-dragula#1.2.8

bower angular-mocks#~1.5.8 install angular-mocks#1.5.11

bower rxjs#^4.1.0 install rxjs#4.1.0

bower Caret.js#>= 0.2.0 install Caret.js#0.3.1

bower foundation-apps#1.1.0 install foundation-apps#1.1.0

bower viewport-units-buggyfill#~0.4.1 install viewport-units-buggyfill#0.4.1

bower fastclick#~1.0.3 install fastclick#1.0.6

bower tether#~0.6.5 install tether#0.6.5

bower hammerjs#~2.0.4 install hammerjs#2.0.8

angular-modal#d45eb9ceb7 bower_components/angular-modal

└── angular#1.5.11

jquery-ui#1.10.4 bower_components/jquery-ui

└── jquery#1.11.0

select2#3.5.2 bower_components/select2

└── jquery#1.11.0

angular-truncate#fdf60fda26 bower_components/angular-truncate

jquery-ujs#1.0.0 bower_components/jquery-ujs

└── jquery#1.11.0

angular-context-menu#a908eccaec bower_components/angular-context-menu

└── angular#1.5.11

jquery.atwho#0.5.1 bower_components/jquery.atwho

├── Caret.js#0.3.1

└── jquery#1.11.0

jquery#1.11.0 bower_components/jquery

angular-aria#1.5.11 bower_components/angular-aria

└── angular#1.5.11

angular-animate#1.5.11 bower_components/angular-animate

└── angular#1.5.11

angular#1.5.11 bower_components/angular

angular-ui-router#0.3.2 bower_components/angular-ui-router

└── angular#1.5.11

angular-cache#4.6.0 bower_components/angular-cache

└── angular#1.5.11

jquery-migrate#1.2.1 bower_components/jquery-migrate

angular-elastic#2.5.1 bower_components/angular-elastic

└── angular#1.5.11

moment#2.10.6 bower_components/moment

angular-sanitize#1.5.11 bower_components/angular-sanitize

└── angular#1.5.11

bourbon#4.2.7 bower_components/bourbon

angular-i18n#1.5.11 bower_components/angular-i18n

angular-ui-select#0.19.6 bower_components/angular-ui-select

└── angular#1.5.11

angular-busy#4.1.4 bower_components/angular-busy

├── angular#1.5.11

└── angular-animate#1.5.11

lodash#2.4.2 bower_components/lodash

mousetrap#1.4.6 bower_components/mousetrap

ng-file-upload#5.0.9 bower_components/ng-file-upload

ng-dialog#0.6.6 bower_components/ng-dialog

└── angular#1.5.11

moment-timezone#0.4.1 bower_components/moment-timezone

└── moment#2.10.6

mocha#1.14.0 bower_components/mocha

chai#1.9.2 bower_components/chai

jquery-mockjax#1.5.4 bower_components/jquery-mockjax

angular-dragula#1.2.8 bower_components/angular-dragula

angular-mocks#1.5.11 bower_components/angular-mocks

└── angular#1.5.11

rxjs#4.1.0 bower_components/rxjs

Caret.js#0.3.1 bower_components/Caret.js

└── jquery#1.11.0

foundation-apps#1.1.0 bower_components/foundation-apps

├── angular#1.5.11

├── angular-animate#1.5.11

├── angular-ui-router#0.3.2

├── fastclick#1.0.6

├── hammerjs#2.0.8

├── tether#0.6.5

└── viewport-units-buggyfill#0.4.1

viewport-units-buggyfill#0.4.1 bower_components/viewport-units-buggyfill

fastclick#1.0.6 bower_components/fastclick

tether#0.6.5 bower_components/tether

hammerjs#2.0.8 bower_components/hammerjs

openproject-frontend@0.1.0 /tmp/d20170122-17-13e7qmq/opt/openproject/frontend

+-- acorn@2.6.4

+-- align-text@0.1.4

+-- alter@0.2.0

+-- amdefine@1.0.0

+-- angular@1.5.8

+-- angular-elastic@2.5.1

+-- angular-ui-bootstrap@2.2.0

+-- anymatch@1.3.0

+-- arr-diff@2.0.0

+-- arr-flatten@1.0.1

+-- array-unique@0.2.1

+-- arrify@1.0.1

+-- assert@1.4.1

+-- async@0.2.10

+-- async-each@1.0.1

+-- atoa@1.0.0

+-- autoprefixer-core@5.2.1

+-- autoprefixer-loader@1.2.0

+-- awesome-typescript-loader@2.2.4

| `-- lodash@4.16.4

+-- balanced-match@0.4.2

+-- Base64@0.2.1

+-- base64-js@1.2.0

+-- big.js@3.1.3

+-- binary-extensions@1.7.0

+-- bower@1.7.9

+-- brace-expansion@1.1.6

+-- braces@1.8.5

+-- browserify-zlib@0.1.4

+-- browserslist@0.4.0

+-- buffer@4.9.1

+-- buffer-shims@1.0.0

+-- camelcase@1.2.1

+-- caniuse-db@1.0.30000569

+-- center-align@0.1.3

+-- chokidar@1.6.1

+-- cliui@2.1.0

| `-- wordwrap@0.0.2

+-- clone@1.0.2

+-- colors@1.1.2

+-- concat-map@0.0.1

+-- console-browserify@1.1.0

+-- constants-browserify@0.0.1

+-- contra@1.9.4

+-- convert-source-map@1.1.3

+-- core-util-is@1.0.2

+-- crossvent@1.5.4

+-- crypto-browserify@3.2.8

+-- css-loader@0.9.1

| `-- source-map@0.1.43

+-- csso@1.3.12

+-- custom-event@1.0.0

+-- d@0.1.1

+-- date-now@0.1.4

+-- decamelize@1.2.0

+-- domain-browser@1.1.7

+-- dragula@3.7.2

+-- emojis-list@2.1.0

+-- enhanced-resolve@2.3.0

+-- errno@0.1.4

+-- es5-ext@0.10.12

+-- es6-iterator@2.0.0

+-- es6-promise@2.3.0

+-- es6-symbol@3.1.0

+-- es6-weak-map@0.1.4

| +-- es6-iterator@0.1.3

| `-- es6-symbol@2.0.1

+-- event-emitter@0.3.4

+-- events@1.1.1

+-- expand-brackets@0.1.5

+-- expand-range@1.8.2

+-- exports-loader@0.6.3

| `-- source-map@0.1.43

+-- expose-loader@0.6.0

+-- extglob@0.3.2

+-- extract-text-webpack-plugin@0.3.8

| `-- source-map@0.1.43

+-- fastparse@1.1.1

+-- file-loader@0.8.5

+-- filename-regex@2.0.0

+-- fill-range@2.2.3

+-- for-in@0.1.6

+-- for-own@0.1.4

+-- glob@4.5.3

+-- glob-base@0.3.0

+-- glob-parent@2.0.0

+-- graceful-fs@4.1.9

+-- has-flag@1.0.0

+-- html-loader@0.2.3

| `-- source-map@0.1.43

+-- html-minifier@0.5.6

+-- http-browserify@1.7.0

+-- https-browserify@0.0.0

+-- ieee754@1.1.8

+-- indexof@0.0.1

+-- inflight@1.0.6

+-- inherits@2.0.3

+-- interpret@0.6.6

+-- is-binary-path@1.0.1

+-- is-buffer@1.1.4

+-- is-dotfile@1.0.2

+-- is-equal-shallow@0.1.3

+-- is-extendable@0.1.1

+-- is-extglob@1.0.0

+-- is-glob@2.0.1

+-- is-number@2.1.0

+-- is-posix-bracket@0.1.1

+-- is-primitive@2.0.0

+-- isarray@1.0.0

+-- isobject@2.1.0

+-- js-base64@2.1.9

+-- json5@0.4.0

+-- kind-of@3.0.4

+-- lazy-cache@1.0.4

+-- loader-utils@0.2.16

| `-- json5@0.5.0

+-- lodash@2.4.2

+-- longest@1.0.1

+-- lru-queue@0.1.0

+-- memoizee@0.3.10

+-- memory-fs@0.3.0

+-- micromatch@2.3.11

+-- mime@1.2.11

+-- minimatch@2.0.10

+-- minimist@0.0.10

+-- mkdirp@0.5.1

| `-- minimist@0.0.8

+-- nan@2.4.0

+-- next-tick@0.2.2

+-- ng-annotate@1.2.1

| `-- source-map@0.5.6

+-- ng-annotate-loader@0.0.10

| `-- source-map@0.4.2

+-- ngtemplate-loader@0.1.3

+-- node-libs-browser@0.6.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- normalize-path@2.0.1

+-- num2fraction@1.2.2

+-- object-assign@4.1.0

+-- object.omit@2.0.1

+-- observable-array@0.0.4

+-- observable-value@0.0.5

+-- once@1.4.0

+-- optimist@0.6.1

+-- ordered-ast-traverse@1.1.1

+-- ordered-esprima-props@1.1.0

+-- os-browserify@0.1.2

+-- pako@0.2.9

+-- parse-glob@3.0.4

+-- path-browserify@0.0.0

+-- path-is-absolute@1.0.1

+-- pbkdf2-compat@2.0.1

+-- phantomjs-polyfill@0.0.2

+-- postcss@4.1.16

+-- preserve@0.2.0

+-- process@0.11.9

+-- process-nextick-args@1.0.7

+-- prr@0.0.0

+-- punycode@1.4.1

+-- querystring@0.2.0

+-- querystring-es3@0.2.1

+-- randomatic@1.1.5

+-- readable-stream@2.1.5

+-- readdirp@2.1.0

| `-- minimatch@3.0.3

+-- regex-cache@0.4.3

+-- repeat-element@1.1.2

+-- repeat-string@1.6.1

+-- right-align@0.1.3

+-- ripemd160@0.2.0

+-- set-immediate-shim@1.0.1

+-- sha.js@2.2.6

+-- shelljs@0.3.0

+-- simple-fmt@0.1.0

+-- simple-is@0.2.0

+-- source-list-map@0.1.6

+-- source-map@0.4.4

+-- source-map-support@0.4.5

| `-- source-map@0.5.6

+-- stable@0.1.5

+-- stream-browserify@1.0.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- string_decoder@0.10.31

+-- stringmap@0.2.2

+-- stringset@0.2.1

+-- style-loader@0.8.3

+-- supports-color@3.1.2

+-- tapable@0.2.4

+-- ticky@1.0.1

+-- timers-browserify@1.4.2

+-- timers-ext@0.1.0

+-- tryor@0.1.2

+-- tty-browserify@0.0.0

+-- typescript@2.0.6

+-- uglify-js@2.7.4

| `-- source-map@0.5.6

+-- uglify-to-browserify@1.0.2

+-- URIjs@1.16.1

+-- url@0.10.3

| `-- punycode@1.3.2

+-- url-loader@0.5.7

+-- util@0.10.3

| `-- inherits@2.0.1

+-- util-deprecate@1.0.2

+-- vm-browserify@0.0.4

+-- watchpack@0.2.9

| `-- async@0.9.2

+-- webpack@1.13.3

| +-- acorn@3.3.0

| +-- async@1.5.2

| +-- enhanced-resolve@0.9.1

| | `-- memory-fs@0.2.0

| `-- tapable@0.1.10

+-- webpack-core@0.6.8

+-- window-size@0.1.0

+-- wordwrap@0.0.3

+-- wrappy@1.0.2

`-- yargs@3.10.0

npm WARN openproject-frontend@0.1.0 No repository field.

npm WARN openproject-frontend@0.1.0 No license field.

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.0.14 (node_modules/fsevents):

npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.0.14: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

-----> Checking startup method

Found Procfile

-----> Finalizing build

Creating runtime environment

Exporting binary paths

Cleaning npm artifacts

Cleaning previous cache

Caching results for future builds

-----> Build succeeded!

openproject@0.1.0 /tmp/d20170122-17-13e7qmq/opt/openproject

`-- typescript@2.0.8

=====> Downloading Buildpack: https://github.com/pkgr/heroku-buildpack-ruby.git

=====> Detected Framework: Ruby

-----> Compiling Ruby/Rails

-----> Using Ruby version: ruby-2.3.1

-----> Installing dependencies using bundler 1.13.2

cp: ‘/tmp/d20170122-17-13e7qmq/opt/openproject/.git/cache/vendor/bundle/.’ and ‘/tmp/d20170122-17-13e7qmq/opt/openproject/.git/cache/vendor/bundle/.’ are the same file

Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Fetching gem metadata from https://rubygems.org/......

Fetching version metadata from https://rubygems.org/..

Fetching dependency metadata from https://rubygems.org/.

Using i18n 0.7.0

Installing minitest 5.9.0

Installing rake 11.3.0

Installing concurrent-ruby 1.0.2

Using thread_safe 0.3.5

Using erubis 2.7.0

Using mini_portile2 2.1.0

Using rack 2.0.1

Using nio4r 1.2.1

Using websocket-extensions 0.1.2

Using mime-types 2.99.3

Using method_source 0.8.2

Installing builder 3.2.2

Installing pkg-config 1.1.7

Using multi_json 1.12.1

Using acts_as_silent_list 3.0.0

Using addressable 2.4.0

Using airbrake-ruby 1.5.0

Using attr_required 1.0.1

Using execjs 2.7.0

Using ice_nine 0.11.2

Using bcrypt 3.1.11

Using bindata 2.3.4

Using sass 3.4.22

Using tilt 2.0.5

Using uber 0.0.15

Using erbse 0.0.2

Using coderay 1.1.1

Using color-tools 1.3.0

Using unf_ext 0.0.7.2

Using netrc 0.11.0

Using daemons 1.2.4

Using dalli 2.7.6

Using enumerable-lazy 0.0.1

Using equalizer 0.0.11

Using excon 0.52.0

Using ffi 1.9.14

Using formatador 0.2.5

Using ipaddress 0.8.3

Using get_process_mem 0.2.1

Using request_store 1.3.1

Using json 1.8.3

Using hashie 3.4.6

Using multi_xml 0.5.5

Using gravatar_image_tag 1.2.0

Using bundler 1.13.2

Using htmldiff 0.0.1

Installing arel 7.1.2

Installing thor 0.19.1

Using icalendar 2.3.0

Using iso8601 0.9.1

Using securecompare 1.0.0

Using url_safe_base64 0.2.2

Using kgio 2.10.0

Using mixlib-shellout 2.1.0

Using mysql2 0.4.4

Using net-ldap 0.14.0

Using newrelic_rpm 3.16.2.321

Using oj 2.17.4

Using pdf-core 0.6.1

Using ttfunk 1.4.0

Using rmagick 2.15.4

Using rubyzip 1.2.0

Using ruby-ole 1.2.12

Using pg 0.19.0

Using rails_serve_static_assets 0.0.5

Using rails_stdout_logging 0.0.5

Using raindrops 0.17.0

Using ruby-progressbar 1.8.1

Using structured_warnings 0.2.0

Using sqlite3 1.3.11

Using stringex 2.6.1

Using svg-graph 2.0.1

Using syck 1.0.5

Using will_paginate 3.1.3

Using i18n-js 3.0.0.rc14

Using tzinfo 1.2.2

Using descendants_tracker 0.0.4

Using rack-test 0.6.3

Using rack-accept 0.4.5

Using passenger 5.0.30

Using rack-attack 5.0.1

Using rack-protection 2.0.0.beta2

Using warden 1.2.6

Using websocket-driver 0.6.4

Using mail 2.6.4

Installing httpclient 2.8.2.4

Using airbrake 5.1.0

Using autoprefixer-rails 6.4.1.1

Using cells 4.1.3

Using unf 0.1.4

Using mustermann19 0.4.4

Using sys-filesystem 1.1.7

Using fog-core 1.42.0

Using rdoc 4.2.2

Using omniauth 1.3.1 from https://github.com/oliverguenther/omniauth (at 8385bc0@8385bc0)

Using bourbon 4.2.7

Using prawn 2.1.0

Using spreadsheet 0.8.9

Using rails_12factor 0.0.3

Using unicorn 5.1.0

Using rubytree 0.9.7

Using axiom-types 0.1.1

Using coercible 1.0.0

Installing sprockets 3.7.0

Using tzinfo-data 1.2016.6

Using warden-basic_auth 0.2.1

Using cells-erb 0.0.8

Using domain_name 0.5.20161129

Using fog-json 1.0.2

Using prawn-table 0.2.2

Using unicorn-worker-killer 0.4.4

Using virtus 1.0.5

Using http-cookie 1.0.3

Using rest-client 1.8.0

Using crowdin-api 0.4.1

Installing activesupport 5.0.0.1

Using globalid 0.3.7

Using climate_control 0.0.3

Using delayed_job 4.1.2

Using grape 0.17.0

Installing json-jwt 1.6.5

Installing activemodel 5.0.0.1

Using swd 1.0.1

Using webfinger 1.0.2

Using rabl 0.13.0

Using ruby-duration 3.2.3

Installing rack-oauth2 1.4.0

Using cocaine 0.5.8

Using grape-cache_control 1.0.1

Installing activejob 5.0.0.1

Using carrierwave 1.0.0.beta from https://github.com/carrierwaveuploader/carrierwave (at master@5367a63)

Using date_validator 0.9.0

Using validate_email 0.1.6

Using validate_url 1.0.2

Using openid_connect 0.8.3

Using omniauth-openid-connect 0.2.0 from https://github.com/finnlabs/omniauth-openid-connect.git (at dev@c3bce4c)

Using omniauth-openid_connect-providers 0.1.0 from https://github.com/finnlabs/omniauth-openid_connect-providers.git (at dev@86f3670)

Installing activerecord 5.0.0.1

Using activemodel-serializers-xml 1.0.1

Using acts_as_list 0.8.1

Using acts_as_tree 2.5.1

Using awesome_nested_set 3.1.1

Using delayed_job_active_record 4.1.1

Using friendly_id 5.2.0.beta.1 from https://github.com/norman/friendly_id (at aff0564@aff0564)

Using globalize 5.1.0 from https://github.com/globalize/globalize (at 38443bc@38443bc)

Using transactional_lock 0.1.0 from https://github.com/finnlabs/transactional_lock.git (at master@6948b1d)

Installing nokogiri 1.6.8 with native extensions

Using loofah 2.0.3

Using representable 2.1.8

Using fog-xml 0.1.2

Using ruby-saml 1.4.0

Using disposable 0.0.9

Using roar 1.0.4

Using rails-html-sanitizer 1.0.3

Using fog-aws 0.11.0

Using omniauth-saml 1.6.0 from git://github.com/omniauth/omniauth-saml.git (at master@5559d6b)

Using reform 1.2.6

Using openproject-auth_saml 0.1.0 from https://github.com/finnlabs/openproject-auth_saml (at dev@97212ab)

Installing rails-dom-testing 2.0.1

Installing actionview 5.0.0.1

Installing actionpack 5.0.0.1

Installing actionmailer 5.0.0.1

Using cells-rails 0.0.6

Using gon 4.1.1

Using sprockets-rails 3.2.0

Installing actioncable 5.0.0.1

Installing railties 5.0.0.1

Using actionpack-xml_parser 2.0.0

Using activerecord-session_store 1.0.0

Using jquery-tablesorter 1.22.7

Using responders 2.3.0

Using sass-rails 5.0.6

Installing rails 5.0.0.1

Using health_check 2.2.1

Using lobby_boy 0.1.2

Using openproject-auth_plugins 6.1.4 from source at `vendored-plugins/openproject-auth_plugins`

Using openproject-pdf_export 6.1.4 from source at `vendored-plugins/openproject-pdf_export`

Using openproject-costs 6.1.4 from source at `vendored-plugins/openproject-costs`

Using openproject-documents 6.1.4 from source at `vendored-plugins/openproject-documents`

Using openproject-webhooks 6.1.4 from source at `vendored-plugins/openproject-webhooks`

Using openproject-global_roles 6.1.4 from source at `vendored-plugins/openproject-global_roles`

Using openproject-local_avatars 6.1.4 from source at `vendored-plugins/openproject-local_avatars`

Using openproject-meeting 6.1.4 from source at `vendored-plugins/openproject-meeting`

Using openproject-my_project_page 6.1.4 from source at `vendored-plugins/openproject-my_project_page`

Using reporting_engine 6.1.4 from source at `vendored-plugins/reporting_engine`

Using openproject-themes-dark 6.1.4 from source at `vendored-plugins/openproject-themes-dark`

Using openproject-translations 6.1.4 from https://github.com/opf/openproject-translations.git (at stable/6@da52ff9)

Using openproject-xls_export 6.1.4 from source at `vendored-plugins/openproject-xls_export`

Using rails-angular-xss 0.3.0.pre.pre from https://github.com/opf/rails-angular-xss (at a45267d@a45267d)

Using rails_autolink 1.1.6

Using openproject-openid_connect 6.1.4 from source at `vendored-plugins/openproject-openid_connect`

Using openproject-backlogs 6.1.4 from source at `vendored-plugins/openproject-backlogs`

Using openproject-github_integration 6.1.4 from source at `vendored-plugins/openproject-github_integration`

Using openproject-reporting 6.1.4 from source at `vendored-plugins/openproject-reporting`

Bundle complete! 138 Gemfile dependencies, 195 gems now installed.

Gems in the groups development and test were not installed.

Bundled gems are installed into ./vendor/bundle.

Bundle completed (21.03s)

Cleaning up the bundler cache.

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Removing thor (0.19.4)

Removing builder (3.2.3)

Removing arel (7.1.4)

Removing concurrent-ruby (1.0.4)

Removing activerecord (5.0.1)

Removing sprockets (3.7.1)

Removing rails-dom-testing (2.0.2)

Removing actioncable (5.0.1)

Removing rails (5.0.1)

Removing actionview (5.0.1)

Removing activesupport (5.0.1)

Removing rake (12.0.0)

Removing activejob (5.0.1)

Removing railties (5.0.1)

Removing rack-oauth2 (1.5.1)

Removing minitest (5.10.1)

Removing httpclient (2.8.3)

Removing activemodel (5.0.1)

Removing actionmailer (5.0.1)

Removing json-jwt (1.7.1)

Removing openproject-token (1.0.0)

Removing nokogiri (1.6.8.1)

Removing actionpack (5.0.1)

-----> Detecting rake tasks

-----> Preparing app for Rails asset pipeline

Running: rake assets:precompile

$(npm bin)/webpack --config webpack.production.config.js

{"omniauth-openid-connect":"/tmp/d20170122-17-13e7qmq/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid-connect-c3bce4c9e9ac","omniauth-openid_connect-providers":"/tmp/d20170122-17-13e7qmq/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid_connect-providers-86f3670e127e","omniauth-saml":"/tmp/d20170122-17-13e7qmq/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-saml-5559d6b80805","openproject-auth_plugins":"/tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-auth_plugins","openproject-auth_saml":"/tmp/d20170122-17-13e7qmq/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-auth_saml-97212abb8378","openproject-pdf_export":"/tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-pdf_export","openproject-backlogs":"/tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-backlogs","openproject-costs":"/tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-costs","openproject-documents":"/tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-documents","openproject-webhooks":"/tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-webhooks","openproject-github_integration":"/tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-github_integration","openproject-global_roles":"/tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-global_roles","openproject-local_avatars":"/tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-local_avatars","openproject-meeting":"/tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-meeting","openproject-my_project_page":"/tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-my_project_page","openproject-openid_connect":"/tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-openid_connect","reporting_engine":"/tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/reporting_engine","openproject-reporting":"/tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-reporting","openproject-themes-dark":"/tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-themes-dark","openproject-translations":"/tmp/d20170122-17-13e7qmq/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-translations-da52ff92cdcd","openproject-xls_export":"/tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-xls_export"}

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Hash: fc55e5c6262e2280e3f7

Version: webpack 1.13.3

Child

Hash: fc55e5c6262e2280e3f7

Version: webpack 1.13.3

Time: 13858ms

Asset Size Chunks Chunk Names

7b9776076d5fceef4993b55c9383dedd.gif 1.85 kB [emitted]

openproject-backlogs.js 453 kB 0 [emitted] backlogs

openproject-core-app.js 3.43 MB 1 [emitted] core-app

openproject-costs.js 526 kB 2 [emitted] costs

openproject-global.js 3.51 MB 3 [emitted] global

openproject-my_project_page.js 14.3 kB 4 [emitted] my_project_page

openproject-core-app.css 4.71 kB 1 [emitted] core-app

openproject-global.css 49 kB 3 [emitted] global

[213] ./templates \.html$ 1.22 kB {1} [built]

[242] ./components ^((?!\.(test|spec)).)*\.(js|ts|html)$ 16.1 kB {1} [built]

[633] /tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 425 bytes {2} [built]

[765] /tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 330 bytes {4} [built]

+ 769 hidden modules

ERROR in [default]

File '/tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-budget-subform.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-13e7qmq/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-13e7qmq/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/subform/cost-subform.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-13e7qmq/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts' is not under 'rootDir' '/tmp/d20170122-17-13e7qmq/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts' is not under 'rootDir' '/tmp/d20170122-17-13e7qmq/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-block.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-13e7qmq/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-page-layout.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-13e7qmq/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-textile-block.directive.ts' is not under 'rootDir' '/tmp/d20170122-17-13e7qmq/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default] /tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:49:18

Argument of type 'string' is not assignable to parameter of type '{ [key: string]: any; }'.

ERROR in [default] /tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:53:4

Supplied parameters do not match any signature of call target.

ERROR in [default] /tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:30:38

Cannot find module 'app/components/work-packages/work-package-cache.service'.

ERROR in [default] /tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:49:30

Cannot find name 'HalResource'.

ERROR in [default] /tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:54:57

Property '$injector' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:13

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:27

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:60:11

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:70:23

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:76:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:77:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:78:16

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:36:17

Property 'value' does not exist on type 'CurrencyDisplayField'.

ERROR in [default] /tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:37:23

Property 'value' does not exist on type 'CurrencyDisplayField'.

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 5 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

autoprefixer: /tmp/d20170122-17-13e7qmq/opt/openproject/app/assets/stylesheets/default.css.sass:6426:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-13e7qmq/opt/openproject/app/assets/stylesheets/default.css.sass:6456:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-13e7qmq/opt/openproject/app/assets/stylesheets/default.css.sass:11729:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-13e7qmq/opt/openproject/app/assets/stylesheets/default.css.sass:12110:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-13e7qmq/opt/openproject/app/assets/stylesheets/default.css.sass:12155:3: You should write display: flex by final spec instead of display: box

I, [2017-01-22T21:54:57.268106 #2860] INFO -- : Writing /tmp/d20170122-17-13e7qmq/opt/openproject/public/assets/default-b00e18110df905a5bf6f92466cbe06ed3965967d2d5e90d24ce836de132adb64.css

I, [2017-01-22T21:54:57.268859 #2860] INFO -- : Writing /tmp/d20170122-17-13e7qmq/opt/openproject/public/assets/default-b00e18110df905a5bf6f92466cbe06ed3965967d2d5e90d24ce836de132adb64.css.gz

I, [2017-01-22T21:54:59.200509 #2860] INFO -- : Writing /tmp/d20170122-17-13e7qmq/opt/openproject/public/assets/application-162355587daf13182d19955dd158f3ca471749b3caf8b300aa2173b266bda896.js

I, [2017-01-22T21:54:59.200826 #2860] INFO -- : Writing /tmp/d20170122-17-13e7qmq/opt/openproject/public/assets/application-162355587daf13182d19955dd158f3ca471749b3caf8b300aa2173b266bda896.js.gz

I, [2017-01-22T21:54:59.427736 #2860] INFO -- : Writing /tmp/d20170122-17-13e7qmq/opt/openproject/public/assets/locales/fa-ddde1dd90c7cd953dfe06fe7a99c8374773412c294f93ffe9efa3414e6b62c2a.js

I, [2017-01-22T21:54:59.428114 #2860] INFO -- : Writing /tmp/d20170122-17-13e7qmq/opt/openproject/public/assets/locales/fa-ddde1dd90c7cd953dfe06fe7a99c8374773412c294f93ffe9efa3414e6b62c2a.js.gz

I, [2017-01-22T21:54:59.443562 #2860] INFO -- : Writing /tmp/d20170122-17-13e7qmq/opt/openproject/public/assets/locales/id-a2a805a38128ac7a7ac9f665acb2885e446ba208b069cf9378b8ec1aec800649.js

I, [2017-01-22T21:54:59.443923 #2860] INFO -- : Writing /tmp/d20170122-17-13e7qmq/opt/openproject/public/assets/locales/id-a2a805a38128ac7a7ac9f665acb2885e446ba208b069cf9378b8ec1aec800649.js.gz

I, [2017-01-22T21:54:59.452854 #2860] INFO -- : Writing /tmp/d20170122-17-13e7qmq/opt/openproject/public/assets/locales/it-2da9fe25a38c3b5ecc1ad49f013f4f2780e7cc8c7760e14b5e0cf9133a3ca888.js

I, [2017-01-22T21:54:59.453103 #2860] INFO -- : Writing /tmp/d20170122-17-13e7qmq/opt/openproject/public/assets/locales/it-2da9fe25a38c3b5ecc1ad49f013f4f2780e7cc8c7760e14b5e0cf9133a3ca888.js.gz

I, [2017-01-22T21:54:59.462368 #2860] INFO -- : Writing /tmp/d20170122-17-13e7qmq/opt/openproject/public/assets/locales/ja-f8632d5fff009c766a77c499986ac2ab325405dc4f1bf26622ae18f9ce8792a8.js

I, [2017-01-22T21:54:59.462527 #2860] INFO -- : Writing /tmp/d20170122-17-13e7qmq/opt/openproject/public/assets/locales/ja-f8632d5fff009c766a77c499986ac2ab325405dc4f1bf26622ae18f9ce8792a8.js.gz

I, [2017-01-22T21:54:59.476618 #2860] INFO -- : Writing /tmp/d20170122-17-13e7qmq/opt/openproject/public/assets/locales/nl-e7e1a58e4a0fe3814cc911c20cd36192bb5110c5ac32a7e583e9d4d177bd693e.js

I, [2017-01-22T21:54:59.476761 #2860] INFO -- : Writing /tmp/d20170122-17-13e7qmq/opt/openproject/public/assets/locales/nl-e7e1a58e4a0fe3814cc911c20cd36192bb5110c5ac32a7e583e9d4d177bd693e.js.gz

autoprefixer: /tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:6446:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:6476:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:11749:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:12130:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-17-13e7qmq/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:12175:3: You should write display: flex by final spec instead of display: box

I, [2017-01-22T21:55:14.292894 #2860] INFO -- : Writing /tmp/d20170122-17-13e7qmq/opt/openproject/public/assets/dark-feeac1abf7e73be6eb6d80d8a8f8e5b9bf79b47ce3eba05b133e96395d495c5a.css

I, [2017-01-22T21:55:14.293198 #2860] INFO -- : Writing /tmp/d20170122-17-13e7qmq/opt/openproject/public/assets/dark-feeac1abf7e73be6eb6d80d8a8f8e5b9bf79b47ce3eba05b133e96395d495c5a.css.gz

Asset precompilation completed (65.39s)

Cleaning assets

Running: rake assets:clean

I, [2017-01-22T21:55:22.910311 #3095] INFO -- : Removed locales/fa-0dbf392eccd6c0bdd63cfadefebb8a9b2ae0ffc90b91c905764f3b009aecb046.js

I, [2017-01-22T21:55:22.918110 #3095] INFO -- : Removed locales/id-a7c8c482240a4e457ff26930c4a800331ec9a565832f4a26b05aa189e690b876.js

I, [2017-01-22T21:55:22.923600 #3095] INFO -- : Removed locales/it-7e1d737729288534422df10d26c1b9357bd99ef564864ac74c1080c53037c9a5.js

I, [2017-01-22T21:55:22.929519 #3095] INFO -- : Removed locales/ja-90d4866d75e8e5c66cb904ef183adae9eb1ec8ea412d548a25b9f8b367258fdf.js

I, [2017-01-22T21:55:22.939078 #3095] INFO -- : Removed default-270b9c30b239e0622b55c68a93351ad8b56bde4af52e9dc6dee3ed4d7e1124b5.css

I, [2017-01-22T21:55:22.944889 #3095] INFO -- : Removed locales/nl-3f2643487cd26bc712d2d53bade04dcfbf8de02db124d1453990847eac991965.js

I, [2017-01-22T21:55:22.953021 #3095] INFO -- : Removed dark-681a673a66ecee6ff638adb9b42edc00086247fb6aa9dc57b93483f16f574571.css

I, [2017-01-22T21:55:22.958845 #3095] INFO -- : Removed application-980d667388976612422c0fe6c0d43931fa69a72be6e28023e8c02adc2d3e0db2.js

Using release configuration from last framework (Ruby).

-----> [cron] /opt/openproject/packaging/cron/openproject-clear-old-sessions => /etc/cron.d/openproject-clear-old-sessions

-----> Verifying package openproject_6.1.4-1485121203.2cb8b63.trusty_amd64.deb

NEW PACKAGE: openproject_6.1.4-1485121203.2cb8b63.trusty_amd64.deb (294.01 MiB)

-----> Releasing...

DONE!

====== Attempt #1

-----> Fetching repository

Cloning into '/tmp/d20170122-16665-1cqf3a7/input'...

-----> Restoring cache

-----> Starting packaging process

-----> Installing missing build dependencies: libmagickwand-dev, libsqlite3-dev

-----> [wizard] adding legacy-installer wizard (https://github.com/pkgr/addon-legacy-installer#master)

-----> [wizard] adding mysql wizard (https://github.com/pkgr/addon-mysql#master)

-----> [wizard] adding apache2 wizard (https://github.com/pkgr/addon-apache2#master)

-----> [wizard] adding repositories wizard (https://github.com/finnlabs/addon-repositories#master)

-----> [wizard] adding smtp wizard (https://github.com/pkgr/addon-smtp#master)

-----> [wizard] adding memcached wizard (https://github.com/pkgr/addon-memcached#master)

-----> [wizard] adding openproject wizard (https://github.com/pkgr/addon-openproject#master)

-----> Fetching buildpack https://github.com/opf/heroku-buildpack-multi.git at master

-----> Multipack app

-----> Running hook: "packaging/setup"

WARNING: This buildpack is no longer maintained.

Please choose a different buildpack or go to https://github.com/ddollar/heroku-buildpack-multi

and fork it to your own account.

=====> Downloading Buildpack: https://github.com/pkgr/pkgr-buildpack-imagemagick.git

=====> Detected Framework: ImageMagick

-----> SKIP

=====> Downloading Buildpack: https://github.com/heroku/heroku-buildpack-nodejs.git

=====> Detected Framework: Node.js

-----> Reading application state

package.json...

build directory...

cache directory...

environment variables...

Node engine: 6.9.1

Npm engine: 4.0.0

Start mechanism: Procfile

node_modules source: package.json

node_modules cached: true

NPM_CONFIG_PRODUCTION=true

NODE_MODULES_CACHE=true

-----> Installing binaries

Downloading and installing node 6.9.1...

Downloading and installing npm 4.0.0 (replacing version 3.10.8)...

-----> Building dependencies

Restoring node modules from cache

Pruning unused dependencies

Installing any new modules

> openproject@0.1.0 postinstall /tmp/d20170122-18-cxm1tu/opt/openproject

> cd frontend && npm install

> openproject-frontend@0.1.0 postinstall /tmp/d20170122-18-cxm1tu/opt/openproject/frontend

> bower install --config.interactive=false

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 not-cached git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolve git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de not-cached git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolve git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 not-cached git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolve git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 checkout d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower jquery-ujs#1.0.0 not-cached https://github.com/rails/jquery-ujs.git#1.0.0

bower jquery-ujs#1.0.0 resolve https://github.com/rails/jquery-ujs.git#1.0.0

bower select2#3.5.2 not-cached https://github.com/ivaynberg/select2.git#3.5.2

bower select2#3.5.2 resolve https://github.com/ivaynberg/select2.git#3.5.2

bower jquery.atwho#0.5.1 not-cached https://github.com/ichord/At.js.git#0.5.1

bower jquery.atwho#0.5.1 resolve https://github.com/ichord/At.js.git#0.5.1

bower angular#~1.5.8 not-cached https://github.com/angular/bower-angular.git#~1.5.8

bower angular#~1.5.8 resolve https://github.com/angular/bower-angular.git#~1.5.8

bower jquery#1.11.0 not-cached https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery#1.11.0 resolve https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery-ui#~1.10.4 not-cached https://github.com/components/jqueryui.git#~1.10.4

bower jquery-ui#~1.10.4 resolve https://github.com/components/jqueryui.git#~1.10.4

bower angular-animate#~1.5.8 not-cached https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-animate#~1.5.8 resolve https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-ui-router#~0.3.1 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-ui-router#~0.3.1 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-aria#~1.5.8 not-cached https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-aria#~1.5.8 resolve https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-sanitize#~1.5.8 not-cached https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-sanitize#~1.5.8 resolve https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-i18n#~1.5.5 not-cached https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-i18n#~1.5.5 resolve https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-elastic#~2.5.1 not-cached https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-elastic#~2.5.1 resolve https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-cache#~4.6.0 not-cached https://github.com/jmdobry/angular-cache.git#~4.6.0

bower angular-cache#~4.6.0 resolve https://github.com/jmdobry/angular-cache.git#~4.6.0

bower jquery-migrate#~1.2.1 not-cached https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower jquery-migrate#~1.2.1 resolve https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower moment#~2.10.6 not-cached https://github.com/moment/moment.git#~2.10.6

bower moment#~2.10.6 resolve https://github.com/moment/moment.git#~2.10.6

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de checkout fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 checkout a908eccaec323cd66973d58af4965694bdff16a1

bower moment-timezone#0.4.x not-cached https://github.com/moment/moment-timezone.git#0.4.x

bower moment-timezone#0.4.x resolve https://github.com/moment/moment-timezone.git#0.4.x

bower angular-busy#~4.1.3 not-cached https://github.com/cgross/angular-busy.git#~4.1.3

bower angular-busy#~4.1.3 resolve https://github.com/cgross/angular-busy.git#~4.1.3

bower foundation-apps#1.1.0 not-cached https://github.com/zurb/foundation-apps.git#1.1.0

bower foundation-apps#1.1.0 resolve https://github.com/zurb/foundation-apps.git#1.1.0

bower lodash#~2.4.1 not-cached https://github.com/lodash/lodash.git#~2.4.1

bower lodash#~2.4.1 resolve https://github.com/lodash/lodash.git#~2.4.1

bower angular-ui-select#~0.19.4 not-cached https://github.com/angular-ui/ui-select.git#~0.19.4

bower angular-ui-select#~0.19.4 resolve https://github.com/angular-ui/ui-select.git#~0.19.4

bower bourbon#~4.2.1 not-cached https://github.com/thoughtbot/bourbon.git#~4.2.1

bower bourbon#~4.2.1 resolve https://github.com/thoughtbot/bourbon.git#~4.2.1

bower mousetrap#~1.4.6 not-cached https://github.com/ccampbell/mousetrap.git#~1.4.6

bower mousetrap#~1.4.6 resolve https://github.com/ccampbell/mousetrap.git#~1.4.6

bower ng-file-upload#~5.0.9 not-cached https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower ng-file-upload#~5.0.9 resolve https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower rxjs#^4.1.0 not-cached https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower rxjs#^4.1.0 resolve https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower angular-dragula#^1.2.8 not-cached https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower angular-dragula#^1.2.8 resolve https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower ng-dialog#^0.6.2 not-cached https://github.com/likeastore/ngDialog.git#^0.6.2

bower ng-dialog#^0.6.2 resolve https://github.com/likeastore/ngDialog.git#^0.6.2

bower chai#~1.9.0 not-cached https://github.com/chaijs/chai.git#~1.9.0

bower chai#~1.9.0 resolve https://github.com/chaijs/chai.git#~1.9.0

bower angular-mocks#~1.5.8 not-cached https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower angular-mocks#~1.5.8 resolve https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower jquery-mockjax#~1.5.3 not-cached https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery-mockjax#~1.5.3 resolve https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery.atwho#0.5.1 checkout v0.5.1

bower select2#3.5.2 checkout 3.5.2

bower mocha#~1.14.0 not-cached https://github.com/mochajs/mocha.git#~1.14.0

bower mocha#~1.14.0 resolve https://github.com/mochajs/mocha.git#~1.14.0

bower jquery#1.11.0 checkout 1.11.0

bower angular#~1.5.8 checkout v1.5.11

bower angular-ui-router#~0.3.1 checkout 0.3.2

bower jquery-ujs#1.0.0 checkout v1.0.0

bower jquery-ui#~1.10.4 checkout 1.10.4

bower angular-animate#~1.5.8 checkout v1.5.11

bower angular-cache#~4.6.0 checkout 4.6.0

bower angular-aria#~1.5.8 checkout v1.5.11

bower angular-elastic#~2.5.1 checkout v2.5.1

bower moment#~2.10.6 checkout 2.10.6

bower jquery-migrate#~1.2.1 checkout 1.2.1

bower angular-i18n#~1.5.5 checkout v1.5.11

bower angular-sanitize#~1.5.8 checkout v1.5.11

bower angular-ui-select#~0.19.4 checkout v0.19.6

bower lodash#~2.4.1 checkout 2.4.2

bower foundation-apps#1.1.0 checkout v1.1.0

bower angular-busy#~4.1.3 checkout v4.1.4

bower moment-timezone#0.4.x checkout 0.4.1

bower mousetrap#~1.4.6 checkout 1.4.6

bower bourbon#~4.2.1 checkout v4.2.7

bower angular-dragula#^1.2.8 checkout v1.2.8

bower ng-file-upload#~5.0.9 checkout 5.0.9

bower rxjs#^4.1.0 checkout v4.1.0

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolved git://github.com/finnlabs/angular-modal.git#d45eb9ceb7

bower angular#^1.3.0 not-cached https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 resolve https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 checkout v1.6.1

bower jquery-mockjax#~1.5.3 checkout v1.5.4

bower ng-dialog#^0.6.2 checkout v0.6.6

bower angular-mocks#~1.5.8 checkout v1.5.11

bower mocha#~1.14.0 checkout 1.14.0

bower chai#~1.9.0 checkout 1.9.2

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .png files: ["select2.png","select2x2.png"]

bower jquery.atwho#0.5.1 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower select2#3.5.2 resolved https://github.com/ivaynberg/select2.git#3.5.2

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolved git://github.com/sparkalow/angular-truncate.git#fdf60fda26

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolved git://github.com/nickmessing/angular-context-menu.git#a908eccaec

bower angular#>= 1.2.5 not-cached https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 resolve https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 checkout v1.6.1

bower jquery.atwho#0.5.1 resolved https://github.com/ichord/At.js.git#0.5.1

bower jquery#1.11.0 resolved https://github.com/jquery/jquery-dist.git#1.11.0

bower Caret.js#>= 0.2.0 not-cached https://github.com/ichord/Caret.js.git#>= 0.2.0

bower Caret.js#>= 0.2.0 resolve https://github.com/ichord/Caret.js.git#>= 0.2.0

bower jquery-ujs#1.0.0 resolved https://github.com/rails/jquery-ujs.git#1.0.0

bower angular-animate#~1.5.8 resolved https://github.com/angular/bower-angular-animate.git#1.5.11

bower jquery-ui#~1.10.4 resolved https://github.com/components/jqueryui.git#1.10.4

bower angular-ui-router#~0.3.1 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.3.2

bower angular#~1.5.8 resolved https://github.com/angular/bower-angular.git#1.5.11

bower angular-cache#~4.6.0 resolved https://github.com/jmdobry/angular-cache.git#4.6.0

bower angular-elastic#~2.5.1 resolved https://github.com/monospaced/angular-elastic.git#2.5.1

bower angular-aria#~1.5.8 resolved https://github.com/angular/bower-angular-aria.git#1.5.11

bower jquery-migrate#~1.2.1 deprecated Package jquery-migrate is using the deprecated component.json

bower jquery-migrate#~1.2.1 resolved https://github.com/appleboy/jquery-migrate.git#1.2.1

bower angular-sanitize#~1.5.8 resolved https://github.com/angular/bower-angular-sanitize.git#1.5.11

bower angular-ui-select#~0.19.4 resolved https://github.com/angular-ui/ui-select.git#0.19.6

bower moment#~2.10.6 resolved https://github.com/moment/moment.git#2.10.6

bower lodash#~2.4.1 resolved https://github.com/lodash/lodash.git#2.4.2

bower foundation-apps#1.1.0 resolved https://github.com/zurb/foundation-apps.git#1.1.0

bower angular#~1.3.4 not-cached https://github.com/angular/bower-angular.git#~1.3.4

bower angular#~1.3.4 resolve https://github.com/angular/bower-angular.git#~1.3.4

bower angular-ui-router#~0.2.12 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-ui-router#~0.2.12 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-animate#~1.3.4 not-cached https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular-animate#~1.3.4 resolve https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular#~1.3.4 checkout v1.3.20

bower angular-ui-router#~0.2.12 checkout 0.2.18

bower angular-animate#~1.3.4 checkout v1.3.20

bower mousetrap#~1.4.6 resolved https://github.com/ccampbell/mousetrap.git#1.4.6

bower angular-dragula#^1.2.8 resolved https://github.com/bevacqua/angular-dragula.git#1.2.8

bower ng-file-upload#~5.0.9 resolved https://github.com/danialfarid/angular-file-upload-bower.git#5.0.9

bower viewport-units-buggyfill#~0.4.1 not-cached https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower viewport-units-buggyfill#~0.4.1 resolve https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower fastclick#~1.0.3 not-cached https://github.com/ftlabs/fastclick.git#~1.0.3

bower fastclick#~1.0.3 resolve https://github.com/ftlabs/fastclick.git#~1.0.3

bower tether#~0.6.5 not-cached https://github.com/HubSpot/tether.git#~0.6.5

bower tether#~0.6.5 resolve https://github.com/HubSpot/tether.git#~0.6.5

bower hammerjs#~2.0.4 not-cached https://github.com/EightMedia/hammer.js.git#~2.0.4

bower hammerjs#~2.0.4 resolve https://github.com/EightMedia/hammer.js.git#~2.0.4

bower angular-busy#~4.1.3 resolved https://github.com/cgross/angular-busy.git#4.1.4

bower moment-timezone#0.4.x resolved https://github.com/moment/moment-timezone.git#0.4.1

bower bourbon#~4.2.1 resolved https://github.com/thoughtbot/bourbon.git#4.2.7

bower ng-dialog#^0.6.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .css files: ["css/ngDialog.css","css/ngDialog-theme-default.css"]

bower ng-dialog#^0.6.2 resolved https://github.com/likeastore/ngDialog.git#0.6.6

bower jquery-mockjax#~1.5.3 resolved https://github.com/jakerella/jquery-mockjax.git#1.5.4

bower angular-mocks#~1.5.8 resolved https://github.com/angular/bower-angular-mocks.git#1.5.11

bower angular#^1.3.0 resolved https://github.com/angular/bower-angular.git#1.6.1

bower angular-i18n#~1.5.5 resolved https://github.com/angular/bower-angular-i18n.git#1.5.11

bower mocha#~1.14.0 mismatch Version declared in the json (1.12.0) is different than the resolved one (1.14.0)

bower Caret.js#>= 0.2.0 checkout v0.3.1

bower mocha#~1.14.0 resolved https://github.com/mochajs/mocha.git#1.14.0

bower chai#~1.9.0 resolved https://github.com/chaijs/chai.git#1.9.2

bower angular#>= 1.2.5 resolved https://github.com/angular/bower-angular.git#1.6.1

bower angular-ui-router#~0.2.12 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.2.18

bower angular-animate#~1.3.4 resolved https://github.com/angular/bower-angular-animate.git#1.3.20

bower viewport-units-buggyfill#~0.4.1 checkout v0.4.1

bower fastclick#~1.0.3 checkout v1.0.6

bower angular#~1.3.4 resolved https://github.com/angular/bower-angular.git#1.3.20

bower tether#~0.6.5 checkout v0.6.5

bower hammerjs#~2.0.4 checkout v2.0.8

bower rxjs#^4.1.0 resolved https://github.com/Reactive-Extensions/RxJS.git#4.1.0

bower Caret.js#>= 0.2.0 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower Caret.js#>= 0.2.0 resolved https://github.com/ichord/Caret.js.git#0.3.1

bower fastclick#~1.0.3 resolved https://github.com/ftlabs/fastclick.git#1.0.6

bower viewport-units-buggyfill#~0.4.1 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .js files: ["./viewport-units-buggyfill.js","./viewport-units-buggyfill.hacks.js"]

bower viewport-units-buggyfill#~0.4.1 resolved https://github.com/rodneyrehm/viewport-units-buggyfill.git#0.4.1

bower hammerjs#~2.0.4 resolved https://github.com/EightMedia/hammer.js.git#2.0.8

bower tether#~0.6.5 resolved https://github.com/HubSpot/tether.git#0.6.5

Please note that,

foundation-apps#1.1.0 depends on angular-animate#~1.3.4 which resolved to angular-animate#1.3.20

openproject depends on angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

angular-busy#4.1.4 depends on angular-animate#>=1.3 which resolved to angular-animate#1.5.11

Resort to using angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

Code incompatibilities may occur.

Please note that,

foundation-apps#1.1.0 depends on angular-ui-router#~0.2.12 which resolved to angular-ui-router#0.2.18

openproject depends on angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Resort to using angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Code incompatibilities may occur.

Please note that,

angular-animate#1.3.20 depends on angular#1.3.20 which resolved to angular#1.3.20

foundation-apps#1.1.0 depends on angular#~1.3.4 which resolved to angular#1.3.20

angular-animate#1.5.11, angular-aria#1.5.11, angular-mocks#1.5.11, angular-sanitize#1.5.11 depends on angular#1.5.11 which resolved to angular#1.5.11

angular-ui-router#0.3.2, angular-ui-router#0.2.18 depends on angular#^1.0.8 which resolved to angular#1.5.11

angular-elastic#2.5.1 depends on angular#>=1.0.6 which resolved to angular#1.5.11

angular-ui-select#0.19.6 depends on angular#>=1.2.18 which resolved to angular#1.5.11

angular-busy#4.1.4 depends on angular#>=1.3 which resolved to angular#1.5.11

openproject depends on angular#~1.5.8 which resolved to angular#1.5.11

angular-cache#4.6.0 depends on angular#>=1.x which resolved to angular#1.5.11

ng-dialog#0.6.6 depends on angular#>=1.5 which resolved to angular#1.5.11

angular-context-menu#a908eccaec depends on angular#>= 1.2.5 which resolved to angular#1.6.1

angular-modal#d45eb9ceb7 depends on angular#^1.3.0 which resolved to angular#1.6.1

Resort to using angular#~1.5.8 which resolved to angular#1.5.11

Code incompatibilities may occur.

bower jquery extra-resolution Unnecessary resolution: jquery#1.11.0

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 install angular-modal#d45eb9ceb7

bower select2#3.5.2 install select2#3.5.2

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de install angular-truncate#fdf60fda26

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 install angular-context-menu#a908eccaec

bower jquery.atwho#0.5.1 install jquery.atwho#0.5.1

bower jquery#1.11.0 install jquery#1.11.0

bower jquery-ujs#1.0.0 install jquery-ujs#1.0.0

bower angular-animate#~1.5.8 install angular-animate#1.5.11

bower jquery-ui#~1.10.4 install jquery-ui#1.10.4

bower angular-ui-router#~0.3.1 install angular-ui-router#0.3.2

bower angular#1.5.11 install angular#1.5.11

bower angular-cache#~4.6.0 install angular-cache#4.6.0

bower angular-elastic#~2.5.1 install angular-elastic#2.5.1

bower angular-aria#~1.5.8 install angular-aria#1.5.11

bower jquery-migrate#~1.2.1 install jquery-migrate#1.2.1

bower angular-sanitize#~1.5.8 install angular-sanitize#1.5.11

bower angular-ui-select#~0.19.4 install angular-ui-select#0.19.6

bower moment#~2.10.6 install moment#2.10.6

bower lodash#~2.4.1 install lodash#2.4.2

bower foundation-apps#1.1.0 install foundation-apps#1.1.0

bower mousetrap#~1.4.6 install mousetrap#1.4.6

bower angular-dragula#^1.2.8 install angular-dragula#1.2.8

bower ng-file-upload#~5.0.9 install ng-file-upload#5.0.9

bower angular-busy#~4.1.3 install angular-busy#4.1.4

bower moment-timezone#0.4.x install moment-timezone#0.4.1

bower bourbon#~4.2.1 install bourbon#4.2.7

bower ng-dialog#^0.6.2 install ng-dialog#0.6.6

bower jquery-mockjax#~1.5.3 install jquery-mockjax#1.5.4

bower angular-mocks#~1.5.8 install angular-mocks#1.5.11

bower angular-i18n#~1.5.5 install angular-i18n#1.5.11

bower mocha#~1.14.0 install mocha#1.14.0

bower chai#~1.9.0 install chai#1.9.2

bower rxjs#^4.1.0 install rxjs#4.1.0

bower Caret.js#>= 0.2.0 install Caret.js#0.3.1

bower fastclick#~1.0.3 install fastclick#1.0.6

bower viewport-units-buggyfill#~0.4.1 install viewport-units-buggyfill#0.4.1

bower hammerjs#~2.0.4 install hammerjs#2.0.8

bower tether#~0.6.5 install tether#0.6.5

angular-modal#d45eb9ceb7 bower_components/angular-modal

└── angular#1.5.11

select2#3.5.2 bower_components/select2

└── jquery#1.11.0

angular-truncate#fdf60fda26 bower_components/angular-truncate

angular-context-menu#a908eccaec bower_components/angular-context-menu

└── angular#1.5.11

jquery.atwho#0.5.1 bower_components/jquery.atwho

├── Caret.js#0.3.1

└── jquery#1.11.0

jquery#1.11.0 bower_components/jquery

jquery-ujs#1.0.0 bower_components/jquery-ujs

└── jquery#1.11.0

angular-animate#1.5.11 bower_components/angular-animate

└── angular#1.5.11

jquery-ui#1.10.4 bower_components/jquery-ui

└── jquery#1.11.0

angular-ui-router#0.3.2 bower_components/angular-ui-router

└── angular#1.5.11

angular#1.5.11 bower_components/angular

angular-cache#4.6.0 bower_components/angular-cache

└── angular#1.5.11

angular-elastic#2.5.1 bower_components/angular-elastic

└── angular#1.5.11

angular-aria#1.5.11 bower_components/angular-aria

└── angular#1.5.11

jquery-migrate#1.2.1 bower_components/jquery-migrate

angular-sanitize#1.5.11 bower_components/angular-sanitize

└── angular#1.5.11

angular-ui-select#0.19.6 bower_components/angular-ui-select

└── angular#1.5.11

moment#2.10.6 bower_components/moment

lodash#2.4.2 bower_components/lodash

foundation-apps#1.1.0 bower_components/foundation-apps

├── angular#1.5.11

├── angular-animate#1.5.11

├── angular-ui-router#0.3.2

├── fastclick#1.0.6

├── hammerjs#2.0.8

├── tether#0.6.5

└── viewport-units-buggyfill#0.4.1

mousetrap#1.4.6 bower_components/mousetrap

angular-dragula#1.2.8 bower_components/angular-dragula

ng-file-upload#5.0.9 bower_components/ng-file-upload

angular-busy#4.1.4 bower_components/angular-busy

├── angular#1.5.11

└── angular-animate#1.5.11

moment-timezone#0.4.1 bower_components/moment-timezone

└── moment#2.10.6

bourbon#4.2.7 bower_components/bourbon

ng-dialog#0.6.6 bower_components/ng-dialog

└── angular#1.5.11

jquery-mockjax#1.5.4 bower_components/jquery-mockjax

angular-mocks#1.5.11 bower_components/angular-mocks

└── angular#1.5.11

angular-i18n#1.5.11 bower_components/angular-i18n

mocha#1.14.0 bower_components/mocha

chai#1.9.2 bower_components/chai

rxjs#4.1.0 bower_components/rxjs

Caret.js#0.3.1 bower_components/Caret.js

└── jquery#1.11.0

fastclick#1.0.6 bower_components/fastclick

viewport-units-buggyfill#0.4.1 bower_components/viewport-units-buggyfill

hammerjs#2.0.8 bower_components/hammerjs

tether#0.6.5 bower_components/tether

openproject-frontend@0.1.0 /tmp/d20170122-18-cxm1tu/opt/openproject/frontend

+-- acorn@2.6.4

+-- align-text@0.1.4

+-- alter@0.2.0

+-- amdefine@1.0.0

+-- angular@1.5.8

+-- angular-elastic@2.5.1

+-- angular-ui-bootstrap@2.2.0

+-- anymatch@1.3.0

+-- arr-diff@2.0.0

+-- arr-flatten@1.0.1

+-- array-unique@0.2.1

+-- arrify@1.0.1

+-- assert@1.4.1

+-- async@0.2.10

+-- async-each@1.0.1

+-- atoa@1.0.0

+-- autoprefixer-core@5.2.1

+-- autoprefixer-loader@1.2.0

+-- awesome-typescript-loader@2.2.4

| `-- lodash@4.16.4

+-- balanced-match@0.4.2

+-- Base64@0.2.1

+-- base64-js@1.2.0

+-- big.js@3.1.3

+-- binary-extensions@1.7.0

+-- bower@1.7.9

+-- brace-expansion@1.1.6

+-- braces@1.8.5

+-- browserify-zlib@0.1.4

+-- browserslist@0.4.0

+-- buffer@4.9.1

+-- buffer-shims@1.0.0

+-- camelcase@1.2.1

+-- caniuse-db@1.0.30000569

+-- center-align@0.1.3

+-- chokidar@1.6.1

+-- cliui@2.1.0

| `-- wordwrap@0.0.2

+-- clone@1.0.2

+-- colors@1.1.2

+-- concat-map@0.0.1

+-- console-browserify@1.1.0

+-- constants-browserify@0.0.1

+-- contra@1.9.4

+-- convert-source-map@1.1.3

+-- core-util-is@1.0.2

+-- crossvent@1.5.4

+-- crypto-browserify@3.2.8

+-- css-loader@0.9.1

| `-- source-map@0.1.43

+-- csso@1.3.12

+-- custom-event@1.0.0

+-- d@0.1.1

+-- date-now@0.1.4

+-- decamelize@1.2.0

+-- domain-browser@1.1.7

+-- dragula@3.7.2

+-- emojis-list@2.1.0

+-- enhanced-resolve@2.3.0

+-- errno@0.1.4

+-- es5-ext@0.10.12

+-- es6-iterator@2.0.0

+-- es6-promise@2.3.0

+-- es6-symbol@3.1.0

+-- es6-weak-map@0.1.4

| +-- es6-iterator@0.1.3

| `-- es6-symbol@2.0.1

+-- event-emitter@0.3.4

+-- events@1.1.1

+-- expand-brackets@0.1.5

+-- expand-range@1.8.2

+-- exports-loader@0.6.3

| `-- source-map@0.1.43

+-- expose-loader@0.6.0

+-- extglob@0.3.2

+-- extract-text-webpack-plugin@0.3.8

| `-- source-map@0.1.43

+-- fastparse@1.1.1

+-- file-loader@0.8.5

+-- filename-regex@2.0.0

+-- fill-range@2.2.3

+-- for-in@0.1.6

+-- for-own@0.1.4

+-- glob@4.5.3

+-- glob-base@0.3.0

+-- glob-parent@2.0.0

+-- graceful-fs@4.1.9

+-- has-flag@1.0.0

+-- html-loader@0.2.3

| `-- source-map@0.1.43

+-- html-minifier@0.5.6

+-- http-browserify@1.7.0

+-- https-browserify@0.0.0

+-- ieee754@1.1.8

+-- indexof@0.0.1

+-- inflight@1.0.6

+-- inherits@2.0.3

+-- interpret@0.6.6

+-- is-binary-path@1.0.1

+-- is-buffer@1.1.4

+-- is-dotfile@1.0.2

+-- is-equal-shallow@0.1.3

+-- is-extendable@0.1.1

+-- is-extglob@1.0.0

+-- is-glob@2.0.1

+-- is-number@2.1.0

+-- is-posix-bracket@0.1.1

+-- is-primitive@2.0.0

+-- isarray@1.0.0

+-- isobject@2.1.0

+-- js-base64@2.1.9

+-- json5@0.4.0

+-- kind-of@3.0.4

+-- lazy-cache@1.0.4

+-- loader-utils@0.2.16

| `-- json5@0.5.0

+-- lodash@2.4.2

+-- longest@1.0.1

+-- lru-queue@0.1.0

+-- memoizee@0.3.10

+-- memory-fs@0.3.0

+-- micromatch@2.3.11

+-- mime@1.2.11

+-- minimatch@2.0.10

+-- minimist@0.0.10

+-- mkdirp@0.5.1

| `-- minimist@0.0.8

+-- nan@2.4.0

+-- next-tick@0.2.2

+-- ng-annotate@1.2.1

| `-- source-map@0.5.6

+-- ng-annotate-loader@0.0.10

| `-- source-map@0.4.2

+-- ngtemplate-loader@0.1.3

+-- node-libs-browser@0.6.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- normalize-path@2.0.1

+-- num2fraction@1.2.2

+-- object-assign@4.1.0

+-- object.omit@2.0.1

+-- observable-array@0.0.4

+-- observable-value@0.0.5

+-- once@1.4.0

+-- optimist@0.6.1

+-- ordered-ast-traverse@1.1.1

+-- ordered-esprima-props@1.1.0

+-- os-browserify@0.1.2

+-- pako@0.2.9

+-- parse-glob@3.0.4

+-- path-browserify@0.0.0

+-- path-is-absolute@1.0.1

+-- pbkdf2-compat@2.0.1

+-- phantomjs-polyfill@0.0.2

+-- postcss@4.1.16

+-- preserve@0.2.0

+-- process@0.11.9

+-- process-nextick-args@1.0.7

+-- prr@0.0.0

+-- punycode@1.4.1

+-- querystring@0.2.0

+-- querystring-es3@0.2.1

+-- randomatic@1.1.5

+-- readable-stream@2.1.5

+-- readdirp@2.1.0

| `-- minimatch@3.0.3

+-- regex-cache@0.4.3

+-- repeat-element@1.1.2

+-- repeat-string@1.6.1

+-- right-align@0.1.3

+-- ripemd160@0.2.0

+-- set-immediate-shim@1.0.1

+-- sha.js@2.2.6

+-- shelljs@0.3.0

+-- simple-fmt@0.1.0

+-- simple-is@0.2.0

+-- source-list-map@0.1.6

+-- source-map@0.4.4

+-- source-map-support@0.4.5

| `-- source-map@0.5.6

+-- stable@0.1.5

+-- stream-browserify@1.0.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- string_decoder@0.10.31

+-- stringmap@0.2.2

+-- stringset@0.2.1

+-- style-loader@0.8.3

+-- supports-color@3.1.2

+-- tapable@0.2.4

+-- ticky@1.0.1

+-- timers-browserify@1.4.2

+-- timers-ext@0.1.0

+-- tryor@0.1.2

+-- tty-browserify@0.0.0

+-- typescript@2.0.6

+-- uglify-js@2.7.4

| `-- source-map@0.5.6

+-- uglify-to-browserify@1.0.2

+-- URIjs@1.16.1

+-- url@0.10.3

| `-- punycode@1.3.2

+-- url-loader@0.5.7

+-- util@0.10.3

| `-- inherits@2.0.1

+-- util-deprecate@1.0.2

+-- vm-browserify@0.0.4

+-- watchpack@0.2.9

| `-- async@0.9.2

+-- webpack@1.13.3

| +-- acorn@3.3.0

| +-- async@1.5.2

| +-- enhanced-resolve@0.9.1

| | `-- memory-fs@0.2.0

| `-- tapable@0.1.10

+-- webpack-core@0.6.8

+-- window-size@0.1.0

+-- wordwrap@0.0.3

+-- wrappy@1.0.2

`-- yargs@3.10.0

npm WARN openproject-frontend@0.1.0 No repository field.

npm WARN openproject-frontend@0.1.0 No license field.

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.0.14 (node_modules/fsevents):

npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.0.14: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

-----> Checking startup method

Found Procfile

-----> Finalizing build

Creating runtime environment

Exporting binary paths

Cleaning npm artifacts

Cleaning previous cache

Caching results for future builds

-----> Build succeeded!

openproject@0.1.0 /tmp/d20170122-18-cxm1tu/opt/openproject

`-- typescript@2.0.8

=====> Downloading Buildpack: https://github.com/pkgr/heroku-buildpack-ruby.git

=====> Detected Framework: Ruby

-----> Compiling Ruby/Rails

-----> Using Ruby version: ruby-2.3.1

-----> Installing dependencies using bundler 1.13.2

cp: '/tmp/d20170122-18-cxm1tu/opt/openproject/.git/cache/vendor/bundle/.' and '/tmp/d20170122-18-cxm1tu/opt/openproject/.git/cache/vendor/bundle/.' are the same file

Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Fetching gem metadata from https://rubygems.org/......

Fetching version metadata from https://rubygems.org/..

Fetching dependency metadata from https://rubygems.org/.

Using i18n 0.7.0

Installing minitest 5.9.0

Installing rake 11.3.0

Installing concurrent-ruby 1.0.2

Using thread_safe 0.3.5

Using erubis 2.7.0

Using mini_portile2 2.1.0

Using rack 2.0.1

Using nio4r 1.2.1

Using websocket-extensions 0.1.2

Using mime-types 2.99.3

Using method_source 0.8.2

Installing builder 3.2.2

Installing pkg-config 1.1.7

Using multi_json 1.12.1

Using acts_as_silent_list 3.0.0

Using addressable 2.4.0

Using airbrake-ruby 1.5.0

Using attr_required 1.0.1

Using execjs 2.7.0

Using ice_nine 0.11.2

Using bcrypt 3.1.11

Using bindata 2.3.4

Using sass 3.4.22

Using tilt 2.0.5

Using uber 0.0.15

Using erbse 0.0.2

Using coderay 1.1.1

Using color-tools 1.3.0

Using unf_ext 0.0.7.2

Using netrc 0.11.0

Using daemons 1.2.4

Using dalli 2.7.6

Using enumerable-lazy 0.0.1

Using equalizer 0.0.11

Using excon 0.52.0

Using ffi 1.9.14

Using formatador 0.2.5

Using ipaddress 0.8.3

Using get_process_mem 0.2.1

Using request_store 1.3.1

Using json 1.8.3

Using hashie 3.4.6

Using multi_xml 0.5.5

Using gravatar_image_tag 1.2.0

Using bundler 1.13.2

Using htmldiff 0.0.1

Installing thor 0.19.1

Installing arel 7.1.2

Using icalendar 2.3.0

Using iso8601 0.9.1

Using securecompare 1.0.0

Using url_safe_base64 0.2.2

Using kgio 2.10.0

Using mixlib-shellout 2.1.0

Using mysql2 0.4.4

Using net-ldap 0.14.0

Using newrelic_rpm 3.16.2.321

Using oj 2.17.4

Using pdf-core 0.6.1

Using ttfunk 1.4.0

Using rmagick 2.15.4

Using rubyzip 1.2.0

Using ruby-ole 1.2.12

Using pg 0.19.0

Using rails_serve_static_assets 0.0.5

Using rails_stdout_logging 0.0.5

Using raindrops 0.17.0

Using ruby-progressbar 1.8.1

Using structured_warnings 0.2.0

Using sqlite3 1.3.11

Using stringex 2.6.1

Using svg-graph 2.0.1

Using syck 1.0.5

Using will_paginate 3.1.3

Using i18n-js 3.0.0.rc14

Using tzinfo 1.2.2

Using descendants_tracker 0.0.4

Using rack-test 0.6.3

Using rack-accept 0.4.5

Using passenger 5.0.30

Using rack-attack 5.0.1

Using rack-protection 2.0.0.beta2

Using warden 1.2.6

Using websocket-driver 0.6.4

Using mail 2.6.4

Installing httpclient 2.8.2.4

Using airbrake 5.1.0

Using autoprefixer-rails 6.4.1.1

Using cells 4.1.3

Using unf 0.1.4

Using mustermann19 0.4.4

Using sys-filesystem 1.1.7

Using fog-core 1.42.0

Using rdoc 4.2.2

Using omniauth 1.3.1 from https://github.com/oliverguenther/omniauth (at 8385bc0@8385bc0)

Using prawn 2.1.0

Using spreadsheet 0.8.9

Using rails_12factor 0.0.3

Using unicorn 5.1.0

Using rubytree 0.9.7

Using bourbon 4.2.7

Installing sprockets 3.7.0

Using tzinfo-data 1.2016.6

Using axiom-types 0.1.1

Using coercible 1.0.0

Using warden-basic_auth 0.2.1

Using cells-erb 0.0.8

Using domain_name 0.5.20161129

Using fog-json 1.0.2

Using prawn-table 0.2.2

Using unicorn-worker-killer 0.4.4

Using virtus 1.0.5

Using http-cookie 1.0.3

Using rest-client 1.8.0

Using crowdin-api 0.4.1

Installing activesupport 5.0.0.1

Using globalid 0.3.7

Using climate_control 0.0.3

Using delayed_job 4.1.2

Using grape 0.17.0

Installing json-jwt 1.6.5

Installing activemodel 5.0.0.1

Using swd 1.0.1

Using webfinger 1.0.2

Using rabl 0.13.0

Using ruby-duration 3.2.3

Installing rack-oauth2 1.4.0

Installing activejob 5.0.0.1

Using cocaine 0.5.8

Using grape-cache_control 1.0.1

Using carrierwave 1.0.0.beta from https://github.com/carrierwaveuploader/carrierwave (at master@5367a63)

Using date_validator 0.9.0

Using validate_email 0.1.6

Using validate_url 1.0.2

Using openid_connect 0.8.3

Using omniauth-openid-connect 0.2.0 from https://github.com/finnlabs/omniauth-openid-connect.git (at dev@c3bce4c)

Using omniauth-openid_connect-providers 0.1.0 from https://github.com/finnlabs/omniauth-openid_connect-providers.git (at dev@86f3670)

Installing activerecord 5.0.0.1

Using activemodel-serializers-xml 1.0.1

Using acts_as_list 0.8.1

Using acts_as_tree 2.5.1

Using awesome_nested_set 3.1.1

Using delayed_job_active_record 4.1.1

Using friendly_id 5.2.0.beta.1 from https://github.com/norman/friendly_id (at aff0564@aff0564)

Using globalize 5.1.0 from https://github.com/globalize/globalize (at 38443bc@38443bc)

Using transactional_lock 0.1.0 from https://github.com/finnlabs/transactional_lock.git (at master@6948b1d)

Installing nokogiri 1.6.8 with native extensions

Using loofah 2.0.3

Using representable 2.1.8

Using fog-xml 0.1.2

Using ruby-saml 1.4.0

Using rails-html-sanitizer 1.0.3

Using disposable 0.0.9

Using roar 1.0.4

Using fog-aws 0.11.0

Using omniauth-saml 1.6.0 from git://github.com/omniauth/omniauth-saml.git (at master@5559d6b)

Using reform 1.2.6

Using openproject-auth_saml 0.1.0 from https://github.com/finnlabs/openproject-auth_saml (at dev@97212ab)

Installing rails-dom-testing 2.0.1

Installing actionview 5.0.0.1

Installing actionpack 5.0.0.1

Installing actionmailer 5.0.0.1

Using cells-rails 0.0.6

Using gon 4.1.1

Using sprockets-rails 3.2.0

Installing actioncable 5.0.0.1

Installing railties 5.0.0.1

Using actionpack-xml_parser 2.0.0

Using activerecord-session_store 1.0.0

Using jquery-tablesorter 1.22.7

Using responders 2.3.0

Using sass-rails 5.0.6

Installing rails 5.0.0.1

Using health_check 2.2.1

Using lobby_boy 0.1.2

Using openproject-auth_plugins 6.1.4 from source at `vendored-plugins/openproject-auth_plugins`

Using openproject-pdf_export 6.1.4 from source at `vendored-plugins/openproject-pdf_export`

Using openproject-costs 6.1.4 from source at `vendored-plugins/openproject-costs`

Using openproject-documents 6.1.4 from source at `vendored-plugins/openproject-documents`

Using openproject-webhooks 6.1.4 from source at `vendored-plugins/openproject-webhooks`

Using openproject-global_roles 6.1.4 from source at `vendored-plugins/openproject-global_roles`

Using openproject-local_avatars 6.1.4 from source at `vendored-plugins/openproject-local_avatars`

Using openproject-meeting 6.1.4 from source at `vendored-plugins/openproject-meeting`

Using openproject-my_project_page 6.1.4 from source at `vendored-plugins/openproject-my_project_page`

Using reporting_engine 6.1.4 from source at `vendored-plugins/reporting_engine`

Using openproject-themes-dark 6.1.4 from source at `vendored-plugins/openproject-themes-dark`

Using openproject-translations 6.1.4 from https://github.com/opf/openproject-translations.git (at stable/6@da52ff9)

Using openproject-xls_export 6.1.4 from source at `vendored-plugins/openproject-xls_export`

Using rails-angular-xss 0.3.0.pre.pre from https://github.com/opf/rails-angular-xss (at a45267d@a45267d)

Using rails_autolink 1.1.6

Using openproject-backlogs 6.1.4 from source at `vendored-plugins/openproject-backlogs`

Using openproject-openid_connect 6.1.4 from source at `vendored-plugins/openproject-openid_connect`

Using openproject-github_integration 6.1.4 from source at `vendored-plugins/openproject-github_integration`

Using openproject-reporting 6.1.4 from source at `vendored-plugins/openproject-reporting`

Bundle complete! 138 Gemfile dependencies, 195 gems now installed.

Gems in the groups development and test were not installed.

Bundled gems are installed into ./vendor/bundle.

Bundle completed (23.68s)

Cleaning up the bundler cache.

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Removing thor (0.19.4)

Removing builder (3.2.3)

Removing arel (7.1.4)

Removing concurrent-ruby (1.0.4)

Removing activerecord (5.0.1)

Removing sprockets (3.7.1)

Removing rails-dom-testing (2.0.2)

Removing actioncable (5.0.1)

Removing rails (5.0.1)

Removing actionview (5.0.1)

Removing activesupport (5.0.1)

Removing rake (12.0.0)

Removing activejob (5.0.1)

Removing railties (5.0.1)

Removing rack-oauth2 (1.5.1)

Removing minitest (5.10.1)

Removing httpclient (2.8.3)

Removing activemodel (5.0.1)

Removing actionmailer (5.0.1)

Removing json-jwt (1.7.1)

Removing openproject-token (1.0.0)

Removing nokogiri (1.6.8.1)

Removing actionpack (5.0.1)

-----> Detecting rake tasks

-----> Preparing app for Rails asset pipeline

Running: rake assets:precompile

$(npm bin)/webpack --config webpack.production.config.js

{"omniauth-openid-connect":"/tmp/d20170122-18-cxm1tu/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid-connect-c3bce4c9e9ac","omniauth-openid_connect-providers":"/tmp/d20170122-18-cxm1tu/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid_connect-providers-86f3670e127e","omniauth-saml":"/tmp/d20170122-18-cxm1tu/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-saml-5559d6b80805","openproject-auth_plugins":"/tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-auth_plugins","openproject-auth_saml":"/tmp/d20170122-18-cxm1tu/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-auth_saml-97212abb8378","openproject-pdf_export":"/tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-pdf_export","openproject-backlogs":"/tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-backlogs","openproject-costs":"/tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-costs","openproject-documents":"/tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-documents","openproject-webhooks":"/tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-webhooks","openproject-github_integration":"/tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-github_integration","openproject-global_roles":"/tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-global_roles","openproject-local_avatars":"/tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-local_avatars","openproject-meeting":"/tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-meeting","openproject-my_project_page":"/tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-my_project_page","openproject-openid_connect":"/tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-openid_connect","reporting_engine":"/tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/reporting_engine","openproject-reporting":"/tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-reporting","openproject-themes-dark":"/tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-themes-dark","openproject-translations":"/tmp/d20170122-18-cxm1tu/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-translations-da52ff92cdcd","openproject-xls_export":"/tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-xls_export"}

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Hash: 4ae33da8a3d9033f43d5

Version: webpack 1.13.3

Child

Hash: 4ae33da8a3d9033f43d5

Version: webpack 1.13.3

Time: 14082ms

Asset Size Chunks Chunk Names

7b9776076d5fceef4993b55c9383dedd.gif 1.85 kB [emitted]

openproject-backlogs.js 453 kB 0 [emitted] backlogs

openproject-core-app.js 3.43 MB 1 [emitted] core-app

openproject-costs.js 526 kB 2 [emitted] costs

openproject-global.js 3.51 MB 3 [emitted] global

openproject-my_project_page.js 14.3 kB 4 [emitted] my_project_page

openproject-core-app.css 4.71 kB 1 [emitted] core-app

openproject-global.css 49 kB 3 [emitted] global

[213] ./templates \.html$ 1.22 kB {1} [built]

[242] ./components ^((?!\.(test|spec)).)*\.(js|ts|html)$ 16.1 kB {1} [built]

[633] /tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 425 bytes {2} [built]

[765] /tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 330 bytes {4} [built]

+ 769 hidden modules

ERROR in [default]

File '/tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-budget-subform.directive.ts' is not under 'rootDir' '/tmp/d20170122-18-cxm1tu/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts' is not under 'rootDir' '/tmp/d20170122-18-cxm1tu/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/subform/cost-subform.directive.ts' is not under 'rootDir' '/tmp/d20170122-18-cxm1tu/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts' is not under 'rootDir' '/tmp/d20170122-18-cxm1tu/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts' is not under 'rootDir' '/tmp/d20170122-18-cxm1tu/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-block.directive.ts' is not under 'rootDir' '/tmp/d20170122-18-cxm1tu/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-page-layout.directive.ts' is not under 'rootDir' '/tmp/d20170122-18-cxm1tu/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-textile-block.directive.ts' is not under 'rootDir' '/tmp/d20170122-18-cxm1tu/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default] /tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:49:18

Argument of type 'string' is not assignable to parameter of type '{ [key: string]: any; }'.

ERROR in [default] /tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:53:4

Supplied parameters do not match any signature of call target.

ERROR in [default] /tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:30:38

Cannot find module 'app/components/work-packages/work-package-cache.service'.

ERROR in [default] /tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:49:30

Cannot find name 'HalResource'.

ERROR in [default] /tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:54:57

Property '$injector' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:13

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:27

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:60:11

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:70:23

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:76:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:77:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:78:16

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:36:17

Property 'value' does not exist on type 'CurrencyDisplayField'.

ERROR in [default] /tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:37:23

Property 'value' does not exist on type 'CurrencyDisplayField'.

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 5 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

autoprefixer: /tmp/d20170122-18-cxm1tu/opt/openproject/app/assets/stylesheets/default.css.sass:6426:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-18-cxm1tu/opt/openproject/app/assets/stylesheets/default.css.sass:6456:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-18-cxm1tu/opt/openproject/app/assets/stylesheets/default.css.sass:11729:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-18-cxm1tu/opt/openproject/app/assets/stylesheets/default.css.sass:12110:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-18-cxm1tu/opt/openproject/app/assets/stylesheets/default.css.sass:12155:3: You should write display: flex by final spec instead of display: box

I, [2017-01-22T22:14:12.427601 #2744] INFO -- : Writing /tmp/d20170122-18-cxm1tu/opt/openproject/public/assets/default-b00e18110df905a5bf6f92466cbe06ed3965967d2d5e90d24ce836de132adb64.css

I, [2017-01-22T22:14:12.428488 #2744] INFO -- : Writing /tmp/d20170122-18-cxm1tu/opt/openproject/public/assets/default-b00e18110df905a5bf6f92466cbe06ed3965967d2d5e90d24ce836de132adb64.css.gz

I, [2017-01-22T22:14:14.407943 #2744] INFO -- : Writing /tmp/d20170122-18-cxm1tu/opt/openproject/public/assets/application-b8b0dc4e0bf3f4ffe8079e50b0722c042a5b61eb2f2a4bae1199f0fc80ed0530.js

I, [2017-01-22T22:14:14.408111 #2744] INFO -- : Writing /tmp/d20170122-18-cxm1tu/opt/openproject/public/assets/application-b8b0dc4e0bf3f4ffe8079e50b0722c042a5b61eb2f2a4bae1199f0fc80ed0530.js.gz

I, [2017-01-22T22:14:14.682291 #2744] INFO -- : Writing /tmp/d20170122-18-cxm1tu/opt/openproject/public/assets/locales/fa-ddde1dd90c7cd953dfe06fe7a99c8374773412c294f93ffe9efa3414e6b62c2a.js

I, [2017-01-22T22:14:14.683573 #2744] INFO -- : Writing /tmp/d20170122-18-cxm1tu/opt/openproject/public/assets/locales/fa-ddde1dd90c7cd953dfe06fe7a99c8374773412c294f93ffe9efa3414e6b62c2a.js.gz

I, [2017-01-22T22:14:14.697579 #2744] INFO -- : Writing /tmp/d20170122-18-cxm1tu/opt/openproject/public/assets/locales/id-a2a805a38128ac7a7ac9f665acb2885e446ba208b069cf9378b8ec1aec800649.js

I, [2017-01-22T22:14:14.697797 #2744] INFO -- : Writing /tmp/d20170122-18-cxm1tu/opt/openproject/public/assets/locales/id-a2a805a38128ac7a7ac9f665acb2885e446ba208b069cf9378b8ec1aec800649.js.gz

I, [2017-01-22T22:14:14.706065 #2744] INFO -- : Writing /tmp/d20170122-18-cxm1tu/opt/openproject/public/assets/locales/it-2da9fe25a38c3b5ecc1ad49f013f4f2780e7cc8c7760e14b5e0cf9133a3ca888.js

I, [2017-01-22T22:14:14.706224 #2744] INFO -- : Writing /tmp/d20170122-18-cxm1tu/opt/openproject/public/assets/locales/it-2da9fe25a38c3b5ecc1ad49f013f4f2780e7cc8c7760e14b5e0cf9133a3ca888.js.gz

I, [2017-01-22T22:14:14.714812 #2744] INFO -- : Writing /tmp/d20170122-18-cxm1tu/opt/openproject/public/assets/locales/ja-f8632d5fff009c766a77c499986ac2ab325405dc4f1bf26622ae18f9ce8792a8.js

I, [2017-01-22T22:14:14.714969 #2744] INFO -- : Writing /tmp/d20170122-18-cxm1tu/opt/openproject/public/assets/locales/ja-f8632d5fff009c766a77c499986ac2ab325405dc4f1bf26622ae18f9ce8792a8.js.gz

I, [2017-01-22T22:14:14.730536 #2744] INFO -- : Writing /tmp/d20170122-18-cxm1tu/opt/openproject/public/assets/locales/nl-e7e1a58e4a0fe3814cc911c20cd36192bb5110c5ac32a7e583e9d4d177bd693e.js

I, [2017-01-22T22:14:14.730709 #2744] INFO -- : Writing /tmp/d20170122-18-cxm1tu/opt/openproject/public/assets/locales/nl-e7e1a58e4a0fe3814cc911c20cd36192bb5110c5ac32a7e583e9d4d177bd693e.js.gz

autoprefixer: /tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:6446:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:6476:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:11749:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:12130:3: You should write display: flex by final spec instead of display: box

autoprefixer: /tmp/d20170122-18-cxm1tu/opt/openproject/vendored-plugins/openproject-themes-dark/app/assets/stylesheets/dark.sass:12175:3: You should write display: flex by final spec instead of display: box

I, [2017-01-22T22:14:28.470037 #2744] INFO -- : Writing /tmp/d20170122-18-cxm1tu/opt/openproject/public/assets/dark-feeac1abf7e73be6eb6d80d8a8f8e5b9bf79b47ce3eba05b133e96395d495c5a.css

I, [2017-01-22T22:14:28.470375 #2744] INFO -- : Writing /tmp/d20170122-18-cxm1tu/opt/openproject/public/assets/dark-feeac1abf7e73be6eb6d80d8a8f8e5b9bf79b47ce3eba05b133e96395d495c5a.css.gz

Asset precompilation completed (62.67s)

Cleaning assets

Running: rake assets:clean

I, [2017-01-22T22:14:36.445165 #2976] INFO -- : Removed locales/fa-0dbf392eccd6c0bdd63cfadefebb8a9b2ae0ffc90b91c905764f3b009aecb046.js

I, [2017-01-22T22:14:36.451170 #2976] INFO -- : Removed locales/id-a7c8c482240a4e457ff26930c4a800331ec9a565832f4a26b05aa189e690b876.js

I, [2017-01-22T22:14:36.456735 #2976] INFO -- : Removed locales/it-7e1d737729288534422df10d26c1b9357bd99ef564864ac74c1080c53037c9a5.js

I, [2017-01-22T22:14:36.461998 #2976] INFO -- : Removed locales/ja-90d4866d75e8e5c66cb904ef183adae9eb1ec8ea412d548a25b9f8b367258fdf.js

I, [2017-01-22T22:14:36.475632 #2976] INFO -- : Removed default-270b9c30b239e0622b55c68a93351ad8b56bde4af52e9dc6dee3ed4d7e1124b5.css

I, [2017-01-22T22:14:36.481330 #2976] INFO -- : Removed locales/nl-3f2643487cd26bc712d2d53bade04dcfbf8de02db124d1453990847eac991965.js

I, [2017-01-22T22:14:36.487037 #2976] INFO -- : Removed dark-681a673a66ecee6ff638adb9b42edc00086247fb6aa9dc57b93483f16f574571.css

I, [2017-01-22T22:14:36.492685 #2976] INFO -- : Removed application-3cf81183e2baef03ea85931dbaa3f4e9dd3e4f07d0f783b30f41acebb33b4672.js

Using release configuration from last framework (Ruby).

-----> [cron] /opt/openproject/packaging/cron/openproject-clear-old-sessions => /etc/cron.d/openproject-clear-old-sessions

-----> Verifying package openproject_6.1.4-1485121203.2cb8b63.xenial_amd64.deb

NEW PACKAGE: openproject_6.1.4-1485121203.2cb8b63.xenial_amd64.deb (288.29 MiB)

-----> Releasing...

DONE!