Build Logs

====== Attempt #1

-----> Fetching repository

Cloning into '/tmp/d20170210-16665-ifca1t/input'...

-----> Restoring cache

-----> Starting packaging process

-----> Installing missing build dependencies: mysql-devel, ImageMagick-devel

-----> [wizard] adding legacy-installer wizard (https://github.com/pkgr/addon-legacy-installer#master)

-----> [wizard] adding mysql wizard (https://github.com/pkgr/addon-mysql#master)

-----> [wizard] adding apache2 wizard (https://github.com/pkgr/addon-apache2#master)

-----> [wizard] adding repositories wizard (https://github.com/finnlabs/addon-repositories#master)

-----> [wizard] adding smtp wizard (https://github.com/pkgr/addon-smtp#master)

-----> [wizard] adding memcached wizard (https://github.com/pkgr/addon-memcached#master)

-----> [wizard] adding openproject wizard (https://github.com/pkgr/addon-openproject#master)

-----> Fetching buildpack https://github.com/opf/heroku-buildpack-multi.git at master

-----> Multipack app

-----> Running hook: "packaging/setup"

WARNING: This buildpack is no longer maintained.

Please choose a different buildpack or go to https://github.com/ddollar/heroku-buildpack-multi

and fork it to your own account.

=====> Downloading Buildpack: https://github.com/pkgr/pkgr-buildpack-imagemagick.git

=====> Detected Framework: ImageMagick

-----> SKIP

=====> Downloading Buildpack: https://github.com/heroku/heroku-buildpack-nodejs.git

=====> Detected Framework: Node.js

-----> Reading application state

package.json...

build directory...

cache directory...

environment variables...

Node engine: 6.9.1

Npm engine: 4.0.0

Start mechanism: Procfile

node_modules source: package.json

node_modules cached: true

NPM_CONFIG_PRODUCTION=true

NODE_MODULES_CACHE=true

-----> Installing binaries

Downloading and installing node 6.9.1...

Downloading and installing npm 4.0.0 (replacing version 3.10.8)...

-----> Building dependencies

Restoring node modules from cache

Pruning unused dependencies

Installing any new modules

> openproject@0.1.0 postinstall /tmp/d20170210-18-130ey7k/opt/openproject

> cd frontend && npm install

> openproject-frontend@0.1.0 postinstall /tmp/d20170210-18-130ey7k/opt/openproject/frontend

> bower install --config.interactive=false

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 not-cached git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolve git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de not-cached git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolve git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 not-cached git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolve git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 checkout d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower jquery#1.11.0 not-cached https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery#1.11.0 resolve https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery-ujs#1.0.0 not-cached https://github.com/rails/jquery-ujs.git#1.0.0

bower jquery-ujs#1.0.0 resolve https://github.com/rails/jquery-ujs.git#1.0.0

bower select2#3.5.2 not-cached https://github.com/ivaynberg/select2.git#3.5.2

bower select2#3.5.2 resolve https://github.com/ivaynberg/select2.git#3.5.2

bower jquery-ui#~1.10.4 not-cached https://github.com/components/jqueryui.git#~1.10.4

bower jquery-ui#~1.10.4 resolve https://github.com/components/jqueryui.git#~1.10.4

bower jquery.atwho#0.5.1 not-cached https://github.com/ichord/At.js.git#0.5.1

bower jquery.atwho#0.5.1 resolve https://github.com/ichord/At.js.git#0.5.1

bower angular#~1.5.8 not-cached https://github.com/angular/bower-angular.git#~1.5.8

bower angular#~1.5.8 resolve https://github.com/angular/bower-angular.git#~1.5.8

bower angular-animate#~1.5.8 not-cached https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-animate#~1.5.8 resolve https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-aria#~1.5.8 not-cached https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-aria#~1.5.8 resolve https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-ui-router#~0.3.1 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-ui-router#~0.3.1 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-i18n#~1.5.5 not-cached https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-i18n#~1.5.5 resolve https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-sanitize#~1.5.8 not-cached https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-sanitize#~1.5.8 resolve https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-cache#~4.6.0 not-cached https://github.com/jmdobry/angular-cache.git#~4.6.0

bower angular-cache#~4.6.0 resolve https://github.com/jmdobry/angular-cache.git#~4.6.0

bower jquery-migrate#~1.2.1 not-cached https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower jquery-migrate#~1.2.1 resolve https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de checkout fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 checkout a908eccaec323cd66973d58af4965694bdff16a1

bower moment#~2.10.6 not-cached https://github.com/moment/moment.git#~2.10.6

bower moment#~2.10.6 resolve https://github.com/moment/moment.git#~2.10.6

bower angular-elastic#~2.5.1 not-cached https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-elastic#~2.5.1 resolve https://github.com/monospaced/angular-elastic.git#~2.5.1

bower moment-timezone#0.4.x not-cached https://github.com/moment/moment-timezone.git#0.4.x

bower moment-timezone#0.4.x resolve https://github.com/moment/moment-timezone.git#0.4.x

bower angular-busy#~4.1.3 not-cached https://github.com/cgross/angular-busy.git#~4.1.3

bower angular-busy#~4.1.3 resolve https://github.com/cgross/angular-busy.git#~4.1.3

bower lodash#~2.4.1 not-cached https://github.com/lodash/lodash.git#~2.4.1

bower lodash#~2.4.1 resolve https://github.com/lodash/lodash.git#~2.4.1

bower foundation-apps#1.1.0 not-cached https://github.com/zurb/foundation-apps.git#1.1.0

bower foundation-apps#1.1.0 resolve https://github.com/zurb/foundation-apps.git#1.1.0

bower bourbon#~4.2.1 not-cached https://github.com/thoughtbot/bourbon.git#~4.2.1

bower bourbon#~4.2.1 resolve https://github.com/thoughtbot/bourbon.git#~4.2.1

bower angular-ui-select#~0.19.4 not-cached https://github.com/angular-ui/ui-select.git#~0.19.4

bower angular-ui-select#~0.19.4 resolve https://github.com/angular-ui/ui-select.git#~0.19.4

bower mousetrap#~1.4.6 not-cached https://github.com/ccampbell/mousetrap.git#~1.4.6

bower mousetrap#~1.4.6 resolve https://github.com/ccampbell/mousetrap.git#~1.4.6

bower ng-file-upload#~5.0.9 not-cached https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower ng-file-upload#~5.0.9 resolve https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower rxjs#^4.1.0 not-cached https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower rxjs#^4.1.0 resolve https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower ng-dialog#^0.6.2 not-cached https://github.com/likeastore/ngDialog.git#^0.6.2

bower ng-dialog#^0.6.2 resolve https://github.com/likeastore/ngDialog.git#^0.6.2

bower mocha#~1.14.0 not-cached https://github.com/mochajs/mocha.git#~1.14.0

bower mocha#~1.14.0 resolve https://github.com/mochajs/mocha.git#~1.14.0

bower angular-dragula#^1.2.8 not-cached https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower angular-dragula#^1.2.8 resolve https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower angular-mocks#~1.5.8 not-cached https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower angular-mocks#~1.5.8 resolve https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower chai#~1.9.0 not-cached https://github.com/chaijs/chai.git#~1.9.0

bower chai#~1.9.0 resolve https://github.com/chaijs/chai.git#~1.9.0

bower jquery-mockjax#~1.5.3 not-cached https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery-mockjax#~1.5.3 resolve https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery-ui#~1.10.4 checkout 1.10.4

bower jquery#1.11.0 checkout 1.11.0

bower jquery-ujs#1.0.0 checkout v1.0.0

bower angular#~1.5.8 checkout v1.5.11

bower jquery.atwho#0.5.1 checkout v0.5.1

bower select2#3.5.2 checkout 3.5.2

bower angular-aria#~1.5.8 checkout v1.5.11

bower angular-ui-router#~0.3.1 checkout 0.3.2

bower angular-animate#~1.5.8 checkout v1.5.11

bower moment#~2.10.6 checkout 2.10.6

bower jquery-migrate#~1.2.1 checkout 1.2.1

bower angular-cache#~4.6.0 checkout 4.6.0

bower angular-sanitize#~1.5.8 checkout v1.5.11

bower angular-i18n#~1.5.5 checkout v1.5.11

bower foundation-apps#1.1.0 checkout v1.1.0

bower lodash#~2.4.1 checkout 2.4.2

bower angular-busy#~4.1.3 checkout v4.1.4

bower moment-timezone#0.4.x checkout 0.4.1

bower angular-elastic#~2.5.1 checkout v2.5.1

bower bourbon#~4.2.1 checkout v4.2.7

bower angular-ui-select#~0.19.4 checkout v0.19.6

bower mousetrap#~1.4.6 checkout 1.4.6

bower ng-file-upload#~5.0.9 checkout 5.0.9

bower rxjs#^4.1.0 checkout v4.1.0

bower ng-dialog#^0.6.2 checkout v0.6.6

bower angular-dragula#^1.2.8 checkout v1.2.8

bower mocha#~1.14.0 checkout 1.14.0

bower chai#~1.9.0 checkout 1.9.2

bower angular-mocks#~1.5.8 checkout v1.5.11

bower jquery-mockjax#~1.5.3 checkout v1.5.4

bower jquery-ui#~1.10.4 resolved https://github.com/components/jqueryui.git#1.10.4

bower angular#~1.5.8 resolved https://github.com/angular/bower-angular.git#1.5.11

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolved git://github.com/sparkalow/angular-truncate.git#fdf60fda26

bower jquery-ujs#1.0.0 resolved https://github.com/rails/jquery-ujs.git#1.0.0

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolved git://github.com/nickmessing/angular-context-menu.git#a908eccaec

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolved git://github.com/finnlabs/angular-modal.git#d45eb9ceb7

bower jquery#1.11.0 resolved https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery.atwho#0.5.1 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower angular-aria#~1.5.8 resolved https://github.com/angular/bower-angular-aria.git#1.5.11

bower jquery.atwho#0.5.1 resolved https://github.com/ichord/At.js.git#0.5.1

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .png files: ["select2.png","select2x2.png"]

bower select2#3.5.2 resolved https://github.com/ivaynberg/select2.git#3.5.2

bower angular-animate#~1.5.8 resolved https://github.com/angular/bower-angular-animate.git#1.5.11

bower Caret.js#>= 0.2.0 not-cached https://github.com/ichord/Caret.js.git#>= 0.2.0

bower Caret.js#>= 0.2.0 resolve https://github.com/ichord/Caret.js.git#>= 0.2.0

bower angular-ui-router#~0.3.1 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.3.2

bower jquery-migrate#~1.2.1 deprecated Package jquery-migrate is using the deprecated component.json

bower jquery-migrate#~1.2.1 resolved https://github.com/appleboy/jquery-migrate.git#1.2.1

bower moment#~2.10.6 resolved https://github.com/moment/moment.git#2.10.6

bower angular-sanitize#~1.5.8 resolved https://github.com/angular/bower-angular-sanitize.git#1.5.11

bower foundation-apps#1.1.0 resolved https://github.com/zurb/foundation-apps.git#1.1.0

bower angular#~1.3.4 not-cached https://github.com/angular/bower-angular.git#~1.3.4

bower angular#~1.3.4 resolve https://github.com/angular/bower-angular.git#~1.3.4

bower angular-ui-router#~0.2.12 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-ui-router#~0.2.12 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-animate#~1.3.4 not-cached https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular-animate#~1.3.4 resolve https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular#~1.3.4 checkout v1.3.20

bower angular-ui-router#~0.2.12 checkout 0.2.18

bower angular-animate#~1.3.4 checkout v1.3.20

bower angular-elastic#~2.5.1 resolved https://github.com/monospaced/angular-elastic.git#2.5.1

bower lodash#~2.4.1 resolved https://github.com/lodash/lodash.git#2.4.2

bower angular-busy#~4.1.3 resolved https://github.com/cgross/angular-busy.git#4.1.4

bower hammerjs#~2.0.4 not-cached https://github.com/EightMedia/hammer.js.git#~2.0.4

bower hammerjs#~2.0.4 resolve https://github.com/EightMedia/hammer.js.git#~2.0.4

bower viewport-units-buggyfill#~0.4.1 not-cached https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower viewport-units-buggyfill#~0.4.1 resolve https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower tether#~0.6.5 not-cached https://github.com/HubSpot/tether.git#~0.6.5

bower tether#~0.6.5 resolve https://github.com/HubSpot/tether.git#~0.6.5

bower fastclick#~1.0.3 not-cached https://github.com/ftlabs/fastclick.git#~1.0.3

bower fastclick#~1.0.3 resolve https://github.com/ftlabs/fastclick.git#~1.0.3

bower bourbon#~4.2.1 resolved https://github.com/thoughtbot/bourbon.git#4.2.7

bower moment-timezone#0.4.x resolved https://github.com/moment/moment-timezone.git#0.4.1

bower mousetrap#~1.4.6 resolved https://github.com/ccampbell/mousetrap.git#1.4.6

bower angular-ui-select#~0.19.4 resolved https://github.com/angular-ui/ui-select.git#0.19.6

bower ng-file-upload#~5.0.9 resolved https://github.com/danialfarid/angular-file-upload-bower.git#5.0.9

bower angular-i18n#~1.5.5 resolved https://github.com/angular/bower-angular-i18n.git#1.5.11

bower ng-dialog#^0.6.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .css files: ["css/ngDialog.css","css/ngDialog-theme-default.css"]

bower ng-dialog#^0.6.2 resolved https://github.com/likeastore/ngDialog.git#0.6.6

bower angular-dragula#^1.2.8 resolved https://github.com/bevacqua/angular-dragula.git#1.2.8

bower mocha#~1.14.0 mismatch Version declared in the json (1.12.0) is different than the resolved one (1.14.0)

bower mocha#~1.14.0 resolved https://github.com/mochajs/mocha.git#1.14.0

bower chai#~1.9.0 resolved https://github.com/chaijs/chai.git#1.9.2

bower angular-mocks#~1.5.8 resolved https://github.com/angular/bower-angular-mocks.git#1.5.11

bower Caret.js#>= 0.2.0 checkout v0.3.1

bower jquery-mockjax#~1.5.3 resolved https://github.com/jakerella/jquery-mockjax.git#1.5.4

bower rxjs#^4.1.0 resolved https://github.com/Reactive-Extensions/RxJS.git#4.1.0

bower hammerjs#~2.0.4 checkout v2.0.8

bower angular-ui-router#~0.2.12 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.2.18

bower viewport-units-buggyfill#~0.4.1 checkout v0.4.1

bower angular-animate#~1.3.4 resolved https://github.com/angular/bower-angular-animate.git#1.3.20

bower angular#~1.3.4 resolved https://github.com/angular/bower-angular.git#1.3.20

bower tether#~0.6.5 checkout v0.6.5

bower fastclick#~1.0.3 checkout v1.0.6

bower Caret.js#>= 0.2.0 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower Caret.js#>= 0.2.0 resolved https://github.com/ichord/Caret.js.git#0.3.1

bower angular-cache#~4.6.0 resolved https://github.com/jmdobry/angular-cache.git#4.6.0

bower viewport-units-buggyfill#~0.4.1 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .js files: ["./viewport-units-buggyfill.js","./viewport-units-buggyfill.hacks.js"]

bower viewport-units-buggyfill#~0.4.1 resolved https://github.com/rodneyrehm/viewport-units-buggyfill.git#0.4.1

bower hammerjs#~2.0.4 resolved https://github.com/EightMedia/hammer.js.git#2.0.8

bower tether#~0.6.5 resolved https://github.com/HubSpot/tether.git#0.6.5

bower fastclick#~1.0.3 resolved https://github.com/ftlabs/fastclick.git#1.0.6

Please note that,

angular-animate#1.3.20 depends on angular#1.3.20 which resolved to angular#1.3.20

foundation-apps#1.1.0 depends on angular#~1.3.4 which resolved to angular#1.3.20

angular-animate#1.5.11, angular-aria#1.5.11, angular-mocks#1.5.11, angular-sanitize#1.5.11 depends on angular#1.5.11 which resolved to angular#1.5.11

angular-ui-router#0.3.2, angular-ui-router#0.2.18 depends on angular#^1.0.8 which resolved to angular#1.5.11

angular-modal#d45eb9ceb7 depends on angular#^1.3.0 which resolved to angular#1.5.11

angular-elastic#2.5.1 depends on angular#>=1.0.6 which resolved to angular#1.5.11

openproject depends on angular#~1.5.8 which resolved to angular#1.5.11

angular-ui-select#0.19.6 depends on angular#>=1.2.18 which resolved to angular#1.5.11

ng-dialog#0.6.6 depends on angular#>=1.5 which resolved to angular#1.5.11

angular-cache#4.6.0 depends on angular#>=1.x which resolved to angular#1.5.11

angular-busy#4.1.4 depends on angular#>=1.3 which resolved to angular#1.5.11

angular-context-menu#a908eccaec depends on angular#>= 1.2.5 which resolved to angular#1.5.11

Resort to using angular#~1.5.8 which resolved to angular#1.5.11

Code incompatibilities may occur.

Please note that,

foundation-apps#1.1.0 depends on angular-animate#~1.3.4 which resolved to angular-animate#1.3.20

openproject depends on angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

angular-busy#4.1.4 depends on angular-animate#>=1.3 which resolved to angular-animate#1.5.11

Resort to using angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

Code incompatibilities may occur.

Please note that,

foundation-apps#1.1.0 depends on angular-ui-router#~0.2.12 which resolved to angular-ui-router#0.2.18

openproject depends on angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Resort to using angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Code incompatibilities may occur.

bower jquery extra-resolution Unnecessary resolution: jquery#1.11.0

bower jquery-ui#~1.10.4 install jquery-ui#1.10.4

bower angular#1.5.11 install angular#1.5.11

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de install angular-truncate#fdf60fda26

bower jquery-ujs#1.0.0 install jquery-ujs#1.0.0

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 install angular-context-menu#a908eccaec

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 install angular-modal#d45eb9ceb7

bower jquery#1.11.0 install jquery#1.11.0

bower angular-aria#~1.5.8 install angular-aria#1.5.11

bower jquery.atwho#0.5.1 install jquery.atwho#0.5.1

bower select2#3.5.2 install select2#3.5.2

bower angular-animate#~1.5.8 install angular-animate#1.5.11

bower angular-ui-router#~0.3.1 install angular-ui-router#0.3.2

bower jquery-migrate#~1.2.1 install jquery-migrate#1.2.1

bower moment#~2.10.6 install moment#2.10.6

bower angular-sanitize#~1.5.8 install angular-sanitize#1.5.11

bower foundation-apps#1.1.0 install foundation-apps#1.1.0

bower angular-elastic#~2.5.1 install angular-elastic#2.5.1

bower lodash#~2.4.1 install lodash#2.4.2

bower angular-busy#~4.1.3 install angular-busy#4.1.4

bower bourbon#~4.2.1 install bourbon#4.2.7

bower moment-timezone#0.4.x install moment-timezone#0.4.1

bower mousetrap#~1.4.6 install mousetrap#1.4.6

bower angular-ui-select#~0.19.4 install angular-ui-select#0.19.6

bower ng-file-upload#~5.0.9 install ng-file-upload#5.0.9

bower angular-i18n#~1.5.5 install angular-i18n#1.5.11

bower ng-dialog#^0.6.2 install ng-dialog#0.6.6

bower angular-dragula#^1.2.8 install angular-dragula#1.2.8

bower mocha#~1.14.0 install mocha#1.14.0

bower chai#~1.9.0 install chai#1.9.2

bower angular-mocks#~1.5.8 install angular-mocks#1.5.11

bower jquery-mockjax#~1.5.3 install jquery-mockjax#1.5.4

bower rxjs#^4.1.0 install rxjs#4.1.0

bower Caret.js#>= 0.2.0 install Caret.js#0.3.1

bower angular-cache#~4.6.0 install angular-cache#4.6.0

bower viewport-units-buggyfill#~0.4.1 install viewport-units-buggyfill#0.4.1

bower hammerjs#~2.0.4 install hammerjs#2.0.8

bower tether#~0.6.5 install tether#0.6.5

bower fastclick#~1.0.3 install fastclick#1.0.6

jquery-ui#1.10.4 bower_components/jquery-ui

└── jquery#1.11.0

angular#1.5.11 bower_components/angular

angular-truncate#fdf60fda26 bower_components/angular-truncate

jquery-ujs#1.0.0 bower_components/jquery-ujs

└── jquery#1.11.0

angular-context-menu#a908eccaec bower_components/angular-context-menu

└── angular#1.5.11

angular-modal#d45eb9ceb7 bower_components/angular-modal

└── angular#1.5.11

jquery#1.11.0 bower_components/jquery

angular-aria#1.5.11 bower_components/angular-aria

└── angular#1.5.11

jquery.atwho#0.5.1 bower_components/jquery.atwho

├── Caret.js#0.3.1

└── jquery#1.11.0

select2#3.5.2 bower_components/select2

└── jquery#1.11.0

angular-animate#1.5.11 bower_components/angular-animate

└── angular#1.5.11

angular-ui-router#0.3.2 bower_components/angular-ui-router

└── angular#1.5.11

jquery-migrate#1.2.1 bower_components/jquery-migrate

moment#2.10.6 bower_components/moment

angular-sanitize#1.5.11 bower_components/angular-sanitize

└── angular#1.5.11

foundation-apps#1.1.0 bower_components/foundation-apps

├── angular#1.5.11

├── angular-animate#1.5.11

├── angular-ui-router#0.3.2

├── fastclick#1.0.6

├── hammerjs#2.0.8

├── tether#0.6.5

└── viewport-units-buggyfill#0.4.1

angular-elastic#2.5.1 bower_components/angular-elastic

└── angular#1.5.11

lodash#2.4.2 bower_components/lodash

angular-busy#4.1.4 bower_components/angular-busy

├── angular#1.5.11

└── angular-animate#1.5.11

bourbon#4.2.7 bower_components/bourbon

moment-timezone#0.4.1 bower_components/moment-timezone

└── moment#2.10.6

mousetrap#1.4.6 bower_components/mousetrap

angular-ui-select#0.19.6 bower_components/angular-ui-select

└── angular#1.5.11

ng-file-upload#5.0.9 bower_components/ng-file-upload

angular-i18n#1.5.11 bower_components/angular-i18n

ng-dialog#0.6.6 bower_components/ng-dialog

└── angular#1.5.11

angular-dragula#1.2.8 bower_components/angular-dragula

mocha#1.14.0 bower_components/mocha

chai#1.9.2 bower_components/chai

angular-mocks#1.5.11 bower_components/angular-mocks

└── angular#1.5.11

jquery-mockjax#1.5.4 bower_components/jquery-mockjax

rxjs#4.1.0 bower_components/rxjs

Caret.js#0.3.1 bower_components/Caret.js

└── jquery#1.11.0

angular-cache#4.6.0 bower_components/angular-cache

└── angular#1.5.11

viewport-units-buggyfill#0.4.1 bower_components/viewport-units-buggyfill

hammerjs#2.0.8 bower_components/hammerjs

tether#0.6.5 bower_components/tether

fastclick#1.0.6 bower_components/fastclick

openproject-frontend@0.1.0 /tmp/d20170210-18-130ey7k/opt/openproject/frontend

+-- acorn@2.6.4

+-- align-text@0.1.4

+-- alter@0.2.0

+-- amdefine@1.0.0

+-- angular@1.5.8

+-- angular-elastic@2.5.1

+-- angular-ui-bootstrap@2.2.0

+-- anymatch@1.3.0

+-- arr-diff@2.0.0

+-- arr-flatten@1.0.1

+-- array-unique@0.2.1

+-- arrify@1.0.1

+-- assert@1.4.1

+-- async@0.2.10

+-- async-each@1.0.1

+-- atoa@1.0.0

+-- autoprefixer-core@5.2.1

+-- autoprefixer-loader@1.2.0

+-- awesome-typescript-loader@2.2.4

| `-- lodash@4.16.4

+-- balanced-match@0.4.2

+-- Base64@0.2.1

+-- base64-js@1.2.0

+-- big.js@3.1.3

+-- binary-extensions@1.7.0

+-- bower@1.7.9

+-- brace-expansion@1.1.6

+-- braces@1.8.5

+-- browserify-zlib@0.1.4

+-- browserslist@0.4.0

+-- buffer@4.9.1

+-- buffer-shims@1.0.0

+-- camelcase@1.2.1

+-- caniuse-db@1.0.30000569

+-- center-align@0.1.3

+-- chokidar@1.6.1

+-- cliui@2.1.0

| `-- wordwrap@0.0.2

+-- clone@1.0.2

+-- colors@1.1.2

+-- concat-map@0.0.1

+-- console-browserify@1.1.0

+-- constants-browserify@0.0.1

+-- contra@1.9.4

+-- convert-source-map@1.1.3

+-- core-util-is@1.0.2

+-- crossvent@1.5.4

+-- crypto-browserify@3.2.8

+-- css-loader@0.9.1

| `-- source-map@0.1.43

+-- csso@1.3.12

+-- custom-event@1.0.0

+-- d@0.1.1

+-- date-now@0.1.4

+-- decamelize@1.2.0

+-- domain-browser@1.1.7

+-- dragula@3.7.2

+-- emojis-list@2.1.0

+-- enhanced-resolve@2.3.0

+-- errno@0.1.4

+-- es5-ext@0.10.12

+-- es6-iterator@2.0.0

+-- es6-promise@2.3.0

+-- es6-symbol@3.1.0

+-- es6-weak-map@0.1.4

| +-- es6-iterator@0.1.3

| `-- es6-symbol@2.0.1

+-- event-emitter@0.3.4

+-- events@1.1.1

+-- expand-brackets@0.1.5

+-- expand-range@1.8.2

+-- exports-loader@0.6.3

| `-- source-map@0.1.43

+-- expose-loader@0.6.0

+-- extglob@0.3.2

+-- extract-text-webpack-plugin@0.3.8

| `-- source-map@0.1.43

+-- fastparse@1.1.1

+-- file-loader@0.8.5

+-- filename-regex@2.0.0

+-- fill-range@2.2.3

+-- for-in@0.1.6

+-- for-own@0.1.4

+-- glob@4.5.3

+-- glob-base@0.3.0

+-- glob-parent@2.0.0

+-- graceful-fs@4.1.9

+-- has-flag@1.0.0

+-- html-loader@0.2.3

| `-- source-map@0.1.43

+-- html-minifier@0.5.6

+-- http-browserify@1.7.0

+-- https-browserify@0.0.0

+-- ieee754@1.1.8

+-- indexof@0.0.1

+-- inflight@1.0.6

+-- inherits@2.0.3

+-- interpret@0.6.6

+-- is-binary-path@1.0.1

+-- is-buffer@1.1.4

+-- is-dotfile@1.0.2

+-- is-equal-shallow@0.1.3

+-- is-extendable@0.1.1

+-- is-extglob@1.0.0

+-- is-glob@2.0.1

+-- is-number@2.1.0

+-- is-posix-bracket@0.1.1

+-- is-primitive@2.0.0

+-- isarray@1.0.0

+-- isobject@2.1.0

+-- js-base64@2.1.9

+-- json5@0.4.0

+-- kind-of@3.0.4

+-- lazy-cache@1.0.4

+-- loader-utils@0.2.16

| `-- json5@0.5.0

+-- lodash@2.4.2

+-- longest@1.0.1

+-- lru-queue@0.1.0

+-- memoizee@0.3.10

+-- memory-fs@0.3.0

+-- micromatch@2.3.11

+-- mime@1.2.11

+-- minimatch@2.0.10

+-- minimist@0.0.10

+-- mkdirp@0.5.1

| `-- minimist@0.0.8

+-- nan@2.4.0

+-- next-tick@0.2.2

+-- ng-annotate@1.2.1

| `-- source-map@0.5.6

+-- ng-annotate-loader@0.0.10

| `-- source-map@0.4.2

+-- ngtemplate-loader@0.1.3

+-- node-libs-browser@0.6.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- normalize-path@2.0.1

+-- num2fraction@1.2.2

+-- object-assign@4.1.0

+-- object.omit@2.0.1

+-- observable-array@0.0.4

+-- observable-value@0.0.5

+-- once@1.4.0

+-- optimist@0.6.1

+-- ordered-ast-traverse@1.1.1

+-- ordered-esprima-props@1.1.0

+-- os-browserify@0.1.2

+-- pako@0.2.9

+-- parse-glob@3.0.4

+-- path-browserify@0.0.0

+-- path-is-absolute@1.0.1

+-- pbkdf2-compat@2.0.1

+-- phantomjs-polyfill@0.0.2

+-- postcss@4.1.16

+-- preserve@0.2.0

+-- process@0.11.9

+-- process-nextick-args@1.0.7

+-- prr@0.0.0

+-- punycode@1.4.1

+-- querystring@0.2.0

+-- querystring-es3@0.2.1

+-- randomatic@1.1.5

+-- readable-stream@2.1.5

+-- readdirp@2.1.0

| `-- minimatch@3.0.3

+-- regex-cache@0.4.3

+-- repeat-element@1.1.2

+-- repeat-string@1.6.1

+-- right-align@0.1.3

+-- ripemd160@0.2.0

+-- set-immediate-shim@1.0.1

+-- sha.js@2.2.6

+-- shelljs@0.3.0

+-- simple-fmt@0.1.0

+-- simple-is@0.2.0

+-- source-list-map@0.1.6

+-- source-map@0.4.4

+-- source-map-support@0.4.5

| `-- source-map@0.5.6

+-- stable@0.1.5

+-- stream-browserify@1.0.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- string_decoder@0.10.31

+-- stringmap@0.2.2

+-- stringset@0.2.1

+-- style-loader@0.8.3

+-- supports-color@3.1.2

+-- tapable@0.2.4

+-- ticky@1.0.1

+-- timers-browserify@1.4.2

+-- timers-ext@0.1.0

+-- tryor@0.1.2

+-- tty-browserify@0.0.0

+-- typescript@2.0.6

+-- uglify-js@2.7.4

| `-- source-map@0.5.6

+-- uglify-to-browserify@1.0.2

+-- URIjs@1.16.1

+-- url@0.10.3

| `-- punycode@1.3.2

+-- url-loader@0.5.7

+-- util@0.10.3

| `-- inherits@2.0.1

+-- util-deprecate@1.0.2

+-- vm-browserify@0.0.4

+-- watchpack@0.2.9

| `-- async@0.9.2

+-- webpack@1.13.3

| +-- acorn@3.3.0

| +-- async@1.5.2

| +-- enhanced-resolve@0.9.1

| | `-- memory-fs@0.2.0

| `-- tapable@0.1.10

+-- webpack-core@0.6.8

+-- window-size@0.1.0

+-- wordwrap@0.0.3

+-- wrappy@1.0.2

`-- yargs@3.10.0

npm WARN openproject-frontend@0.1.0 No repository field.

npm WARN openproject-frontend@0.1.0 No license field.

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.0.14 (node_modules/fsevents):

npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.0.14: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

-----> Checking startup method

Found Procfile

-----> Finalizing build

Creating runtime environment

Exporting binary paths

Cleaning npm artifacts

Cleaning previous cache

Caching results for future builds

-----> Build succeeded!

openproject@0.1.0 /tmp/d20170210-18-130ey7k/opt/openproject

`-- typescript@2.0.8

=====> Downloading Buildpack: https://github.com/pkgr/heroku-buildpack-ruby.git

=====> Detected Framework: Ruby

-----> Compiling Ruby/Rails

-----> Using Ruby version: ruby-2.3.1

-----> Installing dependencies using bundler 1.13.2

cp: ‘/tmp/d20170210-18-130ey7k/opt/openproject/.git/cache/vendor/bundle/.’ and ‘/tmp/d20170210-18-130ey7k/opt/openproject/.git/cache/vendor/bundle/.’ are the same file

Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Fetching gem metadata from https://rubygems.org/......

Fetching version metadata from https://rubygems.org/..

Fetching dependency metadata from https://rubygems.org/.

Using rake 11.3.0

Using concurrent-ruby 1.0.2

Using i18n 0.7.0

Using minitest 5.9.0

Using thread_safe 0.3.5

Using builder 3.2.2

Using erubis 2.7.0

Using mini_portile2 2.1.0

Using pkg-config 1.1.7

Using rack 2.0.1

Using nio4r 1.2.1

Using websocket-extensions 0.1.2

Using mime-types 2.99.3

Using method_source 0.8.2

Using thor 0.19.1

Using arel 7.1.2

Using multi_json 1.12.1

Using acts_as_silent_list 3.0.0

Using addressable 2.4.0

Using airbrake-ruby 1.5.0

Using attr_required 1.0.1

Using execjs 2.7.0

Using ice_nine 0.11.2

Using bcrypt 3.1.11

Using bindata 2.3.4

Using sass 3.4.22

Using tilt 2.0.5

Using uber 0.0.15

Using erbse 0.0.2

Using coderay 1.1.1

Using color-tools 1.3.0

Using unf_ext 0.0.7.2

Using netrc 0.11.0

Using daemons 1.2.4

Using dalli 2.7.6

Using enumerable-lazy 0.0.1

Using equalizer 0.0.11

Using excon 0.52.0

Using ffi 1.9.14

Using formatador 0.2.5

Using ipaddress 0.8.3

Using get_process_mem 0.2.1

Using request_store 1.3.1

Using json 1.8.3

Using hashie 3.4.6

Using multi_xml 0.5.5

Using gravatar_image_tag 1.2.0

Using bundler 1.13.2

Using htmldiff 0.0.1

Using httpclient 2.8.2.4

Using icalendar 2.3.0

Using iso8601 0.9.1

Using securecompare 1.0.0

Using url_safe_base64 0.2.2

Using kgio 2.10.0

Using mixlib-shellout 2.1.0

Using mysql2 0.4.4

Using net-ldap 0.14.0

Using newrelic_rpm 3.16.2.321

Using oj 2.17.4

Using pdf-core 0.6.1

Using ttfunk 1.4.0

Using rmagick 2.15.4

Using rubyzip 1.2.0

Using ruby-ole 1.2.12

Using pg 0.19.0

Using rails_serve_static_assets 0.0.5

Using rails_stdout_logging 0.0.5

Using raindrops 0.17.0

Using ruby-progressbar 1.8.1

Using structured_warnings 0.2.0

Using sqlite3 1.3.11

Using stringex 2.6.1

Using svg-graph 2.0.1

Using syck 1.0.5

Using will_paginate 3.1.3

Using i18n-js 3.0.0.rc14

Using tzinfo 1.2.2

Using descendants_tracker 0.0.4

Using nokogiri 1.6.8

Using websocket-driver 0.6.4

Using mail 2.6.4

Using rack-test 0.6.3

Using rack-accept 0.4.5

Using sprockets 3.7.0

Using passenger 5.0.30

Using rack-attack 5.0.1

Using rack-protection 2.0.0.beta2

Using warden 1.2.6

Using airbrake 5.1.0

Using autoprefixer-rails 6.4.1.1

Using bourbon 4.2.7

Using cells 4.1.3

Using unf 0.1.4

Using mustermann19 0.4.4

Using sys-filesystem 1.1.7

Using fog-core 1.42.0

Using rdoc 4.2.2

Using omniauth 1.3.1 from https://github.com/oliverguenther/omniauth (at 8385bc0@8385bc0)

Using prawn 2.1.0

Using spreadsheet 0.8.9

Using rails_12factor 0.0.3

Using unicorn 5.1.0

Using rubytree 0.9.7

Using axiom-types 0.1.1

Using coercible 1.0.0

Using activesupport 5.0.0.1

Using tzinfo-data 1.2016.6

Using loofah 2.0.3

Using representable 2.1.8

Using ruby-saml 1.4.0

Using warden-basic_auth 0.2.1

Using cells-erb 0.0.8

Using domain_name 0.5.20161129

Using fog-json 1.0.2

Using fog-xml 0.1.2

Using prawn-table 0.2.2

Using unicorn-worker-killer 0.4.4

Using virtus 1.0.5

Using rails-dom-testing 2.0.1

Using globalid 0.3.7

Using activemodel 5.0.0.1

Using climate_control 0.0.3

Using delayed_job 4.1.2

Using json-jwt 1.6.5

Using rack-oauth2 1.4.0

Using swd 1.0.1

Using webfinger 1.0.2

Using rabl 0.13.0

Using ruby-duration 3.2.3

Using rails-html-sanitizer 1.0.3

Using disposable 0.0.9

Using roar 1.0.4

Using omniauth-saml 1.6.0 from git://github.com/omniauth/omniauth-saml.git (at master@5559d6b)

Using http-cookie 1.0.3

Using fog-aws 0.11.0

Using grape 0.17.0

Using activerecord 5.0.0.1

Using carrierwave 1.0.0.beta from https://github.com/carrierwaveuploader/carrierwave (at master@5367a63)

Using date_validator 0.9.0

Using validate_email 0.1.6

Using validate_url 1.0.2

Using activejob 5.0.0.1

Using cocaine 0.5.8

Using reform 1.2.6

Using actionview 5.0.0.1

Using rest-client 1.8.0

Using grape-cache_control 1.0.1

Using openproject-auth_saml 0.1.0 from https://github.com/finnlabs/openproject-auth_saml (at dev@97212ab)

Using activemodel-serializers-xml 1.0.1

Using acts_as_list 0.8.1

Using acts_as_tree 2.5.1

Using awesome_nested_set 3.1.1

Using delayed_job_active_record 4.1.1

Using friendly_id 5.2.0.beta.1 from https://github.com/norman/friendly_id (at aff0564@aff0564)

Using globalize 5.1.0 from https://github.com/globalize/globalize (at 38443bc@38443bc)

Using transactional_lock 0.1.0 from https://github.com/finnlabs/transactional_lock.git (at master@6948b1d)

Using openid_connect 0.8.3

Using actionpack 5.0.0.1

Using crowdin-api 0.4.1

Using omniauth-openid-connect 0.2.0 from https://github.com/finnlabs/omniauth-openid-connect.git (at dev@c3bce4c)

Using actioncable 5.0.0.1

Using actionmailer 5.0.0.1

Using railties 5.0.0.1

Using cells-rails 0.0.6

Using gon 4.1.1

Using sprockets-rails 3.2.0

Using omniauth-openid_connect-providers 0.1.0 from https://github.com/finnlabs/omniauth-openid_connect-providers.git (at dev@86f3670)

Using actionpack-xml_parser 2.0.0

Using activerecord-session_store 1.0.0

Using jquery-tablesorter 1.22.7

Using responders 2.3.0

Using rails 5.0.0.1

Using sass-rails 5.0.6

Using health_check 2.2.1

Using lobby_boy 0.1.2

Using openproject-auth_plugins 6.1.4 from source at `vendored-plugins/openproject-auth_plugins`

Using openproject-pdf_export 6.1.4 from source at `vendored-plugins/openproject-pdf_export`

Using openproject-costs 6.1.4 from source at `vendored-plugins/openproject-costs`

Using openproject-documents 6.1.4 from source at `vendored-plugins/openproject-documents`

Using openproject-webhooks 6.1.4 from source at `vendored-plugins/openproject-webhooks`

Using openproject-global_roles 6.1.4 from source at `vendored-plugins/openproject-global_roles`

Using openproject-local_avatars 6.1.4 from source at `vendored-plugins/openproject-local_avatars`

Using openproject-meeting 6.1.4 from source at `vendored-plugins/openproject-meeting`

Using openproject-my_project_page 6.1.4 from source at `vendored-plugins/openproject-my_project_page`

Using reporting_engine 6.1.4 from source at `vendored-plugins/reporting_engine`

Using openproject-themes-dark 6.1.4 from source at `vendored-plugins/openproject-themes-dark`

Using openproject-translations 6.1.4 from https://github.com/opf/openproject-translations.git (at stable/6@da52ff9)

Using openproject-xls_export 6.1.4 from source at `vendored-plugins/openproject-xls_export`

Using rails-angular-xss 0.3.0.pre.pre from https://github.com/opf/rails-angular-xss (at a45267d@a45267d)

Using rails_autolink 1.1.6

Using openproject-openid_connect 6.1.4 from source at `vendored-plugins/openproject-openid_connect`

Using openproject-backlogs 6.1.4 from source at `vendored-plugins/openproject-backlogs`

Using openproject-github_integration 6.1.4 from source at `vendored-plugins/openproject-github_integration`

Using openproject-reporting 6.1.4 from source at `vendored-plugins/openproject-reporting`

Bundle complete! 138 Gemfile dependencies, 195 gems now installed.

Gems in the groups development and test were not installed.

Bundled gems are installed into ./vendor/bundle.

Bundle completed (11.27s)

Cleaning up the bundler cache.

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

-----> Detecting rake tasks

-----> Preparing app for Rails asset pipeline

Running: rake assets:precompile

$(npm bin)/webpack --config webpack.production.config.js

{"omniauth-openid-connect":"/tmp/d20170210-18-130ey7k/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid-connect-c3bce4c9e9ac","omniauth-openid_connect-providers":"/tmp/d20170210-18-130ey7k/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid_connect-providers-86f3670e127e","omniauth-saml":"/tmp/d20170210-18-130ey7k/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-saml-5559d6b80805","openproject-auth_plugins":"/tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-auth_plugins","openproject-auth_saml":"/tmp/d20170210-18-130ey7k/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-auth_saml-97212abb8378","openproject-pdf_export":"/tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-pdf_export","openproject-backlogs":"/tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-backlogs","openproject-costs":"/tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-costs","openproject-documents":"/tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-documents","openproject-webhooks":"/tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-webhooks","openproject-github_integration":"/tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-github_integration","openproject-global_roles":"/tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-global_roles","openproject-local_avatars":"/tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-local_avatars","openproject-meeting":"/tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-meeting","openproject-my_project_page":"/tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-my_project_page","openproject-openid_connect":"/tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-openid_connect","reporting_engine":"/tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/reporting_engine","openproject-reporting":"/tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-reporting","openproject-themes-dark":"/tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-themes-dark","openproject-translations":"/tmp/d20170210-18-130ey7k/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-translations-da52ff92cdcd","openproject-xls_export":"/tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-xls_export"}

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Hash: 760638c6ce25cfdb202d

Version: webpack 1.13.3

Child

Hash: 760638c6ce25cfdb202d

Version: webpack 1.13.3

Time: 14246ms

Asset Size Chunks Chunk Names

7b9776076d5fceef4993b55c9383dedd.gif 1.85 kB [emitted]

openproject-backlogs.js 453 kB 0 [emitted] backlogs

openproject-core-app.js 3.43 MB 1 [emitted] core-app

openproject-costs.js 526 kB 2 [emitted] costs

openproject-global.js 3.51 MB 3 [emitted] global

openproject-my_project_page.js 14.3 kB 4 [emitted] my_project_page

openproject-core-app.css 4.71 kB 1 [emitted] core-app

openproject-global.css 49 kB 3 [emitted] global

[213] ./templates \.html$ 1.22 kB {1} [built]

[242] ./components ^((?!\.(test|spec)).)*\.(js|ts|html)$ 16.1 kB {1} [built]

[633] /tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 425 bytes {2} [built]

[765] /tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 330 bytes {4} [built]

+ 769 hidden modules

ERROR in [default]

File '/tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-budget-subform.directive.ts' is not under 'rootDir' '/tmp/d20170210-18-130ey7k/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts' is not under 'rootDir' '/tmp/d20170210-18-130ey7k/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/subform/cost-subform.directive.ts' is not under 'rootDir' '/tmp/d20170210-18-130ey7k/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts' is not under 'rootDir' '/tmp/d20170210-18-130ey7k/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts' is not under 'rootDir' '/tmp/d20170210-18-130ey7k/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-block.directive.ts' is not under 'rootDir' '/tmp/d20170210-18-130ey7k/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-page-layout.directive.ts' is not under 'rootDir' '/tmp/d20170210-18-130ey7k/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-textile-block.directive.ts' is not under 'rootDir' '/tmp/d20170210-18-130ey7k/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default] /tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:49:18

Argument of type 'string' is not assignable to parameter of type '{ [key: string]: any; }'.

ERROR in [default] /tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:53:4

Supplied parameters do not match any signature of call target.

ERROR in [default] /tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:30:38

Cannot find module 'app/components/work-packages/work-package-cache.service'.

ERROR in [default] /tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:49:30

Cannot find name 'HalResource'.

ERROR in [default] /tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:54:57

Property '$injector' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:13

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:27

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:60:11

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:70:23

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:76:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:77:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:78:16

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:36:17

Property 'value' does not exist on type 'CurrencyDisplayField'.

ERROR in [default] /tmp/d20170210-18-130ey7k/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:37:23

Property 'value' does not exist on type 'CurrencyDisplayField'.

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 5 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

I, [2017-02-10T13:14:57.298135 #2194] INFO -- : Writing /tmp/d20170210-18-130ey7k/opt/openproject/public/assets/application-77c9f19ebbf8e41498e5fb15914bbfd70b0990ad089bdce1bd64028fc44ead1a.js

I, [2017-02-10T13:14:57.298820 #2194] INFO -- : Writing /tmp/d20170210-18-130ey7k/opt/openproject/public/assets/application-77c9f19ebbf8e41498e5fb15914bbfd70b0990ad089bdce1bd64028fc44ead1a.js.gz

Asset precompilation completed (30.88s)

Cleaning assets

Running: rake assets:clean

I, [2017-02-10T13:15:07.096031 #2366] INFO -- : Removed application-c26cca5536a53540cbee338eedc39752a6ee3327822a6dd55ca8ccaaded7929b.js

Using release configuration from last framework (Ruby).

-----> [cron] /opt/openproject/packaging/cron/openproject-clear-old-sessions => /etc/cron.d/openproject-clear-old-sessions

NEW PACKAGE: openproject-6.1.4-1486730985.5bf684b.centos7.x86_64.rpm (289.48 MiB)

-----> Releasing...

DONE!

====== Attempt #1

-----> Fetching repository

Cloning into '/tmp/d20170210-16665-679m7o/input'...

-----> Restoring cache

-----> Starting packaging process

-----> Installing missing build dependencies: libmagickwand-dev, libsqlite3-dev

-----> [wizard] adding legacy-installer wizard (https://github.com/pkgr/addon-legacy-installer#master)

-----> [wizard] adding mysql wizard (https://github.com/pkgr/addon-mysql#master)

-----> [wizard] adding apache2 wizard (https://github.com/pkgr/addon-apache2#master)

-----> [wizard] adding repositories wizard (https://github.com/finnlabs/addon-repositories#master)

-----> [wizard] adding smtp wizard (https://github.com/pkgr/addon-smtp#master)

-----> [wizard] adding memcached wizard (https://github.com/pkgr/addon-memcached#master)

-----> [wizard] adding openproject wizard (https://github.com/pkgr/addon-openproject#master)

/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)

-----> Fetching buildpack https://github.com/opf/heroku-buildpack-multi.git at master

-----> Multipack app

-----> Running hook: "packaging/setup"

WARNING: This buildpack is no longer maintained.

Please choose a different buildpack or go to https://github.com/ddollar/heroku-buildpack-multi

and fork it to your own account.

=====> Downloading Buildpack: https://github.com/pkgr/pkgr-buildpack-imagemagick.git

=====> Detected Framework: ImageMagick

-----> SKIP

=====> Downloading Buildpack: https://github.com/heroku/heroku-buildpack-nodejs.git

=====> Detected Framework: Node.js

-----> Reading application state

package.json...

build directory...

cache directory...

environment variables...

Node engine: 6.9.1

Npm engine: 4.0.0

Start mechanism: Procfile

node_modules source: package.json

node_modules cached: true

NPM_CONFIG_PRODUCTION=true

NODE_MODULES_CACHE=true

-----> Installing binaries

Downloading and installing node 6.9.1...

Downloading and installing npm 4.0.0 (replacing version 3.10.8)...

-----> Building dependencies

Restoring node modules from cache

Pruning unused dependencies

Installing any new modules

> openproject@0.1.0 postinstall /tmp/d20170210-17-4efcbc/opt/openproject

> cd frontend && npm install

> openproject-frontend@0.1.0 postinstall /tmp/d20170210-17-4efcbc/opt/openproject/frontend

> bower install --config.interactive=false

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 not-cached git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolve git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de not-cached git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolve git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 not-cached git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolve git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 checkout d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower jquery#1.11.0 not-cached https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery#1.11.0 resolve https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery-ui#~1.10.4 not-cached https://github.com/components/jqueryui.git#~1.10.4

bower jquery-ui#~1.10.4 resolve https://github.com/components/jqueryui.git#~1.10.4

bower jquery-ujs#1.0.0 not-cached https://github.com/rails/jquery-ujs.git#1.0.0

bower jquery-ujs#1.0.0 resolve https://github.com/rails/jquery-ujs.git#1.0.0

bower jquery.atwho#0.5.1 not-cached https://github.com/ichord/At.js.git#0.5.1

bower jquery.atwho#0.5.1 resolve https://github.com/ichord/At.js.git#0.5.1

bower angular#~1.5.8 not-cached https://github.com/angular/bower-angular.git#~1.5.8

bower angular#~1.5.8 resolve https://github.com/angular/bower-angular.git#~1.5.8

bower angular-animate#~1.5.8 not-cached https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-animate#~1.5.8 resolve https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-aria#~1.5.8 not-cached https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-aria#~1.5.8 resolve https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-ui-router#~0.3.1 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-ui-router#~0.3.1 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-i18n#~1.5.5 not-cached https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-i18n#~1.5.5 resolve https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-sanitize#~1.5.8 not-cached https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-sanitize#~1.5.8 resolve https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-elastic#~2.5.1 not-cached https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-elastic#~2.5.1 resolve https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-cache#~4.6.0 not-cached https://github.com/jmdobry/angular-cache.git#~4.6.0

bower angular-cache#~4.6.0 resolve https://github.com/jmdobry/angular-cache.git#~4.6.0

bower jquery-migrate#~1.2.1 not-cached https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower jquery-migrate#~1.2.1 resolve https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower moment#~2.10.6 not-cached https://github.com/moment/moment.git#~2.10.6

bower moment#~2.10.6 resolve https://github.com/moment/moment.git#~2.10.6

bower moment-timezone#0.4.x not-cached https://github.com/moment/moment-timezone.git#0.4.x

bower moment-timezone#0.4.x resolve https://github.com/moment/moment-timezone.git#0.4.x

bower angular-busy#~4.1.3 not-cached https://github.com/cgross/angular-busy.git#~4.1.3

bower angular-busy#~4.1.3 resolve https://github.com/cgross/angular-busy.git#~4.1.3

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de checkout fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 checkout a908eccaec323cd66973d58af4965694bdff16a1

bower lodash#~2.4.1 not-cached https://github.com/lodash/lodash.git#~2.4.1

bower lodash#~2.4.1 resolve https://github.com/lodash/lodash.git#~2.4.1

bower foundation-apps#1.1.0 not-cached https://github.com/zurb/foundation-apps.git#1.1.0

bower foundation-apps#1.1.0 resolve https://github.com/zurb/foundation-apps.git#1.1.0

bower angular-ui-select#~0.19.4 not-cached https://github.com/angular-ui/ui-select.git#~0.19.4

bower angular-ui-select#~0.19.4 resolve https://github.com/angular-ui/ui-select.git#~0.19.4

bower bourbon#~4.2.1 not-cached https://github.com/thoughtbot/bourbon.git#~4.2.1

bower bourbon#~4.2.1 resolve https://github.com/thoughtbot/bourbon.git#~4.2.1

bower rxjs#^4.1.0 not-cached https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower rxjs#^4.1.0 resolve https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower ng-dialog#^0.6.2 not-cached https://github.com/likeastore/ngDialog.git#^0.6.2

bower ng-dialog#^0.6.2 resolve https://github.com/likeastore/ngDialog.git#^0.6.2

bower angular-dragula#^1.2.8 not-cached https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower angular-dragula#^1.2.8 resolve https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower mocha#~1.14.0 not-cached https://github.com/mochajs/mocha.git#~1.14.0

bower mocha#~1.14.0 resolve https://github.com/mochajs/mocha.git#~1.14.0

bower angular-mocks#~1.5.8 not-cached https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower angular-mocks#~1.5.8 resolve https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower chai#~1.9.0 not-cached https://github.com/chaijs/chai.git#~1.9.0

bower chai#~1.9.0 resolve https://github.com/chaijs/chai.git#~1.9.0

bower jquery-mockjax#~1.5.3 not-cached https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery-mockjax#~1.5.3 resolve https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower mousetrap#~1.4.6 not-cached https://github.com/ccampbell/mousetrap.git#~1.4.6

bower mousetrap#~1.4.6 resolve https://github.com/ccampbell/mousetrap.git#~1.4.6

bower ng-file-upload#~5.0.9 not-cached https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower ng-file-upload#~5.0.9 resolve https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower jquery#1.11.0 checkout 1.11.0

bower jquery-ui#~1.10.4 checkout 1.10.4

bower jquery.atwho#0.5.1 checkout v0.5.1

bower angular-ui-router#~0.3.1 checkout 0.3.2

bower angular-animate#~1.5.8 checkout v1.5.11

bower angular-elastic#~2.5.1 checkout v2.5.1

bower angular-sanitize#~1.5.8 checkout v1.5.11

bower angular-i18n#~1.5.5 checkout v1.5.11

bower angular#~1.5.8 checkout v1.5.11

bower angular-busy#~4.1.3 checkout v4.1.4

bower moment-timezone#0.4.x checkout 0.4.1

bower moment#~2.10.6 checkout 2.10.6

bower jquery-migrate#~1.2.1 checkout 1.2.1

bower angular-cache#~4.6.0 checkout 4.6.0

bower jquery-ujs#1.0.0 checkout v1.0.0

bower foundation-apps#1.1.0 checkout v1.1.0

bower angular-ui-select#~0.19.4 checkout v0.19.6

bower angular-aria#~1.5.8 checkout v1.5.11

bower angular-dragula#^1.2.8 checkout v1.2.8

bower ng-dialog#^0.6.2 checkout v0.6.6

bower rxjs#^4.1.0 checkout v4.1.0

bower bourbon#~4.2.1 checkout v4.2.7

bower lodash#~2.4.1 checkout 2.4.2

bower jquery-mockjax#~1.5.3 checkout v1.5.4

bower mocha#~1.14.0 checkout 1.14.0

bower chai#~1.9.0 checkout 1.9.2

bower mousetrap#~1.4.6 checkout 1.4.6

bower angular-mocks#~1.5.8 checkout v1.5.11

bower ng-file-upload#~5.0.9 checkout 5.0.9

bower select2#3.5.2 not-cached https://github.com/ivaynberg/select2.git#3.5.2

bower select2#3.5.2 resolve https://github.com/ivaynberg/select2.git#3.5.2

bower jquery.atwho#0.5.1 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolved git://github.com/nickmessing/angular-context-menu.git#a908eccaec

bower angular#>= 1.2.5 not-cached https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 resolve https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolved git://github.com/finnlabs/angular-modal.git#d45eb9ceb7

bower angular#^1.3.0 not-cached https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 resolve https://github.com/angular/bower-angular.git#^1.3.0

bower angular#>= 1.2.5 checkout v1.6.2

bower angular#^1.3.0 checkout v1.6.2

bower jquery-ui#~1.10.4 resolved https://github.com/components/jqueryui.git#1.10.4

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolved git://github.com/sparkalow/angular-truncate.git#fdf60fda26

bower angular-elastic#~2.5.1 resolved https://github.com/monospaced/angular-elastic.git#2.5.1

bower angular#>=1.0.6 not-cached https://github.com/angular/bower-angular.git#>=1.0.6

bower angular#>=1.0.6 resolve https://github.com/angular/bower-angular.git#>=1.0.6

bower angular#>=1.0.6 checkout v1.6.2

bower jquery.atwho#0.5.1 resolved https://github.com/ichord/At.js.git#0.5.1

bower angular-ui-router#~0.3.1 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.3.2

bower Caret.js#>= 0.2.0 not-cached https://github.com/ichord/Caret.js.git#>= 0.2.0

bower Caret.js#>= 0.2.0 resolve https://github.com/ichord/Caret.js.git#>= 0.2.0

bower angular-animate#~1.5.8 resolved https://github.com/angular/bower-angular-animate.git#1.5.11

bower angular-sanitize#~1.5.8 resolved https://github.com/angular/bower-angular-sanitize.git#1.5.11

bower jquery#1.11.0 resolved https://github.com/jquery/jquery-dist.git#1.11.0

bower angular-busy#~4.1.3 resolved https://github.com/cgross/angular-busy.git#4.1.4

bower angular#>=1.3 not-cached https://github.com/angular/bower-angular.git#>=1.3

bower angular#>=1.3 resolve https://github.com/angular/bower-angular.git#>=1.3

bower angular#>=1.3 checkout v1.6.2

bower jquery-migrate#~1.2.1 deprecated Package jquery-migrate is using the deprecated component.json

bower jquery-migrate#~1.2.1 resolved https://github.com/appleboy/jquery-migrate.git#1.2.1

bower angular-cache#~4.6.0 resolved https://github.com/jmdobry/angular-cache.git#4.6.0

bower angular#>=1.x not-cached https://github.com/angular/bower-angular.git#>=1.x

bower angular#>=1.x resolve https://github.com/angular/bower-angular.git#>=1.x

bower angular#>=1.x checkout v1.6.2

bower jquery-ujs#1.0.0 resolved https://github.com/rails/jquery-ujs.git#1.0.0

bower foundation-apps#1.1.0 resolved https://github.com/zurb/foundation-apps.git#1.1.0

bower angular#~1.3.4 not-cached https://github.com/angular/bower-angular.git#~1.3.4

bower angular#~1.3.4 resolve https://github.com/angular/bower-angular.git#~1.3.4

bower angular-ui-router#~0.2.12 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-ui-router#~0.2.12 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-animate#~1.3.4 not-cached https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular-animate#~1.3.4 resolve https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular#~1.3.4 checkout v1.3.20

bower angular-ui-router#~0.2.12 checkout 0.2.18

bower angular-animate#~1.3.4 checkout v1.3.20

bower angular-aria#~1.5.8 resolved https://github.com/angular/bower-angular-aria.git#1.5.11

bower angular-ui-select#~0.19.4 resolved https://github.com/angular-ui/ui-select.git#0.19.6

bower angular#>=1.2.18 not-cached https://github.com/angular/bower-angular.git#>=1.2.18

bower angular#>=1.2.18 resolve https://github.com/angular/bower-angular.git#>=1.2.18

bower angular#>=1.2.18 checkout v1.6.2

bower viewport-units-buggyfill#~0.4.1 not-cached https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower viewport-units-buggyfill#~0.4.1 resolve https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower hammerjs#~2.0.4 not-cached https://github.com/EightMedia/hammer.js.git#~2.0.4

bower hammerjs#~2.0.4 resolve https://github.com/EightMedia/hammer.js.git#~2.0.4

bower tether#~0.6.5 not-cached https://github.com/HubSpot/tether.git#~0.6.5

bower tether#~0.6.5 resolve https://github.com/HubSpot/tether.git#~0.6.5

bower fastclick#~1.0.3 not-cached https://github.com/ftlabs/fastclick.git#~1.0.3

bower fastclick#~1.0.3 resolve https://github.com/ftlabs/fastclick.git#~1.0.3

bower moment-timezone#0.4.x resolved https://github.com/moment/moment-timezone.git#0.4.1

bower moment#>= 2.6.0 not-cached https://github.com/moment/moment.git#>= 2.6.0

bower moment#>= 2.6.0 resolve https://github.com/moment/moment.git#>= 2.6.0

bower moment#>= 2.6.0 checkout 2.17.1

bower ng-dialog#^0.6.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .css files: ["css/ngDialog.css","css/ngDialog-theme-default.css"]

bower moment#~2.10.6 resolved https://github.com/moment/moment.git#2.10.6

bower angular-dragula#^1.2.8 resolved https://github.com/bevacqua/angular-dragula.git#1.2.8

bower ng-dialog#^0.6.2 resolved https://github.com/likeastore/ngDialog.git#0.6.6

bower angular#>=1.5 not-cached https://github.com/angular/bower-angular.git#>=1.5

bower angular#>=1.5 resolve https://github.com/angular/bower-angular.git#>=1.5

bower angular#>=1.5 checkout v1.6.2

bower bourbon#~4.2.1 resolved https://github.com/thoughtbot/bourbon.git#4.2.7

bower angular-i18n#~1.5.5 resolved https://github.com/angular/bower-angular-i18n.git#1.5.11

bower jquery-mockjax#~1.5.3 resolved https://github.com/jakerella/jquery-mockjax.git#1.5.4

bower angular#~1.5.8 progress Receiving objects: 94% (3634/3865), 27.75 MiB | 6.90 MiB/s

bower chai#~1.9.0 resolved https://github.com/chaijs/chai.git#1.9.2

bower mocha#~1.14.0 mismatch Version declared in the json (1.12.0) is different than the resolved one (1.14.0)

bower mocha#~1.14.0 resolved https://github.com/mochajs/mocha.git#1.14.0

bower lodash#~2.4.1 progress Receiving objects: 23% (6954/30231)

bower rxjs#^4.1.0 resolved https://github.com/Reactive-Extensions/RxJS.git#4.1.0

bower angular#~1.5.8 progress Receiving objects: 96% (3720/3865), 29.55 MiB | 6.53 MiB/s

bower mousetrap#~1.4.6 resolved https://github.com/ccampbell/mousetrap.git#1.4.6

bower ng-file-upload#~5.0.9 resolved https://github.com/danialfarid/angular-file-upload-bower.git#5.0.9

bower select2#3.5.2 checkout 3.5.2

bower lodash#~2.4.1 progress Receiving objects: 89% (26906/30231), 10.22 MiB | 10.15 MiB/s

bower angular#~1.5.8 progress Receiving objects: 98% (3799/3865), 32.18 MiB | 5.06 MiB/s

bower angular-mocks#~1.5.8 resolved https://github.com/angular/bower-angular-mocks.git#1.5.11

bower angular#>= 1.2.5 progress remote: Compressing objects: 43% (89/205)

bower angular#^1.3.0 progress Receiving objects: 55% (228/413)

bower lodash#~2.4.1 progress Resolving deltas: 59% (12107/20195)

bower angular#>=1.0.6 progress remote: Compressing objects: 34% (70/205)

bower angular#~1.5.8 progress Resolving deltas: 3% (74/2437)

bower angular#>= 1.2.5 progress Resolving deltas: 99% (243/245)

bower angular#>= 1.2.5 progress Resolving deltas: 100% (245/245)

bower angular#>= 1.2.5 progress Resolving deltas: 100% (245/245), done.

bower angular#>= 1.2.5 resolved https://github.com/angular/bower-angular.git#1.6.2

bower angular#^1.3.0 resolved https://github.com/angular/bower-angular.git#1.6.2

bower lodash#~2.4.1 resolved https://github.com/lodash/lodash.git#2.4.2

bower Caret.js#>= 0.2.0 checkout v0.3.1

bower angular#>=1.0.6 progress Receiving objects: 97% (401/413), 2.63 MiB | 5.17 MiB/s

bower angular#~1.5.8 progress Resolving deltas: 67% (1656/2437)

bower angular#>=1.3 progress remote: Compressing objects: 34% (70/205)

bower angular#>=1.0.6 resolved https://github.com/angular/bower-angular.git#1.6.2

bower angular#~1.5.8 progress Resolving deltas: 97% (2369/2437)

bower angular#>=1.x progress Resolving deltas: 22% (55/245)

bower angular#>=1.3 progress Resolving deltas: 44% (109/245)

bower angular#>=1.x resolved https://github.com/angular/bower-angular.git#1.6.2

bower angular#>=1.3 resolved https://github.com/angular/bower-angular.git#1.6.2

bower angular#~1.5.8 resolved https://github.com/angular/bower-angular.git#1.5.11

bower viewport-units-buggyfill#~0.4.1 checkout v0.4.1

bower angular-ui-router#~0.2.12 progress Resolving deltas: 56% (269/477)

bower angular-ui-router#~0.2.12 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.2.18

bower angular#~1.3.4 progress remote: Compressing objects: 44% (2003/4551)

bower hammerjs#~2.0.4 checkout v2.0.8

bower tether#~0.6.5 checkout v0.6.5

bower fastclick#~1.0.3 checkout v1.0.6

bower angular#>=1.2.18 progress remote: Compressing objects: 36% (74/205)

bower angular#~1.3.4 progress Receiving objects: 52% (6100/11729), 5.07 MiB | 10.12 MiB/s

bower angular#>=1.5 progress remote: Compressing objects: 46% (95/205)

bower angular#>=1.5 progress remote: Compressing objects: 47% (97/205)

bower angular#>=1.5 progress remote: Compressing objects: 48% (99/205)

bower angular#>=1.5 progress remote: Compressing objects: 49% (101/205)

bower angular#>=1.5 progress remote: Compressing objects: 50% (103/205)

bower angular-animate#~1.3.4 progress Resolving deltas: 81% (6025/7419)

bower angular#>=1.2.18 progress Resolving deltas: 0% (0/245)

bower angular-animate#~1.3.4 resolved https://github.com/angular/bower-angular-animate.git#1.3.20

bower angular#>=1.2.18 resolved https://github.com/angular/bower-angular.git#1.6.2

bower angular#~1.3.4 progress Receiving objects: 58% (6803/11729), 14.96 MiB | 9.93 MiB/s

bower moment#>= 2.6.0 resolved https://github.com/moment/moment.git#2.17.1

bower angular#>=1.5 progress Resolving deltas: 0% (0/245)

bower Caret.js#>= 0.2.0 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower Caret.js#>= 0.2.0 resolved https://github.com/ichord/Caret.js.git#0.3.1

bower viewport-units-buggyfill#~0.4.1 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .js files: ["./viewport-units-buggyfill.js","./viewport-units-buggyfill.hacks.js"]

bower angular#>=1.5 resolved https://github.com/angular/bower-angular.git#1.6.2

bower viewport-units-buggyfill#~0.4.1 resolved https://github.com/rodneyrehm/viewport-units-buggyfill.git#0.4.1

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .png files: ["select2.png","select2x2.png"]

bower select2#3.5.2 resolved https://github.com/ivaynberg/select2.git#3.5.2

bower angular#~1.3.4 progress Receiving objects: 60% (7038/11729), 21.84 MiB | 8.68 MiB/s

bower hammerjs#~2.0.4 resolved https://github.com/EightMedia/hammer.js.git#2.0.8

bower fastclick#~1.0.3 resolved https://github.com/ftlabs/fastclick.git#1.0.6

bower tether#~0.6.5 resolved https://github.com/HubSpot/tether.git#0.6.5

bower angular#~1.3.4 progress Receiving objects: 61% (7155/11729), 25.29 MiB | 8.38 MiB/s

bower angular#~1.3.4 progress Receiving objects: 64% (7507/11729), 36.47 MiB | 8.06 MiB/s

bower angular#~1.3.4 progress Receiving objects: 67% (7859/11729), 44.86 MiB | 7.59 MiB/s

bower angular#~1.3.4 progress Receiving objects: 85% (9970/11729), 53.76 MiB | 7.77 MiB/s

bower angular#~1.3.4 progress Receiving objects: 88% (10322/11729), 63.36 MiB | 8.41 MiB/s

bower angular#~1.3.4 progress Receiving objects: 91% (10674/11729), 73.51 MiB | 9.06 MiB/s

bower angular#~1.3.4 progress Receiving objects: 94% (11026/11729), 84.30 MiB | 9.66 MiB/s

bower angular#~1.3.4 progress Resolving deltas: 8% (619/7731)

bower angular#~1.3.4 progress Resolving deltas: 13% (1019/7731)

bower angular#~1.3.4 progress Resolving deltas: 49% (3800/7731)

bower angular#~1.3.4 progress Resolving deltas: 72% (5586/7731)

bower angular#~1.3.4 progress Resolving deltas: 78% (6085/7731)

bower angular#~1.3.4 progress Resolving deltas: 100% (7731/7731)

bower angular#~1.3.4 progress Resolving deltas: 100% (7731/7731), done.

bower angular#~1.3.4 resolved https://github.com/angular/bower-angular.git#1.3.20

Please note that,

foundation-apps#1.1.0 depends on angular-ui-router#~0.2.12 which resolved to angular-ui-router#0.2.18

openproject depends on angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Resort to using angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Code incompatibilities may occur.

Please note that,

foundation-apps#1.1.0 depends on angular-animate#~1.3.4 which resolved to angular-animate#1.3.20

openproject depends on angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

angular-busy#4.1.4 depends on angular-animate#>=1.3 which resolved to angular-animate#1.5.11

Resort to using angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

Code incompatibilities may occur.

Please note that,

angular-animate#1.3.20 depends on angular#1.3.20 which resolved to angular#1.3.20

foundation-apps#1.1.0 depends on angular#~1.3.4 which resolved to angular#1.3.20

angular-animate#1.5.11, angular-aria#1.5.11, angular-mocks#1.5.11, angular-sanitize#1.5.11 depends on angular#1.5.11 which resolved to angular#1.5.11

openproject depends on angular#~1.5.8 which resolved to angular#1.5.11

angular-ui-router#0.3.2, angular-ui-router#0.2.18 depends on angular#^1.0.8 which resolved to angular#1.6.2

angular-modal#d45eb9ceb7 depends on angular#^1.3.0 which resolved to angular#1.6.2

angular-context-menu#a908eccaec depends on angular#>= 1.2.5 which resolved to angular#1.6.2

ng-dialog#0.6.6 depends on angular#>=1.5 which resolved to angular#1.6.2

angular-elastic#2.5.1 depends on angular#>=1.0.6 which resolved to angular#1.6.2

angular-cache#4.6.0 depends on angular#>=1.x which resolved to angular#1.6.2

angular-busy#4.1.4 depends on angular#>=1.3 which resolved to angular#1.6.2

angular-ui-select#0.19.6 depends on angular#>=1.2.18 which resolved to angular#1.6.2

Resort to using angular#~1.5.8 which resolved to angular#1.5.11

Code incompatibilities may occur.

bower jquery extra-resolution Unnecessary resolution: jquery#1.11.0

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 install angular-context-menu#a908eccaec

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 install angular-modal#d45eb9ceb7

bower jquery-ui#~1.10.4 install jquery-ui#1.10.4

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de install angular-truncate#fdf60fda26

bower angular-elastic#~2.5.1 install angular-elastic#2.5.1

bower jquery.atwho#0.5.1 install jquery.atwho#0.5.1

bower angular-ui-router#~0.3.1 install angular-ui-router#0.3.2

bower angular-animate#~1.5.8 install angular-animate#1.5.11

bower angular-sanitize#~1.5.8 install angular-sanitize#1.5.11

bower jquery#1.11.0 install jquery#1.11.0

bower angular-busy#~4.1.3 install angular-busy#4.1.4

bower jquery-migrate#~1.2.1 install jquery-migrate#1.2.1

bower angular-cache#~4.6.0 install angular-cache#4.6.0

bower jquery-ujs#1.0.0 install jquery-ujs#1.0.0

bower foundation-apps#1.1.0 install foundation-apps#1.1.0

bower angular-aria#~1.5.8 install angular-aria#1.5.11

bower angular-ui-select#~0.19.4 install angular-ui-select#0.19.6

bower moment-timezone#0.4.x install moment-timezone#0.4.1

bower moment#~2.10.6 install moment#2.10.6

bower angular-dragula#^1.2.8 install angular-dragula#1.2.8

bower ng-dialog#^0.6.2 install ng-dialog#0.6.6

bower bourbon#~4.2.1 install bourbon#4.2.7

bower angular-i18n#~1.5.5 install angular-i18n#1.5.11

bower jquery-mockjax#~1.5.3 install jquery-mockjax#1.5.4

bower chai#~1.9.0 install chai#1.9.2

bower mocha#~1.14.0 install mocha#1.14.0

bower rxjs#^4.1.0 install rxjs#4.1.0

bower mousetrap#~1.4.6 install mousetrap#1.4.6

bower ng-file-upload#~5.0.9 install ng-file-upload#5.0.9

bower angular-mocks#~1.5.8 install angular-mocks#1.5.11

bower angular#1.5.11 install angular#1.5.11

bower lodash#~2.4.1 install lodash#2.4.2

bower Caret.js#>= 0.2.0 install Caret.js#0.3.1

bower viewport-units-buggyfill#~0.4.1 install viewport-units-buggyfill#0.4.1

bower select2#3.5.2 install select2#3.5.2

bower hammerjs#~2.0.4 install hammerjs#2.0.8

bower fastclick#~1.0.3 install fastclick#1.0.6

bower tether#~0.6.5 install tether#0.6.5

angular-context-menu#a908eccaec bower_components/angular-context-menu

└── angular#1.5.11

angular-modal#d45eb9ceb7 bower_components/angular-modal

└── angular#1.5.11

jquery-ui#1.10.4 bower_components/jquery-ui

└── jquery#1.11.0

angular-truncate#fdf60fda26 bower_components/angular-truncate

angular-elastic#2.5.1 bower_components/angular-elastic

└── angular#1.5.11

jquery.atwho#0.5.1 bower_components/jquery.atwho

├── Caret.js#0.3.1

└── jquery#1.11.0

angular-ui-router#0.3.2 bower_components/angular-ui-router

└── angular#1.5.11

angular-animate#1.5.11 bower_components/angular-animate

└── angular#1.5.11

angular-sanitize#1.5.11 bower_components/angular-sanitize

└── angular#1.5.11

jquery#1.11.0 bower_components/jquery

angular-busy#4.1.4 bower_components/angular-busy

├── angular#1.5.11

└── angular-animate#1.5.11

jquery-migrate#1.2.1 bower_components/jquery-migrate

angular-cache#4.6.0 bower_components/angular-cache

└── angular#1.5.11

jquery-ujs#1.0.0 bower_components/jquery-ujs

└── jquery#1.11.0

foundation-apps#1.1.0 bower_components/foundation-apps

├── angular#1.5.11

├── angular-animate#1.5.11

├── angular-ui-router#0.3.2

├── fastclick#1.0.6

├── hammerjs#2.0.8

├── tether#0.6.5

└── viewport-units-buggyfill#0.4.1

angular-aria#1.5.11 bower_components/angular-aria

└── angular#1.5.11

angular-ui-select#0.19.6 bower_components/angular-ui-select

└── angular#1.5.11

moment-timezone#0.4.1 bower_components/moment-timezone

└── moment#2.10.6

moment#2.10.6 bower_components/moment

angular-dragula#1.2.8 bower_components/angular-dragula

ng-dialog#0.6.6 bower_components/ng-dialog

└── angular#1.5.11

bourbon#4.2.7 bower_components/bourbon

angular-i18n#1.5.11 bower_components/angular-i18n

jquery-mockjax#1.5.4 bower_components/jquery-mockjax

chai#1.9.2 bower_components/chai

mocha#1.14.0 bower_components/mocha

rxjs#4.1.0 bower_components/rxjs

mousetrap#1.4.6 bower_components/mousetrap

ng-file-upload#5.0.9 bower_components/ng-file-upload

angular-mocks#1.5.11 bower_components/angular-mocks

└── angular#1.5.11

angular#1.5.11 bower_components/angular

lodash#2.4.2 bower_components/lodash

Caret.js#0.3.1 bower_components/Caret.js

└── jquery#1.11.0

viewport-units-buggyfill#0.4.1 bower_components/viewport-units-buggyfill

select2#3.5.2 bower_components/select2

└── jquery#1.11.0

hammerjs#2.0.8 bower_components/hammerjs

fastclick#1.0.6 bower_components/fastclick

tether#0.6.5 bower_components/tether

openproject-frontend@0.1.0 /tmp/d20170210-17-4efcbc/opt/openproject/frontend

+-- acorn@2.6.4

+-- align-text@0.1.4

+-- alter@0.2.0

+-- amdefine@1.0.0

+-- angular@1.5.8

+-- angular-elastic@2.5.1

+-- angular-ui-bootstrap@2.2.0

+-- anymatch@1.3.0

+-- arr-diff@2.0.0

+-- arr-flatten@1.0.1

+-- array-unique@0.2.1

+-- arrify@1.0.1

+-- assert@1.4.1

+-- async@0.2.10

+-- async-each@1.0.1

+-- atoa@1.0.0

+-- autoprefixer-core@5.2.1

+-- autoprefixer-loader@1.2.0

+-- awesome-typescript-loader@2.2.4

| `-- lodash@4.16.4

+-- balanced-match@0.4.2

+-- Base64@0.2.1

+-- base64-js@1.2.0

+-- big.js@3.1.3

+-- binary-extensions@1.7.0

+-- bower@1.7.9

+-- brace-expansion@1.1.6

+-- braces@1.8.5

+-- browserify-zlib@0.1.4

+-- browserslist@0.4.0

+-- buffer@4.9.1

+-- buffer-shims@1.0.0

+-- camelcase@1.2.1

+-- caniuse-db@1.0.30000569

+-- center-align@0.1.3

+-- chokidar@1.6.1

+-- cliui@2.1.0

| `-- wordwrap@0.0.2

+-- clone@1.0.2

+-- colors@1.1.2

+-- concat-map@0.0.1

+-- console-browserify@1.1.0

+-- constants-browserify@0.0.1

+-- contra@1.9.4

+-- convert-source-map@1.1.3

+-- core-util-is@1.0.2

+-- crossvent@1.5.4

+-- crypto-browserify@3.2.8

+-- css-loader@0.9.1

| `-- source-map@0.1.43

+-- csso@1.3.12

+-- custom-event@1.0.0

+-- d@0.1.1

+-- date-now@0.1.4

+-- decamelize@1.2.0

+-- domain-browser@1.1.7

+-- dragula@3.7.2

+-- emojis-list@2.1.0

+-- enhanced-resolve@2.3.0

+-- errno@0.1.4

+-- es5-ext@0.10.12

+-- es6-iterator@2.0.0

+-- es6-promise@2.3.0

+-- es6-symbol@3.1.0

+-- es6-weak-map@0.1.4

| +-- es6-iterator@0.1.3

| `-- es6-symbol@2.0.1

+-- event-emitter@0.3.4

+-- events@1.1.1

+-- expand-brackets@0.1.5

+-- expand-range@1.8.2

+-- exports-loader@0.6.3

| `-- source-map@0.1.43

+-- expose-loader@0.6.0

+-- extglob@0.3.2

+-- extract-text-webpack-plugin@0.3.8

| `-- source-map@0.1.43

+-- fastparse@1.1.1

+-- file-loader@0.8.5

+-- filename-regex@2.0.0

+-- fill-range@2.2.3

+-- for-in@0.1.6

+-- for-own@0.1.4

+-- glob@4.5.3

+-- glob-base@0.3.0

+-- glob-parent@2.0.0

+-- graceful-fs@4.1.9

+-- has-flag@1.0.0

+-- html-loader@0.2.3

| `-- source-map@0.1.43

+-- html-minifier@0.5.6

+-- http-browserify@1.7.0

+-- https-browserify@0.0.0

+-- ieee754@1.1.8

+-- indexof@0.0.1

+-- inflight@1.0.6

+-- inherits@2.0.3

+-- interpret@0.6.6

+-- is-binary-path@1.0.1

+-- is-buffer@1.1.4

+-- is-dotfile@1.0.2

+-- is-equal-shallow@0.1.3

+-- is-extendable@0.1.1

+-- is-extglob@1.0.0

+-- is-glob@2.0.1

+-- is-number@2.1.0

+-- is-posix-bracket@0.1.1

+-- is-primitive@2.0.0

+-- isarray@1.0.0

+-- isobject@2.1.0

+-- js-base64@2.1.9

+-- json5@0.4.0

+-- kind-of@3.0.4

+-- lazy-cache@1.0.4

+-- loader-utils@0.2.16

| `-- json5@0.5.0

+-- lodash@2.4.2

+-- longest@1.0.1

+-- lru-queue@0.1.0

+-- memoizee@0.3.10

+-- memory-fs@0.3.0

+-- micromatch@2.3.11

+-- mime@1.2.11

+-- minimatch@2.0.10

+-- minimist@0.0.10

+-- mkdirp@0.5.1

| `-- minimist@0.0.8

+-- nan@2.4.0

+-- next-tick@0.2.2

+-- ng-annotate@1.2.1

| `-- source-map@0.5.6

+-- ng-annotate-loader@0.0.10

| `-- source-map@0.4.2

+-- ngtemplate-loader@0.1.3

+-- node-libs-browser@0.6.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- normalize-path@2.0.1

+-- num2fraction@1.2.2

+-- object-assign@4.1.0

+-- object.omit@2.0.1

+-- observable-array@0.0.4

+-- observable-value@0.0.5

+-- once@1.4.0

+-- optimist@0.6.1

+-- ordered-ast-traverse@1.1.1

+-- ordered-esprima-props@1.1.0

+-- os-browserify@0.1.2

+-- pako@0.2.9

+-- parse-glob@3.0.4

+-- path-browserify@0.0.0

+-- path-is-absolute@1.0.1

+-- pbkdf2-compat@2.0.1

+-- phantomjs-polyfill@0.0.2

+-- postcss@4.1.16

+-- preserve@0.2.0

+-- process@0.11.9

+-- process-nextick-args@1.0.7

+-- prr@0.0.0

+-- punycode@1.4.1

+-- querystring@0.2.0

+-- querystring-es3@0.2.1

+-- randomatic@1.1.5

+-- readable-stream@2.1.5

+-- readdirp@2.1.0

| `-- minimatch@3.0.3

+-- regex-cache@0.4.3

+-- repeat-element@1.1.2

+-- repeat-string@1.6.1

+-- right-align@0.1.3

+-- ripemd160@0.2.0

+-- set-immediate-shim@1.0.1

+-- sha.js@2.2.6

+-- shelljs@0.3.0

+-- simple-fmt@0.1.0

+-- simple-is@0.2.0

+-- source-list-map@0.1.6

+-- source-map@0.4.4

+-- source-map-support@0.4.5

| `-- source-map@0.5.6

+-- stable@0.1.5

+-- stream-browserify@1.0.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- string_decoder@0.10.31

+-- stringmap@0.2.2

+-- stringset@0.2.1

+-- style-loader@0.8.3

+-- supports-color@3.1.2

+-- tapable@0.2.4

+-- ticky@1.0.1

+-- timers-browserify@1.4.2

+-- timers-ext@0.1.0

+-- tryor@0.1.2

+-- tty-browserify@0.0.0

+-- typescript@2.0.6

+-- uglify-js@2.7.4

| `-- source-map@0.5.6

+-- uglify-to-browserify@1.0.2

+-- URIjs@1.16.1

+-- url@0.10.3

| `-- punycode@1.3.2

+-- url-loader@0.5.7

+-- util@0.10.3

| `-- inherits@2.0.1

+-- util-deprecate@1.0.2

+-- vm-browserify@0.0.4

+-- watchpack@0.2.9

| `-- async@0.9.2

+-- webpack@1.13.3

| +-- acorn@3.3.0

| +-- async@1.5.2

| +-- enhanced-resolve@0.9.1

| | `-- memory-fs@0.2.0

| `-- tapable@0.1.10

+-- webpack-core@0.6.8

+-- window-size@0.1.0

+-- wordwrap@0.0.3

+-- wrappy@1.0.2

`-- yargs@3.10.0

npm WARN openproject-frontend@0.1.0 No repository field.

npm WARN openproject-frontend@0.1.0 No license field.

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.0.14 (node_modules/fsevents):

npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.0.14: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

-----> Checking startup method

Found Procfile

-----> Finalizing build

Creating runtime environment

Exporting binary paths

Cleaning npm artifacts

Cleaning previous cache

Caching results for future builds

-----> Build succeeded!

openproject@0.1.0 /tmp/d20170210-17-4efcbc/opt/openproject

`-- typescript@2.0.8

=====> Downloading Buildpack: https://github.com/pkgr/heroku-buildpack-ruby.git

=====> Detected Framework: Ruby

-----> Compiling Ruby/Rails

-----> Using Ruby version: ruby-2.3.1

-----> Installing dependencies using bundler 1.13.2

cp: `/tmp/d20170210-17-4efcbc/opt/openproject/.git/cache/vendor/bundle/.' and `/tmp/d20170210-17-4efcbc/opt/openproject/.git/cache/vendor/bundle/.' are the same file

Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Fetching gem metadata from https://rubygems.org/......

Fetching version metadata from https://rubygems.org/..

Fetching dependency metadata from https://rubygems.org/.

Using rake 11.3.0

Using concurrent-ruby 1.0.2

Using i18n 0.7.0

Using minitest 5.9.0

Using thread_safe 0.3.5

Using builder 3.2.2

Using erubis 2.7.0

Using mini_portile2 2.1.0

Using pkg-config 1.1.7

Using rack 2.0.1

Using nio4r 1.2.1

Using websocket-extensions 0.1.2

Using mime-types 2.99.3

Using method_source 0.8.2

Using thor 0.19.1

Using arel 7.1.2

Using multi_json 1.12.1

Using acts_as_silent_list 3.0.0

Using addressable 2.4.0

Using airbrake-ruby 1.5.0

Using attr_required 1.0.1

Using execjs 2.7.0

Using ice_nine 0.11.2

Using bcrypt 3.1.11

Using bindata 2.3.4

Using sass 3.4.22

Using tilt 2.0.5

Using uber 0.0.15

Using erbse 0.0.2

Using coderay 1.1.1

Using color-tools 1.3.0

Using unf_ext 0.0.7.2

Using netrc 0.11.0

Using daemons 1.2.4

Using dalli 2.7.6

Using enumerable-lazy 0.0.1

Using equalizer 0.0.11

Using excon 0.52.0

Using ffi 1.9.14

Using formatador 0.2.5

Using ipaddress 0.8.3

Using get_process_mem 0.2.1

Using request_store 1.3.1

Using json 1.8.3

Using hashie 3.4.6

Using multi_xml 0.5.5

Using gravatar_image_tag 1.2.0

Using bundler 1.13.2

Using htmldiff 0.0.1

Using httpclient 2.8.2.4

Using icalendar 2.3.0

Using iso8601 0.9.1

Using securecompare 1.0.0

Using url_safe_base64 0.2.2

Using kgio 2.10.0

Using mixlib-shellout 2.1.0

Using mysql2 0.4.4

Using net-ldap 0.14.0

Using newrelic_rpm 3.16.2.321

Using oj 2.17.4

Using pdf-core 0.6.1

Using ttfunk 1.4.0

Using rmagick 2.15.4

Using rubyzip 1.2.0

Using ruby-ole 1.2.12

Using pg 0.19.0

Using rails_serve_static_assets 0.0.5

Using rails_stdout_logging 0.0.5

Using raindrops 0.17.0

Using ruby-progressbar 1.8.1

Using structured_warnings 0.2.0

Using sqlite3 1.3.11

Using stringex 2.6.1

Using svg-graph 2.0.1

Using syck 1.0.5

Using will_paginate 3.1.3

Using i18n-js 3.0.0.rc14

Using tzinfo 1.2.2

Using descendants_tracker 0.0.4

Using nokogiri 1.6.8

Using rack-test 0.6.3

Using rack-accept 0.4.5

Using sprockets 3.7.0

Using passenger 5.0.30

Using rack-attack 5.0.1

Using rack-protection 2.0.0.beta2

Using warden 1.2.6

Using websocket-driver 0.6.4

Using mail 2.6.4

Using airbrake 5.1.0

Using bourbon 4.2.7

Using cells 4.1.3

Using unf 0.1.4

Using autoprefixer-rails 6.4.1.1

Using mustermann19 0.4.4

Using sys-filesystem 1.1.7

Using fog-core 1.42.0

Using rdoc 4.2.2

Using omniauth 1.3.1 from https://github.com/oliverguenther/omniauth (at 8385bc0@8385bc0)

Using prawn 2.1.0

Using spreadsheet 0.8.9

Using rails_12factor 0.0.3

Using unicorn 5.1.0

Using rubytree 0.9.7

Using activesupport 5.0.0.1

Using tzinfo-data 1.2016.6

Using axiom-types 0.1.1

Using coercible 1.0.0

Using loofah 2.0.3

Using representable 2.1.8

Using ruby-saml 1.4.0

Using warden-basic_auth 0.2.1

Using cells-erb 0.0.8

Using domain_name 0.5.20161129

Using fog-json 1.0.2

Using fog-xml 0.1.2

Using prawn-table 0.2.2

Using rails-dom-testing 2.0.1

Using globalid 0.3.7

Using activemodel 5.0.0.1

Using climate_control 0.0.3

Using delayed_job 4.1.2

Using json-jwt 1.6.5

Using rack-oauth2 1.4.0

Using swd 1.0.1

Using webfinger 1.0.2

Using rabl 0.13.0

Using ruby-duration 3.2.3

Using unicorn-worker-killer 0.4.4

Using rails-html-sanitizer 1.0.3

Using disposable 0.0.9

Using roar 1.0.4

Using virtus 1.0.5

Using omniauth-saml 1.6.0 from git://github.com/omniauth/omniauth-saml.git (at master@5559d6b)

Using http-cookie 1.0.3

Using fog-aws 0.11.0

Using activerecord 5.0.0.1

Using carrierwave 1.0.0.beta from https://github.com/carrierwaveuploader/carrierwave (at master@5367a63)

Using date_validator 0.9.0

Using validate_email 0.1.6

Using validate_url 1.0.2

Using cocaine 0.5.8

Using activejob 5.0.0.1

Using actionview 5.0.0.1

Using reform 1.2.6

Using openproject-auth_saml 0.1.0 from https://github.com/finnlabs/openproject-auth_saml (at dev@97212ab)

Using grape 0.17.0

Using rest-client 1.8.0

Using activemodel-serializers-xml 1.0.1

Using acts_as_list 0.8.1

Using acts_as_tree 2.5.1

Using awesome_nested_set 3.1.1

Using delayed_job_active_record 4.1.1

Using friendly_id 5.2.0.beta.1 from https://github.com/norman/friendly_id (at aff0564@aff0564)

Using globalize 5.1.0 from https://github.com/globalize/globalize (at 38443bc@38443bc)

Using transactional_lock 0.1.0 from https://github.com/finnlabs/transactional_lock.git (at master@6948b1d)

Using openid_connect 0.8.3

Using actionpack 5.0.0.1

Using grape-cache_control 1.0.1

Using crowdin-api 0.4.1

Using omniauth-openid-connect 0.2.0 from https://github.com/finnlabs/omniauth-openid-connect.git (at dev@c3bce4c)

Using actioncable 5.0.0.1

Using actionmailer 5.0.0.1

Using railties 5.0.0.1

Using cells-rails 0.0.6

Using gon 4.1.1

Using sprockets-rails 3.2.0

Using omniauth-openid_connect-providers 0.1.0 from https://github.com/finnlabs/omniauth-openid_connect-providers.git (at dev@86f3670)

Using actionpack-xml_parser 2.0.0

Using activerecord-session_store 1.0.0

Using rails 5.0.0.1

Using jquery-tablesorter 1.22.7

Using responders 2.3.0

Using sass-rails 5.0.6

Using health_check 2.2.1

Using lobby_boy 0.1.2

Using openproject-auth_plugins 6.1.4 from source at `vendored-plugins/openproject-auth_plugins`

Using openproject-pdf_export 6.1.4 from source at `vendored-plugins/openproject-pdf_export`

Using openproject-costs 6.1.4 from source at `vendored-plugins/openproject-costs`

Using openproject-documents 6.1.4 from source at `vendored-plugins/openproject-documents`

Using openproject-webhooks 6.1.4 from source at `vendored-plugins/openproject-webhooks`

Using openproject-global_roles 6.1.4 from source at `vendored-plugins/openproject-global_roles`

Using openproject-local_avatars 6.1.4 from source at `vendored-plugins/openproject-local_avatars`

Using openproject-meeting 6.1.4 from source at `vendored-plugins/openproject-meeting`

Using openproject-my_project_page 6.1.4 from source at `vendored-plugins/openproject-my_project_page`

Using reporting_engine 6.1.4 from source at `vendored-plugins/reporting_engine`

Using openproject-themes-dark 6.1.4 from source at `vendored-plugins/openproject-themes-dark`

Using openproject-translations 6.1.4 from https://github.com/opf/openproject-translations.git (at stable/6@da52ff9)

Using openproject-xls_export 6.1.4 from source at `vendored-plugins/openproject-xls_export`

Using rails-angular-xss 0.3.0.pre.pre from https://github.com/opf/rails-angular-xss (at a45267d@a45267d)

Using rails_autolink 1.1.6

Using openproject-openid_connect 6.1.4 from source at `vendored-plugins/openproject-openid_connect`

Using openproject-backlogs 6.1.4 from source at `vendored-plugins/openproject-backlogs`

Using openproject-github_integration 6.1.4 from source at `vendored-plugins/openproject-github_integration`

Using openproject-reporting 6.1.4 from source at `vendored-plugins/openproject-reporting`

Bundle complete! 138 Gemfile dependencies, 195 gems now installed.

Gems in the groups development and test were not installed.

Bundled gems are installed into ./vendor/bundle.

Bundle completed (12.10s)

Cleaning up the bundler cache.

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

-----> Detecting rake tasks

-----> Preparing app for Rails asset pipeline

Running: rake assets:precompile

$(npm bin)/webpack --config webpack.production.config.js

{"omniauth-openid-connect":"/tmp/d20170210-17-4efcbc/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid-connect-c3bce4c9e9ac","omniauth-openid_connect-providers":"/tmp/d20170210-17-4efcbc/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid_connect-providers-86f3670e127e","omniauth-saml":"/tmp/d20170210-17-4efcbc/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-saml-5559d6b80805","openproject-auth_plugins":"/tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-auth_plugins","openproject-auth_saml":"/tmp/d20170210-17-4efcbc/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-auth_saml-97212abb8378","openproject-pdf_export":"/tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-pdf_export","openproject-backlogs":"/tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-backlogs","openproject-costs":"/tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-costs","openproject-documents":"/tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-documents","openproject-webhooks":"/tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-webhooks","openproject-github_integration":"/tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-github_integration","openproject-global_roles":"/tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-global_roles","openproject-local_avatars":"/tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-local_avatars","openproject-meeting":"/tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-meeting","openproject-my_project_page":"/tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-my_project_page","openproject-openid_connect":"/tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-openid_connect","reporting_engine":"/tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/reporting_engine","openproject-reporting":"/tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-reporting","openproject-themes-dark":"/tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-themes-dark","openproject-translations":"/tmp/d20170210-17-4efcbc/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-translations-da52ff92cdcd","openproject-xls_export":"/tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-xls_export"}

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Hash: 3fae438f1b91f586860e

Version: webpack 1.13.3

Child

Hash: 3fae438f1b91f586860e

Version: webpack 1.13.3

Time: 17344ms

Asset Size Chunks Chunk Names

7b9776076d5fceef4993b55c9383dedd.gif 1.85 kB [emitted]

openproject-backlogs.js 453 kB 0 [emitted] backlogs

openproject-core-app.js 3.43 MB 1 [emitted] core-app

openproject-costs.js 526 kB 2 [emitted] costs

openproject-global.js 3.51 MB 3 [emitted] global

openproject-my_project_page.js 14.3 kB 4 [emitted] my_project_page

openproject-core-app.css 4.71 kB 1 [emitted] core-app

openproject-global.css 49 kB 3 [emitted] global

[213] ./templates \.html$ 1.22 kB {1} [built]

[242] ./components ^((?!\.(test|spec)).)*\.(js|ts|html)$ 16.1 kB {1} [built]

[633] /tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 425 bytes {2} [built]

[765] /tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 330 bytes {4} [built]

+ 769 hidden modules

ERROR in [default]

File '/tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-budget-subform.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-4efcbc/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-4efcbc/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/subform/cost-subform.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-4efcbc/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts' is not under 'rootDir' '/tmp/d20170210-17-4efcbc/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts' is not under 'rootDir' '/tmp/d20170210-17-4efcbc/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-block.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-4efcbc/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-page-layout.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-4efcbc/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-textile-block.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-4efcbc/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default] /tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:49:18

Argument of type 'string' is not assignable to parameter of type '{ [key: string]: any; }'.

ERROR in [default] /tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:53:4

Supplied parameters do not match any signature of call target.

ERROR in [default] /tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:30:38

Cannot find module 'app/components/work-packages/work-package-cache.service'.

ERROR in [default] /tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:49:30

Cannot find name 'HalResource'.

ERROR in [default] /tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:54:57

Property '$injector' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:13

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:27

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:60:11

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:70:23

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:76:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:77:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:78:16

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:36:17

Property 'value' does not exist on type 'CurrencyDisplayField'.

ERROR in [default] /tmp/d20170210-17-4efcbc/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:37:23

Property 'value' does not exist on type 'CurrencyDisplayField'.

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 5 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

I, [2017-02-10T12:54:40.106706 #2420] INFO -- : Writing /tmp/d20170210-17-4efcbc/opt/openproject/public/assets/application-e7e19b8fbaccbe64e8f5a8a244ba087d40dac6c16f743a1cba083da054dfa31f.js

I, [2017-02-10T12:54:40.107178 #2420] INFO -- : Writing /tmp/d20170210-17-4efcbc/opt/openproject/public/assets/application-e7e19b8fbaccbe64e8f5a8a244ba087d40dac6c16f743a1cba083da054dfa31f.js.gz

Asset precompilation completed (34.01s)

Cleaning assets

Running: rake assets:clean

I, [2017-02-10T12:54:52.924126 #2595] INFO -- : Removed application-72e391967c2440c188aa021eb694bed0601afaef8c2d325fe94800a3b638abc2.js

Using release configuration from last framework (Ruby).

-----> [cron] /opt/openproject/packaging/cron/openproject-clear-old-sessions => /etc/cron.d/openproject-clear-old-sessions

-----> Verifying package openproject_6.1.4-1486730985.5bf684b.wheezy_amd64.deb

NEW PACKAGE: openproject_6.1.4-1486730985.5bf684b.wheezy_amd64.deb (286.52 MiB)

-----> Releasing...

DONE!

====== Attempt #1

-----> Fetching repository

Cloning into '/tmp/d20170210-16665-iexldr/input'...

-----> Restoring cache

-----> Starting packaging process

-----> Installing missing build dependencies: libmagickwand-dev, libsqlite3-dev

-----> [wizard] adding legacy-installer wizard (https://github.com/pkgr/addon-legacy-installer#master)

-----> [wizard] adding mysql wizard (https://github.com/pkgr/addon-mysql#master)

-----> [wizard] adding apache2 wizard (https://github.com/pkgr/addon-apache2#master)

-----> [wizard] adding repositories wizard (https://github.com/finnlabs/addon-repositories#master)

-----> [wizard] adding smtp wizard (https://github.com/pkgr/addon-smtp#master)

-----> [wizard] adding memcached wizard (https://github.com/pkgr/addon-memcached#master)

-----> [wizard] adding openproject wizard (https://github.com/pkgr/addon-openproject#master)

/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)

-----> Fetching buildpack https://github.com/opf/heroku-buildpack-multi.git at master

-----> Multipack app

-----> Running hook: "packaging/setup"

WARNING: This buildpack is no longer maintained.

Please choose a different buildpack or go to https://github.com/ddollar/heroku-buildpack-multi

and fork it to your own account.

=====> Downloading Buildpack: https://github.com/pkgr/pkgr-buildpack-imagemagick.git

=====> Detected Framework: ImageMagick

-----> SKIP

=====> Downloading Buildpack: https://github.com/heroku/heroku-buildpack-nodejs.git

=====> Detected Framework: Node.js

-----> Reading application state

package.json...

build directory...

cache directory...

environment variables...

Node engine: 6.9.1

Npm engine: 4.0.0

Start mechanism: Procfile

node_modules source: package.json

node_modules cached: true

NPM_CONFIG_PRODUCTION=true

NODE_MODULES_CACHE=true

-----> Installing binaries

Downloading and installing node 6.9.1...

Downloading and installing npm 4.0.0 (replacing version 3.10.8)...

-----> Building dependencies

Restoring node modules from cache

Pruning unused dependencies

Installing any new modules

> openproject@0.1.0 postinstall /tmp/d20170210-17-1jd6p5j/opt/openproject

> cd frontend && npm install

> openproject-frontend@0.1.0 postinstall /tmp/d20170210-17-1jd6p5j/opt/openproject/frontend

> bower install --config.interactive=false

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 not-cached git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolve git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de not-cached git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolve git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 not-cached git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolve git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 checkout d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower jquery#1.11.0 not-cached https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery#1.11.0 resolve https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery-ui#~1.10.4 not-cached https://github.com/components/jqueryui.git#~1.10.4

bower jquery-ui#~1.10.4 resolve https://github.com/components/jqueryui.git#~1.10.4

bower jquery-ujs#1.0.0 not-cached https://github.com/rails/jquery-ujs.git#1.0.0

bower jquery-ujs#1.0.0 resolve https://github.com/rails/jquery-ujs.git#1.0.0

bower select2#3.5.2 not-cached https://github.com/ivaynberg/select2.git#3.5.2

bower select2#3.5.2 resolve https://github.com/ivaynberg/select2.git#3.5.2

bower angular#~1.5.8 not-cached https://github.com/angular/bower-angular.git#~1.5.8

bower angular#~1.5.8 resolve https://github.com/angular/bower-angular.git#~1.5.8

bower angular-aria#~1.5.8 not-cached https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-aria#~1.5.8 resolve https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-animate#~1.5.8 not-cached https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-animate#~1.5.8 resolve https://github.com/angular/bower-angular-animate.git#~1.5.8

bower jquery.atwho#0.5.1 not-cached https://github.com/ichord/At.js.git#0.5.1

bower jquery.atwho#0.5.1 resolve https://github.com/ichord/At.js.git#0.5.1

bower angular-ui-router#~0.3.1 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-ui-router#~0.3.1 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-elastic#~2.5.1 not-cached https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-elastic#~2.5.1 resolve https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-sanitize#~1.5.8 not-cached https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-sanitize#~1.5.8 resolve https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-i18n#~1.5.5 not-cached https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-i18n#~1.5.5 resolve https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de checkout fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 checkout a908eccaec323cd66973d58af4965694bdff16a1

bower angular-cache#~4.6.0 not-cached https://github.com/jmdobry/angular-cache.git#~4.6.0

bower angular-cache#~4.6.0 resolve https://github.com/jmdobry/angular-cache.git#~4.6.0

bower jquery-migrate#~1.2.1 not-cached https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower jquery-migrate#~1.2.1 resolve https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower moment#~2.10.6 not-cached https://github.com/moment/moment.git#~2.10.6

bower moment#~2.10.6 resolve https://github.com/moment/moment.git#~2.10.6

bower moment-timezone#0.4.x not-cached https://github.com/moment/moment-timezone.git#0.4.x

bower moment-timezone#0.4.x resolve https://github.com/moment/moment-timezone.git#0.4.x

bower lodash#~2.4.1 not-cached https://github.com/lodash/lodash.git#~2.4.1

bower lodash#~2.4.1 resolve https://github.com/lodash/lodash.git#~2.4.1

bower angular-busy#~4.1.3 not-cached https://github.com/cgross/angular-busy.git#~4.1.3

bower angular-busy#~4.1.3 resolve https://github.com/cgross/angular-busy.git#~4.1.3

bower bourbon#~4.2.1 not-cached https://github.com/thoughtbot/bourbon.git#~4.2.1

bower bourbon#~4.2.1 resolve https://github.com/thoughtbot/bourbon.git#~4.2.1

bower foundation-apps#1.1.0 not-cached https://github.com/zurb/foundation-apps.git#1.1.0

bower foundation-apps#1.1.0 resolve https://github.com/zurb/foundation-apps.git#1.1.0

bower angular-ui-select#~0.19.4 not-cached https://github.com/angular-ui/ui-select.git#~0.19.4

bower angular-ui-select#~0.19.4 resolve https://github.com/angular-ui/ui-select.git#~0.19.4

bower ng-file-upload#~5.0.9 not-cached https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower ng-file-upload#~5.0.9 resolve https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower rxjs#^4.1.0 not-cached https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower rxjs#^4.1.0 resolve https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower mousetrap#~1.4.6 not-cached https://github.com/ccampbell/mousetrap.git#~1.4.6

bower mousetrap#~1.4.6 resolve https://github.com/ccampbell/mousetrap.git#~1.4.6

bower angular-dragula#^1.2.8 not-cached https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower angular-dragula#^1.2.8 resolve https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower mocha#~1.14.0 not-cached https://github.com/mochajs/mocha.git#~1.14.0

bower mocha#~1.14.0 resolve https://github.com/mochajs/mocha.git#~1.14.0

bower ng-dialog#^0.6.2 not-cached https://github.com/likeastore/ngDialog.git#^0.6.2

bower ng-dialog#^0.6.2 resolve https://github.com/likeastore/ngDialog.git#^0.6.2

bower angular-mocks#~1.5.8 not-cached https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower angular-mocks#~1.5.8 resolve https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower chai#~1.9.0 not-cached https://github.com/chaijs/chai.git#~1.9.0

bower chai#~1.9.0 resolve https://github.com/chaijs/chai.git#~1.9.0

bower jquery-mockjax#~1.5.3 not-cached https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery-mockjax#~1.5.3 resolve https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery-ui#~1.10.4 checkout 1.10.4

bower jquery#1.11.0 checkout 1.11.0

bower select2#3.5.2 checkout 3.5.2

bower jquery-ujs#1.0.0 checkout v1.0.0

bower angular#~1.5.8 checkout v1.5.11

bower angular-ui-router#~0.3.1 checkout 0.3.2

bower jquery.atwho#0.5.1 checkout v0.5.1

bower angular-aria#~1.5.8 checkout v1.5.11

bower angular-elastic#~2.5.1 checkout v2.5.1

bower angular-animate#~1.5.8 checkout v1.5.11

bower jquery-migrate#~1.2.1 checkout 1.2.1

bower angular-cache#~4.6.0 checkout 4.6.0

bower angular-i18n#~1.5.5 checkout v1.5.11

bower angular-sanitize#~1.5.8 checkout v1.5.11

bower angular-busy#~4.1.3 checkout v4.1.4

bower foundation-apps#1.1.0 checkout v1.1.0

bower lodash#~2.4.1 checkout 2.4.2

bower moment-timezone#0.4.x checkout 0.4.1

bower moment#~2.10.6 checkout 2.10.6

bower bourbon#~4.2.1 checkout v4.2.7

bower ng-file-upload#~5.0.9 checkout 5.0.9

bower angular-ui-select#~0.19.4 checkout v0.19.6

bower mousetrap#~1.4.6 checkout 1.4.6

bower rxjs#^4.1.0 checkout v4.1.0

bower angular-dragula#^1.2.8 checkout v1.2.8

bower ng-dialog#^0.6.2 checkout v0.6.6

bower mocha#~1.14.0 checkout 1.14.0

bower chai#~1.9.0 checkout 1.9.2

bower angular-mocks#~1.5.8 checkout v1.5.11

bower jquery-mockjax#~1.5.3 checkout v1.5.4

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .png files: ["select2.png","select2x2.png"]

bower jquery-ui#~1.10.4 resolved https://github.com/components/jqueryui.git#1.10.4

bower select2#3.5.2 resolved https://github.com/ivaynberg/select2.git#3.5.2

bower jquery-ujs#1.0.0 resolved https://github.com/rails/jquery-ujs.git#1.0.0

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolved git://github.com/nickmessing/angular-context-menu.git#a908eccaec

bower angular#>= 1.2.5 not-cached https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 resolve https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 checkout v1.6.2

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolved git://github.com/finnlabs/angular-modal.git#d45eb9ceb7

bower angular#^1.3.0 not-cached https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 resolve https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 checkout v1.6.2

bower jquery.atwho#0.5.1 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower angular-aria#~1.5.8 resolved https://github.com/angular/bower-angular-aria.git#1.5.11

bower angular#~1.5.8 resolved https://github.com/angular/bower-angular.git#1.5.11

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolved git://github.com/sparkalow/angular-truncate.git#fdf60fda26

bower angular-elastic#~2.5.1 resolved https://github.com/monospaced/angular-elastic.git#2.5.1

bower angular-ui-router#~0.3.1 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.3.2

bower angular-animate#~1.5.8 resolved https://github.com/angular/bower-angular-animate.git#1.5.11

bower jquery.atwho#0.5.1 resolved https://github.com/ichord/At.js.git#0.5.1

bower jquery#1.11.0 resolved https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery-migrate#~1.2.1 deprecated Package jquery-migrate is using the deprecated component.json

bower jquery-migrate#~1.2.1 resolved https://github.com/appleboy/jquery-migrate.git#1.2.1

bower Caret.js#>= 0.2.0 not-cached https://github.com/ichord/Caret.js.git#>= 0.2.0

bower Caret.js#>= 0.2.0 resolve https://github.com/ichord/Caret.js.git#>= 0.2.0

bower angular-cache#~4.6.0 resolved https://github.com/jmdobry/angular-cache.git#4.6.0

bower angular-sanitize#~1.5.8 resolved https://github.com/angular/bower-angular-sanitize.git#1.5.11

bower angular-busy#~4.1.3 resolved https://github.com/cgross/angular-busy.git#4.1.4

bower lodash#~2.4.1 resolved https://github.com/lodash/lodash.git#2.4.2

bower foundation-apps#1.1.0 resolved https://github.com/zurb/foundation-apps.git#1.1.0

bower angular#~1.3.4 not-cached https://github.com/angular/bower-angular.git#~1.3.4

bower angular#~1.3.4 resolve https://github.com/angular/bower-angular.git#~1.3.4

bower angular-ui-router#~0.2.12 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-ui-router#~0.2.12 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-animate#~1.3.4 not-cached https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular-animate#~1.3.4 resolve https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular-ui-router#~0.2.12 checkout 0.2.18

bower angular#~1.3.4 checkout v1.3.20

bower angular-animate#~1.3.4 checkout v1.3.20

bower fastclick#~1.0.3 not-cached https://github.com/ftlabs/fastclick.git#~1.0.3

bower fastclick#~1.0.3 resolve https://github.com/ftlabs/fastclick.git#~1.0.3

bower viewport-units-buggyfill#~0.4.1 not-cached https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower viewport-units-buggyfill#~0.4.1 resolve https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower mousetrap#~1.4.6 resolved https://github.com/ccampbell/mousetrap.git#1.4.6

bower ng-file-upload#~5.0.9 resolved https://github.com/danialfarid/angular-file-upload-bower.git#5.0.9

bower tether#~0.6.5 not-cached https://github.com/HubSpot/tether.git#~0.6.5

bower tether#~0.6.5 resolve https://github.com/HubSpot/tether.git#~0.6.5

bower hammerjs#~2.0.4 not-cached https://github.com/EightMedia/hammer.js.git#~2.0.4

bower hammerjs#~2.0.4 resolve https://github.com/EightMedia/hammer.js.git#~2.0.4

bower angular-ui-select#~0.19.4 resolved https://github.com/angular-ui/ui-select.git#0.19.6

bower moment-timezone#0.4.x resolved https://github.com/moment/moment-timezone.git#0.4.1

bower moment#>= 2.6.0 not-cached https://github.com/moment/moment.git#>= 2.6.0

bower moment#>= 2.6.0 resolve https://github.com/moment/moment.git#>= 2.6.0

bower moment#>= 2.6.0 checkout 2.17.1

bower ng-dialog#^0.6.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .css files: ["css/ngDialog.css","css/ngDialog-theme-default.css"]

bower angular-dragula#^1.2.8 resolved https://github.com/bevacqua/angular-dragula.git#1.2.8

bower mocha#~1.14.0 mismatch Version declared in the json (1.12.0) is different than the resolved one (1.14.0)

bower mocha#~1.14.0 resolved https://github.com/mochajs/mocha.git#1.14.0

bower chai#~1.9.0 resolved https://github.com/chaijs/chai.git#1.9.2

bower ng-dialog#^0.6.2 resolved https://github.com/likeastore/ngDialog.git#0.6.6

bower bourbon#~4.2.1 resolved https://github.com/thoughtbot/bourbon.git#4.2.7

bower moment#~2.10.6 resolved https://github.com/moment/moment.git#2.10.6

bower angular-mocks#~1.5.8 resolved https://github.com/angular/bower-angular-mocks.git#1.5.11

bower jquery-mockjax#~1.5.3 resolved https://github.com/jakerella/jquery-mockjax.git#1.5.4

bower Caret.js#>= 0.2.0 checkout v0.3.1

bower angular#^1.3.0 resolved https://github.com/angular/bower-angular.git#1.6.2

bower angular-ui-router#~0.2.12 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.2.18

bower angular#>= 1.2.5 resolved https://github.com/angular/bower-angular.git#1.6.2

bower fastclick#~1.0.3 checkout v1.0.6

bower viewport-units-buggyfill#~0.4.1 checkout v0.4.1

bower tether#~0.6.5 checkout v0.6.5

bower angular-animate#~1.3.4 resolved https://github.com/angular/bower-angular-animate.git#1.3.20

bower hammerjs#~2.0.4 checkout v2.0.8

bower Caret.js#>= 0.2.0 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower rxjs#^4.1.0 resolved https://github.com/Reactive-Extensions/RxJS.git#4.1.0

bower angular#~1.3.4 resolved https://github.com/angular/bower-angular.git#1.3.20

bower fastclick#~1.0.3 resolved https://github.com/ftlabs/fastclick.git#1.0.6

bower Caret.js#>= 0.2.0 resolved https://github.com/ichord/Caret.js.git#0.3.1

bower angular-i18n#~1.5.5 resolved https://github.com/angular/bower-angular-i18n.git#1.5.11

bower viewport-units-buggyfill#~0.4.1 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .js files: ["./viewport-units-buggyfill.js","./viewport-units-buggyfill.hacks.js"]

bower viewport-units-buggyfill#~0.4.1 resolved https://github.com/rodneyrehm/viewport-units-buggyfill.git#0.4.1

bower hammerjs#~2.0.4 resolved https://github.com/EightMedia/hammer.js.git#2.0.8

bower tether#~0.6.5 resolved https://github.com/HubSpot/tether.git#0.6.5

bower moment#>= 2.6.0 resolved https://github.com/moment/moment.git#2.17.1

Please note that,

angular-animate#1.3.20 depends on angular#1.3.20 which resolved to angular#1.3.20

foundation-apps#1.1.0 depends on angular#~1.3.4 which resolved to angular#1.3.20

angular-animate#1.5.11, angular-aria#1.5.11, angular-mocks#1.5.11, angular-sanitize#1.5.11 depends on angular#1.5.11 which resolved to angular#1.5.11

angular-ui-router#0.3.2, angular-ui-router#0.2.18 depends on angular#^1.0.8 which resolved to angular#1.5.11

angular-cache#4.6.0 depends on angular#>=1.x which resolved to angular#1.5.11

angular-busy#4.1.4 depends on angular#>=1.3 which resolved to angular#1.5.11

ng-dialog#0.6.6 depends on angular#>=1.5 which resolved to angular#1.5.11

openproject depends on angular#~1.5.8 which resolved to angular#1.5.11

angular-elastic#2.5.1 depends on angular#>=1.0.6 which resolved to angular#1.5.11

angular-ui-select#0.19.6 depends on angular#>=1.2.18 which resolved to angular#1.5.11

angular-context-menu#a908eccaec depends on angular#>= 1.2.5 which resolved to angular#1.6.2

angular-modal#d45eb9ceb7 depends on angular#^1.3.0 which resolved to angular#1.6.2

Resort to using angular#~1.5.8 which resolved to angular#1.5.11

Code incompatibilities may occur.

Please note that,

foundation-apps#1.1.0 depends on angular-ui-router#~0.2.12 which resolved to angular-ui-router#0.2.18

openproject depends on angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Resort to using angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Code incompatibilities may occur.

Please note that,

foundation-apps#1.1.0 depends on angular-animate#~1.3.4 which resolved to angular-animate#1.3.20

openproject depends on angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

angular-busy#4.1.4 depends on angular-animate#>=1.3 which resolved to angular-animate#1.5.11

Resort to using angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

Code incompatibilities may occur.

bower jquery extra-resolution Unnecessary resolution: jquery#1.11.0

bower jquery-ui#~1.10.4 install jquery-ui#1.10.4

bower select2#3.5.2 install select2#3.5.2

bower jquery-ujs#1.0.0 install jquery-ujs#1.0.0

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 install angular-context-menu#a908eccaec

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 install angular-modal#d45eb9ceb7

bower angular-aria#~1.5.8 install angular-aria#1.5.11

bower angular#1.5.11 install angular#1.5.11

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de install angular-truncate#fdf60fda26

bower angular-elastic#~2.5.1 install angular-elastic#2.5.1

bower angular-ui-router#~0.3.1 install angular-ui-router#0.3.2

bower angular-animate#~1.5.8 install angular-animate#1.5.11

bower jquery.atwho#0.5.1 install jquery.atwho#0.5.1

bower jquery#1.11.0 install jquery#1.11.0

bower jquery-migrate#~1.2.1 install jquery-migrate#1.2.1

bower angular-cache#~4.6.0 install angular-cache#4.6.0

bower angular-sanitize#~1.5.8 install angular-sanitize#1.5.11

bower angular-busy#~4.1.3 install angular-busy#4.1.4

bower lodash#~2.4.1 install lodash#2.4.2

bower foundation-apps#1.1.0 install foundation-apps#1.1.0

bower mousetrap#~1.4.6 install mousetrap#1.4.6

bower ng-file-upload#~5.0.9 install ng-file-upload#5.0.9

bower angular-ui-select#~0.19.4 install angular-ui-select#0.19.6

bower moment-timezone#0.4.x install moment-timezone#0.4.1

bower angular-dragula#^1.2.8 install angular-dragula#1.2.8

bower mocha#~1.14.0 install mocha#1.14.0

bower chai#~1.9.0 install chai#1.9.2

bower ng-dialog#^0.6.2 install ng-dialog#0.6.6

bower bourbon#~4.2.1 install bourbon#4.2.7

bower moment#~2.10.6 install moment#2.10.6

bower angular-mocks#~1.5.8 install angular-mocks#1.5.11

bower jquery-mockjax#~1.5.3 install jquery-mockjax#1.5.4

bower rxjs#^4.1.0 install rxjs#4.1.0

bower fastclick#~1.0.3 install fastclick#1.0.6

bower Caret.js#>= 0.2.0 install Caret.js#0.3.1

bower angular-i18n#~1.5.5 install angular-i18n#1.5.11

bower viewport-units-buggyfill#~0.4.1 install viewport-units-buggyfill#0.4.1

bower hammerjs#~2.0.4 install hammerjs#2.0.8

bower tether#~0.6.5 install tether#0.6.5

jquery-ui#1.10.4 bower_components/jquery-ui

└── jquery#1.11.0

select2#3.5.2 bower_components/select2

└── jquery#1.11.0

jquery-ujs#1.0.0 bower_components/jquery-ujs

└── jquery#1.11.0

angular-context-menu#a908eccaec bower_components/angular-context-menu

└── angular#1.5.11

angular-modal#d45eb9ceb7 bower_components/angular-modal

└── angular#1.5.11

angular-aria#1.5.11 bower_components/angular-aria

└── angular#1.5.11

angular#1.5.11 bower_components/angular

angular-truncate#fdf60fda26 bower_components/angular-truncate

angular-elastic#2.5.1 bower_components/angular-elastic

└── angular#1.5.11

angular-ui-router#0.3.2 bower_components/angular-ui-router

└── angular#1.5.11

angular-animate#1.5.11 bower_components/angular-animate

└── angular#1.5.11

jquery.atwho#0.5.1 bower_components/jquery.atwho

├── Caret.js#0.3.1

└── jquery#1.11.0

jquery#1.11.0 bower_components/jquery

jquery-migrate#1.2.1 bower_components/jquery-migrate

angular-cache#4.6.0 bower_components/angular-cache

└── angular#1.5.11

angular-sanitize#1.5.11 bower_components/angular-sanitize

└── angular#1.5.11

angular-busy#4.1.4 bower_components/angular-busy

├── angular#1.5.11

└── angular-animate#1.5.11

lodash#2.4.2 bower_components/lodash

foundation-apps#1.1.0 bower_components/foundation-apps

├── angular#1.5.11

├── angular-animate#1.5.11

├── angular-ui-router#0.3.2

├── fastclick#1.0.6

├── hammerjs#2.0.8

├── tether#0.6.5

└── viewport-units-buggyfill#0.4.1

mousetrap#1.4.6 bower_components/mousetrap

ng-file-upload#5.0.9 bower_components/ng-file-upload

angular-ui-select#0.19.6 bower_components/angular-ui-select

└── angular#1.5.11

moment-timezone#0.4.1 bower_components/moment-timezone

└── moment#2.10.6

angular-dragula#1.2.8 bower_components/angular-dragula

mocha#1.14.0 bower_components/mocha

chai#1.9.2 bower_components/chai

ng-dialog#0.6.6 bower_components/ng-dialog

└── angular#1.5.11

bourbon#4.2.7 bower_components/bourbon

moment#2.10.6 bower_components/moment

angular-mocks#1.5.11 bower_components/angular-mocks

└── angular#1.5.11

jquery-mockjax#1.5.4 bower_components/jquery-mockjax

rxjs#4.1.0 bower_components/rxjs

fastclick#1.0.6 bower_components/fastclick

Caret.js#0.3.1 bower_components/Caret.js

└── jquery#1.11.0

angular-i18n#1.5.11 bower_components/angular-i18n

viewport-units-buggyfill#0.4.1 bower_components/viewport-units-buggyfill

hammerjs#2.0.8 bower_components/hammerjs

tether#0.6.5 bower_components/tether

openproject-frontend@0.1.0 /tmp/d20170210-17-1jd6p5j/opt/openproject/frontend

+-- acorn@2.6.4

+-- align-text@0.1.4

+-- alter@0.2.0

+-- amdefine@1.0.0

+-- angular@1.5.8

+-- angular-elastic@2.5.1

+-- angular-ui-bootstrap@2.2.0

+-- anymatch@1.3.0

+-- arr-diff@2.0.0

+-- arr-flatten@1.0.1

+-- array-unique@0.2.1

+-- arrify@1.0.1

+-- assert@1.4.1

+-- async@0.2.10

+-- async-each@1.0.1

+-- atoa@1.0.0

+-- autoprefixer-core@5.2.1

+-- autoprefixer-loader@1.2.0

+-- awesome-typescript-loader@2.2.4

| `-- lodash@4.16.4

+-- balanced-match@0.4.2

+-- Base64@0.2.1

+-- base64-js@1.2.0

+-- big.js@3.1.3

+-- binary-extensions@1.7.0

+-- bower@1.7.9

+-- brace-expansion@1.1.6

+-- braces@1.8.5

+-- browserify-zlib@0.1.4

+-- browserslist@0.4.0

+-- buffer@4.9.1

+-- buffer-shims@1.0.0

+-- camelcase@1.2.1

+-- caniuse-db@1.0.30000569

+-- center-align@0.1.3

+-- chokidar@1.6.1

+-- cliui@2.1.0

| `-- wordwrap@0.0.2

+-- clone@1.0.2

+-- colors@1.1.2

+-- concat-map@0.0.1

+-- console-browserify@1.1.0

+-- constants-browserify@0.0.1

+-- contra@1.9.4

+-- convert-source-map@1.1.3

+-- core-util-is@1.0.2

+-- crossvent@1.5.4

+-- crypto-browserify@3.2.8

+-- css-loader@0.9.1

| `-- source-map@0.1.43

+-- csso@1.3.12

+-- custom-event@1.0.0

+-- d@0.1.1

+-- date-now@0.1.4

+-- decamelize@1.2.0

+-- domain-browser@1.1.7

+-- dragula@3.7.2

+-- emojis-list@2.1.0

+-- enhanced-resolve@2.3.0

+-- errno@0.1.4

+-- es5-ext@0.10.12

+-- es6-iterator@2.0.0

+-- es6-promise@2.3.0

+-- es6-symbol@3.1.0

+-- es6-weak-map@0.1.4

| +-- es6-iterator@0.1.3

| `-- es6-symbol@2.0.1

+-- event-emitter@0.3.4

+-- events@1.1.1

+-- expand-brackets@0.1.5

+-- expand-range@1.8.2

+-- exports-loader@0.6.3

| `-- source-map@0.1.43

+-- expose-loader@0.6.0

+-- extglob@0.3.2

+-- extract-text-webpack-plugin@0.3.8

| `-- source-map@0.1.43

+-- fastparse@1.1.1

+-- file-loader@0.8.5

+-- filename-regex@2.0.0

+-- fill-range@2.2.3

+-- for-in@0.1.6

+-- for-own@0.1.4

+-- glob@4.5.3

+-- glob-base@0.3.0

+-- glob-parent@2.0.0

+-- graceful-fs@4.1.9

+-- has-flag@1.0.0

+-- html-loader@0.2.3

| `-- source-map@0.1.43

+-- html-minifier@0.5.6

+-- http-browserify@1.7.0

+-- https-browserify@0.0.0

+-- ieee754@1.1.8

+-- indexof@0.0.1

+-- inflight@1.0.6

+-- inherits@2.0.3

+-- interpret@0.6.6

+-- is-binary-path@1.0.1

+-- is-buffer@1.1.4

+-- is-dotfile@1.0.2

+-- is-equal-shallow@0.1.3

+-- is-extendable@0.1.1

+-- is-extglob@1.0.0

+-- is-glob@2.0.1

+-- is-number@2.1.0

+-- is-posix-bracket@0.1.1

+-- is-primitive@2.0.0

+-- isarray@1.0.0

+-- isobject@2.1.0

+-- js-base64@2.1.9

+-- json5@0.4.0

+-- kind-of@3.0.4

+-- lazy-cache@1.0.4

+-- loader-utils@0.2.16

| `-- json5@0.5.0

+-- lodash@2.4.2

+-- longest@1.0.1

+-- lru-queue@0.1.0

+-- memoizee@0.3.10

+-- memory-fs@0.3.0

+-- micromatch@2.3.11

+-- mime@1.2.11

+-- minimatch@2.0.10

+-- minimist@0.0.10

+-- mkdirp@0.5.1

| `-- minimist@0.0.8

+-- nan@2.4.0

+-- next-tick@0.2.2

+-- ng-annotate@1.2.1

| `-- source-map@0.5.6

+-- ng-annotate-loader@0.0.10

| `-- source-map@0.4.2

+-- ngtemplate-loader@0.1.3

+-- node-libs-browser@0.6.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- normalize-path@2.0.1

+-- num2fraction@1.2.2

+-- object-assign@4.1.0

+-- object.omit@2.0.1

+-- observable-array@0.0.4

+-- observable-value@0.0.5

+-- once@1.4.0

+-- optimist@0.6.1

+-- ordered-ast-traverse@1.1.1

+-- ordered-esprima-props@1.1.0

+-- os-browserify@0.1.2

+-- pako@0.2.9

+-- parse-glob@3.0.4

+-- path-browserify@0.0.0

+-- path-is-absolute@1.0.1

+-- pbkdf2-compat@2.0.1

+-- phantomjs-polyfill@0.0.2

+-- postcss@4.1.16

+-- preserve@0.2.0

+-- process@0.11.9

+-- process-nextick-args@1.0.7

+-- prr@0.0.0

+-- punycode@1.4.1

+-- querystring@0.2.0

+-- querystring-es3@0.2.1

+-- randomatic@1.1.5

+-- readable-stream@2.1.5

+-- readdirp@2.1.0

| `-- minimatch@3.0.3

+-- regex-cache@0.4.3

+-- repeat-element@1.1.2

+-- repeat-string@1.6.1

+-- right-align@0.1.3

+-- ripemd160@0.2.0

+-- set-immediate-shim@1.0.1

+-- sha.js@2.2.6

+-- shelljs@0.3.0

+-- simple-fmt@0.1.0

+-- simple-is@0.2.0

+-- source-list-map@0.1.6

+-- source-map@0.4.4

+-- source-map-support@0.4.5

| `-- source-map@0.5.6

+-- stable@0.1.5

+-- stream-browserify@1.0.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- string_decoder@0.10.31

+-- stringmap@0.2.2

+-- stringset@0.2.1

+-- style-loader@0.8.3

+-- supports-color@3.1.2

+-- tapable@0.2.4

+-- ticky@1.0.1

+-- timers-browserify@1.4.2

+-- timers-ext@0.1.0

+-- tryor@0.1.2

+-- tty-browserify@0.0.0

+-- typescript@2.0.6

+-- uglify-js@2.7.4

| `-- source-map@0.5.6

+-- uglify-to-browserify@1.0.2

+-- URIjs@1.16.1

+-- url@0.10.3

| `-- punycode@1.3.2

+-- url-loader@0.5.7

+-- util@0.10.3

| `-- inherits@2.0.1

+-- util-deprecate@1.0.2

+-- vm-browserify@0.0.4

+-- watchpack@0.2.9

| `-- async@0.9.2

+-- webpack@1.13.3

| +-- acorn@3.3.0

| +-- async@1.5.2

| +-- enhanced-resolve@0.9.1

| | `-- memory-fs@0.2.0

| `-- tapable@0.1.10

+-- webpack-core@0.6.8

+-- window-size@0.1.0

+-- wordwrap@0.0.3

+-- wrappy@1.0.2

`-- yargs@3.10.0

npm WARN openproject-frontend@0.1.0 No repository field.

npm WARN openproject-frontend@0.1.0 No license field.

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.0.14 (node_modules/fsevents):

npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.0.14: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

-----> Checking startup method

Found Procfile

-----> Finalizing build

Creating runtime environment

Exporting binary paths

Cleaning npm artifacts

Cleaning previous cache

Caching results for future builds

-----> Build succeeded!

openproject@0.1.0 /tmp/d20170210-17-1jd6p5j/opt/openproject

`-- typescript@2.0.8

=====> Downloading Buildpack: https://github.com/pkgr/heroku-buildpack-ruby.git

=====> Detected Framework: Ruby

-----> Compiling Ruby/Rails

-----> Using Ruby version: ruby-2.3.1

-----> Installing dependencies using bundler 1.13.2

cp: '/tmp/d20170210-17-1jd6p5j/opt/openproject/.git/cache/vendor/bundle/.' and '/tmp/d20170210-17-1jd6p5j/opt/openproject/.git/cache/vendor/bundle/.' are the same file

Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Fetching gem metadata from https://rubygems.org/......

Fetching version metadata from https://rubygems.org/..

Fetching dependency metadata from https://rubygems.org/.

Using rake 11.3.0

Using concurrent-ruby 1.0.2

Using i18n 0.7.0

Using minitest 5.9.0

Using thread_safe 0.3.5

Using builder 3.2.2

Using erubis 2.7.0

Using mini_portile2 2.1.0

Using pkg-config 1.1.7

Using rack 2.0.1

Using nio4r 1.2.1

Using websocket-extensions 0.1.2

Using mime-types 2.99.3

Using method_source 0.8.2

Using thor 0.19.1

Using arel 7.1.2

Using multi_json 1.12.1

Using acts_as_silent_list 3.0.0

Using addressable 2.4.0

Using airbrake-ruby 1.5.0

Using attr_required 1.0.1

Using execjs 2.7.0

Using ice_nine 0.11.2

Using bcrypt 3.1.11

Using bindata 2.3.4

Using sass 3.4.22

Using tilt 2.0.5

Using uber 0.0.15

Using erbse 0.0.2

Using coderay 1.1.1

Using color-tools 1.3.0

Using unf_ext 0.0.7.2

Using netrc 0.11.0

Using daemons 1.2.4

Using dalli 2.7.6

Using enumerable-lazy 0.0.1

Using equalizer 0.0.11

Using excon 0.52.0

Using ffi 1.9.14

Using formatador 0.2.5

Using ipaddress 0.8.3

Using get_process_mem 0.2.1

Using request_store 1.3.1

Using json 1.8.3

Using hashie 3.4.6

Using multi_xml 0.5.5

Using gravatar_image_tag 1.2.0

Using bundler 1.13.2

Using htmldiff 0.0.1

Using httpclient 2.8.2.4

Using icalendar 2.3.0

Using iso8601 0.9.1

Using securecompare 1.0.0

Using url_safe_base64 0.2.2

Using kgio 2.10.0

Using mixlib-shellout 2.1.0

Using mysql2 0.4.4

Using net-ldap 0.14.0

Using newrelic_rpm 3.16.2.321

Using oj 2.17.4

Using pdf-core 0.6.1

Using ttfunk 1.4.0

Using rmagick 2.15.4

Using rubyzip 1.2.0

Using ruby-ole 1.2.12

Using pg 0.19.0

Using rails_serve_static_assets 0.0.5

Using rails_stdout_logging 0.0.5

Using raindrops 0.17.0

Using ruby-progressbar 1.8.1

Using structured_warnings 0.2.0

Using sqlite3 1.3.11

Using stringex 2.6.1

Using svg-graph 2.0.1

Using syck 1.0.5

Using will_paginate 3.1.3

Using i18n-js 3.0.0.rc14

Using tzinfo 1.2.2

Using descendants_tracker 0.0.4

Using nokogiri 1.6.8

Using websocket-driver 0.6.4

Using rack-test 0.6.3

Using rack-accept 0.4.5

Using sprockets 3.7.0

Using passenger 5.0.30

Using rack-attack 5.0.1

Using rack-protection 2.0.0.beta2

Using warden 1.2.6

Using mail 2.6.4

Using airbrake 5.1.0

Using autoprefixer-rails 6.4.1.1

Using cells 4.1.3

Using unf 0.1.4

Using bourbon 4.2.7

Using mustermann19 0.4.4

Using sys-filesystem 1.1.7

Using fog-core 1.42.0

Using rdoc 4.2.2

Using omniauth 1.3.1 from https://github.com/oliverguenther/omniauth (at 8385bc0@8385bc0)

Using prawn 2.1.0

Using spreadsheet 0.8.9

Using rails_12factor 0.0.3

Using rubytree 0.9.7

Using unicorn 5.1.0

Using activesupport 5.0.0.1

Using tzinfo-data 1.2016.6

Using axiom-types 0.1.1

Using coercible 1.0.0

Using loofah 2.0.3

Using representable 2.1.8

Using ruby-saml 1.4.0

Using warden-basic_auth 0.2.1

Using cells-erb 0.0.8

Using domain_name 0.5.20161129

Using fog-json 1.0.2

Using fog-xml 0.1.2

Using prawn-table 0.2.2

Using rails-dom-testing 2.0.1

Using globalid 0.3.7

Using activemodel 5.0.0.1

Using climate_control 0.0.3

Using delayed_job 4.1.2

Using json-jwt 1.6.5

Using rack-oauth2 1.4.0

Using swd 1.0.1

Using webfinger 1.0.2

Using rabl 0.13.0

Using ruby-duration 3.2.3

Using virtus 1.0.5

Using disposable 0.0.9

Using roar 1.0.4

Using rails-html-sanitizer 1.0.3

Using omniauth-saml 1.6.0 from git://github.com/omniauth/omniauth-saml.git (at master@5559d6b)

Using unicorn-worker-killer 0.4.4

Using http-cookie 1.0.3

Using fog-aws 0.11.0

Using activerecord 5.0.0.1

Using carrierwave 1.0.0.beta from https://github.com/carrierwaveuploader/carrierwave (at master@5367a63)

Using date_validator 0.9.0

Using validate_email 0.1.6

Using validate_url 1.0.2

Using cocaine 0.5.8

Using activejob 5.0.0.1

Using grape 0.17.0

Using reform 1.2.6

Using actionview 5.0.0.1

Using openproject-auth_saml 0.1.0 from https://github.com/finnlabs/openproject-auth_saml (at dev@97212ab)

Using rest-client 1.8.0

Using activemodel-serializers-xml 1.0.1

Using acts_as_list 0.8.1

Using acts_as_tree 2.5.1

Using awesome_nested_set 3.1.1

Using delayed_job_active_record 4.1.1

Using friendly_id 5.2.0.beta.1 from https://github.com/norman/friendly_id (at aff0564@aff0564)

Using globalize 5.1.0 from https://github.com/globalize/globalize (at 38443bc@38443bc)

Using transactional_lock 0.1.0 from https://github.com/finnlabs/transactional_lock.git (at master@6948b1d)

Using openid_connect 0.8.3

Using grape-cache_control 1.0.1

Using actionpack 5.0.0.1

Using crowdin-api 0.4.1

Using omniauth-openid-connect 0.2.0 from https://github.com/finnlabs/omniauth-openid-connect.git (at dev@c3bce4c)

Using actioncable 5.0.0.1

Using actionmailer 5.0.0.1

Using railties 5.0.0.1

Using cells-rails 0.0.6

Using gon 4.1.1

Using sprockets-rails 3.2.0

Using omniauth-openid_connect-providers 0.1.0 from https://github.com/finnlabs/omniauth-openid_connect-providers.git (at dev@86f3670)

Using actionpack-xml_parser 2.0.0

Using activerecord-session_store 1.0.0

Using jquery-tablesorter 1.22.7

Using responders 2.3.0

Using rails 5.0.0.1

Using sass-rails 5.0.6

Using health_check 2.2.1

Using lobby_boy 0.1.2

Using openproject-auth_plugins 6.1.4 from source at `vendored-plugins/openproject-auth_plugins`

Using openproject-pdf_export 6.1.4 from source at `vendored-plugins/openproject-pdf_export`

Using openproject-costs 6.1.4 from source at `vendored-plugins/openproject-costs`

Using openproject-documents 6.1.4 from source at `vendored-plugins/openproject-documents`

Using openproject-webhooks 6.1.4 from source at `vendored-plugins/openproject-webhooks`

Using openproject-global_roles 6.1.4 from source at `vendored-plugins/openproject-global_roles`

Using openproject-local_avatars 6.1.4 from source at `vendored-plugins/openproject-local_avatars`

Using openproject-meeting 6.1.4 from source at `vendored-plugins/openproject-meeting`

Using openproject-my_project_page 6.1.4 from source at `vendored-plugins/openproject-my_project_page`

Using reporting_engine 6.1.4 from source at `vendored-plugins/reporting_engine`

Using openproject-themes-dark 6.1.4 from source at `vendored-plugins/openproject-themes-dark`

Using openproject-translations 6.1.4 from https://github.com/opf/openproject-translations.git (at stable/6@da52ff9)

Using openproject-xls_export 6.1.4 from source at `vendored-plugins/openproject-xls_export`

Using rails-angular-xss 0.3.0.pre.pre from https://github.com/opf/rails-angular-xss (at a45267d@a45267d)

Using rails_autolink 1.1.6

Using openproject-openid_connect 6.1.4 from source at `vendored-plugins/openproject-openid_connect`

Using openproject-backlogs 6.1.4 from source at `vendored-plugins/openproject-backlogs`

Using openproject-github_integration 6.1.4 from source at `vendored-plugins/openproject-github_integration`

Using openproject-reporting 6.1.4 from source at `vendored-plugins/openproject-reporting`

Bundle complete! 138 Gemfile dependencies, 195 gems now installed.

Gems in the groups development and test were not installed.

Bundled gems are installed into ./vendor/bundle.

Bundle completed (6.11s)

Cleaning up the bundler cache.

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

-----> Detecting rake tasks

-----> Preparing app for Rails asset pipeline

Running: rake assets:precompile

$(npm bin)/webpack --config webpack.production.config.js

{"omniauth-openid-connect":"/tmp/d20170210-17-1jd6p5j/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid-connect-c3bce4c9e9ac","omniauth-openid_connect-providers":"/tmp/d20170210-17-1jd6p5j/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid_connect-providers-86f3670e127e","omniauth-saml":"/tmp/d20170210-17-1jd6p5j/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-saml-5559d6b80805","openproject-auth_plugins":"/tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-auth_plugins","openproject-auth_saml":"/tmp/d20170210-17-1jd6p5j/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-auth_saml-97212abb8378","openproject-pdf_export":"/tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-pdf_export","openproject-backlogs":"/tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-backlogs","openproject-costs":"/tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-costs","openproject-documents":"/tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-documents","openproject-webhooks":"/tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-webhooks","openproject-github_integration":"/tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-github_integration","openproject-global_roles":"/tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-global_roles","openproject-local_avatars":"/tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-local_avatars","openproject-meeting":"/tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-meeting","openproject-my_project_page":"/tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-my_project_page","openproject-openid_connect":"/tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-openid_connect","reporting_engine":"/tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/reporting_engine","openproject-reporting":"/tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-reporting","openproject-themes-dark":"/tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-themes-dark","openproject-translations":"/tmp/d20170210-17-1jd6p5j/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-translations-da52ff92cdcd","openproject-xls_export":"/tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-xls_export"}

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Hash: f176f5645a882036669b

Version: webpack 1.13.3

Child

Hash: f176f5645a882036669b

Version: webpack 1.13.3

Time: 14948ms

Asset Size Chunks Chunk Names

7b9776076d5fceef4993b55c9383dedd.gif 1.85 kB [emitted]

openproject-backlogs.js 453 kB 0 [emitted] backlogs

openproject-core-app.js 3.43 MB 1 [emitted] core-app

openproject-costs.js 526 kB 2 [emitted] costs

openproject-global.js 3.51 MB 3 [emitted] global

openproject-my_project_page.js 14.3 kB 4 [emitted] my_project_page

openproject-core-app.css 4.71 kB 1 [emitted] core-app

openproject-global.css 49 kB 3 [emitted] global

[213] ./templates \.html$ 1.22 kB {1} [built]

[242] ./components ^((?!\.(test|spec)).)*\.(js|ts|html)$ 16.1 kB {1} [built]

[633] /tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 425 bytes {2} [built]

[765] /tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 330 bytes {4} [built]

+ 769 hidden modules

ERROR in [default]

File '/tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-budget-subform.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-1jd6p5j/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-1jd6p5j/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/subform/cost-subform.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-1jd6p5j/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts' is not under 'rootDir' '/tmp/d20170210-17-1jd6p5j/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts' is not under 'rootDir' '/tmp/d20170210-17-1jd6p5j/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-block.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-1jd6p5j/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-page-layout.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-1jd6p5j/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-textile-block.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-1jd6p5j/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default] /tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:49:18

Argument of type 'string' is not assignable to parameter of type '{ [key: string]: any; }'.

ERROR in [default] /tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:53:4

Supplied parameters do not match any signature of call target.

ERROR in [default] /tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:30:38

Cannot find module 'app/components/work-packages/work-package-cache.service'.

ERROR in [default] /tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:49:30

Cannot find name 'HalResource'.

ERROR in [default] /tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:54:57

Property '$injector' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:13

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:27

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:60:11

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:70:23

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:76:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:77:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:78:16

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:36:17

Property 'value' does not exist on type 'CurrencyDisplayField'.

ERROR in [default] /tmp/d20170210-17-1jd6p5j/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:37:23

Property 'value' does not exist on type 'CurrencyDisplayField'.

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 5 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

I, [2017-02-10T12:53:59.759542 #2367] INFO -- : Writing /tmp/d20170210-17-1jd6p5j/opt/openproject/public/assets/application-97f4fd3f475566c2d84ad83a0d3ad879eb4d50780ec3e907a5c5570a2c0e8cc9.js

I, [2017-02-10T12:53:59.760246 #2367] INFO -- : Writing /tmp/d20170210-17-1jd6p5j/opt/openproject/public/assets/application-97f4fd3f475566c2d84ad83a0d3ad879eb4d50780ec3e907a5c5570a2c0e8cc9.js.gz

Asset precompilation completed (30.96s)

Cleaning assets

Running: rake assets:clean

I, [2017-02-10T12:54:08.496169 #2539] INFO -- : Removed application-e47e20e07f3e90408326e8bae209856c544bd64b37167f34bbfb6d0928a793d8.js

Using release configuration from last framework (Ruby).

-----> [cron] /opt/openproject/packaging/cron/openproject-clear-old-sessions => /etc/cron.d/openproject-clear-old-sessions

-----> Verifying package openproject_6.1.4-1486730985.5bf684b.jessie_amd64.deb

NEW PACKAGE: openproject_6.1.4-1486730985.5bf684b.jessie_amd64.deb (286.18 MiB)

-----> Releasing...

DONE!

====== Attempt #1

-----> Fetching repository

Cloning into '/tmp/d20170210-16665-16lmc6k/input'...

-----> Restoring cache

-----> Starting packaging process

-----> Installing missing build dependencies: timezone

-----> [wizard] adding legacy-installer wizard (https://github.com/pkgr/addon-legacy-installer#master)

-----> [wizard] adding mysql wizard (https://github.com/pkgr/addon-mysql#master)

-----> [wizard] adding apache2 wizard (https://github.com/pkgr/addon-apache2#master)

-----> [wizard] adding repositories wizard (https://github.com/finnlabs/addon-repositories#master)

-----> [wizard] adding smtp wizard (https://github.com/pkgr/addon-smtp#master)

-----> [wizard] adding memcached wizard (https://github.com/pkgr/addon-memcached#master)

-----> [wizard] adding openproject wizard (https://github.com/pkgr/addon-openproject#master)

-----> Fetching buildpack https://github.com/opf/heroku-buildpack-multi.git at master

-----> Multipack app

-----> Running hook: "packaging/setup"

WARNING: This buildpack is no longer maintained.

Please choose a different buildpack or go to https://github.com/ddollar/heroku-buildpack-multi

and fork it to your own account.

=====> Downloading Buildpack: https://github.com/pkgr/pkgr-buildpack-imagemagick.git

=====> Detected Framework: ImageMagick

% Total % Received % Xferd Average Speed Time Time Time Current

Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0 19 10.0M 19 2022k 0 0 1817k 0 0:00:05 0:00:01 0:00:04 2080k 50 10.0M 50 5252k 0 0 2478k 0 0:00:04 0:00:02 0:00:02 2655k 95 10.0M 95 9807k 0 0 3137k 0 0:00:03 0:00:03 --:--:-- 3285k 100 10.0M 100 10.0M 0 0 3200k 0 0:00:03 0:00:03 --:--:-- 3348k

=====> Downloading Buildpack: https://github.com/heroku/heroku-buildpack-nodejs.git

=====> Detected Framework: Node.js

-----> Reading application state

package.json...

build directory...

cache directory...

environment variables...

Node engine: 6.9.1

Npm engine: 4.0.0

Start mechanism: Procfile

node_modules source: package.json

node_modules cached: true

NPM_CONFIG_PRODUCTION=true

NODE_MODULES_CACHE=true

-----> Installing binaries

Downloading and installing node 6.9.1...

Downloading and installing npm 4.0.0 (replacing version 3.10.8)...

-----> Building dependencies

Restoring node modules from cache

Pruning unused dependencies

Installing any new modules

> openproject@0.1.0 postinstall /tmp/d20170210-17-2qodh8/opt/openproject

> cd frontend && npm install

> openproject-frontend@0.1.0 postinstall /tmp/d20170210-17-2qodh8/opt/openproject/frontend

> bower install --config.interactive=false

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 not-cached git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolve git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de not-cached git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolve git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 not-cached git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolve git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 checkout d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower jquery#1.11.0 not-cached https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery#1.11.0 resolve https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery-ujs#1.0.0 not-cached https://github.com/rails/jquery-ujs.git#1.0.0

bower jquery-ujs#1.0.0 resolve https://github.com/rails/jquery-ujs.git#1.0.0

bower jquery-ui#~1.10.4 not-cached https://github.com/components/jqueryui.git#~1.10.4

bower jquery-ui#~1.10.4 resolve https://github.com/components/jqueryui.git#~1.10.4

bower select2#3.5.2 not-cached https://github.com/ivaynberg/select2.git#3.5.2

bower select2#3.5.2 resolve https://github.com/ivaynberg/select2.git#3.5.2

bower jquery.atwho#0.5.1 not-cached https://github.com/ichord/At.js.git#0.5.1

bower jquery.atwho#0.5.1 resolve https://github.com/ichord/At.js.git#0.5.1

bower angular-animate#~1.5.8 not-cached https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-animate#~1.5.8 resolve https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular#~1.5.8 not-cached https://github.com/angular/bower-angular.git#~1.5.8

bower angular#~1.5.8 resolve https://github.com/angular/bower-angular.git#~1.5.8

bower angular-aria#~1.5.8 not-cached https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-aria#~1.5.8 resolve https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-ui-router#~0.3.1 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-ui-router#~0.3.1 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-i18n#~1.5.5 not-cached https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-i18n#~1.5.5 resolve https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-cache#~4.6.0 not-cached https://github.com/jmdobry/angular-cache.git#~4.6.0

bower angular-cache#~4.6.0 resolve https://github.com/jmdobry/angular-cache.git#~4.6.0

bower jquery-migrate#~1.2.1 not-cached https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower jquery-migrate#~1.2.1 resolve https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower moment#~2.10.6 not-cached https://github.com/moment/moment.git#~2.10.6

bower moment#~2.10.6 resolve https://github.com/moment/moment.git#~2.10.6

bower moment-timezone#0.4.x not-cached https://github.com/moment/moment-timezone.git#0.4.x

bower moment-timezone#0.4.x resolve https://github.com/moment/moment-timezone.git#0.4.x

bower angular-elastic#~2.5.1 not-cached https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-elastic#~2.5.1 resolve https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-busy#~4.1.3 not-cached https://github.com/cgross/angular-busy.git#~4.1.3

bower angular-busy#~4.1.3 resolve https://github.com/cgross/angular-busy.git#~4.1.3

bower lodash#~2.4.1 not-cached https://github.com/lodash/lodash.git#~2.4.1

bower lodash#~2.4.1 resolve https://github.com/lodash/lodash.git#~2.4.1

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de checkout fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 checkout a908eccaec323cd66973d58af4965694bdff16a1

bower foundation-apps#1.1.0 not-cached https://github.com/zurb/foundation-apps.git#1.1.0

bower foundation-apps#1.1.0 resolve https://github.com/zurb/foundation-apps.git#1.1.0

bower bourbon#~4.2.1 not-cached https://github.com/thoughtbot/bourbon.git#~4.2.1

bower bourbon#~4.2.1 resolve https://github.com/thoughtbot/bourbon.git#~4.2.1

bower angular-ui-select#~0.19.4 not-cached https://github.com/angular-ui/ui-select.git#~0.19.4

bower angular-ui-select#~0.19.4 resolve https://github.com/angular-ui/ui-select.git#~0.19.4

bower mousetrap#~1.4.6 not-cached https://github.com/ccampbell/mousetrap.git#~1.4.6

bower mousetrap#~1.4.6 resolve https://github.com/ccampbell/mousetrap.git#~1.4.6

bower ng-file-upload#~5.0.9 not-cached https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower ng-file-upload#~5.0.9 resolve https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower rxjs#^4.1.0 not-cached https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower rxjs#^4.1.0 resolve https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower ng-dialog#^0.6.2 not-cached https://github.com/likeastore/ngDialog.git#^0.6.2

bower ng-dialog#^0.6.2 resolve https://github.com/likeastore/ngDialog.git#^0.6.2

bower angular-dragula#^1.2.8 not-cached https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower angular-dragula#^1.2.8 resolve https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower mocha#~1.14.0 not-cached https://github.com/mochajs/mocha.git#~1.14.0

bower mocha#~1.14.0 resolve https://github.com/mochajs/mocha.git#~1.14.0

bower angular-mocks#~1.5.8 not-cached https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower angular-mocks#~1.5.8 resolve https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower chai#~1.9.0 not-cached https://github.com/chaijs/chai.git#~1.9.0

bower chai#~1.9.0 resolve https://github.com/chaijs/chai.git#~1.9.0

bower jquery-ujs#1.0.0 checkout v1.0.0

bower jquery#1.11.0 checkout 1.11.0

bower jquery.atwho#0.5.1 checkout v0.5.1

bower select2#3.5.2 checkout 3.5.2

bower angular-animate#~1.5.8 checkout v1.5.11

bower angular-aria#~1.5.8 checkout v1.5.11

bower jquery-ui#~1.10.4 checkout 1.10.4

bower angular#~1.5.8 checkout v1.5.11

bower jquery-migrate#~1.2.1 checkout 1.2.1

bower angular-cache#~4.6.0 checkout 4.6.0

bower angular-ui-router#~0.3.1 checkout 0.3.2

bower angular-i18n#~1.5.5 checkout v1.5.11

bower angular-busy#~4.1.3 checkout v4.1.4

bower moment#~2.10.6 checkout 2.10.6

bower moment-timezone#0.4.x checkout 0.4.1

bower angular-elastic#~2.5.1 checkout v2.5.1

bower foundation-apps#1.1.0 checkout v1.1.0

bower bourbon#~4.2.1 checkout v4.2.7

bower angular-ui-select#~0.19.4 checkout v0.19.6

bower lodash#~2.4.1 checkout 2.4.2

bower mousetrap#~1.4.6 checkout 1.4.6

bower ng-file-upload#~5.0.9 checkout 5.0.9

bower ng-dialog#^0.6.2 checkout v0.6.6

bower rxjs#^4.1.0 checkout v4.1.0

bower angular-dragula#^1.2.8 checkout v1.2.8

bower mocha#~1.14.0 checkout 1.14.0

bower chai#~1.9.0 checkout 1.9.2

bower angular-mocks#~1.5.8 checkout v1.5.11

bower angular-sanitize#~1.5.8 not-cached https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-sanitize#~1.5.8 resolve https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .png files: ["select2.png","select2x2.png"]

bower jquery.atwho#0.5.1 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower select2#3.5.2 resolved https://github.com/ivaynberg/select2.git#3.5.2

bower jquery-ujs#1.0.0 resolved https://github.com/rails/jquery-ujs.git#1.0.0

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolved git://github.com/nickmessing/angular-context-menu.git#a908eccaec

bower angular#>= 1.2.5 not-cached https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 resolve https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 checkout v1.6.2

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolved git://github.com/finnlabs/angular-modal.git#d45eb9ceb7

bower angular#^1.3.0 not-cached https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 resolve https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 checkout v1.6.2

bower angular-aria#~1.5.8 resolved https://github.com/angular/bower-angular-aria.git#1.5.11

bower jquery-mockjax#~1.5.3 not-cached https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery-mockjax#~1.5.3 resolve https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower angular-animate#~1.5.8 resolved https://github.com/angular/bower-angular-animate.git#1.5.11

bower jquery.atwho#0.5.1 resolved https://github.com/ichord/At.js.git#0.5.1

bower jquery#1.11.0 resolved https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery-migrate#~1.2.1 deprecated Package jquery-migrate is using the deprecated component.json

bower jquery-migrate#~1.2.1 resolved https://github.com/appleboy/jquery-migrate.git#1.2.1

bower Caret.js#>= 0.2.0 not-cached https://github.com/ichord/Caret.js.git#>= 0.2.0

bower Caret.js#>= 0.2.0 resolve https://github.com/ichord/Caret.js.git#>= 0.2.0

bower jquery-ui#~1.10.4 resolved https://github.com/components/jqueryui.git#1.10.4

bower angular-cache#~4.6.0 resolved https://github.com/jmdobry/angular-cache.git#4.6.0

bower angular#>=1.x not-cached https://github.com/angular/bower-angular.git#>=1.x

bower angular#>=1.x resolve https://github.com/angular/bower-angular.git#>=1.x

bower angular#>=1.x checkout v1.6.2

bower angular#~1.5.8 resolved https://github.com/angular/bower-angular.git#1.5.11

bower angular-ui-router#~0.3.1 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.3.2

bower angular-busy#~4.1.3 resolved https://github.com/cgross/angular-busy.git#4.1.4

bower angular-elastic#~2.5.1 resolved https://github.com/monospaced/angular-elastic.git#2.5.1

bower moment#~2.10.6 resolved https://github.com/moment/moment.git#2.10.6

bower foundation-apps#1.1.0 resolved https://github.com/zurb/foundation-apps.git#1.1.0

bower angular#~1.3.4 not-cached https://github.com/angular/bower-angular.git#~1.3.4

bower angular#~1.3.4 resolve https://github.com/angular/bower-angular.git#~1.3.4

bower angular-ui-router#~0.2.12 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-ui-router#~0.2.12 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-animate#~1.3.4 not-cached https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular-animate#~1.3.4 resolve https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular#~1.3.4 checkout v1.3.20

bower angular-ui-router#~0.2.12 checkout 0.2.18

bower angular-animate#~1.3.4 checkout v1.3.20

bower ng-dialog#^0.6.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .css files: ["css/ngDialog.css","css/ngDialog-theme-default.css"]

bower viewport-units-buggyfill#~0.4.1 not-cached https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower viewport-units-buggyfill#~0.4.1 resolve https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower ng-file-upload#~5.0.9 resolved https://github.com/danialfarid/angular-file-upload-bower.git#5.0.9

bower mousetrap#~1.4.6 resolved https://github.com/ccampbell/mousetrap.git#1.4.6

bower tether#~0.6.5 not-cached https://github.com/HubSpot/tether.git#~0.6.5

bower tether#~0.6.5 resolve https://github.com/HubSpot/tether.git#~0.6.5

bower hammerjs#~2.0.4 not-cached https://github.com/EightMedia/hammer.js.git#~2.0.4

bower hammerjs#~2.0.4 resolve https://github.com/EightMedia/hammer.js.git#~2.0.4

bower fastclick#~1.0.3 not-cached https://github.com/ftlabs/fastclick.git#~1.0.3

bower fastclick#~1.0.3 resolve https://github.com/ftlabs/fastclick.git#~1.0.3

bower lodash#~2.4.1 resolved https://github.com/lodash/lodash.git#2.4.2

bower ng-dialog#^0.6.2 resolved https://github.com/likeastore/ngDialog.git#0.6.6

bower angular-ui-select#~0.19.4 resolved https://github.com/angular-ui/ui-select.git#0.19.6

bower moment-timezone#0.4.x resolved https://github.com/moment/moment-timezone.git#0.4.1

bower bourbon#~4.2.1 resolved https://github.com/thoughtbot/bourbon.git#4.2.7

bower angular-dragula#^1.2.8 resolved https://github.com/bevacqua/angular-dragula.git#1.2.8

bower angular-mocks#~1.5.8 resolved https://github.com/angular/bower-angular-mocks.git#1.5.11

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolved git://github.com/sparkalow/angular-truncate.git#fdf60fda26

bower chai#~1.9.0 resolved https://github.com/chaijs/chai.git#1.9.2

bower angular-sanitize#~1.5.8 checkout v1.5.11

bower Caret.js#>= 0.2.0 checkout v0.3.1

bower jquery-mockjax#~1.5.3 checkout v1.5.4

bower mocha#~1.14.0 mismatch Version declared in the json (1.12.0) is different than the resolved one (1.14.0)

bower mocha#~1.14.0 resolved https://github.com/mochajs/mocha.git#1.14.0

bower angular#^1.3.0 resolved https://github.com/angular/bower-angular.git#1.6.2

bower viewport-units-buggyfill#~0.4.1 checkout v0.4.1

bower angular#>= 1.2.5 resolved https://github.com/angular/bower-angular.git#1.6.2

bower angular-i18n#~1.5.5 resolved https://github.com/angular/bower-angular-i18n.git#1.5.11

bower tether#~0.6.5 checkout v0.6.5

bower hammerjs#~2.0.4 checkout v2.0.8

bower fastclick#~1.0.3 checkout v1.0.6

bower rxjs#^4.1.0 resolved https://github.com/Reactive-Extensions/RxJS.git#4.1.0

bower angular-animate#~1.3.4 resolved https://github.com/angular/bower-angular-animate.git#1.3.20

bower angular-ui-router#~0.2.12 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.2.18

bower angular#~1.3.4 resolved https://github.com/angular/bower-angular.git#1.3.20

bower angular#>=1.x resolved https://github.com/angular/bower-angular.git#1.6.2

bower Caret.js#>= 0.2.0 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower Caret.js#>= 0.2.0 resolved https://github.com/ichord/Caret.js.git#0.3.1

bower angular-sanitize#~1.5.8 resolved https://github.com/angular/bower-angular-sanitize.git#1.5.11

bower jquery-mockjax#~1.5.3 resolved https://github.com/jakerella/jquery-mockjax.git#1.5.4

bower viewport-units-buggyfill#~0.4.1 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .js files: ["./viewport-units-buggyfill.js","./viewport-units-buggyfill.hacks.js"]

bower viewport-units-buggyfill#~0.4.1 resolved https://github.com/rodneyrehm/viewport-units-buggyfill.git#0.4.1

bower tether#~0.6.5 resolved https://github.com/HubSpot/tether.git#0.6.5

bower fastclick#~1.0.3 resolved https://github.com/ftlabs/fastclick.git#1.0.6

bower hammerjs#~2.0.4 resolved https://github.com/EightMedia/hammer.js.git#2.0.8

Please note that,

foundation-apps#1.1.0 depends on angular-animate#~1.3.4 which resolved to angular-animate#1.3.20

openproject depends on angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

angular-busy#4.1.4 depends on angular-animate#>=1.3 which resolved to angular-animate#1.5.11

Resort to using angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

Code incompatibilities may occur.

Please note that,

angular-animate#1.3.20 depends on angular#1.3.20 which resolved to angular#1.3.20

foundation-apps#1.1.0 depends on angular#~1.3.4 which resolved to angular#1.3.20

angular-animate#1.5.11, angular-aria#1.5.11, angular-mocks#1.5.11, angular-sanitize#1.5.11 depends on angular#1.5.11 which resolved to angular#1.5.11

angular-ui-router#0.3.2, angular-ui-router#0.2.18 depends on angular#^1.0.8 which resolved to angular#1.5.11

angular-ui-select#0.19.6 depends on angular#>=1.2.18 which resolved to angular#1.5.11

angular-elastic#2.5.1 depends on angular#>=1.0.6 which resolved to angular#1.5.11

ng-dialog#0.6.6 depends on angular#>=1.5 which resolved to angular#1.5.11

openproject depends on angular#~1.5.8 which resolved to angular#1.5.11

angular-busy#4.1.4 depends on angular#>=1.3 which resolved to angular#1.5.11

angular-context-menu#a908eccaec depends on angular#>= 1.2.5 which resolved to angular#1.6.2

angular-cache#4.6.0 depends on angular#>=1.x which resolved to angular#1.6.2

angular-modal#d45eb9ceb7 depends on angular#^1.3.0 which resolved to angular#1.6.2

Resort to using angular#~1.5.8 which resolved to angular#1.5.11

Code incompatibilities may occur.

Please note that,

foundation-apps#1.1.0 depends on angular-ui-router#~0.2.12 which resolved to angular-ui-router#0.2.18

openproject depends on angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Resort to using angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Code incompatibilities may occur.

bower jquery extra-resolution Unnecessary resolution: jquery#1.11.0

bower select2#3.5.2 install select2#3.5.2

bower jquery-ujs#1.0.0 install jquery-ujs#1.0.0

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 install angular-context-menu#a908eccaec

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 install angular-modal#d45eb9ceb7

bower angular-aria#~1.5.8 install angular-aria#1.5.11

bower angular-animate#~1.5.8 install angular-animate#1.5.11

bower jquery.atwho#0.5.1 install jquery.atwho#0.5.1

bower jquery#1.11.0 install jquery#1.11.0

bower jquery-migrate#~1.2.1 install jquery-migrate#1.2.1

bower jquery-ui#~1.10.4 install jquery-ui#1.10.4

bower angular-cache#~4.6.0 install angular-cache#4.6.0

bower angular#1.5.11 install angular#1.5.11

bower angular-ui-router#~0.3.1 install angular-ui-router#0.3.2

bower angular-busy#~4.1.3 install angular-busy#4.1.4

bower angular-elastic#~2.5.1 install angular-elastic#2.5.1

bower moment#~2.10.6 install moment#2.10.6

bower foundation-apps#1.1.0 install foundation-apps#1.1.0

bower ng-file-upload#~5.0.9 install ng-file-upload#5.0.9

bower mousetrap#~1.4.6 install mousetrap#1.4.6

bower lodash#~2.4.1 install lodash#2.4.2

bower ng-dialog#^0.6.2 install ng-dialog#0.6.6

bower angular-ui-select#~0.19.4 install angular-ui-select#0.19.6

bower moment-timezone#0.4.x install moment-timezone#0.4.1

bower bourbon#~4.2.1 install bourbon#4.2.7

bower angular-dragula#^1.2.8 install angular-dragula#1.2.8

bower angular-mocks#~1.5.8 install angular-mocks#1.5.11

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de install angular-truncate#fdf60fda26

bower chai#~1.9.0 install chai#1.9.2

bower mocha#~1.14.0 install mocha#1.14.0

bower angular-i18n#~1.5.5 install angular-i18n#1.5.11

bower rxjs#^4.1.0 install rxjs#4.1.0

bower Caret.js#>= 0.2.0 install Caret.js#0.3.1

bower angular-sanitize#~1.5.8 install angular-sanitize#1.5.11

bower jquery-mockjax#~1.5.3 install jquery-mockjax#1.5.4

bower viewport-units-buggyfill#~0.4.1 install viewport-units-buggyfill#0.4.1

bower tether#~0.6.5 install tether#0.6.5

bower fastclick#~1.0.3 install fastclick#1.0.6

bower hammerjs#~2.0.4 install hammerjs#2.0.8

select2#3.5.2 bower_components/select2

└── jquery#1.11.0

jquery-ujs#1.0.0 bower_components/jquery-ujs

└── jquery#1.11.0

angular-context-menu#a908eccaec bower_components/angular-context-menu

└── angular#1.5.11

angular-modal#d45eb9ceb7 bower_components/angular-modal

└── angular#1.5.11

angular-aria#1.5.11 bower_components/angular-aria

└── angular#1.5.11

angular-animate#1.5.11 bower_components/angular-animate

└── angular#1.5.11

jquery.atwho#0.5.1 bower_components/jquery.atwho

├── Caret.js#0.3.1

└── jquery#1.11.0

jquery#1.11.0 bower_components/jquery

jquery-migrate#1.2.1 bower_components/jquery-migrate

jquery-ui#1.10.4 bower_components/jquery-ui

└── jquery#1.11.0

angular-cache#4.6.0 bower_components/angular-cache

└── angular#1.5.11

angular#1.5.11 bower_components/angular

angular-ui-router#0.3.2 bower_components/angular-ui-router

└── angular#1.5.11

angular-busy#4.1.4 bower_components/angular-busy

├── angular#1.5.11

└── angular-animate#1.5.11

angular-elastic#2.5.1 bower_components/angular-elastic

└── angular#1.5.11

moment#2.10.6 bower_components/moment

foundation-apps#1.1.0 bower_components/foundation-apps

├── angular#1.5.11

├── angular-animate#1.5.11

├── angular-ui-router#0.3.2

├── fastclick#1.0.6

├── hammerjs#2.0.8

├── tether#0.6.5

└── viewport-units-buggyfill#0.4.1

ng-file-upload#5.0.9 bower_components/ng-file-upload

mousetrap#1.4.6 bower_components/mousetrap

lodash#2.4.2 bower_components/lodash

ng-dialog#0.6.6 bower_components/ng-dialog

└── angular#1.5.11

angular-ui-select#0.19.6 bower_components/angular-ui-select

└── angular#1.5.11

moment-timezone#0.4.1 bower_components/moment-timezone

└── moment#2.10.6

bourbon#4.2.7 bower_components/bourbon

angular-dragula#1.2.8 bower_components/angular-dragula

angular-mocks#1.5.11 bower_components/angular-mocks

└── angular#1.5.11

angular-truncate#fdf60fda26 bower_components/angular-truncate

chai#1.9.2 bower_components/chai

mocha#1.14.0 bower_components/mocha

angular-i18n#1.5.11 bower_components/angular-i18n

rxjs#4.1.0 bower_components/rxjs

Caret.js#0.3.1 bower_components/Caret.js

└── jquery#1.11.0

angular-sanitize#1.5.11 bower_components/angular-sanitize

└── angular#1.5.11

jquery-mockjax#1.5.4 bower_components/jquery-mockjax

viewport-units-buggyfill#0.4.1 bower_components/viewport-units-buggyfill

tether#0.6.5 bower_components/tether

fastclick#1.0.6 bower_components/fastclick

hammerjs#2.0.8 bower_components/hammerjs

openproject-frontend@0.1.0 /tmp/d20170210-17-2qodh8/opt/openproject/frontend

+-- acorn@2.6.4

+-- align-text@0.1.4

+-- alter@0.2.0

+-- amdefine@1.0.0

+-- angular@1.5.8

+-- angular-elastic@2.5.1

+-- angular-ui-bootstrap@2.2.0

+-- anymatch@1.3.0

+-- arr-diff@2.0.0

+-- arr-flatten@1.0.1

+-- array-unique@0.2.1

+-- arrify@1.0.1

+-- assert@1.4.1

+-- async@0.2.10

+-- async-each@1.0.1

+-- atoa@1.0.0

+-- autoprefixer-core@5.2.1

+-- autoprefixer-loader@1.2.0

+-- awesome-typescript-loader@2.2.4

| `-- lodash@4.16.4

+-- balanced-match@0.4.2

+-- Base64@0.2.1

+-- base64-js@1.2.0

+-- big.js@3.1.3

+-- binary-extensions@1.7.0

+-- bower@1.7.9

+-- brace-expansion@1.1.6

+-- braces@1.8.5

+-- browserify-zlib@0.1.4

+-- browserslist@0.4.0

+-- buffer@4.9.1

+-- buffer-shims@1.0.0

+-- camelcase@1.2.1

+-- caniuse-db@1.0.30000569

+-- center-align@0.1.3

+-- chokidar@1.6.1

+-- cliui@2.1.0

| `-- wordwrap@0.0.2

+-- clone@1.0.2

+-- colors@1.1.2

+-- concat-map@0.0.1

+-- console-browserify@1.1.0

+-- constants-browserify@0.0.1

+-- contra@1.9.4

+-- convert-source-map@1.1.3

+-- core-util-is@1.0.2

+-- crossvent@1.5.4

+-- crypto-browserify@3.2.8

+-- css-loader@0.9.1

| `-- source-map@0.1.43

+-- csso@1.3.12

+-- custom-event@1.0.0

+-- d@0.1.1

+-- date-now@0.1.4

+-- decamelize@1.2.0

+-- domain-browser@1.1.7

+-- dragula@3.7.2

+-- emojis-list@2.1.0

+-- enhanced-resolve@2.3.0

+-- errno@0.1.4

+-- es5-ext@0.10.12

+-- es6-iterator@2.0.0

+-- es6-promise@2.3.0

+-- es6-symbol@3.1.0

+-- es6-weak-map@0.1.4

| +-- es6-iterator@0.1.3

| `-- es6-symbol@2.0.1

+-- event-emitter@0.3.4

+-- events@1.1.1

+-- expand-brackets@0.1.5

+-- expand-range@1.8.2

+-- exports-loader@0.6.3

| `-- source-map@0.1.43

+-- expose-loader@0.6.0

+-- extglob@0.3.2

+-- extract-text-webpack-plugin@0.3.8

| `-- source-map@0.1.43

+-- fastparse@1.1.1

+-- file-loader@0.8.5

+-- filename-regex@2.0.0

+-- fill-range@2.2.3

+-- for-in@0.1.6

+-- for-own@0.1.4

+-- glob@4.5.3

+-- glob-base@0.3.0

+-- glob-parent@2.0.0

+-- graceful-fs@4.1.9

+-- has-flag@1.0.0

+-- html-loader@0.2.3

| `-- source-map@0.1.43

+-- html-minifier@0.5.6

+-- http-browserify@1.7.0

+-- https-browserify@0.0.0

+-- ieee754@1.1.8

+-- indexof@0.0.1

+-- inflight@1.0.6

+-- inherits@2.0.3

+-- interpret@0.6.6

+-- is-binary-path@1.0.1

+-- is-buffer@1.1.4

+-- is-dotfile@1.0.2

+-- is-equal-shallow@0.1.3

+-- is-extendable@0.1.1

+-- is-extglob@1.0.0

+-- is-glob@2.0.1

+-- is-number@2.1.0

+-- is-posix-bracket@0.1.1

+-- is-primitive@2.0.0

+-- isarray@1.0.0

+-- isobject@2.1.0

+-- js-base64@2.1.9

+-- json5@0.4.0

+-- kind-of@3.0.4

+-- lazy-cache@1.0.4

+-- loader-utils@0.2.16

| `-- json5@0.5.0

+-- lodash@2.4.2

+-- longest@1.0.1

+-- lru-queue@0.1.0

+-- memoizee@0.3.10

+-- memory-fs@0.3.0

+-- micromatch@2.3.11

+-- mime@1.2.11

+-- minimatch@2.0.10

+-- minimist@0.0.10

+-- mkdirp@0.5.1

| `-- minimist@0.0.8

+-- nan@2.4.0

+-- next-tick@0.2.2

+-- ng-annotate@1.2.1

| `-- source-map@0.5.6

+-- ng-annotate-loader@0.0.10

| `-- source-map@0.4.2

+-- ngtemplate-loader@0.1.3

+-- node-libs-browser@0.6.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- normalize-path@2.0.1

+-- num2fraction@1.2.2

+-- object-assign@4.1.0

+-- object.omit@2.0.1

+-- observable-array@0.0.4

+-- observable-value@0.0.5

+-- once@1.4.0

+-- optimist@0.6.1

+-- ordered-ast-traverse@1.1.1

+-- ordered-esprima-props@1.1.0

+-- os-browserify@0.1.2

+-- pako@0.2.9

+-- parse-glob@3.0.4

+-- path-browserify@0.0.0

+-- path-is-absolute@1.0.1

+-- pbkdf2-compat@2.0.1

+-- phantomjs-polyfill@0.0.2

+-- postcss@4.1.16

+-- preserve@0.2.0

+-- process@0.11.9

+-- process-nextick-args@1.0.7

+-- prr@0.0.0

+-- punycode@1.4.1

+-- querystring@0.2.0

+-- querystring-es3@0.2.1

+-- randomatic@1.1.5

+-- readable-stream@2.1.5

+-- readdirp@2.1.0

| `-- minimatch@3.0.3

+-- regex-cache@0.4.3

+-- repeat-element@1.1.2

+-- repeat-string@1.6.1

+-- right-align@0.1.3

+-- ripemd160@0.2.0

+-- set-immediate-shim@1.0.1

+-- sha.js@2.2.6

+-- shelljs@0.3.0

+-- simple-fmt@0.1.0

+-- simple-is@0.2.0

+-- source-list-map@0.1.6

+-- source-map@0.4.4

+-- source-map-support@0.4.5

| `-- source-map@0.5.6

+-- stable@0.1.5

+-- stream-browserify@1.0.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- string_decoder@0.10.31

+-- stringmap@0.2.2

+-- stringset@0.2.1

+-- style-loader@0.8.3

+-- supports-color@3.1.2

+-- tapable@0.2.4

+-- ticky@1.0.1

+-- timers-browserify@1.4.2

+-- timers-ext@0.1.0

+-- tryor@0.1.2

+-- tty-browserify@0.0.0

+-- typescript@2.0.6

+-- uglify-js@2.7.4

| `-- source-map@0.5.6

+-- uglify-to-browserify@1.0.2

+-- URIjs@1.16.1

+-- url@0.10.3

| `-- punycode@1.3.2

+-- url-loader@0.5.7

+-- util@0.10.3

| `-- inherits@2.0.1

+-- util-deprecate@1.0.2

+-- vm-browserify@0.0.4

+-- watchpack@0.2.9

| `-- async@0.9.2

+-- webpack@1.13.3

| +-- acorn@3.3.0

| +-- async@1.5.2

| +-- enhanced-resolve@0.9.1

| | `-- memory-fs@0.2.0

| `-- tapable@0.1.10

+-- webpack-core@0.6.8

+-- window-size@0.1.0

+-- wordwrap@0.0.3

+-- wrappy@1.0.2

`-- yargs@3.10.0

npm WARN openproject-frontend@0.1.0 No repository field.

npm WARN openproject-frontend@0.1.0 No license field.

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.0.14 (node_modules/fsevents):

npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.0.14: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

-----> Checking startup method

Found Procfile

-----> Finalizing build

Creating runtime environment

Exporting binary paths

Cleaning npm artifacts

Cleaning previous cache

Caching results for future builds

-----> Build succeeded!

openproject@0.1.0 /tmp/d20170210-17-2qodh8/opt/openproject

`-- typescript@2.0.8

=====> Downloading Buildpack: https://github.com/pkgr/heroku-buildpack-ruby.git

=====> Detected Framework: Ruby

-----> Compiling Ruby/Rails

-----> Using Ruby version: ruby-2.3.1

-----> Installing dependencies using bundler 1.13.2

cp: `/tmp/d20170210-17-2qodh8/opt/openproject/.git/cache/vendor/bundle/.' and `/tmp/d20170210-17-2qodh8/opt/openproject/.git/cache/vendor/bundle/.' are the same file

Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Fetching gem metadata from https://rubygems.org/......

Fetching version metadata from https://rubygems.org/..

Fetching dependency metadata from https://rubygems.org/.

Using rake 11.3.0

Using concurrent-ruby 1.0.2

Using i18n 0.7.0

Using minitest 5.9.0

Using thread_safe 0.3.5

Using builder 3.2.2

Using erubis 2.7.0

Using mini_portile2 2.1.0

Using pkg-config 1.1.7

Using rack 2.0.1

Using nio4r 1.2.1

Using websocket-extensions 0.1.2

Using mime-types 2.99.3

Using method_source 0.8.2

Using thor 0.19.1

Using arel 7.1.2

Using multi_json 1.12.1

Using acts_as_silent_list 3.0.0

Using addressable 2.4.0

Using airbrake-ruby 1.5.0

Using attr_required 1.0.1

Using execjs 2.7.0

Using ice_nine 0.11.2

Using bcrypt 3.1.11

Using bindata 2.3.4

Using sass 3.4.22

Using tilt 2.0.5

Using uber 0.0.15

Using erbse 0.0.2

Using coderay 1.1.1

Using color-tools 1.3.0

Using unf_ext 0.0.7.2

Using netrc 0.11.0

Using daemons 1.2.4

Using dalli 2.7.6

Using enumerable-lazy 0.0.1

Using equalizer 0.0.11

Using excon 0.52.0

Using ffi 1.9.14

Using formatador 0.2.5

Using ipaddress 0.8.3

Using get_process_mem 0.2.1

Using request_store 1.3.1

Using json 1.8.3

Using hashie 3.4.6

Using multi_xml 0.5.5

Using gravatar_image_tag 1.2.0

Using bundler 1.13.2

Using htmldiff 0.0.1

Using httpclient 2.8.2.4

Using icalendar 2.3.0

Using iso8601 0.9.1

Using securecompare 1.0.0

Using url_safe_base64 0.2.2

Using kgio 2.10.0

Using mixlib-shellout 2.1.0

Using mysql2 0.4.4

Using net-ldap 0.14.0

Using newrelic_rpm 3.16.2.321

Using oj 2.17.4

Using pdf-core 0.6.1

Using ttfunk 1.4.0

Using rmagick 2.15.4

Using rubyzip 1.2.0

Using ruby-ole 1.2.12

Using pg 0.19.0

Using rails_serve_static_assets 0.0.5

Using rails_stdout_logging 0.0.5

Using raindrops 0.17.0

Using ruby-progressbar 1.8.1

Using structured_warnings 0.2.0

Using sqlite3 1.3.11

Using stringex 2.6.1

Using svg-graph 2.0.1

Using syck 1.0.5

Using will_paginate 3.1.3

Using i18n-js 3.0.0.rc14

Using tzinfo 1.2.2

Using descendants_tracker 0.0.4

Using nokogiri 1.6.8

Using websocket-driver 0.6.4

Using rack-test 0.6.3

Using rack-accept 0.4.5

Using sprockets 3.7.0

Using passenger 5.0.30

Using rack-attack 5.0.1

Using rack-protection 2.0.0.beta2

Using warden 1.2.6

Using mail 2.6.4

Using airbrake 5.1.0

Using autoprefixer-rails 6.4.1.1

Using cells 4.1.3

Using bourbon 4.2.7

Using unf 0.1.4

Using mustermann19 0.4.4

Using sys-filesystem 1.1.7

Using fog-core 1.42.0

Using omniauth 1.3.1 from https://github.com/oliverguenther/omniauth (at 8385bc0@8385bc0)

Using rdoc 4.2.2

Using prawn 2.1.0

Using spreadsheet 0.8.9

Using rails_12factor 0.0.3

Using unicorn 5.1.0

Using rubytree 0.9.7

Using axiom-types 0.1.1

Using coercible 1.0.0

Using activesupport 5.0.0.1

Using tzinfo-data 1.2016.6

Using loofah 2.0.3

Using representable 2.1.8

Using ruby-saml 1.4.0

Using warden-basic_auth 0.2.1

Using cells-erb 0.0.8

Using domain_name 0.5.20161129

Using fog-json 1.0.2

Using fog-xml 0.1.2

Using prawn-table 0.2.2

Using rails-dom-testing 2.0.1

Using globalid 0.3.7

Using activemodel 5.0.0.1

Using climate_control 0.0.3

Using delayed_job 4.1.2

Using json-jwt 1.6.5

Using rack-oauth2 1.4.0

Using swd 1.0.1

Using webfinger 1.0.2

Using rabl 0.13.0

Using ruby-duration 3.2.3

Using virtus 1.0.5

Using rails-html-sanitizer 1.0.3

Using unicorn-worker-killer 0.4.4

Using omniauth-saml 1.6.0 from git://github.com/omniauth/omniauth-saml.git (at master@5559d6b)

Using disposable 0.0.9

Using roar 1.0.4

Using http-cookie 1.0.3

Using fog-aws 0.11.0

Using activejob 5.0.0.1

Using activerecord 5.0.0.1

Using carrierwave 1.0.0.beta from https://github.com/carrierwaveuploader/carrierwave (at master@5367a63)

Using date_validator 0.9.0

Using validate_email 0.1.6

Using validate_url 1.0.2

Using cocaine 0.5.8

Using grape 0.17.0

Using actionview 5.0.0.1

Using openproject-auth_saml 0.1.0 from https://github.com/finnlabs/openproject-auth_saml (at dev@97212ab)

Using reform 1.2.6

Using rest-client 1.8.0

Using activemodel-serializers-xml 1.0.1

Using acts_as_list 0.8.1

Using acts_as_tree 2.5.1

Using awesome_nested_set 3.1.1

Using delayed_job_active_record 4.1.1

Using friendly_id 5.2.0.beta.1 from https://github.com/norman/friendly_id (at aff0564@aff0564)

Using globalize 5.1.0 from https://github.com/globalize/globalize (at 38443bc@38443bc)

Using transactional_lock 0.1.0 from https://github.com/finnlabs/transactional_lock.git (at master@6948b1d)

Using openid_connect 0.8.3

Using grape-cache_control 1.0.1

Using actionpack 5.0.0.1

Using crowdin-api 0.4.1

Using omniauth-openid-connect 0.2.0 from https://github.com/finnlabs/omniauth-openid-connect.git (at dev@c3bce4c)

Using actioncable 5.0.0.1

Using actionmailer 5.0.0.1

Using railties 5.0.0.1

Using cells-rails 0.0.6

Using gon 4.1.1

Using sprockets-rails 3.2.0

Using omniauth-openid_connect-providers 0.1.0 from https://github.com/finnlabs/omniauth-openid_connect-providers.git (at dev@86f3670)

Using actionpack-xml_parser 2.0.0

Using activerecord-session_store 1.0.0

Using rails 5.0.0.1

Using jquery-tablesorter 1.22.7

Using responders 2.3.0

Using sass-rails 5.0.6

Using health_check 2.2.1

Using lobby_boy 0.1.2

Using openproject-auth_plugins 6.1.4 from source at `vendored-plugins/openproject-auth_plugins`

Using openproject-pdf_export 6.1.4 from source at `vendored-plugins/openproject-pdf_export`

Using openproject-costs 6.1.4 from source at `vendored-plugins/openproject-costs`

Using openproject-documents 6.1.4 from source at `vendored-plugins/openproject-documents`

Using openproject-webhooks 6.1.4 from source at `vendored-plugins/openproject-webhooks`

Using openproject-global_roles 6.1.4 from source at `vendored-plugins/openproject-global_roles`

Using openproject-local_avatars 6.1.4 from source at `vendored-plugins/openproject-local_avatars`

Using openproject-meeting 6.1.4 from source at `vendored-plugins/openproject-meeting`

Using openproject-my_project_page 6.1.4 from source at `vendored-plugins/openproject-my_project_page`

Using reporting_engine 6.1.4 from source at `vendored-plugins/reporting_engine`

Using openproject-themes-dark 6.1.4 from source at `vendored-plugins/openproject-themes-dark`

Using openproject-translations 6.1.4 from https://github.com/opf/openproject-translations.git (at stable/6@da52ff9)

Using openproject-xls_export 6.1.4 from source at `vendored-plugins/openproject-xls_export`

Using rails-angular-xss 0.3.0.pre.pre from https://github.com/opf/rails-angular-xss (at a45267d@a45267d)

Using rails_autolink 1.1.6

Using openproject-openid_connect 6.1.4 from source at `vendored-plugins/openproject-openid_connect`

Using openproject-backlogs 6.1.4 from source at `vendored-plugins/openproject-backlogs`

Using openproject-github_integration 6.1.4 from source at `vendored-plugins/openproject-github_integration`

Using openproject-reporting 6.1.4 from source at `vendored-plugins/openproject-reporting`

Bundle complete! 138 Gemfile dependencies, 195 gems now installed.

Gems in the groups development and test were not installed.

Bundled gems are installed into ./vendor/bundle.

Bundle completed (8.40s)

Cleaning up the bundler cache.

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

-----> Detecting rake tasks

-----> Preparing app for Rails asset pipeline

Running: rake assets:precompile

$(npm bin)/webpack --config webpack.production.config.js

{"omniauth-openid-connect":"/tmp/d20170210-17-2qodh8/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid-connect-c3bce4c9e9ac","omniauth-openid_connect-providers":"/tmp/d20170210-17-2qodh8/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid_connect-providers-86f3670e127e","omniauth-saml":"/tmp/d20170210-17-2qodh8/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-saml-5559d6b80805","openproject-auth_plugins":"/tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-auth_plugins","openproject-auth_saml":"/tmp/d20170210-17-2qodh8/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-auth_saml-97212abb8378","openproject-pdf_export":"/tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-pdf_export","openproject-backlogs":"/tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-backlogs","openproject-costs":"/tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-costs","openproject-documents":"/tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-documents","openproject-webhooks":"/tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-webhooks","openproject-github_integration":"/tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-github_integration","openproject-global_roles":"/tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-global_roles","openproject-local_avatars":"/tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-local_avatars","openproject-meeting":"/tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-meeting","openproject-my_project_page":"/tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-my_project_page","openproject-openid_connect":"/tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-openid_connect","reporting_engine":"/tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/reporting_engine","openproject-reporting":"/tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-reporting","openproject-themes-dark":"/tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-themes-dark","openproject-translations":"/tmp/d20170210-17-2qodh8/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-translations-da52ff92cdcd","openproject-xls_export":"/tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-xls_export"}

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Hash: dfcfb18a2e5f6ebb3ad5

Version: webpack 1.13.3

Child

Hash: dfcfb18a2e5f6ebb3ad5

Version: webpack 1.13.3

Time: 15295ms

Asset Size Chunks Chunk Names

7b9776076d5fceef4993b55c9383dedd.gif 1.85 kB [emitted]

openproject-backlogs.js 453 kB 0 [emitted] backlogs

openproject-core-app.js 3.43 MB 1 [emitted] core-app

openproject-costs.js 526 kB 2 [emitted] costs

openproject-global.js 3.51 MB 3 [emitted] global

openproject-my_project_page.js 14.3 kB 4 [emitted] my_project_page

openproject-core-app.css 4.71 kB 1 [emitted] core-app

openproject-global.css 49 kB 3 [emitted] global

[213] ./templates \.html$ 1.22 kB {1} [built]

[242] ./components ^((?!\.(test|spec)).)*\.(js|ts|html)$ 16.1 kB {1} [built]

[633] /tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 425 bytes {2} [built]

[765] /tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 330 bytes {4} [built]

+ 769 hidden modules

ERROR in [default]

File '/tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-budget-subform.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-2qodh8/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-2qodh8/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/subform/cost-subform.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-2qodh8/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts' is not under 'rootDir' '/tmp/d20170210-17-2qodh8/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts' is not under 'rootDir' '/tmp/d20170210-17-2qodh8/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-block.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-2qodh8/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-page-layout.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-2qodh8/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-textile-block.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-2qodh8/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default] /tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:49:18

Argument of type 'string' is not assignable to parameter of type '{ [key: string]: any; }'.

ERROR in [default] /tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:53:4

Supplied parameters do not match any signature of call target.

ERROR in [default] /tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:30:38

Cannot find module 'app/components/work-packages/work-package-cache.service'.

ERROR in [default] /tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:49:30

Cannot find name 'HalResource'.

ERROR in [default] /tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:54:57

Property '$injector' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:13

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:27

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:60:11

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:70:23

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:76:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:77:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:78:16

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:36:17

Property 'value' does not exist on type 'CurrencyDisplayField'.

ERROR in [default] /tmp/d20170210-17-2qodh8/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:37:23

Property 'value' does not exist on type 'CurrencyDisplayField'.

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 5 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

I, [2017-02-10T13:28:58.706573 #2052] INFO -- : Writing /tmp/d20170210-17-2qodh8/opt/openproject/public/assets/application-63469527439a0833249dc92eb8e35589845157c34c67aab4eae3b20b4d024269.js

I, [2017-02-10T13:28:58.707337 #2052] INFO -- : Writing /tmp/d20170210-17-2qodh8/opt/openproject/public/assets/application-63469527439a0833249dc92eb8e35589845157c34c67aab4eae3b20b4d024269.js.gz

Asset precompilation completed (35.52s)

Cleaning assets

Running: rake assets:clean

I, [2017-02-10T13:29:07.470051 #2224] INFO -- : Removed application-d6db70ad959313ed6ee322048de32c146b2e5a07eb8649af3e84436b3c17a755.js

Using release configuration from last framework (Ruby).

-----> [cron] /opt/openproject/packaging/cron/openproject-clear-old-sessions => /etc/cron.d/openproject-clear-old-sessions

NEW PACKAGE: openproject-6.1.4-1486730985.5bf684b.sles11.x86_64.rpm (289.91 MiB)

-----> Releasing...

DONE!

====== Attempt #1

-----> Fetching repository

Cloning into '/tmp/d20170210-16665-leq682/input'...

-----> Restoring cache

-----> Starting packaging process

-----> Installing missing build dependencies: gcc-c++, readline-devel, libxml2-devel, libxslt-devel, libevent-devel, libmysqlclient-devel, sqlite3-devel, timezone, kernel-devel, postgresql-devel, ImageMagick-devel

-----> [wizard] adding legacy-installer wizard (https://github.com/pkgr/addon-legacy-installer#master)

-----> [wizard] adding mysql wizard (https://github.com/pkgr/addon-mysql#master)

-----> [wizard] adding apache2 wizard (https://github.com/pkgr/addon-apache2#master)

-----> [wizard] adding repositories wizard (https://github.com/finnlabs/addon-repositories#master)

-----> [wizard] adding smtp wizard (https://github.com/pkgr/addon-smtp#master)

-----> [wizard] adding memcached wizard (https://github.com/pkgr/addon-memcached#master)

-----> [wizard] adding openproject wizard (https://github.com/pkgr/addon-openproject#master)

-----> Fetching buildpack https://github.com/opf/heroku-buildpack-multi.git at master

-----> Multipack app

-----> Running hook: "packaging/setup"

WARNING: This buildpack is no longer maintained.

Please choose a different buildpack or go to https://github.com/ddollar/heroku-buildpack-multi

and fork it to your own account.

=====> Downloading Buildpack: https://github.com/pkgr/pkgr-buildpack-imagemagick.git

=====> Detected Framework: ImageMagick

-----> SKIP

=====> Downloading Buildpack: https://github.com/heroku/heroku-buildpack-nodejs.git

=====> Detected Framework: Node.js

-----> Reading application state

package.json...

build directory...

cache directory...

environment variables...

Node engine: 6.9.1

Npm engine: 4.0.0

Start mechanism: Procfile

node_modules source: package.json

node_modules cached: true

NPM_CONFIG_PRODUCTION=true

NODE_MODULES_CACHE=true

-----> Installing binaries

Downloading and installing node 6.9.1...

Downloading and installing npm 4.0.0 (replacing version 3.10.8)...

-----> Building dependencies

Restoring node modules from cache

Pruning unused dependencies

Installing any new modules

> openproject@0.1.0 postinstall /tmp/d20170210-17-wr9vdm/opt/openproject

> cd frontend && npm install

> openproject-frontend@0.1.0 postinstall /tmp/d20170210-17-wr9vdm/opt/openproject/frontend

> bower install --config.interactive=false

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 not-cached git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolve git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de not-cached git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolve git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 not-cached git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolve git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 checkout d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower jquery-ui#~1.10.4 not-cached https://github.com/components/jqueryui.git#~1.10.4

bower jquery-ui#~1.10.4 resolve https://github.com/components/jqueryui.git#~1.10.4

bower select2#3.5.2 not-cached https://github.com/ivaynberg/select2.git#3.5.2

bower select2#3.5.2 resolve https://github.com/ivaynberg/select2.git#3.5.2

bower jquery-ujs#1.0.0 not-cached https://github.com/rails/jquery-ujs.git#1.0.0

bower jquery-ujs#1.0.0 resolve https://github.com/rails/jquery-ujs.git#1.0.0

bower angular#~1.5.8 not-cached https://github.com/angular/bower-angular.git#~1.5.8

bower angular#~1.5.8 resolve https://github.com/angular/bower-angular.git#~1.5.8

bower jquery.atwho#0.5.1 not-cached https://github.com/ichord/At.js.git#0.5.1

bower jquery.atwho#0.5.1 resolve https://github.com/ichord/At.js.git#0.5.1

bower angular-animate#~1.5.8 not-cached https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-animate#~1.5.8 resolve https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-i18n#~1.5.5 not-cached https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-i18n#~1.5.5 resolve https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-ui-router#~0.3.1 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-ui-router#~0.3.1 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-aria#~1.5.8 not-cached https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-aria#~1.5.8 resolve https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-sanitize#~1.5.8 not-cached https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-sanitize#~1.5.8 resolve https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-elastic#~2.5.1 not-cached https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-elastic#~2.5.1 resolve https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-cache#~4.6.0 not-cached https://github.com/jmdobry/angular-cache.git#~4.6.0

bower angular-cache#~4.6.0 resolve https://github.com/jmdobry/angular-cache.git#~4.6.0

bower jquery-migrate#~1.2.1 not-cached https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower jquery-migrate#~1.2.1 resolve https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower moment#~2.10.6 not-cached https://github.com/moment/moment.git#~2.10.6

bower moment#~2.10.6 resolve https://github.com/moment/moment.git#~2.10.6

bower moment-timezone#0.4.x not-cached https://github.com/moment/moment-timezone.git#0.4.x

bower moment-timezone#0.4.x resolve https://github.com/moment/moment-timezone.git#0.4.x

bower angular-busy#~4.1.3 not-cached https://github.com/cgross/angular-busy.git#~4.1.3

bower angular-busy#~4.1.3 resolve https://github.com/cgross/angular-busy.git#~4.1.3

bower lodash#~2.4.1 not-cached https://github.com/lodash/lodash.git#~2.4.1

bower lodash#~2.4.1 resolve https://github.com/lodash/lodash.git#~2.4.1

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de checkout fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 checkout a908eccaec323cd66973d58af4965694bdff16a1

bower foundation-apps#1.1.0 not-cached https://github.com/zurb/foundation-apps.git#1.1.0

bower foundation-apps#1.1.0 resolve https://github.com/zurb/foundation-apps.git#1.1.0

bower mousetrap#~1.4.6 not-cached https://github.com/ccampbell/mousetrap.git#~1.4.6

bower mousetrap#~1.4.6 resolve https://github.com/ccampbell/mousetrap.git#~1.4.6

bower angular-ui-select#~0.19.4 not-cached https://github.com/angular-ui/ui-select.git#~0.19.4

bower angular-ui-select#~0.19.4 resolve https://github.com/angular-ui/ui-select.git#~0.19.4

bower bourbon#~4.2.1 not-cached https://github.com/thoughtbot/bourbon.git#~4.2.1

bower bourbon#~4.2.1 resolve https://github.com/thoughtbot/bourbon.git#~4.2.1

bower ng-file-upload#~5.0.9 not-cached https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower ng-file-upload#~5.0.9 resolve https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower rxjs#^4.1.0 not-cached https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower rxjs#^4.1.0 resolve https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower ng-dialog#^0.6.2 not-cached https://github.com/likeastore/ngDialog.git#^0.6.2

bower ng-dialog#^0.6.2 resolve https://github.com/likeastore/ngDialog.git#^0.6.2

bower mocha#~1.14.0 not-cached https://github.com/mochajs/mocha.git#~1.14.0

bower mocha#~1.14.0 resolve https://github.com/mochajs/mocha.git#~1.14.0

bower angular-dragula#^1.2.8 not-cached https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower angular-dragula#^1.2.8 resolve https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower angular-mocks#~1.5.8 not-cached https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower angular-mocks#~1.5.8 resolve https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower jquery-mockjax#~1.5.3 not-cached https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery-mockjax#~1.5.3 resolve https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower chai#~1.9.0 not-cached https://github.com/chaijs/chai.git#~1.9.0

bower chai#~1.9.0 resolve https://github.com/chaijs/chai.git#~1.9.0

bower jquery-ui#~1.10.4 checkout 1.10.4

bower select2#3.5.2 checkout 3.5.2

bower jquery-ujs#1.0.0 checkout v1.0.0

bower jquery.atwho#0.5.1 checkout v0.5.1

bower angular#~1.5.8 checkout v1.5.11

bower angular-aria#~1.5.8 checkout v1.5.11

bower angular-ui-router#~0.3.1 checkout 0.3.2

bower angular-i18n#~1.5.5 checkout v1.5.11

bower angular-animate#~1.5.8 checkout v1.5.11

bower moment#~2.10.6 checkout 2.10.6

bower jquery-migrate#~1.2.1 checkout 1.2.1

bower angular-cache#~4.6.0 checkout 4.6.0

bower angular-elastic#~2.5.1 checkout v2.5.1

bower angular-sanitize#~1.5.8 checkout v1.5.11

bower mousetrap#~1.4.6 checkout 1.4.6

bower foundation-apps#1.1.0 checkout v1.1.0

bower lodash#~2.4.1 checkout 2.4.2

bower angular-busy#~4.1.3 checkout v4.1.4

bower moment-timezone#0.4.x checkout 0.4.1

bower angular-ui-select#~0.19.4 checkout v0.19.6

bower bourbon#~4.2.1 checkout v4.2.7

bower ng-file-upload#~5.0.9 checkout 5.0.9

bower ng-dialog#^0.6.2 checkout v0.6.6

bower rxjs#^4.1.0 checkout v4.1.0

bower angular-dragula#^1.2.8 checkout v1.2.8

bower mocha#~1.14.0 checkout 1.14.0

bower jquery-mockjax#~1.5.3 checkout v1.5.4

bower angular-mocks#~1.5.8 checkout v1.5.11

bower chai#~1.9.0 checkout 1.9.2

bower jquery.atwho#0.5.1 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .png files: ["select2.png","select2x2.png"]

bower jquery#1.11.0 not-cached https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery#1.11.0 resolve https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery-ui#~1.10.4 resolved https://github.com/components/jqueryui.git#1.10.4

bower select2#3.5.2 resolved https://github.com/ivaynberg/select2.git#3.5.2

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolved git://github.com/sparkalow/angular-truncate.git#fdf60fda26

bower jquery-ujs#1.0.0 resolved https://github.com/rails/jquery-ujs.git#1.0.0

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolved git://github.com/nickmessing/angular-context-menu.git#a908eccaec

bower angular#>= 1.2.5 not-cached https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 resolve https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 checkout v1.6.2

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolved git://github.com/finnlabs/angular-modal.git#d45eb9ceb7

bower angular#^1.3.0 not-cached https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 resolve https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 checkout v1.6.2

bower angular-aria#~1.5.8 resolved https://github.com/angular/bower-angular-aria.git#1.5.11

bower jquery.atwho#0.5.1 resolved https://github.com/ichord/At.js.git#0.5.1

bower Caret.js#>= 0.2.0 not-cached https://github.com/ichord/Caret.js.git#>= 0.2.0

bower Caret.js#>= 0.2.0 resolve https://github.com/ichord/Caret.js.git#>= 0.2.0

bower angular-animate#~1.5.8 resolved https://github.com/angular/bower-angular-animate.git#1.5.11

bower angular#~1.5.8 resolved https://github.com/angular/bower-angular.git#1.5.11

bower angular-ui-router#~0.3.1 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.3.2

bower jquery-migrate#~1.2.1 deprecated Package jquery-migrate is using the deprecated component.json

bower jquery-migrate#~1.2.1 resolved https://github.com/appleboy/jquery-migrate.git#1.2.1

bower angular-elastic#~2.5.1 resolved https://github.com/monospaced/angular-elastic.git#2.5.1

bower angular-cache#~4.6.0 resolved https://github.com/jmdobry/angular-cache.git#4.6.0

bower angular-sanitize#~1.5.8 resolved https://github.com/angular/bower-angular-sanitize.git#1.5.11

bower mousetrap#~1.4.6 resolved https://github.com/ccampbell/mousetrap.git#1.4.6

bower moment#~2.10.6 resolved https://github.com/moment/moment.git#2.10.6

bower foundation-apps#1.1.0 resolved https://github.com/zurb/foundation-apps.git#1.1.0

bower angular#~1.3.4 not-cached https://github.com/angular/bower-angular.git#~1.3.4

bower angular#~1.3.4 resolve https://github.com/angular/bower-angular.git#~1.3.4

bower angular-ui-router#~0.2.12 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-ui-router#~0.2.12 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-animate#~1.3.4 not-cached https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular-animate#~1.3.4 resolve https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular#~1.3.4 checkout v1.3.20

bower angular-ui-router#~0.2.12 checkout 0.2.18

bower angular-animate#~1.3.4 checkout v1.3.20

bower ng-file-upload#~5.0.9 resolved https://github.com/danialfarid/angular-file-upload-bower.git#5.0.9

bower fastclick#~1.0.3 not-cached https://github.com/ftlabs/fastclick.git#~1.0.3

bower fastclick#~1.0.3 resolve https://github.com/ftlabs/fastclick.git#~1.0.3

bower hammerjs#~2.0.4 not-cached https://github.com/EightMedia/hammer.js.git#~2.0.4

bower hammerjs#~2.0.4 resolve https://github.com/EightMedia/hammer.js.git#~2.0.4

bower tether#~0.6.5 not-cached https://github.com/HubSpot/tether.git#~0.6.5

bower tether#~0.6.5 resolve https://github.com/HubSpot/tether.git#~0.6.5

bower viewport-units-buggyfill#~0.4.1 not-cached https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower viewport-units-buggyfill#~0.4.1 resolve https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower lodash#~2.4.1 resolved https://github.com/lodash/lodash.git#2.4.2

bower angular-busy#~4.1.3 resolved https://github.com/cgross/angular-busy.git#4.1.4

bower angular-ui-select#~0.19.4 resolved https://github.com/angular-ui/ui-select.git#0.19.6

bower bourbon#~4.2.1 resolved https://github.com/thoughtbot/bourbon.git#4.2.7

bower angular-i18n#~1.5.5 resolved https://github.com/angular/bower-angular-i18n.git#1.5.11

bower ng-dialog#^0.6.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .css files: ["css/ngDialog.css","css/ngDialog-theme-default.css"]

bower ng-dialog#^0.6.2 resolved https://github.com/likeastore/ngDialog.git#0.6.6

bower angular-dragula#^1.2.8 resolved https://github.com/bevacqua/angular-dragula.git#1.2.8

bower jquery#1.11.0 checkout 1.11.0

bower moment-timezone#0.4.x resolved https://github.com/moment/moment-timezone.git#0.4.1

bower mocha#~1.14.0 mismatch Version declared in the json (1.12.0) is different than the resolved one (1.14.0)

bower mocha#~1.14.0 resolved https://github.com/mochajs/mocha.git#1.14.0

bower jquery-mockjax#~1.5.3 resolved https://github.com/jakerella/jquery-mockjax.git#1.5.4

bower chai#~1.9.0 resolved https://github.com/chaijs/chai.git#1.9.2

bower angular-mocks#~1.5.8 resolved https://github.com/angular/bower-angular-mocks.git#1.5.11

bower Caret.js#>= 0.2.0 checkout v0.3.1

bower angular#>= 1.2.5 resolved https://github.com/angular/bower-angular.git#1.6.2

bower angular-ui-router#~0.2.12 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.2.18

bower fastclick#~1.0.3 checkout v1.0.6

bower hammerjs#~2.0.4 checkout v2.0.8

bower angular#^1.3.0 resolved https://github.com/angular/bower-angular.git#1.6.2

bower tether#~0.6.5 checkout v0.6.5

bower viewport-units-buggyfill#~0.4.1 checkout v0.4.1

bower angular#~1.3.4 resolved https://github.com/angular/bower-angular.git#1.3.20

bower Caret.js#>= 0.2.0 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower rxjs#^4.1.0 resolved https://github.com/Reactive-Extensions/RxJS.git#4.1.0

bower angular-animate#~1.3.4 resolved https://github.com/angular/bower-angular-animate.git#1.3.20

bower fastclick#~1.0.3 resolved https://github.com/ftlabs/fastclick.git#1.0.6

bower hammerjs#~2.0.4 resolved https://github.com/EightMedia/hammer.js.git#2.0.8

bower Caret.js#>= 0.2.0 resolved https://github.com/ichord/Caret.js.git#0.3.1

bower jquery#1.11.0 resolved https://github.com/jquery/jquery-dist.git#1.11.0

bower tether#~0.6.5 resolved https://github.com/HubSpot/tether.git#0.6.5

bower viewport-units-buggyfill#~0.4.1 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .js files: ["./viewport-units-buggyfill.js","./viewport-units-buggyfill.hacks.js"]

bower viewport-units-buggyfill#~0.4.1 resolved https://github.com/rodneyrehm/viewport-units-buggyfill.git#0.4.1

Please note that,

foundation-apps#1.1.0 depends on angular-animate#~1.3.4 which resolved to angular-animate#1.3.20

openproject depends on angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

angular-busy#4.1.4 depends on angular-animate#>=1.3 which resolved to angular-animate#1.5.11

Resort to using angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

Code incompatibilities may occur.

Please note that,

angular-animate#1.3.20 depends on angular#1.3.20 which resolved to angular#1.3.20

foundation-apps#1.1.0 depends on angular#~1.3.4 which resolved to angular#1.3.20

angular-animate#1.5.11, angular-aria#1.5.11, angular-mocks#1.5.11, angular-sanitize#1.5.11 depends on angular#1.5.11 which resolved to angular#1.5.11

angular-ui-router#0.3.2, angular-ui-router#0.2.18 depends on angular#^1.0.8 which resolved to angular#1.5.11

angular-elastic#2.5.1 depends on angular#>=1.0.6 which resolved to angular#1.5.11

angular-cache#4.6.0 depends on angular#>=1.x which resolved to angular#1.5.11

angular-busy#4.1.4 depends on angular#>=1.3 which resolved to angular#1.5.11

ng-dialog#0.6.6 depends on angular#>=1.5 which resolved to angular#1.5.11

openproject depends on angular#~1.5.8 which resolved to angular#1.5.11

angular-ui-select#0.19.6 depends on angular#>=1.2.18 which resolved to angular#1.5.11

angular-modal#d45eb9ceb7 depends on angular#^1.3.0 which resolved to angular#1.6.2

angular-context-menu#a908eccaec depends on angular#>= 1.2.5 which resolved to angular#1.6.2

Resort to using angular#~1.5.8 which resolved to angular#1.5.11

Code incompatibilities may occur.

Please note that,

foundation-apps#1.1.0 depends on angular-ui-router#~0.2.12 which resolved to angular-ui-router#0.2.18

openproject depends on angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Resort to using angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Code incompatibilities may occur.

bower jquery extra-resolution Unnecessary resolution: jquery#1.11.0

bower jquery-ui#~1.10.4 install jquery-ui#1.10.4

bower select2#3.5.2 install select2#3.5.2

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de install angular-truncate#fdf60fda26

bower jquery-ujs#1.0.0 install jquery-ujs#1.0.0

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 install angular-context-menu#a908eccaec

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 install angular-modal#d45eb9ceb7

bower angular-aria#~1.5.8 install angular-aria#1.5.11

bower jquery.atwho#0.5.1 install jquery.atwho#0.5.1

bower angular-animate#~1.5.8 install angular-animate#1.5.11

bower angular#1.5.11 install angular#1.5.11

bower angular-ui-router#~0.3.1 install angular-ui-router#0.3.2

bower jquery-migrate#~1.2.1 install jquery-migrate#1.2.1

bower angular-elastic#~2.5.1 install angular-elastic#2.5.1

bower angular-cache#~4.6.0 install angular-cache#4.6.0

bower angular-sanitize#~1.5.8 install angular-sanitize#1.5.11

bower mousetrap#~1.4.6 install mousetrap#1.4.6

bower moment#~2.10.6 install moment#2.10.6

bower foundation-apps#1.1.0 install foundation-apps#1.1.0

bower ng-file-upload#~5.0.9 install ng-file-upload#5.0.9

bower lodash#~2.4.1 install lodash#2.4.2

bower angular-busy#~4.1.3 install angular-busy#4.1.4

bower angular-ui-select#~0.19.4 install angular-ui-select#0.19.6

bower bourbon#~4.2.1 install bourbon#4.2.7

bower angular-i18n#~1.5.5 install angular-i18n#1.5.11

bower ng-dialog#^0.6.2 install ng-dialog#0.6.6

bower angular-dragula#^1.2.8 install angular-dragula#1.2.8

bower moment-timezone#0.4.x install moment-timezone#0.4.1

bower mocha#~1.14.0 install mocha#1.14.0

bower jquery-mockjax#~1.5.3 install jquery-mockjax#1.5.4

bower chai#~1.9.0 install chai#1.9.2

bower angular-mocks#~1.5.8 install angular-mocks#1.5.11

bower rxjs#^4.1.0 install rxjs#4.1.0

bower fastclick#~1.0.3 install fastclick#1.0.6

bower hammerjs#~2.0.4 install hammerjs#2.0.8

bower Caret.js#>= 0.2.0 install Caret.js#0.3.1

bower jquery#1.11.0 install jquery#1.11.0

bower tether#~0.6.5 install tether#0.6.5

bower viewport-units-buggyfill#~0.4.1 install viewport-units-buggyfill#0.4.1

jquery-ui#1.10.4 bower_components/jquery-ui

└── jquery#1.11.0

select2#3.5.2 bower_components/select2

└── jquery#1.11.0

angular-truncate#fdf60fda26 bower_components/angular-truncate

jquery-ujs#1.0.0 bower_components/jquery-ujs

└── jquery#1.11.0

angular-context-menu#a908eccaec bower_components/angular-context-menu

└── angular#1.5.11

angular-modal#d45eb9ceb7 bower_components/angular-modal

└── angular#1.5.11

angular-aria#1.5.11 bower_components/angular-aria

└── angular#1.5.11

jquery.atwho#0.5.1 bower_components/jquery.atwho

├── Caret.js#0.3.1

└── jquery#1.11.0

angular-animate#1.5.11 bower_components/angular-animate

└── angular#1.5.11

angular#1.5.11 bower_components/angular

angular-ui-router#0.3.2 bower_components/angular-ui-router

└── angular#1.5.11

jquery-migrate#1.2.1 bower_components/jquery-migrate

angular-elastic#2.5.1 bower_components/angular-elastic

└── angular#1.5.11

angular-cache#4.6.0 bower_components/angular-cache

└── angular#1.5.11

angular-sanitize#1.5.11 bower_components/angular-sanitize

└── angular#1.5.11

mousetrap#1.4.6 bower_components/mousetrap

moment#2.10.6 bower_components/moment

foundation-apps#1.1.0 bower_components/foundation-apps

├── angular#1.5.11

├── angular-animate#1.5.11

├── angular-ui-router#0.3.2

├── fastclick#1.0.6

├── hammerjs#2.0.8

├── tether#0.6.5

└── viewport-units-buggyfill#0.4.1

ng-file-upload#5.0.9 bower_components/ng-file-upload

lodash#2.4.2 bower_components/lodash

angular-busy#4.1.4 bower_components/angular-busy

├── angular#1.5.11

└── angular-animate#1.5.11

angular-ui-select#0.19.6 bower_components/angular-ui-select

└── angular#1.5.11

bourbon#4.2.7 bower_components/bourbon

angular-i18n#1.5.11 bower_components/angular-i18n

ng-dialog#0.6.6 bower_components/ng-dialog

└── angular#1.5.11

angular-dragula#1.2.8 bower_components/angular-dragula

moment-timezone#0.4.1 bower_components/moment-timezone

└── moment#2.10.6

mocha#1.14.0 bower_components/mocha

jquery-mockjax#1.5.4 bower_components/jquery-mockjax

chai#1.9.2 bower_components/chai

angular-mocks#1.5.11 bower_components/angular-mocks

└── angular#1.5.11

rxjs#4.1.0 bower_components/rxjs

fastclick#1.0.6 bower_components/fastclick

hammerjs#2.0.8 bower_components/hammerjs

Caret.js#0.3.1 bower_components/Caret.js

└── jquery#1.11.0

jquery#1.11.0 bower_components/jquery

tether#0.6.5 bower_components/tether

viewport-units-buggyfill#0.4.1 bower_components/viewport-units-buggyfill

openproject-frontend@0.1.0 /tmp/d20170210-17-wr9vdm/opt/openproject/frontend

+-- acorn@2.6.4

+-- align-text@0.1.4

+-- alter@0.2.0

+-- amdefine@1.0.0

+-- angular@1.5.8

+-- angular-elastic@2.5.1

+-- angular-ui-bootstrap@2.2.0

+-- anymatch@1.3.0

+-- arr-diff@2.0.0

+-- arr-flatten@1.0.1

+-- array-unique@0.2.1

+-- arrify@1.0.1

+-- assert@1.4.1

+-- async@0.2.10

+-- async-each@1.0.1

+-- atoa@1.0.0

+-- autoprefixer-core@5.2.1

+-- autoprefixer-loader@1.2.0

+-- awesome-typescript-loader@2.2.4

| `-- lodash@4.16.4

+-- balanced-match@0.4.2

+-- Base64@0.2.1

+-- base64-js@1.2.0

+-- big.js@3.1.3

+-- binary-extensions@1.7.0

+-- bower@1.7.9

+-- brace-expansion@1.1.6

+-- braces@1.8.5

+-- browserify-zlib@0.1.4

+-- browserslist@0.4.0

+-- buffer@4.9.1

+-- buffer-shims@1.0.0

+-- camelcase@1.2.1

+-- caniuse-db@1.0.30000569

+-- center-align@0.1.3

+-- chokidar@1.6.1

+-- cliui@2.1.0

| `-- wordwrap@0.0.2

+-- clone@1.0.2

+-- colors@1.1.2

+-- concat-map@0.0.1

+-- console-browserify@1.1.0

+-- constants-browserify@0.0.1

+-- contra@1.9.4

+-- convert-source-map@1.1.3

+-- core-util-is@1.0.2

+-- crossvent@1.5.4

+-- crypto-browserify@3.2.8

+-- css-loader@0.9.1

| `-- source-map@0.1.43

+-- csso@1.3.12

+-- custom-event@1.0.0

+-- d@0.1.1

+-- date-now@0.1.4

+-- decamelize@1.2.0

+-- domain-browser@1.1.7

+-- dragula@3.7.2

+-- emojis-list@2.1.0

+-- enhanced-resolve@2.3.0

+-- errno@0.1.4

+-- es5-ext@0.10.12

+-- es6-iterator@2.0.0

+-- es6-promise@2.3.0

+-- es6-symbol@3.1.0

+-- es6-weak-map@0.1.4

| +-- es6-iterator@0.1.3

| `-- es6-symbol@2.0.1

+-- event-emitter@0.3.4

+-- events@1.1.1

+-- expand-brackets@0.1.5

+-- expand-range@1.8.2

+-- exports-loader@0.6.3

| `-- source-map@0.1.43

+-- expose-loader@0.6.0

+-- extglob@0.3.2

+-- extract-text-webpack-plugin@0.3.8

| `-- source-map@0.1.43

+-- fastparse@1.1.1

+-- file-loader@0.8.5

+-- filename-regex@2.0.0

+-- fill-range@2.2.3

+-- for-in@0.1.6

+-- for-own@0.1.4

+-- glob@4.5.3

+-- glob-base@0.3.0

+-- glob-parent@2.0.0

+-- graceful-fs@4.1.9

+-- has-flag@1.0.0

+-- html-loader@0.2.3

| `-- source-map@0.1.43

+-- html-minifier@0.5.6

+-- http-browserify@1.7.0

+-- https-browserify@0.0.0

+-- ieee754@1.1.8

+-- indexof@0.0.1

+-- inflight@1.0.6

+-- inherits@2.0.3

+-- interpret@0.6.6

+-- is-binary-path@1.0.1

+-- is-buffer@1.1.4

+-- is-dotfile@1.0.2

+-- is-equal-shallow@0.1.3

+-- is-extendable@0.1.1

+-- is-extglob@1.0.0

+-- is-glob@2.0.1

+-- is-number@2.1.0

+-- is-posix-bracket@0.1.1

+-- is-primitive@2.0.0

+-- isarray@1.0.0

+-- isobject@2.1.0

+-- js-base64@2.1.9

+-- json5@0.4.0

+-- kind-of@3.0.4

+-- lazy-cache@1.0.4

+-- loader-utils@0.2.16

| `-- json5@0.5.0

+-- lodash@2.4.2

+-- longest@1.0.1

+-- lru-queue@0.1.0

+-- memoizee@0.3.10

+-- memory-fs@0.3.0

+-- micromatch@2.3.11

+-- mime@1.2.11

+-- minimatch@2.0.10

+-- minimist@0.0.10

+-- mkdirp@0.5.1

| `-- minimist@0.0.8

+-- nan@2.4.0

+-- next-tick@0.2.2

+-- ng-annotate@1.2.1

| `-- source-map@0.5.6

+-- ng-annotate-loader@0.0.10

| `-- source-map@0.4.2

+-- ngtemplate-loader@0.1.3

+-- node-libs-browser@0.6.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- normalize-path@2.0.1

+-- num2fraction@1.2.2

+-- object-assign@4.1.0

+-- object.omit@2.0.1

+-- observable-array@0.0.4

+-- observable-value@0.0.5

+-- once@1.4.0

+-- optimist@0.6.1

+-- ordered-ast-traverse@1.1.1

+-- ordered-esprima-props@1.1.0

+-- os-browserify@0.1.2

+-- pako@0.2.9

+-- parse-glob@3.0.4

+-- path-browserify@0.0.0

+-- path-is-absolute@1.0.1

+-- pbkdf2-compat@2.0.1

+-- phantomjs-polyfill@0.0.2

+-- postcss@4.1.16

+-- preserve@0.2.0

+-- process@0.11.9

+-- process-nextick-args@1.0.7

+-- prr@0.0.0

+-- punycode@1.4.1

+-- querystring@0.2.0

+-- querystring-es3@0.2.1

+-- randomatic@1.1.5

+-- readable-stream@2.1.5

+-- readdirp@2.1.0

| `-- minimatch@3.0.3

+-- regex-cache@0.4.3

+-- repeat-element@1.1.2

+-- repeat-string@1.6.1

+-- right-align@0.1.3

+-- ripemd160@0.2.0

+-- set-immediate-shim@1.0.1

+-- sha.js@2.2.6

+-- shelljs@0.3.0

+-- simple-fmt@0.1.0

+-- simple-is@0.2.0

+-- source-list-map@0.1.6

+-- source-map@0.4.4

+-- source-map-support@0.4.5

| `-- source-map@0.5.6

+-- stable@0.1.5

+-- stream-browserify@1.0.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- string_decoder@0.10.31

+-- stringmap@0.2.2

+-- stringset@0.2.1

+-- style-loader@0.8.3

+-- supports-color@3.1.2

+-- tapable@0.2.4

+-- ticky@1.0.1

+-- timers-browserify@1.4.2

+-- timers-ext@0.1.0

+-- tryor@0.1.2

+-- tty-browserify@0.0.0

+-- typescript@2.0.6

+-- uglify-js@2.7.4

| `-- source-map@0.5.6

+-- uglify-to-browserify@1.0.2

+-- URIjs@1.16.1

+-- url@0.10.3

| `-- punycode@1.3.2

+-- url-loader@0.5.7

+-- util@0.10.3

| `-- inherits@2.0.1

+-- util-deprecate@1.0.2

+-- vm-browserify@0.0.4

+-- watchpack@0.2.9

| `-- async@0.9.2

+-- webpack@1.13.3

| +-- acorn@3.3.0

| +-- async@1.5.2

| +-- enhanced-resolve@0.9.1

| | `-- memory-fs@0.2.0

| `-- tapable@0.1.10

+-- webpack-core@0.6.8

+-- window-size@0.1.0

+-- wordwrap@0.0.3

+-- wrappy@1.0.2

`-- yargs@3.10.0

npm WARN openproject-frontend@0.1.0 No repository field.

npm WARN openproject-frontend@0.1.0 No license field.

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.0.14 (node_modules/fsevents):

npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.0.14: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

-----> Checking startup method

Found Procfile

-----> Finalizing build

Creating runtime environment

Exporting binary paths

Cleaning npm artifacts

Cleaning previous cache

Caching results for future builds

-----> Build succeeded!

openproject@0.1.0 /tmp/d20170210-17-wr9vdm/opt/openproject

`-- typescript@2.0.8

=====> Downloading Buildpack: https://github.com/pkgr/heroku-buildpack-ruby.git

=====> Detected Framework: Ruby

-----> Compiling Ruby/Rails

-----> Using Ruby version: ruby-2.3.1

-----> Installing dependencies using bundler 1.13.2

cp: ‘/tmp/d20170210-17-wr9vdm/opt/openproject/.git/cache/vendor/bundle/.’ and ‘/tmp/d20170210-17-wr9vdm/opt/openproject/.git/cache/vendor/bundle/.’ are the same file

Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Fetching gem metadata from https://rubygems.org/......

Fetching version metadata from https://rubygems.org/..

Fetching dependency metadata from https://rubygems.org/.

Using rake 11.3.0

Using concurrent-ruby 1.0.2

Using i18n 0.7.0

Using minitest 5.9.0

Using thread_safe 0.3.5

Using builder 3.2.2

Using erubis 2.7.0

Using mini_portile2 2.1.0

Using pkg-config 1.1.7

Using rack 2.0.1

Using nio4r 1.2.1

Using websocket-extensions 0.1.2

Using mime-types 2.99.3

Using method_source 0.8.2

Using thor 0.19.1

Using arel 7.1.2

Using multi_json 1.12.1

Using acts_as_silent_list 3.0.0

Using addressable 2.4.0

Using airbrake-ruby 1.5.0

Using attr_required 1.0.1

Using execjs 2.7.0

Using ice_nine 0.11.2

Using bcrypt 3.1.11

Using bindata 2.3.4

Using sass 3.4.22

Using tilt 2.0.5

Using uber 0.0.15

Using erbse 0.0.2

Using coderay 1.1.1

Using color-tools 1.3.0

Using unf_ext 0.0.7.2

Using netrc 0.11.0

Using daemons 1.2.4

Using dalli 2.7.6

Using enumerable-lazy 0.0.1

Using equalizer 0.0.11

Using excon 0.52.0

Using ffi 1.9.14

Using formatador 0.2.5

Using ipaddress 0.8.3

Using get_process_mem 0.2.1

Using request_store 1.3.1

Using json 1.8.3

Using hashie 3.4.6

Using multi_xml 0.5.5

Using gravatar_image_tag 1.2.0

Using bundler 1.13.2

Using htmldiff 0.0.1

Using httpclient 2.8.2.4

Using icalendar 2.3.0

Using iso8601 0.9.1

Using securecompare 1.0.0

Using url_safe_base64 0.2.2

Using kgio 2.10.0

Using mixlib-shellout 2.1.0

Using mysql2 0.4.4

Using net-ldap 0.14.0

Using newrelic_rpm 3.16.2.321

Using oj 2.17.4

Using pdf-core 0.6.1

Using ttfunk 1.4.0

Using rmagick 2.15.4

Using rubyzip 1.2.0

Using ruby-ole 1.2.12

Using pg 0.19.0

Using rails_serve_static_assets 0.0.5

Using rails_stdout_logging 0.0.5

Using raindrops 0.17.0

Using ruby-progressbar 1.8.1

Using structured_warnings 0.2.0

Using sqlite3 1.3.11

Using stringex 2.6.1

Using svg-graph 2.0.1

Using syck 1.0.5

Using will_paginate 3.1.3

Using i18n-js 3.0.0.rc14

Using tzinfo 1.2.2

Using descendants_tracker 0.0.4

Using nokogiri 1.6.8

Using websocket-driver 0.6.4

Using rack-test 0.6.3

Using rack-accept 0.4.5

Using sprockets 3.7.0

Using passenger 5.0.30

Using rack-attack 5.0.1

Using rack-protection 2.0.0.beta2

Using warden 1.2.6

Using mail 2.6.4

Using airbrake 5.1.0

Using autoprefixer-rails 6.4.1.1

Using cells 4.1.3

Using bourbon 4.2.7

Using unf 0.1.4

Using mustermann19 0.4.4

Using sys-filesystem 1.1.7

Using rdoc 4.2.2

Using fog-core 1.42.0

Using omniauth 1.3.1 from https://github.com/oliverguenther/omniauth (at 8385bc0@8385bc0)

Using prawn 2.1.0

Using unicorn 5.1.0

Using rubytree 0.9.7

Using activesupport 5.0.0.1

Using tzinfo-data 1.2016.6

Using axiom-types 0.1.1

Using coercible 1.0.0

Using loofah 2.0.3

Using representable 2.1.8

Using ruby-saml 1.4.0

Using spreadsheet 0.8.9

Using rails_12factor 0.0.3

Using warden-basic_auth 0.2.1

Using cells-erb 0.0.8

Using domain_name 0.5.20161129

Using fog-json 1.0.2

Using fog-xml 0.1.2

Using prawn-table 0.2.2

Using unicorn-worker-killer 0.4.4

Using rails-dom-testing 2.0.1

Using globalid 0.3.7

Using activemodel 5.0.0.1

Using climate_control 0.0.3

Using delayed_job 4.1.2

Using json-jwt 1.6.5

Using rack-oauth2 1.4.0

Using swd 1.0.1

Using webfinger 1.0.2

Using rabl 0.13.0

Using ruby-duration 3.2.3

Using virtus 1.0.5

Using rails-html-sanitizer 1.0.3

Using omniauth-saml 1.6.0 from git://github.com/omniauth/omniauth-saml.git (at master@5559d6b)

Using http-cookie 1.0.3

Using disposable 0.0.9

Using roar 1.0.4

Using fog-aws 0.11.0

Using activejob 5.0.0.1

Using activerecord 5.0.0.1

Using carrierwave 1.0.0.beta from https://github.com/carrierwaveuploader/carrierwave (at master@5367a63)

Using date_validator 0.9.0

Using validate_email 0.1.6

Using validate_url 1.0.2

Using cocaine 0.5.8

Using actionview 5.0.0.1

Using grape 0.17.0

Using openproject-auth_saml 0.1.0 from https://github.com/finnlabs/openproject-auth_saml (at dev@97212ab)

Using rest-client 1.8.0

Using reform 1.2.6

Using activemodel-serializers-xml 1.0.1

Using acts_as_list 0.8.1

Using acts_as_tree 2.5.1

Using awesome_nested_set 3.1.1

Using delayed_job_active_record 4.1.1

Using friendly_id 5.2.0.beta.1 from https://github.com/norman/friendly_id (at aff0564@aff0564)

Using globalize 5.1.0 from https://github.com/globalize/globalize (at 38443bc@38443bc)

Using transactional_lock 0.1.0 from https://github.com/finnlabs/transactional_lock.git (at master@6948b1d)

Using actionpack 5.0.0.1

Using openid_connect 0.8.3

Using grape-cache_control 1.0.1

Using crowdin-api 0.4.1

Using actioncable 5.0.0.1

Using actionmailer 5.0.0.1

Using railties 5.0.0.1

Using cells-rails 0.0.6

Using gon 4.1.1

Using sprockets-rails 3.2.0

Using omniauth-openid-connect 0.2.0 from https://github.com/finnlabs/omniauth-openid-connect.git (at dev@c3bce4c)

Using actionpack-xml_parser 2.0.0

Using activerecord-session_store 1.0.0

Using jquery-tablesorter 1.22.7

Using responders 2.3.0

Using omniauth-openid_connect-providers 0.1.0 from https://github.com/finnlabs/omniauth-openid_connect-providers.git (at dev@86f3670)

Using rails 5.0.0.1

Using sass-rails 5.0.6

Using health_check 2.2.1

Using lobby_boy 0.1.2

Using openproject-auth_plugins 6.1.4 from source at `vendored-plugins/openproject-auth_plugins`

Using openproject-pdf_export 6.1.4 from source at `vendored-plugins/openproject-pdf_export`

Using openproject-costs 6.1.4 from source at `vendored-plugins/openproject-costs`

Using openproject-documents 6.1.4 from source at `vendored-plugins/openproject-documents`

Using openproject-webhooks 6.1.4 from source at `vendored-plugins/openproject-webhooks`

Using openproject-global_roles 6.1.4 from source at `vendored-plugins/openproject-global_roles`

Using openproject-local_avatars 6.1.4 from source at `vendored-plugins/openproject-local_avatars`

Using openproject-meeting 6.1.4 from source at `vendored-plugins/openproject-meeting`

Using openproject-my_project_page 6.1.4 from source at `vendored-plugins/openproject-my_project_page`

Using reporting_engine 6.1.4 from source at `vendored-plugins/reporting_engine`

Using openproject-themes-dark 6.1.4 from source at `vendored-plugins/openproject-themes-dark`

Using openproject-translations 6.1.4 from https://github.com/opf/openproject-translations.git (at stable/6@da52ff9)

Using openproject-xls_export 6.1.4 from source at `vendored-plugins/openproject-xls_export`

Using rails-angular-xss 0.3.0.pre.pre from https://github.com/opf/rails-angular-xss (at a45267d@a45267d)

Using rails_autolink 1.1.6

Using openproject-openid_connect 6.1.4 from source at `vendored-plugins/openproject-openid_connect`

Using openproject-backlogs 6.1.4 from source at `vendored-plugins/openproject-backlogs`

Using openproject-github_integration 6.1.4 from source at `vendored-plugins/openproject-github_integration`

Using openproject-reporting 6.1.4 from source at `vendored-plugins/openproject-reporting`

Bundle complete! 138 Gemfile dependencies, 195 gems now installed.

Gems in the groups development and test were not installed.

Bundled gems are installed into ./vendor/bundle.

Bundle completed (6.78s)

Cleaning up the bundler cache.

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

-----> Detecting rake tasks

-----> Preparing app for Rails asset pipeline

Running: rake assets:precompile

$(npm bin)/webpack --config webpack.production.config.js

{"omniauth-openid-connect":"/tmp/d20170210-17-wr9vdm/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid-connect-c3bce4c9e9ac","omniauth-openid_connect-providers":"/tmp/d20170210-17-wr9vdm/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid_connect-providers-86f3670e127e","omniauth-saml":"/tmp/d20170210-17-wr9vdm/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-saml-5559d6b80805","openproject-auth_plugins":"/tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-auth_plugins","openproject-auth_saml":"/tmp/d20170210-17-wr9vdm/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-auth_saml-97212abb8378","openproject-pdf_export":"/tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-pdf_export","openproject-backlogs":"/tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-backlogs","openproject-costs":"/tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-costs","openproject-documents":"/tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-documents","openproject-webhooks":"/tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-webhooks","openproject-github_integration":"/tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-github_integration","openproject-global_roles":"/tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-global_roles","openproject-local_avatars":"/tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-local_avatars","openproject-meeting":"/tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-meeting","openproject-my_project_page":"/tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-my_project_page","openproject-openid_connect":"/tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-openid_connect","reporting_engine":"/tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/reporting_engine","openproject-reporting":"/tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-reporting","openproject-themes-dark":"/tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-themes-dark","openproject-translations":"/tmp/d20170210-17-wr9vdm/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-translations-da52ff92cdcd","openproject-xls_export":"/tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-xls_export"}

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Hash: f2179b9b4e2b97c8a99a

Version: webpack 1.13.3

Child

Hash: f2179b9b4e2b97c8a99a

Version: webpack 1.13.3

Time: 13855ms

Asset Size Chunks Chunk Names

7b9776076d5fceef4993b55c9383dedd.gif 1.85 kB [emitted]

openproject-backlogs.js 453 kB 0 [emitted] backlogs

openproject-core-app.js 3.43 MB 1 [emitted] core-app

openproject-costs.js 526 kB 2 [emitted] costs

openproject-global.js 3.51 MB 3 [emitted] global

openproject-my_project_page.js 14.3 kB 4 [emitted] my_project_page

openproject-core-app.css 4.71 kB 1 [emitted] core-app

openproject-global.css 49 kB 3 [emitted] global

[213] ./templates \.html$ 1.22 kB {1} [built]

[242] ./components ^((?!\.(test|spec)).)*\.(js|ts|html)$ 16.1 kB {1} [built]

[633] /tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 425 bytes {2} [built]

[765] /tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 330 bytes {4} [built]

+ 769 hidden modules

ERROR in [default]

File '/tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-budget-subform.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-wr9vdm/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-wr9vdm/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/subform/cost-subform.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-wr9vdm/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts' is not under 'rootDir' '/tmp/d20170210-17-wr9vdm/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts' is not under 'rootDir' '/tmp/d20170210-17-wr9vdm/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-block.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-wr9vdm/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-page-layout.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-wr9vdm/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-textile-block.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-wr9vdm/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default] /tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:49:18

Argument of type 'string' is not assignable to parameter of type '{ [key: string]: any; }'.

ERROR in [default] /tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:53:4

Supplied parameters do not match any signature of call target.

ERROR in [default] /tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:30:38

Cannot find module 'app/components/work-packages/work-package-cache.service'.

ERROR in [default] /tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:49:30

Cannot find name 'HalResource'.

ERROR in [default] /tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:54:57

Property '$injector' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:13

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:27

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:60:11

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:70:23

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:76:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:77:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:78:16

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:36:17

Property 'value' does not exist on type 'CurrencyDisplayField'.

ERROR in [default] /tmp/d20170210-17-wr9vdm/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:37:23

Property 'value' does not exist on type 'CurrencyDisplayField'.

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 5 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

I, [2017-02-10T13:08:55.934710 #2237] INFO -- : Writing /tmp/d20170210-17-wr9vdm/opt/openproject/public/assets/application-79bf292fc4ef2681c3672464c2ddd22e2a6e408b9016682c80c973d1d6de9bc3.js

I, [2017-02-10T13:08:55.935350 #2237] INFO -- : Writing /tmp/d20170210-17-wr9vdm/opt/openproject/public/assets/application-79bf292fc4ef2681c3672464c2ddd22e2a6e408b9016682c80c973d1d6de9bc3.js.gz

Asset precompilation completed (27.84s)

Cleaning assets

Running: rake assets:clean

I, [2017-02-10T13:09:07.190535 #2409] INFO -- : Removed application-3cfcb126fa882ec3132eb54903828743e16007dd66cdce86f8bf270f0e5d07e9.js

Using release configuration from last framework (Ruby).

-----> [cron] /opt/openproject/packaging/cron/openproject-clear-old-sessions => /etc/cron.d/openproject-clear-old-sessions

NEW PACKAGE: openproject-6.1.4-1486730985.5bf684b.sles12.x86_64.rpm (289.62 MiB)

-----> Releasing...

DONE!

====== Attempt #1

-----> Fetching repository

Cloning into '/tmp/d20170210-16665-ec586r/input'...

-----> Restoring cache

-----> Starting packaging process

-----> Installing missing build dependencies: libmagickwand-dev, libsqlite3-dev

-----> [wizard] adding legacy-installer wizard (https://github.com/pkgr/addon-legacy-installer#master)

-----> [wizard] adding mysql wizard (https://github.com/pkgr/addon-mysql#master)

-----> [wizard] adding apache2 wizard (https://github.com/pkgr/addon-apache2#master)

-----> [wizard] adding repositories wizard (https://github.com/finnlabs/addon-repositories#master)

-----> [wizard] adding smtp wizard (https://github.com/pkgr/addon-smtp#master)

-----> [wizard] adding memcached wizard (https://github.com/pkgr/addon-memcached#master)

-----> [wizard] adding openproject wizard (https://github.com/pkgr/addon-openproject#master)

-----> Fetching buildpack https://github.com/opf/heroku-buildpack-multi.git at master

-----> Multipack app

-----> Running hook: "packaging/setup"

WARNING: This buildpack is no longer maintained.

Please choose a different buildpack or go to https://github.com/ddollar/heroku-buildpack-multi

and fork it to your own account.

=====> Downloading Buildpack: https://github.com/pkgr/pkgr-buildpack-imagemagick.git

=====> Detected Framework: ImageMagick

-----> SKIP

=====> Downloading Buildpack: https://github.com/heroku/heroku-buildpack-nodejs.git

=====> Detected Framework: Node.js

-----> Reading application state

package.json...

build directory...

cache directory...

environment variables...

Node engine: 6.9.1

Npm engine: 4.0.0

Start mechanism: Procfile

node_modules source: package.json

node_modules cached: true

NPM_CONFIG_PRODUCTION=true

NODE_MODULES_CACHE=true

-----> Installing binaries

Downloading and installing node 6.9.1...

Downloading and installing npm 4.0.0 (replacing version 3.10.8)...

-----> Building dependencies

Restoring node modules from cache

Pruning unused dependencies

Installing any new modules

> openproject@0.1.0 postinstall /tmp/d20170210-17-bzdjkf/opt/openproject

> cd frontend && npm install

> openproject-frontend@0.1.0 postinstall /tmp/d20170210-17-bzdjkf/opt/openproject/frontend

> bower install --config.interactive=false

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 not-cached git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolve git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de not-cached git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolve git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 not-cached git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolve git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 checkout d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower jquery#1.11.0 not-cached https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery#1.11.0 resolve https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery-ui#~1.10.4 not-cached https://github.com/components/jqueryui.git#~1.10.4

bower jquery-ui#~1.10.4 resolve https://github.com/components/jqueryui.git#~1.10.4

bower jquery-ujs#1.0.0 not-cached https://github.com/rails/jquery-ujs.git#1.0.0

bower jquery-ujs#1.0.0 resolve https://github.com/rails/jquery-ujs.git#1.0.0

bower select2#3.5.2 not-cached https://github.com/ivaynberg/select2.git#3.5.2

bower select2#3.5.2 resolve https://github.com/ivaynberg/select2.git#3.5.2

bower angular#~1.5.8 not-cached https://github.com/angular/bower-angular.git#~1.5.8

bower angular#~1.5.8 resolve https://github.com/angular/bower-angular.git#~1.5.8

bower jquery.atwho#0.5.1 not-cached https://github.com/ichord/At.js.git#0.5.1

bower jquery.atwho#0.5.1 resolve https://github.com/ichord/At.js.git#0.5.1

bower angular-i18n#~1.5.5 not-cached https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-i18n#~1.5.5 resolve https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-sanitize#~1.5.8 not-cached https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-sanitize#~1.5.8 resolve https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-elastic#~2.5.1 not-cached https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-elastic#~2.5.1 resolve https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-aria#~1.5.8 not-cached https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-aria#~1.5.8 resolve https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-animate#~1.5.8 not-cached https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-animate#~1.5.8 resolve https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-cache#~4.6.0 not-cached https://github.com/jmdobry/angular-cache.git#~4.6.0

bower angular-cache#~4.6.0 resolve https://github.com/jmdobry/angular-cache.git#~4.6.0

bower jquery-migrate#~1.2.1 not-cached https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower jquery-migrate#~1.2.1 resolve https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower moment#~2.10.6 not-cached https://github.com/moment/moment.git#~2.10.6

bower moment#~2.10.6 resolve https://github.com/moment/moment.git#~2.10.6

bower moment-timezone#0.4.x not-cached https://github.com/moment/moment-timezone.git#0.4.x

bower moment-timezone#0.4.x resolve https://github.com/moment/moment-timezone.git#0.4.x

bower angular-busy#~4.1.3 not-cached https://github.com/cgross/angular-busy.git#~4.1.3

bower angular-busy#~4.1.3 resolve https://github.com/cgross/angular-busy.git#~4.1.3

bower lodash#~2.4.1 not-cached https://github.com/lodash/lodash.git#~2.4.1

bower lodash#~2.4.1 resolve https://github.com/lodash/lodash.git#~2.4.1

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de checkout fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 checkout a908eccaec323cd66973d58af4965694bdff16a1

bower foundation-apps#1.1.0 not-cached https://github.com/zurb/foundation-apps.git#1.1.0

bower foundation-apps#1.1.0 resolve https://github.com/zurb/foundation-apps.git#1.1.0

bower bourbon#~4.2.1 not-cached https://github.com/thoughtbot/bourbon.git#~4.2.1

bower bourbon#~4.2.1 resolve https://github.com/thoughtbot/bourbon.git#~4.2.1

bower angular-ui-select#~0.19.4 not-cached https://github.com/angular-ui/ui-select.git#~0.19.4

bower angular-ui-select#~0.19.4 resolve https://github.com/angular-ui/ui-select.git#~0.19.4

bower rxjs#^4.1.0 not-cached https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower rxjs#^4.1.0 resolve https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower ng-file-upload#~5.0.9 not-cached https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower ng-file-upload#~5.0.9 resolve https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower mousetrap#~1.4.6 not-cached https://github.com/ccampbell/mousetrap.git#~1.4.6

bower mousetrap#~1.4.6 resolve https://github.com/ccampbell/mousetrap.git#~1.4.6

bower mocha#~1.14.0 not-cached https://github.com/mochajs/mocha.git#~1.14.0

bower mocha#~1.14.0 resolve https://github.com/mochajs/mocha.git#~1.14.0

bower angular-dragula#^1.2.8 not-cached https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower angular-dragula#^1.2.8 resolve https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower ng-dialog#^0.6.2 not-cached https://github.com/likeastore/ngDialog.git#^0.6.2

bower ng-dialog#^0.6.2 resolve https://github.com/likeastore/ngDialog.git#^0.6.2

bower angular-mocks#~1.5.8 not-cached https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower angular-mocks#~1.5.8 resolve https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower chai#~1.9.0 not-cached https://github.com/chaijs/chai.git#~1.9.0

bower chai#~1.9.0 resolve https://github.com/chaijs/chai.git#~1.9.0

bower jquery-mockjax#~1.5.3 not-cached https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery-mockjax#~1.5.3 resolve https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery#1.11.0 checkout 1.11.0

bower jquery-ui#~1.10.4 checkout 1.10.4

bower jquery-ujs#1.0.0 checkout v1.0.0

bower jquery.atwho#0.5.1 checkout v0.5.1

bower select2#3.5.2 checkout 3.5.2

bower angular#~1.5.8 checkout v1.5.11

bower angular-aria#~1.5.8 checkout v1.5.11

bower angular-elastic#~2.5.1 checkout v2.5.1

bower angular-sanitize#~1.5.8 checkout v1.5.11

bower angular-i18n#~1.5.5 checkout v1.5.11

bower moment-timezone#0.4.x checkout 0.4.1

bower moment#~2.10.6 checkout 2.10.6

bower jquery-migrate#~1.2.1 checkout 1.2.1

bower angular-cache#~4.6.0 checkout 4.6.0

bower angular-animate#~1.5.8 checkout v1.5.11

bower angular-ui-select#~0.19.4 checkout v0.19.6

bower bourbon#~4.2.1 checkout v4.2.7

bower foundation-apps#1.1.0 checkout v1.1.0

bower lodash#~2.4.1 checkout 2.4.2

bower angular-busy#~4.1.3 checkout v4.1.4

bower rxjs#^4.1.0 checkout v4.1.0

bower mousetrap#~1.4.6 checkout 1.4.6

bower ng-file-upload#~5.0.9 checkout 5.0.9

bower angular-dragula#^1.2.8 checkout v1.2.8

bower mocha#~1.14.0 checkout 1.14.0

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolved git://github.com/finnlabs/angular-modal.git#d45eb9ceb7

bower angular#^1.3.0 not-cached https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 resolve https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 checkout v1.6.2

bower chai#~1.9.0 checkout 1.9.2

bower jquery-mockjax#~1.5.3 checkout v1.5.4

bower ng-dialog#^0.6.2 checkout v0.6.6

bower angular-mocks#~1.5.8 checkout v1.5.11

bower jquery.atwho#0.5.1 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .png files: ["select2.png","select2x2.png"]

bower angular-ui-router#~0.3.1 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-ui-router#~0.3.1 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower jquery-ui#~1.10.4 resolved https://github.com/components/jqueryui.git#1.10.4

bower select2#3.5.2 resolved https://github.com/ivaynberg/select2.git#3.5.2

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolved git://github.com/sparkalow/angular-truncate.git#fdf60fda26

bower jquery-ujs#1.0.0 resolved https://github.com/rails/jquery-ujs.git#1.0.0

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolved git://github.com/nickmessing/angular-context-menu.git#a908eccaec

bower angular#>= 1.2.5 not-cached https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 resolve https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 checkout v1.6.2

bower jquery.atwho#0.5.1 resolved https://github.com/ichord/At.js.git#0.5.1

bower jquery#1.11.0 resolved https://github.com/jquery/jquery-dist.git#1.11.0

bower Caret.js#>= 0.2.0 not-cached https://github.com/ichord/Caret.js.git#>= 0.2.0

bower Caret.js#>= 0.2.0 resolve https://github.com/ichord/Caret.js.git#>= 0.2.0

bower angular-elastic#~2.5.1 resolved https://github.com/monospaced/angular-elastic.git#2.5.1

bower angular#>=1.0.6 not-cached https://github.com/angular/bower-angular.git#>=1.0.6

bower angular#>=1.0.6 resolve https://github.com/angular/bower-angular.git#>=1.0.6

bower angular#>=1.0.6 checkout v1.6.2

bower angular-aria#~1.5.8 resolved https://github.com/angular/bower-angular-aria.git#1.5.11

bower angular-sanitize#~1.5.8 resolved https://github.com/angular/bower-angular-sanitize.git#1.5.11

bower angular#~1.5.8 resolved https://github.com/angular/bower-angular.git#1.5.11

bower angular-cache#~4.6.0 resolved https://github.com/jmdobry/angular-cache.git#4.6.0

bower jquery-migrate#~1.2.1 deprecated Package jquery-migrate is using the deprecated component.json

bower jquery-migrate#~1.2.1 resolved https://github.com/appleboy/jquery-migrate.git#1.2.1

bower moment-timezone#0.4.x resolved https://github.com/moment/moment-timezone.git#0.4.1

bower moment#>= 2.6.0 not-cached https://github.com/moment/moment.git#>= 2.6.0

bower moment#>= 2.6.0 resolve https://github.com/moment/moment.git#>= 2.6.0

bower moment#>= 2.6.0 checkout 2.17.1

bower angular-animate#~1.5.8 resolved https://github.com/angular/bower-angular-animate.git#1.5.11

bower moment#~2.10.6 resolved https://github.com/moment/moment.git#2.10.6

bower angular-ui-select#~0.19.4 resolved https://github.com/angular-ui/ui-select.git#0.19.6

bower bourbon#~4.2.1 resolved https://github.com/thoughtbot/bourbon.git#4.2.7

bower foundation-apps#1.1.0 resolved https://github.com/zurb/foundation-apps.git#1.1.0

bower angular#~1.3.4 not-cached https://github.com/angular/bower-angular.git#~1.3.4

bower angular#~1.3.4 resolve https://github.com/angular/bower-angular.git#~1.3.4

bower angular-ui-router#~0.2.12 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-ui-router#~0.2.12 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-animate#~1.3.4 not-cached https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular-animate#~1.3.4 resolve https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular#~1.3.4 checkout v1.3.20

bower angular-animate#~1.3.4 checkout v1.3.20

bower mousetrap#~1.4.6 resolved https://github.com/ccampbell/mousetrap.git#1.4.6

bower ng-file-upload#~5.0.9 resolved https://github.com/danialfarid/angular-file-upload-bower.git#5.0.9

bower fastclick#~1.0.3 not-cached https://github.com/ftlabs/fastclick.git#~1.0.3

bower fastclick#~1.0.3 resolve https://github.com/ftlabs/fastclick.git#~1.0.3

bower lodash#~2.4.1 resolved https://github.com/lodash/lodash.git#2.4.2

bower tether#~0.6.5 not-cached https://github.com/HubSpot/tether.git#~0.6.5

bower tether#~0.6.5 resolve https://github.com/HubSpot/tether.git#~0.6.5

bower angular-busy#~4.1.3 resolved https://github.com/cgross/angular-busy.git#4.1.4

bower viewport-units-buggyfill#~0.4.1 not-cached https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower viewport-units-buggyfill#~0.4.1 resolve https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower hammerjs#~2.0.4 not-cached https://github.com/EightMedia/hammer.js.git#~2.0.4

bower hammerjs#~2.0.4 resolve https://github.com/EightMedia/hammer.js.git#~2.0.4

bower angular-dragula#^1.2.8 resolved https://github.com/bevacqua/angular-dragula.git#1.2.8

bower mocha#~1.14.0 mismatch Version declared in the json (1.12.0) is different than the resolved one (1.14.0)

bower mocha#~1.14.0 resolved https://github.com/mochajs/mocha.git#1.14.0

bower chai#~1.9.0 resolved https://github.com/chaijs/chai.git#1.9.2

bower angular-i18n#~1.5.5 resolved https://github.com/angular/bower-angular-i18n.git#1.5.11

bower ng-dialog#^0.6.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .css files: ["css/ngDialog.css","css/ngDialog-theme-default.css"]

bower angular-ui-router#~0.2.12 checkout 0.2.18

bower angular-ui-router#~0.3.1 checkout 0.3.2

bower jquery-mockjax#~1.5.3 resolved https://github.com/jakerella/jquery-mockjax.git#1.5.4

bower ng-dialog#^0.6.2 resolved https://github.com/likeastore/ngDialog.git#0.6.6

bower angular#^1.3.0 resolved https://github.com/angular/bower-angular.git#1.6.2

bower Caret.js#>= 0.2.0 checkout v0.3.1

bower angular-mocks#~1.5.8 resolved https://github.com/angular/bower-angular-mocks.git#1.5.11

bower rxjs#^4.1.0 resolved https://github.com/Reactive-Extensions/RxJS.git#4.1.0

bower angular#>= 1.2.5 resolved https://github.com/angular/bower-angular.git#1.6.2

bower fastclick#~1.0.3 checkout v1.0.6

bower angular#~1.3.4 resolved https://github.com/angular/bower-angular.git#1.3.20

bower angular#>=1.0.6 resolved https://github.com/angular/bower-angular.git#1.6.2

bower angular-animate#~1.3.4 resolved https://github.com/angular/bower-angular-animate.git#1.3.20

bower moment#>= 2.6.0 resolved https://github.com/moment/moment.git#2.17.1

bower tether#~0.6.5 checkout v0.6.5

bower viewport-units-buggyfill#~0.4.1 checkout v0.4.1

bower hammerjs#~2.0.4 checkout v2.0.8

bower angular-ui-router#~0.2.12 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.2.18

bower Caret.js#>= 0.2.0 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower Caret.js#>= 0.2.0 resolved https://github.com/ichord/Caret.js.git#0.3.1

bower fastclick#~1.0.3 resolved https://github.com/ftlabs/fastclick.git#1.0.6

bower tether#~0.6.5 resolved https://github.com/HubSpot/tether.git#0.6.5

bower angular-ui-router#~0.3.1 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.3.2

bower viewport-units-buggyfill#~0.4.1 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .js files: ["./viewport-units-buggyfill.js","./viewport-units-buggyfill.hacks.js"]

bower viewport-units-buggyfill#~0.4.1 resolved https://github.com/rodneyrehm/viewport-units-buggyfill.git#0.4.1

bower hammerjs#~2.0.4 resolved https://github.com/EightMedia/hammer.js.git#2.0.8

Please note that,

angular-animate#1.3.20 depends on angular#1.3.20 which resolved to angular#1.3.20

foundation-apps#1.1.0 depends on angular#~1.3.4 which resolved to angular#1.3.20

angular-animate#1.5.11, angular-aria#1.5.11, angular-mocks#1.5.11, angular-sanitize#1.5.11 depends on angular#1.5.11 which resolved to angular#1.5.11

angular-ui-router#0.2.18, angular-ui-router#0.3.2 depends on angular#^1.0.8 which resolved to angular#1.5.11

angular-ui-select#0.19.6 depends on angular#>=1.2.18 which resolved to angular#1.5.11

angular-busy#4.1.4 depends on angular#>=1.3 which resolved to angular#1.5.11

ng-dialog#0.6.6 depends on angular#>=1.5 which resolved to angular#1.5.11

openproject depends on angular#~1.5.8 which resolved to angular#1.5.11

angular-cache#4.6.0 depends on angular#>=1.x which resolved to angular#1.5.11

angular-context-menu#a908eccaec depends on angular#>= 1.2.5 which resolved to angular#1.6.2

angular-elastic#2.5.1 depends on angular#>=1.0.6 which resolved to angular#1.6.2

angular-modal#d45eb9ceb7 depends on angular#^1.3.0 which resolved to angular#1.6.2

Resort to using angular#~1.5.8 which resolved to angular#1.5.11

Code incompatibilities may occur.

Please note that,

foundation-apps#1.1.0 depends on angular-animate#~1.3.4 which resolved to angular-animate#1.3.20

openproject depends on angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

angular-busy#4.1.4 depends on angular-animate#>=1.3 which resolved to angular-animate#1.5.11

Resort to using angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

Code incompatibilities may occur.

Please note that,

foundation-apps#1.1.0 depends on angular-ui-router#~0.2.12 which resolved to angular-ui-router#0.2.18

openproject depends on angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Resort to using angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Code incompatibilities may occur.

bower jquery extra-resolution Unnecessary resolution: jquery#1.11.0

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 install angular-modal#d45eb9ceb7

bower jquery-ui#~1.10.4 install jquery-ui#1.10.4

bower select2#3.5.2 install select2#3.5.2

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de install angular-truncate#fdf60fda26

bower jquery-ujs#1.0.0 install jquery-ujs#1.0.0

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 install angular-context-menu#a908eccaec

bower jquery.atwho#0.5.1 install jquery.atwho#0.5.1

bower jquery#1.11.0 install jquery#1.11.0

bower angular-elastic#~2.5.1 install angular-elastic#2.5.1

bower angular-aria#~1.5.8 install angular-aria#1.5.11

bower angular-sanitize#~1.5.8 install angular-sanitize#1.5.11

bower angular#1.5.11 install angular#1.5.11

bower angular-cache#~4.6.0 install angular-cache#4.6.0

bower jquery-migrate#~1.2.1 install jquery-migrate#1.2.1

bower moment-timezone#0.4.x install moment-timezone#0.4.1

bower angular-animate#~1.5.8 install angular-animate#1.5.11

bower moment#~2.10.6 install moment#2.10.6

bower angular-ui-select#~0.19.4 install angular-ui-select#0.19.6

bower bourbon#~4.2.1 install bourbon#4.2.7

bower foundation-apps#1.1.0 install foundation-apps#1.1.0

bower mousetrap#~1.4.6 install mousetrap#1.4.6

bower ng-file-upload#~5.0.9 install ng-file-upload#5.0.9

bower lodash#~2.4.1 install lodash#2.4.2

bower angular-busy#~4.1.3 install angular-busy#4.1.4

bower angular-dragula#^1.2.8 install angular-dragula#1.2.8

bower mocha#~1.14.0 install mocha#1.14.0

bower chai#~1.9.0 install chai#1.9.2

bower angular-i18n#~1.5.5 install angular-i18n#1.5.11

bower jquery-mockjax#~1.5.3 install jquery-mockjax#1.5.4

bower ng-dialog#^0.6.2 install ng-dialog#0.6.6

bower angular-mocks#~1.5.8 install angular-mocks#1.5.11

bower rxjs#^4.1.0 install rxjs#4.1.0

bower angular-ui-router#~0.3.1 install angular-ui-router#0.3.2

bower Caret.js#>= 0.2.0 install Caret.js#0.3.1

bower fastclick#~1.0.3 install fastclick#1.0.6

bower tether#~0.6.5 install tether#0.6.5

bower viewport-units-buggyfill#~0.4.1 install viewport-units-buggyfill#0.4.1

bower hammerjs#~2.0.4 install hammerjs#2.0.8

angular-modal#d45eb9ceb7 bower_components/angular-modal

└── angular#1.5.11

jquery-ui#1.10.4 bower_components/jquery-ui

└── jquery#1.11.0

select2#3.5.2 bower_components/select2

└── jquery#1.11.0

angular-truncate#fdf60fda26 bower_components/angular-truncate

jquery-ujs#1.0.0 bower_components/jquery-ujs

└── jquery#1.11.0

angular-context-menu#a908eccaec bower_components/angular-context-menu

└── angular#1.5.11

jquery.atwho#0.5.1 bower_components/jquery.atwho

├── Caret.js#0.3.1

└── jquery#1.11.0

jquery#1.11.0 bower_components/jquery

angular-elastic#2.5.1 bower_components/angular-elastic

└── angular#1.5.11

angular-aria#1.5.11 bower_components/angular-aria

└── angular#1.5.11

angular-sanitize#1.5.11 bower_components/angular-sanitize

└── angular#1.5.11

angular#1.5.11 bower_components/angular

angular-cache#4.6.0 bower_components/angular-cache

└── angular#1.5.11

jquery-migrate#1.2.1 bower_components/jquery-migrate

moment-timezone#0.4.1 bower_components/moment-timezone

└── moment#2.10.6

angular-animate#1.5.11 bower_components/angular-animate

└── angular#1.5.11

moment#2.10.6 bower_components/moment

angular-ui-select#0.19.6 bower_components/angular-ui-select

└── angular#1.5.11

bourbon#4.2.7 bower_components/bourbon

foundation-apps#1.1.0 bower_components/foundation-apps

├── angular#1.5.11

├── angular-animate#1.5.11

├── angular-ui-router#0.3.2

├── fastclick#1.0.6

├── hammerjs#2.0.8

├── tether#0.6.5

└── viewport-units-buggyfill#0.4.1

mousetrap#1.4.6 bower_components/mousetrap

ng-file-upload#5.0.9 bower_components/ng-file-upload

lodash#2.4.2 bower_components/lodash

angular-busy#4.1.4 bower_components/angular-busy

├── angular#1.5.11

└── angular-animate#1.5.11

angular-dragula#1.2.8 bower_components/angular-dragula

mocha#1.14.0 bower_components/mocha

chai#1.9.2 bower_components/chai

angular-i18n#1.5.11 bower_components/angular-i18n

jquery-mockjax#1.5.4 bower_components/jquery-mockjax

ng-dialog#0.6.6 bower_components/ng-dialog

└── angular#1.5.11

angular-mocks#1.5.11 bower_components/angular-mocks

└── angular#1.5.11

rxjs#4.1.0 bower_components/rxjs

angular-ui-router#0.3.2 bower_components/angular-ui-router

└── angular#1.5.11

Caret.js#0.3.1 bower_components/Caret.js

└── jquery#1.11.0

fastclick#1.0.6 bower_components/fastclick

tether#0.6.5 bower_components/tether

viewport-units-buggyfill#0.4.1 bower_components/viewport-units-buggyfill

hammerjs#2.0.8 bower_components/hammerjs

openproject-frontend@0.1.0 /tmp/d20170210-17-bzdjkf/opt/openproject/frontend

+-- acorn@2.6.4

+-- align-text@0.1.4

+-- alter@0.2.0

+-- amdefine@1.0.0

+-- angular@1.5.8

+-- angular-elastic@2.5.1

+-- angular-ui-bootstrap@2.2.0

+-- anymatch@1.3.0

+-- arr-diff@2.0.0

+-- arr-flatten@1.0.1

+-- array-unique@0.2.1

+-- arrify@1.0.1

+-- assert@1.4.1

+-- async@0.2.10

+-- async-each@1.0.1

+-- atoa@1.0.0

+-- autoprefixer-core@5.2.1

+-- autoprefixer-loader@1.2.0

+-- awesome-typescript-loader@2.2.4

| `-- lodash@4.16.4

+-- balanced-match@0.4.2

+-- Base64@0.2.1

+-- base64-js@1.2.0

+-- big.js@3.1.3

+-- binary-extensions@1.7.0

+-- bower@1.7.9

+-- brace-expansion@1.1.6

+-- braces@1.8.5

+-- browserify-zlib@0.1.4

+-- browserslist@0.4.0

+-- buffer@4.9.1

+-- buffer-shims@1.0.0

+-- camelcase@1.2.1

+-- caniuse-db@1.0.30000569

+-- center-align@0.1.3

+-- chokidar@1.6.1

+-- cliui@2.1.0

| `-- wordwrap@0.0.2

+-- clone@1.0.2

+-- colors@1.1.2

+-- concat-map@0.0.1

+-- console-browserify@1.1.0

+-- constants-browserify@0.0.1

+-- contra@1.9.4

+-- convert-source-map@1.1.3

+-- core-util-is@1.0.2

+-- crossvent@1.5.4

+-- crypto-browserify@3.2.8

+-- css-loader@0.9.1

| `-- source-map@0.1.43

+-- csso@1.3.12

+-- custom-event@1.0.0

+-- d@0.1.1

+-- date-now@0.1.4

+-- decamelize@1.2.0

+-- domain-browser@1.1.7

+-- dragula@3.7.2

+-- emojis-list@2.1.0

+-- enhanced-resolve@2.3.0

+-- errno@0.1.4

+-- es5-ext@0.10.12

+-- es6-iterator@2.0.0

+-- es6-promise@2.3.0

+-- es6-symbol@3.1.0

+-- es6-weak-map@0.1.4

| +-- es6-iterator@0.1.3

| `-- es6-symbol@2.0.1

+-- event-emitter@0.3.4

+-- events@1.1.1

+-- expand-brackets@0.1.5

+-- expand-range@1.8.2

+-- exports-loader@0.6.3

| `-- source-map@0.1.43

+-- expose-loader@0.6.0

+-- extglob@0.3.2

+-- extract-text-webpack-plugin@0.3.8

| `-- source-map@0.1.43

+-- fastparse@1.1.1

+-- file-loader@0.8.5

+-- filename-regex@2.0.0

+-- fill-range@2.2.3

+-- for-in@0.1.6

+-- for-own@0.1.4

+-- glob@4.5.3

+-- glob-base@0.3.0

+-- glob-parent@2.0.0

+-- graceful-fs@4.1.9

+-- has-flag@1.0.0

+-- html-loader@0.2.3

| `-- source-map@0.1.43

+-- html-minifier@0.5.6

+-- http-browserify@1.7.0

+-- https-browserify@0.0.0

+-- ieee754@1.1.8

+-- indexof@0.0.1

+-- inflight@1.0.6

+-- inherits@2.0.3

+-- interpret@0.6.6

+-- is-binary-path@1.0.1

+-- is-buffer@1.1.4

+-- is-dotfile@1.0.2

+-- is-equal-shallow@0.1.3

+-- is-extendable@0.1.1

+-- is-extglob@1.0.0

+-- is-glob@2.0.1

+-- is-number@2.1.0

+-- is-posix-bracket@0.1.1

+-- is-primitive@2.0.0

+-- isarray@1.0.0

+-- isobject@2.1.0

+-- js-base64@2.1.9

+-- json5@0.4.0

+-- kind-of@3.0.4

+-- lazy-cache@1.0.4

+-- loader-utils@0.2.16

| `-- json5@0.5.0

+-- lodash@2.4.2

+-- longest@1.0.1

+-- lru-queue@0.1.0

+-- memoizee@0.3.10

+-- memory-fs@0.3.0

+-- micromatch@2.3.11

+-- mime@1.2.11

+-- minimatch@2.0.10

+-- minimist@0.0.10

+-- mkdirp@0.5.1

| `-- minimist@0.0.8

+-- nan@2.4.0

+-- next-tick@0.2.2

+-- ng-annotate@1.2.1

| `-- source-map@0.5.6

+-- ng-annotate-loader@0.0.10

| `-- source-map@0.4.2

+-- ngtemplate-loader@0.1.3

+-- node-libs-browser@0.6.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- normalize-path@2.0.1

+-- num2fraction@1.2.2

+-- object-assign@4.1.0

+-- object.omit@2.0.1

+-- observable-array@0.0.4

+-- observable-value@0.0.5

+-- once@1.4.0

+-- optimist@0.6.1

+-- ordered-ast-traverse@1.1.1

+-- ordered-esprima-props@1.1.0

+-- os-browserify@0.1.2

+-- pako@0.2.9

+-- parse-glob@3.0.4

+-- path-browserify@0.0.0

+-- path-is-absolute@1.0.1

+-- pbkdf2-compat@2.0.1

+-- phantomjs-polyfill@0.0.2

+-- postcss@4.1.16

+-- preserve@0.2.0

+-- process@0.11.9

+-- process-nextick-args@1.0.7

+-- prr@0.0.0

+-- punycode@1.4.1

+-- querystring@0.2.0

+-- querystring-es3@0.2.1

+-- randomatic@1.1.5

+-- readable-stream@2.1.5

+-- readdirp@2.1.0

| `-- minimatch@3.0.3

+-- regex-cache@0.4.3

+-- repeat-element@1.1.2

+-- repeat-string@1.6.1

+-- right-align@0.1.3

+-- ripemd160@0.2.0

+-- set-immediate-shim@1.0.1

+-- sha.js@2.2.6

+-- shelljs@0.3.0

+-- simple-fmt@0.1.0

+-- simple-is@0.2.0

+-- source-list-map@0.1.6

+-- source-map@0.4.4

+-- source-map-support@0.4.5

| `-- source-map@0.5.6

+-- stable@0.1.5

+-- stream-browserify@1.0.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- string_decoder@0.10.31

+-- stringmap@0.2.2

+-- stringset@0.2.1

+-- style-loader@0.8.3

+-- supports-color@3.1.2

+-- tapable@0.2.4

+-- ticky@1.0.1

+-- timers-browserify@1.4.2

+-- timers-ext@0.1.0

+-- tryor@0.1.2

+-- tty-browserify@0.0.0

+-- typescript@2.0.6

+-- uglify-js@2.7.4

| `-- source-map@0.5.6

+-- uglify-to-browserify@1.0.2

+-- URIjs@1.16.1

+-- url@0.10.3

| `-- punycode@1.3.2

+-- url-loader@0.5.7

+-- util@0.10.3

| `-- inherits@2.0.1

+-- util-deprecate@1.0.2

+-- vm-browserify@0.0.4

+-- watchpack@0.2.9

| `-- async@0.9.2

+-- webpack@1.13.3

| +-- acorn@3.3.0

| +-- async@1.5.2

| +-- enhanced-resolve@0.9.1

| | `-- memory-fs@0.2.0

| `-- tapable@0.1.10

+-- webpack-core@0.6.8

+-- window-size@0.1.0

+-- wordwrap@0.0.3

+-- wrappy@1.0.2

`-- yargs@3.10.0

npm WARN openproject-frontend@0.1.0 No repository field.

npm WARN openproject-frontend@0.1.0 No license field.

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.0.14 (node_modules/fsevents):

npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.0.14: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

-----> Checking startup method

Found Procfile

-----> Finalizing build

Creating runtime environment

Exporting binary paths

Cleaning npm artifacts

Cleaning previous cache

Caching results for future builds

-----> Build succeeded!

openproject@0.1.0 /tmp/d20170210-17-bzdjkf/opt/openproject

`-- typescript@2.0.8

=====> Downloading Buildpack: https://github.com/pkgr/heroku-buildpack-ruby.git

=====> Detected Framework: Ruby

-----> Compiling Ruby/Rails

-----> Using Ruby version: ruby-2.3.1

-----> Installing dependencies using bundler 1.13.2

cp: ‘/tmp/d20170210-17-bzdjkf/opt/openproject/.git/cache/vendor/bundle/.’ and ‘/tmp/d20170210-17-bzdjkf/opt/openproject/.git/cache/vendor/bundle/.’ are the same file

Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Fetching gem metadata from https://rubygems.org/......

Fetching version metadata from https://rubygems.org/..

Fetching dependency metadata from https://rubygems.org/.

Using rake 11.3.0

Using concurrent-ruby 1.0.2

Using i18n 0.7.0

Using minitest 5.9.0

Using thread_safe 0.3.5

Using builder 3.2.2

Using erubis 2.7.0

Using mini_portile2 2.1.0

Using pkg-config 1.1.7

Using rack 2.0.1

Using nio4r 1.2.1

Using websocket-extensions 0.1.2

Using mime-types 2.99.3

Using method_source 0.8.2

Using thor 0.19.1

Using arel 7.1.2

Using multi_json 1.12.1

Using acts_as_silent_list 3.0.0

Using addressable 2.4.0

Using airbrake-ruby 1.5.0

Using attr_required 1.0.1

Using execjs 2.7.0

Using ice_nine 0.11.2

Using bcrypt 3.1.11

Using bindata 2.3.4

Using sass 3.4.22

Using tilt 2.0.5

Using uber 0.0.15

Using erbse 0.0.2

Using coderay 1.1.1

Using color-tools 1.3.0

Using unf_ext 0.0.7.2

Using netrc 0.11.0

Using daemons 1.2.4

Using dalli 2.7.6

Using enumerable-lazy 0.0.1

Using equalizer 0.0.11

Using excon 0.52.0

Using ffi 1.9.14

Using formatador 0.2.5

Using ipaddress 0.8.3

Using get_process_mem 0.2.1

Using request_store 1.3.1

Using json 1.8.3

Using hashie 3.4.6

Using multi_xml 0.5.5

Using gravatar_image_tag 1.2.0

Using bundler 1.13.2

Using htmldiff 0.0.1

Using httpclient 2.8.2.4

Using icalendar 2.3.0

Using iso8601 0.9.1

Using securecompare 1.0.0

Using url_safe_base64 0.2.2

Using kgio 2.10.0

Using mixlib-shellout 2.1.0

Using mysql2 0.4.4

Using net-ldap 0.14.0

Using newrelic_rpm 3.16.2.321

Using oj 2.17.4

Using pdf-core 0.6.1

Using ttfunk 1.4.0

Using rmagick 2.15.4

Using rubyzip 1.2.0

Using ruby-ole 1.2.12

Using pg 0.19.0

Using rails_serve_static_assets 0.0.5

Using rails_stdout_logging 0.0.5

Using raindrops 0.17.0

Using ruby-progressbar 1.8.1

Using structured_warnings 0.2.0

Using sqlite3 1.3.11

Using stringex 2.6.1

Using svg-graph 2.0.1

Using syck 1.0.5

Using will_paginate 3.1.3

Using i18n-js 3.0.0.rc14

Using tzinfo 1.2.2

Using descendants_tracker 0.0.4

Using nokogiri 1.6.8

Using websocket-driver 0.6.4

Using mail 2.6.4

Using rack-test 0.6.3

Using rack-accept 0.4.5

Using sprockets 3.7.0

Using passenger 5.0.30

Using rack-attack 5.0.1

Using rack-protection 2.0.0.beta2

Using warden 1.2.6

Using airbrake 5.1.0

Using autoprefixer-rails 6.4.1.1

Using cells 4.1.3

Using bourbon 4.2.7

Using mustermann19 0.4.4

Using sys-filesystem 1.1.7

Using fog-core 1.42.0

Using rdoc 4.2.2

Using unf 0.1.4

Using omniauth 1.3.1 from https://github.com/oliverguenther/omniauth (at 8385bc0@8385bc0)

Using prawn 2.1.0

Using spreadsheet 0.8.9

Using rails_12factor 0.0.3

Using unicorn 5.1.0

Using rubytree 0.9.7

Using axiom-types 0.1.1

Using coercible 1.0.0

Using activesupport 5.0.0.1

Using tzinfo-data 1.2016.6

Using loofah 2.0.3

Using representable 2.1.8

Using ruby-saml 1.4.0

Using warden-basic_auth 0.2.1

Using cells-erb 0.0.8

Using fog-json 1.0.2

Using fog-xml 0.1.2

Using domain_name 0.5.20161129

Using prawn-table 0.2.2

Using virtus 1.0.5

Using rails-dom-testing 2.0.1

Using globalid 0.3.7

Using activemodel 5.0.0.1

Using climate_control 0.0.3

Using delayed_job 4.1.2

Using json-jwt 1.6.5

Using rack-oauth2 1.4.0

Using swd 1.0.1

Using webfinger 1.0.2

Using rabl 0.13.0

Using ruby-duration 3.2.3

Using unicorn-worker-killer 0.4.4

Using disposable 0.0.9

Using roar 1.0.4

Using rails-html-sanitizer 1.0.3

Using omniauth-saml 1.6.0 from git://github.com/omniauth/omniauth-saml.git (at master@5559d6b)

Using http-cookie 1.0.3

Using fog-aws 0.11.0

Using grape 0.17.0

Using cocaine 0.5.8

Using activerecord 5.0.0.1

Using carrierwave 1.0.0.beta from https://github.com/carrierwaveuploader/carrierwave (at master@5367a63)

Using date_validator 0.9.0

Using validate_email 0.1.6

Using validate_url 1.0.2

Using activejob 5.0.0.1

Using reform 1.2.6

Using actionview 5.0.0.1

Using openproject-auth_saml 0.1.0 from https://github.com/finnlabs/openproject-auth_saml (at dev@97212ab)

Using rest-client 1.8.0

Using grape-cache_control 1.0.1

Using activemodel-serializers-xml 1.0.1

Using acts_as_list 0.8.1

Using acts_as_tree 2.5.1

Using awesome_nested_set 3.1.1

Using delayed_job_active_record 4.1.1

Using friendly_id 5.2.0.beta.1 from https://github.com/norman/friendly_id (at aff0564@aff0564)

Using globalize 5.1.0 from https://github.com/globalize/globalize (at 38443bc@38443bc)

Using transactional_lock 0.1.0 from https://github.com/finnlabs/transactional_lock.git (at master@6948b1d)

Using openid_connect 0.8.3

Using actionpack 5.0.0.1

Using crowdin-api 0.4.1

Using omniauth-openid-connect 0.2.0 from https://github.com/finnlabs/omniauth-openid-connect.git (at dev@c3bce4c)

Using actioncable 5.0.0.1

Using actionmailer 5.0.0.1

Using railties 5.0.0.1

Using cells-rails 0.0.6

Using gon 4.1.1

Using sprockets-rails 3.2.0

Using omniauth-openid_connect-providers 0.1.0 from https://github.com/finnlabs/omniauth-openid_connect-providers.git (at dev@86f3670)

Using actionpack-xml_parser 2.0.0

Using activerecord-session_store 1.0.0

Using jquery-tablesorter 1.22.7

Using responders 2.3.0

Using rails 5.0.0.1

Using sass-rails 5.0.6

Using health_check 2.2.1

Using lobby_boy 0.1.2

Using openproject-auth_plugins 6.1.4 from source at `vendored-plugins/openproject-auth_plugins`

Using openproject-pdf_export 6.1.4 from source at `vendored-plugins/openproject-pdf_export`

Using openproject-costs 6.1.4 from source at `vendored-plugins/openproject-costs`

Using openproject-documents 6.1.4 from source at `vendored-plugins/openproject-documents`

Using openproject-webhooks 6.1.4 from source at `vendored-plugins/openproject-webhooks`

Using openproject-global_roles 6.1.4 from source at `vendored-plugins/openproject-global_roles`

Using openproject-local_avatars 6.1.4 from source at `vendored-plugins/openproject-local_avatars`

Using openproject-meeting 6.1.4 from source at `vendored-plugins/openproject-meeting`

Using openproject-my_project_page 6.1.4 from source at `vendored-plugins/openproject-my_project_page`

Using reporting_engine 6.1.4 from source at `vendored-plugins/reporting_engine`

Using openproject-themes-dark 6.1.4 from source at `vendored-plugins/openproject-themes-dark`

Using openproject-translations 6.1.4 from https://github.com/opf/openproject-translations.git (at stable/6@da52ff9)

Using openproject-xls_export 6.1.4 from source at `vendored-plugins/openproject-xls_export`

Using rails-angular-xss 0.3.0.pre.pre from https://github.com/opf/rails-angular-xss (at a45267d@a45267d)

Using rails_autolink 1.1.6

Using openproject-openid_connect 6.1.4 from source at `vendored-plugins/openproject-openid_connect`

Using openproject-backlogs 6.1.4 from source at `vendored-plugins/openproject-backlogs`

Using openproject-github_integration 6.1.4 from source at `vendored-plugins/openproject-github_integration`

Using openproject-reporting 6.1.4 from source at `vendored-plugins/openproject-reporting`

Bundle complete! 138 Gemfile dependencies, 195 gems now installed.

Gems in the groups development and test were not installed.

Bundled gems are installed into ./vendor/bundle.

Bundle completed (13.04s)

Cleaning up the bundler cache.

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

-----> Detecting rake tasks

-----> Preparing app for Rails asset pipeline

Running: rake assets:precompile

$(npm bin)/webpack --config webpack.production.config.js

{"omniauth-openid-connect":"/tmp/d20170210-17-bzdjkf/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid-connect-c3bce4c9e9ac","omniauth-openid_connect-providers":"/tmp/d20170210-17-bzdjkf/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid_connect-providers-86f3670e127e","omniauth-saml":"/tmp/d20170210-17-bzdjkf/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-saml-5559d6b80805","openproject-auth_plugins":"/tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-auth_plugins","openproject-auth_saml":"/tmp/d20170210-17-bzdjkf/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-auth_saml-97212abb8378","openproject-pdf_export":"/tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-pdf_export","openproject-backlogs":"/tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-backlogs","openproject-costs":"/tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-costs","openproject-documents":"/tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-documents","openproject-webhooks":"/tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-webhooks","openproject-github_integration":"/tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-github_integration","openproject-global_roles":"/tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-global_roles","openproject-local_avatars":"/tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-local_avatars","openproject-meeting":"/tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-meeting","openproject-my_project_page":"/tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-my_project_page","openproject-openid_connect":"/tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-openid_connect","reporting_engine":"/tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/reporting_engine","openproject-reporting":"/tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-reporting","openproject-themes-dark":"/tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-themes-dark","openproject-translations":"/tmp/d20170210-17-bzdjkf/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-translations-da52ff92cdcd","openproject-xls_export":"/tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-xls_export"}

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Hash: 6fde6ad5c852c07fa5a9

Version: webpack 1.13.3

Child

Hash: 6fde6ad5c852c07fa5a9

Version: webpack 1.13.3

Time: 18964ms

Asset Size Chunks Chunk Names

7b9776076d5fceef4993b55c9383dedd.gif 1.85 kB [emitted]

openproject-backlogs.js 453 kB 0 [emitted] backlogs

openproject-core-app.js 3.43 MB 1 [emitted] core-app

openproject-costs.js 526 kB 2 [emitted] costs

openproject-global.js 3.51 MB 3 [emitted] global

openproject-my_project_page.js 14.3 kB 4 [emitted] my_project_page

openproject-core-app.css 4.71 kB 1 [emitted] core-app

openproject-global.css 49 kB 3 [emitted] global

[213] ./templates \.html$ 1.22 kB {1} [built]

[242] ./components ^((?!\.(test|spec)).)*\.(js|ts|html)$ 16.1 kB {1} [built]

[633] /tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 425 bytes {2} [built]

[765] /tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 330 bytes {4} [built]

+ 769 hidden modules

ERROR in [default]

File '/tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-budget-subform.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-bzdjkf/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-bzdjkf/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/subform/cost-subform.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-bzdjkf/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts' is not under 'rootDir' '/tmp/d20170210-17-bzdjkf/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts' is not under 'rootDir' '/tmp/d20170210-17-bzdjkf/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-block.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-bzdjkf/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-page-layout.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-bzdjkf/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-textile-block.directive.ts' is not under 'rootDir' '/tmp/d20170210-17-bzdjkf/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default] /tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:49:18

Argument of type 'string' is not assignable to parameter of type '{ [key: string]: any; }'.

ERROR in [default] /tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:53:4

Supplied parameters do not match any signature of call target.

ERROR in [default] /tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:30:38

Cannot find module 'app/components/work-packages/work-package-cache.service'.

ERROR in [default] /tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:49:30

Cannot find name 'HalResource'.

ERROR in [default] /tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:54:57

Property '$injector' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:13

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:27

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:60:11

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:70:23

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:76:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:77:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:78:16

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:36:17

Property 'value' does not exist on type 'CurrencyDisplayField'.

ERROR in [default] /tmp/d20170210-17-bzdjkf/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:37:23

Property 'value' does not exist on type 'CurrencyDisplayField'.

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 5 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

I, [2017-02-10T13:24:12.876771 #2574] INFO -- : Writing /tmp/d20170210-17-bzdjkf/opt/openproject/public/assets/application-5ed6f2c8d6dd614c295a8baba53ad44d4799d8a55e5c18451a60d6ff670f0c20.js

I, [2017-02-10T13:24:12.877242 #2574] INFO -- : Writing /tmp/d20170210-17-bzdjkf/opt/openproject/public/assets/application-5ed6f2c8d6dd614c295a8baba53ad44d4799d8a55e5c18451a60d6ff670f0c20.js.gz

Asset precompilation completed (32.86s)

Cleaning assets

Running: rake assets:clean

I, [2017-02-10T13:24:23.329148 #2749] INFO -- : Removed application-3bd5824ebf9196767a9c1f3ffe545667f4f9d0bf126e4917cbac26b70ad708e6.js

Using release configuration from last framework (Ruby).

-----> [cron] /opt/openproject/packaging/cron/openproject-clear-old-sessions => /etc/cron.d/openproject-clear-old-sessions

-----> Verifying package openproject_6.1.4-1486730985.5bf684b.trusty_amd64.deb

NEW PACKAGE: openproject_6.1.4-1486730985.5bf684b.trusty_amd64.deb (289.28 MiB)

-----> Releasing...

DONE!

====== Attempt #1

-----> Fetching repository

Cloning into '/tmp/d20170210-16665-18265di/input'...

-----> Restoring cache

-----> Starting packaging process

-----> Installing missing build dependencies: libmagickwand-dev, libsqlite3-dev

-----> [wizard] adding legacy-installer wizard (https://github.com/pkgr/addon-legacy-installer#master)

-----> [wizard] adding mysql wizard (https://github.com/pkgr/addon-mysql#master)

-----> [wizard] adding apache2 wizard (https://github.com/pkgr/addon-apache2#master)

-----> [wizard] adding repositories wizard (https://github.com/finnlabs/addon-repositories#master)

-----> [wizard] adding smtp wizard (https://github.com/pkgr/addon-smtp#master)

-----> [wizard] adding memcached wizard (https://github.com/pkgr/addon-memcached#master)

-----> [wizard] adding openproject wizard (https://github.com/pkgr/addon-openproject#master)

-----> Fetching buildpack https://github.com/opf/heroku-buildpack-multi.git at master

-----> Multipack app

-----> Running hook: "packaging/setup"

WARNING: This buildpack is no longer maintained.

Please choose a different buildpack or go to https://github.com/ddollar/heroku-buildpack-multi

and fork it to your own account.

=====> Downloading Buildpack: https://github.com/pkgr/pkgr-buildpack-imagemagick.git

=====> Detected Framework: ImageMagick

-----> SKIP

=====> Downloading Buildpack: https://github.com/heroku/heroku-buildpack-nodejs.git

=====> Detected Framework: Node.js

-----> Reading application state

package.json...

build directory...

cache directory...

environment variables...

Node engine: 6.9.1

Npm engine: 4.0.0

Start mechanism: Procfile

node_modules source: package.json

node_modules cached: true

NPM_CONFIG_PRODUCTION=true

NODE_MODULES_CACHE=true

-----> Installing binaries

Downloading and installing node 6.9.1...

Downloading and installing npm 4.0.0 (replacing version 3.10.8)...

-----> Building dependencies

Restoring node modules from cache

Pruning unused dependencies

Installing any new modules

> openproject@0.1.0 postinstall /tmp/d20170210-18-yyhehe/opt/openproject

> cd frontend && npm install

> openproject-frontend@0.1.0 postinstall /tmp/d20170210-18-yyhehe/opt/openproject/frontend

> bower install --config.interactive=false

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 not-cached git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolve git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de not-cached git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolve git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 not-cached git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolve git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 checkout d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower select2#3.5.2 not-cached https://github.com/ivaynberg/select2.git#3.5.2

bower select2#3.5.2 resolve https://github.com/ivaynberg/select2.git#3.5.2

bower jquery-ujs#1.0.0 not-cached https://github.com/rails/jquery-ujs.git#1.0.0

bower jquery-ujs#1.0.0 resolve https://github.com/rails/jquery-ujs.git#1.0.0

bower angular#~1.5.8 not-cached https://github.com/angular/bower-angular.git#~1.5.8

bower angular#~1.5.8 resolve https://github.com/angular/bower-angular.git#~1.5.8

bower jquery#1.11.0 not-cached https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery#1.11.0 resolve https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery-ui#~1.10.4 not-cached https://github.com/components/jqueryui.git#~1.10.4

bower jquery-ui#~1.10.4 resolve https://github.com/components/jqueryui.git#~1.10.4

bower angular-animate#~1.5.8 not-cached https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-animate#~1.5.8 resolve https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-aria#~1.5.8 not-cached https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-aria#~1.5.8 resolve https://github.com/angular/bower-angular-aria.git#~1.5.8

bower jquery.atwho#0.5.1 not-cached https://github.com/ichord/At.js.git#0.5.1

bower jquery.atwho#0.5.1 resolve https://github.com/ichord/At.js.git#0.5.1

bower angular-ui-router#~0.3.1 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-ui-router#~0.3.1 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-i18n#~1.5.5 not-cached https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-i18n#~1.5.5 resolve https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-sanitize#~1.5.8 not-cached https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-sanitize#~1.5.8 resolve https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-cache#~4.6.0 not-cached https://github.com/jmdobry/angular-cache.git#~4.6.0

bower angular-cache#~4.6.0 resolve https://github.com/jmdobry/angular-cache.git#~4.6.0

bower angular-elastic#~2.5.1 not-cached https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-elastic#~2.5.1 resolve https://github.com/monospaced/angular-elastic.git#~2.5.1

bower jquery-migrate#~1.2.1 not-cached https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower jquery-migrate#~1.2.1 resolve https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de checkout fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 checkout a908eccaec323cd66973d58af4965694bdff16a1

bower moment#~2.10.6 not-cached https://github.com/moment/moment.git#~2.10.6

bower moment#~2.10.6 resolve https://github.com/moment/moment.git#~2.10.6

bower angular-busy#~4.1.3 not-cached https://github.com/cgross/angular-busy.git#~4.1.3

bower angular-busy#~4.1.3 resolve https://github.com/cgross/angular-busy.git#~4.1.3

bower moment-timezone#0.4.x not-cached https://github.com/moment/moment-timezone.git#0.4.x

bower moment-timezone#0.4.x resolve https://github.com/moment/moment-timezone.git#0.4.x

bower lodash#~2.4.1 not-cached https://github.com/lodash/lodash.git#~2.4.1

bower lodash#~2.4.1 resolve https://github.com/lodash/lodash.git#~2.4.1

bower bourbon#~4.2.1 not-cached https://github.com/thoughtbot/bourbon.git#~4.2.1

bower bourbon#~4.2.1 resolve https://github.com/thoughtbot/bourbon.git#~4.2.1

bower foundation-apps#1.1.0 not-cached https://github.com/zurb/foundation-apps.git#1.1.0

bower foundation-apps#1.1.0 resolve https://github.com/zurb/foundation-apps.git#1.1.0

bower angular-ui-select#~0.19.4 not-cached https://github.com/angular-ui/ui-select.git#~0.19.4

bower angular-ui-select#~0.19.4 resolve https://github.com/angular-ui/ui-select.git#~0.19.4

bower mousetrap#~1.4.6 not-cached https://github.com/ccampbell/mousetrap.git#~1.4.6

bower mousetrap#~1.4.6 resolve https://github.com/ccampbell/mousetrap.git#~1.4.6

bower ng-file-upload#~5.0.9 not-cached https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower ng-file-upload#~5.0.9 resolve https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower rxjs#^4.1.0 not-cached https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower rxjs#^4.1.0 resolve https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower ng-dialog#^0.6.2 not-cached https://github.com/likeastore/ngDialog.git#^0.6.2

bower ng-dialog#^0.6.2 resolve https://github.com/likeastore/ngDialog.git#^0.6.2

bower angular-dragula#^1.2.8 not-cached https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower angular-dragula#^1.2.8 resolve https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower angular-mocks#~1.5.8 not-cached https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower angular-mocks#~1.5.8 resolve https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower mocha#~1.14.0 not-cached https://github.com/mochajs/mocha.git#~1.14.0

bower mocha#~1.14.0 resolve https://github.com/mochajs/mocha.git#~1.14.0

bower jquery-mockjax#~1.5.3 not-cached https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery-mockjax#~1.5.3 resolve https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower chai#~1.9.0 not-cached https://github.com/chaijs/chai.git#~1.9.0

bower chai#~1.9.0 resolve https://github.com/chaijs/chai.git#~1.9.0

bower jquery-ujs#1.0.0 checkout v1.0.0

bower select2#3.5.2 checkout 3.5.2

bower jquery#1.11.0 checkout 1.11.0

bower jquery-ui#~1.10.4 checkout 1.10.4

bower angular#~1.5.8 checkout v1.5.11

bower jquery.atwho#0.5.1 checkout v0.5.1

bower angular-ui-router#~0.3.1 checkout 0.3.2

bower angular-aria#~1.5.8 checkout v1.5.11

bower angular-elastic#~2.5.1 checkout v2.5.1

bower angular-cache#~4.6.0 checkout 4.6.0

bower angular-animate#~1.5.8 checkout v1.5.11

bower angular-busy#~4.1.3 checkout v4.1.4

bower moment#~2.10.6 checkout 2.10.6

bower jquery-migrate#~1.2.1 checkout 1.2.1

bower angular-i18n#~1.5.5 checkout v1.5.11

bower foundation-apps#1.1.0 checkout v1.1.0

bower bourbon#~4.2.1 checkout v4.2.7

bower lodash#~2.4.1 checkout 2.4.2

bower moment-timezone#0.4.x checkout 0.4.1

bower angular-sanitize#~1.5.8 checkout v1.5.11

bower ng-dialog#^0.6.2 checkout v0.6.6

bower rxjs#^4.1.0 checkout v4.1.0

bower ng-file-upload#~5.0.9 checkout 5.0.9

bower mousetrap#~1.4.6 checkout 1.4.6

bower angular-ui-select#~0.19.4 checkout v0.19.6

bower angular-dragula#^1.2.8 checkout v1.2.8

bower mocha#~1.14.0 checkout 1.14.0

bower jquery-mockjax#~1.5.3 checkout v1.5.4

bower chai#~1.9.0 checkout 1.9.2

bower angular-mocks#~1.5.8 checkout v1.5.11

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .png files: ["select2.png","select2x2.png"]

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolved git://github.com/nickmessing/angular-context-menu.git#a908eccaec

bower angular#>= 1.2.5 not-cached https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 resolve https://github.com/angular/bower-angular.git#>= 1.2.5

bower jquery-ui#~1.10.4 resolved https://github.com/components/jqueryui.git#1.10.4

bower select2#3.5.2 resolved https://github.com/ivaynberg/select2.git#3.5.2

bower angular#>= 1.2.5 checkout v1.6.2

bower angular#~1.5.8 resolved https://github.com/angular/bower-angular.git#1.5.11

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolved git://github.com/finnlabs/angular-modal.git#d45eb9ceb7

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolved git://github.com/sparkalow/angular-truncate.git#fdf60fda26

bower jquery-ujs#1.0.0 resolved https://github.com/rails/jquery-ujs.git#1.0.0

bower jquery#1.11.0 resolved https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery.atwho#0.5.1 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower angular-elastic#~2.5.1 resolved https://github.com/monospaced/angular-elastic.git#2.5.1

bower angular-aria#~1.5.8 resolved https://github.com/angular/bower-angular-aria.git#1.5.11

bower jquery.atwho#0.5.1 resolved https://github.com/ichord/At.js.git#0.5.1

bower angular-cache#~4.6.0 resolved https://github.com/jmdobry/angular-cache.git#4.6.0

bower Caret.js#>= 0.2.0 not-cached https://github.com/ichord/Caret.js.git#>= 0.2.0

bower Caret.js#>= 0.2.0 resolve https://github.com/ichord/Caret.js.git#>= 0.2.0

bower angular-ui-router#~0.3.1 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.3.2

bower jquery-migrate#~1.2.1 deprecated Package jquery-migrate is using the deprecated component.json

bower jquery-migrate#~1.2.1 resolved https://github.com/appleboy/jquery-migrate.git#1.2.1

bower angular-animate#~1.5.8 resolved https://github.com/angular/bower-angular-animate.git#1.5.11

bower angular-busy#~4.1.3 resolved https://github.com/cgross/angular-busy.git#4.1.4

bower moment#~2.10.6 resolved https://github.com/moment/moment.git#2.10.6

bower bourbon#~4.2.1 resolved https://github.com/thoughtbot/bourbon.git#4.2.7

bower foundation-apps#1.1.0 resolved https://github.com/zurb/foundation-apps.git#1.1.0

bower angular#~1.3.4 not-cached https://github.com/angular/bower-angular.git#~1.3.4

bower angular#~1.3.4 resolve https://github.com/angular/bower-angular.git#~1.3.4

bower angular-ui-router#~0.2.12 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-ui-router#~0.2.12 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-animate#~1.3.4 not-cached https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular-animate#~1.3.4 resolve https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular#~1.3.4 checkout v1.3.20

bower angular-ui-router#~0.2.12 checkout 0.2.18

bower angular-animate#~1.3.4 checkout v1.3.20

bower ng-dialog#^0.6.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .css files: ["css/ngDialog.css","css/ngDialog-theme-default.css"]

bower viewport-units-buggyfill#~0.4.1 not-cached https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower viewport-units-buggyfill#~0.4.1 resolve https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower tether#~0.6.5 not-cached https://github.com/HubSpot/tether.git#~0.6.5

bower tether#~0.6.5 resolve https://github.com/HubSpot/tether.git#~0.6.5

bower angular-sanitize#~1.5.8 resolved https://github.com/angular/bower-angular-sanitize.git#1.5.11

bower hammerjs#~2.0.4 not-cached https://github.com/EightMedia/hammer.js.git#~2.0.4

bower hammerjs#~2.0.4 resolve https://github.com/EightMedia/hammer.js.git#~2.0.4

bower lodash#~2.4.1 resolved https://github.com/lodash/lodash.git#2.4.2

bower ng-dialog#^0.6.2 resolved https://github.com/likeastore/ngDialog.git#0.6.6

bower fastclick#~1.0.3 not-cached https://github.com/ftlabs/fastclick.git#~1.0.3

bower fastclick#~1.0.3 resolve https://github.com/ftlabs/fastclick.git#~1.0.3

bower ng-file-upload#~5.0.9 resolved https://github.com/danialfarid/angular-file-upload-bower.git#5.0.9

bower mousetrap#~1.4.6 resolved https://github.com/ccampbell/mousetrap.git#1.4.6

bower angular-i18n#~1.5.5 resolved https://github.com/angular/bower-angular-i18n.git#1.5.11

bower angular-dragula#^1.2.8 resolved https://github.com/bevacqua/angular-dragula.git#1.2.8

bower angular-ui-select#~0.19.4 resolved https://github.com/angular-ui/ui-select.git#0.19.6

bower moment-timezone#0.4.x resolved https://github.com/moment/moment-timezone.git#0.4.1

bower jquery-mockjax#~1.5.3 resolved https://github.com/jakerella/jquery-mockjax.git#1.5.4

bower chai#~1.9.0 resolved https://github.com/chaijs/chai.git#1.9.2

bower mocha#~1.14.0 mismatch Version declared in the json (1.12.0) is different than the resolved one (1.14.0)

bower mocha#~1.14.0 resolved https://github.com/mochajs/mocha.git#1.14.0

bower Caret.js#>= 0.2.0 checkout v0.3.1

bower angular-mocks#~1.5.8 resolved https://github.com/angular/bower-angular-mocks.git#1.5.11

bower viewport-units-buggyfill#~0.4.1 checkout v0.4.1

bower rxjs#^4.1.0 resolved https://github.com/Reactive-Extensions/RxJS.git#4.1.0

bower angular-ui-router#~0.2.12 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.2.18

bower angular#>= 1.2.5 resolved https://github.com/angular/bower-angular.git#1.6.2

bower angular#~1.3.4 resolved https://github.com/angular/bower-angular.git#1.3.20

bower tether#~0.6.5 checkout v0.6.5

bower angular-animate#~1.3.4 resolved https://github.com/angular/bower-angular-animate.git#1.3.20

bower hammerjs#~2.0.4 checkout v2.0.8

bower fastclick#~1.0.3 checkout v1.0.6

bower Caret.js#>= 0.2.0 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower Caret.js#>= 0.2.0 resolved https://github.com/ichord/Caret.js.git#0.3.1

bower viewport-units-buggyfill#~0.4.1 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .js files: ["./viewport-units-buggyfill.js","./viewport-units-buggyfill.hacks.js"]

bower viewport-units-buggyfill#~0.4.1 resolved https://github.com/rodneyrehm/viewport-units-buggyfill.git#0.4.1

bower hammerjs#~2.0.4 resolved https://github.com/EightMedia/hammer.js.git#2.0.8

bower fastclick#~1.0.3 resolved https://github.com/ftlabs/fastclick.git#1.0.6

bower tether#~0.6.5 resolved https://github.com/HubSpot/tether.git#0.6.5

Please note that,

angular-animate#1.3.20 depends on angular#1.3.20 which resolved to angular#1.3.20

foundation-apps#1.1.0 depends on angular#~1.3.4 which resolved to angular#1.3.20

angular-animate#1.5.11, angular-aria#1.5.11, angular-mocks#1.5.11, angular-sanitize#1.5.11 depends on angular#1.5.11 which resolved to angular#1.5.11

angular-ui-router#0.3.2, angular-ui-router#0.2.18 depends on angular#^1.0.8 which resolved to angular#1.5.11

angular-cache#4.6.0 depends on angular#>=1.x which resolved to angular#1.5.11

angular-elastic#2.5.1 depends on angular#>=1.0.6 which resolved to angular#1.5.11

angular-busy#4.1.4 depends on angular#>=1.3 which resolved to angular#1.5.11

ng-dialog#0.6.6 depends on angular#>=1.5 which resolved to angular#1.5.11

angular-ui-select#0.19.6 depends on angular#>=1.2.18 which resolved to angular#1.5.11

openproject depends on angular#~1.5.8 which resolved to angular#1.5.11

angular-modal#d45eb9ceb7 depends on angular#^1.3.0 which resolved to angular#1.5.11

angular-context-menu#a908eccaec depends on angular#>= 1.2.5 which resolved to angular#1.6.2

Resort to using angular#~1.5.8 which resolved to angular#1.5.11

Code incompatibilities may occur.

Please note that,

foundation-apps#1.1.0 depends on angular-ui-router#~0.2.12 which resolved to angular-ui-router#0.2.18

openproject depends on angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Resort to using angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Code incompatibilities may occur.

Please note that,

foundation-apps#1.1.0 depends on angular-animate#~1.3.4 which resolved to angular-animate#1.3.20

openproject depends on angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

angular-busy#4.1.4 depends on angular-animate#>=1.3 which resolved to angular-animate#1.5.11

Resort to using angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

Code incompatibilities may occur.

bower jquery extra-resolution Unnecessary resolution: jquery#1.11.0

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 install angular-context-menu#a908eccaec

bower jquery-ui#~1.10.4 install jquery-ui#1.10.4

bower select2#3.5.2 install select2#3.5.2

bower angular#1.5.11 install angular#1.5.11

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 install angular-modal#d45eb9ceb7

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de install angular-truncate#fdf60fda26

bower jquery-ujs#1.0.0 install jquery-ujs#1.0.0

bower jquery#1.11.0 install jquery#1.11.0

bower angular-elastic#~2.5.1 install angular-elastic#2.5.1

bower angular-aria#~1.5.8 install angular-aria#1.5.11

bower jquery.atwho#0.5.1 install jquery.atwho#0.5.1

bower angular-cache#~4.6.0 install angular-cache#4.6.0

bower angular-ui-router#~0.3.1 install angular-ui-router#0.3.2

bower jquery-migrate#~1.2.1 install jquery-migrate#1.2.1

bower angular-animate#~1.5.8 install angular-animate#1.5.11

bower angular-busy#~4.1.3 install angular-busy#4.1.4

bower moment#~2.10.6 install moment#2.10.6

bower bourbon#~4.2.1 install bourbon#4.2.7

bower foundation-apps#1.1.0 install foundation-apps#1.1.0

bower angular-sanitize#~1.5.8 install angular-sanitize#1.5.11

bower lodash#~2.4.1 install lodash#2.4.2

bower ng-dialog#^0.6.2 install ng-dialog#0.6.6

bower ng-file-upload#~5.0.9 install ng-file-upload#5.0.9

bower mousetrap#~1.4.6 install mousetrap#1.4.6

bower angular-i18n#~1.5.5 install angular-i18n#1.5.11

bower angular-dragula#^1.2.8 install angular-dragula#1.2.8

bower angular-ui-select#~0.19.4 install angular-ui-select#0.19.6

bower moment-timezone#0.4.x install moment-timezone#0.4.1

bower jquery-mockjax#~1.5.3 install jquery-mockjax#1.5.4

bower chai#~1.9.0 install chai#1.9.2

bower mocha#~1.14.0 install mocha#1.14.0

bower angular-mocks#~1.5.8 install angular-mocks#1.5.11

bower rxjs#^4.1.0 install rxjs#4.1.0

bower Caret.js#>= 0.2.0 install Caret.js#0.3.1

bower viewport-units-buggyfill#~0.4.1 install viewport-units-buggyfill#0.4.1

bower hammerjs#~2.0.4 install hammerjs#2.0.8

bower fastclick#~1.0.3 install fastclick#1.0.6

bower tether#~0.6.5 install tether#0.6.5

angular-context-menu#a908eccaec bower_components/angular-context-menu

└── angular#1.5.11

jquery-ui#1.10.4 bower_components/jquery-ui

└── jquery#1.11.0

select2#3.5.2 bower_components/select2

└── jquery#1.11.0

angular#1.5.11 bower_components/angular

angular-modal#d45eb9ceb7 bower_components/angular-modal

└── angular#1.5.11

angular-truncate#fdf60fda26 bower_components/angular-truncate

jquery-ujs#1.0.0 bower_components/jquery-ujs

└── jquery#1.11.0

jquery#1.11.0 bower_components/jquery

angular-elastic#2.5.1 bower_components/angular-elastic

└── angular#1.5.11

angular-aria#1.5.11 bower_components/angular-aria

└── angular#1.5.11

jquery.atwho#0.5.1 bower_components/jquery.atwho

├── Caret.js#0.3.1

└── jquery#1.11.0

angular-cache#4.6.0 bower_components/angular-cache

└── angular#1.5.11

angular-ui-router#0.3.2 bower_components/angular-ui-router

└── angular#1.5.11

jquery-migrate#1.2.1 bower_components/jquery-migrate

angular-animate#1.5.11 bower_components/angular-animate

└── angular#1.5.11

angular-busy#4.1.4 bower_components/angular-busy

├── angular#1.5.11

└── angular-animate#1.5.11

moment#2.10.6 bower_components/moment

bourbon#4.2.7 bower_components/bourbon

foundation-apps#1.1.0 bower_components/foundation-apps

├── angular#1.5.11

├── angular-animate#1.5.11

├── angular-ui-router#0.3.2

├── fastclick#1.0.6

├── hammerjs#2.0.8

├── tether#0.6.5

└── viewport-units-buggyfill#0.4.1

angular-sanitize#1.5.11 bower_components/angular-sanitize

└── angular#1.5.11

lodash#2.4.2 bower_components/lodash

ng-dialog#0.6.6 bower_components/ng-dialog

└── angular#1.5.11

ng-file-upload#5.0.9 bower_components/ng-file-upload

mousetrap#1.4.6 bower_components/mousetrap

angular-i18n#1.5.11 bower_components/angular-i18n

angular-dragula#1.2.8 bower_components/angular-dragula

angular-ui-select#0.19.6 bower_components/angular-ui-select

└── angular#1.5.11

moment-timezone#0.4.1 bower_components/moment-timezone

└── moment#2.10.6

jquery-mockjax#1.5.4 bower_components/jquery-mockjax

chai#1.9.2 bower_components/chai

mocha#1.14.0 bower_components/mocha

angular-mocks#1.5.11 bower_components/angular-mocks

└── angular#1.5.11

rxjs#4.1.0 bower_components/rxjs

Caret.js#0.3.1 bower_components/Caret.js

└── jquery#1.11.0

viewport-units-buggyfill#0.4.1 bower_components/viewport-units-buggyfill

hammerjs#2.0.8 bower_components/hammerjs

fastclick#1.0.6 bower_components/fastclick

tether#0.6.5 bower_components/tether

openproject-frontend@0.1.0 /tmp/d20170210-18-yyhehe/opt/openproject/frontend

+-- acorn@2.6.4

+-- align-text@0.1.4

+-- alter@0.2.0

+-- amdefine@1.0.0

+-- angular@1.5.8

+-- angular-elastic@2.5.1

+-- angular-ui-bootstrap@2.2.0

+-- anymatch@1.3.0

+-- arr-diff@2.0.0

+-- arr-flatten@1.0.1

+-- array-unique@0.2.1

+-- arrify@1.0.1

+-- assert@1.4.1

+-- async@0.2.10

+-- async-each@1.0.1

+-- atoa@1.0.0

+-- autoprefixer-core@5.2.1

+-- autoprefixer-loader@1.2.0

+-- awesome-typescript-loader@2.2.4

| `-- lodash@4.16.4

+-- balanced-match@0.4.2

+-- Base64@0.2.1

+-- base64-js@1.2.0

+-- big.js@3.1.3

+-- binary-extensions@1.7.0

+-- bower@1.7.9

+-- brace-expansion@1.1.6

+-- braces@1.8.5

+-- browserify-zlib@0.1.4

+-- browserslist@0.4.0

+-- buffer@4.9.1

+-- buffer-shims@1.0.0

+-- camelcase@1.2.1

+-- caniuse-db@1.0.30000569

+-- center-align@0.1.3

+-- chokidar@1.6.1

+-- cliui@2.1.0

| `-- wordwrap@0.0.2

+-- clone@1.0.2

+-- colors@1.1.2

+-- concat-map@0.0.1

+-- console-browserify@1.1.0

+-- constants-browserify@0.0.1

+-- contra@1.9.4

+-- convert-source-map@1.1.3

+-- core-util-is@1.0.2

+-- crossvent@1.5.4

+-- crypto-browserify@3.2.8

+-- css-loader@0.9.1

| `-- source-map@0.1.43

+-- csso@1.3.12

+-- custom-event@1.0.0

+-- d@0.1.1

+-- date-now@0.1.4

+-- decamelize@1.2.0

+-- domain-browser@1.1.7

+-- dragula@3.7.2

+-- emojis-list@2.1.0

+-- enhanced-resolve@2.3.0

+-- errno@0.1.4

+-- es5-ext@0.10.12

+-- es6-iterator@2.0.0

+-- es6-promise@2.3.0

+-- es6-symbol@3.1.0

+-- es6-weak-map@0.1.4

| +-- es6-iterator@0.1.3

| `-- es6-symbol@2.0.1

+-- event-emitter@0.3.4

+-- events@1.1.1

+-- expand-brackets@0.1.5

+-- expand-range@1.8.2

+-- exports-loader@0.6.3

| `-- source-map@0.1.43

+-- expose-loader@0.6.0

+-- extglob@0.3.2

+-- extract-text-webpack-plugin@0.3.8

| `-- source-map@0.1.43

+-- fastparse@1.1.1

+-- file-loader@0.8.5

+-- filename-regex@2.0.0

+-- fill-range@2.2.3

+-- for-in@0.1.6

+-- for-own@0.1.4

+-- glob@4.5.3

+-- glob-base@0.3.0

+-- glob-parent@2.0.0

+-- graceful-fs@4.1.9

+-- has-flag@1.0.0

+-- html-loader@0.2.3

| `-- source-map@0.1.43

+-- html-minifier@0.5.6

+-- http-browserify@1.7.0

+-- https-browserify@0.0.0

+-- ieee754@1.1.8

+-- indexof@0.0.1

+-- inflight@1.0.6

+-- inherits@2.0.3

+-- interpret@0.6.6

+-- is-binary-path@1.0.1

+-- is-buffer@1.1.4

+-- is-dotfile@1.0.2

+-- is-equal-shallow@0.1.3

+-- is-extendable@0.1.1

+-- is-extglob@1.0.0

+-- is-glob@2.0.1

+-- is-number@2.1.0

+-- is-posix-bracket@0.1.1

+-- is-primitive@2.0.0

+-- isarray@1.0.0

+-- isobject@2.1.0

+-- js-base64@2.1.9

+-- json5@0.4.0

+-- kind-of@3.0.4

+-- lazy-cache@1.0.4

+-- loader-utils@0.2.16

| `-- json5@0.5.0

+-- lodash@2.4.2

+-- longest@1.0.1

+-- lru-queue@0.1.0

+-- memoizee@0.3.10

+-- memory-fs@0.3.0

+-- micromatch@2.3.11

+-- mime@1.2.11

+-- minimatch@2.0.10

+-- minimist@0.0.10

+-- mkdirp@0.5.1

| `-- minimist@0.0.8

+-- nan@2.4.0

+-- next-tick@0.2.2

+-- ng-annotate@1.2.1

| `-- source-map@0.5.6

+-- ng-annotate-loader@0.0.10

| `-- source-map@0.4.2

+-- ngtemplate-loader@0.1.3

+-- node-libs-browser@0.6.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- normalize-path@2.0.1

+-- num2fraction@1.2.2

+-- object-assign@4.1.0

+-- object.omit@2.0.1

+-- observable-array@0.0.4

+-- observable-value@0.0.5

+-- once@1.4.0

+-- optimist@0.6.1

+-- ordered-ast-traverse@1.1.1

+-- ordered-esprima-props@1.1.0

+-- os-browserify@0.1.2

+-- pako@0.2.9

+-- parse-glob@3.0.4

+-- path-browserify@0.0.0

+-- path-is-absolute@1.0.1

+-- pbkdf2-compat@2.0.1

+-- phantomjs-polyfill@0.0.2

+-- postcss@4.1.16

+-- preserve@0.2.0

+-- process@0.11.9

+-- process-nextick-args@1.0.7

+-- prr@0.0.0

+-- punycode@1.4.1

+-- querystring@0.2.0

+-- querystring-es3@0.2.1

+-- randomatic@1.1.5

+-- readable-stream@2.1.5

+-- readdirp@2.1.0

| `-- minimatch@3.0.3

+-- regex-cache@0.4.3

+-- repeat-element@1.1.2

+-- repeat-string@1.6.1

+-- right-align@0.1.3

+-- ripemd160@0.2.0

+-- set-immediate-shim@1.0.1

+-- sha.js@2.2.6

+-- shelljs@0.3.0

+-- simple-fmt@0.1.0

+-- simple-is@0.2.0

+-- source-list-map@0.1.6

+-- source-map@0.4.4

+-- source-map-support@0.4.5

| `-- source-map@0.5.6

+-- stable@0.1.5

+-- stream-browserify@1.0.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- string_decoder@0.10.31

+-- stringmap@0.2.2

+-- stringset@0.2.1

+-- style-loader@0.8.3

+-- supports-color@3.1.2

+-- tapable@0.2.4

+-- ticky@1.0.1

+-- timers-browserify@1.4.2

+-- timers-ext@0.1.0

+-- tryor@0.1.2

+-- tty-browserify@0.0.0

+-- typescript@2.0.6

+-- uglify-js@2.7.4

| `-- source-map@0.5.6

+-- uglify-to-browserify@1.0.2

+-- URIjs@1.16.1

+-- url@0.10.3

| `-- punycode@1.3.2

+-- url-loader@0.5.7

+-- util@0.10.3

| `-- inherits@2.0.1

+-- util-deprecate@1.0.2

+-- vm-browserify@0.0.4

+-- watchpack@0.2.9

| `-- async@0.9.2

+-- webpack@1.13.3

| +-- acorn@3.3.0

| +-- async@1.5.2

| +-- enhanced-resolve@0.9.1

| | `-- memory-fs@0.2.0

| `-- tapable@0.1.10

+-- webpack-core@0.6.8

+-- window-size@0.1.0

+-- wordwrap@0.0.3

+-- wrappy@1.0.2

`-- yargs@3.10.0

npm WARN openproject-frontend@0.1.0 No repository field.

npm WARN openproject-frontend@0.1.0 No license field.

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.0.14 (node_modules/fsevents):

npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.0.14: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

-----> Checking startup method

Found Procfile

-----> Finalizing build

Creating runtime environment

Exporting binary paths

Cleaning npm artifacts

Cleaning previous cache

Caching results for future builds

-----> Build succeeded!

openproject@0.1.0 /tmp/d20170210-18-yyhehe/opt/openproject

`-- typescript@2.0.8

=====> Downloading Buildpack: https://github.com/pkgr/heroku-buildpack-ruby.git

=====> Detected Framework: Ruby

-----> Compiling Ruby/Rails

-----> Using Ruby version: ruby-2.3.1

-----> Installing dependencies using bundler 1.13.2

cp: '/tmp/d20170210-18-yyhehe/opt/openproject/.git/cache/vendor/bundle/.' and '/tmp/d20170210-18-yyhehe/opt/openproject/.git/cache/vendor/bundle/.' are the same file

Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Fetching gem metadata from https://rubygems.org/......

Fetching version metadata from https://rubygems.org/..

Fetching dependency metadata from https://rubygems.org/.

Using rake 11.3.0

Using concurrent-ruby 1.0.2

Using i18n 0.7.0

Using minitest 5.9.0

Using thread_safe 0.3.5

Using builder 3.2.2

Using erubis 2.7.0

Using mini_portile2 2.1.0

Using pkg-config 1.1.7

Using rack 2.0.1

Using nio4r 1.2.1

Using websocket-extensions 0.1.2

Using mime-types 2.99.3

Using method_source 0.8.2

Using thor 0.19.1

Using arel 7.1.2

Using multi_json 1.12.1

Using acts_as_silent_list 3.0.0

Using addressable 2.4.0

Using airbrake-ruby 1.5.0

Using attr_required 1.0.1

Using execjs 2.7.0

Using ice_nine 0.11.2

Using bcrypt 3.1.11

Using bindata 2.3.4

Using sass 3.4.22

Using tilt 2.0.5

Using uber 0.0.15

Using erbse 0.0.2

Using coderay 1.1.1

Using color-tools 1.3.0

Using unf_ext 0.0.7.2

Using netrc 0.11.0

Using daemons 1.2.4

Using dalli 2.7.6

Using enumerable-lazy 0.0.1

Using equalizer 0.0.11

Using excon 0.52.0

Using ffi 1.9.14

Using formatador 0.2.5

Using ipaddress 0.8.3

Using get_process_mem 0.2.1

Using request_store 1.3.1

Using json 1.8.3

Using hashie 3.4.6

Using multi_xml 0.5.5

Using gravatar_image_tag 1.2.0

Using bundler 1.13.2

Using htmldiff 0.0.1

Using httpclient 2.8.2.4

Using icalendar 2.3.0

Using iso8601 0.9.1

Using securecompare 1.0.0

Using url_safe_base64 0.2.2

Using kgio 2.10.0

Using mixlib-shellout 2.1.0

Using mysql2 0.4.4

Using net-ldap 0.14.0

Using newrelic_rpm 3.16.2.321

Using oj 2.17.4

Using pdf-core 0.6.1

Using ttfunk 1.4.0

Using rmagick 2.15.4

Using rubyzip 1.2.0

Using ruby-ole 1.2.12

Using pg 0.19.0

Using rails_serve_static_assets 0.0.5

Using rails_stdout_logging 0.0.5

Using raindrops 0.17.0

Using ruby-progressbar 1.8.1

Using structured_warnings 0.2.0

Using sqlite3 1.3.11

Using stringex 2.6.1

Using svg-graph 2.0.1

Using syck 1.0.5

Using will_paginate 3.1.3

Using i18n-js 3.0.0.rc14

Using tzinfo 1.2.2

Using descendants_tracker 0.0.4

Using rack-test 0.6.3

Using rack-accept 0.4.5

Using sprockets 3.7.0

Using passenger 5.0.30

Using rack-attack 5.0.1

Using rack-protection 2.0.0.beta2

Using warden 1.2.6

Using websocket-driver 0.6.4

Using mail 2.6.4

Using nokogiri 1.6.8

Using airbrake 5.1.0

Using autoprefixer-rails 6.4.1.1

Using cells 4.1.3

Using unf 0.1.4

Using bourbon 4.2.7

Using mustermann19 0.4.4

Using sys-filesystem 1.1.7

Using fog-core 1.42.0

Using rdoc 4.2.2

Using omniauth 1.3.1 from https://github.com/oliverguenther/omniauth (at 8385bc0@8385bc0)

Using prawn 2.1.0

Using spreadsheet 0.8.9

Using rails_12factor 0.0.3

Using unicorn 5.1.0

Using rubytree 0.9.7

Using activesupport 5.0.0.1

Using tzinfo-data 1.2016.6

Using axiom-types 0.1.1

Using coercible 1.0.0

Using warden-basic_auth 0.2.1

Using loofah 2.0.3

Using representable 2.1.8

Using ruby-saml 1.4.0

Using domain_name 0.5.20161129

Using cells-erb 0.0.8

Using fog-json 1.0.2

Using fog-xml 0.1.2

Using prawn-table 0.2.2

Using unicorn-worker-killer 0.4.4

Using rails-dom-testing 2.0.1

Using globalid 0.3.7

Using activemodel 5.0.0.1

Using climate_control 0.0.3

Using delayed_job 4.1.2

Using json-jwt 1.6.5

Using rack-oauth2 1.4.0

Using swd 1.0.1

Using webfinger 1.0.2

Using rabl 0.13.0

Using ruby-duration 3.2.3

Using virtus 1.0.5

Using rails-html-sanitizer 1.0.3

Using disposable 0.0.9

Using roar 1.0.4

Using omniauth-saml 1.6.0 from git://github.com/omniauth/omniauth-saml.git (at master@5559d6b)

Using http-cookie 1.0.3

Using fog-aws 0.11.0

Using activejob 5.0.0.1

Using activerecord 5.0.0.1

Using carrierwave 1.0.0.beta from https://github.com/carrierwaveuploader/carrierwave (at master@5367a63)

Using date_validator 0.9.0

Using validate_email 0.1.6

Using validate_url 1.0.2

Using cocaine 0.5.8

Using grape 0.17.0

Using actionview 5.0.0.1

Using reform 1.2.6

Using rest-client 1.8.0

Using openproject-auth_saml 0.1.0 from https://github.com/finnlabs/openproject-auth_saml (at dev@97212ab)

Using activemodel-serializers-xml 1.0.1

Using acts_as_list 0.8.1

Using acts_as_tree 2.5.1

Using awesome_nested_set 3.1.1

Using delayed_job_active_record 4.1.1

Using friendly_id 5.2.0.beta.1 from https://github.com/norman/friendly_id (at aff0564@aff0564)

Using globalize 5.1.0 from https://github.com/globalize/globalize (at 38443bc@38443bc)

Using transactional_lock 0.1.0 from https://github.com/finnlabs/transactional_lock.git (at master@6948b1d)

Using openid_connect 0.8.3

Using actionpack 5.0.0.1

Using grape-cache_control 1.0.1

Using crowdin-api 0.4.1

Using omniauth-openid-connect 0.2.0 from https://github.com/finnlabs/omniauth-openid-connect.git (at dev@c3bce4c)

Using actioncable 5.0.0.1

Using actionmailer 5.0.0.1

Using railties 5.0.0.1

Using cells-rails 0.0.6

Using gon 4.1.1

Using sprockets-rails 3.2.0

Using omniauth-openid_connect-providers 0.1.0 from https://github.com/finnlabs/omniauth-openid_connect-providers.git (at dev@86f3670)

Using actionpack-xml_parser 2.0.0

Using activerecord-session_store 1.0.0

Using rails 5.0.0.1

Using jquery-tablesorter 1.22.7

Using responders 2.3.0

Using sass-rails 5.0.6

Using health_check 2.2.1

Using lobby_boy 0.1.2

Using openproject-auth_plugins 6.1.4 from source at `vendored-plugins/openproject-auth_plugins`

Using openproject-pdf_export 6.1.4 from source at `vendored-plugins/openproject-pdf_export`

Using openproject-costs 6.1.4 from source at `vendored-plugins/openproject-costs`

Using openproject-documents 6.1.4 from source at `vendored-plugins/openproject-documents`

Using openproject-webhooks 6.1.4 from source at `vendored-plugins/openproject-webhooks`

Using openproject-global_roles 6.1.4 from source at `vendored-plugins/openproject-global_roles`

Using openproject-local_avatars 6.1.4 from source at `vendored-plugins/openproject-local_avatars`

Using openproject-meeting 6.1.4 from source at `vendored-plugins/openproject-meeting`

Using openproject-my_project_page 6.1.4 from source at `vendored-plugins/openproject-my_project_page`

Using reporting_engine 6.1.4 from source at `vendored-plugins/reporting_engine`

Using openproject-themes-dark 6.1.4 from source at `vendored-plugins/openproject-themes-dark`

Using openproject-translations 6.1.4 from https://github.com/opf/openproject-translations.git (at stable/6@da52ff9)

Using openproject-xls_export 6.1.4 from source at `vendored-plugins/openproject-xls_export`

Using rails-angular-xss 0.3.0.pre.pre from https://github.com/opf/rails-angular-xss (at a45267d@a45267d)

Using rails_autolink 1.1.6

Using openproject-openid_connect 6.1.4 from source at `vendored-plugins/openproject-openid_connect`

Using openproject-backlogs 6.1.4 from source at `vendored-plugins/openproject-backlogs`

Using openproject-github_integration 6.1.4 from source at `vendored-plugins/openproject-github_integration`

Using openproject-reporting 6.1.4 from source at `vendored-plugins/openproject-reporting`

Bundle complete! 138 Gemfile dependencies, 195 gems now installed.

Gems in the groups development and test were not installed.

Bundled gems are installed into ./vendor/bundle.

Bundle completed (10.54s)

Cleaning up the bundler cache.

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

-----> Detecting rake tasks

-----> Preparing app for Rails asset pipeline

Running: rake assets:precompile

$(npm bin)/webpack --config webpack.production.config.js

{"omniauth-openid-connect":"/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid-connect-c3bce4c9e9ac","omniauth-openid_connect-providers":"/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid_connect-providers-86f3670e127e","omniauth-saml":"/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-saml-5559d6b80805","openproject-auth_plugins":"/tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-auth_plugins","openproject-auth_saml":"/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-auth_saml-97212abb8378","openproject-pdf_export":"/tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-pdf_export","openproject-backlogs":"/tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-backlogs","openproject-costs":"/tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-costs","openproject-documents":"/tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-documents","openproject-webhooks":"/tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-webhooks","openproject-github_integration":"/tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-github_integration","openproject-global_roles":"/tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-global_roles","openproject-local_avatars":"/tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-local_avatars","openproject-meeting":"/tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-meeting","openproject-my_project_page":"/tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-my_project_page","openproject-openid_connect":"/tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-openid_connect","reporting_engine":"/tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/reporting_engine","openproject-reporting":"/tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-reporting","openproject-themes-dark":"/tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-themes-dark","openproject-translations":"/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-translations-da52ff92cdcd","openproject-xls_export":"/tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-xls_export"}

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Hash: 3be7ca5cf58fa64d7819

Version: webpack 1.13.3

Child

Hash: 3be7ca5cf58fa64d7819

Version: webpack 1.13.3

Time: 17449ms

Asset Size Chunks Chunk Names

7b9776076d5fceef4993b55c9383dedd.gif 1.85 kB [emitted]

openproject-backlogs.js 453 kB 0 [emitted] backlogs

openproject-core-app.js 3.43 MB 1 [emitted] core-app

openproject-costs.js 526 kB 2 [emitted] costs

openproject-global.js 3.51 MB 3 [emitted] global

openproject-my_project_page.js 14.3 kB 4 [emitted] my_project_page

openproject-core-app.css 4.71 kB 1 [emitted] core-app

openproject-global.css 49 kB 3 [emitted] global

[213] ./templates \.html$ 1.22 kB {1} [built]

[242] ./components ^((?!\.(test|spec)).)*\.(js|ts|html)$ 16.1 kB {1} [built]

[633] /tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 425 bytes {2} [built]

[765] /tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 330 bytes {4} [built]

+ 769 hidden modules

ERROR in [default]

File '/tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-budget-subform.directive.ts' is not under 'rootDir' '/tmp/d20170210-18-yyhehe/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts' is not under 'rootDir' '/tmp/d20170210-18-yyhehe/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/subform/cost-subform.directive.ts' is not under 'rootDir' '/tmp/d20170210-18-yyhehe/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts' is not under 'rootDir' '/tmp/d20170210-18-yyhehe/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts' is not under 'rootDir' '/tmp/d20170210-18-yyhehe/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-block.directive.ts' is not under 'rootDir' '/tmp/d20170210-18-yyhehe/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-page-layout.directive.ts' is not under 'rootDir' '/tmp/d20170210-18-yyhehe/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-textile-block.directive.ts' is not under 'rootDir' '/tmp/d20170210-18-yyhehe/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default] /tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:49:18

Argument of type 'string' is not assignable to parameter of type '{ [key: string]: any; }'.

ERROR in [default] /tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:53:4

Supplied parameters do not match any signature of call target.

ERROR in [default] /tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:30:38

Cannot find module 'app/components/work-packages/work-package-cache.service'.

ERROR in [default] /tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:49:30

Cannot find name 'HalResource'.

ERROR in [default] /tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:54:57

Property '$injector' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:13

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:27

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:60:11

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:70:23

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:76:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:77:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:78:16

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:36:17

Property 'value' does not exist on type 'CurrencyDisplayField'.

ERROR in [default] /tmp/d20170210-18-yyhehe/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:37:23

Property 'value' does not exist on type 'CurrencyDisplayField'.

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 5 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

rake aborted!

PG::ConnectionBad: server closed the connection unexpectedly

This probably means the server terminated abnormally

before or while processing the request.

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activerecord-5.0.0.1/lib/active_record/connection_adapters/postgresql_adapter.rb:671:in `initialize'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activerecord-5.0.0.1/lib/active_record/connection_adapters/postgresql_adapter.rb:671:in `new'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activerecord-5.0.0.1/lib/active_record/connection_adapters/postgresql_adapter.rb:671:in `connect'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activerecord-5.0.0.1/lib/active_record/connection_adapters/postgresql_adapter.rb:217:in `initialize'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activerecord-5.0.0.1/lib/active_record/connection_adapters/postgresql_adapter.rb:37:in `new'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activerecord-5.0.0.1/lib/active_record/connection_adapters/postgresql_adapter.rb:37:in `postgresql_connection'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activerecord-5.0.0.1/lib/active_record/connection_adapters/abstract/connection_pool.rb:721:in `new_connection'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activerecord-5.0.0.1/lib/active_record/connection_adapters/abstract/connection_pool.rb:765:in `checkout_new_connection'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activerecord-5.0.0.1/lib/active_record/connection_adapters/abstract/connection_pool.rb:744:in `try_to_checkout_new_connection'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activerecord-5.0.0.1/lib/active_record/connection_adapters/abstract/connection_pool.rb:705:in `acquire_connection'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activerecord-5.0.0.1/lib/active_record/connection_adapters/abstract/connection_pool.rb:501:in `checkout'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activerecord-5.0.0.1/lib/active_record/connection_adapters/abstract/connection_pool.rb:364:in `connection'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activerecord-5.0.0.1/lib/active_record/connection_adapters/abstract/connection_pool.rb:875:in `retrieve_connection'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activerecord-5.0.0.1/lib/active_record/connection_handling.rb:128:in `retrieve_connection'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activerecord-5.0.0.1/lib/active_record/connection_handling.rb:91:in `connection'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activerecord-5.0.0.1/lib/active_record/model_schema.rb:248:in `table_exists?'

/tmp/d20170210-18-yyhehe/opt/openproject/config/initializers/30-redmine.rb:36:in `<top (required)>'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activesupport-5.0.0.1/lib/active_support/dependencies.rb:287:in `load'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activesupport-5.0.0.1/lib/active_support/dependencies.rb:287:in `block in load'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activesupport-5.0.0.1/lib/active_support/dependencies.rb:259:in `load_dependency'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activesupport-5.0.0.1/lib/active_support/dependencies.rb:287:in `load'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/railties-5.0.0.1/lib/rails/engine.rb:648:in `block in load_config_initializer'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activesupport-5.0.0.1/lib/active_support/notifications.rb:166:in `instrument'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/railties-5.0.0.1/lib/rails/engine.rb:647:in `load_config_initializer'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/railties-5.0.0.1/lib/rails/engine.rb:612:in `block (2 levels) in <class:Engine>'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/railties-5.0.0.1/lib/rails/engine.rb:611:in `each'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/railties-5.0.0.1/lib/rails/engine.rb:611:in `block in <class:Engine>'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/railties-5.0.0.1/lib/rails/initializable.rb:30:in `instance_exec'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/railties-5.0.0.1/lib/rails/initializable.rb:30:in `run'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/railties-5.0.0.1/lib/rails/initializable.rb:55:in `block in run_initializers'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/railties-5.0.0.1/lib/rails/initializable.rb:44:in `each'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/railties-5.0.0.1/lib/rails/initializable.rb:44:in `tsort_each_child'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/railties-5.0.0.1/lib/rails/initializable.rb:54:in `run_initializers'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/railties-5.0.0.1/lib/rails/application.rb:352:in `initialize!'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/railties-5.0.0.1/lib/rails/railtie.rb:193:in `public_send'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/railties-5.0.0.1/lib/rails/railtie.rb:193:in `method_missing'

/tmp/d20170210-18-yyhehe/opt/openproject/config/environment.rb:34:in `<top (required)>'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activesupport-5.0.0.1/lib/active_support/dependencies.rb:293:in `require'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activesupport-5.0.0.1/lib/active_support/dependencies.rb:293:in `block in require'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activesupport-5.0.0.1/lib/active_support/dependencies.rb:259:in `load_dependency'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/activesupport-5.0.0.1/lib/active_support/dependencies.rb:293:in `require'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/railties-5.0.0.1/lib/rails/application.rb:328:in `require_environment!'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/railties-5.0.0.1/lib/rails/application.rb:448:in `block in run_tasks_blocks'

/tmp/d20170210-18-yyhehe/opt/openproject/vendor/bundle/ruby/2.3.0/gems/rake-11.3.0/exe/rake:27:in `<top (required)>'

Tasks: TOP => assets:precompile => assets:compile_environment => assets:prepare_op => assets:export_locales => i18n:js:export => environment

(See full trace by running task with --trace)

!

! Precompiling assets failed.

!

! ERROR: compile failed

! FAILED.

Failure during packaging

! Please contact support.

====== Attempt #2

-----> Fetching repository

Cloning into '/tmp/d20170223-16665-1whepai/input'...

-----> Restoring cache

-----> Starting packaging process

-----> Installing missing build dependencies: libmagickwand-dev, libsqlite3-dev

-----> [wizard] adding legacy-installer wizard (https://github.com/pkgr/addon-legacy-installer#master)

-----> [wizard] adding mysql wizard (https://github.com/pkgr/addon-mysql#master)

-----> [wizard] adding apache2 wizard (https://github.com/pkgr/addon-apache2#master)

-----> [wizard] adding repositories wizard (https://github.com/finnlabs/addon-repositories#master)

-----> [wizard] adding smtp wizard (https://github.com/pkgr/addon-smtp#master)

-----> [wizard] adding memcached wizard (https://github.com/pkgr/addon-memcached#master)

-----> [wizard] adding openproject wizard (https://github.com/pkgr/addon-openproject#master)

-----> Fetching buildpack https://github.com/opf/heroku-buildpack-multi.git at master

-----> Multipack app

-----> Running hook: "packaging/setup"

WARNING: This buildpack is no longer maintained.

Please choose a different buildpack or go to https://github.com/ddollar/heroku-buildpack-multi

and fork it to your own account.

=====> Downloading Buildpack: https://github.com/pkgr/pkgr-buildpack-imagemagick.git

=====> Detected Framework: ImageMagick

-----> SKIP

=====> Downloading Buildpack: https://github.com/heroku/heroku-buildpack-nodejs.git

=====> Detected Framework: Node.js

-----> Reading application state

package.json...

build directory...

cache directory...

environment variables...

Node engine: 6.9.1

Npm engine: 4.0.0

Start mechanism: Procfile

node_modules source: package.json

node_modules cached: true

NPM_CONFIG_PRODUCTION=true

NODE_MODULES_CACHE=true

-----> Installing binaries

Downloading and installing node 6.9.1...

Downloading and installing npm 4.0.0 (replacing version 3.10.8)...

-----> Building dependencies

Restoring node modules from cache

Pruning unused dependencies

Installing any new modules

> openproject@0.1.0 postinstall /tmp/d20170223-17-1yooo7y/opt/openproject

> cd frontend && npm install

> openproject-frontend@0.1.0 postinstall /tmp/d20170223-17-1yooo7y/opt/openproject/frontend

> bower install --config.interactive=false

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 not-cached git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolve git://github.com/finnlabs/angular-modal.git#d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de not-cached git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolve git://github.com/sparkalow/angular-truncate.git#fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 not-cached git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolve git://github.com/nickmessing/angular-context-menu.git#a908eccaec323cd66973d58af4965694bdff16a1

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 checkout d45eb9ceb720b8785613ba89ba0f14f8ab197569

bower jquery-ujs#1.0.0 not-cached https://github.com/rails/jquery-ujs.git#1.0.0

bower jquery-ujs#1.0.0 resolve https://github.com/rails/jquery-ujs.git#1.0.0

bower select2#3.5.2 not-cached https://github.com/ivaynberg/select2.git#3.5.2

bower select2#3.5.2 resolve https://github.com/ivaynberg/select2.git#3.5.2

bower jquery#1.11.0 not-cached https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery#1.11.0 resolve https://github.com/jquery/jquery-dist.git#1.11.0

bower jquery-ui#~1.10.4 not-cached https://github.com/components/jqueryui.git#~1.10.4

bower jquery-ui#~1.10.4 resolve https://github.com/components/jqueryui.git#~1.10.4

bower jquery.atwho#0.5.1 not-cached https://github.com/ichord/At.js.git#0.5.1

bower jquery.atwho#0.5.1 resolve https://github.com/ichord/At.js.git#0.5.1

bower angular-animate#~1.5.8 not-cached https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular-animate#~1.5.8 resolve https://github.com/angular/bower-angular-animate.git#~1.5.8

bower angular#~1.5.8 not-cached https://github.com/angular/bower-angular.git#~1.5.8

bower angular#~1.5.8 resolve https://github.com/angular/bower-angular.git#~1.5.8

bower angular-aria#~1.5.8 not-cached https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-aria#~1.5.8 resolve https://github.com/angular/bower-angular-aria.git#~1.5.8

bower angular-ui-router#~0.3.1 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-ui-router#~0.3.1 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.3.1

bower angular-i18n#~1.5.5 not-cached https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-i18n#~1.5.5 resolve https://github.com/angular/bower-angular-i18n.git#~1.5.5

bower angular-sanitize#~1.5.8 not-cached https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-sanitize#~1.5.8 resolve https://github.com/angular/bower-angular-sanitize.git#~1.5.8

bower angular-elastic#~2.5.1 not-cached https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-elastic#~2.5.1 resolve https://github.com/monospaced/angular-elastic.git#~2.5.1

bower angular-cache#~4.6.0 not-cached https://github.com/jmdobry/angular-cache.git#~4.6.0

bower angular-cache#~4.6.0 resolve https://github.com/jmdobry/angular-cache.git#~4.6.0

bower moment-timezone#0.4.x not-cached https://github.com/moment/moment-timezone.git#0.4.x

bower moment-timezone#0.4.x resolve https://github.com/moment/moment-timezone.git#0.4.x

bower jquery-migrate#~1.2.1 not-cached https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower jquery-migrate#~1.2.1 resolve https://github.com/appleboy/jquery-migrate.git#~1.2.1

bower moment#~2.10.6 not-cached https://github.com/moment/moment.git#~2.10.6

bower moment#~2.10.6 resolve https://github.com/moment/moment.git#~2.10.6

bower angular-busy#~4.1.3 not-cached https://github.com/cgross/angular-busy.git#~4.1.3

bower angular-busy#~4.1.3 resolve https://github.com/cgross/angular-busy.git#~4.1.3

bower bourbon#~4.2.1 not-cached https://github.com/thoughtbot/bourbon.git#~4.2.1

bower bourbon#~4.2.1 resolve https://github.com/thoughtbot/bourbon.git#~4.2.1

bower foundation-apps#1.1.0 not-cached https://github.com/zurb/foundation-apps.git#1.1.0

bower foundation-apps#1.1.0 resolve https://github.com/zurb/foundation-apps.git#1.1.0

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de checkout fdf60fda265042d12e9414b5354b2cc52f1419de

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 checkout a908eccaec323cd66973d58af4965694bdff16a1

bower angular-ui-select#~0.19.4 not-cached https://github.com/angular-ui/ui-select.git#~0.19.4

bower angular-ui-select#~0.19.4 resolve https://github.com/angular-ui/ui-select.git#~0.19.4

bower mousetrap#~1.4.6 not-cached https://github.com/ccampbell/mousetrap.git#~1.4.6

bower mousetrap#~1.4.6 resolve https://github.com/ccampbell/mousetrap.git#~1.4.6

bower ng-file-upload#~5.0.9 not-cached https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower ng-file-upload#~5.0.9 resolve https://github.com/danialfarid/angular-file-upload-bower.git#~5.0.9

bower angular-dragula#^1.2.8 not-cached https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower angular-dragula#^1.2.8 resolve https://github.com/bevacqua/angular-dragula.git#^1.2.8

bower ng-dialog#^0.6.2 not-cached https://github.com/likeastore/ngDialog.git#^0.6.2

bower ng-dialog#^0.6.2 resolve https://github.com/likeastore/ngDialog.git#^0.6.2

bower mocha#~1.14.0 not-cached https://github.com/mochajs/mocha.git#~1.14.0

bower mocha#~1.14.0 resolve https://github.com/mochajs/mocha.git#~1.14.0

bower angular-mocks#~1.5.8 not-cached https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower angular-mocks#~1.5.8 resolve https://github.com/angular/bower-angular-mocks.git#~1.5.8

bower chai#~1.9.0 not-cached https://github.com/chaijs/chai.git#~1.9.0

bower chai#~1.9.0 resolve https://github.com/chaijs/chai.git#~1.9.0

bower jquery-ujs#1.0.0 checkout v1.0.0

bower select2#3.5.2 checkout 3.5.2

bower rxjs#^4.1.0 not-cached https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower rxjs#^4.1.0 resolve https://github.com/Reactive-Extensions/RxJS.git#^4.1.0

bower jquery#1.11.0 checkout 1.11.0

bower jquery-ui#~1.10.4 checkout 1.10.4

bower jquery.atwho#0.5.1 checkout v0.5.1

bower angular-animate#~1.5.8 checkout v1.5.11

bower angular-aria#~1.5.8 checkout v1.5.11

bower angular-ui-router#~0.3.1 checkout 0.3.2

bower angular-elastic#~2.5.1 checkout v2.5.1

bower angular-i18n#~1.5.5 checkout v1.5.11

bower angular#~1.5.8 checkout v1.5.11

bower moment#~2.10.6 checkout 2.10.6

bower jquery-migrate#~1.2.1 checkout 1.2.1

bower moment-timezone#0.4.x checkout 0.4.1

bower angular-cache#~4.6.0 checkout 4.6.0

bower angular-sanitize#~1.5.8 checkout v1.5.11

bower mousetrap#~1.4.6 checkout 1.4.6

bower angular-ui-select#~0.19.4 checkout v0.19.6

bower foundation-apps#1.1.0 checkout v1.1.0

bower bourbon#~4.2.1 checkout v4.2.7

bower angular-busy#~4.1.3 checkout v4.1.4

bower ng-file-upload#~5.0.9 checkout 5.0.9

bower angular-dragula#^1.2.8 checkout v1.2.8

bower ng-dialog#^0.6.2 checkout v0.6.6

bower mocha#~1.14.0 checkout 1.14.0

bower angular-mocks#~1.5.8 checkout v1.5.11

bower rxjs#^4.1.0 checkout v4.1.0

bower chai#~1.9.0 checkout 1.9.2

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field cannot contain font, image, audio, or video files

bower select2#3.5.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .png files: ["select2.png","select2x2.png"]

bower select2#3.5.2 resolved https://github.com/ivaynberg/select2.git#3.5.2

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de resolved git://github.com/sparkalow/angular-truncate.git#fdf60fda26

bower jquery-mockjax#~1.5.3 not-cached https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower jquery-mockjax#~1.5.3 resolve https://github.com/jakerella/jquery-mockjax.git#~1.5.3

bower lodash#~2.4.1 not-cached https://github.com/lodash/lodash.git#~2.4.1

bower lodash#~2.4.1 resolve https://github.com/lodash/lodash.git#~2.4.1

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 resolved git://github.com/nickmessing/angular-context-menu.git#a908eccaec

bower angular#>= 1.2.5 not-cached https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 resolve https://github.com/angular/bower-angular.git#>= 1.2.5

bower angular#>= 1.2.5 checkout v1.6.2

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 resolved git://github.com/finnlabs/angular-modal.git#d45eb9ceb7

bower angular#^1.3.0 not-cached https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 resolve https://github.com/angular/bower-angular.git#^1.3.0

bower angular#^1.3.0 checkout v1.6.2

bower jquery-ujs#1.0.0 resolved https://github.com/rails/jquery-ujs.git#1.0.0

bower jquery.atwho#0.5.1 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower angular-aria#~1.5.8 resolved https://github.com/angular/bower-angular-aria.git#1.5.11

bower jquery-ui#~1.10.4 resolved https://github.com/components/jqueryui.git#1.10.4

bower angular-animate#~1.5.8 resolved https://github.com/angular/bower-angular-animate.git#1.5.11

bower jquery.atwho#0.5.1 resolved https://github.com/ichord/At.js.git#0.5.1

bower jquery#1.11.0 resolved https://github.com/jquery/jquery-dist.git#1.11.0

bower Caret.js#>= 0.2.0 not-cached https://github.com/ichord/Caret.js.git#>= 0.2.0

bower Caret.js#>= 0.2.0 resolve https://github.com/ichord/Caret.js.git#>= 0.2.0

bower angular-elastic#~2.5.1 resolved https://github.com/monospaced/angular-elastic.git#2.5.1

bower angular#>=1.0.6 not-cached https://github.com/angular/bower-angular.git#>=1.0.6

bower angular#>=1.0.6 resolve https://github.com/angular/bower-angular.git#>=1.0.6

bower angular#>=1.0.6 checkout v1.6.2

bower angular-ui-router#~0.3.1 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.3.2

bower jquery-migrate#~1.2.1 deprecated Package jquery-migrate is using the deprecated component.json

bower jquery-migrate#~1.2.1 resolved https://github.com/appleboy/jquery-migrate.git#1.2.1

bower angular#~1.5.8 resolved https://github.com/angular/bower-angular.git#1.5.11

bower moment#~2.10.6 resolved https://github.com/moment/moment.git#2.10.6

bower angular-cache#~4.6.0 resolved https://github.com/jmdobry/angular-cache.git#4.6.0

bower mousetrap#~1.4.6 resolved https://github.com/ccampbell/mousetrap.git#1.4.6

bower angular-sanitize#~1.5.8 resolved https://github.com/angular/bower-angular-sanitize.git#1.5.11

bower angular-ui-select#~0.19.4 resolved https://github.com/angular-ui/ui-select.git#0.19.6

bower moment-timezone#0.4.x resolved https://github.com/moment/moment-timezone.git#0.4.1

bower ng-file-upload#~5.0.9 resolved https://github.com/danialfarid/angular-file-upload-bower.git#5.0.9

bower bourbon#~4.2.1 resolved https://github.com/thoughtbot/bourbon.git#4.2.7

bower angular-busy#~4.1.3 resolved https://github.com/cgross/angular-busy.git#4.1.4

bower foundation-apps#1.1.0 resolved https://github.com/zurb/foundation-apps.git#1.1.0

bower angular#~1.3.4 not-cached https://github.com/angular/bower-angular.git#~1.3.4

bower angular#~1.3.4 resolve https://github.com/angular/bower-angular.git#~1.3.4

bower angular-ui-router#~0.2.12 not-cached https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-ui-router#~0.2.12 resolve https://github.com/angular-ui/angular-ui-router-bower.git#~0.2.12

bower angular-animate#~1.3.4 not-cached https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular-animate#~1.3.4 resolve https://github.com/angular/bower-angular-animate.git#~1.3.4

bower angular#~1.3.4 checkout v1.3.20

bower angular-ui-router#~0.2.12 checkout 0.2.18

bower angular-animate#~1.3.4 checkout v1.3.20

bower ng-dialog#^0.6.2 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .css files: ["css/ngDialog.css","css/ngDialog-theme-default.css"]

bower angular-dragula#^1.2.8 resolved https://github.com/bevacqua/angular-dragula.git#1.2.8

bower angular-mocks#~1.5.8 resolved https://github.com/angular/bower-angular-mocks.git#1.5.11

bower tether#~0.6.5 not-cached https://github.com/HubSpot/tether.git#~0.6.5

bower tether#~0.6.5 resolve https://github.com/HubSpot/tether.git#~0.6.5

bower hammerjs#~2.0.4 not-cached https://github.com/EightMedia/hammer.js.git#~2.0.4

bower hammerjs#~2.0.4 resolve https://github.com/EightMedia/hammer.js.git#~2.0.4

bower viewport-units-buggyfill#~0.4.1 not-cached https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower viewport-units-buggyfill#~0.4.1 resolve https://github.com/rodneyrehm/viewport-units-buggyfill.git#~0.4.1

bower mocha#~1.14.0 mismatch Version declared in the json (1.12.0) is different than the resolved one (1.14.0)

bower mocha#~1.14.0 resolved https://github.com/mochajs/mocha.git#1.14.0

bower fastclick#~1.0.3 not-cached https://github.com/ftlabs/fastclick.git#~1.0.3

bower fastclick#~1.0.3 resolve https://github.com/ftlabs/fastclick.git#~1.0.3

bower ng-dialog#^0.6.2 resolved https://github.com/likeastore/ngDialog.git#0.6.6

bower jquery-mockjax#~1.5.3 checkout v1.5.4

bower lodash#~2.4.1 checkout 2.4.2

bower angular-i18n#~1.5.5 resolved https://github.com/angular/bower-angular-i18n.git#1.5.11

bower chai#~1.9.0 resolved https://github.com/chaijs/chai.git#1.9.2

bower Caret.js#>= 0.2.0 checkout v0.3.1

bower angular#>= 1.2.5 resolved https://github.com/angular/bower-angular.git#1.6.2

bower angular#^1.3.0 resolved https://github.com/angular/bower-angular.git#1.6.2

bower rxjs#^4.1.0 resolved https://github.com/Reactive-Extensions/RxJS.git#4.1.0

bower angular#>=1.0.6 resolved https://github.com/angular/bower-angular.git#1.6.2

bower angular#~1.3.4 resolved https://github.com/angular/bower-angular.git#1.3.20

bower tether#~0.6.5 checkout v0.6.5

bower angular-ui-router#~0.2.12 resolved https://github.com/angular-ui/angular-ui-router-bower.git#0.2.18

bower angular-animate#~1.3.4 resolved https://github.com/angular/bower-angular-animate.git#1.3.20

bower viewport-units-buggyfill#~0.4.1 checkout v0.4.1

bower hammerjs#~2.0.4 checkout v2.0.8

bower fastclick#~1.0.3 checkout v1.0.6

bower jquery-mockjax#~1.5.3 resolved https://github.com/jakerella/jquery-mockjax.git#1.5.4

bower Caret.js#>= 0.2.0 invalid-meta The "name" is recommended to be lowercase, can contain digits, dots, dashes

bower Caret.js#>= 0.2.0 resolved https://github.com/ichord/Caret.js.git#0.3.1

bower viewport-units-buggyfill#~0.4.1 invalid-meta The "main" field has to contain only 1 file per filetype; found multiple .js files: ["./viewport-units-buggyfill.js","./viewport-units-buggyfill.hacks.js"]

bower lodash#~2.4.1 resolved https://github.com/lodash/lodash.git#2.4.2

bower viewport-units-buggyfill#~0.4.1 resolved https://github.com/rodneyrehm/viewport-units-buggyfill.git#0.4.1

bower tether#~0.6.5 resolved https://github.com/HubSpot/tether.git#0.6.5

bower fastclick#~1.0.3 resolved https://github.com/ftlabs/fastclick.git#1.0.6

bower hammerjs#~2.0.4 resolved https://github.com/EightMedia/hammer.js.git#2.0.8

Please note that,

foundation-apps#1.1.0 depends on angular-animate#~1.3.4 which resolved to angular-animate#1.3.20

openproject depends on angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

angular-busy#4.1.4 depends on angular-animate#>=1.3 which resolved to angular-animate#1.5.11

Resort to using angular-animate#~1.5.8 which resolved to angular-animate#1.5.11

Code incompatibilities may occur.

Please note that,

foundation-apps#1.1.0 depends on angular-ui-router#~0.2.12 which resolved to angular-ui-router#0.2.18

openproject depends on angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Resort to using angular-ui-router#~0.3.1 which resolved to angular-ui-router#0.3.2

Code incompatibilities may occur.

Please note that,

angular-animate#1.3.20 depends on angular#1.3.20 which resolved to angular#1.3.20

foundation-apps#1.1.0 depends on angular#~1.3.4 which resolved to angular#1.3.20

angular-animate#1.5.11, angular-aria#1.5.11, angular-mocks#1.5.11, angular-sanitize#1.5.11 depends on angular#1.5.11 which resolved to angular#1.5.11

angular-ui-router#0.3.2, angular-ui-router#0.2.18 depends on angular#^1.0.8 which resolved to angular#1.5.11

angular-ui-select#0.19.6 depends on angular#>=1.2.18 which resolved to angular#1.5.11

angular-busy#4.1.4 depends on angular#>=1.3 which resolved to angular#1.5.11

ng-dialog#0.6.6 depends on angular#>=1.5 which resolved to angular#1.5.11

openproject depends on angular#~1.5.8 which resolved to angular#1.5.11

angular-cache#4.6.0 depends on angular#>=1.x which resolved to angular#1.5.11

angular-modal#d45eb9ceb7 depends on angular#^1.3.0 which resolved to angular#1.6.2

angular-elastic#2.5.1 depends on angular#>=1.0.6 which resolved to angular#1.6.2

angular-context-menu#a908eccaec depends on angular#>= 1.2.5 which resolved to angular#1.6.2

Resort to using angular#~1.5.8 which resolved to angular#1.5.11

Code incompatibilities may occur.

bower jquery extra-resolution Unnecessary resolution: jquery#1.11.0

bower select2#3.5.2 install select2#3.5.2

bower angular-truncate#fdf60fda265042d12e9414b5354b2cc52f1419de install angular-truncate#fdf60fda26

bower angular-context-menu#a908eccaec323cd66973d58af4965694bdff16a1 install angular-context-menu#a908eccaec

bower angular-modal#d45eb9ceb720b8785613ba89ba0f14f8ab197569 install angular-modal#d45eb9ceb7

bower jquery-ujs#1.0.0 install jquery-ujs#1.0.0

bower angular-aria#~1.5.8 install angular-aria#1.5.11

bower jquery-ui#~1.10.4 install jquery-ui#1.10.4

bower angular-animate#~1.5.8 install angular-animate#1.5.11

bower jquery.atwho#0.5.1 install jquery.atwho#0.5.1

bower jquery#1.11.0 install jquery#1.11.0

bower angular-elastic#~2.5.1 install angular-elastic#2.5.1

bower angular-ui-router#~0.3.1 install angular-ui-router#0.3.2

bower jquery-migrate#~1.2.1 install jquery-migrate#1.2.1

bower angular#1.5.11 install angular#1.5.11

bower moment#~2.10.6 install moment#2.10.6

bower angular-cache#~4.6.0 install angular-cache#4.6.0

bower mousetrap#~1.4.6 install mousetrap#1.4.6

bower angular-sanitize#~1.5.8 install angular-sanitize#1.5.11

bower angular-ui-select#~0.19.4 install angular-ui-select#0.19.6

bower moment-timezone#0.4.x install moment-timezone#0.4.1

bower ng-file-upload#~5.0.9 install ng-file-upload#5.0.9

bower bourbon#~4.2.1 install bourbon#4.2.7

bower angular-busy#~4.1.3 install angular-busy#4.1.4

bower foundation-apps#1.1.0 install foundation-apps#1.1.0

bower angular-dragula#^1.2.8 install angular-dragula#1.2.8

bower angular-mocks#~1.5.8 install angular-mocks#1.5.11

bower mocha#~1.14.0 install mocha#1.14.0

bower ng-dialog#^0.6.2 install ng-dialog#0.6.6

bower angular-i18n#~1.5.5 install angular-i18n#1.5.11

bower chai#~1.9.0 install chai#1.9.2

bower rxjs#^4.1.0 install rxjs#4.1.0

bower jquery-mockjax#~1.5.3 install jquery-mockjax#1.5.4

bower Caret.js#>= 0.2.0 install Caret.js#0.3.1

bower lodash#~2.4.1 install lodash#2.4.2

bower viewport-units-buggyfill#~0.4.1 install viewport-units-buggyfill#0.4.1

bower tether#~0.6.5 install tether#0.6.5

bower fastclick#~1.0.3 install fastclick#1.0.6

bower hammerjs#~2.0.4 install hammerjs#2.0.8

select2#3.5.2 bower_components/select2

└── jquery#1.11.0

angular-truncate#fdf60fda26 bower_components/angular-truncate

angular-context-menu#a908eccaec bower_components/angular-context-menu

└── angular#1.5.11

angular-modal#d45eb9ceb7 bower_components/angular-modal

└── angular#1.5.11

jquery-ujs#1.0.0 bower_components/jquery-ujs

└── jquery#1.11.0

angular-aria#1.5.11 bower_components/angular-aria

└── angular#1.5.11

jquery-ui#1.10.4 bower_components/jquery-ui

└── jquery#1.11.0

angular-animate#1.5.11 bower_components/angular-animate

└── angular#1.5.11

jquery.atwho#0.5.1 bower_components/jquery.atwho

├── Caret.js#0.3.1

└── jquery#1.11.0

jquery#1.11.0 bower_components/jquery

angular-elastic#2.5.1 bower_components/angular-elastic

└── angular#1.5.11

angular-ui-router#0.3.2 bower_components/angular-ui-router

└── angular#1.5.11

jquery-migrate#1.2.1 bower_components/jquery-migrate

angular#1.5.11 bower_components/angular

moment#2.10.6 bower_components/moment

angular-cache#4.6.0 bower_components/angular-cache

└── angular#1.5.11

mousetrap#1.4.6 bower_components/mousetrap

angular-sanitize#1.5.11 bower_components/angular-sanitize

└── angular#1.5.11

angular-ui-select#0.19.6 bower_components/angular-ui-select

└── angular#1.5.11

moment-timezone#0.4.1 bower_components/moment-timezone

└── moment#2.10.6

ng-file-upload#5.0.9 bower_components/ng-file-upload

bourbon#4.2.7 bower_components/bourbon

angular-busy#4.1.4 bower_components/angular-busy

├── angular#1.5.11

└── angular-animate#1.5.11

foundation-apps#1.1.0 bower_components/foundation-apps

├── angular#1.5.11

├── angular-animate#1.5.11

├── angular-ui-router#0.3.2

├── fastclick#1.0.6

├── hammerjs#2.0.8

├── tether#0.6.5

└── viewport-units-buggyfill#0.4.1

angular-dragula#1.2.8 bower_components/angular-dragula

angular-mocks#1.5.11 bower_components/angular-mocks

└── angular#1.5.11

mocha#1.14.0 bower_components/mocha

ng-dialog#0.6.6 bower_components/ng-dialog

└── angular#1.5.11

angular-i18n#1.5.11 bower_components/angular-i18n

chai#1.9.2 bower_components/chai

rxjs#4.1.0 bower_components/rxjs

jquery-mockjax#1.5.4 bower_components/jquery-mockjax

Caret.js#0.3.1 bower_components/Caret.js

└── jquery#1.11.0

lodash#2.4.2 bower_components/lodash

viewport-units-buggyfill#0.4.1 bower_components/viewport-units-buggyfill

tether#0.6.5 bower_components/tether

fastclick#1.0.6 bower_components/fastclick

hammerjs#2.0.8 bower_components/hammerjs

openproject-frontend@0.1.0 /tmp/d20170223-17-1yooo7y/opt/openproject/frontend

+-- acorn@2.6.4

+-- align-text@0.1.4

+-- alter@0.2.0

+-- amdefine@1.0.0

+-- angular@1.5.8

+-- angular-elastic@2.5.1

+-- angular-ui-bootstrap@2.2.0

+-- anymatch@1.3.0

+-- arr-diff@2.0.0

+-- arr-flatten@1.0.1

+-- array-unique@0.2.1

+-- arrify@1.0.1

+-- assert@1.4.1

+-- async@0.2.10

+-- async-each@1.0.1

+-- atoa@1.0.0

+-- autoprefixer-core@5.2.1

+-- autoprefixer-loader@1.2.0

+-- awesome-typescript-loader@2.2.4

| `-- lodash@4.16.4

+-- balanced-match@0.4.2

+-- Base64@0.2.1

+-- base64-js@1.2.0

+-- big.js@3.1.3

+-- binary-extensions@1.7.0

+-- bower@1.7.9

+-- brace-expansion@1.1.6

+-- braces@1.8.5

+-- browserify-zlib@0.1.4

+-- browserslist@0.4.0

+-- buffer@4.9.1

+-- buffer-shims@1.0.0

+-- camelcase@1.2.1

+-- caniuse-db@1.0.30000569

+-- center-align@0.1.3

+-- chokidar@1.6.1

+-- cliui@2.1.0

| `-- wordwrap@0.0.2

+-- clone@1.0.2

+-- colors@1.1.2

+-- concat-map@0.0.1

+-- console-browserify@1.1.0

+-- constants-browserify@0.0.1

+-- contra@1.9.4

+-- convert-source-map@1.1.3

+-- core-util-is@1.0.2

+-- crossvent@1.5.4

+-- crypto-browserify@3.2.8

+-- css-loader@0.9.1

| `-- source-map@0.1.43

+-- csso@1.3.12

+-- custom-event@1.0.0

+-- d@0.1.1

+-- date-now@0.1.4

+-- decamelize@1.2.0

+-- domain-browser@1.1.7

+-- dragula@3.7.2

+-- emojis-list@2.1.0

+-- enhanced-resolve@2.3.0

+-- errno@0.1.4

+-- es5-ext@0.10.12

+-- es6-iterator@2.0.0

+-- es6-promise@2.3.0

+-- es6-symbol@3.1.0

+-- es6-weak-map@0.1.4

| +-- es6-iterator@0.1.3

| `-- es6-symbol@2.0.1

+-- event-emitter@0.3.4

+-- events@1.1.1

+-- expand-brackets@0.1.5

+-- expand-range@1.8.2

+-- exports-loader@0.6.3

| `-- source-map@0.1.43

+-- expose-loader@0.6.0

+-- extglob@0.3.2

+-- extract-text-webpack-plugin@0.3.8

| `-- source-map@0.1.43

+-- fastparse@1.1.1

+-- file-loader@0.8.5

+-- filename-regex@2.0.0

+-- fill-range@2.2.3

+-- for-in@0.1.6

+-- for-own@0.1.4

+-- glob@4.5.3

+-- glob-base@0.3.0

+-- glob-parent@2.0.0

+-- graceful-fs@4.1.9

+-- has-flag@1.0.0

+-- html-loader@0.2.3

| `-- source-map@0.1.43

+-- html-minifier@0.5.6

+-- http-browserify@1.7.0

+-- https-browserify@0.0.0

+-- ieee754@1.1.8

+-- indexof@0.0.1

+-- inflight@1.0.6

+-- inherits@2.0.3

+-- interpret@0.6.6

+-- is-binary-path@1.0.1

+-- is-buffer@1.1.4

+-- is-dotfile@1.0.2

+-- is-equal-shallow@0.1.3

+-- is-extendable@0.1.1

+-- is-extglob@1.0.0

+-- is-glob@2.0.1

+-- is-number@2.1.0

+-- is-posix-bracket@0.1.1

+-- is-primitive@2.0.0

+-- isarray@1.0.0

+-- isobject@2.1.0

+-- js-base64@2.1.9

+-- json5@0.4.0

+-- kind-of@3.0.4

+-- lazy-cache@1.0.4

+-- loader-utils@0.2.16

| `-- json5@0.5.0

+-- lodash@2.4.2

+-- longest@1.0.1

+-- lru-queue@0.1.0

+-- memoizee@0.3.10

+-- memory-fs@0.3.0

+-- micromatch@2.3.11

+-- mime@1.2.11

+-- minimatch@2.0.10

+-- minimist@0.0.10

+-- mkdirp@0.5.1

| `-- minimist@0.0.8

+-- nan@2.4.0

+-- next-tick@0.2.2

+-- ng-annotate@1.2.1

| `-- source-map@0.5.6

+-- ng-annotate-loader@0.0.10

| `-- source-map@0.4.2

+-- ngtemplate-loader@0.1.3

+-- node-libs-browser@0.6.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- normalize-path@2.0.1

+-- num2fraction@1.2.2

+-- object-assign@4.1.0

+-- object.omit@2.0.1

+-- observable-array@0.0.4

+-- observable-value@0.0.5

+-- once@1.4.0

+-- optimist@0.6.1

+-- ordered-ast-traverse@1.1.1

+-- ordered-esprima-props@1.1.0

+-- os-browserify@0.1.2

+-- pako@0.2.9

+-- parse-glob@3.0.4

+-- path-browserify@0.0.0

+-- path-is-absolute@1.0.1

+-- pbkdf2-compat@2.0.1

+-- phantomjs-polyfill@0.0.2

+-- postcss@4.1.16

+-- preserve@0.2.0

+-- process@0.11.9

+-- process-nextick-args@1.0.7

+-- prr@0.0.0

+-- punycode@1.4.1

+-- querystring@0.2.0

+-- querystring-es3@0.2.1

+-- randomatic@1.1.5

+-- readable-stream@2.1.5

+-- readdirp@2.1.0

| `-- minimatch@3.0.3

+-- regex-cache@0.4.3

+-- repeat-element@1.1.2

+-- repeat-string@1.6.1

+-- right-align@0.1.3

+-- ripemd160@0.2.0

+-- set-immediate-shim@1.0.1

+-- sha.js@2.2.6

+-- shelljs@0.3.0

+-- simple-fmt@0.1.0

+-- simple-is@0.2.0

+-- source-list-map@0.1.6

+-- source-map@0.4.4

+-- source-map-support@0.4.5

| `-- source-map@0.5.6

+-- stable@0.1.5

+-- stream-browserify@1.0.0

| +-- isarray@0.0.1

| `-- readable-stream@1.1.14

+-- string_decoder@0.10.31

+-- stringmap@0.2.2

+-- stringset@0.2.1

+-- style-loader@0.8.3

+-- supports-color@3.1.2

+-- tapable@0.2.4

+-- ticky@1.0.1

+-- timers-browserify@1.4.2

+-- timers-ext@0.1.0

+-- tryor@0.1.2

+-- tty-browserify@0.0.0

+-- typescript@2.0.6

+-- uglify-js@2.7.4

| `-- source-map@0.5.6

+-- uglify-to-browserify@1.0.2

+-- URIjs@1.16.1

+-- url@0.10.3

| `-- punycode@1.3.2

+-- url-loader@0.5.7

+-- util@0.10.3

| `-- inherits@2.0.1

+-- util-deprecate@1.0.2

+-- vm-browserify@0.0.4

+-- watchpack@0.2.9

| `-- async@0.9.2

+-- webpack@1.13.3

| +-- acorn@3.3.0

| +-- async@1.5.2

| +-- enhanced-resolve@0.9.1

| | `-- memory-fs@0.2.0

| `-- tapable@0.1.10

+-- webpack-core@0.6.8

+-- window-size@0.1.0

+-- wordwrap@0.0.3

+-- wrappy@1.0.2

`-- yargs@3.10.0

npm WARN openproject-frontend@0.1.0 No repository field.

npm WARN openproject-frontend@0.1.0 No license field.

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.0.14 (node_modules/fsevents):

npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.0.14: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

-----> Checking startup method

Found Procfile

-----> Finalizing build

Creating runtime environment

Exporting binary paths

Cleaning npm artifacts

Cleaning previous cache

Caching results for future builds

-----> Build succeeded!

openproject@0.1.0 /tmp/d20170223-17-1yooo7y/opt/openproject

`-- typescript@2.0.8

=====> Downloading Buildpack: https://github.com/pkgr/heroku-buildpack-ruby.git

=====> Detected Framework: Ruby

-----> Compiling Ruby/Rails

-----> Using Ruby version: ruby-2.3.1

-----> Installing dependencies using bundler 1.13.2

cp: '/tmp/d20170223-17-1yooo7y/opt/openproject/.git/cache/vendor/bundle/.' and '/tmp/d20170223-17-1yooo7y/opt/openproject/.git/cache/vendor/bundle/.' are the same file

Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Fetching gem metadata from https://rubygems.org/........

Fetching version metadata from https://rubygems.org/...

Fetching dependency metadata from https://rubygems.org/..

Using rake 11.3.0

Using concurrent-ruby 1.0.2

Using i18n 0.7.0

Using minitest 5.9.0

Using thread_safe 0.3.5

Using builder 3.2.2

Using erubis 2.7.0

Using mini_portile2 2.1.0

Using pkg-config 1.1.7

Using rack 2.0.1

Using nio4r 1.2.1

Using websocket-extensions 0.1.2

Using mime-types 2.99.3

Using method_source 0.8.2

Using thor 0.19.1

Using arel 7.1.2

Using multi_json 1.12.1

Using acts_as_silent_list 3.0.0

Using addressable 2.4.0

Using airbrake-ruby 1.5.0

Using attr_required 1.0.1

Using execjs 2.7.0

Using ice_nine 0.11.2

Using bcrypt 3.1.11

Using bindata 2.3.4

Using sass 3.4.22

Using tilt 2.0.5

Using uber 0.0.15

Using erbse 0.0.2

Using coderay 1.1.1

Using color-tools 1.3.0

Using unf_ext 0.0.7.2

Using netrc 0.11.0

Using daemons 1.2.4

Using dalli 2.7.6

Using enumerable-lazy 0.0.1

Using equalizer 0.0.11

Using excon 0.52.0

Using ffi 1.9.14

Using formatador 0.2.5

Using ipaddress 0.8.3

Using get_process_mem 0.2.1

Using request_store 1.3.1

Using json 1.8.3

Using hashie 3.4.6

Using multi_xml 0.5.5

Using gravatar_image_tag 1.2.0

Using bundler 1.13.2

Using htmldiff 0.0.1

Using httpclient 2.8.2.4

Using icalendar 2.3.0

Using iso8601 0.9.1

Using securecompare 1.0.0

Using url_safe_base64 0.2.2

Using kgio 2.10.0

Using mixlib-shellout 2.1.0

Using mysql2 0.4.4

Using net-ldap 0.14.0

Using newrelic_rpm 3.16.2.321

Using oj 2.17.4

Using pdf-core 0.6.1

Using ttfunk 1.4.0

Using rmagick 2.15.4

Using rubyzip 1.2.0

Using ruby-ole 1.2.12

Using pg 0.19.0

Using rails_serve_static_assets 0.0.5

Using rails_stdout_logging 0.0.5

Using raindrops 0.17.0

Using ruby-progressbar 1.8.1

Using structured_warnings 0.2.0

Using sqlite3 1.3.11

Using stringex 2.6.1

Using svg-graph 2.0.1

Using syck 1.0.5

Using will_paginate 3.1.3

Using i18n-js 3.0.0.rc14

Using tzinfo 1.2.2

Using descendants_tracker 0.0.4

Using nokogiri 1.6.8

Using websocket-driver 0.6.4

Using rack-test 0.6.3

Using rack-accept 0.4.5

Using sprockets 3.7.0

Using passenger 5.0.30

Using rack-attack 5.0.1

Using rack-protection 2.0.0.beta2

Using warden 1.2.6

Using mail 2.6.4

Using airbrake 5.1.0

Using autoprefixer-rails 6.4.1.1

Using cells 4.1.3

Using bourbon 4.2.7

Using unf 0.1.4

Using mustermann19 0.4.4

Using fog-core 1.42.0

Using sys-filesystem 1.1.7

Using rdoc 4.2.2

Using omniauth 1.3.1 from https://github.com/oliverguenther/omniauth (at 8385bc0@8385bc0)

Using prawn 2.1.0

Using rails_12factor 0.0.3

Using spreadsheet 0.8.9

Using rubytree 0.9.7

Using unicorn 5.1.0

Using activesupport 5.0.0.1

Using tzinfo-data 1.2016.6

Using axiom-types 0.1.1

Using coercible 1.0.0

Using loofah 2.0.3

Using representable 2.1.8

Using ruby-saml 1.4.0

Using warden-basic_auth 0.2.1

Using cells-erb 0.0.8

Using domain_name 0.5.20161129

Using fog-json 1.0.2

Using fog-xml 0.1.2

Using prawn-table 0.2.2

Using rails-dom-testing 2.0.1

Using globalid 0.3.7

Using activemodel 5.0.0.1

Using climate_control 0.0.3

Using delayed_job 4.1.2

Using json-jwt 1.6.5

Using rack-oauth2 1.4.0

Using swd 1.0.1

Using webfinger 1.0.2

Using rabl 0.13.0

Using ruby-duration 3.2.3

Using unicorn-worker-killer 0.4.4

Using virtus 1.0.5

Using rails-html-sanitizer 1.0.3

Using omniauth-saml 1.6.0 from git://github.com/omniauth/omniauth-saml.git (at master@5559d6b)

Using disposable 0.0.9

Using roar 1.0.4

Using http-cookie 1.0.3

Using fog-aws 0.11.0

Using activejob 5.0.0.1

Using activerecord 5.0.0.1

Using carrierwave 1.0.0.beta from https://github.com/carrierwaveuploader/carrierwave (at master@5367a63)

Using date_validator 0.9.0

Using validate_email 0.1.6

Using validate_url 1.0.2

Using cocaine 0.5.8

Using actionview 5.0.0.1

Using grape 0.17.0

Using reform 1.2.6

Using openproject-auth_saml 0.1.0 from https://github.com/finnlabs/openproject-auth_saml (at dev@97212ab)

Using rest-client 1.8.0

Using openid_connect 0.8.3

Using activemodel-serializers-xml 1.0.1

Using acts_as_list 0.8.1

Using acts_as_tree 2.5.1

Using awesome_nested_set 3.1.1

Using delayed_job_active_record 4.1.1

Using friendly_id 5.2.0.beta.1 from https://github.com/norman/friendly_id (at aff0564@aff0564)

Using globalize 5.1.0 from https://github.com/globalize/globalize (at 38443bc@38443bc)

Using transactional_lock 0.1.0 from https://github.com/finnlabs/transactional_lock.git (at master@6948b1d)

Using actionpack 5.0.0.1

Using grape-cache_control 1.0.1

Using crowdin-api 0.4.1

Using omniauth-openid-connect 0.2.0 from https://github.com/finnlabs/omniauth-openid-connect.git (at dev@c3bce4c)

Using actioncable 5.0.0.1

Using actionmailer 5.0.0.1

Using railties 5.0.0.1

Using cells-rails 0.0.6

Using gon 4.1.1

Using sprockets-rails 3.2.0

Using omniauth-openid_connect-providers 0.1.0 from https://github.com/finnlabs/omniauth-openid_connect-providers.git (at dev@86f3670)

Using actionpack-xml_parser 2.0.0

Using activerecord-session_store 1.0.0

Using rails 5.0.0.1

Using jquery-tablesorter 1.22.7

Using responders 2.3.0

Using sass-rails 5.0.6

Using health_check 2.2.1

Using lobby_boy 0.1.2

Using openproject-auth_plugins 6.1.4 from source at `vendored-plugins/openproject-auth_plugins`

Using openproject-pdf_export 6.1.4 from source at `vendored-plugins/openproject-pdf_export`

Using openproject-costs 6.1.4 from source at `vendored-plugins/openproject-costs`

Using openproject-documents 6.1.4 from source at `vendored-plugins/openproject-documents`

Using openproject-webhooks 6.1.4 from source at `vendored-plugins/openproject-webhooks`

Using openproject-global_roles 6.1.4 from source at `vendored-plugins/openproject-global_roles`

Using openproject-local_avatars 6.1.4 from source at `vendored-plugins/openproject-local_avatars`

Using openproject-meeting 6.1.4 from source at `vendored-plugins/openproject-meeting`

Using openproject-my_project_page 6.1.4 from source at `vendored-plugins/openproject-my_project_page`

Using reporting_engine 6.1.4 from source at `vendored-plugins/reporting_engine`

Using openproject-themes-dark 6.1.4 from source at `vendored-plugins/openproject-themes-dark`

Using openproject-translations 6.1.4 from https://github.com/opf/openproject-translations.git (at stable/6@da52ff9)

Using openproject-xls_export 6.1.4 from source at `vendored-plugins/openproject-xls_export`

Using rails-angular-xss 0.3.0.pre.pre from https://github.com/opf/rails-angular-xss (at a45267d@a45267d)

Using rails_autolink 1.1.6

Using openproject-openid_connect 6.1.4 from source at `vendored-plugins/openproject-openid_connect`

Using openproject-backlogs 6.1.4 from source at `vendored-plugins/openproject-backlogs`

Using openproject-github_integration 6.1.4 from source at `vendored-plugins/openproject-github_integration`

Using openproject-reporting 6.1.4 from source at `vendored-plugins/openproject-reporting`

Bundle complete! 138 Gemfile dependencies, 195 gems now installed.

Gems in the groups development and test were not installed.

Bundled gems are installed into ./vendor/bundle.

Bundle completed (7.84s)

Cleaning up the bundler cache.

The git source `git://github.com/omniauth/omniauth-saml.git` uses the `git` protocol, which transmits data without encryption. Disable this warning with `bundle config git.allow_insecure true`, or switch to the `https` protocol to keep your data secure.

Warning: the running version of Bundler (1.13.2) is older than the version that created the lockfile (1.13.6). We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

-----> Detecting rake tasks

-----> Preparing app for Rails asset pipeline

Running: rake assets:precompile

$(npm bin)/webpack --config webpack.production.config.js

{"omniauth-openid-connect":"/tmp/d20170223-17-1yooo7y/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid-connect-c3bce4c9e9ac","omniauth-openid_connect-providers":"/tmp/d20170223-17-1yooo7y/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-openid_connect-providers-86f3670e127e","omniauth-saml":"/tmp/d20170223-17-1yooo7y/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/omniauth-saml-5559d6b80805","openproject-auth_plugins":"/tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-auth_plugins","openproject-auth_saml":"/tmp/d20170223-17-1yooo7y/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-auth_saml-97212abb8378","openproject-pdf_export":"/tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-pdf_export","openproject-backlogs":"/tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-backlogs","openproject-costs":"/tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-costs","openproject-documents":"/tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-documents","openproject-webhooks":"/tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-webhooks","openproject-github_integration":"/tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-github_integration","openproject-global_roles":"/tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-global_roles","openproject-local_avatars":"/tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-local_avatars","openproject-meeting":"/tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-meeting","openproject-my_project_page":"/tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-my_project_page","openproject-openid_connect":"/tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-openid_connect","reporting_engine":"/tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/reporting_engine","openproject-reporting":"/tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-reporting","openproject-themes-dark":"/tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-themes-dark","openproject-translations":"/tmp/d20170223-17-1yooo7y/opt/openproject/vendor/bundle/ruby/2.3.0/bundler/gems/openproject-translations-da52ff92cdcd","openproject-xls_export":"/tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-xls_export"}

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Autoprefixer's process() method is deprecated and will removed in next major release. Use postcss([autoprefixer]).process() instead

Hash: eb05035e72bad0d3196f

Version: webpack 1.13.3

Child

Hash: eb05035e72bad0d3196f

Version: webpack 1.13.3

Time: 13770ms

Asset Size Chunks Chunk Names

7b9776076d5fceef4993b55c9383dedd.gif 1.85 kB [emitted]

openproject-backlogs.js 453 kB 0 [emitted] backlogs

openproject-core-app.js 3.43 MB 1 [emitted] core-app

openproject-costs.js 526 kB 2 [emitted] costs

openproject-global.js 3.51 MB 3 [emitted] global

openproject-my_project_page.js 14.3 kB 4 [emitted] my_project_page

openproject-core-app.css 4.71 kB 1 [emitted] core-app

openproject-global.css 49 kB 3 [emitted] global

[213] ./templates \.html$ 1.22 kB {1} [built]

[242] ./components ^((?!\.(test|spec)).)*\.(js|ts|html)$ 16.1 kB {1} [built]

[633] /tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 425 bytes {2} [built]

[765] /tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components ^((?!\.(test|spec)).)*\.(js|ts)$ 330 bytes {4} [built]

+ 769 hidden modules

ERROR in [default]

File '/tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-budget-subform.directive.ts' is not under 'rootDir' '/tmp/d20170223-17-1yooo7y/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts' is not under 'rootDir' '/tmp/d20170223-17-1yooo7y/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/subform/cost-subform.directive.ts' is not under 'rootDir' '/tmp/d20170223-17-1yooo7y/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts' is not under 'rootDir' '/tmp/d20170223-17-1yooo7y/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts' is not under 'rootDir' '/tmp/d20170223-17-1yooo7y/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-block.directive.ts' is not under 'rootDir' '/tmp/d20170223-17-1yooo7y/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-page-layout.directive.ts' is not under 'rootDir' '/tmp/d20170223-17-1yooo7y/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default]

File '/tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-my_project_page/frontend/app/components/projects-overview/overview-textile-block.directive.ts' is not under 'rootDir' '/tmp/d20170223-17-1yooo7y/opt/openproject/frontend/app'. 'rootDir' is expected to contain all source files.

ERROR in [default] /tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:49:18

Argument of type 'string' is not assignable to parameter of type '{ [key: string]: any; }'.

ERROR in [default] /tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/budget/cost-unit-subform.directive.ts:53:4

Supplied parameters do not match any signature of call target.

ERROR in [default] /tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:30:38

Cannot find module 'app/components/work-packages/work-package-cache.service'.

ERROR in [default] /tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:49:30

Cannot find name 'HalResource'.

ERROR in [default] /tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:54:57

Property '$injector' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:13

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:59:27

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:60:11

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:70:23

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:76:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:77:17

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-costs-by-type-field.module.ts:78:16

Property 'value' does not exist on type 'CostsByTypeDisplayField'.

ERROR in [default] /tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:29:27

Cannot find module 'app/components/wp-display/wp-display-field/wp-display-field.module'.

ERROR in [default] /tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:36:17

Property 'value' does not exist on type 'CurrencyDisplayField'.

ERROR in [default] /tmp/d20170223-17-1yooo7y/opt/openproject/vendored-plugins/openproject-costs/frontend/app/components/wp-display/field-types/wp-display-currency-field.module.ts:37:23

Property 'value' does not exist on type 'CurrencyDisplayField'.

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 5 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

Child extract-text-webpack-plugin:

+ 2 hidden modules

I, [2017-02-23T18:09:44.831918 #2392] INFO -- : Writing /tmp/d20170223-17-1yooo7y/opt/openproject/public/assets/application-0c538a178127f1b11be292035456226828732d149b9f4bf70f0c6e0b5d6b8e06.js

I, [2017-02-23T18:09:44.832353 #2392] INFO -- : Writing /tmp/d20170223-17-1yooo7y/opt/openproject/public/assets/application-0c538a178127f1b11be292035456226828732d149b9f4bf70f0c6e0b5d6b8e06.js.gz

Asset precompilation completed (28.18s)

Cleaning assets

Running: rake assets:clean

I, [2017-02-23T18:09:53.220068 #2564] INFO -- : Removed application-c4be1d41449b3460d44da4d8c58a430366db995faa7ee20125d22570634b0832.js

Using release configuration from last framework (Ruby).

-----> [cron] /opt/openproject/packaging/cron/openproject-clear-old-sessions => /etc/cron.d/openproject-clear-old-sessions

-----> Verifying package openproject_6.1.4-1486730985.5bf684b.xenial_amd64.deb

NEW PACKAGE: openproject_6.1.4-1486730985.5bf684b.xenial_amd64.deb (296.64 MiB)

-----> Releasing...

DONE!