Debian 9 Stretch 64bits

Logs

====== Attempt #1

-----> Fetching repository

Cloning into '/tmp/d20180528-3278-a5csiw/input'...

-----> Setting up package repository...

-----> Starting packaging process

-----> Starting service postgres...

-----> Additional environment variables

UUID=4f366b35-d28d-4df2-9d12-560516a75712

DATABASE_URL=postgres://postgres:la8ZjhoyTI6zt9rP@8.26.94.84:33299/postgres

DATABASE_HOST=8.26.94.84

DATABASE_PORT=33299

HOME=/home/pkgr

-----> Reusing cache

-----> Fetching pkgr 2d69610cd10a25dc7edbca6c8756db4f780b8cf6...

-----> Starting packaging process...

-----> Installing missing build dependencies: libsqlite3-dev

-----> [wizard] adding legacy-installer wizard (https://github.com/pkgr/addon-legacy-installer#master)

-----> [wizard] adding mysql wizard (https://github.com/pkgr/addon-mysql#master)

-----> [wizard] adding apache2 wizard (https://github.com/pkgr/addon-apache2#master)

-----> [wizard] adding repositories wizard (https://github.com/finnlabs/addon-repositories#master)

-----> [wizard] adding smtp wizard (https://github.com/pkgr/addon-smtp#master)

-----> [wizard] adding memcached wizard (https://github.com/pkgr/addon-memcached#master)

-----> [wizard] adding openproject wizard (https://github.com/pkgr/addon-openproject#master)

-----> Fetching buildpack https://github.com/opf/heroku-buildpack-multi.git at master

-----> Running hook: "packaging/setup"

-----> Multipack app

WARNING: This buildpack is no longer maintained.

Please choose a different buildpack or go to https://github.com/ddollar/heroku-buildpack-multi

and fork it to your own account.

=====> Downloading Buildpack: https://github.com/pkgr/pkgr-buildpack-imagemagick.git

=====> Detected Framework: ImageMagick

-----> SKIP

=====> Downloading Buildpack: https://github.com/heroku/heroku-buildpack-nodejs.git

=====> Detected Framework: Node.js

-----> Creating runtime environment

NPM_CONFIG_LOGLEVEL=error

NPM_CONFIG_PRODUCTION=true

NODE_ENV=production

NODE_MODULES_CACHE=true

NODE_VERBOSE=false

-----> Installing binaries

engines.node (package.json): >= 6.9.1

engines.npm (package.json): >= 4.0.0

Resolving node version >= 6.9.1 via semver.io...

Downloading and installing node 10.2.1...

Resolving npm version >= 4.0.0 via semver.io...

Downloading and installing npm 6.1.0 (replacing version 5.6.0)...

-----> Restoring cache

Loading 2 from cacheDirectories (default):

- node_modules (not cached - skipping)

- bower_components (not cached - skipping)

-----> Building dependencies

Installing node modules (package.json)

> openproject@0.1.0 postinstall /tmp/d20180528-46-awbezt/opt/openproject

> cd frontend && npm install

npm ERR! Maximum call stack size exceeded

npm ERR! A complete log of this run can be found in:

npm ERR! /home/pkgr/.npm/_logs/2018-05-28T07_14_36_350Z-debug.log

npm ERR! code ELIFECYCLE

npm ERR! errno 1

npm ERR! openproject@0.1.0 postinstall: `cd frontend && npm install`

npm ERR! Exit status 1

npm ERR!

npm ERR! Failed at the openproject@0.1.0 postinstall script.

npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:

npm ERR! /home/pkgr/.npm/_logs/2018-05-28T07_14_46_202Z-debug.log

-----> Build failed

We're sorry this build is failing! You can troubleshoot common issues here:

https://devcenter.heroku.com/articles/troubleshooting-node-deploys

Some possible problems:

- Dangerous semver range (>) in engines.node

https://devcenter.heroku.com/articles/nodejs-support#specifying-a-node-js-version

Love,

Heroku

! ERROR: compile failed

Failed to package application

tar: This does not look like a tar archive

tar: Exiting with failure status due to previous errors

! FAILED - Build error.

! Please contact support.