SUSE Linux Enterprise Server 12 64bits

Logs

====== Attempt #1

-----> Fetching repository

Cloning into '/tmp/d20220922-6-3nsruq/input'...

Updating files: 50% (6436/12734) Updating files: 51% (6495/12734) Updating files: 52% (6622/12734) Updating files: 53% (6750/12734) Updating files: 54% (6877/12734) Updating files: 55% (7004/12734) Updating files: 56% (7132/12734) Updating files: 57% (7259/12734) Updating files: 58% (7386/12734) Updating files: 59% (7514/12734) Updating files: 60% (7641/12734) Updating files: 61% (7768/12734) Updating files: 62% (7896/12734) Updating files: 63% (8023/12734) Updating files: 64% (8150/12734) Updating files: 65% (8278/12734) Updating files: 66% (8405/12734) Updating files: 67% (8532/12734) Updating files: 68% (8660/12734) Updating files: 69% (8787/12734) Updating files: 70% (8914/12734) Updating files: 71% (9042/12734) Updating files: 72% (9169/12734) Updating files: 73% (9296/12734) Updating files: 74% (9424/12734) Updating files: 75% (9551/12734) Updating files: 76% (9678/12734) Updating files: 77% (9806/12734) Updating files: 78% (9933/12734) Updating files: 79% (10060/12734) Updating files: 80% (10188/12734) Updating files: 81% (10315/12734) Updating files: 82% (10442/12734) Updating files: 83% (10570/12734) Updating files: 84% (10697/12734) Updating files: 85% (10824/12734) Updating files: 86% (10952/12734) Updating files: 87% (11079/12734) Updating files: 88% (11206/12734) Updating files: 89% (11334/12734) Updating files: 90% (11461/12734) Updating files: 91% (11588/12734) Updating files: 92% (11716/12734) Updating files: 93% (11843/12734) Updating files: 94% (11970/12734) Updating files: 95% (12098/12734) Updating files: 96% (12225/12734) Updating files: 97% (12352/12734) Updating files: 98% (12480/12734) Updating files: 99% (12607/12734) Updating files: 100% (12734/12734) Updating files: 100% (12734/12734), done.

-----> Setting up package repository...

-----> Starting packaging process

-----> Starting service postgres...

-----> Additional environment variables

UUID=7d32b873-77cd-4ab1-9d08-3a727638a73e

DATABASE_URL=postgres://postgres:pgGLaji9y5gdIE7A@65.108.144.194:58021/postgres

DATABASE_HOST=65.108.144.194

DATABASE_PORT=58021

HOME=/home/pkgr

-----> Found valid cache

-----> Restoring cache...

-----> Fetching pkgr f8398b4d6d9e987f7ae6ff9391d69843dd81a6a3...

-----> Starting packaging process...

-----> Installing missing build dependencies: postgresql-devel, ImageMagick

-----> [wizard] adding legacy-installer wizard (https://github.com/pkgr/addon-legacy-installer#master)

-----> [wizard] adding openproject-edition wizard (/tmp/d20220922-39-196w8w9/opt/openproject/packaging/addons/openproject-edition#)

-----> [wizard] adding postgres wizard (https://github.com/pkgr/addon-postgres#master)

-----> [wizard] adding apache2 wizard (https://github.com/pkgr/addon-apache2#master)

-----> [wizard] adding repositories wizard (/tmp/d20220922-39-196w8w9/opt/openproject/packaging/addons/repositories#)

-----> [wizard] adding memcached wizard (https://github.com/pkgr/addon-memcached#master)

-----> [wizard] adding openproject wizard (/tmp/d20220922-39-196w8w9/opt/openproject/packaging/addons/openproject#)

-----> Fetching buildpack https://github.com/opf/heroku-buildpack-multi.git at master

-----> Running hook: "packaging/setup"

-----> Multipack app

=====> Downloading Buildpack: https://github.com/heroku/heroku-buildpack-nodejs.git

=====> Detected Framework: Node.js

-----> Creating runtime environment

NPM_CONFIG_LOGLEVEL=error

NPM_CONFIG_PRODUCTION=false

NODE_VERBOSE=false

NODE_ENV=production

NODE_MODULES_CACHE=true

-----> Installing binaries

engines.node (package.json): ~16.17.0

engines.npm (package.json): ~8.12.1

Resolving node version ~16.17.0...

Downloading and installing node 16.17.0...

Bootstrapping npm ~8.12.1 (replacing 8.15.0)...

npm 8.12.2 installed

-----> Restoring cache

- node_modules

-----> Installing dependencies

Installing node modules (package.json)

> openproject@0.1.0 postinstall

> cd frontend && npm install

added 3494 packages, and audited 3495 packages in 1m

424 packages are looking for funding

run `npm fund` for details

46 vulnerabilities (1 low, 9 moderate, 33 high, 3 critical)

To address issues that do not require attention, run:

npm audit fix

To address all issues (including breaking changes), run:

npm audit fix --force

Run `npm audit` for details.

up to date, audited 218 packages in 1m

10 packages are looking for funding

run `npm fund` for details

6 vulnerabilities (1 low, 1 moderate, 4 high)

Some issues need review, and may require choosing

a different dependency.

Run `npm audit` for details.

-----> Build

-----> Caching build

- node_modules

-----> Pruning devDependencies

Skipping because NPM_CONFIG_PRODUCTION is 'false'

-----> Build succeeded!

=====> Downloading Buildpack: https://github.com/pkgr/heroku-buildpack-ruby.git

=====> Detected Framework: Ruby

which: no java in (/tmp/tmp.qOfGlgPtIp/bin/:/tmp/d20220922-39-196w8w9/opt/openproject/.heroku/node/bin:/tmp/d20220922-39-196w8w9/opt/openproject/.heroku/yarn/bin:/usr/local/bin:/usr/bin:/bin:/tmp/d20220922-39-196w8w9/opt/openproject/node_modules/.bin)

-----> Installing bundler 2.3.10

-----> Removing BUNDLED WITH version in the Gemfile.lock

-----> Compiling Ruby/Rails

-----> Using Ruby version: ruby-3.1.2

cp: '/my/cache/vendor/bundle/.' and '/my/cache/vendor/bundle/.' are the same file

-----> Installing dependencies using bundler 2.3.10

Running: BUNDLE_WITHOUT='development:test' BUNDLE_PATH=vendor/bundle BUNDLE_BIN=vendor/bundle/bin BUNDLE_DEPLOYMENT=1 bundle install -j4

Using rake 13.0.6

Using Ascii85 1.1.0

Using concurrent-ruby 1.1.10

Using i18n 1.12.0

Using minitest 5.16.3

Using tzinfo 2.0.5

Using activesupport 7.0.4

Using builder 3.2.4

Using erubi 1.11.0

Using mini_portile2 2.8.0

Using racc 1.6.0

Using nokogiri 1.13.8 (x86_64-linux)

Using rails-dom-testing 2.0.3

Using crass 1.0.6

Using loofah 2.18.0

Using rails-html-sanitizer 1.4.3

Using actionview 7.0.4

Using rack 2.2.4

Using rack-test 2.0.2

Using actionpack 7.0.4

Using nio4r 2.5.8

Using websocket-extensions 0.1.5

Using websocket-driver 0.7.5

Using actioncable 7.0.4

Using globalid 1.0.0

Using activejob 7.0.4

Using activemodel 7.0.4

Using activerecord 7.0.4

Using marcel 1.0.2

Using mini_mime 1.1.2

Using activestorage 7.0.4

Using mail 2.7.1

Using digest 3.1.0

Using timeout 0.3.0

Using net-protocol 0.1.3

Using strscan 3.0.4

Using net-imap 0.2.3

Using net-pop 0.1.1

Using net-smtp 0.3.1

Using actionmailbox 7.0.4

Using actionmailer 7.0.4

Using method_source 1.0.0

Using thor 1.2.1

Using zeitwerk 2.6.0

Using railties 7.0.4

Using actionpack-xml_parser 2.0.1

Using actiontext 7.0.4

Using activemodel-serializers-xml 1.0.2

Using activerecord-import 1.4.0

Using activerecord-nulldb-adapter 0.8.0

Using multi_json 1.15.0

Using activerecord-session_store 2.0.0

Using acts_as_list 1.0.4

Using acts_as_tree 2.9.1

Using public_suffix 5.0.0

Using addressable 2.8.1

Using aes_key_wrap 1.1.0

Using afm 0.2.2

Using rbtree3 0.7.0

Using airbrake-ruby 6.2.0

Using airbrake 13.0.3

Using appsignal 3.1.4

Using attr_required 1.0.1

Using auto_strip_attributes 2.6.0

Using awesome_nested_set 3.5.0

Using aws-eventstream 1.2.0

Using aws-partitions 1.631.0

Using aws-sigv4 1.5.1

Using jmespath 1.6.1

Using aws-sdk-core 3.148.0

Using aws-sdk-kms 1.58.0

Using aws-sdk-s3 1.114.0

Using aws-sdk-sns 1.55.0

Using bcrypt 3.1.18

Using bindata 2.4.10

Using msgpack 1.5.6

Using bootsnap 1.13.0

Using browser 5.3.1

Using budgets 1.0.0 from source at `modules/budgets`

Using bundler 2.3.10

Using mime-types-data 3.2022.0105

Using mime-types 3.4.1

Using ssrf_filter 1.1.1

Using carrierwave 1.3.2

Using excon 0.92.4

Using formatador 1.1.0

Using fog-core 2.3.0

Using fog-json 1.2.0

Using fog-xml 0.1.4

Using fog-aws 3.15.0

Using carrierwave_direct 2.1.0

Using declarative-option 0.1.0

Using declarative-builder 0.1.0

Using tilt 2.0.11

Using uber 0.1.0

Using cells 4.1.7

Using temple 0.8.2

Using erbse 0.1.4

Using cells-erb 0.1.0

Using cells-rails 0.1.5

Using with_advisory_lock 4.6.0

Using closure_tree 7.4.0

Using commonmarker 0.23.6

Using costs 1.0.0 from source at `modules/costs`

Using daemons 1.4.1

Using dalli 3.2.2

Using grids 1.0.0 from source at `modules/grids`

Using dashboards 1.0.0 from source at `modules/dashboards`

Using date_validator 0.12.0

Using html-pipeline 2.14.2

Using deckar01-task_list 2.3.2

Using declarative 0.0.20

Using et-orbi 1.2.7

Using raabro 1.4.0

Using fugit 1.6.0

Using delayed_cron_job 0.9.0

Using delayed_job 4.1.10

Using delayed_job_active_record 4.1.7

Using trailblazer-option 0.1.2

Using representable 3.2.0

Using disposable 0.6.3

Using unf_ext 0.0.8.2

Using unf 0.1.4

Using domain_name 0.5.20190701

Using doorkeeper 5.5.4

Using dry-container 0.10.1

Using dry-core 0.8.1

Using dry-inflector 0.3.0

Using dry-logic 1.2.0

Using dry-types 1.5.1

Using regexp_parser 2.5.0

Using ecma-re-validator 0.4.0

Using email_validator 2.2.3

Using escape_utils 1.3.0

Using fastimage 2.2.6

Using ffi 1.15.5

Using friendly_id 5.4.2

Using request_store 1.5.1

Using gon 6.4.0

Using ruby2_keywords 0.0.5

Using mustermann 3.0.0

Using mustermann-grape 1.0.2

Using rack-accept 0.4.5

Using grape 1.6.2

Using grape_logging 1.8.4

Using gravatar_image_tag 1.2.0

Using hana 1.3.7

Using hashery 2.1.2

Using hashie 3.6.0

Using htmldiff 0.0.1

Using http-accept 1.7.0

Using http-cookie 1.0.5

Using httpclient 2.8.3

Using i18n-js 3.9.2

Using ice_cube 0.16.4

Using icalendar 2.8.0

Using iso8601 0.13.0

Using json 2.6.2

Using json-jwt 1.15.3

Using uri_template 0.7.0

Using json_schemer 0.2.21

Using omniauth 1.9.0 from https://github.com/opf/omniauth (at fe862f9@fe862f9)

Using rack-oauth2 1.21.2

Using swd 1.3.0

Using validate_email 0.1.6

Using validate_url 1.0.15

Using webfinger 1.2.0

Using openid_connect 1.1.8

Using omniauth-openid-connect 0.4.0 from https://github.com/opf/omniauth-openid-connect.git (at e1173e6@e1173e6)

Using rails 7.0.4

Using lobby_boy 0.1.3

Using lograge 0.12.0

Using matrix 0.4.2

Using messagebird-rest 1.4.2

Using meta-tags 2.17.0

Using mini_magick 4.11.0

Using my_page 1.0.0 from source at `modules/my_page`

Using net-ldap 0.17.1

Using netrc 0.11.0

Using oj 3.13.21

Using okcomputer 1.18.4

Using omniauth-openid_connect-providers 0.2.0 from https://github.com/opf/omniauth-openid_connect-providers.git (at a6c0c3e@a6c0c3e)

Using rexml 3.2.5

Using ruby-saml 1.14.0

Using omniauth-saml 1.10.3

Using openproject-auth_plugins 1.0.0 from source at `modules/auth_plugins`

Using openproject-auth_saml 1.0.0 from source at `modules/auth_saml`

Using openproject-avatars 1.0.0 from source at `modules/avatars`

Using ruby-rc4 0.1.5

Using ttfunk 1.7.0

Using pdf-reader 2.10.0

Using pdf-inspector 1.3.0

Using pdf-core 0.9.0

Using prawn 2.4.0

Using openproject-pdf_export 1.0.0 from source at `modules/pdf_export`

Using openproject-backlogs 1.0.0 from source at `modules/backlogs`

Using rubyzip 2.3.2

Using openproject-bim 1.0.0 from source at `modules/bim`

Using openproject-boards 1.0.0 from source at `modules/boards`

Using openproject-calendar 1.0.0 from source at `modules/calendar`

Using openproject-documents 1.0.0 from source at `modules/documents`

Using openproject-webhooks 1.0.0 from source at `modules/webhooks`

Using openproject-github_integration 1.0.0 from source at `modules/github_integration`

Using openproject-job_status 1.0.0 from source at `modules/job_status`

Using openproject-ldap_groups 1.0.0 from source at `modules/ldap_groups`

Using openproject-meeting 1.0.0 from source at `modules/meeting`

Using openproject-openid_connect 1.0.0 from source at `modules/openid_connect`

Using recaptcha 5.12.3

Using openproject-recaptcha 1.0.0 from source at `modules/recaptcha`

Using openproject-reporting 1.0.0 from source at `modules/reporting`

Using openproject-storages 1.0.0 from source at `modules/storages`

Using openproject-team_planner 1.0.0 from source at `modules/team_planner`

Using openproject-token 2.2.0

Using rotp 6.2.0

Using openproject-two_factor_authentication 1.0.0 from source at `modules/two_factor_authentication`

Using ruby-ole 1.2.12.2

Using spreadsheet 1.3.0

Using openproject-xls_export 1.0.0 from source at `modules/xls_export`

Using overviews 1.0.0 from source at `modules/overviews`

Using paper_trail 12.3.0

Using pg 1.4.3

Using plaintext 0.3.4

Using posix-spawn 0.3.15

Using prawn-table 0.2.2

Using prawn-markup 0.3.7

Using stringio 3.0.2

Using psych 4.0.4

Using puma 5.6.5

Using puma-plugin-statsd 2.2.0

Using rack-attack 6.6.1

Using rack-cors 1.1.1

Using rack-protection 2.2.2

Using rack-timeout 0.6.3

Using rails-i18n 7.0.5

Using rdoc 6.4.0

Using responders 3.0.1

Using rest-client 2.1.0

Using rinku 2.0.6

Using roar 1.1.1

Using rouge 3.30.0

Using ruby-duration 3.2.3

Using ruby-progressbar 1.11.0

Using rubytree 2.0.0

Using sanitize 6.0.0

Using secure_headers 6.4.0

Using semantic 1.6.1

Using sentry-ruby 5.4.2

Using sentry-delayed_job 5.4.2

Using sentry-rails 5.4.2

Using sprockets 3.7.2

Using sprockets-rails 3.4.2

Using stringex 2.8.5

Using structured_warnings 0.4.0

Using svg-graph 2.2.1

Using sys-filesystem 1.4.3

Using typed_dag 2.0.2

Using tzinfo-data 1.2022.3

Using warden 1.2.9

Using warden-basic_auth 0.2.1

Using will_paginate 3.3.1

Bundle complete! 177 Gemfile dependencies, 260 gems now installed.

Gems in the groups 'development' and 'test' were not installed.

Bundled gems are installed into `./vendor/bundle`

Bundle completed (1.37s)

Cleaning up the bundler cache.

-----> Detecting rake tasks

-----> Preparing app for Rails asset pipeline

Running: rake assets:precompile

npm run build

W, [2022-09-22T09:42:26.726468 #4091] WARN -- : 127.0.0.1:11211 failed (count: 0) Errno::ECONNREFUSED: Connection refused - connect(2) for "127.0.0.1" port 11211

W, [2022-09-22T09:42:26.864905 #4091] WARN -- : 127.0.0.1:11211 failed (count: 1) Errno::ECONNREFUSED: Connection refused - connect(2) for "127.0.0.1" port 11211

W, [2022-09-22T09:42:26.864982 #4091] WARN -- : 127.0.0.1:11211 is down

Linking frontend plugins

Cleaning linked target directory /tmp/d20220922-39-196w8w9/opt/openproject/frontend/src/app/features/plugins/linked

Linking frontend of OpenProject plugin budgets to /tmp/d20220922-39-196w8w9/opt/openproject/frontend/src/app/features/plugins/linked/budgets.

Linking frontend of OpenProject plugin costs to /tmp/d20220922-39-196w8w9/opt/openproject/frontend/src/app/features/plugins/linked/costs.

Linking frontend of OpenProject plugin openproject-avatars to /tmp/d20220922-39-196w8w9/opt/openproject/frontend/src/app/features/plugins/linked/openproject-avatars.

Linking frontend of OpenProject plugin openproject-documents to /tmp/d20220922-39-196w8w9/opt/openproject/frontend/src/app/features/plugins/linked/openproject-documents.

Linking frontend of OpenProject plugin openproject-github_integration to /tmp/d20220922-39-196w8w9/opt/openproject/frontend/src/app/features/plugins/linked/openproject-github_integration.

Regenerating frontend plugin registry /tmp/d20220922-39-196w8w9/opt/openproject/frontend/src/app/features/plugins/linked-plugins.module.ts.

Regenerating frontend plugin sass /tmp/d20220922-39-196w8w9/opt/openproject/frontend/src/app/features/plugins/linked-plugins.styles.sass.

Building angular frontend

npm WARN config production Use `--omit=dev` instead.

> openproject-frontend@0.1.0 prebuild

> ./scripts/link_plugin_placeholder.js

> openproject-frontend@0.1.0 build

> node --max_old_space_size=4096 ./node_modules/@angular/cli/bin/ng build --configuration production --named-chunks --extract-css --source-map

Option "extractCss" is deprecated: Deprecated since version 11.0. No longer required to disable CSS extraction for HMR.

- Generating browser application bundles (phase: setup)...

Compiling @angular/core : es2015 as esm2015

Compiling @angular/cdk/keycodes : es2015 as esm2015

Compiling @uirouter/core : module as esm5

Compiling @datorama/akita : es2015 as esm2015

Compiling @angular/common : es2015 as esm2015

Compiling @angular/cdk/collections : es2015 as esm2015

Compiling @angular/cdk/observers : es2015 as esm2015

Compiling @ng-select/ng-option-highlight : es2015 as esm2015

Compiling ng2-dragula : es2015 as esm2015

Compiling @fullcalendar/angular : es2015 as esm2015

Compiling @angular/cdk/platform : es2015 as esm2015

Compiling @angular/cdk/bidi : es2015 as esm2015

Compiling @angular/platform-browser : es2015 as esm2015

Compiling @angular/forms : es2015 as esm2015

Compiling @angular/cdk/scrolling : es2015 as esm2015

Compiling @angular/cdk/a11y : es2015 as esm2015

Compiling @angular/cdk/portal : es2015 as esm2015

Compiling @angular/common/http : es2015 as esm2015

Compiling @ng-select/ng-select : es2015 as esm2015

Compiling @angular/cdk/table : es2015 as esm2015

Compiling @angular/cdk/drag-drop : es2015 as esm2015

Compiling ng-dynamic-component : es2015 as esm2015

Compiling @uirouter/angular : es2015 as esm2015

Compiling @ngneat/content-loader : es2015 as esm2015

Compiling @kolkov/ngx-gallery : es2015 as esm2015

Compiling @ngx-formly/core : es2015 as esm2015

Compiling @angular/cdk/overlay : es2015 as esm2015

Compiling ng2-charts : es2015 as esm2015

Compiling cdk-drag-scroll : es2015 as esm2015

Compiling @angular/cdk/text-field : es2015 as esm2015

Compiling @angular/platform-browser-dynamic : es2015 as esm2015

Compiling @angular/router : es2015 as esm2015

rake aborted!

Failed to compile angular frontend:

/tmp/d20220922-39-196w8w9/opt/openproject/lib/tasks/assets.rake:68:in `block (4 levels) in <top (required)>'

/tmp/d20220922-39-196w8w9/opt/openproject/lib/tasks/assets.rake:67:in `block (3 levels) in <top (required)>'

/tmp/d20220922-39-196w8w9/opt/openproject/lib/tasks/assets.rake:66:in `chdir'

/tmp/d20220922-39-196w8w9/opt/openproject/lib/tasks/assets.rake:66:in `block (2 levels) in <top (required)>'

/tmp/d20220922-39-196w8w9/opt/openproject/vendor/bundle/ruby/3.1.0/gems/sentry-ruby-5.4.2/lib/sentry/rake.rb:24:in `execute'

Tasks: TOP => assets:precompile => assets:compile_environment => assets:prepare_op => assets:angular

(See full trace by running task with --trace)



!

! Precompiling assets failed.

! Attempted to access a nonexistent database:

! https://devcenter.heroku.com/articles/pre-provision-database

!

! ERROR: compile failed

Failed to package application

tar: This does not look like a tar archive

tar: Exiting with failure status due to previous errors

! FAILED - Build error.

! Please contact support.