Debian 8 Jessie 64bits

Logs

====== Attempt #1

-----> Fetching repository

Identity added: /tmp/d20170720-3245-1xsaeix/key (/tmp/d20170720-3245-1xsaeix/key)

11:52:43 I: Started git clone --branch=test-without-redis git@github.com:pkgr/discourse.git /tmp/d20170720-3245-1xsaeix/input

-----> Setting up package repository...

-----> Starting packaging process

-----> Starting service postgres...

-----> Additional environment variables

-----> Starting packaging process...

-----> Fetching buildpack https://github.com/pkgr/heroku-buildpack-ruby.git at buildcurl

-----> Running hook: "./packaging/setup.sh"

-----> Ruby app

-----> Compiling Ruby/Rails

-----> Using Ruby version: ruby-2.4.1

-----> Installing dependencies using bundler 1.11.2

Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment

Warning: the running version of Bundler is older than the version that created the lockfile. We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

Fetching gem metadata from https://rubygems.org/.............

Fetching version metadata from https://rubygems.org/...

Fetching dependency metadata from https://rubygems.org/..

Installing i18n 0.8.1

Installing minitest 5.10.1

Installing builder 3.2.3

Installing thread_safe 0.3.6

Installing erubis 2.7.0

Installing mime-types 2.99.3

Installing arel 6.0.4

Installing jmespath 1.3.1

Installing execjs 2.7.0

Installing babel-source 5.8.34

Installing msgpack 1.1.0 with native extensions

Installing coderay 1.1.1

Installing ember-source 2.10.0

Installing fast_xs 0.8.0 with native extensions

Installing fastimage 2.1.0

Installing ffi 1.9.18 with native extensions

Installing flamegraph 0.9.5

Installing gc_tracer 1.5.1 with native extensions

Installing guess_html_encoding 0.0.11

Installing hashie 3.5.5

Installing highline 1.7.8

Installing hiredis 0.6.1 with native extensions

Installing htmlentities 4.3.4

Installing http_accept_language 2.0.5

Installing jwt 1.5.6

Installing kgio 2.11.0 with native extensions

Installing libv8 5.3.332.38.5

Installing logster 1.2.7

Installing lru_redux 1.1.0

Installing memory_profiler 0.9.7

Installing method_source 0.8.2

Installing multi_json 1.12.1

Installing multi_xml 0.6.0

Installing netrc 0.11.0

Installing oauth 0.5.1

Installing oj 3.0.5 with native extensions

Installing ruby-openid 2.7.0

Installing redis 3.3.3

Installing pg 0.19.0 with native extensions

Installing slop 3.6.0

Installing puma 3.6.0 with native extensions

Installing r2 0.2.6

Using bundler 1.11.2

Installing trollop 2.1.2

Installing rinku 2.0.0 with native extensions

Installing rmmseg-cpp 0.2.9 with native extensions

Installing rtlit 0.0.5

Installing sass 3.4.23

Installing simple-rss 1.3.1

Installing tilt 2.0.5

Installing stackprof 0.2.10 with native extensions

Installing rake-compiler 0.9.9

Installing tzinfo 1.2.3

Installing nokogiri 1.7.2 with native extensions

Installing mail 2.6.6.rc1

Installing rack-test 0.6.3

Installing message_bus 2.0.2

Installing rack-mini-profiler 0.10.4

Installing rack-protection 1.5.3

Installing aws-sdk-core 2.5.3

Installing uglifier 3.0.2

Installing babel-transpiler 0.7.0

Installing sprockets 3.7.1

Installing barber 0.11.2

Installing ember-data-source 2.2.1

Installing discourse_image_optim 0.24.5

Installing faraday 0.11.0

Installing bootsnap 0.3.0 with native extensions

Installing unf 0.1.4

Installing omniauth 1.6.1

Installing mini_racer 0.1.9 with native extensions

Installing rack-openid 1.3.1

Installing openid-redis-store 0.0.2

Installing pry 0.10.4

Installing rbtrace 0.4.8 with native extensions

Installing unicorn 5.3.0 with native extensions

Installing sassc 1.11.2 with native extensions

Installing fast_xor 1.1.3 with native extensions

Installing activesupport 4.2.8

Installing sidekiq 4.2.4

Installing sinatra 1.4.6

Installing aws-sdk-resources 2.5.3

Installing ember-handlebars-template 0.7.5

Installing oauth2 1.3.1

Installing domain_name 0.5.25

Installing loofah 2.0.3

Installing nokogumbo 1.4.10 with native extensions

Installing ruby-readability 0.7.0

Installing omniauth-openid 1.0.1

Installing globalid 0.3.7

Installing omniauth-oauth2 1.4.0

Installing rails-html-sanitizer 1.0.3

Installing omniauth-facebook 4.0.0

Installing rest-client 1.8.0

Installing actionview 4.2.8

Installing actionpack 4.2.8

Installing actionmailer 4.2.8

Installing railties 4.2.8

Installing jquery-rails 4.2.1

Installing rails 4.2.8

Installing ember-rails 0.18.5

Installing rails_multisite 1.0.6

Installing sanitize 4.4.0

Installing onebox 1.8.12

Bundle complete! 96 Gemfile dependencies, 141 gems now installed.

Gems in the groups development and test were not installed.

Warning: the running version of Bundler is older than the version that created the lockfile. We suggest you upgrade to the latest version of Bundler by running `gem install bundler`.

-----> Preparing app for Rails asset pipeline

DEPRECATION WARNING: The configuration option `config.serve_static_assets` has been renamed to `config.serve_static_files` to clarify its role (it merely enables serving everything in the `public` folder and is unrelated to the asset pipeline). The `serve_static_assets` alias will be removed in Rails 5.0. Please migrate your configuration files accordingly. (called from block in <top (required)> at /tmp/d20170720-41-1n53h0g/opt/discourse/config/environments/production.rb:66)

Failed to report error: Error connecting to Redis on localhost:6379 (Errno::ECONNREFUSED) 2 Error connecting to Redis on localhost:6379 (Errno::ECONNREFUSED) subscribe failed, reconnecting in 1 second. Call stack ["/tmp/d20170720-41-1n53h0g/opt/discourse/vendor/bundle/ruby/2.4.0/gems/redis-3.3.3/lib/redis/client.rb:345:in `rescue in establish_connection'", "/tmp/d20170720-41-1n53h0g/opt/discourse/vendor/bundle/ruby/2.4.0/gems/redis-3.3.3/lib/redis/client.rb:331:in `establish_connection'", "/tmp/d20170720-41-1n53h0g/opt/discourse/vendor/bundle/ruby/2.4.0/gems/redis-3.3.3/lib/redis/client.rb:101:in `block in connect'", "/tmp/d20170720-41-1n53h0g/opt/discourse/vendor/bundle/ruby/2.4.0/gems/redis-3.3.3/lib/redis/client.rb:293:in `with_reconnect'", "/tmp/d20170720-41-1n53h0g/opt/discourse/vendor/bundle/ruby/2.4.0/gems/redis-3.3.3/lib/redis/client.rb:100:in `connect'", "/tmp/d20170720-41-1n53h0g/opt/discourse/vendor/bundle/ruby/2.4.0/gems/redis-3.3.3/lib/redis/client.rb:276:in `with_socket_timeout'", "/tmp/d20170720-41-1n53h0g/opt/discourse/vendor/bundle/ruby/2.4.0/gems/redis-3.3.3/lib/redis/client.rb:133:in `call_loop'", "/tmp/d20170720-41-1n53h0g/opt/discourse/vendor/bundle/ruby/2.4.0/gems/redis-3.3.3/lib/redis/subscribe.rb:43:in `subscription'", "/tmp/d20170720-41-1n53h0g/opt/discourse/vendor/bundle/ruby/2.4.0/gems/redis-3.3.3/lib/redis/subscribe.rb:12:in `subscribe'", "/tmp/d20170720-41-1n53h0g/opt/discourse/vendor/bundle/ruby/2.4.0/gems/redis-3.3.3/lib/redis.rb:2765:in `_subscription'", "/tmp/d20170720-41-1n53h0g/opt/discourse/vendor/bundle/ruby/2.4.0/gems/redis-3.3.3/lib/redis.rb:2143:in `block in subscribe'", "/tmp/d20170720-41-1n53h0g/opt/discourse/vendor/bundle/ruby/2.4.0/gems/redis-3.3.3/lib/redis.rb:58:in `block in synchronize'", "/tmp/d20170720-41-1n53h0g/opt/discourse/vendor/ruby-2.4.1/lib/ruby/2.4.0/monitor.rb:214:in `mon_synchronize'", "/tmp/d20170720-41-1n53h0g/opt/discourse/vendor/bundle/ruby/2.4.0/gems/redis-3.3.3/lib/redis.rb:58:in `synchronize'", "/tmp/d20170720-41-1n53h0g/opt/discourse/vendor/bundle/ruby/2.4.0/gems/redis-3.3.3/lib/redis.rb:2142:in `subscribe'", "/tmp/d20170720-41-1n53h0g/opt/discourse/vendor/bundle/ruby/2.4.0/gems/message_bus-2.0.2/lib/message_bus/backends/redis.rb:304:in `global_subscribe'", "/tmp/d20170720-41-1n53h0g/opt/discourse/vendor/bundle/ruby/2.4.0/gems/message_bus-2.0.2/lib/message_bus.rb:513:in `global_subscribe_thread'", "/tmp/d20170720-41-1n53h0g/opt/discourse/vendor/bundle/ruby/2.4.0/gems/message_bus-2.0.2/lib/message_bus.rb:461:in `block in new_subscriber_thread'"]

URGENT: Error connecting to Redis on localhost:6379 (Errno::ECONNREFUSED) Failed to initialize site default

rake aborted!

/tmp/d20170720-41-1n53h0g/opt/discourse/vendor/bundle/ruby/2.4.0/gems/redis-3.3.3/lib/redis/client.rb:345:in `rescue in establish_connection'

-41-1n53h0g/opt/discourse/vendor/bundle/ruby/2.4.0/gems/railties-4.2.8/lib/rails/initializable.rb:44:in `tsort_each_child'

pt/discourse/config/initializers/100-secret_token.rb:4:in `<top (required)>'

ired)>'

! ERROR: compile failed

Failed to package application

tar: This does not look like a tar archive

! FAILED.

! Please contact support.