SUSE Linux Enterprise Server 12 64bits

Logs

====== Attempt #1

-----> Fetching repository

Cloning into '/tmp/d20220112-6-nps0vd/input'...

-----> Setting up package repository...

-----> Starting packaging process

-----> Starting service postgres:13...

-----> Additional environment variables

UUID=7709137c-0c7c-4d05-b6ee-c7182b4fc863

DATABASE_URL=postgres://postgres:y5FRLwtc_ui1zF_T@65.108.144.194:50184/postgres

DATABASE_HOST=65.108.144.194

DATABASE_PORT=50184

HOME=/home/pkgr

-----> Found valid cache

-----> Restoring cache...

-----> Fetching pkgr a146e2f5532e6add357965704e0f0313fe4b937e...

-----> Starting packaging process...

-----> Installing missing build dependencies: https://ftp.gwdg.de/pub/opensuse/discontinued/distribution/12.3/repo/oss/suse/x86_64/imlib2-1.4.5-12.1.1.x86_64.rpm, https://ftp.gwdg.de/pub/opensuse/discontinued/distribution/12.3/repo/oss/suse/x86_64/imlib2-devel-1.4.5-12.1.1.x86_64.rpm, https://ftp.gwdg.de/pub/opensuse/discontinued/distribution/12.3/repo/oss/suse/x86_64/imlib2-filters-1.4.5-12.1.1.x86_64.rpm, https://ftp.gwdg.de/pub/opensuse/discontinued/distribution/12.3/repo/oss/suse/x86_64/libImlib2-1-1.4.5-12.1.1.x86_64.rpm, shared-mime-info

-----> Fetching buildpack https://github.com/pkgr/heroku-buildpack-ruby.git at v227-1

-----> Running hook: "/tmp/before_hook20220112-36-1ipy1a5.sh"

Linux a2ab8ff4adfc 5.4.0-90-generic #101-Ubuntu SMP Fri Oct 15 20:00:55 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

ruby 2.4.1p111 (2017-03-22 revision 58053) [x86_64-linux]

ZAMMAD_RAILS_PORT=3000

APP_NAME=zammad

ZAMMAD_WEBSOCKET_PORT=6042

DATABASE_PORT=50184

ZAMMAD_BIND_IP=127.0.0.1

PATH=/usr/local/bin:/usr/bin:/bin

DATABASE_HOST=65.108.144.194

UUID=7709137c-0c7c-4d05-b6ee-c7182b4fc863

PWD=/tmp/d20220112-36-1fv7aom/opt/zammad

HOME=/home/pkgr

SHLVL=2

RAILS_ENV=production

TARGET=sles:12

DATABASE_URL=postgres://postgres:y5FRLwtc_ui1zF_T@65.108.144.194:50184/postgres

_=/usr/bin/env

GIT

remote: https://github.com/zammad-deps/autodiscover

revision: ee9b53dfa797ce6d4f970b82beea7fbdd2df56bb

specs:

autodiscover (1.0.2)

httpclient

logging

nokogiri

nori

GIT

remote: https://github.com/zammad-deps/mail

revision: 9265cf75bbe376f595944bd10d2dd953f863e765

branch: 2-7-stable

specs:

mail (2.7.2.edge)

mini_mime (>= 0.1.1)

GEM

remote: https://rubygems.org/

specs:

PoParser (3.2.5)

simple_po_parser (~> 1.1.2)

aasm (5.2.0)

concurrent-ruby (~> 1.0)

actioncable (6.0.4.4)

actionpack (= 6.0.4.4)

nio4r (~> 2.0)

websocket-driver (>= 0.6.1)

actionmailbox (6.0.4.4)

actionpack (= 6.0.4.4)

activejob (= 6.0.4.4)

activerecord (= 6.0.4.4)

activestorage (= 6.0.4.4)

activesupport (= 6.0.4.4)

mail (>= 2.7.1)

actionmailer (6.0.4.4)

actionpack (= 6.0.4.4)

actionview (= 6.0.4.4)

activejob (= 6.0.4.4)

mail (~> 2.5, >= 2.5.4)

rails-dom-testing (~> 2.0)

actionpack (6.0.4.4)

actionview (= 6.0.4.4)

activesupport (= 6.0.4.4)

rack (~> 2.0, >= 2.0.8)

rack-test (>= 0.6.3)

rails-dom-testing (~> 2.0)

rails-html-sanitizer (~> 1.0, >= 1.2.0)

actiontext (6.0.4.4)

actionpack (= 6.0.4.4)

activerecord (= 6.0.4.4)

activestorage (= 6.0.4.4)

activesupport (= 6.0.4.4)

nokogiri (>= 1.8.5)

actionview (6.0.4.4)

activesupport (= 6.0.4.4)

builder (~> 3.1)

erubi (~> 1.4)

rails-dom-testing (~> 2.0)

rails-html-sanitizer (~> 1.1, >= 1.2.0)

activejob (6.0.4.4)

activesupport (= 6.0.4.4)

globalid (>= 0.3.6)

activemodel (6.0.4.4)

activesupport (= 6.0.4.4)

activerecord (6.0.4.4)

activemodel (= 6.0.4.4)

activesupport (= 6.0.4.4)

activerecord-import (1.3.0)

activerecord (>= 4.2)

activerecord-nulldb-adapter (0.8.0)

activerecord (>= 5.2.0, < 7.1)

activerecord-session_store (2.0.0)

actionpack (>= 5.2.4.1)

activerecord (>= 5.2.4.1)

multi_json (~> 1.11, >= 1.11.2)

rack (>= 2.0.8, < 3)

railties (>= 5.2.4.1)

activestorage (6.0.4.4)

actionpack (= 6.0.4.4)

activejob (= 6.0.4.4)

activerecord (= 6.0.4.4)

marcel (~> 1.0.0)

activesupport (6.0.4.4)

concurrent-ruby (~> 1.0, >= 1.0.2)

i18n (>= 0.7, < 2)

minitest (~> 5.1)

tzinfo (~> 1.1)

zeitwerk (~> 2.2, >= 2.2.2)

acts_as_list (1.0.4)

activerecord (>= 4.2)

addressable (2.8.0)

public_suffix (>= 2.0.2, < 5.0)

argon2 (2.1.1)

ffi (~> 1.14)

ffi-compiler (~> 1.0)

ast (2.4.2)

async (1.30.1)

console (~> 1.10)

nio4r (~> 2.3)

timers (~> 4.1)

async-http (0.56.5)

async (>= 1.25)

async-io (>= 1.28)

async-pool (>= 0.2)

protocol-http (~> 0.22.0)

protocol-http1 (~> 0.14.0)

protocol-http2 (~> 0.14.0)

async-http-faraday (0.11.0)

async-http (~> 0.42)

faraday

async-io (1.32.2)

async

async-pool (0.3.9)

async (>= 1.25)

autoprefixer-rails (10.4.0.0)

execjs (~> 2)

binding_of_caller (1.0.0)

debug_inspector (>= 0.0.1)

biz (1.8.2)

clavius (~> 1.0)

tzinfo

bootsnap (1.9.4)

msgpack (~> 1.0)

brakeman (5.2.0)

browser (5.3.1)

buftok (0.2.0)

builder (3.2.4)

byebug (11.1.3)

capybara (3.36.0)

addressable

matrix

mini_mime (>= 0.1.3)

nokogiri (~> 1.8)

rack (>= 1.6.0)

rack-test (>= 0.6.3)

regexp_parser (>= 1.5, < 3.0)

xpath (~> 3.2)

childprocess (4.1.0)

chunky_png (1.4.0)

clavius (1.0.4)

clearbit (0.3.3)

nestful (~> 1.1.0)

coderay (1.1.3)

coffee-rails (5.0.0)

coffee-script (>= 2.2.0)

railties (>= 5.2.0)

coffee-script (2.4.1)

coffee-script-source

execjs

coffee-script-source (1.12.2)

coffeelint (1.16.1)

coffee-script

execjs

json

composite_primary_keys (12.0.10)

activerecord (~> 6.0.0)

concurrent-ruby (1.1.9)

console (1.13.1)

fiber-local

coveralls (0.7.1)

multi_json (~> 1.3)

rest-client

simplecov (>= 0.7)

term-ansicolor

thor

crack (0.4.5)

rexml

crass (1.0.6)

csv (3.2.2)

daemons (1.4.1)

dalli (3.2.0)

debug_inspector (1.1.0)

delayed_job (4.1.9)

activesupport (>= 3.0, < 6.2)

delayed_job_active_record (4.1.6)

activerecord (>= 3.0, < 6.2)

delayed_job (>= 3.0, < 5)

deprecation_toolkit (1.5.1)

activesupport (>= 4.2)

diff-lcs (1.4.4)

diffy (3.4.0)

docile (1.4.0)

domain_name (0.5.20190701)

unf (>= 0.0.5, < 1.0.0)

doorkeeper (5.5.4)

railties (>= 5)

dotenv (2.7.6)

eco (1.0.0)

coffee-script

eco-source

execjs

eco-source (1.1.0.rc.1)

em-websocket (0.5.3)

eventmachine (>= 0.12.9)

http_parser.rb (~> 0)

equalizer (0.0.11)

erubi (1.10.0)

eventmachine (1.2.7)

execjs (2.8.1)

factory_bot (6.2.0)

activesupport (>= 5.0.0)

factory_bot_rails (6.2.0)

factory_bot (~> 6.2.0)

railties (>= 5.0.0)

faker (2.19.0)

i18n (>= 1.6, < 2)

faraday (1.8.0)

faraday-em_http (~> 1.0)

faraday-em_synchrony (~> 1.0)

faraday-excon (~> 1.1)

faraday-httpclient (~> 1.0.1)

faraday-net_http (~> 1.0)

faraday-net_http_persistent (~> 1.1)

faraday-patron (~> 1.0)

faraday-rack (~> 1.0)

multipart-post (>= 1.2, < 3)

ruby2_keywords (>= 0.0.4)

faraday-em_http (1.0.0)

faraday-em_synchrony (1.0.0)

faraday-excon (1.1.0)

faraday-http-cache (2.2.0)

faraday (>= 0.8)

faraday-httpclient (1.0.1)

faraday-net_http (1.0.1)

faraday-net_http_persistent (1.2.0)

faraday-patron (1.0.0)

faraday-rack (1.0.0)

faraday_middleware (1.2.0)

faraday (~> 1.0)

ffi (1.15.4)

ffi-compiler (1.0.1)

ffi (>= 1.0.0)

rake

fiber-local (1.0.0)

formatador (0.3.0)

github_changelog_generator (1.16.4)

activesupport

async (>= 1.25.0)

async-http-faraday

faraday-http-cache

multi_json

octokit (~> 4.6)

rainbow (>= 2.2.1)

rake (>= 10.0)

gli (2.20.1)

globalid (1.0.0)

activesupport (>= 5.0)

gmail_xoauth (0.4.2)

oauth (>= 0.3.6)

guard (2.18.0)

formatador (>= 0.2.4)

listen (>= 2.7, < 4.0)

lumberjack (>= 1.0.12, < 2.0)

nenv (~> 0.1)

notiffany (~> 0.0)

pry (>= 0.13.0)

shellany (~> 0.0)

thor (>= 0.18.1)

guard-compat (1.2.1)

guard-livereload (2.5.2)

em-websocket (~> 0.5)

guard (~> 2.8)

guard-compat (~> 1.0)

multi_json (~> 1.8)

guard-symlink (0.1.1)

guard

guard-compat (~> 1.1)

hashdiff (1.0.1)

hashie (5.0.0)

hiredis (0.6.3)

htmlentities (4.3.4)

http (4.4.1)

addressable (~> 2.3)

http-cookie (~> 1.0)

http-form_data (~> 2.2)

http-parser (~> 1.2.0)

http-accept (1.7.0)

http-cookie (1.0.4)

domain_name (~> 0.5)

http-form_data (2.3.0)

http-parser (1.2.3)

ffi-compiler (>= 1.0, < 2.0)

http_parser.rb (0.6.0)

httpclient (2.8.3)

i18n (1.8.11)

concurrent-ruby (~> 1.0)

icalendar (2.7.1)

ice_cube (~> 0.16)

icalendar-recurrence (1.1.3)

icalendar (~> 2.0)

ice_cube (~> 0.16)

ice_cube (0.16.3)

inflection (1.0.0)

iniparse (1.5.0)

interception (0.5)

json (2.6.1)

jwt (2.3.0)

kgio (2.11.4)

koala (3.0.0)

addressable

faraday

json (>= 1.8)

libv8 (8.4.255.0)

listen (3.7.0)

rb-fsevent (~> 0.10, >= 0.10.3)

rb-inotify (~> 0.9, >= 0.9.10)

little-plugger (1.1.4)

logging (2.3.0)

little-plugger (~> 1.1)

multi_json (~> 1.14)

loofah (2.13.0)

crass (~> 1.0.2)

nokogiri (>= 1.5.9)

lumberjack (1.2.8)

marcel (1.0.2)

matrix (0.4.2)

memoizable (0.4.2)

thread_safe (~> 0.3, >= 0.3.1)

messagebird-rest (3.0.0)

method_source (1.0.0)

mime-types (3.4.1)

mime-types-data (~> 3.2015)

mime-types-data (3.2021.1115)

mini_mime (1.1.2)

mini_portile2 (2.6.1)

mini_racer (0.2.9)

libv8 (>= 6.9.411)

minitest (5.15.0)

msgpack (1.4.2)

multi_json (1.15.0)

multi_xml (0.6.0)

multipart-post (2.1.1)

mysql2 (0.5.3)

naught (1.1.0)

nenv (0.3.0)

nestful (1.1.4)

net-ldap (0.17.0)

netrc (0.11.0)

nio4r (2.5.8)

nokogiri (1.12.5)

mini_portile2 (~> 2.6.1)

racc (~> 1.4)

nori (2.6.0)

notiffany (0.1.3)

nenv (~> 0.1)

shellany (~> 0.0)

oauth (0.5.6)

oauth2 (1.4.7)

faraday (>= 0.8, < 2.0)

jwt (>= 1.0, < 3.0)

multi_json (~> 1.3)

multi_xml (~> 0.5)

rack (>= 1.2, < 3)

octokit (4.21.0)

faraday (>= 0.9)

sawyer (~> 0.8.0, >= 0.5.3)

omniauth (1.9.1)

hashie (>= 3.4.6)

rack (>= 1.6.2, < 3)

omniauth-facebook (9.0.0)

omniauth-oauth2 (~> 1.2)

omniauth-github (1.4.0)

omniauth (~> 1.5)

omniauth-oauth2 (>= 1.4.0, < 2.0)

omniauth-gitlab (2.0.0)

omniauth (~> 1.0)

omniauth-oauth2 (~> 1.0)

omniauth-google-oauth2 (0.8.2)

jwt (>= 2.0)

oauth2 (~> 1.1)

omniauth (~> 1.1)

omniauth-oauth2 (>= 1.6)

omniauth-linkedin-oauth2 (1.0.0)

omniauth-oauth2

omniauth-microsoft-office365 (0.0.8)

omniauth

omniauth-oauth2

omniauth-oauth (1.2.0)

oauth

omniauth (>= 1.0, < 3)

omniauth-oauth2 (1.7.1)

oauth2 (~> 1.4)

omniauth (>= 1.9, < 3)

omniauth-rails_csrf_protection (0.1.2)

actionpack (>= 4.2)

omniauth (>= 1.3.1)

omniauth-saml (1.10.3)

omniauth (~> 1.3, >= 1.3.2)

ruby-saml (~> 1.9)

omniauth-twitter (1.4.0)

omniauth-oauth (~> 1.1)

rack

omniauth-weibo-oauth2 (0.5.2)

omniauth (~> 1.5)

omniauth-oauth2 (>= 1.4.0)

openssl (3.0.0)

overcommit (0.58.0)

childprocess (>= 0.6.3, < 5)

iniparse (~> 1.4)

rexml (~> 3.2)

parallel (1.21.0)

parser (3.1.0.0)

ast (~> 2.4.1)

pg (0.21.0)

power_assert (2.0.1)

protocol-hpack (1.4.2)

protocol-http (0.22.5)

protocol-http1 (0.14.2)

protocol-http (~> 0.22)

protocol-http2 (0.14.2)

protocol-hpack (~> 1.4)

protocol-http (~> 0.18)

pry (0.14.1)

coderay (~> 1.1)

method_source (~> 1.0)

pry-rails (0.3.9)

pry (>= 0.10.4)

pry-remote (0.1.8)

pry (~> 0.9)

slop (~> 3.0)

pry-rescue (1.5.2)

interception (>= 0.5)

pry (>= 0.12.0)

pry-stack_explorer (0.6.1)

binding_of_caller (~> 1.0)

pry (~> 0.13)

public_suffix (4.0.6)

puma (4.3.10)

nio4r (~> 2.0)

pundit (2.1.1)

activesupport (>= 3.0.0)

pundit-matchers (1.7.0)

rspec-rails (>= 3.0.0)

racc (1.6.0)

rack (2.2.3)

rack-livereload (0.3.17)

rack

rack-test (1.1.0)

rack (>= 1.0, < 3)

rails (6.0.4.4)

actioncable (= 6.0.4.4)

actionmailbox (= 6.0.4.4)

actionmailer (= 6.0.4.4)

actionpack (= 6.0.4.4)

actiontext (= 6.0.4.4)

actionview (= 6.0.4.4)

activejob (= 6.0.4.4)

activemodel (= 6.0.4.4)

activerecord (= 6.0.4.4)

activestorage (= 6.0.4.4)

activesupport (= 6.0.4.4)

bundler (>= 1.3.0)

railties (= 6.0.4.4)

sprockets-rails (>= 2.0.0)

rails-controller-testing (1.0.5)

actionpack (>= 5.0.1.rc1)

actionview (>= 5.0.1.rc1)

activesupport (>= 5.0.1.rc1)

rails-dom-testing (2.0.3)

activesupport (>= 4.2.0)

nokogiri (>= 1.6)

rails-html-sanitizer (1.4.2)

loofah (~> 2.3)

railties (6.0.4.4)

actionpack (= 6.0.4.4)

activesupport (= 6.0.4.4)

method_source

rake (>= 0.8.7)

thor (>= 0.20.3, < 2.0)

rainbow (3.0.0)

raindrops (0.20.0)

rake (13.0.6)

rb-fsevent (0.11.0)

rb-inotify (0.10.1)

ffi (~> 1.0)

rchardet (1.8.0)

redis (4.5.1)

regexp_parser (2.2.0)

rest-client (2.1.0)

http-accept (>= 1.7.0, < 2.0)

http-cookie (>= 1.0.2, < 2.0)

mime-types (>= 1.16, < 4.0)

netrc (~> 0.8)

rexml (3.2.5)

rspec-core (3.10.1)

rspec-support (~> 3.10.0)

rspec-expectations (3.10.1)

diff-lcs (>= 1.2.0, < 2.0)

rspec-support (~> 3.10.0)

rspec-mocks (3.10.2)

diff-lcs (>= 1.2.0, < 2.0)

rspec-support (~> 3.10.0)

rspec-rails (5.0.2)

actionpack (>= 5.2)

activesupport (>= 5.2)

railties (>= 5.2)

rspec-core (~> 3.10)

rspec-expectations (~> 3.10)

rspec-mocks (~> 3.10)

rspec-support (~> 3.10)

rspec-support (3.10.2)

rszr (0.5.2)

rubocop (1.24.1)

parallel (~> 1.10)

parser (>= 3.0.0.0)

rainbow (>= 2.2.2, < 4.0)

regexp_parser (>= 1.8, < 3.0)

rexml

rubocop-ast (>= 1.15.1, < 2.0)

ruby-progressbar (~> 1.7)

unicode-display_width (>= 1.4.0, < 3.0)

rubocop-ast (1.15.1)

parser (>= 3.0.1.1)

rubocop-faker (1.1.0)

faker (>= 2.12.0)

rubocop (>= 0.82.0)

rubocop-inflector (0.1.1)

activesupport

rubocop

rubocop-rspec

rubocop-performance (1.13.1)

rubocop (>= 1.7.0, < 2.0)

rubocop-ast (>= 0.4.0)

rubocop-rails (2.13.1)

activesupport (>= 4.2.0)

rack (>= 1.1)

rubocop (>= 1.7.0, < 2.0)

rubocop-rspec (2.7.0)

rubocop (~> 1.19)

ruby-progressbar (1.11.0)

ruby-saml (1.13.0)

nokogiri (>= 1.10.5)

rexml

ruby2_keywords (0.0.5)

rubyntlm (0.6.3)

rubyzip (2.3.2)

sassc (2.4.0)

ffi (~> 1.9)

sassc-rails (2.1.2)

railties (>= 4.0.0)

sassc (>= 2.0)

sprockets (> 3.0)

sprockets-rails

tilt

sawyer (0.8.2)

addressable (>= 2.3.5)

faraday (> 0.8, < 2.0)

selenium-webdriver (4.1.0)

childprocess (>= 0.5, < 5.0)

rexml (~> 3.2, >= 3.2.5)

rubyzip (>= 1.2.2)

shellany (0.0.1)

shoulda-matchers (5.1.0)

activesupport (>= 5.2.0)

simple_oauth (0.3.1)

simple_po_parser (1.1.5)

simplecov (0.21.2)

docile (~> 1.1)

simplecov-html (~> 0.11)

simplecov_json_formatter (~> 0.1)

simplecov-html (0.12.3)

simplecov-rcov (0.2.3)

simplecov (>= 0.4.1)

simplecov_json_formatter (0.1.3)

slack-notifier (2.4.0)

slack-ruby-client (1.0.0)

faraday (>= 1.0)

faraday_middleware

gli

hashie

websocket-driver

slop (3.6.0)

spring (4.0.0)

spring-commands-rspec (1.0.4)

spring (>= 0.9.1)

spring-commands-testunit (1.0.1)

spring (>= 0.9.1)

sprockets (3.7.2)

concurrent-ruby (~> 1.0)

rack (> 1, < 3)

sprockets-rails (3.4.2)

actionpack (>= 5.2)

activesupport (>= 5.2)

sprockets (>= 3.0.0)

sync (0.5.0)

tcr (0.2.2)

telegramAPI (1.4.2)

rest-client (~> 2.0, >= 2.0.2)

telephone_number (1.4.13)

term-ansicolor (1.7.1)

tins (~> 1.0)

test-unit (3.5.3)

power_assert

thor (1.1.0)

thread_safe (0.3.6)

tilt (2.0.10)

timers (4.3.3)

tins (1.29.1)

sync

twilio-ruby (5.62.0)

faraday (>= 0.9, < 2.0)

jwt (>= 1.5, <= 2.5)

nokogiri (>= 1.6, < 2.0)

twitter (7.0.0)

addressable (~> 2.3)

buftok (~> 0.2.0)

equalizer (~> 0.0.11)

http (~> 4.0)

http-form_data (~> 2.0)

http_parser.rb (~> 0.6.0)

memoizable (~> 0.4.0)

multipart-post (~> 2.0)

naught (~> 1.0)

simple_oauth (~> 0.3.0)

tzinfo (1.2.9)

thread_safe (~> 0.1)

uglifier (4.2.0)

execjs (>= 0.3.0, < 3)

unf (0.1.4)

unf_ext

unf_ext (0.0.8)

unicode-display_width (2.1.0)

unicorn (6.1.0)

kgio (~> 2.6)

raindrops (~> 0.7)

valid_email2 (4.0.1)

activemodel (>= 3.2)

mail (~> 2.5)

vcr (6.0.0)

viewpoint (1.1.1)

httpclient

logging

nokogiri

rubyntlm

webmock (3.14.0)

addressable (>= 2.8.0)

crack (>= 0.3.2)

hashdiff (>= 0.4.0, < 2.0.0)

websocket-driver (0.7.5)

websocket-extensions (>= 0.1.0)

websocket-extensions (0.1.5)

writeexcel (1.0.5)

xpath (3.2.0)

nokogiri (~> 1.8)

zeitwerk (2.5.3)

zendesk_api (1.34.0)

faraday (>= 0.9.0, < 2.0.0)

hashie (>= 3.5.2, < 6.0.0)

inflection

mini_mime

multipart-post (~> 2.0)

PLATFORMS

ruby

DEPENDENCIES

PoParser

aasm

activerecord-import

activerecord-nulldb-adapter

activerecord-session_store

acts_as_list

argon2

autodiscover!

autoprefixer-rails

biz

bootsnap

brakeman

browser

byebug

capybara

chunky_png

clearbit

coffee-rails

coffeelint

composite_primary_keys

coveralls

csv

daemons

dalli

delayed_job_active_record

deprecation_toolkit

diffy

doorkeeper

dotenv

eco

em-websocket

eventmachine

execjs

factory_bot_rails

faker

github_changelog_generator

gmail_xoauth

guard

guard-livereload

guard-symlink

hiredis

htmlentities

icalendar

icalendar-recurrence

json

koala

libv8

mail!

messagebird-rest

mime-types

mini_racer (= 0.2.9)

mysql2

net-ldap

oauth2

omniauth-facebook

omniauth-github

omniauth-gitlab

omniauth-google-oauth2

omniauth-linkedin-oauth2

omniauth-microsoft-office365

omniauth-rails_csrf_protection

omniauth-saml

omniauth-twitter

omniauth-weibo-oauth2

openssl

overcommit

pg (= 0.21.0)

pry-rails

pry-remote

pry-rescue

pry-stack_explorer

puma (~> 4)

pundit

pundit-matchers

rack-livereload

rails (~> 6.0.0)

rails-controller-testing

rb-fsevent

rchardet (>= 1.8.0)

redis

rspec-rails

rszr (= 0.5.2)

rubocop

rubocop-faker

rubocop-inflector

rubocop-performance

rubocop-rails

rubocop-rspec

sassc-rails

selenium-webdriver

shoulda-matchers

simplecov

simplecov-rcov

slack-notifier

slack-ruby-client

spring

spring-commands-rspec

spring-commands-testunit

sprockets (~> 3.7.2)

tcr

telegramAPI

telephone_number

test-unit

twilio-ruby

twitter

uglifier

unicorn

valid_email2

vcr

viewpoint

webmock

writeexcel

zendesk_api

RUBY VERSION

ruby 2.7.4p191

BUNDLED WITH

2.2.20

+ rm app/assets/javascripts/app/controllers/layout_ref.coffee

+ rm -rf app/assets/javascripts/app/views/layout_ref/

+ rm app/assets/javascripts/app/controllers/karma.coffee

+ rm -rf test

+ rm -rf spec

+ rm .rspec

+ rm -rf .github

+ rm .gitlab-ci.yml

+ rm -rf .rubocop

+ rm .stylelintrc.json

+ rm .eslintignore

+ rm .eslintrc

+ rm .rubocop.yml

+ rm coffeelint.json

+ rm .overcommit.yml

+ rm .codeclimate.yml

+ rm .github_changelog_generator

-----> Ruby app

which: no java in (/tmp/tmp.5srwCJocAU/bin/:/usr/local/bin:/usr/bin:/bin)

-----> Installing bundler 2.2.16

-----> Removing BUNDLED WITH version in the Gemfile.lock

-----> Compiling Ruby/Rails

-----> Using Ruby version: ruby-2.7.4

cp: ‘/my/cache/vendor/bundle/.’ and ‘/my/cache/vendor/bundle/.’ are the same file

-----> Installing dependencies using bundler 2.2.16

Running: BUNDLE_WITHOUT='development:test' BUNDLE_PATH=vendor/bundle BUNDLE_BIN=vendor/bundle/bin BUNDLE_DEPLOYMENT=1 bundle install -j4

Fetching gem metadata from https://rubygems.org/........

Using rake 13.0.6

Using simple_po_parser 1.1.5

Using concurrent-ruby 1.1.9

Using minitest 5.15.0

Using thread_safe 0.3.6

Fetching zeitwerk 2.5.3

Using builder 3.2.4

Using erubi 1.10.0

Using mini_portile2 2.6.1

Using racc 1.6.0

Using crass 1.0.6

Using rack 2.2.3

Using nio4r 2.5.8

Using websocket-extensions 0.1.5

Using marcel 1.0.2

Using mini_mime 1.1.2

Using multi_json 1.15.0

Using method_source 1.0.0

Using thor 1.1.0

Using public_suffix 4.0.6

Using ffi 1.15.4

Using httpclient 2.8.3

Using little-plugger 1.1.4

Using nori 2.6.0

Using execjs 2.8.1

Using clavius 1.0.4

Using msgpack 1.4.2

Using browser 5.3.1

Using buftok 0.2.0

Using bundler 2.2.16

Using nestful 1.1.4

Using coffee-script-source 1.12.2

Using csv 3.2.2

Using daemons 1.4.1

Fetching dalli 3.2.0

Using diffy 3.4.0

Using unf_ext 0.0.8

Using eco-source 1.1.0.rc.1

Using eventmachine 1.2.7

Using http_parser.rb 0.6.0

Using equalizer 0.0.11

Using faraday-em_http 1.0.0

Using faraday-em_synchrony 1.0.0

Installing zeitwerk 2.5.3

Using faraday-excon 1.1.0

Using faraday-httpclient 1.0.1

Using faraday-net_http 1.0.1

Using faraday-net_http_persistent 1.2.0

Using faraday-patron 1.0.0

Using faraday-rack 1.0.0

Using multipart-post 2.1.1

Using ruby2_keywords 0.0.5

Using oauth 0.5.6

Fetching hashie 5.0.0

Using hiredis 0.6.3

Using htmlentities 4.3.4

Using http-form_data 2.3.0

Using http-accept 1.7.0

Using ice_cube 0.16.3

Using inflection 1.0.0

Using json 2.6.1

Using jwt 2.3.0

Using kgio 2.11.4

Using messagebird-rest 3.0.0

Using mime-types-data 3.2021.1115

Using multi_xml 0.6.0

Installing dalli 3.2.0

Using mysql2 0.5.3

Using naught 1.1.0

Using net-ldap 0.17.0

Using netrc 0.11.0

Using rexml 3.2.5

Fetching openssl 3.0.0

Installing hashie 5.0.0

Installing openssl 3.0.0 with native extensions

Using pg 0.21.0

Using raindrops 0.20.0

Using rchardet 1.8.0

Using redis 4.5.1

Using rszr 0.5.2

Using rubyntlm 0.6.3

Using tilt 2.0.10

Using simple_oauth 0.3.1

Using slack-notifier 2.4.0

Using telephone_number 1.4.13

Using writeexcel 1.0.5

Using PoParser 3.2.5

Using aasm 5.2.0

Using i18n 1.8.11

Using tzinfo 1.2.9

Using memoizable 0.4.2

Using nokogiri 1.12.5 (x86_64-linux)

Using websocket-driver 0.7.5

Using rack-test 1.1.0

Using sprockets 3.7.2

Using mail 2.7.2.edge from https://github.com/zammad-deps/mail (at 2-7-stable@9265cf7)

Using puma 4.3.10

Using addressable 2.8.0

Using ffi-compiler 1.0.1

Using sassc 2.4.0

Fetching autoprefixer-rails 10.4.0.0

Using uglifier 4.2.0

Using logging 2.3.0

Fetching bootsnap 1.9.4

Installing bootsnap 1.9.4 with native extensions

Using clearbit 0.3.3

Using coffee-script 2.4.1

Using unf 0.1.4

Using em-websocket 0.5.3

Using faraday 1.8.0

Using gmail_xoauth 0.4.2

Using icalendar 2.7.1

Using mime-types 3.4.1

Using unicorn 6.1.0

Using activesupport 6.0.4.4

Using biz 1.8.2

Using loofah 2.13.0

Using ruby-saml 1.13.0

Using argon2 2.1.1

Using http-parser 1.2.3

Using autodiscover 1.0.2 from https://github.com/zammad-deps/autodiscover (at master@ee9b53d)

Using viewpoint 1.1.1

Using omniauth 1.9.1

Using eco 1.0.0

Using domain_name 0.5.20190701

Using koala 3.0.0

Using oauth2 1.4.7

Using twilio-ruby 5.62.0

Fetching zendesk_api 1.34.0

Installing zendesk_api 1.34.0

Installing autoprefixer-rails 10.4.0.0

Using icalendar-recurrence 1.1.3

Using rails-dom-testing 2.0.3

Using globalid 1.0.0

Using activemodel 6.0.4.4

Using delayed_job 4.1.9

Using pundit 2.1.1

Using rails-html-sanitizer 1.4.2

Using omniauth-oauth 1.2.0

Using omniauth-saml 1.10.3

Using http-cookie 1.0.4

Using omniauth-oauth2 1.7.1

Using activejob 6.0.4.4

Using activerecord 6.0.4.4

Using valid_email2 4.0.1

Using actionview 6.0.4.4

Using omniauth-twitter 1.4.0

Using http 4.4.1

Using rest-client 2.1.0

Using omniauth-facebook 9.0.0

Using omniauth-github 1.4.0

Using omniauth-gitlab 2.0.0

Using omniauth-google-oauth2 0.8.2

Using omniauth-linkedin-oauth2 1.0.0

Using omniauth-microsoft-office365 0.0.8

Using omniauth-weibo-oauth2 0.5.2

Using activerecord-import 1.3.0

Using activerecord-nulldb-adapter 0.8.0

Using acts_as_list 1.0.4

Using composite_primary_keys 12.0.10

Using delayed_job_active_record 4.1.6

Using actionpack 6.0.4.4

Using twitter 7.0.0

Using telegramAPI 1.4.2

Using actioncable 6.0.4.4

Using activestorage 6.0.4.4

Using actionmailer 6.0.4.4

Using railties 6.0.4.4

Using omniauth-rails_csrf_protection 0.1.2

Using sprockets-rails 3.4.2

Using actionmailbox 6.0.4.4

Using actiontext 6.0.4.4

Using activerecord-session_store 2.0.0

Using coffee-rails 5.0.0

Using doorkeeper 5.5.4

Using sassc-rails 2.1.2

Using rails 6.0.4.4

Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

current directory:

/tmp/d20220112-36-1fv7aom/opt/zammad/vendor/bundle/ruby/2.7.0/gems/openssl-3.0.0/ext/openssl

/tmp/d20220112-36-1fv7aom/opt/zammad/vendor/ruby-2.7.4/bin/ruby -I

/tmp/d20220112-36-1fv7aom/opt/zammad/vendor/ruby-2.7.4/lib/ruby/2.7.0 -r

./siteconf20220112-1236-vfzaea.rb extconf.rb

checking for rb_io_maybe_wait()... no

checking for t_open() in -lnsl... no

checking for socket() in -lsocket... no

checking for openssl/ssl.h... yes

checking for LIBRESSL_VERSION_NUMBER in openssl/opensslv.h... no

checking for OpenSSL version >= 1.0.2... no

*** extconf.rb failed ***

Could not create Makefile due to some reason, probably lack of necessary

libraries and/or headers. Check the mkmf.log file for more details. You may

need configuration options.

Provided configuration options:

--with-opt-dir

--without-opt-dir

--with-opt-include

--without-opt-include=${opt-dir}/include

--with-opt-lib

--without-opt-lib=${opt-dir}/lib

--with-make-prog

--without-make-prog

--srcdir=.

--curdir

--ruby=/tmp/d20220112-36-1fv7aom/opt/zammad/vendor/ruby-2.7.4/bin/$(RUBY_BASE_NAME)

--with-openssl-dir

--without-openssl-dir

--with-openssl-include

--without-openssl-include=${openssl-dir}/include

--with-openssl-lib

--without-openssl-lib=${openssl-dir}/lib

--with-kerberos-dir

--without-kerberos-dir

--with-kerberos-include

--without-kerberos-include=${kerberos-dir}/include

--with-kerberos-lib

--without-kerberos-lib=${kerberos-dir}/lib

--with-debug

--without-debug

--enable-debug

--disable-debug

--with-nsl-dir

--without-nsl-dir

--with-nsl-include

--without-nsl-include=${nsl-dir}/include

--with-nsl-lib

--without-nsl-lib=${nsl-dir}/lib

--with-nsllib

--without-nsllib

--with-socket-dir

--without-socket-dir

--with-socket-include

--without-socket-include=${socket-dir}/include

--with-socket-lib

--without-socket-lib=${socket-dir}/lib

--with-socketlib

--without-socketlib

--with-openssl-config

--without-openssl-config

--with-pkg-config

--without-pkg-config

extconf.rb:114:in `<main>': OpenSSL >= 1.0.2 or LibreSSL >= 3.1.0 is required

(RuntimeError)

To see why this extension failed to compile, please check the mkmf.log which can

be found here:

/tmp/d20220112-36-1fv7aom/opt/zammad/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0-static/openssl-3.0.0/mkmf.log

extconf failed, exit code 1

Gem files will remain installed in

/tmp/d20220112-36-1fv7aom/opt/zammad/vendor/bundle/ruby/2.7.0/gems/openssl-3.0.0

for inspection.

Results logged to

/tmp/d20220112-36-1fv7aom/opt/zammad/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0-static/openssl-3.0.0/gem_make.out

An error occurred while installing openssl (3.0.0), and Bundler cannot continue.

Make sure that `gem install openssl -v '3.0.0' --source 'https://rubygems.org/'`

succeeds before bundling.

In Gemfile:

openssl

Bundler Output: Fetching gem metadata from https://rubygems.org/........

Using rake 13.0.6

Using simple_po_parser 1.1.5

Using concurrent-ruby 1.1.9

Using minitest 5.15.0

Using thread_safe 0.3.6

Fetching zeitwerk 2.5.3

Using builder 3.2.4

Using erubi 1.10.0

Using mini_portile2 2.6.1

Using racc 1.6.0

Using crass 1.0.6

Using rack 2.2.3

Using nio4r 2.5.8

Using websocket-extensions 0.1.5

Using marcel 1.0.2

Using mini_mime 1.1.2

Using multi_json 1.15.0

Using method_source 1.0.0

Using thor 1.1.0

Using public_suffix 4.0.6

Using ffi 1.15.4

Using httpclient 2.8.3

Using little-plugger 1.1.4

Using nori 2.6.0

Using execjs 2.8.1

Using clavius 1.0.4

Using msgpack 1.4.2

Using browser 5.3.1

Using buftok 0.2.0

Using bundler 2.2.16

Using nestful 1.1.4

Using coffee-script-source 1.12.2

Using csv 3.2.2

Using daemons 1.4.1

Fetching dalli 3.2.0

Using diffy 3.4.0

Using unf_ext 0.0.8

Using eco-source 1.1.0.rc.1

Using eventmachine 1.2.7

Using http_parser.rb 0.6.0

Using equalizer 0.0.11

Using faraday-em_http 1.0.0

Using faraday-em_synchrony 1.0.0

Installing zeitwerk 2.5.3

Using faraday-excon 1.1.0

Using faraday-httpclient 1.0.1

Using faraday-net_http 1.0.1

Using faraday-net_http_persistent 1.2.0

Using faraday-patron 1.0.0

Using faraday-rack 1.0.0

Using multipart-post 2.1.1

Using ruby2_keywords 0.0.5

Using oauth 0.5.6

Fetching hashie 5.0.0

Using hiredis 0.6.3

Using htmlentities 4.3.4

Using http-form_data 2.3.0

Using http-accept 1.7.0

Using ice_cube 0.16.3

Using inflection 1.0.0

Using json 2.6.1

Using jwt 2.3.0

Using kgio 2.11.4

Using messagebird-rest 3.0.0

Using mime-types-data 3.2021.1115

Using multi_xml 0.6.0

Installing dalli 3.2.0

Using mysql2 0.5.3

Using naught 1.1.0

Using net-ldap 0.17.0

Using netrc 0.11.0

Using rexml 3.2.5

Fetching openssl 3.0.0

Installing hashie 5.0.0

Installing openssl 3.0.0 with native extensions

Using pg 0.21.0

Using raindrops 0.20.0

Using rchardet 1.8.0

Using redis 4.5.1

Using rszr 0.5.2

Using rubyntlm 0.6.3

Using tilt 2.0.10

Using simple_oauth 0.3.1

Using slack-notifier 2.4.0

Using telephone_number 1.4.13

Using writeexcel 1.0.5

Using PoParser 3.2.5

Using aasm 5.2.0

Using i18n 1.8.11

Using tzinfo 1.2.9

Using memoizable 0.4.2

Using nokogiri 1.12.5 (x86_64-linux)

Using websocket-driver 0.7.5

Using rack-test 1.1.0

Using sprockets 3.7.2

Using mail 2.7.2.edge from https://github.com/zammad-deps/mail (at 2-7-stable@9265cf7)

Using puma 4.3.10

Using addressable 2.8.0

Using ffi-compiler 1.0.1

Using sassc 2.4.0

Fetching autoprefixer-rails 10.4.0.0

Using uglifier 4.2.0

Using logging 2.3.0

Fetching bootsnap 1.9.4

Installing bootsnap 1.9.4 with native extensions

Using clearbit 0.3.3

Using coffee-script 2.4.1

Using unf 0.1.4

Using em-websocket 0.5.3

Using faraday 1.8.0

Using gmail_xoauth 0.4.2

Using icalendar 2.7.1

Using mime-types 3.4.1

Using unicorn 6.1.0

Using activesupport 6.0.4.4

Using biz 1.8.2

Using loofah 2.13.0

Using ruby-saml 1.13.0

Using argon2 2.1.1

Using http-parser 1.2.3

Using autodiscover 1.0.2 from https://github.com/zammad-deps/autodiscover (at master@ee9b53d)

Using viewpoint 1.1.1

Using omniauth 1.9.1

Using eco 1.0.0

Using domain_name 0.5.20190701

Using koala 3.0.0

Using oauth2 1.4.7

Using twilio-ruby 5.62.0

Fetching zendesk_api 1.34.0

Installing zendesk_api 1.34.0

Installing autoprefixer-rails 10.4.0.0

Using icalendar-recurrence 1.1.3

Using rails-dom-testing 2.0.3

Using globalid 1.0.0

Using activemodel 6.0.4.4

Using delayed_job 4.1.9

Using pundit 2.1.1

Using rails-html-sanitizer 1.4.2

Using omniauth-oauth 1.2.0

Using omniauth-saml 1.10.3

Using http-cookie 1.0.4

Using omniauth-oauth2 1.7.1

Using activejob 6.0.4.4

Using activerecord 6.0.4.4

Using valid_email2 4.0.1

Using actionview 6.0.4.4

Using omniauth-twitter 1.4.0

Using http 4.4.1

Using rest-client 2.1.0

Using omniauth-facebook 9.0.0

Using omniauth-github 1.4.0

Using omniauth-gitlab 2.0.0

Using omniauth-google-oauth2 0.8.2

Using omniauth-linkedin-oauth2 1.0.0

Using omniauth-microsoft-office365 0.0.8

Using omniauth-weibo-oauth2 0.5.2

Using activerecord-import 1.3.0

Using activerecord-nulldb-adapter 0.8.0

Using acts_as_list 1.0.4

Using composite_primary_keys 12.0.10

Using delayed_job_active_record 4.1.6

Using actionpack 6.0.4.4

Using twitter 7.0.0

Using telegramAPI 1.4.2

Using actioncable 6.0.4.4

Using activestorage 6.0.4.4

Using actionmailer 6.0.4.4

Using railties 6.0.4.4

Using omniauth-rails_csrf_protection 0.1.2

Using sprockets-rails 3.4.2

Using actionmailbox 6.0.4.4

Using actiontext 6.0.4.4

Using activerecord-session_store 2.0.0

Using coffee-rails 5.0.0

Using doorkeeper 5.5.4

Using sassc-rails 2.1.2

Using rails 6.0.4.4

Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

current directory:

/tmp/d20220112-36-1fv7aom/opt/zammad/vendor/bundle/ruby/2.7.0/gems/openssl-3.0.0/ext/openssl

/tmp/d20220112-36-1fv7aom/opt/zammad/vendor/ruby-2.7.4/bin/ruby -I

/tmp/d20220112-36-1fv7aom/opt/zammad/vendor/ruby-2.7.4/lib/ruby/2.7.0 -r

./siteconf20220112-1236-vfzaea.rb extconf.rb

checking for rb_io_maybe_wait()... no

checking for t_open() in -lnsl... no

checking for socket() in -lsocket... no

checking for openssl/ssl.h... yes

checking for LIBRESSL_VERSION_NUMBER in openssl/opensslv.h... no

checking for OpenSSL version >= 1.0.2... no

*** extconf.rb failed ***

Could not create Makefile due to some reason, probably lack of necessary

libraries and/or headers. Check the mkmf.log file for more details. You may

need configuration options.

Provided configuration options:

--with-opt-dir

--without-opt-dir

--with-opt-include

--without-opt-include=${opt-dir}/include

--with-opt-lib

--without-opt-lib=${opt-dir}/lib

--with-make-prog

--without-make-prog

--srcdir=.

--curdir

--ruby=/tmp/d20220112-36-1fv7aom/opt/zammad/vendor/ruby-2.7.4/bin/$(RUBY_BASE_NAME)

--with-openssl-dir

--without-openssl-dir

--with-openssl-include

--without-openssl-include=${openssl-dir}/include

--with-openssl-lib

--without-openssl-lib=${openssl-dir}/lib

--with-kerberos-dir

--without-kerberos-dir

--with-kerberos-include

--without-kerberos-include=${kerberos-dir}/include

--with-kerberos-lib

--without-kerberos-lib=${kerberos-dir}/lib

--with-debug

--without-debug

--enable-debug

--disable-debug

--with-nsl-dir

--without-nsl-dir

--with-nsl-include

--without-nsl-include=${nsl-dir}/include

--with-nsl-lib

--without-nsl-lib=${nsl-dir}/lib

--with-nsllib

--without-nsllib

--with-socket-dir

--without-socket-dir

--with-socket-include

--without-socket-include=${socket-dir}/include

--with-socket-lib

--without-socket-lib=${socket-dir}/lib

--with-socketlib

--without-socketlib

--with-openssl-config

--without-openssl-config

--with-pkg-config

--without-pkg-config

extconf.rb:114:in `<main>': OpenSSL >= 1.0.2 or LibreSSL >= 3.1.0 is required

(RuntimeError)

To see why this extension failed to compile, please check the mkmf.log which can

be found here:

/tmp/d20220112-36-1fv7aom/opt/zammad/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0-static/openssl-3.0.0/mkmf.log

extconf failed, exit code 1

Gem files will remain installed in

/tmp/d20220112-36-1fv7aom/opt/zammad/vendor/bundle/ruby/2.7.0/gems/openssl-3.0.0

for inspection.

Results logged to

/tmp/d20220112-36-1fv7aom/opt/zammad/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0-static/openssl-3.0.0/gem_make.out

An error occurred while installing openssl (3.0.0), and Bundler cannot continue.

Make sure that `gem install openssl -v '3.0.0' --source 'https://rubygems.org/'`

succeeds before bundling.

In Gemfile:

openssl



!

! Failed to install gems via Bundler.

!

! ERROR: compile failed

Failed to package application

tar: This does not look like a tar archive

tar: Exiting with failure status due to previous errors

! FAILED - Build error.

! Please contact support.